Zone de saisie

La zone de saisie est un objet qui sert à saisir des données dans des variables QlikView et à afficher leurs valeurs.

Cliquez avec le bouton droit de la souris dans la zone de saisie pour afficher le menu Objet. Il est également accessible à partir du menu Objet, lorsque la zone de saisie est l'objet actif.

Utilisation de la zone de saisie

Une zone de saisie consiste en trois colonnes disposées comme une liste multiple. La première colonne affiche une liste de variables. La deuxième colonne contient le signe '=' et la troisième les valeurs des variables. Elle peut contenir une variable ou beaucoup plus, chaque variable étant alors sur une ligne distincte.

Les variables dans QlikView sont des entités nommées contenant une seule valeur, contrairement aux champs qui peuvent contenir (et c'est normalement le cas) plusieurs valeurs. En outre, tandis que les champs obtiennent leurs valeurs des instructions load et select du script, les variables les obtiennent des instructions let et set du script, par des appels d'automatisation ou à l'aide de zones de saisie dans la disposition.

Les variables peuvent contenir des données numériques ou alphanumériques. Si le premier caractère d'une valeur de variable est un signe égal (=), QlikView tente d'évaluer la valeur comme une formule (expression QlikView), puis affiche ou renvoie le résultat plutôt que le texte de la formule proprement dit.

Une zone de saisie affiche la valeur actuelle de la variable. Lorsqu'on clique sur une valeur dans la zone de saisie, la cellule passe en mode d'édition, de sorte qu'on puisse saisir une nouvelle valeur ou modifier l'ancienne. Si la variable contient une formule, c'est elle qui sera alors affichée plutôt que son résultat. La cellule en mode d'édition contient normalement un bouton ..., qui ouvre un éditeur complet destiné à faciliter la création de formules élaborées. La fonction d'une cellule de variable dans une zone de saisie peut très bien être comparée à celle d'une cellule dans une feuille de calcul.

Parfois, la cellule de variable d'une zone de saisie contiendra une icône de liste déroulante fournissant un accès rapide aux valeurs récemment utilisées ou à des valeurs prédéfinies. Des contraintes de saisie peuvent être liées à une variable, empêchant la saisie de toutes les valeurs qui ne satisfont pas à certains critères. Dans une zone de saisie, une variable peut parfois être en lecture seule, auquel cas il est impossible de passer en mode d'édition.

See also:

 
  • Objet
  • Propriétés de la zone de saisieGénéralPropriétés
  • Propriétés de la zone de saisieContraintesPropriétésVariables affichéesVariablesContraintes
  • Propriétés du documentVariablesParamètresPropriétés du document VariablesAfficher les variables systèmeCréer...Supprimer
  • Paramètres de la variable sélectionnéeValeur...Éditer l'expression
  • Inclure dans les favoris
  • Contraintes de saisie
  • Liste de valeurs
  • Valeurs prédéfinies
  • See also:

  • Propriétés de la zone de saisie NombrePropriétés
  • Variables
  • Propriétés du document : Nombre
  • Outrepasser les paramètres du document
  • Afficher en pourcentage %NombreEntierFixé à
  • DécimalDe milliersSéparateurs
  • ISO
  • Système
  • See also:

  • PoliceStyle de policeTaille de police
  • Propriétés de l'objet : PoliceAppliquer aux objetsPropriétés du document : Police
  • Propriétés du document : Police
  • Préférences utilisateur : Police
  • CouleurFixeCalculée
  • Fonctions de couleur

  • Afficher les bordures
  • SimplifiéStyle des objetsPropriétés du document : GénéralIntensité de l'ombreLargeur de bordure
  • Angles arrondis
  • Angles arrondisAngles arrondisStyle des objetsAvancéPropriétés du document : Général
  • Couche
  • Couche
  • Créateur de thèmes...
  • Créateur de thèmes
  • Appliquer le thème...
  • Thèmes de disposition
  • Afficher
  • Afficher
  • Options
  • OptionsPropriétés du document : DispositionPropriétés de la feuille : Sécurité
  • Barres de défilement

Menu Objet

Propriétés... Ouvre la boîte de dialogue Propriétés de la zone de saisie qui permet de définir les paramètres associés.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Notes et commentaires

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Imprimer... Ouvre la boîte de dialogue Imprimer, qui permet de configurer les paramètres d'impression.
Imprimer au format PDF...

Ouvre la boîte de dialogue Imprimer avec l'imprimante PDF-XChange 3.0 présélectionnée. Après avoir cliqué sur le bouton Imprimer, vous serez invité à donner un nom au fichier de sortie PDF. Cette commande est uniquement disponible si une imprimante PDF est installée sur le système.

Envoyer vers Excel Exporte les valeurs de la zone de saisie vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Les valeurs exportées apparaîtront dans une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur.
Exporter...

Ouvre une boîte de dialogue où vous pouvez exporter le contenu de la zone de saisie vers un fichier de votre choix. Le fichier peut être enregistré dans l'un des formats suivants : délimité par des virgules, délimité par des points virgules, délimité par des tabulations, hypertexte (HTML), XML et Excel (xls ou xlsx). Le format par défaut est *.qvo (QlikViewOutput), fichier séparé par des tabulations.

Copier dans le Presse-papiers Ce menu en cascade contient les diverses options de copie de l'objet.
Données
Copie les lignes de données sélectionnées de la zone de saisie dans le Presse-papiers. 
Valeur de la cellule
Copie dans le Presse-papiers la valeur textuelle de la cellule de zone de saisie sur laquelle vous avez cliqué avec le bouton droit de la souris (pour ouvrir le menu Objet).
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclut ou exclut la légende et la bordure de l'objet de feuille selon les paramètres définis dans la boîte de dialogue Préférences utilisateur : onglet Exporter.
Objet
Copie l'objet de feuille entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher cet objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double-clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende de l'objet (si elle est visible) d'un objet agrandi produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Général

Titre

Texte de la barre de titre de la zone de saisie. Le titre peut être défini par une expression pour une mise à jour dynamique de l'étiquette. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Variables disponibles Toutes les variables disponibles sont listées dans cette colonne. Pour inclure les variables système, cochez la case Afficher les variables système. Sélectionnez les éléments à utiliser/supprimer en cliquant dessus. Utilisez le bouton Ajouter > ou le bouton < Supprimer pour les déplacer vers la colonne voulue.
Afficher les variables système Affiche les variables système dans la liste Variables disponibles.
Nouvelle variable Ouvre la boîte de dialogue Nouvelle variable où l'on peut définir une variable personnalisée.
Variables affichées Les variables à afficher dans la zone de saisie sont listées dans cette colonne. Au début, elle est vide.
Promouvoir Déplace une variable vers le haut dans l'ordre d'affichage.
Abaisser Déplace une variable vers le bas dans l'ordre d'affichage.
Étiquette

On peut saisir ici un autre nom à utiliser comme titre de la variable dans la zone de saisie. L'étiquette peut être définie sous forme d'expression pour permettre les mises à jour dynamiques. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de feuille reçoit un numéro d'identification unique, qui commence pour les zones de saisie par IB01. Les objets de feuille liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Interpréteur de macros interne

Présentation

Variables Affiche la liste de toutes les variables de la zone de saisie active. On peut modifier les propriétés d'une variable en sélectionnant son nom dans la liste.
Afficher le signe égal Décochez cette case si vous ne voulez pas que le signe égal apparaisse dans la zone de saisie. Ce paramètre vaut pour toutes les variables.
Arrière-plan... Ouvre la boîte de dialogue Paramètres d'arrière-plan.
Alignement L'alignement des variables peut être défini. Les variables peuvent être individuellement alignées à gauche, au centre ou à droite.
Couleurs de lignes Dans ce groupe, on peut effectuer des réglages pour la ligne sélectionnée dans la liste Variables à gauche.
Arrière-plan
Spécifie la couleur d'arrière-plan de la ligne sélectionnée. Il peut s'agir d'une couleur unie ou d'un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur ce bouton.
Texte
Spécifie la couleur du texte de la ligne sélectionnée.
Appliquer à toutes les lignes
Lorsque vous cochez cette case avant de cliquer sur Appliquer ou sur OK, les couleurs sélectionnées sont appliquées à toutes les lignes de la zone de saisie.

Contraintes

Aucune contrainte Les valeurs d'entrée ne sont vérifiées par rapport à aucune contrainte.
Standard Les valeurs d'entrée seront vérifiées par rapport à une contrainte standard sélectionnée dans la liste déroulante des contraintes les plus courantes. Par défaut, aucune contrainte n'est sélectionnée, c'est-à-dire que vous pouvez donner n'importe quelle valeur à la variable. Vous ne pouvez cocher qu'une seule des options suivantes à la fois : Standard, Personnalisé,Valeurs prédéfinies uniquement et Lecture seule.
Personnalisé Les valeurs d'entrée seront vérifiées par rapport à une contrainte spécifiée par l'utilisateur. La contrainte est saisie dans la zone d'édition et doit être exprimée sous la forme d'une expression QlikView renvoyant VRAI (valeur différente de zéro) si la valeur d'entrée est acceptable. La référence à la valeur d'entrée se fait dans l'expression par le symbole du dollar ($).

Example:  

$>0 Avec , la zone de saisie acceptera uniquement les nombres positifs dans la variable sélectionnée.

Pour faire référence à la valeur précédente de la variable, on peut utiliser son nom.

Example:  

La contrainte $>=abc+1 pour une variable appelée abc fera que la zone de saisie n'acceptera que les saisies numériques avec une valeur supérieure de 1 à l'ancienne valeur.

Valeurs prédéfinies uniquement Les valeurs d'entrée seront vérifiées par rapport à une liste de valeurs définies dans le groupe Valeurs prédéfinies. Seules les valeurs d'entrée figurant dans la liste seront acceptées.
Lecture seule La variable est en lecture seule. Aucune valeur ne peut être saisie.
Activer la boîte de dialogue Éditer l'expression Cochez cette option pour autoriser la modification de la valeur des variables dans la boîte de dialogue Éditer l'expression, accessible à partir du bouton ... qui s'affiche lorsque vous cliquez sur la valeur elle-même.
Émettre un son pour signaler une entrée non autorisée Cochez cette option pour que QlikView émette un avertissement sonore quand l'utilisateur tente de saisir une valeur qui ne répond pas aux contraintes fixées.
Afficher un message d'erreur

Normalement, si l'utilisateur tente de saisir une valeur qui ne répond pas aux contraintes, elle sera simplement rejetée et laissera l'ancienne variable en place. En cochant cette option, on peut indiquer un message d'erreur personnalisé qui s'affiche en cas de saisie incorrecte. Saisissez le message d'erreur dans la zone d'édition. Il peut être défini comme une expression pour permettre les mises à jour dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Messages d'erreur personnalisés

Syntaxe des expressions pour les formules calculées

Aucune liste Aucune liste de valeurs déjà utilisées pour la variable n'est conservée.
Liste des _ valeurs récentes L'utilisateur trouvera une liste déroulante des valeurs récemment utilisées (MRU, Most Recently Used values) pour la variable sélectionnée dans la zone de saisie. Le nombre d'anciennes valeurs à stocker peut être défini dans la zone.
Valeurs prédéfinies dans la liste déroulante L'utilisateur trouvera une liste déroulante des Valeurs prédéfinies pour la variable sélectionnée dans la zone de saisie.
Valeurs prédéfinies avec défilement L'utilisateur pourra utiliser une barre de défilement pour voir les Valeurs prédéfinies pour la variable sélectionnée dans la zone de saisie. Celle-ci permet à l'utilisateur de passer en revue les Valeurs prédéfinies.
Série de nombres Cochez cette option pour générer une liste de valeurs numériques prédéfinies basée sur une limite inférieure (De), une limite supérieure (à) et une valeur d'Étape. Cette option peut être utilisée seule ou en combinaison avec les Valeurs listées.
Valeurs listées Cochez cette option pour spécifier une liste de valeurs prédéfinies arbitraires. Les valeurs peuvent être soit numériques, soit alphanumériques. Les valeurs alphanumériques doivent être données entre guillemets (par exemple, 'abc'). Les valeurs sont séparées par un point-virgule (;) (par exemple, 'abc';45;14.3;'xyz' ). Cette option peut être utilisée seule ou en combinaison avec la Série de nombres.
Commentaire Il s'agit d'un champ de commentaire dans lequel le créateur d'une variable peut décrire l'objet et la fonction de cette dernière.

Nombre

Mixte À la fois des nombres et du texte. Les nombres sont affichés dans leur format d'origine.
Nombre Affiche des valeurs numériques dont le nombre de chiffres est défini dans la boîte fléchée précision.
Entier Affiche les valeurs numériques sous forme d'entiers.
Fixé à _ décimales Affiche des valeurs décimales dont le nombre de décimales est défini dans la boîte fléchée Décimales.
Monétaire Affiche les valeurs au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu. Le format par défaut est le format monétaire de Windows.
Date Affiche des valeurs qui peuvent être interprétées comme des dates au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Heure Affiche des valeurs qui peuvent être interprétées comme des heures au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Horodateur Affiche des valeurs qui peuvent être interprétées comme la date et l'heure au format défini dans la zone d'édition Modèle de format. Un exemple est donné dans la zone de texte Aperçu.
Intervalle Affiche l'heure sous forme d'incrément temporel séquentiel (par exemple, format = mm affiche la valeur en nombre de minutes depuis le début du calendrier, à savoir 1899:12:30:24:00).

Police

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.
Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Disposition

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Continue
Bordure unie d'une seule couleur.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet.
Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.
Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence selon les sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Fonctions de couleur

Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Il est possible de configurer un grand nombre de commandes du menu Objet des objets de feuille comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.