Objet conteneur

Le conteneur est un objet qui contient d'autres objets. Il peut contenir tous les autres objets d'une feuille. Les objets sont groupés et partagent des paramètres communs pour la police, la disposition et les légendes.

Lorsque vous cliquez sur le conteneur avec le bouton droit de la souris, le menu Conteneur : Objet s'affiche. Vous pouvez également y accéder à partir du menu Objet lorsque le conteneur est l'objet actif.

Menu Objet

Le menu Objet du conteneur s'ouvre lorsque vous cliquez sur l'objet avec le bouton droit de la souris. Les commandes en sont :

Propriétés...

Ouvre la boîte de dialogue Propriétés du conteneur permettant de définir un certain nombre de paramètres.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Notes et commentaires

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Copier dans le Presse-papiers

Ce menu en cascade contient les diverses options de copie de l'objet.
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclura ou exclura la barre de titre de l'objet et les bordures selon les paramètres définis dans la boîte de dialogue Préférences utilisateur, sous l'onglet Exporter.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher cet objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double-clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende de l'objet (si elle est visible) d'un objet agrandi produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Général

Pour ouvrir l'onglet Propriétés du conteneur : Général, cliquez sur un conteneur avec le bouton droit de la souris et choisissez Propriétés. Si la commande Propriétés est grisée, vous ne disposez probablement pas des privilèges requis pour apporter des modifications aux propriétés.

Une fois les propriétés de votre choix définies, vous pouvez les mettre en œuvre à l'aide des boutons OK ou Appliquer. Le bouton OK ferme aussi la boîte de dialogue, tandis que le bouton Appliquer ne le fait pas.

Dans la fenêtre Titre, vous pouvez donner au conteneur un nom qui s'affichera dans la légende de la fenêtre. Vous pouvez également définir le titre sous forme de formule calculée afin de mettre à jour le texte de l'étiquette de manière dynamique. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Objets existants Liste des objets disponibles du document. Sélectionnez les éléments à utiliser/supprimer en cliquant dessus. Utilisez le bouton Ajouter > ou le bouton < Supprimer pour les déplacer vers la colonne voulue.
Filtre Avec ce paramètre, il est possible de filtrer la liste des objets existants par exemple par type d'objet.
Objets affichés dans le conteneur Liste des objets se trouvant déjà dans le conteneur.
Promouvoir Déplace l'objet sélectionné d'un cran vers le haut.
Abaisser Déplace l'objet champ sélectionné d'un cran vers le bas.
ID de l'objet Numéro d'identification unique du conteneur actif. À sa création, tout objet de feuille reçoit un numéro d'identification unique afin de permettre le contrôle par automatisation. Les objets liés partagent le même ID d'objet. L'ID consiste en une combinaison de lettres définissant le type d'objet et d'un nombre. Le premier conteneur d'un document reçoit l'ID CT01. Un ID d'objet peut être remplacé par toute autre chaîne, à condition qu'elle ne soit pas déjà en cours d'utilisation pour un autre objet, une autre feuille ou un favori du document.
État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
Étiquette de l'objet sélectionné Vous pouvez saisir ici un autre nom pour l'objet affiché. L'étiquette peut être définie sous forme de formule calculée pour permettre les mises à jour dynamiques. Le bouton ... ouvre en entier la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

See also:

 
  • PoliceStyle de policeTaille de police
  • Propriétés de l'objet : PoliceAppliquer aux objetsPropriétés du document : Police
  • Propriétés du document : Police
  • Préférences utilisateur : Police
  • CouleurFixeCalculée
  • Fonctions de couleur

  • Afficher les bordures
  • SimplifiéStyle des objetsPropriétés du document : GénéralIntensité de l'ombreLargeur de bordure
  • Angles arrondis
  • Angles arrondisAngles arrondisStyle des objetsAvancéPropriétés du document : Général
  • Couche
  • Couche
  • Créateur de thèmes...
  • Créateur de thèmes
  • Appliquer le thème...
  • Thèmes de disposition
  • Afficher
  • Afficher
  • Options
  • OptionsPropriétés du document : DispositionPropriétés de la feuille : Sécurité
  • Barres de défilement
  • Barres de défilement
  • propriétés de l'objet
    propriétés du document
  • Légende
  • Couleurs activesCouleurs inactives
  • Couleur d'arrière-planCouleur du texteCouleur de la zonecouleur d'arrière-planunieen dégradéCouleur de la zonecouleur du textefixecalculée
  • Fonctions de couleur
  • normalréduit
  • Alignement de la légende
  • Icônes spéciales

Présentation

Type de conteneur Choisissez le type de conteneur dans la liste déroulante.
Apparence Permet de définir comment les divers objets du conteneur doivent être affichés. Disponible uniquement en mode Objet unique.
Onglets en haut
Tous les objets du conteneur s'affichent sous forme d'onglets en haut du conteneur.
Onglets à gauche
Tous les objets du conteneur s'affichent sous la forme d'onglets à gauche du conteneur.
Onglets à droite
Tous les objets du conteneur s'affichent sous la forme d'onglets à droite du conteneur.
Onglets en bas
Tous les objets du conteneur s'affichent sous forme d'onglets au bas du conteneur.
Dérouler du début
Tous les objets du conteneur s'affichent dans un menu déroulant situé en haut du conteneur.
Afficher les icônes de type d'objet Activez ce paramètre pour obtenir des icônes symbolisant les différents objets des onglets. Disponible uniquement en mode Objet unique.
Couleur de l'onglet Spécifie la couleur des onglets. Il peut s'agir d'une couleur unie ou d'un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur ce bouton. Disponible uniquement en mode Objet unique.
Colonnes Sélectionnez le nombre de colonnes. Disponible uniquement en mode Grille.
Lignes Sélectionnez le nombre de lignes. Disponible uniquement en mode Grille.
Espacement Sélectionnez la taille de l'espacement. Disponible uniquement en mode Grille.
Arrière-plan... Ouvre la boîte de dialogue Paramètres d'arrière-plan.

Police

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.
Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Disposition

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Continue
Bordure unie d'une seule couleur.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet.
Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.
Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence selon les sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.
Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.
Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.
Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.
Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.
Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.