Bouton

Dans QlikView, on peut créer et définir des boutons pour exécuter des commandes ou actions. Il existe principalement trois types de boutons : le bouton Lancer/Exporter, le bouton Raccourci et le bouton Macro.

Lorsque vous cliquez sur l'objet avec le bouton droit de la souris, le menu Bouton : Objet s'affiche. Il est également possible d'y accéder à partir du menu Objet, lorsque le bouton est l'objet actif.

Menu Objet

Le menu Objet du bouton s'ouvre lorsque vous cliquez sur l'objet avec le bouton droit de la souris. Les commandes en sont :

Propriétés... Ouvre la boîte de dialogue Propriétés du bouton permettant de définir un certain nombre de paramètres.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Notes et commentaires

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus élevée actuellement utilisée par n'importe quel objet de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet de feuille sur la valeur la plus faible actuellement utilisée par n'importe quel objet de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Envoyer vers Excel Exporte le texte vers le programme Microsoft Excel, qui est lancé automatiquement s'il n'est pas déjà ouvert. Le texte apparaîtra dans une seule cellule d'une nouvelle feuille de calcul Excel. Pour utiliser cette fonction, vous devez avoir installé Microsoft Excel 2007 ou version ultérieure sur votre ordinateur.
Copier dans le Presse-papiers Ce menu en cascade contient les diverses options de copie de l'objet.
Texte
Copie le texte affiché sur le bouton dans le Presse-papiers.
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclura ou exclura la barre de titre de l'objet et les bordures selon les paramètres définis dans la boîte de dialogue Préférences utilisateur, sous l'onglet Exporter.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher cet objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double-clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende de l'objet (si elle est visible) d'un objet agrandi produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Général

Dans le groupe Texte, vous pouvez définir les propriétés du texte à afficher sur le bouton.

Texte

La saisie d'un texte dans la zone de texte permet d'étiqueter le bouton. Ce texte peut être défini sous forme de formule calculée. Il peut se composer de plusieurs lignes si vous appuyez sur Entrée.

Syntaxe des expressions pour les formules calculées

Alignement Le texte du bouton peut être aligné à gauche, centré ou aligné à droite.

Dans le groupe Arrière-plan, vous pouvez spécifier l'arrière-plan du bouton. La liste déroulante vous propose trois styles de base différents pour le bouton.

Turquoise Type défini par défaut pour les nouveaux boutons. Crée un bouton arrondi avec un aspect translucide en trois dimensions.
Uni Crée un bouton QlikView uni classique.
Valeurs système par défaut
Fournit un arrière-plan uni de la couleur définie pour les boutons dans le système d'exploitation.
Image Produit un bouton sous forme d'image. L'image peut être soit une image statique unique, soit une image combinée composée de trois parties, représentant chacune un des trois états possibles du bouton (actif, inactif, enfoncé).
Image combinée
Sélectionnez cette case d'option et recherchez un fichier image à l'aide du bouton Sélectionner... pour affecter au bouton une image combinée représentant trois états. Le fichier image doit comprendre trois images côte à côte du bouton : la première représentant un bouton actif, la deuxième un bouton enfoncé et la troisième un bouton estompé (inactif).
Image simple
Sélectionnez cette case d'option et recherchez un fichier image à l'aide du bouton Sélectionner... pour affecter au bouton une image représentant un seul état. Les fichiers image jpg, png, bmp, gif et gif animés sont notamment pris en charge.
Couleur Cochez cette case d'option si vous souhaitez que le bouton ait un arrière-plan coloré (indisponible avec le paramètre Image). Il peut s'agir d'une couleur unie ou d'un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsque vous cliquez sur le bouton de couleur.
Transparence Définit le degré de transparence de l'arrière-plan du bouton. À 100 %, l'arrière-plan sera totalement transparent. La transparence s'appliquera quelle que soit la nature de l'arrière-plan : couleur ou image.
État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet Numéro d'identification unique du bouton actif. À sa création, tout objet reçoit un numéro d'identification unique afin de permettre le contrôle par automatisation. L'ID consiste en une combinaison de lettres définissant le type d'objet et d'un nombre. Le premier bouton d'un document recevra le numéro ID BU01. Les objets partagés partagent le même ID d'objet. Un ID d'objet peut être remplacé par toute autre chaîne, à condition qu'elle ne soit pas déjà utilisée pour un autre objet, une feuille ou un favori du document.
Activer la condition L'expression saisie ici détermine l'état du bouton. Si l'expression renvoie 0, le bouton sera désactivé ; si elle renvoie 1, le bouton sera activé. Si aucune expression n'est saisie, c'est 1 qui est utilisé. Les boutons désactivés en raison d'un état sous-jacent ne peuvent pas être activés au moyen d'une condition.
Paramètres d'impression... En cliquant sur ce bouton, vous accéderez à la boîte de dialogue Paramètres d'impression dans laquelle vous pourrez définir les marges et le format d'en-tête/pied de page.

Actions

Sur cette page, vous pouvez définir des actions pour certains objets :

  • boutons
  • objets texte
  • jauges
  • objets ligne/flèche

Les actions incluent le lancement d'une application externe ou l'exportation de données à partir de QlikView.

Ajouter Ouvre la boîte de dialogue Ajouter une action permettant de choisir les actions associées à l'objet. Choisissez un type d'action dans les listes. Les paramètres affichés à la page Actions varient en fonction de l'action. Les actions seront exécutées dans l'ordre d'apparition dans la liste.
Supprimer Supprime l'action de l'objet.
Promouvoir Déplace l'action sélectionnée vers le haut de la liste.
État alternatif Définit l'état auquel l'action fait référence. Ce paramètre ne présente de l'intérêt que pour les actions portant sur des sélections ou des favoris.

Boîte de dialogue Ajouter une action

Les actions suivantes peuvent être ajoutées à partir de la boîte de dialogue Ajouter une action. Dans tous les champs comportant le bouton ..., il est possible de saisir une formule calculée.

Syntaxe des expressions pour les formules calculées

Sélection

Sélectionner dans le champ Sélectionne les champs et les valeurs qui sont spécifiés. La chaîne de recherche vous permet de spécifier un masque de recherche, tel que (A|B) qui sélectionnera à la fois A et B. La mise entre guillemets est uniquement nécessaire dans le cas de valeurs non numériques ; elle peut être omise avec les valeurs numériques.
Sélectionner les valeurs exclues Sélectionne les valeurs exclues du champ spécifié.
Sélectionner les valeurs possibles Sélectionne les valeurs possibles pour le champ spécifié.
Bouton de sélection Permet d'alterner entre la sélection actuelle, la valeur du paramètre Champ spécifié et celle de la zone Chaîne de caractères à rechercher. Dans la zone Chaîne de caractères à rechercher, vous pouvez spécifier un masque de recherche, par exemple (A|B) permettra de sélectionner à la fois A et B.
Suivant Passe à la sélection suivante dans la liste.
Précédent Revient à la sélection précédente dans la liste.
Sélection Pareto Définit une sélection Pareto dans le champ spécifié à partir d'une expression et d'un pourcentage. Ce type de sélection permet d'identifier les principaux contributeurs à une mesure donnée, lesquels répondent habituellement à la loi des 80/20. Par exemple, pour identifier les principaux clients qui contribuent à 80 % du chiffre d'affaires, Client doit servir de champ, sum(Chiffre d'affaires) d'expression et 80 de pourcentage.
Verrouiller le champ Verrouille les sélections du champ spécifié.
Verrouiller tout Verrouille les valeurs de tous les champs.
Déverrouiller le champ Déverrouille les sélections du champ spécifié.
Déverrouiller tout Déverrouille les valeurs de tous les champs.
Déverrouiller et effacer tout Déverrouille toutes les valeurs et efface les sélections dans tous les champs.
Effacer les autres champs Efface tous les champs associés, sauf celui spécifié.
Effacer tout Efface toutes les sélections, sauf celles verrouillées.
Effacer le champ Efface un champ donné.
Copier le contenu de l'état Copie la sélection du champ État de la source dans le champ État cible. Option uniquement disponible lorsque des états alternatifs ont été définis.
Permuter le contenu de l'état Permute les sélections entre les champs État 1 et État 2. Option uniquement disponible lorsque des états alternatifs ont été définis.

Disposition

Activer l'objet Active l'objet spécifié par le paramètre ID de l'objet. Cette fonction n'est pas compatible avec le client AJAX.
Activer la feuille Active la feuille spécifiée par le paramètre ID de la feuille.
Activer la feuille suivante Ouvre la feuille suivante du document.
Activer la feuille précédente Ouvre la feuille précédente du document.
Réduire l'objet Réduit l'objet spécifié par le paramètre ID de l'objet.
Agrandir l'objet Agrandit l'objet spécifié par le paramètre ID de l'objet.
Restaurer l'objet Restaure l'objet spécifié par le paramètre ID de l'objet.
Définir le nom de l'état Applique l'état spécifié à l'objet spécifié par le paramètre ID de l'objet. Uniquement disponible lorsque des états alternatifs ont été définis.

Favori

Appliquer le favori

Applique un favori spécifié par le paramètre ID du favori. Si deux favoris portent le même ID, c'est celui du document qui est appliqué. Pour appliquer le favori serveur, vous devez spécifier Server\bookmarkID. 

Créer le favori

Crée un favori à partir de la sélection active. Spécifiez les paramètres ID du favori et Nom du favori. Sélectionnez Masqué pour créer un favori masqué.

Remplacer le favori

Remplace le favori spécifié par le paramètre ID du favori par la sélection active.

Imprimer

Imprimer l'objet

Imprime l'objet spécifié par le paramètre ID de l'objet. Renseignez le champ Nom de l'imprimante si l'objet doit être envoyé vers une imprimante différente de l'imprimante par défaut. (non disponible comme déclencheur de feuille et document)

Imprimer la feuille

Imprime la feuille spécifiée par le paramètre ID de la feuille. (non disponible comme déclencheur de feuille et document) Cette fonction n'est pas compatible avec le client AJAX.

Imprimer le rapport

Imprime le rapport spécifié par le paramètre ID de rapport. Renseignez le champ Nom de l'imprimante si le rapport doit être envoyé vers une imprimante différente de l'imprimante par défaut. Cochez la case Afficher la boîte de dialogue d'impression si vous souhaitez afficher la boîte de dialogue d'impression de Windows. (non disponible comme déclencheur de feuille et document)

Externe

Exporter

Exporte une table contenant un ensemble de champs donné, mais seuls les enregistrements applicables d'après la sélection effectuée seront effectivement exportés. Cliquez sur le bouton Configurer de la page Actions pour ouvrir la boîte de dialogue Paramètres des actions à exporter (non disponible en tant que déclencheur de document et de feuille).

Lancer

Lance un programme externe. Les paramètres suivants sont configurables dans la boîte de dialogue Actions :
Application
Cliquez sur Parcourir... pour rechercher l'application à lancer. (non disponible comme déclencheur de feuille et document)
Nom du fichier
Saisissez le chemin d'accès au fichier à ouvrir à l'aide de l'application indiquée au-dessus. (non disponible comme déclencheur de feuille et document)
Paramètres
Configurez les paramètres de la ligne de commande à partir de laquelle l'application est lancée. (non disponible comme déclencheur de feuille et document)
Répertoire de travail
Définit le répertoire de travail de l'application à lancer. (non disponible comme déclencheur de feuille et document)
Quitter l'application à la fermeture de QlikView
Oblige l'application à se fermer lorsque vous quittez QlikView. (non disponible comme déclencheur de feuille et document)
Cette fonction n'est pas compatible avec le client AJAX.

Ouvrir une URL

La fonction Ouvrir une URL vous permet d'ouvrir une URL pointant vers un document QlikView à partir d'un autre document QlikView (chaînage de documents). Ce paramètre ouvre l'URL dans le navigateur Web par défaut. Cette fonction ne peut pas servir de déclencheur de document et de feuille. Si vous utilisez Ouvrir une URL, assurez-vous de saisir le nom du document en minuscules dans la chaîne d'action.

Dans la mesure du possible, utilisez Ouvrir un document QlikView plutôt que la fonction Ouvrir une URL.

Ouvrir un document QlikView

La fonction Ouvrir un document QlikView vous permet d'ouvrir un document QlikView à partir d'un autre document QlikView (chaînage de documents). L'extension du fichier de destination doit être précisée. Cette fonction ne peut pas servir de déclencheur de document et de feuille. Les chemins relatifs servant à naviguer d'un document QlikView vers un autre sont pris en charge par tous les clients, du moment que les documents chaînés sont stockés dans la même structure de dossiers (le même montage).

Exemples

Les exemples suivants illustrent la façon de spécifier le chemin d'accès au fichier de destination en vue de configurer le chaînage de documents à l'aide de la fonction Ouvrir un document QlikView.

Example: Fichier situé dans la même structure de dossiers (le même montage).

  • Si le fichier de destination se trouve dans le même dossier :
    DestinationDoc.qvw
  • Si le fichier de destination se trouve dans un sous-dossier :
    SubFolder/DestinationDoc.qvw
  • Si le fichier de destination se trouve dans un dossier situé plus haut :
    ../DestinationDoc.qvw
  • Si le fichier de destination se trouve dans un dossier situé plus haut et parallèle :
    ../ParallelFolder/DestinationDoc.qvw

Example: Fichier situé dans une structure de dossiers différente (un montage différent).

Le chemin relatif entre différents montages est uniquement pris en charge par le client Ajax.

  • Si le fichier de destination se trouve sur un montage différent :
    ../DifferentMount/DestinationDoc.qvw

Example: Utilisation du chemin de montage pour pointer vers un document QlikView

La définition du chemin d'accès sur des dossiers montés est uniquement prise en charge par le client Ajax.

  • Si le fichier de destination se trouve dans le même dossier monté :
    \Mount\DestinationDoc.qvw
  • Si le fichier de destination se trouve dans un dossier monté différent :
    \DifferentMount\DestinationDoc.qvw
Remarque: Le chaînage de documents avec des dossiers montés n'est pas compatible avec le plug-in Internet Explorer (IE).

Example: Utilisation du chemin absolu pour pointer vers un document QlikView

Le recours aux chemins absolus pour le chaînage de documents est pris en charge par le client Ajax at par QlikView Desktop.

  • Chemin absolu vers le montage ou dossier racine local :
    C:\...\DestinationDoc.qvw
  • Chemin absolu vers un partage réseau :
    \\SharedStorage\...\DestinationDoc.qvw

Sélectionnez Transférer l'état pour transférer les sélections du document d'origine vers le document de destination. Les sélections seront d'abord supprimées du document de destination.
Sélectionnez Appliquer l'état en plus de l'état actif afin de conserver les sélections du document de destination et d'appliquer en plus celles du document d'origine.

Remarque: L'emploi de l'option Appliquer l'état en plus de l'état actif peut renvoyer des résultats inattendus si les sélections effectuées dans les deux documents sont conflictuelles.

Sélectionnez Ouvrir dans la même fenêtre afin d'ouvrir le nouveau document dans le même onglet de navigateur lorsque vous utilisez le client AJAX ZFC.

Remarque: L'action Ouvrir un document QlikView n'est pas prise en charge pour les utilisateurs hors du domaine lorsque le plug-in Internet Explorer (IE) est utilisé.

Exécuter une macro

Saisissez le chemin d'accès et le nom de la macro à exécuter. Tapez un nom pour lequel il sera possible de créer par la suite une macro via la boîte de dialogue Éditer le module ou une expression calculée pour effectuer une mise à jour dynamique.

Définir la variable

Attribue une valeur à la variable spécifiée.

Afficher les informations

Affiche les informations associées, telles qu'un fichier texte ou une image pour le fichier spécifié sous Champ. Cette fonction n'est pas compatible avec le client AJAX.

Fermer ce document

Ferme le document QlikView actif.

Recharger

Procède au rechargement du document actif. Cette fonction n'est pas compatible avec le client AJAX et le plug-in IE.

Mise à jour dynamique

Procède à une mise à jour dynamique des données dans le document actuellement chargé. Saisissez l'instruction de mise à jour dynamique dans le champ Instruction.

La fonction Mise à jour dynamique a été conçue pour permettre à un administrateur QlikView d'intégrer dans un document QlikView des quantités de données limitées provenant d'une source unique sans avoir à recharger le document. Il est ensuite possible à différents clients se connectant au serveur QlikView d'effectuer une analyse.

Remarque : Les informations téléchargées sont uniquement stockées dans la mémoire RAM. Par conséquent, les données ajoutées ou mises à jour à l'aide de la fonction Mise à jour dynamique sont perdues si le document est rechargé.

La grammaire suivante décrit les instructions possibles et les composants associés pouvant être utilisés avec la fonction Mise à jour dynamique :

  • statements ::= statement { “;” statement }
  • statement ::= insert_statement | update_statement | delete_statement | begin_transaction_statement | commit_transaction_statement
  • insert_statement ::= "INSERT" "INTO" ("*" | table_name) field_list "VALUES" value_list {"," value_list} ["KEY" ["AUTO" | (" (" field_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
  • update_statement ::= "UPDATE" ("*" | table_name) set_clause {"," | set_clause} "WHERE" condition ["AUTO" "INSERT"]
  • delete_statement ::= "DELETE" "FROM" ("*" | table_name] "WHERE" condition
  • begin_transaction_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans_name]
  • commit_transaction_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans_name]
  • table_name ::= identifier | quoted_name
  • field_list ::= "(" field_name {"," field_name} ")"
  • value_list ::= "("value {"," value} ")"
  • set_clause ::= "SET" field_name "=" any_valid_non_aggregated_qlikview_expression
  • field_name ::= identifier | quoted string
  • value ::= identifier | any_qlikview_number | quoted string
  • condition ::= any_valid_non_aggregated_qlikview_expression
  • identifier ::= any_qlikview_identifier
  • quoted_string ::= "[" [^]]+ "]"

Example:  

UPDATE AbcTable SET Discount = 123 WHERE AbcField=1

Remarque: Pour utiliser cette fonction, assurez-vous que la mise à jour dynamique est autorisée à la fois au niveau du document et au niveau du serveur.
Remarque: Les actions qui déclenchent d'autres actions, appelées actions en cascades, peuvent avoir des conséquences imprévues et ne sont pas prises en charge.
Remarque:

Il existe des restrictions relatives au comportement de certains déclencheurs de macro dans les documents stockés sur QlikView Server.

Utilisation de macros de documents QV sur le serveur QV

Boîte de dialogue Paramètres des actions à exporter

Sélection

Dans ce groupe, vous déterminerez les champs à sélectionner pour l'exportation.

Champs Dans la zone Champs, vous trouverez une liste des champs disponibles.
Exporter les lignes Dans cette zone, vous trouverez les champs que vous aurez sélectionnés pour l'exportation. Les champs pour lesquels vous avez autorisé plusieurs valeurs sont signalés par une astérisque.
Ajouter > Ajoute des champs à la zone Exporter les lignes.
< Supprimer Supprime des champs de la zone Exporter les lignes.
Promouvoir Monte le champ sélectionné d'un cran, c'est-à-dire d'un cran vers la gauche dans la table d'exportation.
Abaisser Descend le champ sélectionné d'un cran, c'est-à-dire d'un cran vers la droite dans la table d'exportation.
Valeurs multiples (*) En sélectionnant un champ dans la zone Exporter les lignes et en cochant cette commande, vous autorisez un champ à avoir plusieurs valeurs dans la liste d'exportation.

Destination de l'exportation

Dans ce groupe, vous pouvez choisir d'exporter les valeurs vers un fichier ou dans le Presse-papiers.

Fichier

Si vous exportez dans un fichier, vous devez cocher cette case et saisir le nom du fichier. Si aucun nom de fichier n'est saisi, les valeurs seront exportées dans le Presse-papiers. Le nom du fichier peut être une formule calculée.

Syntaxe des expressions pour les formules calculées

Parcourir Ouvre la boîte de dialogue Fichier d'exportation qui vous permet de chercher un fichier vers lequel exporter les valeurs.
Presse-papiers Paramètre par défaut. Si aucun fichier n'est spécifié au-dessus, les valeurs seront exportées dans le Presse-papiers.
Sélections actives Si cette case d'option est cochée, le fichier d'exportation aura, pour chaque champ sélectionné, toutes les valeurs de champs possibles sur une ligne, séparées par des tabulations.
Inclure les libellés Si cette case est cochée, la première position de la ligne (quand l'option Sélections actives est définie) ou le premier enregistrement (quand l'option Enregistrements est définie) contiendra les noms des champs.
Enregistrements Si cette case d'option est cochée, le fichier d'exportation aura une colonne pour chaque champ sélectionné, séparée des autres par des tabulations.
Ajouter à un fichier existant Si cette case est cochée, les données seront ajoutées au fichier d'exportation, à condition que le fichier existe déjà. Les étiquettes ne sont pas exportées lorsqu'on ajoute les données à un fichier existant. Si le fichier d'exportation n'existe pas, l'option n'est pas pertinente.

Formatage des nombres

Certains autres programmes peuvent avoir des difficultés à gérer correctement les nombres et leur format. QlikView propose trois possibilités pour exporter le formatage des nombres de données numériques vers des fichiers ou vers le Presse-papiers.

Les nouveaux boutons d'exportation héritent du réglage par défaut de la boîte de dialogue Préférences utilisateur : onglet Exporter. Ce paramètre peut cependant être configuré individuellement pour chaque bouton d'exportation.

Format complet Demande à QlikView d'exporter les données numériques avec leur format de nombre complet, exactement tel qu'il apparaît dans les objets de feuille du document.
Pas de séparateur des milliers Supprime le séparateur des milliers des données numériques.
Aucun formatage Supprime tout le formatage des nombres des données et exporte les nombres bruts. Le séparateur décimal sera celui défini dans les paramètres système (via le Panneau de configuration).
Remarque:

Il existe des restrictions relatives au comportement de certains déclencheurs de macro dans les documents stockés sur QlikView Server.

Utilisation de macros de documents QV sur le serveur QV

Police

Vous pouvez définir ici la Police, le Style de police et la Taille de police à utiliser.

Vous pouvez définir la police d'un seul objet (Propriétés de l'objet : Police) ou tous les objets d'un document (Appliquer aux objets sous Propriétés du document : Police).

Les polices par défaut du document des nouveaux objets peuvent également être définies dans Propriétés du document : Police. Il existe deux polices par défaut :

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.

Enfin, il est possible de définir les polices par défaut des nouveaux documents sous l'onglet Préférences utilisateur : Police.

Pour les graphiques, les boutons et les objets texte (sauf les objets de recherche), vous pouvez aussi spécifier une Couleur de police. La couleur peut être Fixe ou Calculée de façon dynamique par une expression. L'expression doit être une représentation de couleur valide, créée à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le police est noire par défaut.

Fonctions de couleur

Les paramètres supplémentaires sont :

Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Un échantillon de la police sélectionnée est présenté dans le volet d'aperçu.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de la feuille. Spécifiez un type de bordure dans le menu déroulant.

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Continue
Bordure unie d'une seule couleur.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet.

Lorsque le style Simplifié correspond au Style des objets choisi sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de la feuille :

Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence selon les sélections, etc. L'objet de feuille est uniquement masqué lorsque la condition renvoie la valeur FAUX.

Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) sur le document peuvent contourner toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Fonctions de couleur

Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Il est possible de configurer un grand nombre de commandes du menu Objet des objets de feuille comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.