Objet curseur/calendrier

Les objets curseur/calendrier constituent un autre moyen de sélectionner des valeurs de champs dans QlikView. Vous pouvez également les utiliser pour saisir des valeurs dans des variables de script QlikView. Comme son nom l'indique, un objet curseur/calendrier comporte deux modes entièrement distincts. Malgré leurs différences d'aspect, ils se comportent de manière semblable derrière l'interface graphique utilisateur.

Lorsque vous cliquez sur un objet curseur/calendrier avec le bouton droit de la souris, le menu Objet curseur/calendrier : Menu Objet s'affiche. Il est également accessible à partir du menu Objet, lorsque l'objet curseur/calendrier est l'objet actif.

Utilisation d'un objet curseur/calendrier

Mode curseur

Une valeur unique, deux valeurs ou une plage de valeurs (en fonction des propriétés de l'objet) sont sélectionnées dans un champ ou insérées dans une ou deux variables par glissement d'un curseur le long de l'arrière-plan du curseur. Le curseur peut également être déplacé à l'aide des flèches de défilement. Certains curseurs peuvent incorporer une échelle et des graduations pour faciliter la navigation.

Mode calendrier

En mode calendrier, un objet curseur/calendrier apparaît sous la forme d'une zone de liste déroulante avec une icône en forme de calendrier à droite. Lorsque vous cliquez sur cette icône, elle se développe pour se transformer en contrôle calendrier. Il est possible de passer d'un mois à l'autre et d'une année à l'autre à l'aide des boutons fléchés ou des listes déroulantes de sélection. Après que vous avez sélectionné une date ou une plage de dates (selon les propriétés de l'objet) dans le contrôle calendrier, la sélection est appliquée au champ ou à la variable sous-jacente.

Si l'objet est connecté à un champ, les sélections dans le champ seront reflétées dans le contrôle calendrier développé sur la base des mêmes codes couleur de sélection que ceux que l'on trouve dans les listes de sélection (par exemple, vert pour les valeurs sélectionnées). Dans la mesure où l'objet est configuré pour des valeurs multiples, il est possible de balayer plusieurs valeurs, tout comme dans une liste de sélection. En maintenant la touche Ctrl enfoncée, il est possible de sélectionner plusieurs plages de valeurs, même si elles apparaissent dans des mois ou des années différentes. Une fois le calendrier fermé à l'issue de la sélection, la liste déroulante se comporte essentiellement comme une liste déroulante de champs dans une liste multiple.

Menu Objet

Le menu Objet de l'objet curseur/calendrier s'ouvre lorsque vous cliquez sur l'objet avec le bouton droit de la souris. Les commandes en sont :

Propriétés... Ouvre la boîte de dialogue Propriétés de l'objet curseur/calendrier permettant de définir un certain nombre de paramètres.
Notes

Permet de créer et de partager des notes concernant l'objet actif.

Voir  : Notes et commentaires

Ordre

Ce menu en cascade est uniquement disponible lorsque la commande Grille de conception du menu Affichage est activée ou lorsque la case Toujours afficher les éléments du menu Conception est cochée sous Préférences utilisateur : Conception. Il contient quatre commandes permettant de définir la couche de disposition des objets de la feuille. Les numéros de couches possibles sont compris entre -128 et 127.

Mettre au premier plan
Définit la couche de disposition de l'objet sur la valeur la plus élevée de toutes les valeurs des autres objets de la feuille active.

Mettre à l'arrière-plan
Définit la couche de disposition de l'objet sur la valeur la plus faible de toutes les valeurs des autres objets de la feuille active.

Avancer
Augmente d'un incrément de un la couche de disposition de l'objet de feuille. Valeur maximale 127.

Reculer
Diminue d'un incrément de un la couche de disposition de l'objet de feuille. Valeur minimale -128.


Copier dans le Presse-papiers Ce menu en cascade contient les diverses options de copie de l'objet.
Image
Copie une image de l'objet dans le Presse-papiers. L'image inclura ou exclura la barre de titre de l'objet et les bordures selon les paramètres définis dans la boîte de dialogue Préférences utilisateur : onglet Exporter.
Objet
Copie l'objet entier dans le Presse-papiers pour que vous puissiez le coller ailleurs dans la disposition ou dans un autre document ouvert dans l'instance active de QlikView.
Objets liés

Ouvre un menu comportant les commandes suivantes applicables aux objets liés.
Ajuster la position des objets liés
Tous les objets liés de toutes les feuilles sont ajustés selon la même position et la même taille que ceux mis en surbrillance.
Détacher l'objet/Détacher les objets
Rompt le lien établi entre les objets, les individualisant à l'aide d'identificateurs uniques.

Réduire Réduit l'objet en icône. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si la réduction en icône est autorisée dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Agrandir Agrandit l'objet pour qu'il remplisse la feuille. Un clic sur l'icône dans la légende de l'objet (si elle est visible) produit le même résultat. Cette commande est uniquement disponible si l'agrandissement est autorisé dans la boîte de dialogue Propriétés de l'objet, sous l'onglet Légende.
Restaurer Restaure un objet réduit ou agrandi à sa taille et à son emplacement de départ. Un double clic sur l'icône d'un objet réduit ou un clic sur l'icône dans la légende d'un objet agrandi (si elle est visible) produit le même résultat. Cette commande est uniquement disponible pour les objets réduits ou agrandis.
Aide Ouvre l'aide de QlikView.
Supprimer Supprime l'objet de feuille de la feuille.

Général

L'onglet Propriétés de l'objet curseur/calendrier : Général s'ouvre via un clic droit sur un objet curseur/calendrier, puis via la commande Propriétés du menu contextuel. Cet onglet vous permet de définir les paramètres généraux pour les données devant être manipulées par l'objet curseur/calendrier. Vous pouvez également accéder à ces informations via la boîte de dialogue Nouvel objet curseur/calendrier.

Sous Style de saisie, sélectionnez le mode de base de l'objet curseur/calendrier. Utilisez le menu déroulant pour choisir si l'objet doit être représenté par une commande Curseur ou une commande de saisie par Calendrier.

Le groupe Données permet de définir l'objet de données auquel le curseur/calendrier est connecté. Un curseur/calendrier peut être connecté soit à un champ, soit à une variable ou une paire de variables.

Champ Sélectionnez cette option pour associer l'objet curseur/calendrier à un champ ou une expression. Sélectionnez le champ dans la liste déroulante. Si vous choisissez Expression, la boîte de dialogue Éditer l'expression s'ouvre.
Éditer... Ouvre la boîte de dialogue Éditer l'expression associée à l'expression sélectionnée dans la liste déroulante.
Variable(s) Cochez cette case d'option et sélectionnez la ou les variable(s) voulue(s) dans les listes déroulantes. La seconde variable n'est disponible que si vous sélectionnez Valeurs multiples dans le groupe Mode (ci-dessous).

Dans le groupe Mode, indiquez si le curseur/calendrier doit être utilisé pour sélectionner une valeur unique ou une plage de valeurs, Valeurs multiples.

Dans le groupe Mode valeur, vous indiquerez si l'objet curseur/calendrier doit sélectionner des valeurs de type Discret (indisponible en mode Valeurs multiples) ou définir une Plage numérique continue (indisponible en mode Valeur simple avec des données de type Champ). Ce groupe n’est pas disponible en mode Calendrier. En mode Calendrier, les valeurs discrètes sont toujours supposées.

Valeur min. Fixe la valeur minimum de l'objet curseur/calendrier dont le type d'intervalle est Plage numérique continue.
Valeur max. Fixe la valeur maximum de l'objet curseur/calendrier dont le type d'intervalle est Plage numérique continue.
Intervalle fixe Cochez la case et saisissez une valeur dans la zone d'édition afin de spécifier un intervalle fixe pour les valeurs du curseur/calendrier dont le type d'intervalle est Plage numérique continue.
Valeur 1 Affiche la valeur actuelle du curseur en mode Plage numérique continue si l'objet curseur/calendrier est défini sur Valeur simple. En mode Valeurs multiples, c'est la valeur basse qui est affichée.
Valeur 2 Affiche la valeur haute actuelle de l'objet curseur/calendrier dont le type d'intervalle est Plage numérique continue. Uniquement en mode Valeurs multiples.
Outrepasser le verrouillage du champ Si cette case est cochée, vous pouvez effectuer des sélections dans le champ via un objet curseur/calendrier, même si le champ est verrouillé. Le champ reste verrouillé pour les changements logiques provenant des sélections effectuées dans d'autres champs. Cette option est sélectionnée par défaut pour les objets curseur/calendrier.
Plage fixe Quand cette option est cochée, l'utilisateur ne peut pas élargir ou rétrécir la plage en tirant les côtés du curseur.
État alternatif Choisissez un des états disponibles dans la liste. Les états alternatifs suivants sont toujours disponibles.
Hérité
Les feuilles et les objets de la feuille sont toujours définis dans l'état hérité, à moins que le développeur QlikView ne remplace cet état par un autre. Ce paramètre est hérité de l'objet situé au niveau ci-dessus. Si l'option hérité est activée, un graphique contenu dans une feuille dispose des mêmes paramètres que cette dernière.
État par défaut
Il s'agit de l'état dans lequel la plupart des actions QlikView se produisent. Il est représenté par le symbole $. Le document QlikView est toujours défini dans l'état par défaut.
ID de l'objet

Ce paramètre s'utilise avec les macros. Chaque objet de la feuille se voit attribuer un numéro d'identification (ID) unique. Pour les objets curseur, l'ID commence par SL01. Les objets liés partagent le même ID d'objet. Vous pourrez modifier ce numéro d'identification ultérieurement.

Voir  : Interpréteur de macros interne

Paramètres d'impression En cliquant sur ce bouton, vous accéderez à la boîte de dialogue Paramètres d'impression où vous pourrez définir les marges et le format d'en-tête/pied de page.

Présentation (mode curseur)

L'onglet Propriétés de l'objet curseur/calendrier : Présentation s'ouvre via un clic du bouton droit sur un objet curseur/calendrier et via la commande Propriétés disponible dans le menu contextuel. L'onglet Présentation vous donne accès à la configuration de l'aspect de l'objet curseur/calendrier.

Le groupe Couleurs vous permet de définir les couleurs des différentes parties du curseur/calendrier, comme l'illustre cette image :

A Graduations
B Arrière-plan de l'échelle
C Arrière-plan du curseur
D Punaise du curseur
E Flèches de défilement

La couleur définie pour les options Arrière-plan du curseur et Arrière-plan de l'échelle peut être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsque vous cliquez sur le bouton correspondant. Le degré de transparence de l'arrière-plan du curseur peut être défini à l'aide de la commande Transparence à droite du bouton. À 0 %, l'arrière-plan sera totalement opaque. À 100 %, l'arrière-plan sera totalement transparent.

Le curseur, les flèches de défilement et les graduations peuvent être d'une couleur unie ou correspondre à un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsque vous cliquez sur le bouton correspondant.

Dans le groupe Orientation du défilement, le curseur peut être affiché dans le sens Horizontal ou Vertical.

Dans le groupe Orientation de l'étiquette vous pouvez déterminer si l'étiquette donnant l'échelle doit être Horizontale ou Verticale.

Dans le groupe Échelle, vous pouvez définir une échelle de curseur. Sélectionnez Mise à l'échelle automatique pour que l'échelle soit générée automatiquement à partir de la taille du curseur et des valeurs sous-jacentes. L'option Utiliser une échelle personnalisée permet de définir des paramètres relatifs à l'échelle :

Graduations principales Ce nombre définit le nombre de graduations principales sur l'échelle du curseur.
Étiquettes toutes les n graduations Définit la densité du texte sur l'échelle.
Graduations secondaires par graduation principale Définit le nombre de graduations secondaires entre chaque graduation principale sur l'échelle du curseur.

Les flèches de défilement peuvent être rendues visibles ou masquées grâce à l'option Afficher les flèches de défilement.

Style de curseur peut être défini sur Continu ou Miroitement.

Remarque: Il existe des limitations à l'emploi des fonctions de mise à l'échelle automatique et d'orientation de l'étiquette verticale en mode AJAX/WebView.
Dans la mesure du possible, il est recommandé de définir les paramètres d'échelle à l'aide de l'option Utiliser une échelle personnalisée.

Présentation (mode calendrier)

L'onglet Propriétés de l'objet curseur/calendrier : Présentation s'ouvre via un clic du bouton droit sur un objet curseur/calendrier et via la commande Propriétés disponible dans le menu contextuel. L'onglet Présentation vous donne accès à la configuration de l'aspect de l'objet curseur/calendrier.

Le groupe Couleurs vous permet de définir la couleur de fond du contrôle calendrier. Cette couleur d'arrière-plan peut être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsque vous cliquez sur ce bouton. Le degré de transparence du fond du contrôle calendrier est défini via le paramètre Transparence situé à droite du bouton. À 0 %, l'arrière-plan sera totalement opaque. À 100 %, l'arrière-plan sera totalement transparent.

Trier

Sous l'onglet Trier, vous définissez l'ordre de tri des données du curseur. Cette boîte de dialogue est très similaire à son équivalent sous Propriétés du document.

Nombre

Sous l'onglet Nombre, vous définissez le format de nombre de l'échelle du curseur. Cette boîte de dialogue est très similaire à son équivalent sous Propriétés du document.

Police

On peut définir ici la Police, le Style de police et la Taille de police à utiliser.

On peut définir la police pour un seul objet (Propriétés de l'objet : Police) ou tous les objets d'un document (Appliquer aux objets sous Propriétés du document : Police).

Les polices par défaut du document des nouveaux objets peuvent également être définies dans Propriétés du document : Police. Il existe deux polices par défaut :

  1. La première police par défaut (Listes de sélection, Graphiques, etc.) est utilisée pour la plupart des objets, notamment les listes de sélection et les graphiques.
  2. La deuxième police par défaut (Objets Texte et Boutons) est utilisée pour les boutons et les zones de texte, objets qui nécessitent généralement une police plus grande.

Enfin, les polices par défaut des nouveaux documents peuvent être définies dans l'onglet Préférences utilisateur : Police.

Pour les graphiques, les boutons et les objets texte (sauf les objets de recherche), vous pouvez aussi spécifier une Couleur de police. La couleur peut être Fixe ou Calculée de façon dynamique par une expression. L'expression doit être une représentation de couleur valide, créée à l'aide des fonctions de couleur. Si le résultat de l'expression n'est pas une représentation de couleur valide, le police est noire par défaut.

Voir  : Fonctions de couleur

Les paramètres supplémentaires sont :

Ombre portée Si cette option est cochée, une ombre sera ajoutée au texte.
Souligner Si cette option est cochée, le texte sera souligné.

Un échantillon de la police sélectionnée est présenté dans le volet d'aperçu.

Disposition

Un paramètre disponible sous Disposition est uniquement appliqué à l'objet actif s'il est défini à partir de l'onglet Propriétés de l'objet.
Il s'applique à tous les objets des types spécifiés dans le document s'il est défini à partir de l'onglet Propriétés du document.

Afficher les bordures

Activez ce paramètre pour utiliser une bordure autour de l'objet de la feuille. Spécifiez un type de bordure dans le menu déroulant.

Intensité de l'ombre Le menu déroulant Intensité de l'ombre permet de définir l'intensité de l'ombre entourant les objets. L'option Aucune ombre est également possible.
Style de bordure Les types de bordure prédéfinis suivants sont disponibles :
Unie
Bordure d'une seule couleur unie.
Enfoncé
Bordure donnant l'impression que l'objet est enfoncé par rapport à l'arrière-plan.
En relief
Bordure donnant l'impression que l'objet est surélevé par rapport à l'arrière-plan.
Mur
Bordure donnant l'impression d'un mur autour de l'objet.
Largeur de bordure Cette option est disponible pour tous les types de bordures. La largeur peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).
Couleur Cliquez sur ce bouton pour ouvrir une boîte de dialogue vous permettant de choisir dans la palette de couleurs une couleur de base convenant à tous les types de bordures.
Arc-en-ciel Crée une bordure aux couleurs de l'arc-en-ciel pour tous les types de bordures. L'arc-en-ciel commencera par la couleur de base sélectionnée en haut de l'objet de feuille.

Lorsque le style Simplifié est le Style des objets sélectionné sous Propriétés du document : Général, vous ne pouvez pas choisir le type de la bordure ; seuls le menu déroulant Intensité de l'ombre et le paramètre Largeur de bordure sont disponibles.

Angles arrondis

Dans le groupe Angles arrondis, vous définissez la forme générale de l'objet de feuille. Ces paramètres permettent de dessiner des objets de feuille de formes diverses, allant de parfaitement circulaires/elliptiques à rectangulaires, en passant par totalement elliptiques. L'option Angles arrondis est uniquement disponible si vous avez sélectionné le Style des objets Avancé sous Propriétés du document : Général.

Angles arrondis Cette option rend les options d'angles arrondis disponibles.
Coins Les coins dont la case à cocher correspondante reste vide seront dessinés en angle droit.
Angulosité Un nombre variable compris entre 2 et 100 où 100 définit un rectangle avec des angles parfaitement droit et 2 correspond à une ellipse parfaite (un cercle pour une échelle 1:1). Une angulosité comprise entre 2 et 5 est généralement optimale pour des angles arrondis.
Rayon de l'angle Ce paramètre détermine le rayon des angles sous forme de distance fixe (Fixe) ou d'un pourcentage du quadrant total (Relatif (%)). Il vous permet de contrôler à quel point les coins seront modifiés par la forme générale sous-jacente définie par l'Angulosité. La distance peut être indiquée en mm, cm, pouces (", pouce), pixels (px, pxl, pixel), points (pt, pts, point) ou en docunits (du, docunit).

Couche

Dans le groupe Couche, on peut indiquer que l'objet se trouve dans une des trois couches proposées :

Inférieure Un objet défini sur la propriété de couche Inférieure ne peut jamais masquer les objets placés sur les couches Standard et Supérieure. Il peut uniquement être placé au-dessus d'autres objets de feuille dans la couche Inférieure.
Standard À leur création, les objets se trouvent sur la couche Standard (intermédiaire). Un objet placé sur la couche Standard ne peut jamais être masqué par des objets placés sur la couche Inférieure et ne peut jamais masquer des objets situés sur la couche Supérieure.
Supérieure Un objet placé sur la couche Supérieure ne peut jamais être masqué par des objets des couches Standard et Inférieure. Seuls d'autres objets de la couche Supérieure peuvent être placés au-dessus.
Personnalisée Les couches Supérieure, Standard et Inférieure correspondent aux couches numérotées en interne 1, 0 et -1 respectivement. Toutes les valeurs comprises entre -128 et 127 sont acceptées. Sélectionnez cette option pour saisir la valeur de votre choix.

Créateur de thèmes...

Ouvre la boîte de dialogue Créateur de thèmes dans laquelle vous pouvez créer un thème de disposition.

Appliquer le thème...

Vous pouvez appliquer un thème de disposition à l'objet, à la feuille ou au document.

Voir  : Thèmes de disposition

Afficher

Dans le groupe Afficher, il est possible de spécifier une condition pour l'affichage de l'objet de la feuille :

Toujours L'objet de la feuille est toujours affiché.
Conditionnel

L'objet de feuille est affiché ou masqué selon une fonction conditionnelle qui est évaluée en permanence en fonction des sélections, etc. L'objet de feuille est uniquement visible si la condition renvoie VRAI.

Voir  : Fonctions conditionnelles

Remarque:

Les utilisateurs dotés des privilèges d'administrateur (Admin) pour le document peuvent outrepasser toutes les conditions d'affichage en sélectionnant l'option Afficher tous les objets et feuilles sous Propriétés du document : Sécurité. On peut basculer dans cette fonctionnalité en appuyant sur Ctrl+Maj+S.

Voir  : Propriétés du document : Sécurité

Options

Dans le groupe Options, il est possible d'interdire le déplacement et le redimensionnement de l'objet. Les paramètres disponibles dans ce groupe s'appliquent uniquement si les cases à cocher correspondantes sont activées dans les boîtes de dialogue Propriétés du document : Disposition et Propriétés de la feuille : Sécurité.

Autoriser le déplacement et le dimensionnement Si cette option est désactivée, il est impossible de déplacer ou de redimensionner l'objet.
Autoriser la copie/le clonage Si cette option est désactivée, il sera impossible de faire une copie de l'objet.
Autoriser les informations

Lorsque la fonction Infos est utilisée, une icône d'information s'affiche dans la légende de la fenêtre chaque fois que des informations sont associées à une valeur de champ. Si vous ne voulez pas que cette icône s'affiche dans la légende, vous désactivez cette option.

Voir  : Info

Ajuster la taille aux données Dans QlikView, les bordures entourant les objets de table sont normalement réduites lorsque des sélections font passer la taille de la table en dessous de la taille allouée à l'objet. En désélectionnant cette case, vous désactivez cet ajustement automatique de la taille et tout surplus d'espace restera vide.

Barres de défilement

Plusieurs paramètres permettant de changer la disposition du contenu de la barre de défilement sont disponibles dans le groupe Barres de défilement :

Conserver la position de défilement

Lorsque ce paramètre est activé, QlikView tente de conserver la position de défilement dans les tables et les graphiques dotés d'une barre de défilement quand une sélection est effectuée dans un autre objet. Ce paramètre doit également être activé dans la boîte de dialogue Préférences utilisateur : Objets.

La position de défilement n'est pas conservée à la fermeture du document.

Boutons Définit la couleur des boutons fléchés. Sélectionnez une couleur en cliquant sur le bouton. Notez que les tons de gris moyen rendent souvent les meilleurs résultats pour les barres de défilement. Ces couleurs peuvent être une couleur unie ou un dégradé défini à l'aide de la boîte de dialogue Couleur de la zone qui s'ouvre lorsqu'on clique sur le bouton approprié.
Arrière-plan

Définit la couleur d'arrière-plan des barres de défilement. Sélectionnez une couleur en cliquant sur le bouton.

Largeur de la barre Cette option permet de modifier à la fois la largeur et la taille relative des symboles de la barre de défilement.
Style de barre

Définit le style des barres de défilement. Sélectionnez le style dans la liste déroulante. Le style Classique correspond aux barres de défilement de QlikView 4/5. Le style Standard leur donne un aspect plus moderne. Le troisième style, Simple, correspond à une barre plus fine et plus claire.

L'option Style des objets doit être définie sur Avancé pour que le style des barres de défilement soit visible. Ce paramètre est disponible sous l'onglet Général. Pour y accéder, ouvrez le menu déroulant Paramètres, puis sélectionnez Propriétés du document.

Appliquer à... Ouvre la boîte de dialogue Propriétés de légende et de bordure dans laquelle vous pouvez définir les éléments auxquels s'appliquent les propriétés définies sous l'onglet Disposition.

Légende

Les paramètres de légende s'appliquent à l'objet actif uniquement s'ils sont définis à partir des propriétés de l'objet.
Ils s'appliqueront à tous les objets du type indiqué dans le document s'ils sont effectués via les propriétés du document.

Sous l'onglet Légende, spécifiez des options de disposition complètement distinctes de la disposition générale de l'objet.

Afficher la barre de titre Lorsque cette option est cochée, une barre de titre est dessinée en haut de l'objet. Cette option est activée par défaut pour les listes de sélection et autres « objets zone », contrairement aux objets texte et ligne/flèche.
Texte du titre Cette zone de texte permet de spécifier un titre à afficher dans la légende de l'objet. Cliquez sur le bouton Police… pour changer la police de la légende.

Définissez les couleurs de la légende selon les différents états de la fenêtre. Les paramètres Couleurs actives et Couleurs inactives peuvent être configurés séparément les uns des autres.

Cliquez sur le bouton Couleur d'arrière-plan ou Couleur du texte pour ouvrir la boîte de dialogue Couleur de la zone. La couleur d'arrière-plan peut être définie comme une couleur unie ou en dégradé dans la boîte de dialogue Couleur de la zone. La couleur du texte peut être définie comme fixe ou calculée via les fonctions de couleur.

Voir  : Fonctions de couleur

Renvoi auto. à la ligne Si cette option est cochée, la légende sera affichée sur deux ou plusieurs lignes.
Hauteur de la légende (lignes) Définissez le nombre de lignes de légende dans cette zone d'édition.

La taille et la position précises de l'objet QlikView peuvent être déterminées et ajustées par les paramètres de taille/position de l'objet QlikView normal ou réduit. Ces paramètres sont mesurés en pixels :

Pos. X Définit la position horizontale du côté gauche de l'objet par rapport au bord gauche de la feuille.
Pos. Y Définit la position verticale du côté supérieur de l'objet par rapport au bord supérieur de la feuille.
Largeur Définit la largeur de l'objet QlikView.
Hauteur Définit la hauteur de l'objet QlikView.

L'orientation de la légende peut être modifiée à l'aide des options Alignement de la légende :

Horizontal L'étiquette peut être alignée horizontalement : à gauche, aucentre ou à droite dans la zone de la légende.
Vertical L'étiquette peut être alignée verticalement : en Haut, au Centre ou en Bas dans la zone de la légende.

Icônes spéciales
Bon nombre des commandes du menu Objet des objets de feuille peuvent être configurées comme des icônes de légende. Sélectionnez les commandes à afficher ainsi en cochant la case qui se trouve à leur gauche dans la liste.

Remarque: Utilisez les icônes de légende spéciales avec précaution. Trop d'icônes ne feront qu'embrouiller l'utilisateur.
Autoriser la réduction Quand cette option est cochée, une icône de réduction s'affiche dans la légende de l'objet pour indiquer qu'on peut le réduire. Une autre solution consiste à double-cliquer sur la légende.
Réduction automatique Cette option devient disponible lorsque la case Autoriser la réduction est cochée. Lorsque la case Réduction automatique est cochée pour plusieurs objets de la même feuille, ils sont tous réduits automatiquement sauf un. Cette option s'avère utile pour, par exemple, afficher alternativement plusieurs graphiques dans la même zone de la feuille.
Autoriser l'agrandissement Quand cette option est cochée, une icône d'agrandissement s'affiche dans la barre de titre de l'objet pour indiquer qu'on peut l'agrandir. Une autre solution consiste à double-cliquer sur la légende. Si les deux cases Autoriser la réduction et Autoriser l'agrandissement sont cochées, double-cliquer sur l'objet le réduira.
Texte d'aide

Vous pouvez saisir ici un texte d'aide à afficher dans une fenêtre contextuelle. Le texte d'aide peut être défini sous la forme d'une formule calculée. Cette option n'est pas disponible au niveau du document. Cliquez sur le bouton ... pour ouvrir la boîte de dialogue Éditer l'expression qui facilite l'édition des formules longues.

Voir  : Syntaxe des expressions pour les formules calculées

Saisissez par exemple une description de l'objet. Une icône d'aide sera ajoutée à la légende de l'objet. Lorsque le pointeur de la souris est immobilisé sur l'icône, le texte s'affiche dans une fenêtre contextuelle.