Création d'un tableau croisé dynamique à l'aide de colonnes de tableau Excel

Vous pouvez créer des tableaux croisés dynamiques Excel en utilisant des niveaux. Néanmoins, nous recommandons la méthode suivante, plus simple et plus rapide.

Les procédures suivantes doivent être exécutées dans Excel 2007 ou une version ultérieure.

Création d'un rapport Excel

Procédez comme suit :

  1. Sélectionnez Rapports dans le menu principal de Qlik NPrinting, puis cliquez sur Créer un rapport.
  2. Renseignez le champ Titre du rapport. Pivot table report using Excel table.
  3. Sélectionnez Excel dans la liste déroulante Type.
  4. Sélectionnez une application dans la liste déroulante Application.
  5. Cliquez sur Créer pour créer le rapport.
  6. Cliquez sur Éditer le modèle pour ouvrir l'éditeur de modèle.

Ajout d'un objet comme table et modification de la propriété Keep Source Formats

Procédez comme suit :

  1. Cliquez sur le nœud Tables avec le bouton droit de la souris, puis sélectionnez Ajouter des objets.
  2. Sélectionnez la connexion au document QlikView contenant l'objet souhaité.
  3. Ajoutez CH205 comme table au modèle.

    Seuls les tableaux simples QlikView peuvent être utilisés pour créer le modèle. Si vous souhaitez utiliser un tableau croisé dynamique QlikView, vous devez le convertir en tableau simple ou, si vous souhaitez conserver l'original, le cloner et convertir le clone. Ajoutez ensuite le tableau converti à votre modèle.

  4. Cliquez avec le bouton droit de la souris sur CH205 dans le nœud Tables, puis sélectionnez Propriétés.
  5. Désactivez la case à cocher Keep Source Formats associée à CH205.

Construction de la table à partir de colonnes

Construisez la table de base en faisant glisser les colonnes une à une dans le modèle, puis en les déposant dans des cellules vides. Vous pouvez utiliser toutes les colonnes ou une partie d'entre elles.

Procédez comme suit :

  1. Développez les colonnes CH205.
  2. Appuyez sur la touche Maj et sélectionnez toutes les colonnes.
  3. Faites glisser les colonnes et déposez-les dans des cellules vides du modèle.
  4. Ouvrez le Excel ruban en cliquant sur l'icône Barre d'outils du groupe Afficher de la barre d'outils de l'éditeur de modèle.
  5. Ajustez et mettez en forme les en-têtes de colonne, le cas échéant.
  6. Mettez en surbrillance l'en-tête de colonne, la balise et une ligne sous les cellules pour les sélectionner.
  7. Sur le ruban, sélectionnez l'onglet Insertion.
  8. Cliquez sur Tableau dans le groupe Tableaux du ruban.
  9. Vérifiez que la case Mon tableau comporte des en-têtes est cochée.
  10. Cliquez sur OK.
  11. Faites glisser une balise deleterow et déposez-la dans la colonne A de la première ligne vide sous le tableau pour la supprimer.

Conversion en tableau croisé dynamique

Procédez comme suit :

  1. Mettez en surbrillance la balise de colonne et les cellules d'en-tête pour les sélectionner, le cas échéant.
  2. Sélectionnez l'onglet Création sous Outils de tableau dans le ruban.
  3. Cliquez sur Synthétiser avec l'élément Tableau croisé dynamique sélectionné dans le groupe Outils.
  4. Cliquez sur OK.

    Le nouveau tableau croisé dynamique est créé sur une nouvelle feuille de calcul. Vous pouvez également ajouter le tableau croisé dynamique sur la même feuille de calcul que les données d'origine et, par exemple, masquer la colonne contenant les données.

  5. Faites glisser le champ Year dans la zone Colonnes.
  6. Faites glisser les champs Salesman et Country dans la zone Étiquettes de lignes.
  7. Faites glisser le champ Sales dans la zone Valeurs, puis cliquez dessus.
  8. Cliquez sur Count of Total sales pour ouvrir le menu.
  9. Sélectionnez Paramètres des champs de valeurs.
  10. Sélectionnez Somme sous l'onglet Synthétiser des valeurs par de la boîte de dialogue Paramètres des champs de valeurs.
  11. Cliquez sur OK.

Définition des données à actualiser

Procédez comme suit :

  1. Cliquez sur le menu déroulant Options sous l'onglet Outils de tableau croisé dynamique - Analyser.
  2. Sélectionnez l'onglet Données.
  3. Cochez la case Actualiser les données lors de l'ouverture du fichier.
  4. Définissez l'option Nombre d'éléments à retenir par champ sur None.
  5. Cliquez sur OK au bas de la boîte de dialogue Options du tableau croisé dynamique.

Si vous ne réalisez pas ces étapes, un tableau croisé dynamique vide s'affichera dans le rapport généré.

Aperçu et enregistrement

Procédez comme suit :

  1. Cliquez sur Aperçu.
  2. Vérifiez le rapport, fermez-le, puis éditez à nouveau le modèle, le cas échéant.
  3. Cliquez sur Enregistrer et fermer pour enregistrer le modèle et fermer l'éditeur de modèle.