Accéder au contenu principal

Création de tableaux croisés dynamiques Excel

Vous pouvez créer des tableaux croisés dynamiques Excel en utilisant des niveaux ou des colonnes de table Excel.

Les tableaux croisés dynamiques Qlik Sense peuvent uniquement être ajoutés comme images dans Qlik NPrinting. Les tableaux croisés dynamiques QlikView peuvent être ajoutés comme images et tableaux simples. Aucun ne peut être converti en tableau croisé dynamique Excel dans les rapports. Si vous souhaitez reproduire un tableau croisé dynamique dans un rapport Excel, vous avez deux possibilités :

  • Convertir le tableau croisé dynamique d'origine en tableau simple
  • Cloner votre tableau croisé dynamique et convertir le clone en tableau simple

Création d'un tableau croisé dynamique à l'aide de colonnes de table Excel

Nous vous conseillons d'utiliser les colonnes de table Excel pour créer des tableaux croisés dynamiques dans les rapports Excel. Cette méthode est plus simple que les niveaux et ne ralentit pas la génération de rapports.

Conditions requises

Conditions requises pour la création d'un tableau croisé dynamique dans le Qlik NPrinting Designer :

  • Excel 2007 ou ultérieur
  • Un tableau simple Qlik Sense ou QlikView

À faire

Vous allez :

  1. Ajouter un tableau simple QlikView comme objet de table dans un rapport Excel.
  2. Créer une table colonne par colonne
  3. Convertir cette table en tableau croisé dynamique.

Ce tutoriel utilise des données QlikView se trouvant dans Fichiers exemples. Vous pouvez aussi utiliser vos données Qlik Sense ou QlikView.

Création d'un nouveau rapport Excel

Procédez comme suit :

  1. Sélectionnez Rapports dans le menu principal de Qlik NPrinting, puis cliquez sur Créer un rapport.
  2. Renseignez le champ Titre du rapport.
  3. Sélectionnez Excel dans la liste déroulante Type.
  4. Sélectionnez une application dans la liste déroulante Application.
  5. Cliquez sur Créer pour créer le rapport.
  6. Cliquez sur Éditer le modèle pour ouvrir l'éditeur de modèle.

Ajout d'un objet graphique en tant que table colonne par colonne

Procédez comme suit :

  1. Cliquez sur le nœud Tables avec le bouton droit de la souris, puis sélectionnez Add objets (Ajouter des objets).
  2. Sélectionnez la connexion contenant le tableau simple.
  3. Sélectionnez un objet table. Par exemple : Straight Country - Salesman - Year. Cliquez sur OK.

  4. Dans le nœud Tables, sélectionnez Straight Country - Salesman - Year.
  5. Dans le volet Properties (Propriétés), désélectionnez la case à cocher Keep Source Formats.
  6. Cliquez sur + à côté de Straight Country - Salesman - Year.

    Cela permet de développer le nœud de la table et affiche toutes les colonnes.

  7. Maintenez la touche Shift ou CTRL enfoncée et sélectionnez les colonnes à ajouter. Dans cet exemple, sélectionnez les quatre champs de table.
  8. Faites glisser les colonnes sur le modèle.

    Excel report template with levels added as table.

  9. Mettez en surbrillance les en-têtes de colonne, les balises de table et une ligne vide en-dessous.
  10. Sur le ruban Excel, cliquez sur Insertion.
  11. Dans le groupe Tables, cliquez sur Table.
  12. Vérifiez que la case Mon tableau comporte des en-têtes est cochée. Cliquez sur OK.

    Excel report template with levels added as table.

  13. Dans le volet gauche, cliquez sur Extras. Faites glisser une balise deleterowdans une cellule de la ligne vide située en dessous du tableau.

    Cette balise permettra de supprimer la ligne vide dans le rapport final.

    Excel report template creation with pivot table.

Conversion en tableau croisé dynamique

Procédez comme suit :

  1. Mettez en surbrillance les cellules d'en-tête et de champ de table.
  2. Sur le ruban Excel, sous Outils de tableau, cliquez sur l'onglet Création.
  3. Dans le groupe Outils, cliquez sur Synthétiser avec un tableau croisé dynamique.

  4. Dans la fenêtre de création de tableau croisé dynamique, cliquez sur OK.

    Excel report template creation with pivot table.

    Le nouveau tableau croisé dynamique est créé sur une nouvelle feuille de calcul. Vous pouvez aussi ajouter le tableau croisé dynamique sur la même feuille de calcul et masquer la colonne contenant les données.

  5. Faites glisser le champ Year dans la zone Colonnes.
  6. Faites glisser les champs Salesman et Country dans la zone Étiquettes de lignes.
  7. Faites glisser le champ Sales dans la zone Valeurs.

    Excel report template creation with pivot table.

  8. Cliquez sur Count of Total sales pour ouvrir le menu déroulant. Sélectionnez Paramètres des champs de valeurs.

    Excel report template with levels added as table.

  9. Dans l'onglet Synthétiser des valeurs par, sélectionnez Somme. Cliquez sur OK.
  10. Sélectionnez les cellules de la table contenant des valeurs Ventes. Appliquez le format Monétaire.

    Excel report template creation with pivot table.

S'assurer que les données ont été actualisées lorsque le rapport s'ouvre.

Si vous ne réalisez pas ces étapes, un tableau croisé dynamique vide s'affichera dans le rapport généré.

Procédez comme suit :

  1. Sous l'onglet Outils de tableau croisé dynamique - Analyser. À gauche, cliquez sur le menu déroulant Options.
  2. Sélectionnez l'onglet Données.
  3. Cochez la case Actualiser les données lors de l'ouverture du fichier.
  4. Définissez l'option Nombre d'éléments à retenir par champ sur None.
  5. Cliquez sur OK.

    Excel report template creation with pivot table.

Aperçu du rapport

Procédez comme suit :

  1. Cliquez sur Aperçu.

    Excel lance et affiche le rapport.

  2. Un rapport contenant un tableau croisé dynamique s'affiche.

    Excel report template creation with pivot table.

  3. Cliquez sur Enregistrer et fermer pour enregistrer le modèle et fermer l'éditeur de modèle.

Création d'un rapport de tableau croisé dynamique à l'aide de niveaux

Vous pouvez créer des tableaux croisés dynamiques à l'aide de niveaux, mais cela ralentit la création de rapports. N'utilisez cette méthode que si vous possédez une version de Excel (2003 ou antérieure) ne prenant pas en charge l'ajout de colonnes de table.

À faire

  1. Ajouter un tableau simple QlikView comme objet de niveau dans un rapport Excel.
  2. Créer une table à l'aide de niveaux.
  3. Convertir cette table en tableau croisé dynamique.

Ce tutoriel utilise des données QlikView se trouvant dans Fichiers exemples. Vous pouvez aussi utiliser vos données Qlik Sense ou QlikView.

Ajout de niveaux au modèle

Procédez comme suit :

  1. Créez un nouveau rapport ou ouvrez un rapport existant Excel.

    Voir : Création

  2. Cliquez sur le nœud Levels (Niveaux) avec le bouton droit de la souris, puis sélectionnez Add levels (Ajouter des niveaux).
  3. Sélectionnez Straight Country - Salesman - Year dans la liste des niveaux. Cliquez sur OK.
  4. Faites glisser le nœud CH205_Level - Straight Country-Salesman-Year sur des cellules vides du modèle. Des balises d'ouverture et de fermeture sont alors créées pour le niveau.

    Excel report template creation with pivot table.

  5. Cliquez sur + à côté du nœud CH205_Level - Straight Country-Salesman-Year.
  6. Glissez les nœuds Country, Salesman, Year et Sales sur des cellules vides dans les lignes situées entre les balises <CH205_Level> et </CH205_Level>.

    Dans le volet Propriétés, assurez-vous que la case Keep Sources Formats (Conserver les formats source) n'est cochée pour aucun de ces quatre objets.

  7. Saisissez des en-têtes pour les colonnes sur la ligne au-dessus de la balise <CH205_Level>.

    Excel report template creation with pivot table.

Remarque:

Les objets QlikView comportant des dimensions calculées ou des valeurs nulles peuvent être utilisés comme niveaux. Cependant, vous ne pouvez pas imbriquer d'autres objets à l'intérieur, à l'exception des champs provenant de l'objet de feuille en question. Qlik Sense En revanche, il n'est pas possible d'utiliser les visualisations Qlik Sense comprenant des dimensions calculées comme niveaux.

Création d'un tableau croisé dynamique

Procédez comme suit :

  1. Sélectionnez la plage de cellules comprenant les éléments suivants :
    • Les en-têtes
    • La balise d'ouverture <CH205_Level>
    • Les balises de colonne
    • La balise de fermeture </CH205_Level>
  2. Dans le ruban Excel, sélectionnez l'onglet Insertion. Dans le groupe Tables, sélectionnez Tableau croisé dynamique.
  3. Dans la fenêtre de création de tableau croisé dynamique, cliquez sur OK.

    Excel report template creation with pivot table.

    Le nouveau tableau croisé dynamique est créé sur une nouvelle feuille de calcul. Vous pouvez aussi ajouter le tableau croisé dynamique sur la même feuille de calcul et masquer la colonne contenant les données.

  4. Faites glisser les champs Country et Salesman dans la zone Étiquettes de lignes.
  5. Faites glisser le champ Year dans la zone Étiquettes de colonnes.
  6. Faites glisser le champ Sales dans la zone Valeurs.

    Excel report template creation with pivot table.

  7. Dans le groupe Champ actif, cliquez sur le bouton Paramètres de champ.
  8. Modifiez la valeur de l'onglet Résumer le champ de valeur par en sélectionnant Somme. Cliquez sur OK.

    Excel report template creation with pivot table.

  9. Sélectionnez les cellules de la table contenant des valeurs Ventes. Appliquez le format Monétaire.

    Excel report template creation with pivot table.

S'assurer que les données ont été actualisées lorsque le rapport s'ouvre.

Si vous ne réalisez pas ces étapes, un tableau croisé dynamique vide s'affichera dans le rapport généré.

Procédez comme suit :

  1. Sous l'onglet Outils de tableau croisé dynamique - Analyser. À gauche, cliquez sur le menu déroulant Options.
  2. Sélectionnez l'onglet Données.
  3. Cochez la case Actualiser les données lors de l'ouverture du fichier.
  4. Définissez l'option Nombre d'éléments à retenir par champ sur None.
  5. Cliquez sur OK.

    Excel report template creation with pivot table.

Aperçu du rapport

Procédez comme suit :

  1. Cliquez sur Aperçu.

    Excel lance et affiche le rapport.

  2. Un rapport contenant un tableau croisé dynamique s'affiche.

    Excel report template creation with pivot table.

  3. Cliquez sur Enregistrer et fermer pour enregistrer le modèle et fermer l'éditeur de modèle.