Publication d'un rapport simple à partir d'un document QlikView

Ce didacticiel vous explique comment créer et publier un rapport Qlik NPrinting PowerPoint simple à l'aide de données QlikView.

Qlik NPrinting comporte de nombreuses fonctions. Ce didacticiel est conçu pour aider les nouveaux utilisateurs à créer leur premier rapport. Il ne présente pas tous les types de rapport, éléments de conception ou options de publication. Au terme de ce didacticiel, vous aurez créé, édité et publié un rapport PowerPoint consultable par les utilisateurs que vous aurez sélectionnés.

Autres didacticiels Qlik NPrinting :

Remarque: Microsoft Office doit être installé sur l'ordinateur pour que vous puissiez éditer et créer des rapports dans des formats de fichier Office.

Ce didacticiel passera en revue les procédures suivantes :

Accès à un document QlikView

Les rapports nécessitent des données. Vous apprendrez à télécharger et à importer un exemple de document QlikView.

Connexion de Qlik NPrinting à un document QlikView

Qlik NPrinting doit se connecter au document QlikView. Vous apprendrez à configurer Qlik NPrinting pour qu'il accède à l'exemple de document ou aux données QlikView existantes.

Création d'un modèle de rapport Qlik NPrinting

Les modèles de rapports contrôlent la disposition et les formats de sortie des rapports. Cette section vous montrera comment en créer un nouveau.

Édition du modèle de rapport

Les rapports offrent de nombreuses options de mise en forme différentes. Dans cette section, nous verrons comment ajouter un titre, des images, une table, un graphique et des pages à un rapport.

Publication sur NewsStand et par e-mail

NewsStand est une console Web à laquelle les utilisateurs peuvent accéder pour consulter des rapports. Vous apprendrez à publier un rapport sur NewsStand et par e-mail.

Accès à un document QlikView

Les documents QlikView contiennent les données et visualisations que Qlik NPrinting utilise pour élaborer les rapports. Il existe différentes manières d'accéder à un document QlikView.

  • Vous pouvez télécharger un document QlikView à partir du site d'aide de Qlik, puis l'enregistrer dans un dossier de votre ordinateur.
  • Vous pouvez utiliser votre propre document QlikView et passer directement à Connexion de Qlik NPrinting à un document QlikView. Si vous utilisez l'un de vos documents pour effectuer ce didacticiel, choisissez-en un simple. La durée de chargement de Qlik NPrinting est plus longue pour les documents QlikView complexes.

Téléchargement d'un document QlikView à partir du site d'aide de Qlik et enregistrement sur l'ordinateur

Procédez comme suit :

  1. Sur le site d'aide de Qlik NPrinting, accédez au dossier Fichiers exemples, puis téléchargez le fichier Examples.zip à l'emplacement de votre choix sur l'ordinateur sur lequel Qlik NPrinting est installé.
  2. Sous Windows, décompressez Sales Demo.qvw, puis enregistrez-le dans le dossier C:\Program Files\QlikView\Examples\. S'il n'existe pas encore, créez le dossier.

    Si vous enregistrez les fichiers à un emplacement différent, il est nécessaire de substituer cet emplacement au chemin C:\Program Files\QlikView\Examples\ indiqué dans l'aide de Qlik NPrinting.

Avertissement: Les lecteurs mappés, tels que Z:\NPrintingServer\QlikViewDocuments, ne sont pas pris en charge par Qlik NPrinting. Vous devez utiliser des chemins d'accès UNC (Universal Naming Convention), tels que \\NomServeur\NPrintingServer\QlikViewDocuments.

Connexion de Qlik NPrinting à un document QlikView

Nous allons à présent créer une application Qlik NPrinting et la connecter à votre document QlikView.

Les applications Qlik NPrinting contiennent des rapports, des filtres et des connexions à des applications Qlik Sense ou des documents QlikView. Elles permettent au composant Qlik NPrinting Designer d'accéder à vos données afin qu'il puisse les utiliser dans un rapport.

Procédez comme suit :

  1. Connectez-vous à la console Web Qlik NPrinting.
  2. Dans le menu principal, cliquez sur le menu déroulant Applications, puis sélectionnez Applications.
  3. Cliquez sur le bouton Créer une application.
    1. Saisissez le nom de cette nouvelle application. Par exemple : Beginner's Tutorial NP App - QV.
    2. Vérifiez que la case Activé est cochée. Sinon, l'application sera ignorée par le composant Qlik NPrinting Engine.
    3. Cliquez sur Créer.

      Vous pouvez désormais visualiser l'application Beginner's Tutorial NP App - QV sous Applications.

  4. Dans le menu principal, cliquez sur le menu déroulant Applications, puis sélectionnez Connexions.
    1. Cliquez sur le bouton Créer une connexion.
    2. Dans la zone Nom, saisissez un nom pour la connexion : Beginner's Tutorial Connection - QV.
    3. Dans la liste déroulante Application, sélectionnez l'application Qlik NPrinting précédemment créée : Beginner's Tutorial NP App - QV.
    4. Sous Source, sélectionnez QlikView.
    5. Sous Type, sélectionnez Local.
    6. Sous Chemin d'accès au document, indiquez l'emplacement du document QlikView auquel vous souhaitez vous connecter.

      Par exemple : C:\Program Files\QlikView\Examples\Sales Demo.qvw

      Avertissement: Les lecteurs mappés, tels que Z:\NPrintingServer\QlikViewDocuments, ne sont pas pris en charge par Qlik NPrinting. Vous devez utiliser des chemins d'accès UNC (Universal Naming Convention), tels que \\NomServeur\NPrintingServer\QlikViewDocuments.
    7. Si le document QlikView exige une authentification, assurez-vous que la case Authentification requise pour la connexion est cochée.

      Voir : Section access.

    8. Cliquez sur le bouton Exécuter la vérification. Cette action vérifie que la connexion est valide.

      Si la connexion est valide, le message « La vérification est terminée. » s'affiche à l'écran. Sinon, le message suivant est généré : « Des erreurs ont été détectées. Consultez les détails ci-dessous. »

    9. Une fois les paramètres de connexion vérifiés, cliquez sur Créer. Vous revenez automatiquement au menu Connexions.
    10. La nouvelle connexion affichera l'état État du cache - En cours de génération. Autrement dit, Qlik NPrinting est en train de se connecter à QlikView et d'importer des métadonnées. Si le document QlikView est volumineux, cette opération peut prendre plusieurs minutes.
      Remarque:

      Chaque fois que vous ajoutez de nouveaux objets au document QlikView, vous devez recharger les métadonnées de la connexion.

    11. Une fois que l'état du cache affiche Généré, vous pouvez créer un nouveau modèle de rapport. Si l'état Erreur est indiqué, vérifiez les informations de connexion.

La nouvelle connexion est désormais disponible sur l'écran Connexions.

Si vous ne parvenez pas à vous connecter à votre document QlikView, voir :

Création d'un modèle de rapport Qlik NPrinting

Les modèles de rapports contrôlent la disposition et les formats de sortie des rapports. Vous pouvez organiser les objets et mettre en forme les pages à l'aide des options standard du type de rapport choisi. Par exemple, un rapport PowerPoint aura les mêmes options de mise en forme et la même interface qu'un diaporama PowerPoint.

Procédez comme suit :

  1. Sur la console Web Qlik NPrinting, cliquez sur Rapports dans le menu principal.
  2. Cliquez sur le bouton Créer un rapport.
  3. Saisissez un titre dans le champ Titre. Par exemple : Beginner's Tutorial NP PowerPoint.
  4. Dans la liste déroulante Type, sélectionnez PowerPoint.
  5. Dans la liste déroulante Application, sélectionnez l'application intitulée Beginner's Tutorial NP App - QV.
  6. Dans les options disponibles sous Modèle, cliquez sur Fichier vide.
  7. Vérifiez que la case Activé est cochée. Sinon, votre rapport sera ignoré par le composant Qlik NPrinting Engine.
  8. Cliquez sur Créer.

Vous pouvez désormais consulter l'application Beginner's Tutorial NP PowerPoint sous Rapports.

Édition du modèle de rapport

Il existe différentes manières d'éditer un modèle de rapport. Nous allons ajouter les éléments suivants :

  • Titres : texte simple utilisé pour organiser votre rapport. Ils sont modifiables à l'aide des outils de mise en forme standard d'PowerPoint.
  • Tables : permettent de présenter les données QlikView sous forme de table.
  • Images : permettent de présenter les données QlikView au format .png.
  • Graphiques : permettent de présenter les données de table QlikView sous forme de graphique PowerPoint.

  • Pages : permettent de subdiviser vos données selon une dimension. Elles peuvent être appliquées à des tables et à des images. Nous allons diviser Year et Category Name.

Cette section ne traite pas de toutes les opérations qu'il est possible d'effectuer dans Qlik NPrinting Designer. Si vous souhaitez en savoir plus sur les fonctions de rapport PowerPoint avancées, voir : Rapports PowerPoint.

Remarque: L'aperçu d'un rapport peut varier par rapport à l'image ci-dessous en fonction de la mise en forme que vous lui avez appliquée. Certains objets peuvent porter des noms légèrement différents, selon l'ordre dans lequel ils ont été sélectionnés.

Procédez comme suit :

  1. Sur la console Web Qlik NPrinting, cliquez sur Rapports dans le menu principal.
  2. Dans l'écran Rapports, cliquez sur le rapport pertinent.
  3. Cliquez sur le bouton Éditer le modèle pour ouvrir l'éditeur de modèle de Qlik NPrinting Designer.

  4. L'assistant de création de graphique Qlik NPrinting Designer s'ouvre. Comme nous sommes en train d'élaborer un rapport PowerPoint, l'interface standard de PowerPoint va s'afficher. Vous pouvez appliquer la plupart des fonctions de mise en forme de PowerPoint à votre rapport à partir de cette interface.
  5. Saisissez un titre :
    1. Sur la première diapositive, saisissez un titre : Par exemple, « Sales Trends by Product Category ».
    2. Saisissez un sous-titre ou supprimez la zone de texte du sous-titre.

      Conseil: Vous pouvez utiliser les options de mise en forme de PowerPoint pour modifier l'aspect de ces titres. Par exemple, vous pouvez modifier la taille et la couleur de police.
  6. Ajoutez des images :
    1. Sur la barre d'outils de PowerPoint, cliquez sur l'onglet Insertion.
    2. Cliquez sur le bouton Nouvelle diapositive.
    3. Saisissez un titre : par exemple, "Top Selling Products". Supprimez la deuxième zone de texte vide.
    4. Dans le volet gauche, cliquez sur Images avec le bouton droit de la souris, puis sélectionnez Add objects (Ajouter des objets).

    5. Une nouvelle fenêtre s'ouvre. Sélectionnez Products et Sales by Category for 2014 vs 2013, puis cliquez sur OK.

      Vous pouvez sélectionner plusieurs options en maintenant la touche CTRL enfoncée.

    6. Faites glisser SH02 - Products sur la diapositive.

    7. Sur la barre d'outils de PowerPoint, cliquez sur l'onglet Insertion.
    8. Cliquez sur le bouton Nouvelle diapositive.
    9. Saisissez un titre : par exemple, "Sales by Category: 2013 vs 2014". Supprimez la deuxième zone de texte vide.
    10. Faites glisser CH212 - Sales by Category for 2014 vs 2013 sur la diapositive.

  7. Ajoutez une table :
    1. Dans le volet gauche, cliquez sur Tables avec le bouton droit de la souris, puis sélectionnez Add objects (Ajouter des objets).
    2. Une nouvelle fenêtre s'ouvre. Sélectionnez Sales by Category: 2013 vs 2014. Cliquez sur OK.

    3. Faites glisser CH212_1 - Sales by Category for 2014 vs 2013 sur la diapositive.

  8. Ajoutez un graphique PowerPoint natif :
    1. Sur la barre d'outils de PowerPoint, cliquez sur l'onglet Insertion.
    2. Cliquez sur le bouton Nouvelle diapositive.
    3. Saisissez un titre : par exemple, "Sales Trends:". Supprimez la deuxième zone de texte vide.
    4. Dans le volet gauche, cliquez sur Tables avec le bouton droit de la souris, puis sélectionnez Add objects (Ajouter des objets).

    5. Une nouvelle fenêtre s'ouvre. Sélectionnez CH326 - Sales by YearMonthNum. Cliquez sur OK.

    6. Sur la barre d'outils de PowerPoint, sélectionnez l'onglet Insertion.
    7. Dans la section Illustrations, cliquez sur Graphique .
    8. Une nouvelle fenêtre s'ouvre. Sous Column (Colonne), sélectionnez le premier histogramme, puis cliquez sur OK.

    9. Une feuille de calcul Excel s'affiche. Il s'agit de la source de données de votre graphique.

      Nous devrons insérer des balises Qlik NPrinting sur cette feuille et supprimer des données inutiles.

    10. Dans le volet gauche de l'interface de PowerPoint, développez le nœud CH326 - Sales by YearMonthNum.
    11. Sélectionnez les balises YearMonthNum et Sales.

      Vous pouvez sélectionner plusieurs options en maintenant la touche CTRL enfoncée.

    12. Faites glisser la balise Year MonthNum et déposez-la dans la cellule A1 de la feuille de calcul Excel. Vous obtiendrez l'axe des ordonnées. Faites glisser les balises Sales dans la cellule B1. Vous obtiendrez l'axe des abscisses.

    13. Sélectionnez et supprimez les colonnes C et D.

      Les nombres réels sont inutiles, car Qlik NPrinting utilisera les balises pour élaborer le graphique.

    14. Sélectionnez et supprimez les lignes 3, 4 et 5.

    15. Fermez Excel.

      Vos modifications seront enregistrées automatiquement.

    16. Pour que le graphique tienne sur la diapositive, vous devrez peut-être ajuster sa taille. Vous pouvez utiliser les flèches de dimensionnement.

    17. Dans le menu de l'éditeur de modèle Qlik NPrinting, cliquez sur l'onglet Fichier. Cliquez sur Enregistrer.
    18. Cliquez sur l'onglet Modèle, puis sur le bouton Aperçu afin d'afficher un aperçu de votre rapport.

      Votre diaporama comporte quatre diapositives pour le moment.

  9. Ajoutez des pages :
    1. Rendez-vous sur la diapositive où vous souhaitez ajouter la page. Dans notre cas, il s'agit de la quatrième diapositive.

      Les pages ne sont appliquées qu'à la diapositive active.

    2. Dans le volet gauche, cliquez sur Page avec le bouton droit de la souris, puis sélectionnez Add page to current sheet (Ajouter la page à la feuille active).
    3. Une nouvelle fenêtre s'ouvre. Sélectionnez CategoryName. Cliquez sur OK.

      Remarque: Remarque : si vous ajoutez une deuxième page à une diapositive, elle écrase la page précédente.
    4. Développez le nœud CategoryName_Page - CategoryName. Faites glisser la balise CategoryName sur la diapositive.

      Cette balise divisera les données par catégorie, chaque catégorie étant contenue sur une diapositive. Le texte <CategoryName> sera remplacé par le nom de la catégorie de chaque diapositive. Au lieu qu'une diapositive indique « Sales Trends: », vous obtiendrez plusieurs diapositives portant des titres uniques : « Sales Trends: Baby Clothes », « Sales Trends: Women's Shoes ».

      La balise <CategoryName> s'affichera en tant que nouvelle zone de texte. Si vous coupez et collez ce nouveau texte dans la zone de texte du titre, vous pouvez le mettre en forme pour qu'il corresponde mieux au titre.

    5. Passons à la deuxième diapositive, « Top Selling Products ».
    6. Dans le volet gauche, cliquez sur Page avec le bouton droit de la souris, puis sélectionnez Add page to current sheet (Ajouter la page à la feuille active).
    7. Une nouvelle fenêtre s'ouvre. Sélectionnez Year. Cliquez sur OK.
    8. Développez le nœud Year_Page - Year. Faites glisser la balise Year sur la diapositive.

      Elle s'affichera sous la forme d'une nouvelle zone de texte. Si vous coupez et collez ce nouveau texte dans la zone de texte du titre, vous pouvez le mettre en forme pour qu'il corresponde mieux au titre.

    9. Sur la barre d'outils de PowerPoint, cliquez sur l'onglet Insertion.
    10. Cliquez sur le bouton Numéro de diapositive.
    11. Une nouvelle fenêtre s'ouvre. Cochez les cases Date et heure, Numéro de diapositive et Ne pas afficher sur la diapositive de titre. Cliquez sur Appliquer partout.

  10. Dans le menu de l'éditeur de modèle Qlik NPrinting, cliquez sur l'onglet Fichier. Cliquez sur Enregistrer.
  11. Cliquez sur l'onglet Modèle, puis sur le bouton Aperçu afin d'afficher un aperçu de votre rapport.

    Le chargement de l'aperçu peut prendre plusieurs minutes, selon la taille du rapport.

    Vous disposez à présent d'un rapport constitué de 13 diapositives. Les diapositives auxquelles des pages sont appliquées ont été développées en nouvelles pages dont les informations sont divisées selon les catégories de page que vous avez définies.

    Dans cet exemple, les diapositives 2 à 4 affichent les données filtrées par Year, tandis que les diapositives 6 à 13 présentent les données filtrées par CategoryName.

    Avertissement: Les éditions effectuées en mode aperçu ne sont pas enregistrées.
  12. Si vous souhaitez poursuivre l'édition, fermez la fenêtre d'aperçu et mettez en forme le rapport dans l'éditeur de modèle.
  13. Lorsque vous avez terminé, cliquez sur Enregistrer et fermer.

Le modèle de rapport est désormais enregistré et prêt à être partagé avec les utilisateurs.

Publication sur NewsStand et par e-mail

Pour que les utilisateurs puissent y accéder, les rapports doivent être publiés. Voyons comment publier sur NewsStand et par e-mail.

NewsStand est un portail Web qui permet aux utilisateurs de prévisualiser et de télécharger des rapports, et de s'abonner à des mises à jour automatiques. Voir : Vue d'ensemble de NewsStand

Les e-mails contiennent vos rapports en pièce jointe. Il est possible d'en personnaliser le contenu en ajoutant du texte et des images. Voir : Distribution de rapports par e-mail.

Remarque: Vous devez configurer votre serveur de messagerie SMTP afin qu'il envoie les e-mails à partir de Qlik NPrinting. Voir : Configuration du serveur SMTP.

Procédez comme suit :

  1. Sur la console Web Qlik NPrinting, cliquez sur Tâches dans le menu principal, puis sélectionnez Tâche de publication.
  2. Cliquez sur le bouton Créer une tâche.

    1. Saisissez un nom. Par exemple : Publish Beginner's Tutorial NP PowerPoint.
    2. Sélectionnez votre application dans la liste déroulante : Beginner's Tutorial NP App - QV.
    3. Conservez les valeurs par défaut des autres options. Cliquez sur Créer.
  3. Cliquez sur l'onglet Rapports.
    1. Cliquez sur le bouton Ajouter un rapport.

    2. Sélectionnez Beginner's Tutorial - NP PowerPoint dans la liste déroulante Choisir un rapport.
    3. Sélectionnez PPTX dans la liste déroulante Format de sortie.
    4. Assurez-vous que les cases Joindre à l'e-mail et Activé sont cochées.
    5. Cliquez sur Ajouter un rapport.

  4. Cliquez sur l'onglet Utilisateurs/groupes.
    1. Cliquez sur le bouton Ajouter un utilisateur ou un groupe.
    2. Sélectionnez un utilisateur ou un groupe dans la liste déroulante Choisir un destinataire.

      Si vous souhaitez apprendre à créer des utilisateurs, voir : Création d'utilisateurs.

    3. Sélectionnez les cases à cocher Activé, Destination NewsStand et Destination de l'e-mail.
    4. Cliquez sur Ajouter un destinataire.
  5. Cliquez sur l'onglet Destinations.
    1. Dans la colonne NewsStand, cliquez sur la case à cocher Publier pour tous.
    2. Dans la colonne E-mail, cliquez sur la case à cocher Publier pour tous.
    3. Cliquez sur Enregistrer.
  6. Vous revenez automatiquement à l'onglet Vue d'ensemble.
  7. Cliquez sur le bouton Exécuter maintenant.

    Une fois la tâche terminée, un message de confirmation s'affiche en haut de la page.

Les destinataires peuvent à présent accéder à NewsStand depuis leur navigateur afin de consulter le rapport. Un exemplaire leur est également envoyé par e-mail.

Conseil: Dans les installations standard, vous pouvez passer de Qlik NPrinting Web Console à NewsStand en remplaçant le port 4993 par le port 4994 sur la barre de votre navigateur. Par exemple, si votre console Web est située sur https://YourServerName:4993, alors NewsStand correspond à https://YourServerName:4994.