Mapa de calor

Un gráfico de mapa de calor (Mapa de calor) muestra datos comparativos donde los valores se representan como patrones de color en un gráfico. Crear un mapa de calor ayuda a transmitir información de manera instantánea, al combinar elementos de varias fuentes en una. Va incluido en el paquete Visualization bundle.

Un mapa de calor puede mostrar grandes cantidades de datos en su totalidad porque los valores se reemplazan por colores. Este formato de código de color condensado proporciona una visión general de los datos fácil de entender.

Los mapas de calor requieren dos dimensiones y una medida. Una segunda medida es opcional. El gráfico se muestra en un formato tabular con mosaicos codificados por colores. Los valores más altos y más bajos se muestran en cada columna de dimensión. Los valores intermedios se muestran en un degradado de color, centrado en torno al promedio.

Cuándo se utiliza

Un gráfico de mapa de calor muestra un resumen visual de grandes cantidades de datos comparativos. La información se presenta en patrones de color y se comunica casi instantáneamente en un solo gráfico. Un mapa de calor también es útil cuando deseamos:

  • Comparar el rendimiento de empresas, mercados o inversiones.
  • Identificar el nivel de desempeño entre los departamentos de una empresa.
  • Ver las prioridades de inversión y destacar áreas de preocupación.
  • Presentar grandes datos estadísticos y conjuntos de datos.
  • Medir la interacción del usuario con sitios web.
  • Medir y clasificar lugares, personas, actuaciones o trabajos.

Crear un gráfico de mapa de calor

Puede crear un gráfico de mapa de calor en la hoja que está editando.

Haga lo siguiente:

  1. Desde el panel de activos, en Objetos personalizados > Visualization bundle arrastre un objeto Heatmap chart a la hoja.
  2. Haga clic en el botón superior Añadir dimensión y seleccione la dimensión.
  3. Haga clic en el botón inferior Añadir dimensión y seleccione una segunda variable de dimensión.
  4. Haga clic en el botón Añadir medida para seleccionar la medida del gráfico.

Una vez que se han seleccionado las dimensiones y la medida, se muestra el gráfico de mapa de calor.

Examples:

A heatmap displaying results using colors only.

Un mapa de calor que muestra los resultados utilizando solo colores.

A heatmap with grid layout, data, and labels.

El mismo mapa de calor de antes con un diseño de cuadrícula, datos y etiquetas.

Modificar el aspecto del gráfico

Utilizar la herramienta de selección de contorno

La herramienta de selección de contorno le permite realizar una selección bidimensional de un área específica que desee ver más de cerca, trazando un borde alrededor de ella.

Ese contorno desaparece y puede trazar otro contorno en el área deseada.

Haga lo siguiente:

  1. Abra su mapa de calor en el campo de visualización principal. Si está trabajando en el modo de edición, haga clic en Hecho.
  2. Haga clic con el cursor en una tesela de mosaico y, mientras pulsa y dirige el botón del ratón hacia abajo, trace el contorno del área del gráfico que desee observar de cerca.
  3. Finalice el contorno donde comenzó. El gráfico se ampliará automáticamente y mostrará solo el área delimitada.

Examples:

Heatmap with border traced out with the lasso tool.

Se traza un borde en torno a un área utilizando la herramienta de selección de contorno, de color verde.

Heatmap showing a selection picked using lasso tool.

Una vez que la selección está completa, solo se muestra el área delimitada ampliada en el gráfico.

Usar la opción de selección de dimensión

Puede seleccionar una columna o fila de teselas de mosaico para cada dimensión haciendo clic en la etiqueta de dimensión, o una selección de dos dimensiones haciendo clic en una tesela. Una vez seleccionada, solo la fila, columna o tesela elegidas se mostrarán en el gráfico.

Cambiar el esquema de color

Puede cambiar el esquema de colores de su gráfico seleccionando entre cuatro opciones predefinidas.

Haga lo siguiente:

  1. Haga clic en Aspecto > Diseño en el panel de propiedades.
  2. Seleccione un esquema de color en Esquema de color.

    The different colour gradients that can be used in heatmaps.
Los diferentes gradientes de color que se pueden utilizar en mapas de calor.

Cambiar los colores de las etiquetas

Las etiquetas son elementos de texto o imagen que se pueden colocar en cualquier lugar, en cualquier gráfico. Puede configurar su propio color de etiqueta en Aspecto> Color de etiqueta en el panel de propiedades. Haga clic en el cuadro de color de la etiqueta y seleccione un color del círculo de color degradado. También puede hacer clic en el símbolo de caballete bajo el círculo de color y seleccionar el color, o bien introducir una cadena de un código de color en el campo junto al símbolo del caballete. Los colores deberán ser colores CSS válidos.

Alternar la leyenda

La leyenda ofrece una fina línea de gradientes de descripción de color en la parte superior del gráfico. Para ocultar la leyenda, mueva el botón deslizante en Aspecto > Diseño> Leyenda en el panel de propiedades hacia la izquierda para desactivar la opción.

Ajustar la opacidad de las teselas de mosaico

Puede ajustar la opacidad de las teselas de mosaico moviendo el botón del control deslizante de opacidad de tesela en Aspecto > Opacidad de tesela en el panel de propiedades. Establecer la opacidad en 1 permite que la configuración muestre los colores con claridad, lo que le da a las teselas una apariencia más individual.

Usar una media en escala

En un mapa de calor puede calcular y mostrar la media del conjunto de datos. Se utiliza como valor medio en una escala de color. Puede activar o desactivar esta función en Aspecto > Opciones> Usar media en escala en el panel de propiedades.

Introduzca un valor de escala por expresión para el valor medio. Esto permite que el sistema elija el rango de color que define una escala de color mediana. También puede insertar una cadena de escala en la expresión en el Editor de expresiones (Expression) en Aspecto > Opciones > Valor de escala de media en el panel de propiedades. Cuando no se utiliza una media, el valor de la escala media debe establecerse en 0.

Establecer una escala fija

Puede establecer valores mínimos, máximos y medios para definir una escala de color fija independiente de un conjunto de datos. Para hacer esto, mueva el botón deslizante Escala fija a la derecha en Aspecto > Opciones> Escala fija en el panel de propiedades. Después introduzca un valor mínimo en Valor de escala mínimo, un valor máximo en Valor de escala máximo y un valor medio en Valor de escala promedio. También puede insertar una cadena de escala en la expresión en el Editor de expresiones (Expression).

Alternar títulos

Esta opción oculta el nombre del gráfico de mapa de calor. Haga clic en Aspecto > General en el panel de propiedades y alterne con el botón Mostrar títulos.

Cambiar tamaños de etiquetas en los ejes del gráfico.

También puede personalizar el tamaño de las etiquetas tanto en el eje Y como en el eje X del gráfico. Haga clic en Aspecto, en el panel de propiedades, e inserte el tamaño de etiqueta que desee en Tamaño de etiqueta del eje Y y enTamaño de etiqueta del eje X.

Limitar los valores de dimensión

Puede limitar sus valores de dimensión Vaya a Datos > Dimensiones en el panel de propiedades. Haga clic en dimensión y en Limitación, elija una limitación en el menú.

Configurar el tamaño horizontal mínimo

En un mapa de calor, introduzca un tamaño mínimo en cuanto a cómo deberá mostrarse el gráfico horizontalmente. Introduzca el tamaño que desee en Aspecto > Opciones > Tamaño horizontal mínimo en el panel de propiedades. También puede insertar una cadena en la expresión en el Editor de expresiones (Expression).

Formato numérico

Es posible dar formato al valor de la medida. Se pueden aplicar diferentes formatos al mismo valor, por ejemplo, dinero, fecha, duración. El gráfico se actualiza para reflejar el tipo de número modificado.

Haga lo siguiente:

  1. Haga clic en Datos > Medidas en el panel de propiedades y haga clic en una medida.
  2.  Seleccione el formato de número adecuado en el menú Formato numérico.
  3. Introduzca los detalles en los campos del panel. Estos aparecen cuando se elige una opción distinta de Automático al configurar el gráfico.

Limitaciones

Para obtener información sobre limitaciones generales, vea Limitaciones de los paquetes de objetos proporcionados por Qlik.