Objeto de Texto

Los objetos de texto se utilizan para añadir información al documento, como etiquetas, etc. Éstas pueden moverse y colocarse en cualquier área de la hoja, incluso en áreas ocupadas por otros objetos de hoja.

Haciendo clic con el botón derecho en un objeto de texto se muestra el cuadro de diálogo Objeto de Texto: Objeto. También se puede acceder desde el menú del Objeto, cuando el objeto de texto está activo.

Menú Objeto

El menú del objeto de texto Objeto se abre haciendo clic con el botón derecho sobre el objeto. Los comandos del menú son los siguientes:

Propiedades... Abre el cuadro de diálogo Propiedades del Objeto de Texto donde se pueden configurar una serie de parámetros.
Notas

Permite crear y compartir notas relativas al objeto actual.

Notas y Comentarios

Ordenar

Este menú en cascada solo está disponible cuando el comando de la Rejilla de Diseño del menú Ver está activado o cuando se ha marcado la opción Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño. Contiene cuatro comandos para fijar la capa de diseño de los objetos de hoja. Los números válidos de capa van desde -128 a 127.

Traer al Frente
Fija la capa de diseño del objeto de hoja en el mayor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Enviar Atrás
Fija la capa de diseño del objeto de hoja en el menor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Adelantar
Incrementa la capa de diseño del objeto de hoja en un valor. El valor máximo es 127.

Atrasar
Reduce la capa de diseño del objeto de hoja en un valor. El valor mínimo es -128.


Imprimir Abre el diálogo Imprimir donde se pueden especificar las configuraciones de impresión.
Imprimir como PDF...

Abre el cuadro de diálogo Imprimir con la impresora PDF-XChange 3.0 preseleccionada. Tras pulsar el botón Imprimir se le pedirá que introduzca un nombre de archivo para el archivo PDF de salida. Este comando solo está disponible si el sistema dispone de una impresora PDF.

Enviar a Excel... Exporta el texto a Microsoft Excel, el cual es lanzado de inmediato, si es que no estaba ya en ejecución. El texto aparecerá en una única celda en una nueva hoja de Excel. Para que esta funcionalidad opere como es debido es necesario tener instalado Microsoft Excel 2007 o posterior en el equipo.
Copiar al Portapapeles Este menú en cascada contiene las diversas opciones disponibles para el objeto de hoja.
Texto
Copia al portapapeles el texto mostrado en el objeto de texto.
Imagen
Copia una imagen del objeto de hoja en el portapapeles. La imagen incluirá o excluirá el título y el borde del objeto de hoja, dependiendo de los parámetros definidos en el diálogo Preferencias de Usuario: Exportar.
Objeto
Copia el objeto de hoja completo en el portapapeles para poder pegarlo posteriormente en cualquier parte del diseño o en otro documento abierto en la misma sesión actual de QlikView.
Objetos enlazados

Abre un menú con los siguientes comandos relativos a los objetos enlazados.
Ajustar Posición de Objetos Enlazados
Todos los objetos enlazados de todas las hojas se ajustan a la misma posición y tamaño que el de el/los objetos resaltados.
Desenlazar Este Objeto/Desenlazar Objetos
Esto elimina el enlace que había entre los objetos, convirtiéndolos en objetos diferentes con diferentes ID de objeto.

Minimizar Convierte el objeto en un icono. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activada la opción minimizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Maximizar Expande el objeto hasta llenar la hoja. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activa la opción maximizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Restaurar Restaura un objeto maximizado o minimizado a su posición y tamaño anteriores. Hacer doble clic en el icono de un objeto minimizado o hacer clic en el título del objeto (si se muestra) de un objeto maximizado ofrece el mismo resultado. Este comando solo está disponible para objetos minimizados o maximizados.
Ayuda Abre la ayuda de QlikView.
Eliminar Elimina el objeto de la hoja.

General

La página Propiedades del Objeto de Texto: General se abre haciendo clic con el botón derecho sobre un objeto de texto y eligiendo la opción Propiedades en el menú contextual, o seleccionando Propiedades en el menú Objeto cuando un objeto de texto está activo. Aquí podrá configurar las diferentes opciones para el texto, su fondo, alineación, etc.

Primer Plano

Aquí podrá definir el primer plano del objeto de texto. El primer plano normalmente es el texto mismo, pero también podría ser una imagen.

Texto
Aquí puede introducir el texto que desee mostrar. El texto puede definirse como una fórmula calculada para su actualización dinámica.

Sintaxis de Expresión para fórmulas calculadas

Representación
El texto del Objeto de Texto puede interpretarse como una referencia a una imagen en la memoria o en el disco. Se presentan dos alternativas. Cuando seleccione Texto los contenidos del objeto de texto se interpretarán y mostrarán siempre como texto. Cuando seleccione Imagen QlikView tratará de interpretar los contenidos del texto como una referencia a una imagen. La referencia puede ser una ruta a un archivo de imagen en el disco (ej. C:\Mypic.jpg) o dentro del documento qvw (por ej. qmem:// <Nombre>/<Pedro>). También puede ser una función info vinculada a un campo que contenga información sobre una imagen (por ej. =info(MiCampo) ). Si QlikView no puede interpretar los contenidos del texto como una referencia válida a una imagen, se visualizará el texto mismo.
Ocultar Texto cuando falta la Imagen
Si se selecciona esta opción y la interpretación como referencia de la imagen falla por alguna razón, QlikView no mostrará texto en el objeto de texto. El objeto de texto en este caso se dejará en blanco.
Barra de Desplazamiento Horizontal
Si esta opción está seleccionada se añadirá una barra de desplazamiento horizontal al objeto de texto a fin de visualizar el contenido del mismo cuando su contenido de texto sea demasiado amplio como para poder visualizarlo dentro del área proporcionada.
Barra de Desplazamiento Vertical
Si esta opción está seleccionada se añadirá una barra de desplazamiento vertical al objeto de texto cuando su contenido de texto sea demasiado largo como para poder visualizarlo dentro del área suministrada.

Diseño En este grupo puede definir la forma en que QlikView habrá de mostrar el texto o imagen de primer plano dentro del área del objeto de texto.
Alineación Horizontal
El texto puede alinearse horizontalmente a la izquierda, centrado o a la derecha, dentro del objeto de texto.
Alineación Vertical
El texto puede alinearse verticalmente hacia arriba, centrado o hacia abajo, dentro del objeto de texto.
Ajuste de Imagen
Este parámetro describe cómo da formato QlikView a una imagen en primer plano para ajustarla al área del objeto de texto. Hay cuatro alternativas

Sin Ajustar
Si se selecciona esta opción, la imagen se mostrará tal cual es, sin realizar ningún tipo de ajustes. Esto puede hacer que no se vean partes de la imagen o que solo se rellene parte del objeto de texto.
Rellenar
Si se selecciona esta opción, la imagen se ajustará de modo que cubra por completo el área del objeto de texto, sin mantener el ratio de aspecto (las proporciones) de la imagen.
Mantener Aspecto
Si se selecciona esta opción, la imagen se ajustará lo más posible para tratar de cubrir el área de texto al tiempo que se mantiene el ratio de aspecto (las proporciones). Esto normalmente da como resultado áreas en blanco, tanto encima como debajo de la imagen, o en ambas zonas a la vez.
Rellenar con Aspecto
Si se selecciona esta opción, la imagen se ajustará para tratar de cubrir el área del objeto de texto en ambas direcciones al tiempo que mantiene el ratio de aspecto (las proporciones). Esto normalmente da como resultado partes de la imagen sesgadas en una dirección.

Margen de Texto
Esta configuración permite crear un margen entre los bordes externos del objeto de texto y el texto mismo. El ancho del margen se puede detallar en mm, cm, pulgadas (", inch), píxeles (px, pxl, pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Fondo En el grupo Fondo puede especificar el fondo del objeto de texto. Un panel de vista previa muestra las configuraciones actuales.
Color
Seleccione este botón de opción si quiere que el texto se muestre con un color de fondo. El color puede definirse como un color sólido o un degradado a través del diálogo Área de Color que se abre al pulsar el botón.
Imagen
Seleccione este botón de opción si desea mostrar una imagen de fondo. Para cambiar la imagen actual, haga clic en el botón Cambiar. Si no se introduce texto en el campo Texto, el objeto de texto se puede usar para mostrar una imagen fija como objeto de hoja en el diseño. Los tipos de archivo de imagen que admite son jpg, png, bmp, gif y gif animado.
Transparencia
Establece el grado de transparencia para el fondo del objeto de texto. En 100% el fondo es completamente transparente. La transparencia se aplicará independientemente de que se esté utilizando una imagen o un color para el fondo.
Ajuste de Imagen
Este parámetro describe cómo da formato QlikView a una imagen de fondo para que se ajuste al área del objeto de texto. Para más detalles sobre las opciones disponibles vea la sección Ajuste de Imagen arriba.
Alineación
El fondo puede alinearse horizontal o verticalmente.
Estado Alterno Seleccione uno de los estados disponibles en el desplegable. Los siguientes Estados Alternos están siempre disponibles.
Heredado
Las hojas y objetos de hoja siempre se encuentran en estado heredado a menos que el desarrollador de QlikView lo modifique. Este parámetro se hereda del objeto del nivel superior, un gráfico de una hoja recibe los mismos parámetros de la hoja si se ha elegido la opción heredado.
Estado predefinido
Es el estado en el que más uso se hace de QlikView y viene representado por el signo $. El documento QlikView se halla siempre por defecto en el estado predefinido.
ID de Objeto

Esta opción se utiliza para macros. A cada objeto de hoja se le asigna un ID único. Le recomendamos utilizar caracteres alfanuméricos solo en la ID. Para los objetos de texto, el ID comienza por TX01. Los objetos enlazados comparten un mismo ID de objeto. Podrá editar este número ID más adelante.

Intérprete Interno de Macros

Configuraciones de Impresión...  Pulsando este botón tendrá acceso al diálogo Configuraciones de Impresión, donde podrá definir formatos de cabeceras/pies de página y márgenes.

Acciones

En la pestaña Acciones puede especificar las acciones que se llevarán a cabo al hacer clic en el objeto. La página es idéntica a la página Acciones del objeto de botón.

See also:

 
  • FuenteEstilo de FuenteTamaño
  • Propiedades de Objeto: FuenteAplicar a ObjetosPropiedades de Documento: Fuente
  • Propiedades de Documento: Fuente
  • Preferencias de Usuario: Fuente
  • ColorFijoCalculado
  • Funciones de color

  • Utilizar Bordes
  • SimplificadoModo de Asignación de EstiloPropiedades de Documento: GeneralIntensidad de SombreadoAncho de Borde
  • Esquinas Redondeadas
  • Esquinas RedondeadasEsquinas RedondeadasAvanzadoModo de Asignación de EstiloPropiedades de Documento: General
  • Capa
  • Capa
  • Plantillas...
  • Creación de Plantillas
  • Aplicar Plantilla…
  • Plantillas de Diseño
  • Mostrar
  • Mostrar
  • Opciones
  • OpcionesPropiedades de Documento: DiseñoPropiedades de Hoja: Seguridad
  • Barras de Desplazamiento
  • Barras de Desplazamiento
  • Objeto
    Propiedades del Documento
  • Título
  • Colores ActivosColores Inactivos
  • Color de FondoColor de TextoÁrea de ColorColor de FondosólidodegradadoÁrea de colorColor de TextoFijoCalculado
  • Funciones de color
  • NormalMinimizado
  • Alineación de Título:
  • Iconos especiales

Fuente

  1. La primera fuente predefinida (Cuadros de Lista, Gráficos, etc.) es la que se emplea en la mayoría de los objetos, incluidos los cuadros de lista y los gráficos.
  2. La segunda fuente predefinida (Objetos de Texto / Botones) es la que se utiliza para los botones y cuadros de texto, que son objetos que normalmente necesitan un tipo de letra de mayor tamaño.
Sombreado Si está marcada esta opción, se añadirá un sombreado al texto.
Subrayado Si está marcada esta opción, el texto se subrayará.

Diseño

Intensidad de Sombreado El menú desplegable Intensidad de Sombreado permite establecer la intensidad del sombreado que rodea a los objetos de hoja. También existe la opción de Sin Sombreado.
Estilo de Borde Están disponibles los siguientes tipos de borde predefinidos:
Sólido
Un borde de un solo color.
Hundido
Un borde que da la impresión de hundir el objeto de hoja desde el fondo.
Elevado
Un borde que da la impresión de elevar el objeto de hoja desde el fondo.
Enmarcado
Un borde que de la impresión de un muro alrededor del objeto de hoja.
Ancho de Borde Esta opción está disponible para todos los tipos de borde. El ancho puede especificarse en mm, cm, pulgadas ("), píxeles (px,pxl,pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Color Haga clic en este botón para abrir un cuadro de diálogo que permite elegir un color de base apropiado en la paleta de colores para todos los tipos de borde.
Arcoiris Crea un borde con los colores del arco iris para todos los tipos de borde. El arco iris comenzará con el color básico seleccionado en la parte superior del objeto de hoja.
Esquinas Redondeadas Si marca esta opción, podrá hacer las esquinas redondeadas.
Esquinas Las esquinas que no tengan la opción marcada se dibujarán como rectangulares.
Inclinación Es un número variable entre 2 y 100 donde 100 define un rectángulo con esquinas cuadradas y 2 corresponde a una elipse perfecta (un círculo elipsoide con un ratio de aspecto de 1:1). Una inclinación entre 2 y 5 es óptima para conseguir esquinas redondeadas.
Ángulo de Redondeo Este parámetro determina el radio de las esquinas en distancia fija (Fijo) o como un porcentaje del cuadrante total (Relativo (%)). Este parámetro le permitirá controlar hasta qué punto se verán afectadas las esquinas por la forma general definida en Inclinación. La distancia se puede especificar en mm, cm, pulgadas, ('', pulgada), píxeles (px,pxl,pixel), puntos (pt, pts, punto) o unidades de documento (du, docunit).
Inferior Un objeto de hoja con la propiedad de capa Inferior nunca podrá hacer sombra o tapar a objetos que pertenezcan a las capas Normal y Superior. Solo podrá ubicarse sobre otros objetos de hoja de la misma capa Inferior.
Normal Al crearse, los objetos de hoja residen en la capa Normal (capa intermedia). Un objeto de hoja en la capa Normal nunca podrá ser oscurecido por objetos de hoja de la capa Inferior y nunca podrá tapar a objetos de hoja de la capa Superior.
Superior Un objeto de hoja en la capa Superior no puede ser nunca tapado por objetos de hoja de las capas Normal e Inferior. Sin embargo, es posible ubicar otros objetos de hoja de la capa Superior encima de él.
Personalizado Las capas Superior, Normal e Inferior se corresponden con las capas internamente numeradas 1, 0 y -1 respectivamente. De hecho se aceptan todos los valores entre -128 y 127. Escoja esta opción para introducir un valor de su elección.
Siempre El objeto de hoja siempre se mostrará.
Condicional

El objeto de hoja se mostrará u ocultará dependiendo de una función condicional que será evaluada continuamente dependiendo por ej. de las selecciones efectuadas, etc. El objeto de hoja solo se ocultará cuando la condición devuelva FALSO.

Funciones condicionales

Nota:

Los usuarios con privilegios de administrador sobre el documento pueden omitir todas estas condiciones seleccionando Mostrar todas las hojas y objetos de hoja en la página Propiedades de Documento: Seguridad. Esta funcionalidad se puede cambiar pulsando Ctrl+Mayús+S.

Propiedades de Documento: Seguridad

Permitir Mover/Ajustar Si se ha desmarcado esta opción será imposible mover o ajustar el objeto de hoja.
Permitir Copiar/ Clonar Si se ha desmarcado esta opción será imposible hacer una copia del objeto de hoja.
Permitir Información

Cuando utilice la función info, se mostrará un icono de información en la barra de título del objeto siempre que un valor de campo tenga información asociada al mismo. Si no quiere que aparezca el icono de información en la barra de título, puede deseleccionar esta opción.

Info

Ajustar a Datos Normalmente los bordes en torno a cualquier tipo de objeto de tabla en QlikView se encogen cuando las selecciones obligan a que el tamaño de la tabla sea menor que el espacio asignado para el objeto de hoja. Al desmarcar esta casilla este ajuste automático de tamaño se desactivará, quedando el espacio sobrante en blanco.
Preservar Posición de Desplazamiento

Con esta opción habilitada, QlikView tratará de mantener la posición de desplazamiento de tablas y gráficos que tengan una barra de desplazamiento cuando se efectúe una selección en otro objeto. La opción debe estar habilitada también en Preferencias de Usuario: Objetos.

Las posiciones de desplazamiento no se mantendrán si cierra el documento.

Botones de Desplazamiento Determina el color del botón de desplazamiento. Seleccione un color haciendo clic en el botón. Observe que los tonos intermedios de gris a menudo son los que mejor resultado dan en el caso de las barras de desplazamiento. Se puede definir cualquier color como color sólido o un degradado mediante el diálogo Área de Color, que se abre haciendo clic en el botón correspondiente.
Fondo de Barra de Desplazamiento

Define el color de fondo de la barra de desplazamiento. Seleccione un color haciendo clic en el botón.

Ancho de Barra de desplazamiento Este control afecta tanto al ancho como al tamaño relativo de los símbolos de las barras de desplazamiento.
Estilo de Desplazamiento

Establece el estilo de la barra de desplazamiento. Seleccione un estilo en el control desplegable. El estilo Clásico corresponde a las barras de desplazamiento 4/5 de QlikView. El estilo Estándar confiere un aspecto más moderno. El estilo Ligero corresponde a una barra más fina, más ligera.

El Modo de Asignación de Estilo debe configurarse como Avanzado para que el estilo de la barra de desplazamiento esté visible. Este parámetro se encuentra en la pestaña General, abriendo el menú desplegable Configuración y seleccionando Propiedades de Documento.

Aplicar a... Abre el diálogo Propiedades de Título y Borde, en el que podrá definir dónde aplicar las propiedades que se establecieron en la página Diseño.

Título

Mostrar Título Cuando se selecciona esta opción, se crea un título en la parte superior del objeto de hoja. Los cuadros de lista y otros "objetos de cuadro" tendrán la opción activada por defecto, mientras que los botones, objetos de texto y objetos de línea/flecha no.
Texto de Título En el cuadro de texto puede introducir un título que se mostrará en el título del objeto de hoja. Utilice el botón Fuente... si desea cambiar el tipo de letra del título.
Dividir Texto Si se marca esta opción, el título se mostrará en dos o más filas.
Altura de Título (Líneas) En este cuadro de edición se fija el número de líneas del título.
Coord. X Fija la posición horizontal del lado izquierdo del objeto de hoja, en relación con el borde izquierdo de la hoja.
Coord. Y Fija la posición vertical del lado superior del objeto de hoja, en relación con el borde superior de la hoja.
Ancho Fija el ancho del objeto de hoja QlikView.
Altura Fija la altura del objeto de hoja QlikView.
Horizontal La etiqueta puede alinearse horizontalmente a la: Izquierda, Centrado o a la Derecha dentro del área de título.
Vertical La etiqueta puede alinearse verticalmente de forma: Superior, Centrado o Inferior dentro del área del título.
Nota: Utilice los iconos especiales de título con cuidado. Demasiados iconos pueden confundir al usuario.
Permitir Minimizar Cuando se marca esta opción, se mostrará un icono de minimizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea minimizable. Además, esto hará que el objeto se pueda minimizar haciendo doble clic sobre su título.
Minimizado Automático Esta opción estará disponible cuando Permitir Minimizar esté marcado. Si marca la opción Minimizado Automático para varios objetos de hoja de una misma hoja, se minimizarán automáticamente todos menos uno en cualquier momento. Esto puede resultar útil para, por ejemplo, mostrar de forma alternativa diversos gráficos en una misma área de hoja.
Permitir Maximizar Si marca esta opción se mostrará un icono de maximizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea maximizable. Además, esto hará que el objeto se pueda maximizar haciendo doble clic sobre su título. Si están marcados tanto Permitir Minimizar como Permitir Maximizar a la vez, hacer doble clic dará como resultado un objeto minimizado.
Texto de Ayuda

Aquí podrá introducir un texto de ayuda para mostrarlo en una ventana emergente. El texto de ayuda puede definirse como una fórmula calculada. Esta opción no está disponible a nivel de documento. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Puede introducir, por ejemplo, una descripción del objeto de hoja. Se añadirá un icono de ayuda al título de la ventana del objeto. Cuando el puntero del ratón esté sobre el icono, el texto se mostrará en una ventana emergente.