Cuadro de Tabla

El Cuadro de Tabla es un objeto de hoja que muestra varios campos simultáneamente. El contenido de cada fila está conectado de forma lógica. Las columnas pueden recuperarse desde diferentes tablas internas, dejando al usuario crear tablas libremente desde cualquier combinación posible de campos.

Haciendo clic con el botón derecho en el cuadro de tabla se abre el menú Objeto.

Nota: Si añade grandes cantidades de datos de campos de tablas de datos no vinculadas a un cuadro de tabla, QlikView creará uniones cartesianas para resolver el enlace necesario, lo cual podría dar como resultado un alto gasto de memoria y afectar al rendimiento.

Utilización del Cuadro de Tabla

Ordenar

Es posible ordenar el cuadro de tabla por cualquier columna: simplemente haga clic en el botón derecho en la columna y seleccione Ordenación en el menú contextual. Haga doble clic en el título de la columna Ordenar por. Elegir Ordenar desde el menú contextual o hacer doble clic en el título de la columna invertirá el criterio de ordenación.

Cambiar el Orden de las Columnas

Se puede cambiar el orden de las columnas con el método arrastrar y soltar. Apunte al título de la columna, luego mantenga el botón del ratón pulsado mientras arrastra la columna a su nueva posición. Para deshabilitar esta opción desmarque la casilla de verificación Permitir Arrastrar y Soltar en la página Propiedades del Cuadro de Tabla: Presentación.

Menú Objeto

El menú Objeto del Cuadro de Tabla tiene dos versiones diferentes. Si hace clic en el área de título verá aparecer un menú contextual que contiene comandos aplicables al cuadro en su totalidad; en cambio si el puntero del ratón se sitúa sobre un campo individual, el menú se mostrará más extenso, incluyendo comandos de aplicación exclusiva a ese campo. Los diversos comandos de menú disponibles son los siguientes:

Propiedades... Abre el cuadro de diálogo Propiedades del Cuadro de Tabla donde se pueden configurar una serie de parámetros.
Notas

Permite crear y compartir notas relativas al objeto actual.

Notas y Comentarios

Ajustar Columnas a los Datos Ajusta el ancho de todas las columnas de las tablas al dato más ancho de cada columna. La cabecera se incluye en el cálculo.
Igualar Ancho de Columna Si hace clic en una columna esta opción establece el mismo ancho de dicha columna para toda la tabla.
Ordenar Ordena los registros por el campo en el se que haya hecho clic.
Personalizar Formato de Celdas Abre el diálogo Personalizar Formato de Celdas, el cual le permitirá dar formato a las celdas de la columna y de la línea sobre las que haya hecho clic con el ratón. Este menú en cascada solo está disponible si se ha activado la opción Rejilla de Diseño en el menú Ver.
Ordenar

Este menú en cascada solo está disponible cuando el comando de la Rejilla de Diseño del menú Ver está activado o cuando se ha marcado la opción Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño. Contiene cuatro comandos para fijar la capa de diseño de los objetos de hoja. Los números válidos de capa van desde -128 a 127.

Traer al Frente
Fija la capa de diseño del objeto de hoja en el mayor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Enviar Atrás
Fija la capa de diseño del objeto de hoja en el menor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Adelantar
Incrementa la capa de diseño del objeto de hoja en un valor. El valor máximo es 127.

Atrasar
Reduce la capa de diseño del objeto de hoja en un valor. El valor mínimo es -128.


Cambiar Valor Únicamente disponible para columnas de cuadro de tabla que muestren campos de entrada. Sitúa la celda sobre la que se haya hecho clic en modo de edición de entrada. Equivale a pulsar el icono de entrada en la celda.
Restaurar Valores Únicamente disponible para columnas de cuadro de tabla que muestren campos de entrada. Abre un menú en cascada con tres opciones disponibles.
Restaurar Valor Único
Restaura el valor del valor de campo sobre el que se haya hecho clic, devolviéndolo a su valor predeterminado por defecto desde el script.
Restaurar Valores Posibles
Restaura los valores de todos los valores de campo posibles, devolviéndolos a sus valores predefinidos desde el script.
Restaurar Todos los Valores
Restaura los valores de todos los valores de campo, devolviéndolos a sus valores predefinidos desde el script.
Seleccionar Valores Posibles Se seleccionan todos los valores del campo no excluidos.
Seleccionar Valores Excluidos Se seleccionan todos los valores excluidos del campo.
Seleccionar Todo Se selecciona la totalidad de valores del campo.
Borrar Todas las Selecciones Borra las selecciones de todos los campos mostrados en el cuadro de tabla.
Borrar Borra todas las selecciones actuales en el campo.
Borrar Otros Campos Selecciona todos los valores posibles del campo actual, después borra las selecciones en todos los demás campos.
Bloquear Bloquea el(los) valor(es) seleccionado(s) del campo.
Desbloquear Desbloquea los valores bloqueados del campo.
Imprimir Abre el diálogo Imprimir donde se pueden especificar las configuraciones de impresión.
Imprimir como PDF...

Abre el cuadro de diálogo Imprimir con la impresora PDF-XChange 3.0 preseleccionada. Tras pulsar el botón Imprimir se le pedirá que introduzca un nombre de archivo para el archivo PDF de salida. Este comando solo está disponible si el sistema dispone de una impresora PDF.

Enviar a Excel Exporta los valores posibles (incluyendo los seleccionados) a Microsoft Excel, el cual se abre automáticamente, si es que no está ya en ejecución. Los valores exportados aparecerán en una nueva hoja de Excel. Para que esta funcionalidad opere como es debido es necesario tener instalado Microsoft Excel 2007 o posterior en el equipo.
Exportar...

Exporta el contenido de la tabla a un archivo de su elección. El archivo puede guardarse en cualquiera de los siguientes formatos: Delimitado por coma, Delimitado por punto y coma, Delimitado por tabulador, Hipertexto (HTML), XML y Excel (xls o xlsx). El formato predefinido por defecto es *.qvo (QlikViewOutput), un archivo separado por tabulador.

Las imágenes de un cuadro de tabla no se incluirán al exportar a un formato HTML.

Copiar al Portapapeles

Este menú en cascada contiene las diversas opciones disponibles para el objeto de hoja.
Tabla Completa
Copia la tabla completa al Portapapeles, con su cabecera y estado de selección.
Área de Datos de Tabla
Copia en el portapapeles únicamente los valores de la tabla.
Valor de Celda
Copia en el portapapeles el valor de texto de la celda del cuadro de lista sobre la que se haya hecho clic con el botón derecho del ratón (al invocar el menú Objeto).
Imagen
Copia una imagen del objeto de hoja en el portapapeles. La imagen incluirá o excluirá el título y el borde del objeto de hoja, dependiendo de los parámetros definidos en el diálogo Preferencias de Usuario: Exportar. Las tablas generadas por la parte de script oculto no se representarán por su nombre en el campo de sistema $Table.
Objeto
Copia el objeto de hoja completo en el portapapeles para poder pegarlo posteriormente en cualquier parte del diseño o en otro documento abierto en la misma sesión actual de QlikView.
Objetos enlazados

Abre un menú con los siguientes comandos relativos a los objetos enlazados.
Ajustar Posición de Objetos Enlazados
Todos los objetos enlazados de todas las hojas se ajustan a la misma posición y tamaño que el de el/los objetos resaltados.
Desenlazar Este Objeto/Desenlazar Objetos
Esto elimina el enlace que había entre los objetos, convirtiéndolos en objetos diferentes con diferentes ID de objeto.

Minimizar Convierte el objeto en un icono. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activada la opción minimizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Maximizar Expande el objeto hasta llenar la hoja. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activa la opción maximizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Restaurar Restaura un objeto maximizado o minimizado a su posición y tamaño anteriores. Hacer doble clic en el icono de un objeto minimizado o hacer clic en el título del objeto (si se muestra) de un objeto maximizado ofrece el mismo resultado. Este comando solo está disponible para objetos minimizados o maximizados.
Ayuda Abre la ayuda de QlikView.
Eliminar Elimina el objeto de la hoja.

El diálogo Personalizar Formato de Celdas

Este diálogo le permitirá aplicar formatos personalizados a uno o más grupos de celdas de tabla. Puede invocarse desde los menús objeto de un cuadro de tabla, una tabla simple o una tabla pivotante, siempre y cuando la Rejilla de Diseño esté activa en el menú Ver o cuando esté marcada la casilla de verificación Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño.

El grupo de celdas al que habrá de afectar el formato viene determinado por la selección que se haya hecho con el botón derecho del ratón en la tabla sobre la que se desee invocar el comando. El grupo más pequeño de celdas que se pueden formatear como unidad es un campo (normalmente una columna) de un cuadro de tabla, o una expresión/dimensión de un gráfico de tabla. Si se aplican líneas, cada línea se formateará por separado.

Cuando haga uso de este cuadro de diálogo para personalizar el formato de cualquier parte de una tabla, el Estilo fijado en la página Estilo del cuadro de diálogo Propiedades de la tabla pasará a ser [Personalizado]. Si cambia el parámetro definido en Estilo nuevamente a uno de los estilos predefinidos, el formato personalizado se perderá.

Nota: Observe que todos los estilos de tabla en general serán reemplazados por cualquier formateado que se derive de una expresión de atributo.
Panel de Vista Previa de Tabla Este panel de vista previa le mostrará cambios de formato efectuados en un grupo o varios grupos de celdas de tabla. A diferencia del panel de visualización previa más pequeño que hay a la derecha, Texto de Muestra, muestra los cambios en su contexto y tras la aplicación de pistas visuales y/o formateado de expresiones de atributo.
En este panel podrá moverse libremente por la tabla y aplicar formatos a los diversos grupos de celdas. Haga simplemente clic en una celda para variar el foco de formato.
Deshacer El botón Deshacer sirve para poder deshacer paso a paso los cambios efectuados en el diálogo Personalizar Formato de Celdas.
Tras abandonar el diálogo Personalizar Formato de Celdas todos los cambios efectuados en dicho diálogo podrán deshacerse mediante un simple clic de ratón en el botón Deshacer de la barra de herramientas principal.
Rehacer El botón Rehacer sirve para poder reaplicar paso a paso los cambios previamente deshechos con el botón Deshacer en el diálogo Personalizar Formato de Celdas.
Texto de Muestra Aquí tiene una celda de visualización previa que le permitirá ver el efecto de los parámetros aplicados.
Color de Fondo Define el color de fondo de la celda.
Color de Texto Define el color de texto de la celda.
Borde ante la celda Aquí podrá definir el borde que precederá a la celda. Existe un desplegable en el que podrá definir el estilo de borde y también un botón con el que podrá elegir el color del borde. Tenga en cuenta que los bordes de celda de las diversas celdas se mezclarán entre sí, lo cual puede hacer que el borde real de la tabla presente un aspecto distinto del que se observa en la visualización previa.
Borde tras la celda Aquí podrá definir el borde que sucederá a la celda. Existe un desplegable en el que podrá definir el estilo de borde y también un botón con el que podrá elegir el color del borde. Tenga en cuenta que los bordes de celda de las diversas celdas se mezclarán entre sí, lo cual puede hacer que el borde real de la tabla presente un aspecto distinto del que se observa en la visualización previa.
Configuraciones de Texto En este grupo hallará diversos modificadores de texto que se pueden aplicar a la celda.
Tamaño de Texto
Utilice el desplegable para aplicar una modificación de tamaño a la fuente general empleada en la tabla.
Negrita
Marque esta casilla de verificación si desea el texto resaltado en negrita.
Cursiva
Marque esta casilla de verificación si desea el texto en cursiva.
Subrayado
Marque esta casilla de verificación si desea el texto subrayado.
Sombreado
Marque esta casilla de verificación si desea el texto sombreado.
Aplicar cambio a Los cambios normalmente se aplican únicamente a la expresión, dimensión o campo (cuadros de tabla) sobre el que haya hecho clic con el botón derecho para acceder al cuadro de diálogo. Con la ayuda de este desplegable podrá elegir si aplicar el mismo formato a otras expresiones, dimensiones o campos.

General

La página Propiedades del Cuadro de Tabla: General se abre haciendo clic con el botón derecho sobre un cuadro de tabla y eligiendo la opción Propiedades en el menú contextual, o seleccionando Propiedades en el menú Objeto cuando un cuadro de tabla está activo.

Título

En la ventana Título se puede dar un nombre al objeto contenedor, que se mostrará en el título de ventana.El título puede definirse también como una fórmula calculada para actualización dinámica del texto de la etiqueta. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Campos Disponibles En esta columna se muestran los nombres de los campos origen disponibles. Inicialmente, todos los campos (excluyendo los campos del sistema) aparecen en esta columna. Para incluir los campos de sistema, haga clic en Mostrar Campos de Sistema. Seleccione los elementos que se van a utilizar/eliminar haciendo clic en ellos. Utilice los botones Añadir o Quitar para moverlos a la columna deseada.
Campos Mostrados en el Cuadro de Tabla En esta columna se muestran los nombres de los campos seleccionados de la lista Campos Disponibles que se incluirán en el cuadro de tabla. Inicialmente no hay campos en esta columna.
Cuando se selecciona un campo en esta lista, puede darle una Etiqueta personalizada en la ventana de edición.
Mostrar Campos de Sistema Si marca esta casilla se muestran los campos de sistema en la columna Campos Disponibles.
Mostrar Campos de Tabla Desde aquí, podrá controlar qué campos aparecerán en la lista de Campos Disponibles. La lista desplegable muestra la alternativa Todas las Tablas por defecto. Si desea que la lista muestre campos de una tabla específica, seleccione el nombre de tabla en la lista desplegable.
La alternativa Todas las Tablas (Cualificadas) smuestra los campos por el nombre de la(s) tabla(s) en que aparecen. Esto significa que los campos clave (de conexión) aparecerán en la lista más de una vez. (Esta alternativa sólo se emplea para propósitos de presentación y no tiene nada que ver con los campos Qualify del script de carga.)
Ascender Mueve un campo hacia arriba en el orden de visualización.
Descender Mueve un campo hacia abajo en el orden de visualización.
Ordenar por Volumen Ordena los campos de la columna Campos Mostrados en Cuadro de Tabla en orden numérico.
Orden de Carga Ordena los campos de la columna Campos Mostrados en Cuadro de Tabla por orden de carga, es decir, en el orden en que son leídos desde la base de datos.
Orden Alfabético Ordena los campos de la columna Campos Mostrados en Cuadro de Tabla en orden alfabético.
Estado Alterno Seleccione uno de los estados disponibles en el desplegable. Los siguientes Estados Alternos están siempre disponibles.
Heredado
Las hojas y objetos de hoja siempre se encuentran en estado heredado a menos que el desarrollador de QlikView lo modifique. Este parámetro se hereda del objeto del nivel superior, un gráfico de una hoja recibe los mismos parámetros de la hoja si se ha elegido la opción heredado.
Estado predefinido
Es el estado en el que más uso se hace de QlikView y viene representado por el signo $. El documento QlikView se halla siempre por defecto en el estado predefinido.
ID de Objeto

Esta opción se utiliza para macros. A cada objeto de hoja se le asigna un ID único. Le recomendamos utilizar caracteres alfanuméricos solo en la ID. Para los cuadros de tabla, el ID comienza por TB01. Los objetos enlazados comparten un mismo ID de objeto. Podrá editar este número ID más adelante.

Intérprete Interno de Macros

Condición de Cálculo Especifique una Condición de Cálculo la cual debe ser completa para que se muestre el Cuadro de Tabla. Mientras no se cumpla la condición, se mostrará el mensaje "Condición de Cálculo no completa" en su lugar.
Mensajes de Error

Los mensajes de error estándar en los cuadros de tabla (y gráficos) se pueden personalizar en el diálogo Mensajes de Error Personalizados, el cual se abre pulsando el botón Mensajes de error.

Mensajes de Error Personalizados

Ordenar

La página Propiedades del Cuadro de Tabla: Ordenar se abre haciendo clic con el botón derecho sobre un cuadro de tabla y eligiendo el comando Propiedades desde el menú contextual.

En la lista Prioridad de Ordenación se muestra una lista de los campos del Cuadro de Tabla. El orden de los campos determina el orden aplicado cuando se ejecuta el comando Ordenar. El orden de los campos se puede cambiar usando los botones Ascender y Descender. Para cada campo en la lista, se puede establecer el criterio de ordenación que se va a usar. Los criterios de ordenación están descritos abajo.

Ordenar por:

Expresión Los valores de campo se ordenarán según una expresión arbitraria que se introduzca dentro del cuadro de edición de texto que hay bajo esta opción de ordenación.
Frecuencia Cambia si el procedimiento de ordenación de los valores debe hacerse por frecuencia o no.
Valor Numérico Cambia si el procedimiento de ordenación de los valores debe hacerse por valor numérico o no.
Texto Alterna entre hacer el procedimiento de ordenación de los valores por orden alfabético o no, de acuerdo con el estándar ASCII.
Orden de Carga Cambia si el procedimiento de ordenación de los valores debe hacerse por orden de carga o no.

Si se especifica más de un criterio de ordenación la prioridad será expresión, frecuencia, valor numérico, texto y orden de carga.

Presentación

La página Propiedades del Cuadro de Tabla: Presentación se abre haciendo clic con el botón derecho sobre un cuadro de tabla y eligiendo el comando Propiedades en el menú contextual.

En este diálogo se puede elegir el diseño del cuadro de tabla.

Alineación La alineación por defecto de valores de campo puede establecerse separadamente para Texto y Números seleccionando el campo en la lista de Campos y la opción apropiada en el grupo Alineación. Por defecto, los valores de texto están alineados a la izquierda, y los valores numéricos están alineados a la derecha.
Omitir Filas con valores de Campos Nulos Si está activado, se eliminarán del campo seleccionado las filas donde el valor de campo sea nulo. Se entiende por nulo "sin valor".
Selectores Desplegables Si está marcado, se añade un icono de flecha desplegable al lado izquierdo de la cabecera de columna del campo seleccionado. Haga clic en el icono para acceder a los valores de campo desde una lista de campos desplegable. Esto funciona exactamente como hacer selecciones en un Cuadro de Selección Múltiple.
Avanzado... Este botón abre el cuadro de diálogo Configuraciones de Campo Avanzadas que ofrece parámetros para la representación de valores de campo y opciones especiales de búsqueda de texto.
Configuraciones de Varias Filas En este grupo se pueden configurar las cabeceras de tabla y las celdas de datos para que muestren los valores en varias filas, lo cual es útil para cadenas de texto largas.
Dividir TextoAltura de Cabecera n Líneas
Con esta opción seleccionada, la cabecera mostrará sus contenidos en más de una fila. Aquí se especifican los límites deseados del número de líneas de cabecera.
Dividir TextoAltura de Celdan Líneas
Seleccionando esta opción, la celda mostrará sus contencidos en más de una fila. Aquí se pueden especificar los límites del número de líneas de filas de celda.
Etiquetas Verticales Si está marcado, todas las etiquetas de campo serán rotadas a la posición vertical.
Permitir Arrastrar y Soltar Si está marcada esta opción, se podrán ordenar los campos de Cuadro de Tabla haciendo clic y arrastrando y soltando sus cabeceras.
Indicador de Ordenación Si está marcada esta opción, se añadirá un icono de indicador de ordenación al lado derecho de la cabecera de columna del campo por el cual está ordenado actualmente el cuadro de tabla. El icono alterna para reflejar un orden ascendente o descendente.
Indicadores de Selección Si está marcada esta opción, se añadirá un icono de indicador de ordenación al lado derecho de la cabecera de columna del campo por el cual está ordenado actualmente el cuadro de tabla. El icono alterna para reflejar un orden ascendente o descendente.
Suprimir Fila de Cabecera Si está marcado, la tabla se mostrará sin fila de cabecera (etiqueta).

Estilo

Esta página de estilo se aplica a todo QlikView tablas; cuadros de tabla, tablas pivotantes y tablas simples. Aquí podrá configurar los estilos de formato para la tabla.

Estilo Actual Puede elegir el estilo de tabla más apropiado en el desplegable. Si el valor [Personalizado] aparece en el control desplegable, quiere decir que se habrá aplicado un estilo personalizado a la tabla. Si modifica el parámetro, devolviéndolo a uno de los estilos predefinidos, el formato personalizado se perderá.
Líneas cada _Filas Aquí puede establecer si desea que aparezcan líneas de sombreado o no y con qué intervalo de frecuencia.
Modo Indentado Este parámetro solo está disponible para tablas pivotantes. Si selecciona esta opción, creará un estilo de tabla ligeramente diferente, que será de especial utilidad cuando necesite acomodar varias etiquetas de dimensión en un ancho de tabla limitado.
Utilizar Solo Etiqueta de Primera Dimensión
Este parámetro solo está disponible para tablas pivotantes que ya estén en Modo Indentado y sirve para modificar aún más el estilo de la tabla pivotante.
Bordes Verticales de Celdas de Dimensión Este parámetro determina si se mostrarán bordes de celda verticales en las columnas de la dimensión.
Bordes Verticales de Celdas de Expresión Igual que el anterior, pero para las columnas de la expresión.
Borde Sobre el Espaciado

Si se ha determinado previamente un Espaciado en el diálogo Configuraciones de Campo Avanzadas, el estilo de tabla se puede modificar ligeramente marcando esta alternativa.

Advanced Field Settings

Fondo... Abre el diálogo Configuraciones de Fondo.
Transparencia de Color del Fondo de Celda Si se ha aplicado un color o una imagen en Configuraciones de Fondo, aquí podrá ajustar el grado de transparencia de dicho color o imagen en el fondo de celda.
Transparencia de Bordes de Celda Determina cómo serán de pronunciados los bordes de celda.

Fuente

Aquí se puede establecer la Fuente, el Estilo de Fuente y el Tamaño de la fuente que se empleará.

La fuente se puede configurar para un único objeto cualquiera (en Propiedades de Objeto: Fuente), o para todos los objetos de un documento (Aplicar a Objetos en Propiedades de Documento: Fuente).

Además, las fuentes predefinidas para nuevos objetos se pueden configurar en Propiedades de Documento: Fuente. Hay dos fuentes predefinidas:

  1. La primera fuente predefinida (Cuadros de Lista, Gráficos, etc.) es la que se emplea en la mayoría de los objetos, incluidos los cuadros de lista y los gráficos.
  2. La segunda fuente predefinida (Objetos de Texto / Botones) es la que se utiliza para los botones y cuadros de texto, que son objetos que normalmente necesitan un tipo de letra de mayor tamaño.

Por último, las fuentes predefinidas para nuevos documentos se pueden fijar en Preferencias de Usuario: Fuente.

Para los gráficos, botones y objetos de texto (excepto los objetos de búsqueda) también se puede especificar un Color de fuente. El color puede ser Fijo o Calculado dinámicamente desde una expresión. La expresión deberá ser una representación válida de color, la cual se crea empleando las funciones de color. Si el resultado de la expresión no es una representación válida de color, la fuente de color volverá al negro por defecto.

Funciones de color

Otros parámetros adicionales son:

Sombreado Si está marcada esta opción, se añadirá un sombreado al texto.
Subrayado Si está marcada esta opción, el texto se subrayará.

Un ejemplo de la fuente seleccionada se muestra en el panel de vista previa.

Diseño

Un parámetro de diseño solo se aplicará al objeto actual si se realiza desde la página de Propiedades del Objeto.
Un parámetro de diseño se aplicará a todos los objetos de los tipos especificados en el documento, si se realiza desde la página de Propiedades del Documento.

Utilizar Bordes

Habilite este parámetro si desea utilizar un borde alrededor del objeto de hoja. Especifique el tipo de borde seleccionándolo en el menú desplegable.

Intensidad de Sombreado El menú desplegable Intensidad de Sombreado permite establecer la intensidad del sombreado que rodea a los objetos de hoja. También existe la opción de Sin Sombreado.
Estilo de Borde Están disponibles los siguientes tipos de borde predefinidos:
Sólido
Un borde de un solo color.
Hundido
Un borde que da la impresión de hundir el objeto de hoja desde el fondo.
Elevado
Un borde que da la impresión de elevar el objeto de hoja desde el fondo.
Enmarcado
Un borde que de la impresión de un muro alrededor del objeto de hoja.
Ancho de Borde Esta opción está disponible para todos los tipos de borde. El ancho puede especificarse en mm, cm, pulgadas ("), píxeles (px,pxl,pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Color Haga clic en este botón para abrir un cuadro de diálogo que permite elegir un color de base apropiado en la paleta de colores para todos los tipos de borde.
Arcoiris Crea un borde con los colores del arco iris para todos los tipos de borde. El arco iris comenzará con el color básico seleccionado en la parte superior del objeto de hoja.

Cuando Simplificado es el Modo de Asignación de Estilo elegido en Propiedades de Documento: General, no hay elección posible en cuanto al tipo de borde, solo está el menú desplegable Intensidad de Sombreado y el parámetro Ancho de Borde.

Esquinas Redondeadas

En el grupo Esquinas Redondeadas se puede definir la forma general de un objeto. Estas configuraciones permiten trazar objetos de hoja que van desde círculos perfectos hasta formas elípticas o rectangulares: Esquinas Redondeadas solo está disponible si hemos seleccionado antes Avanzado en Modo de Asignación de Estilo, en Propiedades de Documento: General.

Esquinas Redondeadas Si marca esta opción, podrá hacer las esquinas redondeadas.
Esquinas Las esquinas que no tengan la opción marcada se dibujarán como rectangulares.
Inclinación Es un número variable entre 2 y 100 donde 100 define un rectángulo con esquinas cuadradas y 2 corresponde a una elipse perfecta (un círculo elipsoide con un ratio de aspecto de 1:1). Una inclinación entre 2 y 5 es óptima para conseguir esquinas redondeadas.
Ángulo de Redondeo Este parámetro determina el radio de las esquinas en distancia fija (Fijo) o como un porcentaje del cuadrante total (Relativo (%)). Este parámetro le permitirá controlar hasta qué punto se verán afectadas las esquinas por la forma general definida en Inclinación. La distancia se puede especificar en mm, cm, pulgadas, ('', pulgada), píxeles (px,pxl,pixel), puntos (pt, pts, punto) o unidades de documento (du, docunit).

Capa

En el grupo Capa, un objeto puede definirse como residente en una de estas tres capas:

Inferior Un objeto de hoja con la propiedad de capa Inferior nunca podrá hacer sombra o tapar a objetos que pertenezcan a las capas Normal y Superior. Solo podrá ubicarse sobre otros objetos de hoja de la misma capa Inferior.
Normal Al crearse, los objetos de hoja residen en la capa Normal (capa intermedia). Un objeto de hoja en la capa Normal nunca podrá ser oscurecido por objetos de hoja de la capa Inferior y nunca podrá tapar a objetos de hoja de la capa Superior.
Superior Un objeto de hoja en la capa Superior no puede ser nunca tapado por objetos de hoja de las capas Normal e Inferior. Sin embargo, es posible ubicar otros objetos de hoja de la capa Superior encima de él.
Personalizado Las capas Superior, Normal e Inferior se corresponden con las capas internamente numeradas 1, 0 y -1 respectivamente. De hecho se aceptan todos los valores entre -128 y 127. Escoja esta opción para introducir un valor de su elección.

Plantillas...

Abre el asistente de Creación de Plantillas con el que podrá crear una plantilla de diseño.

Aplicar Plantilla…

Puede aplicar una plantilla de diseño al objeto, la hoja o el documento.

Plantillas de Diseño

Mostrar

En el grupo Mostrar se puede especificar una condición bajo la que se mostrará el objeto de hoja:

Siempre El objeto de hoja siempre se mostrará.
Condicional

El objeto de hoja se mostrará u ocultará dependiendo de una función condicional que será evaluada continuamente dependiendo por ej. de las selecciones efectuadas, etc. El objeto de hoja solo se ocultará cuando la condición devuelva FALSO.

Funciones condicionales

Nota:

Los usuarios con privilegios de administrador sobre el documento pueden omitir todas estas condiciones seleccionando Mostrar todas las hojas y objetos de hoja en la página Propiedades de Documento: Seguridad. Esta funcionalidad se puede cambiar pulsando Ctrl+Mayús+S.

Propiedades de Documento: Seguridad

Opciones

En el grupo Opciones se puede desactivar la posibilidad de mover y redimensionar el objeto de hoja. Las configuraciones de este grupo solo son relevantes si están habilitadas las correspondientes casillas de verificación en Propiedades de Documento: Diseño y Propiedades de Hoja: Seguridad.

Permitir Mover/Ajustar Si se ha desmarcado esta opción será imposible mover o ajustar el objeto de hoja.
Permitir Copiar/ Clonar Si se ha desmarcado esta opción será imposible hacer una copia del objeto de hoja.
Permitir Información

Cuando utilice la función info, se mostrará un icono de información en la barra de título del objeto siempre que un valor de campo tenga información asociada al mismo. Si no quiere que aparezca el icono de información en la barra de título, puede deseleccionar esta opción.

Info

Ajustar a Datos Normalmente los bordes en torno a cualquier tipo de objeto de tabla en QlikView se encogen cuando las selecciones obligan a que el tamaño de la tabla sea menor que el espacio asignado para el objeto de hoja. Al desmarcar esta casilla este ajuste automático de tamaño se desactivará, quedando el espacio sobrante en blanco.

Barras de Desplazamiento

En el grupo Barras de Desplazamiento hallará diversos controles para cambiar el formato de las barras de desplazamiento:

Preservar Posición de Desplazamiento

Con esta opción habilitada, QlikView tratará de mantener la posición de desplazamiento de tablas y gráficos que tengan una barra de desplazamiento cuando se efectúe una selección en otro objeto. La opción debe estar habilitada también en Preferencias de Usuario: Objetos.

Las posiciones de desplazamiento no se mantendrán si cierra el documento.

Botones de Desplazamiento Determina el color del botón de desplazamiento. Seleccione un color haciendo clic en el botón. Observe que los tonos intermedios de gris a menudo son los que mejor resultado dan en el caso de las barras de desplazamiento. Se puede definir cualquier color como color sólido o un degradado mediante el diálogo Área de Color, que se abre haciendo clic en el botón correspondiente.
Fondo de Barra de Desplazamiento

Define el color de fondo de la barra de desplazamiento. Seleccione un color haciendo clic en el botón.

Ancho de Barra de desplazamiento Este control afecta tanto al ancho como al tamaño relativo de los símbolos de las barras de desplazamiento.
Estilo de Desplazamiento

Establece el estilo de la barra de desplazamiento. Seleccione un estilo en el control desplegable. El estilo Clásico corresponde a las barras de desplazamiento 4/5 de QlikView. El estilo Estándar confiere un aspecto más moderno. El estilo Ligero corresponde a una barra más fina, más ligera.

El Modo de Asignación de Estilo debe configurarse como Avanzado para que el estilo de la barra de desplazamiento esté visible. Este parámetro se encuentra en la pestaña General, abriendo el menú desplegable Configuración y seleccionando Propiedades de Documento.

Aplicar a... Abre el diálogo Propiedades de Título y Borde, en el que podrá definir dónde aplicar las propiedades que se establecieron en la página Diseño.

Título

Una configuración de Título solo se aplicará al objeto actual si se realiza desde la página de propiedades del Objeto.
Una configuración de Título se aplicará a todos los objetos del(os) tipo(s) especificado(s) en el documento, si ésta se realiza desde la página de Propiedades del Documento.

En la página Título podrá especificar opciones de diseño que son completamente diferentes a las del diseño general del objeto.

Mostrar Título Cuando se selecciona esta opción, se crea un título en la parte superior del objeto de hoja. Los cuadros de lista y otros "objetos de cuadro" tendrán la opción activada por defecto, mientras que los botones, objetos de texto y objetos de línea/flecha no.
Texto de Título En el cuadro de texto puede introducir un título que se mostrará en el título del objeto de hoja. Utilice el botón Fuente... si desea cambiar el tipo de letra del título.

Puede establecer los colores del título en sus diversos estados. Las configuraciones de Colores Activos y Colores Inactivos se pueden activar indistintamente unas de otras.

Pulse el botón Color de Fondo o Color de Texto para abrir el diálogo Área de Color. El Color de Fondo puede definirse como un color sólido o degradado en el diálogo Área de color. Se puede definir el Color de Texto como Fijo o Calculado utilizando las funciones de color.

Funciones de color

Dividir Texto Si se marca esta opción, el título se mostrará en dos o más filas.
Altura de Título (Líneas) En este cuadro de edición se fija el número de líneas del título.

El tamaño y la posición exactos del objeto QlikView pueden determinarse y ajustarse mediante los parámetros de Tamaño/Posición para el objeto de hoja QlikView Normal o Minimizado. Éstos parámetros se miden en píxeles:

Coord. X Fija la posición horizontal del lado izquierdo del objeto de hoja, en relación con el borde izquierdo de la hoja.
Coord. Y Fija la posición vertical del lado superior del objeto de hoja, en relación con el borde superior de la hoja.
Ancho Fija el ancho del objeto de hoja QlikView.
Altura Fija la altura del objeto de hoja QlikView.

La orientación de la etiqueta de título puede modificarse mediante las opciones de Alineación de Título:

Horizontal La etiqueta puede alinearse horizontalmente a la: Izquierda, Centrado o a la Derecha dentro del área de título.
Vertical La etiqueta puede alinearse verticalmente de forma: Superior, Centrado o Inferior dentro del área del título.

Iconos especiales
Muchos de los comandos de menú de los objetos de hoja pueden configurarse como iconos de título. Seleccione los comandos que se mostrarán como iconos de título marcando la casilla de verificación que aparece a la izquierda de cada comando en la lista.

Nota: Utilice los iconos especiales de título con cuidado. Demasiados iconos pueden confundir al usuario.
Permitir Minimizar Cuando se marca esta opción, se mostrará un icono de minimizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea minimizable. Además, esto hará que el objeto se pueda minimizar haciendo doble clic sobre su título.
Minimizado Automático Esta opción estará disponible cuando Permitir Minimizar esté marcado. Si marca la opción Minimizado Automático para varios objetos de hoja de una misma hoja, se minimizarán automáticamente todos menos uno en cualquier momento. Esto puede resultar útil para, por ejemplo, mostrar de forma alternativa diversos gráficos en una misma área de hoja.
Permitir Maximizar Si marca esta opción se mostrará un icono de maximizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea maximizable. Además, esto hará que el objeto se pueda maximizar haciendo doble clic sobre su título. Si están marcados tanto Permitir Minimizar como Permitir Maximizar a la vez, hacer doble clic dará como resultado un objeto minimizado.
Texto de Ayuda

Aquí podrá introducir un texto de ayuda para mostrarlo en una ventana emergente. El texto de ayuda puede definirse como una fórmula calculada. Esta opción no está disponible a nivel de documento. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Puede introducir, por ejemplo, una descripción del objeto de hoja. Se añadirá un icono de ayuda al título de la ventana del objeto. Cuando el puntero del ratón esté sobre el icono, el texto se mostrará en una ventana emergente.