Cuadro de Selección Múltiple

Debido a su característica exclusiva de ordenar los campos visualizados por aplicabilidad, el cuadro de selección múltiple ofrece la solución definitiva al problema de visualizar un gran número de cuadros de lista en una misma hoja. A esta opción Ordenar por Aplicabilidad se accede desde la página Propiedades del Cuadro Múltiple: General.

Haciendo clic con el botón derecho sobre el cuadro de entrada se abre el menú Objeto.

Menú Objeto

El menú Objeto del Cuadro de Selección Múltiple tiene tres versiones diferentes. Si hace clic sobre el área de título, el menú contextual contendrá comandos que son aplicables al cuadro en su totalidad, mientras que si el puntero del ratón se halla sobre un campo individual, el menú se mostrará más extenso, incluyendo comandos de aplicación exclusiva a dicho campo. Por último, si abre primeramente un archivo, el menú flotante mostrará otro diseño diferente. Los diversos comandos de menú disponibles son los siguientes:

Propiedades... Abre el cuadro de diálogo Propiedades del Cuadro de Selección Múltiple donde se pueden configurar una serie de parámetros.
Notas

Permite crear y compartir notas relativas al objeto actual.

Notas y Comentarios

Ordenar

Este menú en cascada solo está disponible cuando el comando de la Rejilla de Diseño del menú Ver está activado o cuando se ha marcado la opción Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño. Contiene cuatro comandos para fijar la capa de diseño de los objetos de hoja. Los números válidos de capa van desde -128 a 127.

Traer al Frente
Fija la capa de diseño del objeto de hoja en el mayor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Enviar Atrás
Fija la capa de diseño del objeto de hoja en el menor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Adelantar
Incrementa la capa de diseño del objeto de hoja en un valor. El valor máximo es 127.

Atrasar
Reduce la capa de diseño del objeto de hoja en un valor. El valor mínimo es -128.


Buscar

Abre el cuadro de búsqueda.

Buscar

Búsqueda Difusa

Abre el cuadro de búsqueda en modo de búsqueda difusa.

Búsqueda Difusa

Búsqueda Avanzada

Abre el diálogo de búsqueda avanzada. Este diálogo permite introducir expresiones de búsqueda avanzada. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+Mayús+F.

Búsqueda Avanzada (diálogo)

Seleccionar Valores Posibles Se seleccionan todos los valores del campo no excluidos.
Seleccionar Valores Excluidos Se seleccionan todos los valores excluidos del campo.
Seleccionar Todo Se selecciona la totalidad de valores del campo.
Borrar Todas las Selecciones Borra todas las selecciones actuales en el cuadro múltiple.
Borrar Borra todas las selecciones actuales en el campo.
Borrar Otros Campos Borra las selecciones de todos los demás objetos de hoja, incluyendo las selecciones efectuadas en otros campos del actual Cuadro de Selección Múltiple, mientras que se mantienen las selecciones en este campo específico del actual cuadro de Selección Múltiple.
Bloquear Bloquea el(los) valor(es) seleccionado(s) del campo.
Bloquear Todas las Selecciones Bloquea el(los) valor(es) seleccionado(s) del Cuadro de Selección Múltiple.
Desbloquear Desbloquea los valores bloqueados del campo.
Desbloquear Todas las Selecciones Desbloquea los valores bloqueados del cuadro múltiple.
Imprimir

Abre el diálogo Imprimir donde se pueden especificar las configuraciones de impresión. Esta operación solo tiene sentido cuando se muestra un único valor en cada campo (bien porque es el único valor seleccionado, o porque es el único valor asociado).

Imprimir: General

Imprimir como PDF...

Abre el cuadro de diálogo Imprimir con la impresora PDF-XChange 3.0 preseleccionada. Tras pulsar el botón Imprimir se le pedirá que introduzca un nombre de archivo para el archivo PDF de salida. Este comando solo está disponible si el sistema dispone de una impresora PDF.

Enviar a Excel Exporta los valores posibles (incluyendo los seleccionados) a Microsoft Excel, el cual se abre automáticamente, si es que no está ya en ejecución. Los valores exportados aparecerán en una nueva hoja de Excel. Para que esta funcionalidad opere como es debido es necesario tener instalado Microsoft Excel 2007 o posterior en el equipo. Esta operación solo tiene sentido cuando se muestra un único valor en cada campo (bien porque es el único valor seleccionado, o porque es el único valor asociado).
Exportar...

Abre un cuadro de diálogo en el que podrá exportar el cuadro múltiple como una tabla a un archivo de su elección. El archivo puede guardarse en cualquiera de los siguientes formatos: Delimitado por coma, Delimitado por punto y coma, Delimitado por tabulador, Hipertexto (HTML), XML y Excel (xls o xlsx). El formato predefinido por defecto es *.qvo (QlikViewOutput), un archivo separado por tabulador.

Copiar al Portapapeles Este menú en cascada contiene las diversas opciones disponibles para el objeto de hoja.
Datos
Copia las filas de datos del cuadro múltiple en el portapapeles.
Valor de Celda
Copia en el portapapeles el valor de texto de la celda del cuadro de selección múltiple sobre la que se haya hecho clic con el botón derecho del ratón (al invocar el menú Objeto).
Imagen
Copia una imagen del objeto de hoja en el portapapeles. La imagen incluirá o excluirá el título y el borde del objeto de hoja, dependiendo de los parámetros definidos en el diálogo Preferencias de Usuario, página Exportar.
Objeto
Copia el objeto de hoja completo en el portapapeles para poder pegarlo posteriormente en cualquier parte del diseño o en otro documento abierto en la misma sesión actual de QlikView.
Objetos enlazados

Abre un menú con los siguientes comandos relativos a los objetos enlazados.
Ajustar Posición de Objetos Enlazados
Todos los objetos enlazados de todas las hojas se ajustan a la misma posición y tamaño que el de el/los objetos resaltados.
Desenlazar Este Objeto/Desenlazar Objetos
Esto elimina el enlace que había entre los objetos, convirtiéndolos en objetos diferentes con diferentes ID de objeto.

Minimizar Convierte el objeto en un icono. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activada la opción minimizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Maximizar Expande el objeto hasta llenar la hoja. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activa la opción maximizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Restaurar Restaura un objeto maximizado o minimizado a su posición y tamaño anteriores. Hacer doble clic en el icono de un objeto minimizado o hacer clic en el título del objeto (si se muestra) de un objeto maximizado ofrece el mismo resultado. Este comando solo está disponible para objetos minimizados o maximizados.
Ayuda Abre la ayuda de QlikView.
Eliminar Elimina el objeto de la hoja.

General

Título

En la ventana Título se puede dar un nombre al cuadro múltiple, el cual se mostrará en el título de ventana.El título puede definirse también como una fórmula calculada para actualización dinámica del texto de la etiqueta. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Estado Alterno Seleccione uno de los estados disponibles en el desplegable. Los siguientes Estados Alternos están siempre disponibles.
Heredado
Las hojas y objetos de hoja siempre se encuentran en estado heredado a menos que el desarrollador de QlikView lo modifique. Este parámetro se hereda del objeto del nivel superior, un gráfico de una hoja recibe los mismos parámetros de la hoja si se ha elegido la opción heredado.
Estado predefinido
Es el estado en el que más uso se hace de QlikView y viene representado por el signo $. El documento QlikView se halla siempre por defecto en el estado predefinido.

Campos Disponibles

En esta columna se muestran los nombres de los campos origen disponibles. Inicialmente, todos los campos (excluyendo los campos del sistema) aparecen en esta columna. Para incluir los campos de sistema, haga clic en Mostrar Campos de Sistema.

Campos de sistema

Los campos clave se indicarán mediante un símbolo de llave. Seleccione los elementos que se van a utilizar/eliminar haciendo clic en ellos. Utilice los botones Añadir o Quitar para moverlos a la columna deseada.

Campos Mostrados en el Cuadro de Selección Múltiple En esta columna se muestran los nombres de los campos seleccionados de la lista Campos Disponibles que se incluirán en el cuadro de tabla. Inicialmente no se visualizan campos en esta columna.
Cuando se selecciona un campo en esta lista, puede darle una Etiqueta personalizada en la ventana de edición.
Mostrar Campos de Tabla Desde aquí, podrá controlar qué campos aparecerán en la lista de Campos Disponibles. La lista desplegable muestra la alternativa Todas las Tablas por defecto.
La alternativa Todas las Tablas (Cualificadas) smuestra los campos por el nombre de la(s) tabla(s) en que aparecen. Esto significa que los campos clave (de conexión) aparecerán en la lista más de una vez. (Esta alternativa solo se emplea para propósitos de presentación y no tiene nada que ver con los campos Qualify del script de carga.)
También es posible ver los campos de una tabla de una vez.
Expresión Abre el diálogo Editar Expresión en el que se puede crear una expresión que pueda emplearse luego como campo mostrado en el cuadro de selección múltiple.
Editar... Abre el diálogo Editar Expresión para el campo elegido en la columna Campos Mostrados en Cuadro de Selección Múltiple.
Ascender Mueve un campo hacia arriba en el orden de visualización.
Descender Mueve un campo hacia abajo en el orden de visualización.
Ordenar por Volumen Ordena los campos de la columna Campos Mostrados en Cuadro de Selección Múltiple en orden numérico.
Orden de Carga Ordena los campos de la columna Campos Mostrados en Cuadro de Selección Múltiple por orden de carga, es decir, en el orden en que son leídos desde la base de datos.
Orden Alfabético Ordena los campos de la columna Campos Mostrados en Cuadro de Selección Múltiple en orden alfabético.
Ordenar por Aplicabilidad Cuando está marcada esta opción, la ordenación de los Campos Mostrados en Cuadro de Selección Múltiple será actualizada dinámicamente durante las selecciones, de tal manera que los valores de campo no excluidos se moverán hacia arriba en la lista, mientras los valores posibles se moverán hacia abajo. Esta opción hará posible en muchos casos usar literalmente cientos de campos en un único cuadro de selección múltiple.
ID de Objeto

Esta opción se utiliza para macros. A cada objeto de hoja se le asigna un ID único. Le recomendamos utilizar caracteres alfanuméricos solo en la ID. Para los cuadros de selección múltiple, el ID comienza por MB01. Los objetos enlazados comparten un mismo ID de objeto. Podrá editar este número ID más adelante.

Intérprete Interno de Macros

Ordenar

La pestaña Ordenar se abre haciendo clic con el botón derecho sobre un objeto de hoja (Cuadro de Lista, Cuadro de selección múltiple, Cuadro de Tabla, Gráfico u Objeto Calendario/Deslizador) y eligiendo el comando Propiedades en el menú contextual (u Objeto, Propiedades en la barra de menú principal). Aquí podrá configurar el criterio de ordenación de los valores en el objeto de hoja. Algunas opciones pueden no estar disponibles para ciertos objetos de hoja.

Ordenar por:

Estado Ordena los valores de campo según su estado lógico (seleccionado, opcional, o excluido).
El parámetro Auto Ascendente ordena el cuadro de lista (o, en un cuadro múltiple, el listado desplegable que contiene los valores de campo) conforme a su Estado solo si el cuadro de lista contiene una barra de desplazamiento vertical. No obstante, si amplía el cuadro de lista para que pase a mostrar todos los valores, el criterio de ordenación de Estado se desactiva por completo.
Expresión

Ordena los valores de campo de acuerdo con la expresión introducida en el cuadro de texto. Si utilizando ordenación como expresión, Se puede definir un conjunto alternativo de registros mediante una expresión de conjunto. Observe que ordenar por expresión sólo funciona con campos numéricos y no con campos de texto.

Análisis de conjuntos y expresiones de conjuntos

Frecuencia Ordena los valores de campo por la frecuencia (la cantidad de veces que aparecen en la tabla).
Valor Numérico Ordena los valores de campo por sus valores numéricos.
Texto Ordena los valores de campo por orden alfabético.
Orden de Carga Ordena los valores de campo por su orden de carga inicial.

El botón Predeterminado establece el criterio de ordenación por defecto.

El orden de prioridad es Estado, Expresión, Frecuencia, Valor numérico, Texto, Orden load. Se puede ordenar cada uno de estos criterios de ordenación de forma Ascendente o Descendente.

Presentación

La página Propiedades del Cuadro de Selección Múltiple: Presentación se abre haciendo clic con el botón derecho sobre un Cuadro de Selección Múltiple y eligiendo el comando Propiedades en el menú Objeto. Aquí se puede ajustar el diseño de las celdas del Cuadro de Selección Múltiple. Los ajustes se realizan de forma independiente para los diferentes campos del Cuadro de Selección Múltiple. También es posible ajustar el diseño para el - Cuadro de Selección Múltiple Cerrado-.

Alineación Aquí se establece la alineación de los valores de campo. La alineación del Texto y de los Números se establece por separado.
Configuraciones de Varias Filas En este grupo se pueden configurar las celdas del cuadro de selección múltiple para que muestren los valores en múltiples filas, lo cual es útil en el caso de largas cadenas de texto.
Dividir Texto
Seleccionando esta opción, la celda mostrará sus contencidos en más de una fila.
Altura de CeldasnLíneas
Aquí se especifica el límite del número de líneas de celda que desee.
Frecuencia Mostrar
Alterna el estado para ver si se mostrará o no la frecuencia del valor de campo seleccionado. Por frecuencia se entiende el número de combinaciones seleccionables en las que aparece el valor.
En Porcentaje
Establece si la frecuencia del campo seleccionado debe ser mostrada en números absolutos o como porcentaje del número total de entradas.
Avanzado Este botón abre el cuadro de diálogo Configuraciones de Campo Avanzadas que ofrece parámetros para la representación de valores de campo y opciones especiales de búsqueda de texto.
Sólo una Columna Con esta opción marcada, los valores del Cuadro de Selección Múltiple se presentarán en una sola columna.
Suprimir Barra de Desplazamiento Horizontal Marque esta opción para suprimir la barra de desplazamiento horizontal que se muestra normalmente cuando los valores de campo son demasiado anchos para la anchura especificada del cuadro de selección múltiple. En su lugar, los valores de campo se truncarán según sea necesario.
Ordenar por Columna En los campos del Cuadro de Selección Múltiple que tengan más de una columna, los valores se mostrarán ordenados por filas según el criterio especificado. La opción Ordenar por columna cambia la ordenación por columnas.
Bordes de Celda Los valores de campo irán separados por líneas horizontales, simulando las filas de una tabla. Bordes de Celda se activa automáticamente cuando la opción Dividir Texto está marcada, pero puede ser desactivada posteriormente.
Ocultar Excluidos Establece si los valores excluidos deberán mostrarse o no. Los valores excluidos se vuelven no seleccionados.
Sólo Lectura Marcar esta casilla evita que se realicen selecciones directamente en el cuadro de Selección Múltiple, haciéndolo únicamente herramienta para mostrar.
Ignorar Nulos Los valores NULL (Nulos) no se considerarán para mostrar los valores posibles de un determinado campo.
Nota: El uso incorrecto de esta opción puede afectar a la visualización de datos no correlacionados en el cuadro de selección múltiple.
Ignorar Campo Bloqueado Esta casilla de verificación permite realizar selecciones en un campo en concreto del cuadro de selección múltiple incluso si ese campo está bloqueado. El campo permanecerá bloqueado para selecciones realizadas en cualquier parte del documento.
Estilo de Rejilla Esta casilla de verificación cambia el diseño del Cuadro de Selección Múltiple, de tal forma que cada etiqueta se posiciona por encima del campo correspondiente.
Sólo Lectura Marcar esta casilla evita que se realicen selecciones directamente en este campo en particular del cuadro de Selección Múltiple, haciéndolo únicamente herramienta para mostrar.
Color Cerrado Establece el color de las celdas de columnas de datos de un cuadro de selección múltiple cerrado. Se puede definir un color como color sólido o como un degradado desde el diálogo Área de Color que se abre al pulsar el botón.
Limitar Lista desplegable a n Líneas Limita la longitud de los cuadros de lista desplegable abiertos en el Cuadro de Selección Múltiple. Introduzca en el cuadro de texto el número máximo de valores que se mostrarán.
Estilo Elija entre los estilos Bordes o Ligero.
Fondo... Abre el diálogo Configuraciones de Fondo.

Configuraciones de Campo Avanzadas

Al diálogo Configuraciones de Campo Avanzadas se puede acceder desde las páginas de diálogo Propiedades del Cuadro de Selección Múltiple: Presentación, Propiedades del Cuadro de Tabla: Presentación y Propiedades de Gráfico: Dimensiones. Las opciones de imagen descritas a continuación no están disponibles para los gráficos de mapa de bits.

Opciones de Imagen

Representación Están disponibles las siguientes alternativas:
Texto
Si está marcada esta opción, los valores de la expresión se interpretarán y mostrarán siempre como texto.
Imagen
Al seleccionar esta opción QlikView tratará de interpretar cada valor de la expresión como una referencia a una imagen. La referencia puede ser una ruta a un archivo de imagen en el disco (ej. C:\Mypic.jpg) o dentro del documento qvw (por ej. qmem://Nombre/Pedro). Si QlikView no puede interpretar el valor de una expresión como una referencia válida a una imagen, se mostrará el valor mismo.
Info como imagen
Si se selecciona esta opción, QlikView mostrará información de la imagen, vinculada con el valor de campo, mediante sentencias info load/select en el script. Si no hay disponible información de imagen alguna para un valor de campo, se mostrará el valor mismo, a menos que esté marcada la opción Ocultar Texto Cuando Falta Imagen. Se trata de una opción no disponible para los gráficos en modo de mapa de bits.
Formato de Imagen Sólo está disponible cuando se han seleccionado las opciones de imagen arriba. Esta configuración describe cómo QlikView formatea la imagen para ajustarla a la celda. Hay cuatro alternativas
Sin Ajustar
Si se selecciona esta opción, la imagen se mostrará tal cual es, sin realizar ningún tipo de ajustes. Esto puede hacer que algunas partes de la imagen queden invisibles o que sólo aparezca rellena una parte de la celda.
Rellenar
Si se selecciona esta opción, la imagen se ajustará hasta llenar la celda, sin tener en cuenta el ratio de aspecto (la proporción) de la imagen.
Mantener Aspecto
Si se selecciona esta opción, la imagen se ajustará lo más posible para llenar la celda al tiempo que mantiene el ratio de aspecto (la proporción). Esto normalmente da como resultado áreas en blanco, tanto encima como debajo de la imagen, o en ambas zonas a la vez.
Rellenar con Aspecto
Si se selecciona esta opción, la imagen se ajustará hasta llenar la celda en ambas direcciones al tiempo que mantiene el ratio de aspecto (la proporción de la imagen). Esto normalmente da como resultado partes de la imagen sesgadas en una dirección.
Ocultar Texto cuando falta la Imagen Si se selecciona esta opción y la interpretación como referencia de imagen falla por alguna razón, QlikView no mostrará el texto del valor de campo. La celda entonces se dejará en blanco.
Ignorar Estilo de Selección Cuando se muestren imágenes en lugar de texto puede que sea necesario emplear otro estilo de selección diferente al que trae el documento por defecto, para que el estado lógico de los valores de campo permanezca visible. Utilice la lista desplegable de Sobreescribir Estilo de Selección para seleccionar un estilo de selección adecuado, por ej. Indicador de Esquina.

Opciones de Búsqueda

Este grupo le permite controlar ciertos aspectos de la búsqueda de texto aplicable a Cuadros de Selección Múltiple abiertos y a selectores desplegables en tablas.

Incluir Valores Excluidos en la Búsqueda Este parámetro especifica si los valores excluidos deberían ser incluidos en las búsquedas de texto. Están disponibles las siguientes alternativas:
<usar predefinido>
Se aplica lo especificado en Preferencias de Usuario como predeterminado.

Los valores excluidos se incluyen siempre en la búsqueda de texto.
No
Los valores excluidos no se incluyen en ningún caso en la búsqueda de texto, mientras que los valores opcionales sí se incluyen, según lo habitual.
Modo de Búsqueda Predeterminado Especifica el modo de búsqueda inicial predefinido que se empleará en las búsquedas de texto. El modo puede modificarse sobre la marcha introduciendo los símbolos * , o bien ~ como parte de la cadena de búsqueda. Están disponibles las siguientes alternativas:
<usar predefinido>
Se aplica lo especificado en Preferencias de Usuario como predeterminado.
Utilizar Búsqueda con Comodín
La cadena de búsqueda inicial serán dos comodines con el cursor entre ellos para facilitar la búsqueda de comodines.
Utilizar Búsqueda Difusa
La cadena de búsqueda inicial será un tipo de tilde (~) que denota una búsqueda difusa.
Utilizar Búsqueda Normal
No se añadirán caracteres adicionales a la cadena de búsqueda. Sin caracteres comodín, se realizará una Búsqueda Normal.

Número

La página Propiedades del Cuadro de Selección Múltiple: Número se abre haciendo clic con el botón derecho en un cuadro de selección múltiple y eligiendo el comando Propiedades en el menú contextual.

Esta página de propiedades da información de formato para todos los campos del cuadro de selección múltiple. El formato de número se puede establecer de forma individual en los campos, seleccionando uno o varios campos (Clic, <Mayús>-clic o <Ctrl>-clic) en el cuadro de texto Campos.

Cada campo tiene un formato numérico predefinido que se puede establecer en la página Propiedades de Documento: Número. No obstante, se puede utilizar también un formato numérico aparte, para un objeto de hoja individual. Para ello, marque la alternativa Ignorar Configuraciones de Documento y especifique un formato de número en el grupo inferior. Esta página de propiedades se aplica al objeto activo y contiene los siguientes controles para dar formato a los valores:

Mixto Incluye números y texto. Los números se muestran en su formato original.
Número Muestra los valores numéricos con el número de dígitos establecido en el cuadro Precisión.
Entero Muestra los valores numéricos como enteros.
Fijar en _ Decimales Muestra los valores numéricos como valores decimales con el número de decimales establecido en el cuadro Decimales.
Moneda Muestra los valores en el formato establecido en el cuadro de edición Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa. El formato por defecto es el establecido en Windows para moneda.
Fecha Muestra valores que pueden ser interpretados como fechas con el formato establecido en el cuadro de edición Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa.
Hora Muestra valores que se pueden interpretar como horas en el formato establecido en el cuadro de edición Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa.
Fecha/Hora Muestra los valores que pueden ser interpretados como fecha + hora con el formato establecido en el cuadro Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa.
Intervalo Muestra la hora como un incremento secuencial de tiempo (es decir formato = mm muestra el valor como un número de minutos desde que comenzó el calendario (1899:12:30:24:00).

El botón Mostrar en % opera en los siguientes formatos: Número, Entero y Fijo.

Los separadores de Decimales y de Miles pueden establecerse en las casillas de edición del grupo Separadores.

El botón ISOestablece el formato de la hora, fecha y fecha-hora conforme al estándar ISO.

El botón Sistema aplica al formato las configuraciones del sistema.

El botón Cambiar Formato de Documento abre la página Propiedades de Documento: Número, donde se puede editar el formato numérico predeterminado de cualquier campo.

See also:

 
  • FuenteEstilo de FuenteTamaño
  • Propiedades de Objeto: FuenteAplicar a ObjetosPropiedades de Documento: Fuente
  • Propiedades de Documento: Fuente
  • Preferencias de Usuario: Fuente
  • ColorFijoCalculado
  • Funciones de color

  • Utilizar Bordes
  • SimplificadoModo de Asignación de EstiloPropiedades de Documento: GeneralIntensidad de SombreadoAncho de Borde
  • Esquinas Redondeadas
  • Esquinas RedondeadasEsquinas RedondeadasAvanzadoModo de Asignación de EstiloPropiedades de Documento: General
  • Capa
  • Capa
  • Plantillas...
  • Creación de Plantillas
  • Aplicar Plantilla…
  • Plantillas de Diseño
  • Mostrar
  • Mostrar
  • Opciones
  • OpcionesPropiedades de Documento: DiseñoPropiedades de Hoja: Seguridad
  • Barras de Desplazamiento
  • Barras de Desplazamiento
  • Objeto
    Propiedades del Documento
  • Título
  • Colores ActivosColores Inactivos
  • Color de FondoColor de TextoÁrea de ColorColor de FondosólidodegradadoÁrea de colorColor de TextoFijoCalculado
  • Funciones de color
  • NormalMinimizado
  • Alineación de Título:
  • Iconos especiales

Fuente

  1. La primera fuente predefinida (Cuadros de Lista, Gráficos, etc.) es la que se emplea en la mayoría de los objetos, incluidos los cuadros de lista y los gráficos.
  2. La segunda fuente predefinida (Objetos de Texto / Botones) es la que se utiliza para los botones y cuadros de texto, que son objetos que normalmente necesitan un tipo de letra de mayor tamaño.
Sombreado Si está marcada esta opción, se añadirá un sombreado al texto.
Subrayado Si está marcada esta opción, el texto se subrayará.

Diseño

Intensidad de Sombreado El menú desplegable Intensidad de Sombreado permite establecer la intensidad del sombreado que rodea a los objetos de hoja. También existe la opción de Sin Sombreado.
Estilo de Borde Están disponibles los siguientes tipos de borde predefinidos:
Sólido
Un borde de un solo color.
Hundido
Un borde que da la impresión de hundir el objeto de hoja desde el fondo.
Elevado
Un borde que da la impresión de elevar el objeto de hoja desde el fondo.
Enmarcado
Un borde que de la impresión de un muro alrededor del objeto de hoja.
Ancho de Borde Esta opción está disponible para todos los tipos de borde. El ancho puede especificarse en mm, cm, pulgadas ("), píxeles (px,pxl,pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Color Haga clic en este botón para abrir un cuadro de diálogo que permite elegir un color de base apropiado en la paleta de colores para todos los tipos de borde.
Arcoiris Crea un borde con los colores del arco iris para todos los tipos de borde. El arco iris comenzará con el color básico seleccionado en la parte superior del objeto de hoja.
Esquinas Redondeadas Si marca esta opción, podrá hacer las esquinas redondeadas.
Esquinas Las esquinas que no tengan la opción marcada se dibujarán como rectangulares.
Inclinación Es un número variable entre 2 y 100 donde 100 define un rectángulo con esquinas cuadradas y 2 corresponde a una elipse perfecta (un círculo elipsoide con un ratio de aspecto de 1:1). Una inclinación entre 2 y 5 es óptima para conseguir esquinas redondeadas.
Ángulo de Redondeo Este parámetro determina el radio de las esquinas en distancia fija (Fijo) o como un porcentaje del cuadrante total (Relativo (%)). Este parámetro le permitirá controlar hasta qué punto se verán afectadas las esquinas por la forma general definida en Inclinación. La distancia se puede especificar en mm, cm, pulgadas, ('', pulgada), píxeles (px,pxl,pixel), puntos (pt, pts, punto) o unidades de documento (du, docunit).
Inferior Un objeto de hoja con la propiedad de capa Inferior nunca podrá hacer sombra o tapar a objetos que pertenezcan a las capas Normal y Superior. Solo podrá ubicarse sobre otros objetos de hoja de la misma capa Inferior.
Normal Al crearse, los objetos de hoja residen en la capa Normal (capa intermedia). Un objeto de hoja en la capa Normal nunca podrá ser oscurecido por objetos de hoja de la capa Inferior y nunca podrá tapar a objetos de hoja de la capa Superior.
Superior Un objeto de hoja en la capa Superior no puede ser nunca tapado por objetos de hoja de las capas Normal e Inferior. Sin embargo, es posible ubicar otros objetos de hoja de la capa Superior encima de él.
Personalizado Las capas Superior, Normal e Inferior se corresponden con las capas internamente numeradas 1, 0 y -1 respectivamente. De hecho se aceptan todos los valores entre -128 y 127. Escoja esta opción para introducir un valor de su elección.
Siempre El objeto de hoja siempre se mostrará.
Condicional

El objeto de hoja se mostrará u ocultará dependiendo de una función condicional que será evaluada continuamente dependiendo por ej. de las selecciones efectuadas, etc. El objeto de hoja solo se ocultará cuando la condición devuelva FALSO.

Funciones condicionales

Nota:

Los usuarios con privilegios de administrador sobre el documento pueden omitir todas estas condiciones seleccionando Mostrar todas las hojas y objetos de hoja en la página Propiedades de Documento: Seguridad. Esta funcionalidad se puede cambiar pulsando Ctrl+Mayús+S.

Propiedades de Documento: Seguridad

Permitir Mover/Ajustar Si se ha desmarcado esta opción será imposible mover o ajustar el objeto de hoja.
Permitir Copiar/ Clonar Si se ha desmarcado esta opción será imposible hacer una copia del objeto de hoja.
Permitir Información

Cuando utilice la función info, se mostrará un icono de información en la barra de título del objeto siempre que un valor de campo tenga información asociada al mismo. Si no quiere que aparezca el icono de información en la barra de título, puede deseleccionar esta opción.

Info

Ajustar a Datos Normalmente los bordes en torno a cualquier tipo de objeto de tabla en QlikView se encogen cuando las selecciones obligan a que el tamaño de la tabla sea menor que el espacio asignado para el objeto de hoja. Al desmarcar esta casilla este ajuste automático de tamaño se desactivará, quedando el espacio sobrante en blanco.
Preservar Posición de Desplazamiento

Con esta opción habilitada, QlikView tratará de mantener la posición de desplazamiento de tablas y gráficos que tengan una barra de desplazamiento cuando se efectúe una selección en otro objeto. La opción debe estar habilitada también en Preferencias de Usuario: Objetos.

Las posiciones de desplazamiento no se mantendrán si cierra el documento.

Botones de Desplazamiento Determina el color del botón de desplazamiento. Seleccione un color haciendo clic en el botón. Observe que los tonos intermedios de gris a menudo son los que mejor resultado dan en el caso de las barras de desplazamiento. Se puede definir cualquier color como color sólido o un degradado mediante el diálogo Área de Color, que se abre haciendo clic en el botón correspondiente.
Fondo de Barra de Desplazamiento

Define el color de fondo de la barra de desplazamiento. Seleccione un color haciendo clic en el botón.

Ancho de Barra de desplazamiento Este control afecta tanto al ancho como al tamaño relativo de los símbolos de las barras de desplazamiento.
Estilo de Desplazamiento

Establece el estilo de la barra de desplazamiento. Seleccione un estilo en el control desplegable. El estilo Clásico corresponde a las barras de desplazamiento 4/5 de QlikView. El estilo Estándar confiere un aspecto más moderno. El estilo Ligero corresponde a una barra más fina, más ligera.

El Modo de Asignación de Estilo debe configurarse como Avanzado para que el estilo de la barra de desplazamiento esté visible. Este parámetro se encuentra en la pestaña General, abriendo el menú desplegable Configuración y seleccionando Propiedades de Documento.

Aplicar a... Abre el diálogo Propiedades de Título y Borde, en el que podrá definir dónde aplicar las propiedades que se establecieron en la página Diseño.

Título

Mostrar Título Cuando se selecciona esta opción, se crea un título en la parte superior del objeto de hoja. Los cuadros de lista y otros "objetos de cuadro" tendrán la opción activada por defecto, mientras que los botones, objetos de texto y objetos de línea/flecha no.
Texto de Título En el cuadro de texto puede introducir un título que se mostrará en el título del objeto de hoja. Utilice el botón Fuente... si desea cambiar el tipo de letra del título.
Dividir Texto Si se marca esta opción, el título se mostrará en dos o más filas.
Altura de Título (Líneas) En este cuadro de edición se fija el número de líneas del título.
Coord. X Fija la posición horizontal del lado izquierdo del objeto de hoja, en relación con el borde izquierdo de la hoja.
Coord. Y Fija la posición vertical del lado superior del objeto de hoja, en relación con el borde superior de la hoja.
Ancho Fija el ancho del objeto de hoja QlikView.
Altura Fija la altura del objeto de hoja QlikView.
Horizontal La etiqueta puede alinearse horizontalmente a la: Izquierda, Centrado o a la Derecha dentro del área de título.
Vertical La etiqueta puede alinearse verticalmente de forma: Superior, Centrado o Inferior dentro del área del título.
Nota: Utilice los iconos especiales de título con cuidado. Demasiados iconos pueden confundir al usuario.
Permitir Minimizar Cuando se marca esta opción, se mostrará un icono de minimizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea minimizable. Además, esto hará que el objeto se pueda minimizar haciendo doble clic sobre su título.
Minimizado Automático Esta opción estará disponible cuando Permitir Minimizar esté marcado. Si marca la opción Minimizado Automático para varios objetos de hoja de una misma hoja, se minimizarán automáticamente todos menos uno en cualquier momento. Esto puede resultar útil para, por ejemplo, mostrar de forma alternativa diversos gráficos en una misma área de hoja.
Permitir Maximizar Si marca esta opción se mostrará un icono de maximizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea maximizable. Además, esto hará que el objeto se pueda maximizar haciendo doble clic sobre su título. Si están marcados tanto Permitir Minimizar como Permitir Maximizar a la vez, hacer doble clic dará como resultado un objeto minimizado.
Texto de Ayuda

Aquí podrá introducir un texto de ayuda para mostrarlo en una ventana emergente. El texto de ayuda puede definirse como una fórmula calculada. Esta opción no está disponible a nivel de documento. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Puede introducir, por ejemplo, una descripción del objeto de hoja. Se añadirá un icono de ayuda al título de la ventana del objeto. Cuando el puntero del ratón esté sobre el icono, el texto se mostrará en una ventana emergente.