Cuadro de Lista

El Cuadro de Lista es el objeto de hoja más básico. Contiene una lista de todos los valores posibles de un campo específico. Cada fila del Cuadro de Lista puede representar varios registros en la tabla cargada, todos con valores idénticos. Seleccionar un valor puede ser equivalente a seleccionar varios registros en la tabla cargada.

Un cuadro de lista también puede contener un grupo cíclico o jerárquico. Cuando se utiliza un grupo jerárquico, seleccionar un valor en el cuadro de lista, hará que éste profundice y cambie al siguiente nivel jerárquico dentro del grupo. Para volver hacia atrás en la jerarquía haga clic en el icono jerárquico que se ve en el título del cuadro de lista.

Si asigna un grupo cíclico a un cuadro de lista, puede cambiar de campo dentro del grupo haciendo clic en el icono de ciclo que aparece en el título del cuadro de lista. También puede ir directamente a cualquier campo del grupo utilizando la opción Ciclo del menú objeto del cuadro de lista.

Haciendo clic con el botón derecho sobre el cuadro de lista se abre el menú Objeto.

Menú Objeto

El menú Objeto del cuadro de lista se abre haciendo clic con el botón derecho en el objeto. Los comandos del menú son los siguientes:

Propiedades... Abre el cuadro de diálogo Propiedades del Cuadro de Lista donde se pueden configurar una serie de parámetros.
Notas

Permite crear y compartir notas relativas al objeto actual.

Notas y Comentarios

Ciclo

Solo está disponible cuando el cuadro de lista se ha configurado para mostrar un grupo cíclico. Abre un menú en cascada con los campos del grupo para seleccionar directamente qué campo se va a mostrar en el cuadro de lista.

Grupos no Jerárquicos (Cíclicos)

Buscar

Abre el cuadro de búsqueda.

Buscar

Búsqueda Difusa

Abre el cuadro de búsqueda en modo de búsqueda difusa.

Búsqueda Difusa

Búsqueda Avanzada

Abre el diálogo de búsqueda avanzada. Este diálogo permite introducir expresiones de búsqueda avanzada. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+Mayús+F.

Búsqueda Avanzada (diálogo)

Ordenar

Este menú en cascada solo está disponible cuando el comando de la Rejilla de Diseño del menú Ver está activado o cuando se ha marcado la opción Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño. Contiene cuatro comandos para fijar la capa de diseño de los objetos de hoja. Los números válidos de capa van desde -128 a 127.

Traer al Frente
Fija la capa de diseño del objeto de hoja en el mayor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Enviar Atrás
Fija la capa de diseño del objeto de hoja en el menor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Adelantar
Incrementa la capa de diseño del objeto de hoja en un valor. El valor máximo es 127.

Atrasar
Reduce la capa de diseño del objeto de hoja en un valor. El valor mínimo es -128.


Cambiar Valor Únicamente disponible para cuadros de lista que muestren campos de entrada. Pone la celda sobre la que se haya hecho clic en modo de edición de entrada. Equivale a pulsar el icono de entrada en la celda.
Restaurar Valores Únicamente disponible para cuadros de lista que muestren campos de entrada. Abre un menú en cascada con tres opciones.
Restaurar Valor Único
Restaura el valor del valor de campo sobre el que se haya hecho clic, devolviéndolo a su valor predeterminado por defecto desde el script.
Restaurar Valores Posibles
Restaura los valores de todos los valores de campo posibles, devolviéndolos a sus valores predefinidos desde el script.
Restaurar Todos los Valores
Restaura los valores de todos los valores de campo, devolviéndolos a sus valores predefinidos desde el script.
Seleccionar Valores Posibles Se seleccionan todos los valores no excluidos en el cuadro de lista.
Seleccionar Valores Excluidos Se seleccionan todos los valores excluidos en el cuadro de lista.
Seleccionar Todo Se seleccionan todos los valores del cuadro de lista
Borrar Borra todas las selecciones actuales del cuadro de lista activo.
Borrar Otros Campos Borra las selecciones en otros objetos de hoja, mientras mantiene las actuales en el cuadro de lista actual.
Bloquear Bloquea los valores seleccionados en el cuadro de lista activo. (Si no se han hecho selecciones, no estará disponible).
Desbloquear Desbloquea los valores bloqueados en el cuadro de lista. (Aparece en lugar de Bloquear si las selecciones han sido previamente bloqueadas).
Crear Gráfico Rápido

Abre el Asistente de Gráfico Rápido, el cual le ayudará a crear un gráfico de forma rápida y fácil.

Asistente de Gráfico Rápido

Crear Gráfico de Tiempos

Abre el Asistente de Gráfico de Tiempos, que permite crear un gráfico en el que una determinada medida (expresión) debería cualificarse y a menudo compararse con distintos períodos de tiempo.

Asistente de gráfico de tiempos

Crear Cuadro de Estadísticas Realiza varios cálculos estadísticos sobre los valores seleccionados de un campo (muestra) y muestra los resultados en un cuadro de estadísticas.
Imprimir Valores Posibles...

Abre el diálogo Imprimir donde se pueden especificar las configuraciones de impresión. Todos los valores no excluidos del Cuadro de Lista activo se envían a la impresora.

Imprimir: General

Imprimir Valores Posibles como PDF

Abre el cuadro de diálogo Imprimir con la impresora PDF-XChange 3.0 preseleccionada. Tras pulsar el botón Imprimir se le pedirá que introduzca un nombre de archivo para el archivo PDF de salida. Este comando solo está disponible si el sistema dispone de una impresora PDF.

Enviar a Excel

Exporta los valores posibles (incluyendo los seleccionados) a Microsoft Excel, el cual se abre automáticamente, si es que no está ya en ejecución. Los valores exportados aparecerán en una nueva hoja de Excel. Para que esta funcionalidad opere como es debido es necesario tener instalado Microsoft Excel 2007 o posterior en el equipo.

Nota: El mini gráfico no se mostrará cuando se exporte a Excel.
Exportar... Abre el diálogo Guardar Como donde se pueden especificar una ruta, nombre de archivo y tipo de archivo (tabla) para los contenidos exportados.
Copiar al Portapapeles Este menú en cascada contiene las diversas opciones disponibles para el objeto de hoja.
Valores Posibles
Copia los valores posibles (seleccionados y opcionales) en el portapapeles.
Valor de Celda
Copia en el portapapeles el valor de texto de la celda del cuadro de lista sobre la que se haya hecho clic con el botón derecho del ratón (al invocar el menú Objeto).
Imagen
Copia una imagen del objeto de hoja en el portapapeles. La imagen incluirá o excluirá el título y el borde del objeto de hoja, dependiendo de los parámetros definidos en el diálogo Preferencias de Usuario: Exportar.
Objeto
Copia el objeto de hoja completo en el portapapeles para poder pegarlo posteriormente en cualquier parte del diseño o en otro documento abierto en la misma sesión actual de QlikView.
Objetos enlazados

Abre un menú con los siguientes comandos relativos a los objetos enlazados.
Ajustar Posición de Objetos Enlazados
Todos los objetos enlazados de todas las hojas se ajustan a la misma posición y tamaño que el de el/los objetos resaltados.
Desenlazar Este Objeto/Desenlazar Objetos
Esto elimina el enlace que había entre los objetos, convirtiéndolos en objetos diferentes con diferentes ID de objeto.

Minimizar Convierte el objeto en un icono. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activada la opción minimizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Maximizar Expande el objeto hasta llenar la hoja. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activa la opción maximizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Restaurar Restaura un objeto maximizado o minimizado a su posición y tamaño anteriores. Hacer doble clic en el icono de un objeto minimizado o hacer clic en el título del objeto (si se muestra) de un objeto maximizado ofrece el mismo resultado. Este comando solo está disponible para objetos minimizados o maximizados.
Ayuda Abre la ayuda de QlikView.
Eliminar Elimina el objeto de la hoja.

General

La página Propiedades del Cuadro de Lista: General se abre haciendo clic con el botón derecho sobre un cuadro de lista y eligiendo el comando Propiedades en el menú contextual. Aquí se pueden establecer los parámetros generales para el cuadro de lista.

Título

El texto que aparecerá en el título del cuadro de lista. El texto por defecto es el nombre del campo seleccionado. El título puede definirse también como una fórmula calculada para actualización dinámica del texto de la etiqueta. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Campo Seleccione un campo de la lista. El cuadro de lista contendrá los valores del campo seleccionado.
Un cuadro de lista también puede contener un grupo cíclico o jerárquico. Solo se mostrará uno de ellos por vez. Estos grupos se crean en el diálogo Propiedades de Documento: Grupos y aparecen listados junto con los campos disponibles.
Si se utiliza un grupo jerárquico, seleccionar un único valor en el cuadro de lista hará que éste profundice y cambie al siguiente nivel jerárquico dentro del grupo. Para volver hacia atrás en la jerarquía haga clic en el icono jerárquico que se ve en el título del cuadro de lista.
Si se asigna un grupo cíclico a un cuadro de lista, se puede cambiar de campo dentro del grupo haciendo clic en el icono de ciclo que aparece en el título del cuadro de lista. También es posible ir directamente a cualquier campo del grupo utilizando la opción Ciclo-> del menú de objeto del cuadro de lista.
Además, se puede mostrar un campo calculado en un cuadro de lista. Un campo calculado no surge de la ejecución de script, sino que es definido desde una expresión. La misma regla se aplica en Dimensiones Calculadas. Si debiera utilizarse un campo calculado en el cuadro de lista, seleccione <Expresión> en el desplegable, tras lo cual se abrirá el cuadro de diálogo Editar Expresión, donde podrá definir la expresión que describa el campo calculado.
Utilizar como Título
Si selecciona esta casilla de verificación, el nombre del campo se empleará como Título. El texto <usar nombre de campo> aparecerá en el cuadro de edición del Título.
Editar...
Este botón sólo está disponible cuando se ha seleccionado <Expression> como nombre de campo. El botón abre el diálogo Editar Expresión donde se puede definir la expresión que describe el campo calculado.
Nota: Cuando se utiliza un campo calculado, parte de la funcionalidad de los cuadros de lista puede ser algo distinta de la de los cuadros de lista habituales. Algunos parámetros de propiedades no estarán disponibles (ver debajo). Además, no podrá crear cuadros estadísticos a partir de tales cuadros de lista.
Nota: Un campo calculado ha de ser siempre una transformación de uno o más campos normales. Los campos calculados puramente sintácticos, creados mediante las funciones valuelist y valueloop no se permiten. Cuando haga selecciones en un campo calculado, realmente está realizando las selecciones en el campo normal subyacente. Cuando emplee más de un campo como base para un campo calculado, las implicaciones lógicas de las selecciones en los campos de base o el campo calculado pueden ser de una gran complejidad..  
Nota: El uso de campos calculados en los cuadros de lista podría afectar al rendimiento con cantidades extremas de datos.
Nota: No es posible utilizar campos MEASURE definidos con la función Direct Discovery en un cuadro de lista.
Modo And

Las selecciones múltiples dentro de un campo deben ser del tipo AND u OR. Por defecto, la selección es de tipo OR. Este comando alterna el modo lógico con el que se hace una selección múltiple. Esta opción de menú está desactivada si el campo no cumple determinadas condiciones. Esta opción no está disponible para los campos calculados.

Mostrar Valores Opcionales Alterna entre si excluir o no los otros valores del campo, tras una selección directa en el cuadro de lista activo. Si está marcada la opción Mostrar Valores Opcionales, todos los valores, excepto el valor seleccionado, se mostrarán como opcionales, pero pueden ser excluidos por asociación con selecciones en otros campos. Si no, todos los demás valores se mostrarán como excluidos por defecto. Esta opción no está disponible para los campos calculados.
Ocultar Excluidos Alterna entre mostrar o no los valores excluidos de un campo. Los valores excluidos se vuelven no seleccionados.
Sólo Lectura Marcar esta casilla impide que se realicen selecciones en el cuadro de lista. No obstante, reflejará las selecciones efectuadas en cualquier otra parte del documento.
Siempre un valor seleccionado

Marcar esta casilla garantiza que solo se podrá seleccionar un valor, lo cual es útil en documentos donde los datos solo tienen sentido si se selecciona un valor, como las tasas de cambio (de moneda), etc. Esta opción solo se activa cuando ya se ha seleccionado un valor en el cuadro de lista. Esta opción no está disponible para los campos calculados.

Nota: Habilitar esta opción modifica el modelo de datos. Como resultado, es posible que los marcadores existentes dejen de funcionar, incluso si mantiene los mismos nombres de campo.
Ignorar Campo Bloqueado Marcar esta opción permite seleccionar en el cuadro de lista aunque éste esté bloqueado. El cuadro de lista seguirá bloqueado para las selecciones efectuadas en cualquier otra parte del documento.
Mostrar en Vista de Árbol

Muestra el cuadro de lista en una presentación arbórea. Este control sólo tiene sentido si el campo contiene la representación de los nodos de ruta en una jerarquía. Un campo así se puede generar empleando el parámetro Path del prefijo Hierarchy.

Vista de Árbol en Cuadros de Lista

Con Separador Establece el carácter que debiera interpretarse como separador en la ruta empleada para la Vista de Árbol.
Mostrar Frecuencia Alterna entre mostrar la frecuencia de un valor de campo, o no mostrarla. Por frecuencia se entiende el número de combinaciones seleccionables en las que aparece el valor. Esta opción no está disponible para los campos calculados.
En Porcentaje Establece si la frecuencia del campo seleccionado debe ser mostrada en números absolutos o como porcentaje del número total de entradas.
Estado Alterno Seleccione uno de los estados disponibles en el desplegable. Los siguientes Estados Alternos están siempre disponibles.
Heredado
Las hojas y objetos de hoja siempre se encuentran en estado heredado a menos que el desarrollador de QlikView lo modifique. Este parámetro se hereda del objeto del nivel superior, un gráfico de una hoja recibe los mismos parámetros de la hoja si se ha elegido la opción heredado.
Estado predefinido
Es el estado en el que más uso se hace de QlikView y viene representado por el signo $. El documento QlikView se halla siempre por defecto en el estado predefinido.
ID de Objeto

Esta opción se utiliza para macros. A cada objeto de hoja se le asigna un ID único. Le recomendamos utilizar caracteres alfanuméricos solo en la ID. Para los cuadros de lista, el ID comienza por LB01. Los objetos enlazados comparten un mismo ID de objeto. Podrá editar este número ID más adelante.

Intérprete Interno de Macros

Incluir Valores Excluidos en la Búsqueda La lista desplegable permite elegir entre , No, o <usar predefinido> lo cual se aplica a la configuración por defecto especificada en Preferencias de Usuario: General.
Modo de Búsqueda Predeterminado Especifica el modo de búsqueda inicial predefinido que se empleará en las búsquedas de texto. El modo puede modificarse sobre la marcha introduciendo los símbolos * , o bien ~ como parte de la cadena de búsqueda. Están disponibles las siguientes alternativas:
Usar <predeterminado>
Se aplica lo especificado en Preferencias de Usuario como predeterminado.
Utilizar Búsqueda con Comodín
La cadena de búsqueda inicial serán dos comodines con el cursor entre ellos para facilitar la búsqueda de comodines.
Utilizar Búsqueda Difusa
La cadena de búsqueda inicial será un tipo de tilde (~) que denota una búsqueda difusa.
Utilizar Búsqueda Normal
No se añadirán caracteres adicionales a la cadena de búsqueda. Sin caracteres comodín, se realizará una Búsqueda Normal.
Usar Búsqueda Asociativa
Se usará búsqueda asociativa en el cuadro de búsqueda.

Buscar

Configuraciones de Impresión Aquí podrá establecer los parámetros de impresión para el trabajo de la impresora.
Imprimir Todos los Valores El comportamiento habitual en los cuadros de lista es imprimir sólo los valores posibles. Si marca esta casilla de verificación, se imprimirán todos los valores (también los excluidos).
Impresión Según el Diseño Si marca esta opción, el cuadro de lista se imprimirá tal y como aparece en pantalla, con sus columnas múltiples, su codificación de colores en las celdas, etc. Esto puede resultar útil, por ej. para la inclusión de cuadros de lista en informes.

Expresiones

En la pestaña Expresiones podrá definir las expresiones que se mostrarán en el cuadro de lista. Cada expresión aparecerá en una nueva columna del cuadro de lista. La esquina superior izquierda del cuadro de diálogo contiene un listado con las expresiones del gráfico.

Los datos de las expresiones también pueden formatearse dinámicamente mediante las expresiones de atributo. Haga clic sobre el icono de expansión que hallará frente a cualquier expresión para visualizar las expresiones de atributo de la dimensión.

Puede utilizar cualquier número y combinación de expresiones de atributo que desee en una determinada expresión base. El formato definido mediante las expresiones de atributo reemplaza y desbanca a cualquier otra opción predeterminada en cuanto a color, etc.

Añadir Si pulsa este botón, se abre el diálogo Editar Expresión, el cual permite crear nuevas expresiones. Esta opción también está disponible en el menú contextual que aparece al hacer clic con el botón derecho sobre una expresión de la lista de expresiones.
Eliminar Elimina la expresión seleccionada. La opción también está disponible en el menú contextual que aparece al hacer clic con el botón derecho en una expresión de la lista de expresiones.
Copiar La opción únicamente está disponible en el menú contextual que aparece al hacer clic con el botón derecho en una expresión de la lista de expresiones. Cuando se utilice este comando en una de las expresiones principales, todos los datos y parámetros asociados con la expresión (incluyendo rótulos y etiquetas) se copiarán al portapapeles como una cadena de xml. La expresión podrá entonces copiarse de nuevo en el mismo objeto o en cualquier otro objeto QlikView del mismo u otro documento. Si se emplea el comando en una expresión de atributo, únicamente se copiará la definición de la expresión de atributo. A continuación se podrá pegar la expresión de atributo en cualquier expresión principal del mismo u otro objeto.
Exportar... La opción solo está disponible en el menú contextual que aparece al hacer clic con el botón derecho en una de las expresiones principales de la lista de expresiones. Cuando se haga uso de este comando en una expresión principal, todos los datos y parámetros asociados a la expresión (incluida la etiqueta) podrán ser exportados a un archivo xml. La expresión podrá entonces importarse de nuevo en el mismo gráfico o en cualquier otro gráfico de QlikView, en el mismo u otro documento. El comando abre el diálogo Exportar Expresión, en el que podrá elegir el destino para el archivo que se ha de exportar. El archivo recibirá una extensión, por ejemplo xml.
Pegar La opción únicamente está disponible en el menú contextual que aparece al hacer clic con el botón derecho en la lista de expresiones y solo si una de dichas expresiones ha sido previamente copiada al portapapeles. Si previamente se ha copiado una expresión principal en el portapapeles, podrá pegarla en el área en blanco de la lista de expresiones, creándose así una nueva expresión idéntica a la copiada originalmente. Si se ha copiado una expresión de atributo, podrá pegarla en una expresión principal.
Importar La opción solo está disponible en el menú contextual que aparece al hacer clic con el botón derecho del ratón sobre el área en blanco de la lista de expresiones. El comando abre un diálogo en el que podrá buscar la expresión previamente exportada. La expresión importada aparecerá como una nueva expresión principal en el gráfico.
Ascender Hace ascender la expresión seleccionada un paso más arriba de la lista. Utilice este botón si desea cambiar el orden de las expresiones.
Descender Hace descender la expresión seleccionada un paso más abajo en la lista . Utilice este botón si desea cambiar el orden de las expresiones.
Símbolo de Nulo El símbolo aquí introducido será el empleado para mostrar valores nulos (valores NULL) en la tabla.
Símbolo de Perdido El símbolo aquí introducido será el empleado para mostrar valores perdidos en la tabla.
Habilitar Marcar esta casilla activará la expresión seleccionada. Si la casilla no se marca, la expresión no se utilizará en absoluto.
Definición Muestra la composición de la expresión seleccionada. Es posible editar la expresión directamente en este cuadro. Haciendo clic en el botón ... se abre el cuadro de diálogo completo Editar Expresión.
Mostrar Si está seleccionada la casilla Siempre, la expresión se mostrará siempre en una columna extra del cuadro de lista. Si está seleccionada la casilla Condicional, el informe se mostrará u ocultará dinámicamente, dependiendo del valor de una expresión condicional introducido en el cuadro de edición que hay a la derecha.
Alineación En este grupo se encuentra la configuración predefinida para la alineación de sus expresiones. Se puede definir la alineación a la izquierda, centrada, o a la derecha para texto y números de forma aislada.
Opciones de Presentación Este grupo define lo que se escribirá en las celdas de expresión del cuadro de lista.
Representación Están disponibles las siguientes alternativas:
Texto
Si está marcada esta opción, los valores de la expresión se interpretarán y mostrarán siempre como texto.
Imagen
Al seleccionar esta opción QlikView tratará de interpretar cada valor de la expresión como una referencia a una imagen. La referencia puede ser una ruta a un archivo de imagen en el disco (ej. C:\Mypic.jpg) o dentro del documento qvw (por ej. qmem://Nombre/Pedro). Si QlikView no puede interpretar el valor de una expresión como una referencia válida a una imagen, se mostrará el valor mismo.
Indicador Circular
Al seleccionar esta opción QlikView mostrará el valor de la expresión en un indicador circular. El gráfico indicador será incluido en la celda de tabla disponible. La configuración visual del indicador puede modificarse mediante el botón Configuraciones de Indicador
Indicador Lineal
Al seleccionar esta opción QlikView mostrará el valor de la expresión en un indicador lineal horizontal. El gráfico indicador será incluido en la celda de tabla disponible. La configuración visual del indicador puede modificarse mediante el botón Configuraciones de Indicador
Indicador de Semáforo
Al seleccionar esta opción QlikView mostrará el valor de la expresión en un indicador de semáforo horizontal. El gráfico indicador será incluido en la celda de tabla disponible. La configuración visual del indicador puede modificarse mediante el botón Configuraciones de Indicador
Indicador LED
Al seleccionar esta opción QlikView mostrará el valor de la expresión en un indicador LED. El gráfico indicador será incluido en la celda de tabla disponible. La configuración visual del indicador puede modificarse mediante el botón Configuraciones de Indicador
Mini Gráfico
Cuando seleccione esta opción, QlikView mostrará el valor de la expresión en un gráfico en miniatura con la expresión agregada a una dimensión extra. El gráfico se inscribirá en la celda de tabla disponible. Se puede definir la dimensión con el minigráfico pudiéndose modificar los parámetros mediante el botón Configuraciones de Mini Gráfico (ver a continuación).
Nota: El mini gráfico no se mostrará cuando se exporte a Excel.
Configuraciones de Indicador… Sólo está disponible cuando una de las opciones de indicador ha sido seleccionada arriba. Abre este diálogo para configurar las propiedades del indicador. Este diálogo es esencialmente igual al de Propiedades de gráfico: Presentación para los gráficos de indicador.
Configuraciones de Mini Gráfico Únicamente disponible si se ha seleccionado antes Mini Gráfico como Opción de Presentación para una expresión de la tabla. Abre un diálogo para configurar las propiedades del mini gráfico.
Formato de Imagen Sólo está disponible cuando se han seleccionado las opciones de imagen arriba. Esta configuración describe cómo QlikView formatea la imagen para ajustarla a la celda. Hay cuatro alternativas
Sin Ajustar
Si se selecciona esta opción, la imagen se mostrará tal cual es, sin realizar ningún tipo de ajustes. Esto puede hacer que algunas partes de la imagen queden invisibles o que sólo aparezca rellena una parte de la celda.
Rellenar
Si se selecciona esta opción, la imagen se ajustará hasta llenar la celda, sin tener en cuenta el ratio de aspecto (la proporción) de la imagen.
Mantener Aspecto
Si se selecciona esta opción, la imagen se ajustará lo más posible para llenar la celda al tiempo que mantiene el ratio de aspecto (la proporción). Esto normalmente da como resultado áreas en blanco, tanto encima como debajo de la imagen, o en ambas zonas a la vez.
Rellenar con Aspecto
Si se selecciona esta opción, la imagen se ajustará hasta llenar la celda en ambas direcciones al tiempo que mantiene el ratio de aspecto (la proporción de la imagen). Esto normalmente da como resultado partes de la imagen sesgadas en una dirección.
Ocultar Texto cuando falta la Imagen
Si se selecciona esta opción y la interpretación como referencia de imagen falla por alguna razón, QlikView no mostrará el texto del valor de campo. La celda entonces se dejará en blanco.

Configuraciones de Mini Gráfico

Únicamente disponible cuando se ha seleccionado la opción Mini Gráficos en la página Expresiones del cuadro de diálogo Propiedades de una tabla simple. Abre un diálogo para configurar las propiedades del mini gráfico.

Dimensión Escoja la dimensión para la cual debería trazarse la expresión.

Aspecto

Mode Establece el mini gráfico como chispa, línea con puntos, puntos, barras o ejes.
Color Abre el diálogo Área de Color desde donde podrá configurar el color del mini gráfico.
Realzar Valor Máximo con Color Marque la casilla de verificación y pulse el botón coloreado para abrir el diálogo Área de Color desde donde podrá establecer el color para el valor máximo.
Realzar Valor Mínimo con Color Marque la casilla de verificación y pulse el botón coloreado para abrir el diálogo Área de Color desde donde podrá establecer el color del valor mínimo.
Realzar Valores Iniciales con Color Marque la casilla de verificación y pulse el botón coloreado para abrir el diálogo Área de Color desde donde podrá establecer el color de los valores iniciales. No disponible para Barras y Ejes.
Realzar Valores Extremos con Color Marque la casilla de verificación y pulse el botón coloreado para abrir el diálogo Área de Color desde donde podrá establecer el color de los valores extremos. No disponible para Barras y Ejes.
Establecer Colores Predeterminados Establece los colores para las opciones de realzado según los colores predeterminados de QlikView.
Forzar Escalado en Cero Fija el límite inferior del gráfico a cero en el eje. No disponible para Ejes.
Forzar Escala Compartida en eje Y Obliga a todas las celdas de una columna a utilizar la misma escala en el eje y.

Ordenar

La pestaña Ordenar se abre haciendo clic con el botón derecho sobre un objeto de hoja (Cuadro de Lista, Cuadro de selección múltiple, Cuadro de Tabla, Gráfico u Objeto Calendario/Control deslizante) y eligiendo el comando Propiedades en el menú contextual (o bien Objeto, Propiedades en el menú principal). Aquí podrá configurar el criterio de ordenación de los valores en el objeto de hoja. Algunas opciones pueden no estar disponibles para ciertos objetos de hoja.

Ordenar por:

Estado

Ordena los valores de campo según su estado lógico (seleccionado, opcional, o excluido).
El parámetro Auto Ascendente ordena el cuadro de lista (o, en un cuadro múltiple, el listado desplegable que contiene los valores de campo) conforme a su Estado solo si el cuadro de lista contiene una barra de desplazamiento vertical. No obstante, si amplía el cuadro de lista para que pase a mostrar todos los valores, el criterio de ordenación de Estado se desactiva por completo.

Nota: No utilice el orden Auto Ascendente en un cuadro de lista de un objeto Contenedor.
Expresión Ordena los valores de campo de acuerdo con la expresión introducida en el cuadro de texto. Si utilizamos ordenar por expresión, se ha de definir un conjunto alternativo de registros mediante una expresión de conjunto, puesto que la expresión se calcula sobre valores seleccionados/posibles de la lista y la ordenación sólo se aplicaría a los valores seleccionados/posibles de la lista.
Nota: Ordenar por expresión sólo funciona con campos numéricos y no con campos de texto.

Análisis de conjuntos y expresiones de conjuntos

Frecuencia Ordena los valores de campo por la frecuencia (la cantidad de veces que aparecen en la tabla).
Valor Numérico Ordena los valores de campo por sus valores numéricos.
Texto Ordena los valores de campo por orden alfabético.
Orden de Carga Ordena los valores de campo por su orden de carga inicial.

El botón Predeterminado establece el criterio de ordenación por defecto.

El orden de prioridad es Estado, Expresión, Frecuencia, Valor numérico, Texto, Orden load. Se puede ordenar cada uno de estos criterios de ordenación de forma Ascendente o Descendente.

Presentación

La página Propiedades del Cuadro de Lista: Presentación se abre haciendo clic con el botón derecho en una ventana del cuadro de lista y eligiendo el comando Propiedades en el menú contextual. Aquí es posible ajustar el diseño de las celdas del cuadro de lista.

En el grupo Opciones de Imagen, puede hacer que un valor de campo tenga una referencia a una imagen en memoria o en disco y sea interpretado como esa imagen:

En Representación puede elegir entre Texto (predeterminado), Imagen e Info como Imagen.

Cuando usted selecciona una Imagen, QlikView trata de interpretar cada valor de campo como una referencia a una imagen. La referencia puede ser una ruta a un archivo de imagen en el disco (ej. C:\Mypic.jpg) o dentro del documento qvw (por ej. qmem://Nombre/Pedro). Si QlikView no puede interpretar un valor de campo como una referencia válida a una imagen, el valor será mostrado como tal, a menos que esté marcada la opción Ocultar Texto Cuando Falta Imagen.

Cuando seleccione Info como Imagen, QlikView mostrará una información de imagen enlazada con el valor de campo mediante info load/info select en el script. Si no hay disponible información de imagen alguna para un valor de campo, se mostrará el valor mismo, a menos que esté marcada la opción Ocultar Texto Cuando Falta Imagen.

Siempre que esté marcada cualquier opción de imagen, las configuraciones bajo Formato de Imagen se pueden utilizar para ajustar la imagen a la celda.

Sin Ajustar La imagen se muestra tal cual es, lo que puede provocar problemas de ocultamiento.
Rellenar La imagen se ajusta de forma que rellene la celda, sin tener en cuenta la proporción o ratio de aspecto.
Mantener Aspecto La imagen se ajusta tanto como sea posible, al tiempo que se mantiene la proporción o ratio de aspecto correcto.
Rellenar con Aspecto La imagen se ajusta tanto como sea posible, al tiempo que se mantiene la proporción o ratio de aspecto correcto. Las áreas no cubiertas con este método se rellenan posteriormente con trozos de la misma imagen.

Cuando se muestren imágenes en lugar de texto puede que sea necesario emplear otro estilo de selección diferente al que trae el documento por defecto, para que el estado lógico de los valores de campo permanezca visible. Utilice la lista desplegable de Sobreescribir Estilo de Selección para seleccionar un estilo de selección adecuado, por ej. Indicador de Esquina.

Sólo una Columna Con esta opción marcada, los valores del cuadro de lista se presentarán en una sola columna.
Suprimir Barra de Desplazamiento Horizontal Marque esta opción para suprimir la barra de desplazamiento horizontal que se muestra normalmente cuando los valores de campo son demasiado anchos para la anchura especificada del cuadro de lista. En su lugar, los valores de campo se truncarán según sea necesario.
Número Fijo de Columnas Marque esta opción para establecer un número fijo de columnas para el cuadro de lista. La opción no está disponible si está seleccionado Sólo una Columna.
Ordenar por Columna En los cuadros de lista con más de una columna, los valores se muestran ordenados por filas, según el criterio de ordenación especificado. La opción Ordenar por columna cambia la ordenación por columnas.
Bordes de Celda Los valores de campo irán separados por líneas horizontales, simulando las filas de una tabla. La casilla Bordes de Celda se activa automáticamente cuando la opción de Dividir Texto está marcada, pero puede ser desactivada a continuación.
Resaltar Búsqueda
Subcadena
La cadena de búsqueda introducida en un objeto de búsqueda se irá resaltando en las correspondencias.
Fondo... Abre el diálogo Configuraciones de Fondo.
Alineación Aquí se establece la alineación de los valores de campo en un cuadro de lista. La alineación del Texto y de los Números se establece por separado.
Configuraciones de Varias Filas En este grupo las celdas del cuadro de lista podrán quedar configuradas para que muestren los valores en múltiples filas, lo cual resulta útil con cadenas largas de texto.
Dividir Texto de Celda
Seleccionando esta opción, la celda mostrará sus contencidos en más de una fila.
Altura de Celdas n Líneas
Aquí se especifican los límites del número de filas de una celda.

Configuraciones de Fondo

Color Si este parámetro está activo se coloreará el fondo del objeto. Puede elegir un color pulsando el botón Color.
Transparencia del Color Sólo disponible si se ha activado la opción del color. Establece el grado de transparencia del color de fondo.
Imagen Si este parámetro está activo, el fondo del objeto será una imagen. Pulse Explorar y escoja una imagen. Pulse Eliminar para eliminarla del fondo.
Ajuste de Imagen Sólo disponible si se ha activado la opción de imagen. El parámetro define cómo ajusta QlikView la imagen para que quepa.
Sin Ajustar
La imagen se mostrará tal cual es, sin ningún tipo de ajuste. Esto puede hacer que algunas partes de la imagen no se visualicen o que tan sólo se rellene una parte del fondo.
Rellenar
La imagen se ajustará de forma que encaje en el fondo, sin mantener el ratio de aspecto (la proporción) de la imagen.
Mantener Aspecto
La imagen se ajustará lo más posible para llenar el fondo de la hoja, al tiempo que se mantiene el ratio de aspecto (o proporción) de la imagen.
Rellenar con Aspecto
Si se selecciona esta opción, la imagen se ajustará hasta llenar el fondo en ambas direcciones al tiempo que mantiene el ratio de aspecto (la proporción) de la imagen. Esto normalmente da como resultado partes de la imagen sesgadas en una dirección.
Alineación Horizontal Sólo disponible si se ha activado la opción de imagen. Alinea la imagen a la Izquierda, Centrado o a la Derecha.
Alineación Vertical Sólo disponible si se ha activado la opción de imagen. Alinea la imagen en la parte Superior, Centrado o Inferior.
Transparencia de Imagen Sólo disponible si se ha activado la opción de imagen. Establece el grado de transparencia de la imagen de fondo.

Número

La página Propiedades: Número se abre haciendo clic con el botón derecho sobre un objeto de hoja y eligiendo el comando Propiedades en el menú flotante.

Cada campo tiene un formato numérico predefinido que se puede establecer en la página Propiedades de Documento: Número. No obstante, se puede utilizar también un formato numérico aparte, para un objeto de hoja individual. Para ello, marque la alternativa Ignorar Configuraciones de Documento y especifique un formato de número en el grupo inferior. Esta página de propiedades se aplica al objeto activo y contiene los siguientes controles para dar formato a los valores:

Mixto Incluye números y texto. Los números se muestran en su formato original.
Número Muestra los valores numéricos con el número de dígitos establecido en el cuadro Precisión.
Entero Muestra los valores numéricos como enteros.
Fijar en Muestra los valores numéricos como valores decimales con el número de decimales establecido en el cuadro Decimales.
Moneda Muestra los valores en el formato establecido en el cuadro de edición Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa. El formato por defecto es el establecido en Windows para moneda.
Fecha Muestra valores que pueden ser interpretados como fechas con el formato establecido en el cuadro de edición Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa.
Hora Muestra valores que se pueden interpretar como horas en el formato establecido en el cuadro de edición Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa.
Fecha/Hora Muestra los valores que pueden ser interpretados como fecha + hora con el formato establecido en el cuadro Patrón de Formato. Un ejemplo de este formato se muestra en el cuadro de texto Vista Previa.
Intervalo Muestra la hora como un incremento secuencial de tiempo (es decir formato = mm muestra el valor como un número de minutos desde que comenzó el calendario (1899:12:30:24:00).
Mostrar en porcentaje (%) Esta casilla de verificación afecta a los siguientes formatos: Número, Entero y Fijo.

Los separadores de Decimal y de Miles pueden configurarse en las casillas de edición del grupo Separadores.

El botón ISOestablece el formato de la hora, fecha y fecha-hora conforme al estándar ISO.

El botón Sistema aplica al formato las configuraciones del sistema.

El botón Cambiar Formato de Documento abre la página Propiedades de Documento: Número, donde se puede editar el formato numérico predeterminado de cualquier campo.

Fuente

Aquí se puede establecer la Fuente, el Estilo de Fuente y el Tamaño de la fuente que se empleará.

La fuente se puede configurar para un único objeto cualquiera (en Propiedades de Objeto: Fuente), o para todos los objetos de un documento (Aplicar a Objetos en Propiedades de Documento: Fuente).

Además, las fuentes predefinidas para nuevos objetos se pueden configurar en Propiedades de Documento: Fuente. Hay dos fuentes predefinidas:

  1. La primera fuente predefinida (Cuadros de Lista, Gráficos, etc.) es la que se emplea en la mayoría de los objetos, incluidos los cuadros de lista y los gráficos.
  2. La segunda fuente predefinida (Objetos de Texto / Botones) es la que se utiliza para los botones y cuadros de texto, que son objetos que normalmente necesitan un tipo de letra de mayor tamaño.

Por último, las fuentes predefinidas para nuevos documentos se pueden fijar en Preferencias de Usuario: Fuente.

Para los gráficos, botones y objetos de texto (excepto los objetos de búsqueda) también se puede especificar un Color de fuente. El color puede ser Fijo o Calculado dinámicamente desde una expresión. La expresión deberá ser una representación válida de color, la cual se crea empleando las funciones de color. Si el resultado de la expresión no es una representación válida de color, la fuente de color volverá al negro por defecto.

Funciones de color

Otros parámetros adicionales son:

Sombreado Si está marcada esta opción, se añadirá un sombreado al texto.
Subrayado Si está marcada esta opción, el texto se subrayará.

Un ejemplo de la fuente seleccionada se muestra en el panel de vista previa.

Diseño

Un parámetro de diseño solo se aplicará al objeto actual si se realiza desde la página de Propiedades del Objeto.
Un parámetro de diseño se aplicará a todos los objetos de los tipos especificados en el documento, si se realiza desde la página de Propiedades del Documento.

Utilizar Bordes

Habilite este parámetro si desea utilizar un borde alrededor del objeto de hoja. Especifique el tipo de borde seleccionándolo en el menú desplegable.

Intensidad de Sombreado El menú desplegable Intensidad de Sombreado permite establecer la intensidad del sombreado que rodea a los objetos de hoja. También existe la opción de Sin Sombreado.
Estilo de Borde Están disponibles los siguientes tipos de borde predefinidos:
Sólido
Un borde de un solo color.
Hundido
Un borde que da la impresión de hundir el objeto de hoja desde el fondo.
Elevado
Un borde que da la impresión de elevar el objeto de hoja desde el fondo.
Enmarcado
Un borde que de la impresión de un muro alrededor del objeto de hoja.
Ancho de Borde Esta opción está disponible para todos los tipos de borde. El ancho puede especificarse en mm, cm, pulgadas ("), píxeles (px,pxl,pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Color Haga clic en este botón para abrir un cuadro de diálogo que permite elegir un color de base apropiado en la paleta de colores para todos los tipos de borde.
Arcoiris Crea un borde con los colores del arco iris para todos los tipos de borde. El arco iris comenzará con el color básico seleccionado en la parte superior del objeto de hoja.

Cuando Simplificado es el Modo de Asignación de Estilo elegido en Propiedades de Documento: General, no hay elección posible en cuanto al tipo de borde, solo está el menú desplegable Intensidad de Sombreado y el parámetro Ancho de Borde.

Esquinas Redondeadas

En el grupo Esquinas Redondeadas se puede definir la forma general de un objeto. Estas configuraciones permiten trazar objetos de hoja que van desde círculos perfectos hasta formas elípticas o rectangulares: Esquinas Redondeadas solo está disponible si hemos seleccionado antes Avanzado en Modo de Asignación de Estilo, en Propiedades de Documento: General.

Esquinas Redondeadas Si marca esta opción, podrá hacer las esquinas redondeadas.
Esquinas Las esquinas que no tengan la opción marcada se dibujarán como rectangulares.
Inclinación Es un número variable entre 2 y 100 donde 100 define un rectángulo con esquinas cuadradas y 2 corresponde a una elipse perfecta (un círculo elipsoide con un ratio de aspecto de 1:1). Una inclinación entre 2 y 5 es óptima para conseguir esquinas redondeadas.
Ángulo de Redondeo Este parámetro determina el radio de las esquinas en distancia fija (Fijo) o como un porcentaje del cuadrante total (Relativo (%)). Este parámetro le permitirá controlar hasta qué punto se verán afectadas las esquinas por la forma general definida en Inclinación. La distancia se puede especificar en mm, cm, pulgadas, ('', pulgada), píxeles (px,pxl,pixel), puntos (pt, pts, punto) o unidades de documento (du, docunit).

Capa

En el grupo Capa, un objeto puede definirse como residente en una de estas tres capas:

Inferior Un objeto de hoja con la propiedad de capa Inferior nunca podrá hacer sombra o tapar a objetos que pertenezcan a las capas Normal y Superior. Solo podrá ubicarse sobre otros objetos de hoja de la misma capa Inferior.
Normal Al crearse, los objetos de hoja residen en la capa Normal (capa intermedia). Un objeto de hoja en la capa Normal nunca podrá ser oscurecido por objetos de hoja de la capa Inferior y nunca podrá tapar a objetos de hoja de la capa Superior.
Superior Un objeto de hoja en la capa Superior no puede ser nunca tapado por objetos de hoja de las capas Normal e Inferior. Sin embargo, es posible ubicar otros objetos de hoja de la capa Superior encima de él.
Personalizado Las capas Superior, Normal e Inferior se corresponden con las capas internamente numeradas 1, 0 y -1 respectivamente. De hecho se aceptan todos los valores entre -128 y 127. Escoja esta opción para introducir un valor de su elección.

Plantillas...

Abre el asistente de Creación de Plantillas con el que podrá crear una plantilla de diseño.

Aplicar Plantilla…

Puede aplicar una plantilla de diseño al objeto, la hoja o el documento.

Plantillas de Diseño

Mostrar

En el grupo Mostrar se puede especificar una condición bajo la que se mostrará el objeto de hoja:

Siempre El objeto de hoja siempre se mostrará.
Condicional

El objeto de hoja se mostrará u ocultará dependiendo de una función condicional que será evaluada continuamente dependiendo por ej. de las selecciones efectuadas, etc. El objeto de hoja solo se ocultará cuando la condición devuelva FALSO.

Funciones condicionales

Nota:

Los usuarios con privilegios de administrador sobre el documento pueden omitir todas estas condiciones seleccionando Mostrar todas las hojas y objetos de hoja en la página Propiedades de Documento: Seguridad. Esta funcionalidad se puede cambiar pulsando Ctrl+Mayús+S.

Propiedades de Documento: Seguridad

Opciones

En el grupo Opciones se puede desactivar la posibilidad de mover y redimensionar el objeto de hoja. Las configuraciones de este grupo solo son relevantes si están habilitadas las correspondientes casillas de verificación en Propiedades de Documento: Diseño y Propiedades de Hoja: Seguridad.

Permitir Mover/Ajustar Si se ha desmarcado esta opción será imposible mover o ajustar el objeto de hoja.
Permitir Copiar/ Clonar Si se ha desmarcado esta opción será imposible hacer una copia del objeto de hoja.
Permitir Información

Cuando utilice la función info, se mostrará un icono de información en la barra de título del objeto siempre que un valor de campo tenga información asociada al mismo. Si no quiere que aparezca el icono de información en la barra de título, puede deseleccionar esta opción.

Info

Ajustar a Datos Normalmente los bordes en torno a cualquier tipo de objeto de tabla en QlikView se encogen cuando las selecciones obligan a que el tamaño de la tabla sea menor que el espacio asignado para el objeto de hoja. Al desmarcar esta casilla este ajuste automático de tamaño se desactivará, quedando el espacio sobrante en blanco.

Barras de Desplazamiento

En el grupo Barras de Desplazamiento hallará diversos controles para cambiar el formato de las barras de desplazamiento:

Preservar Posición de Desplazamiento

Con esta opción habilitada, QlikView tratará de mantener la posición de desplazamiento de tablas y gráficos que tengan una barra de desplazamiento cuando se efectúe una selección en otro objeto. La opción debe estar habilitada también en Preferencias de Usuario: Objetos.

Las posiciones de desplazamiento no se mantendrán si cierra el documento.

Botones de Desplazamiento Determina el color del botón de desplazamiento. Seleccione un color haciendo clic en el botón. Observe que los tonos intermedios de gris a menudo son los que mejor resultado dan en el caso de las barras de desplazamiento. Se puede definir cualquier color como color sólido o un degradado mediante el diálogo Área de Color, que se abre haciendo clic en el botón correspondiente.
Fondo de Barra de Desplazamiento

Define el color de fondo de la barra de desplazamiento. Seleccione un color haciendo clic en el botón.

Ancho de Barra de desplazamiento Este control afecta tanto al ancho como al tamaño relativo de los símbolos de las barras de desplazamiento.
Estilo de Desplazamiento

Establece el estilo de la barra de desplazamiento. Seleccione un estilo en el control desplegable. El estilo Clásico corresponde a las barras de desplazamiento 4/5 de QlikView. El estilo Estándar confiere un aspecto más moderno. El estilo Ligero corresponde a una barra más fina, más ligera.

El Modo de Asignación de Estilo debe configurarse como Avanzado para que el estilo de la barra de desplazamiento esté visible. Este parámetro se encuentra en la pestaña General, abriendo el menú desplegable Configuración y seleccionando Propiedades de Documento.

Aplicar a... Abre el diálogo Propiedades de Título y Borde, en el que podrá definir dónde aplicar las propiedades que se establecieron en la página Diseño.

Título

Una configuración de Título solo se aplicará al objeto actual si se realiza desde la página de propiedades del Objeto.
Una configuración de Título se aplicará a todos los objetos del(os) tipo(s) especificado(s) en el documento, si ésta se realiza desde la página de Propiedades del Documento.

En la página Título podrá especificar opciones de diseño que son completamente diferentes a las del diseño general del objeto.

Mostrar Título Cuando se selecciona esta opción, se crea un título en la parte superior del objeto de hoja. Los cuadros de lista y otros "objetos de cuadro" tendrán la opción activada por defecto, mientras que los botones, objetos de texto y objetos de línea/flecha no.
Texto de Título En el cuadro de texto puede introducir un título que se mostrará en el título del objeto de hoja. Utilice el botón Fuente... si desea cambiar el tipo de letra del título.

Puede establecer los colores del título en sus diversos estados. Las configuraciones de Colores Activos y Colores Inactivos se pueden activar indistintamente unas de otras.

Pulse el botón Color de Fondo o Color de Texto para abrir el diálogo Área de Color. El Color de Fondo puede definirse como un color sólido o degradado en el diálogo Área de color. Se puede definir el Color de Texto como Fijo o Calculado utilizando las funciones de color.

Funciones de color

Dividir Texto Si se marca esta opción, el título se mostrará en dos o más filas.
Altura de Título (Líneas) En este cuadro de edición se fija el número de líneas del título.

El tamaño y la posición exactos del objeto QlikView pueden determinarse y ajustarse mediante los parámetros de Tamaño/Posición para el objeto de hoja QlikView Normal o Minimizado. Éstos parámetros se miden en píxeles:

Coord. X Fija la posición horizontal del lado izquierdo del objeto de hoja, en relación con el borde izquierdo de la hoja.
Coord. Y Fija la posición vertical del lado superior del objeto de hoja, en relación con el borde superior de la hoja.
Ancho Fija el ancho del objeto de hoja QlikView.
Altura Fija la altura del objeto de hoja QlikView.

La orientación de la etiqueta de título puede modificarse mediante las opciones de Alineación de Título:

Horizontal La etiqueta puede alinearse horizontalmente a la: Izquierda, Centrado o a la Derecha dentro del área de título.
Vertical La etiqueta puede alinearse verticalmente de forma: Superior, Centrado o Inferior dentro del área del título.

Iconos especiales
Muchos de los comandos de menú de los objetos de hoja pueden configurarse como iconos de título. Seleccione los comandos que se mostrarán como iconos de título marcando la casilla de verificación que aparece a la izquierda de cada comando en la lista.

Nota: Utilice los iconos especiales de título con cuidado. Demasiados iconos pueden confundir al usuario.
Permitir Minimizar Cuando se marca esta opción, se mostrará un icono de minimizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea minimizable. Además, esto hará que el objeto se pueda minimizar haciendo doble clic sobre su título.
Minimizado Automático Esta opción estará disponible cuando Permitir Minimizar esté marcado. Si marca la opción Minimizado Automático para varios objetos de hoja de una misma hoja, se minimizarán automáticamente todos menos uno en cualquier momento. Esto puede resultar útil para, por ejemplo, mostrar de forma alternativa diversos gráficos en una misma área de hoja.
Permitir Maximizar Si marca esta opción se mostrará un icono de maximizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea maximizable. Además, esto hará que el objeto se pueda maximizar haciendo doble clic sobre su título. Si están marcados tanto Permitir Minimizar como Permitir Maximizar a la vez, hacer doble clic dará como resultado un objeto minimizado.
Texto de Ayuda

Aquí podrá introducir un texto de ayuda para mostrarlo en una ventana emergente. El texto de ayuda puede definirse como una fórmula calculada. Esta opción no está disponible a nivel de documento. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Puede introducir, por ejemplo, una descripción del objeto de hoja. Se añadirá un icono de ayuda al título de la ventana del objeto. Cuando el puntero del ratón esté sobre el icono, el texto se mostrará en una ventana emergente.

Propiedades de Título y Borde

En el diálogo Propiedades de Título y Borde puede establecer a qué objetos del documento se aplicarán las propiedades de título y borde.

Aplicar Propiedades a... Marque esta casilla de verificación si desea que los parámetros se apliquen a otros objetos aparte del objeto actual.
1. Elija una de las opciones:
Objetos en esta hoja
Aplica los parámetros a objetos de la hoja actual únicamente. Solo está disponible cuando este diálogo se abre desde la página Diseño de un objeto de hoja.
Objetos en este documento
Aplica los parámetros a todos los objetos del documento.
2. Elija una de las opciones:
Solo este tipo de objeto
Aplica los parámetros a todos los objetos de este tipo. Solo está disponible cuando este diálogo se abre desde la página Diseño de un objeto de hoja.
Todos los tipos de objeto
Aplica los parámetros a todos los objetos.
Establecer por defecto para nuevos objetos en este documento Marque esta casilla de verificación si desea utilizar los parámetros de manera predeterminada (por defecto) para todo nuevo objeto en el documento actual. Sólo está disponible cuando este diálogo se abre desde la página Diseño de un objeto de hoja.

Vista de Árbol en Cuadros de Lista

Si un campo contiene rutas a nodos en una jerarquía, por ej. El mundo/Norte América/USA/California/ValledeNapa, se puede mostrar un cuadro de lista en modo de árbol. La vista de árbol mostrará los nodos indentados, para facilitar así la navegación y permitir al usuario contraer los nodos de forma que una fila del cuadro de lista represente una rama de la jerarquía, en lugar de un nodo en particular.

Las selecciones se realizarán de la forma habitual y por supuesto se podrán hacer múltiples selecciones en distintos niveles de la jerarquía.

Para nodos expandidos y nodos finales se emplea la codificación de color estándar en QlikView. Los nodos contraídos, en cambio, pueden contener una mezcla de diversos estados. En tal caso, el nodo se visualizará en verde sólo si se han seleccionado todos los valores, en gris si todos los valores se han excluido y en blanco en los demás casos. Además, se mostrará un pequeño indicador, que señala el estado de los nodos ocultos.

Cómo crear cuadros de lista y cuadros de tabla con Direct Discovery

Cuadros de lista

Se pueden crear cuadros de lista con campos DIMENSION y campos MEASURE. Cuando utilizamos un campo MEASURE en una expresión de un cuadro de lista, debería emplearse la función aggr() para mostrar el valor agregado del campo MEASURE con un campo DIMENSION. Laa selecciones efectuadas con campos DIMENSION en un cuadro de lista generan consultas SQL en la fuente de datos para crear la tabla asociativa en memoria.

Los campos DETAIL no están disponibles en cuadros de lista.

Nota:

Como los cuadros de lista muestran solo los valores únicos de un campo DIMENSION, la consulta que genera QlikView para mostrar los datos del cuadro de lista utiliza la palabra clave DISTINCT para recuperar datos de la base de datos. Sin embargo, algunas bases de datos requieren que la consulta incluya una clase GROUP BY en lugar de la palabra clave DISTINCT. Si la tabla de Direct Discovery procede de una base de datos que requiere GROUP BY, utilizamos la variable DirectDistinctSupport para modificar el comportamiento predefinido de las consultas DIMENSION.

DirectDistinctSupport

Cuadros de Tabla

Los cuadros de tabla pueden mostrar todos los tipos de campos Direct Discovery y ofrecen una manera de profundizar en los detalles de registros que contienen campos Direct Discovery. Los cuadros de tabla son los únicos objetos de QlikView en los que se pueden utilizar campos designados como DETAIL en la sentencia de carga Direct Query .

Cuando se utilizan campos Direct Discovery en un cuadro de tabla, se fija un umbral para limitar el número de filas mostradas. El límite por defecto es de 1000 registros. El parámetro del límite por defecto puede cambiarse estableciendo la variable DirectTableBoxListThreshold en el script de carga. Por ejemplo:

SET DirectTableBoxListThreshold=5000

El parámetro del límite se aplica únicamente a cuadros de tabla que contengan campos Direct Discovery. Los cuadros de tabla que contienen solo campos en memoria no están limitados por el parámetro DirectTableBoxListThreshold Configuración

No se mostrará ningún campo en el cuadro de tabla hasta que la selección contenga menos registros que el límite del umbral.

Los campos Direct Discovery pueden mezclarse con campos en memoria en un cuadro de tabla. Los cuadros de tabla que contengan solo campos Direct Discovery deberán incluir un campo DIMENSION.

Los cuadros de tabla con datos Direct Discovery muestran todas las filas seleccionadas incluso si contienen datos idénticos. Los cuadros de tabla con datos en memoria, por otra parte, solo muestran una de las filas seleccionadas cuando contienen datos idénticos.