Asistente de Datos Inline

El diálogo Asistente para Datos Inline se abre desde el menú Insertar, Sentencia Load, Load Inline. Sirve para crear sentencias load inline en el script.

El diálogo contiene algo muy parecido a una hoja de cálculo y de hecho funciona como una de ellas en casi todos los aspectos. Tenga en cuenta no obstante que las fórmulas calculadas no se evaluarán en esta hoja de cálculo como se haría por ejemplo en Microsoft Excel.

Cada columna representa un campo que se va a cargar en QlikView mediante una tabla inline. Cada fila es un registro de la tabla. Se selecciona una celda de datos haciendo clic en ella. Se puede introducir a continuación un valor, tecleándolo o pegándolo desde el portapapeles. Pulse Intro o una tecla de flecha para aceptar el valor y desplazarse a otra celda.

La fila superior (etiqueta) está reservada para etiquetas de campos. Haga doble clic en una etiqueta de celda para editarla. Si no se introduce ningún valor se usarán los nombres de campo F1, F2, etc.

Menú Editar

El menú Editar contiene algunos comandos básicos de edición.

Insertar Columna Inserta una nueva columna en blanco si hay una o más columnas seleccionadas.
Eliminar Columna Elimina las columnas seleccionadas.
Insertar Fila Inserta una nueva fila en blanco si hay una o más filas seleccionadas.
Eliminar Fila Elimina la fila seleccionada.

Menú Herramientas

El menú Herramientas contiene el comando Datos de Documento que abre el Asistente de Datos de Documento desde el que podrá pegar valores de campo desde cualquier campo en el documento. En este diálogo podrá ver cuántos valores de campo hay en un campo seleccionado. También puede ser que elija insertar todos los valores, los valores seleccionados o valores excluidos en el asistente inline.

Haga clic en Aceptar para cerrar el cuadro de diálogo y generar una sentencia Load inline que refleje los contenidos de la cuadrícula de la tabla del cuadro de diálogo.