Menú Archivo

El menú Archivo es un menú desplegable en la parte superior de la pantalla, que contiene los siguientes comandos:

Nuevo Abre una nueva ventana QlikView y permite crear un nuevo archivo QlikView.
Abrir Abre una nueva ventana QlikView y permite abrir un archivo QlikView o un fichero plano. Abrir un fichero plano abre automáticamente el Asistente de Archivo. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+O.
Abrir en el Servidor... Abre un diálogo en el que es posible conectar a un Servidor QlikView y navegar en busca de un documento para abrirlo en modo cliente.
Este comando también puede invocarse con el método abreviado de teclado: Ctrl+Mayús+O.
Nota: Al abrir un documento como cliente de un QlikView Server las posibilidades de lo que se puede o no hacer con el documento están restringidas en comparación con las posibilidades de abrirlo como documento local. Como cliente, no es posible añadir o eliminar objetos de hoja, dependiendo de si el documento admite colaboración. No se podrán añadir o eliminar hojas. Además, no se puede acceder a la totalidad de diálogos de propiedades, macros modificadas, script al que se haya accedido, datos recargados o el documento guardado.
Actualizar Documento Este comando sólo está disponible con documentos abiertos en QlikView Server y cuando haya una nueva versión del documento disponible en el servidor. Cuando invoque una actualización, se obtiene el acceso a los últimos datos al tiempo que mantiene su sesión, incluido el estado de las selecciones y el diseño.
Abrir URL Abre el cuadro de diálogo Abrir URL. En este cuadro de diálogo, introduzca una URL válida de acceso a cualquier página web. La página web se abrirá en una ventana aparte, dentro de QlikView. Esta funcionalidad puede emplearse, por ejemplo, para abrir QlikView Publisher Accesspoint o páginas que muestren los documentos de QlikView Server a través de clientes AJAX. Se puede acceder a las páginas web abiertas a través del menú Windows, igual que se haría con cualquiera de las ventanas estándar de un documento QlikView.
Abrir FTP Abre una nueva ventana QlikView, permite la apertura de un archivo QlikView o fichero plano desde un servidor Ftp. Abrir un fichero plano abre automáticamente el Asistente de Archivo.
Cerrar Cierra el archivo QlikView que estuviera activo.
Favoritos Este menú en cascada controla una lista de documentos favoritos definida por el usuario, gestionados de forma aislada e independientemente de la lista de Documentos recientes (ver más abajo).
Guardar

Guarda la configuración actual en un archivo QlikView. Se guardan los datos, el script y el diseño. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+S.

Si deseamos compartir un documento QlikView utilizando clientes AJAX, el nombre de archivo no debe contener caracteres hash (#).

Guardar como

Guarda la configuración actual en un nuevo archivo QlikView bajo un nuevo nombre de archivo. Este comando también puede invocarse con el método abreviado de teclado: F12.

Si deseamos compartir un documento QlikView utilizando clientes AJAX, el nombre de archivo no debe contener caracteres hash (#).

Guardar enlace Guarda el enlace a un documento abierto en un QlikView Server como archivo de texto en la máquina local. El archivo tendrá extensión qvw pero no contendrá ningún dato ni formato de diseño alguno. Al abrir este documento enlace, QlikView intentará reconectarse al servidor y abrir el documento en el QlikView Server. Este comando no está disponible para documentos locales.
Enviar como Adjunto... Únicamente disponible cuando se trabaja con un documento local. Crea un correo electrónico con una copia adjunta del actual documento qvw. El receptor de dicho correo electrónico podrá abrir el documento qvw siempre y cuando tenga acceso a QlikView y derechos de acceso al documento (si se emplea seguridad de sección de acceso). Para que funcione este comando, debe haberse configurado un cliente de correo en el PC.
Enviar con Marcador como Enlace Únicamente disponible cuando se trabaja con un documento QlikView Server. Crea un correo electrónico con un enlace URL al documento actual del servidor. Se creará un marcador temporal de servidor (incluyendo el estado de diseño) y codificado en la URL. El receptor de dicho correo electrónico podrá utilizar el enlace URL para abrir el documento del servidor y ver lo que usted esté viendo, siempre y cuando obviamente tenga derechos de acceso al documento y a los datos del mismo. Para que este comando funcione debe haberse configurado un cliente de correo en el PC. El servidor QlikView Server debe estar configurado para admitir marcadores de servidor.
Imprimir Abre el diálogo estándar Imprimir, permitiendo imprimir el objeto de hoja actual. Este comando no está disponible para los cuadros de lista. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+P.
Imprimir como PDF... Abre el cuadro de diálogo Imprimir con la impresora PDF-XChange 3.0 preseleccionada. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+Mayús+P.
Imprimir Valores Posibles... Abre el diálogo estándar Imprimir, que permite imprimir los valores posibles (seleccionados y opcionales) del cuadro de lista actual. Este comando sólo está disponible para cuadros de lista.
Imprimir Valores Posibles como PDF Esta opción debe utilizarse cuando se impriman cuadros de lista y cuadros múltiples como PDF.
Imprimir Hoja Abre el diálogo Imprimir, que permite imprimir una imagen de la hoja actual.
Vista Previa Muestra una vista previa de objetos de hoja imprimibles.
Control de Versiones (source control) Configuración
Conjunto que utiliza el dll del proveedor MSSCCI (Microsoft Source Code Control Interface) para utilizarlo cuando se añade un proyecto o se descarga un proyecto de source control.

Añadir Proyecto a Source Control
Guarda el documento QlikView y crea automáticamente una carpeta de proyecto con los archivos de proyecto. Invoca el sistema de source control para incorporar el proyecto a source control.

Obtener Proyecto de Source Control
Recupera un proyecto de source control y reconstruye el documento QlikView a partir de los archivos de proyecto. Los datos QlikView no se almacenan en source control. Para rellenar el documento con los datos, deberá ejecutarse el comando Ejecutar Script.

Obtener Última Versión
Recupera la última versión del documento del sistema source control y reconstruye el documento QlikView.

Subir Cambios
Guarda el documento QlikView y realiza una operación de entrada o subida de datos (check in) en el sistema source control. Esto incluye cuatro operaciones diferentes en source control, con sus respectivos diálogos:
  • Añadir los archivos de nueva creación.
  • Deshacer los archivos checked out (extraídos) que necesitan ser borrados del sistema source control.
  • Eliminar los archivos que se corresponden con las hojas eliminadas u objetos de hoja que forman parte de source control.
  • Check in (subir y guardar) los archivos modificados.

Si el documento no estaba actualizado antes de subir los cambios, entonces reabra el documento para cargar los cambios en el proyecto los cuales pueden introducirse antes de resolverse los conflictos.

 

Deshacer Cambios
Deshace los cambios. Si hubiera archivos modificados localmente que no han sido introducidos en el sistema de control de versiones, dichos archivos son extraídos antes de efectuarse la operación de Check Out. Esta operación reconstruye el documento QlikView, eliminando los archivos que fueron añadidos y no subidos (checked in) y restaura las referencias a posibles archivos perdidos.
Exportar Exportar Contenidos...
Esta alternativa solo está disponible cuando un objeto de hoja exportable está activo. En ese caso, realiza la operación de exportación que se encuentra en el menú Objeto del objeto de hoja.

Exportar Imagen de Hoja...
Abre un diálogo para guardar una imagen de la hoja actual en un archivo.

Exportar Diseño de Documento
Abre un cuadro de diálogo para guardar el diseño de la hoja actual como un archivo XML. No se guardarán datos del documento en el archivo XML.
Editor de Script... Abre el diálogo Editor de Script. Aquí podrá escribir y ejecutar sentencias de script que abren y conectan con las bases de datos.
Recargar Ejecuta el script de carga actual y recarga los datos en el documento QlikView activo. Este proceso es imprescindible si la base de datos ha cambiado de contenidos desde la última vez que se cargó. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+R.
Recarga Parcial Ejecuta el script de carga actual, incluidos todos los comandos de script, como por ejemplo Drop table, y recarga los datos del documento QlikView activo. Sin embargo, sólo se recargan aquellas tablas cuyas sentencias load y select vayan precedidas por el prefijo Replace o Add. A las tablas de datos que no se vean afectadas por este tipo de sentencias load o select tampoco les afectará la recarga parcial. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+Mayús+R.
Reducir Datos Abre un menú que contiene los dos comandos siguientes:

Mantener Valores Posibles
Reduce la base de datos de QlikView eliminando todos los valores excluidos.

Eliminar Todos los Valores
Crea una plantilla eliminando todos los valores de la base de datos de QlikView pero manteniendo la estructura de la base de datos y el diseño.
Visor de Tablas Abre el diálogo Visor de Tablas donde se puede analizar la estructura de los datos cargados de una manera gráfica, en tablas, campos y asociaciones. Este comando también puede invocarse con el método abreviado de teclado: Ctrl+T.
Lista de Documentos Recientes Una lista con los últimos documentos utilizados por QlikView. El número de documentos mostrados se puede definir en el diálogo Configuración: Preferencias de Usuario. El número por defecto es 8. Seleccionar uno de ellos equivale al comando Abrir.
Exit Cierra el documento que estaba abierto y sale de QlikView.