Objeto Personalizado

El objeto personalizado es un objeto de hoja cuya finalidad específica es la de alojar controles externos OCX definidos de forma personalizada.

Se puede acceder al menú Objeto Personalizado: Objeto, desde el menú Objeto cuando el objeto personalizado es el objeto activo.

Los controles externos o de reemplazo son controles OCX sin ventanas, programados por Qlik, por usted mismo, o por terceros proveedores, que han de cumplir con las especificaciones para los controles externos OCX de QlikView. El control OCX se trazará en un rectángulo de la hoja, delimitado por el objeto personalizado subyacente. La comunicación entre el control OCX y el documento QlikView se mantiene mediante el intérprete de macros interno de QlikView.

Intérprete Interno de Macros.

Menú Objeto

El menú Objeto del objeto personalizado se abre haciendo clic con el botón derecho en el objeto. Los comandos del menú son los siguientes:

Propiedades para el Control Externo Abre el cuadro de diálogo de Propiedades del control externo OCX empleado. Este cuadro de diálogo lo proporciona el control externo OCX y podría faltar.
Propiedades... Abre el cuadro de diálogo Propiedades del Objeto Personalizado donde se pueden configurar una serie de parámetros.
Ordenar

Este menú en cascada solo está disponible cuando el comando de la Rejilla de Diseño del menú Ver está activado o cuando se ha marcado la opción Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño. Contiene cuatro comandos para fijar la capa de diseño de los objetos de hoja. Los números válidos de capa van desde -128 a 127.

Traer al Frente
Fija la capa de diseño del objeto de hoja en el mayor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Enviar Atrás
Fija la capa de diseño del objeto de hoja en el menor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Adelantar
Incrementa la capa de diseño del objeto de hoja en un valor. El valor máximo es 127.

Atrasar
Reduce la capa de diseño del objeto de hoja en un valor. El valor mínimo es -128.


Copiar al Portapapeles Este menú contiene las diversas opciones de copia disponibles para el objeto de hoja.
Imagen
Copia una imagen, en modo mapa de bits, del objeto personalizado en el portapapeles. La imagen incluirá o excluirá el título y el borde del objeto de hoja, dependiendo de los parámetros definidos en el diálogo Preferencias de Usuario, página Exportar.
Objeto
Copia el objeto de hoja completo en el portapapeles para poder pegarlo posteriormente en cualquier parte del diseño o en otro documento abierto en la misma sesión actual de QlikView.
Objetos enlazados

Abre un menú con los siguientes comandos relativos a los objetos enlazados.
Ajustar Posición de Objetos Enlazados
Todos los objetos enlazados de todas las hojas se ajustan a la misma posición y tamaño que el de el/los objetos resaltados.
Desenlazar Este Objeto/Desenlazar Objetos
Esto elimina el enlace que había entre los objetos, convirtiéndolos en objetos diferentes con diferentes ID de objeto.

Minimizar Convierte el objeto en un icono. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activada la opción minimizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Maximizar Expande el objeto hasta llenar la hoja. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activa la opción maximizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Restaurar Restaura un objeto maximizado o minimizado a su posición y tamaño anteriores. Hacer doble clic en el icono de un objeto minimizado o hacer clic en el título del objeto (si se muestra) de un objeto maximizado ofrece el mismo resultado. Este comando solo está disponible para objetos minimizados o maximizados.
Ayuda Abre la ayuda de QlikView.
Eliminar Elimina el objeto de la hoja.

General

La página Propiedades de Objeto Personalizado: General se abre haciendo clic con el botón derecho sobre un objeto personalizado y eligiendo el comando Propiedades en el menú contextual. Aquí es donde se pueden establecer configuraciones de título, etc. para el objeto personalizado.

 

OCX Seleccionado Actualmente El nombre del control externo OCX seleccionado actualmente.
ID de Objeto

Esta opción se utiliza para macros. A cada objeto de hoja se le asigna un ID único. Le recomendamos utilizar caracteres alfanuméricos solo en la ID. Para los objetos personalizados, el ID empieza por CO01. Los objetos enlazados comparten un mismo ID de objeto. Podrá editar este número ID más adelante.

Intérprete Interno de Macros

Seleccionar Control Externo OCX Haga clic sobre este botón para abrir el cuadro de diálogo Insertar Objeto donde puede seleccionar o cambiar un Control Externo OCX.
Propiedades de OCX Abre el cuadro de diálogo de Propiedades del control externo OCX empleado. Este cuadro de diálogo está programado por el proveedor del control externo OCX y puede variar en apariencia y funcionalidad. También puede estar no disponible para ciertos controles externos.
Estado Alterno Seleccione uno de los estados disponibles en el desplegable. Los siguientes Estados Alternos están siempre disponibles.
Heredado
Las hojas y objetos de hoja siempre se encuentran en estado heredado a menos que el desarrollador de QlikView lo modifique. Este parámetro se hereda del objeto del nivel superior, un gráfico de una hoja recibe los mismos parámetros de la hoja si se ha elegido la opción heredado.
Estado predefinido
Es el estado en el que más uso se hace de QlikView y viene representado por el signo $. El documento QlikView se halla siempre por defecto en el estado predefinido.

Diseño

Un parámetro de diseño solo se aplicará al objeto actual si se realiza desde la página de Propiedades del Objeto.
Un parámetro de diseño se aplicará a todos los objetos de los tipos especificados en el documento, si se realiza desde la página de Propiedades del Documento.

Utilizar Bordes

Habilite este parámetro si desea utilizar un borde alrededor del objeto de hoja. Especifique el tipo de borde seleccionándolo en el menú desplegable.

Intensidad de Sombreado El menú desplegable Intensidad de Sombreado permite establecer la intensidad del sombreado que rodea a los objetos de hoja. También existe la opción de Sin Sombreado.
Estilo de Borde Están disponibles los siguientes tipos de borde predefinidos:
Sólido
Un borde de un solo color.
Hundido
Un borde que da la impresión de hundir el objeto de hoja desde el fondo.
Elevado
Un borde que da la impresión de elevar el objeto de hoja desde el fondo.
Enmarcado
Un borde que de la impresión de un muro alrededor del objeto de hoja.
Ancho de Borde Esta opción está disponible para todos los tipos de borde. El ancho puede especificarse en mm, cm, pulgadas ("), píxeles (px,pxl,pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Color Haga clic en este botón para abrir un cuadro de diálogo que permite elegir un color de base apropiado en la paleta de colores para todos los tipos de borde.
Arcoiris Crea un borde con los colores del arco iris para todos los tipos de borde. El arco iris comenzará con el color básico seleccionado en la parte superior del objeto de hoja.

Cuando Simplificado es el Modo de Asignación de Estilo elegido en Propiedades de Documento: General, no hay elección posible en cuanto al tipo de borde, solo está el menú desplegable Intensidad de Sombreado y el parámetro Ancho de Borde.

Esquinas Redondeadas

En el grupo Esquinas Redondeadas se puede definir la forma general de un objeto. Estas configuraciones permiten trazar objetos de hoja que van desde círculos perfectos hasta formas elípticas o rectangulares: Esquinas Redondeadas solo está disponible si hemos seleccionado antes Avanzado en Modo de Asignación de Estilo, en Propiedades de Documento: General.

Esquinas Redondeadas Si marca esta opción, podrá hacer las esquinas redondeadas.
Esquinas Las esquinas que no tengan la opción marcada se dibujarán como rectangulares.
Inclinación Es un número variable entre 2 y 100 donde 100 define un rectángulo con esquinas cuadradas y 2 corresponde a una elipse perfecta (un círculo elipsoide con un ratio de aspecto de 1:1). Una inclinación entre 2 y 5 es óptima para conseguir esquinas redondeadas.
Ángulo de Redondeo Este parámetro determina el radio de las esquinas en distancia fija (Fijo) o como un porcentaje del cuadrante total (Relativo (%)). Este parámetro le permitirá controlar hasta qué punto se verán afectadas las esquinas por la forma general definida en Inclinación. La distancia se puede especificar en mm, cm, pulgadas, ('', pulgada), píxeles (px,pxl,pixel), puntos (pt, pts, punto) o unidades de documento (du, docunit).

Capa

En el grupo Capa, un objeto puede definirse como residente en una de estas tres capas:

Inferior Un objeto de hoja con la propiedad de capa Inferior nunca podrá hacer sombra o tapar a objetos que pertenezcan a las capas Normal y Superior. Solo podrá ubicarse sobre otros objetos de hoja de la misma capa Inferior.
Normal Al crearse, los objetos de hoja residen en la capa Normal (capa intermedia). Un objeto de hoja en la capa Normal nunca podrá ser oscurecido por objetos de hoja de la capa Inferior y nunca podrá tapar a objetos de hoja de la capa Superior.
Superior Un objeto de hoja en la capa Superior no puede ser nunca tapado por objetos de hoja de las capas Normal e Inferior. Sin embargo, es posible ubicar otros objetos de hoja de la capa Superior encima de él.
Personalizado Las capas Superior, Normal e Inferior se corresponden con las capas internamente numeradas 1, 0 y -1 respectivamente. De hecho se aceptan todos los valores entre -128 y 127. Escoja esta opción para introducir un valor de su elección.

Plantillas...

Abre el asistente de Creación de Plantillas con el que podrá crear una plantilla de diseño.

Aplicar Plantilla…

Puede aplicar una plantilla de diseño al objeto, la hoja o el documento.

Plantillas de Diseño

Mostrar

En el grupo Mostrar se puede especificar una condición bajo la que se mostrará el objeto de hoja:

Siempre El objeto de hoja siempre se mostrará.
Condicional

El objeto de hoja se mostrará u ocultará dependiendo de una función condicional que será evaluada continuamente dependiendo por ej. de las selecciones efectuadas, etc. El objeto de hoja solo se ocultará cuando la condición devuelva FALSO.

Funciones condicionales

Nota:

Los usuarios con privilegios de administrador sobre el documento pueden omitir todas estas condiciones seleccionando Mostrar todas las hojas y objetos de hoja en la página Propiedades de Documento: Seguridad. Esta funcionalidad se puede cambiar pulsando Ctrl+Mayús+S.

Propiedades de Documento: Seguridad

Opciones

En el grupo Opciones se puede desactivar la posibilidad de mover y redimensionar el objeto de hoja. Las configuraciones de este grupo solo son relevantes si están habilitadas las correspondientes casillas de verificación en Propiedades de Documento: Diseño y Propiedades de Hoja: Seguridad.

Permitir Mover/Ajustar Si se ha desmarcado esta opción será imposible mover o ajustar el objeto de hoja.
Permitir Copiar/ Clonar Si se ha desmarcado esta opción será imposible hacer una copia del objeto de hoja.
Permitir Información

Cuando utilice la función info, se mostrará un icono de información en la barra de título del objeto siempre que un valor de campo tenga información asociada al mismo. Si no quiere que aparezca el icono de información en la barra de título, puede deseleccionar esta opción.

Info

Ajustar a Datos Normalmente los bordes en torno a cualquier tipo de objeto de tabla en QlikView se encogen cuando las selecciones obligan a que el tamaño de la tabla sea menor que el espacio asignado para el objeto de hoja. Al desmarcar esta casilla este ajuste automático de tamaño se desactivará, quedando el espacio sobrante en blanco.

Barras de Desplazamiento

En el grupo Barras de Desplazamiento hallará diversos controles para cambiar el formato de las barras de desplazamiento:

Preservar Posición de Desplazamiento

Con esta opción habilitada, QlikView tratará de mantener la posición de desplazamiento de tablas y gráficos que tengan una barra de desplazamiento cuando se efectúe una selección en otro objeto. La opción debe estar habilitada también en Preferencias de Usuario: Objetos.

Las posiciones de desplazamiento no se mantendrán si cierra el documento.

Botones de Desplazamiento Determina el color del botón de desplazamiento. Seleccione un color haciendo clic en el botón. Observe que los tonos intermedios de gris a menudo son los que mejor resultado dan en el caso de las barras de desplazamiento. Se puede definir cualquier color como color sólido o un degradado mediante el diálogo Área de Color, que se abre haciendo clic en el botón correspondiente.
Fondo de Barra de Desplazamiento

Define el color de fondo de la barra de desplazamiento. Seleccione un color haciendo clic en el botón.

Ancho de Barra de desplazamiento Este control afecta tanto al ancho como al tamaño relativo de los símbolos de las barras de desplazamiento.
Estilo de Desplazamiento

Establece el estilo de la barra de desplazamiento. Seleccione un estilo en el control desplegable. El estilo Clásico corresponde a las barras de desplazamiento 4/5 de QlikView. El estilo Estándar confiere un aspecto más moderno. El estilo Ligero corresponde a una barra más fina, más ligera.

El Modo de Asignación de Estilo debe configurarse como Avanzado para que el estilo de la barra de desplazamiento esté visible. Este parámetro se encuentra en la pestaña General, abriendo el menú desplegable Configuración y seleccionando Propiedades de Documento.

Aplicar a... Abre el diálogo Propiedades de Título y Borde, en el que podrá definir dónde aplicar las propiedades que se establecieron en la página Diseño.

Título

Una configuración de Título solo se aplicará al objeto actual si se realiza desde la página de propiedades del Objeto.
Una configuración de Título se aplicará a todos los objetos del(os) tipo(s) especificado(s) en el documento, si ésta se realiza desde la página de Propiedades del Documento.

En la página Título podrá especificar opciones de diseño que son completamente diferentes a las del diseño general del objeto.

Mostrar Título Cuando se selecciona esta opción, se crea un título en la parte superior del objeto de hoja. Los cuadros de lista y otros "objetos de cuadro" tendrán la opción activada por defecto, mientras que los botones, objetos de texto y objetos de línea/flecha no.
Texto de Título En el cuadro de texto puede introducir un título que se mostrará en el título del objeto de hoja. Utilice el botón Fuente... si desea cambiar el tipo de letra del título.

Puede establecer los colores del título en sus diversos estados. Las configuraciones de Colores Activos y Colores Inactivos se pueden activar indistintamente unas de otras.

Pulse el botón Color de Fondo o Color de Texto para abrir el diálogo Área de Color. El Color de Fondo puede definirse como un color sólido o degradado en el diálogo Área de color. Se puede definir el Color de Texto como Fijo o Calculado utilizando las funciones de color.

Funciones de color

Dividir Texto Si se marca esta opción, el título se mostrará en dos o más filas.
Altura de Título (Líneas) En este cuadro de edición se fija el número de líneas del título.

El tamaño y la posición exactos del objeto QlikView pueden determinarse y ajustarse mediante los parámetros de Tamaño/Posición para el objeto de hoja QlikView Normal o Minimizado. Éstos parámetros se miden en píxeles:

Coord. X Fija la posición horizontal del lado izquierdo del objeto de hoja, en relación con el borde izquierdo de la hoja.
Coord. Y Fija la posición vertical del lado superior del objeto de hoja, en relación con el borde superior de la hoja.
Ancho Fija el ancho del objeto de hoja QlikView.
Altura Fija la altura del objeto de hoja QlikView.

La orientación de la etiqueta de título puede modificarse mediante las opciones de Alineación de Título:

Horizontal La etiqueta puede alinearse horizontalmente a la: Izquierda, Centrado o a la Derecha dentro del área de título.
Vertical La etiqueta puede alinearse verticalmente de forma: Superior, Centrado o Inferior dentro del área del título.

Iconos especiales
Muchos de los comandos de menú de los objetos de hoja pueden configurarse como iconos de título. Seleccione los comandos que se mostrarán como iconos de título marcando la casilla de verificación que aparece a la izquierda de cada comando en la lista.

Nota: Utilice los iconos especiales de título con cuidado. Demasiados iconos pueden confundir al usuario.
Permitir Minimizar Cuando se marca esta opción, se mostrará un icono de minimizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea minimizable. Además, esto hará que el objeto se pueda minimizar haciendo doble clic sobre su título.
Minimizado Automático Esta opción estará disponible cuando Permitir Minimizar esté marcado. Si marca la opción Minimizado Automático para varios objetos de hoja de una misma hoja, se minimizarán automáticamente todos menos uno en cualquier momento. Esto puede resultar útil para, por ejemplo, mostrar de forma alternativa diversos gráficos en una misma área de hoja.
Permitir Maximizar Si marca esta opción se mostrará un icono de maximizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea maximizable. Además, esto hará que el objeto se pueda maximizar haciendo doble clic sobre su título. Si están marcados tanto Permitir Minimizar como Permitir Maximizar a la vez, hacer doble clic dará como resultado un objeto minimizado.
Texto de Ayuda

Aquí podrá introducir un texto de ayuda para mostrarlo en una ventana emergente. El texto de ayuda puede definirse como una fórmula calculada. Esta opción no está disponible a nivel de documento. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Puede introducir, por ejemplo, una descripción del objeto de hoja. Se añadirá un icono de ayuda al título de la ventana del objeto. Cuando el puntero del ratón esté sobre el icono, el texto se mostrará en una ventana emergente.