Botón

En QlikView se pueden crear y definir botones para que ejecuten comandos o acciones. Hay básicamente tres tipos de botones: el botón Lanzar/Exportar, el botón de Acceso Directo y el botón de Macro.

Haciendo clic con el botón derecho en el objeto se muestra el menú Botón: Objeto. También se puede acceder desde el menú Objeto cuando el botón es el objeto activo.

Menú Objeto

El botón Objeto se abre haciendo clic con el botón derecho sobre el objeto. Los comandos del menú son los siguientes:

Propiedades... Abre el cuadro de diálogo Propiedades de Botón donde se pueden configurar una serie de parámetros.
Notas

Permite crear y compartir notas relativas al objeto actual.

Notas y Comentarios

Ordenar

Este menú en cascada solo está disponible cuando el comando de la Rejilla de Diseño del menú Ver está activado o cuando se ha marcado la opción Mostrar Siempre Opciones de Menú de Diseño en Preferencias de Usuario: Diseño. Contiene cuatro comandos para fijar la capa de diseño de los objetos de hoja. Los números válidos de capa van desde -128 a 127.

Traer al Frente
Fija la capa de diseño del objeto de hoja en el mayor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Enviar Atrás
Fija la capa de diseño del objeto de hoja en el menor valor utilizado por cualquiera de los objetos de hoja de la hoja actual.

Adelantar
Incrementa la capa de diseño del objeto de hoja en un valor. El valor máximo es 127.

Atrasar
Reduce la capa de diseño del objeto de hoja en un valor. El valor mínimo es -128.


Enviar a Excel Exporta el texto a Microsoft Excel, el cual es lanzado de inmediato, si es que no estaba ya en ejecución. El texto aparecerá en una única celda en una nueva hoja de Excel. Para que esta funcionalidad opere como es debido es necesario tener instalado Microsoft Excel 2007 o posterior en el equipo.
Copiar al Portapapeles Este menú en cascada contiene las diversas opciones disponibles para el objeto de hoja.
Texto
Copia en el portapapeles el texto mostrado en el botón.
Imagen
Copia una imagen del objeto de hoja en el portapapeles. La imagen incluirá o excluirá el título y el borde del objeto de hoja, dependiendo de los parámetros definidos en el diálogo Preferencias de Usuario, página Exportar.
Objeto
Copia el objeto de hoja completo en el portapapeles para poder pegarlo posteriormente en cualquier parte del diseño o en otro documento abierto en la misma sesión actual de QlikView.
Objetos enlazados

Abre un menú con los siguientes comandos relativos a los objetos enlazados.
Ajustar Posición de Objetos Enlazados
Todos los objetos enlazados de todas las hojas se ajustan a la misma posición y tamaño que el de el/los objetos resaltados.
Desenlazar Este Objeto/Desenlazar Objetos
Esto elimina el enlace que había entre los objetos, convirtiéndolos en objetos diferentes con diferentes ID de objeto.

Minimizar Convierte el objeto en un icono. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activada la opción minimizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Maximizar Expande el objeto hasta llenar la hoja. Hacer clic en el icono en el título del objeto (si se muestra), da el mismo resultado. Este comando solo está disponible si está activa la opción maximizar en el cuadro de diálogo Propiedades del objeto, en la página Título.
Restaurar Restaura un objeto maximizado o minimizado a su posición y tamaño anteriores. Hacer doble clic en el icono de un objeto minimizado o hacer clic en el título del objeto (si se muestra) de un objeto maximizado ofrece el mismo resultado. Este comando solo está disponible para objetos minimizados o maximizados.
Ayuda Abre la ayuda de QlikView.
Eliminar Elimina el objeto de la hoja.

General

En el grupo Texto podrá establecer las propiedades del texto que se mostrará en el botón.

Texto

Si introduce un texto en el campo de texto etiquetará el botón. El texto puede definirse como una fórmula calculada. El texto puede constar de varias líneas, que se separan pulsando Intro.

Sintaxis de Expresión para fórmulas calculadas

Alineación El texto del botón puede alinearse a la izquierda, centrarse o alinearse a la derecha.

En el grupo Fondo podrá definir el fondo del botón. El desplegable le ofrece tres posibles estilos básicos de botón entre los que elegir:

Aqua Opción por defecto para botones de nueva creación. Crea un botón redondeado, con un aspecto acuoso tridimensional.
Plano Crea un botón plano, tradicional en QlikView.
Predeterminado por el sistema
Proporciona un fondo sólido, en el color definido para los botones en el sistema operativo.
Imagen Crea un botón de imagen. La imagen podría ser una única imagen estática, o una imagen combinada, con tres partes, una para cada uno de los tres estados posibles del botón (activo, inactivo o pulsado).
Imagen combinada
Marque este botón de opción y explore hasta encontrar un archivo de imagen utilizando el botón Seleccionar Imagen... para asignar una imagen combinada de tres estados para el botón. El archivo de imagen deberá contener tres imágenes de un mismo botón, una junto a otra, la primera representando el botón activo, la segunda el botón pulsado y la tercera el botón en gris (inactivo).
Imagen única
Marque este botón de opción y explore hasta hallar un archivo de imagen usando el botón Seleccionar Imagen... para asignar una imagen de un único estado al botón. Los tipos de archivo de imagen que admite son jpg, png, bmp, gif y gif animado.
Color Seleccione este botón de radio si desea que el botón aparezca con un fondo de color (no disponible con el parámetro Imagen). El color puede definirse como color sólido o como un degradado mediante el diálogo Área de Color que se abre al hacer clic sobre el botón de color.
Transparencia Establece el grado de transparencia del fondo del Botón. En 100% el fondo es completamente transparente. La transparencia se aplicará independientemente de que se esté utilizando una imagen o un color para el fondo.
Estado Alterno Seleccione uno de los estados disponibles en el desplegable. Los siguientes Estados Alternos están siempre disponibles.
Heredado
Las hojas y objetos de hoja siempre se encuentran en estado heredado a menos que el desarrollador de QlikView lo modifique. Este parámetro se hereda del objeto del nivel superior, un gráfico de una hoja recibe los mismos parámetros de la hoja si se ha elegido la opción heredado.
Estado predefinido
Es el estado en el que más uso se hace de QlikView y viene representado por el signo $. El documento QlikView se halla siempre por defecto en el estado predefinido.
ID de Objeto Es el identificador único y exclusivo para el botón actual. En el momento de su creación, todo objeto de hoja recibe un ID único para su control mediante Automatización. Este ID consta de una combinación de letras que definen el tipo de objeto y un número. Al primer botón de un documento se le asigna el ID BU01. Los objetos compartidos tienen un mismo ID de objeto. Se puede cambiar el ID de un objeto por cualquier otra cadena que no esté en uso actualmente como ID para cualquier otro objeto de hoja, hoja o marcador en el documento.
Condición Habilitada La expresión aquí introducida determina el estado del botón. Si la expresión devuelve 0, el botón quedará inactivo; si la expresión devuelve 1, el botón quedará activo. Si no se introduce expresión alguna, se presupone 1. Los botones deshabilitados debido a un estado subyacente no pueden activarse mediante una condición.
Configuraciones de Impresión... Pulsando este botón tendrá acceso al diálogo Configuraciones de Impresión, donde podrá definir formatos de cabeceras/pies de página y márgenes.

Acciones

En esta página se pueden establecer determinadas acciones para determinados objetos:

  • Botones
  • Objetos de texto
  • Indicadores
  • Objetos de línea/flecha

Entre las acciones se incluyen lanzar una aplicación externa o exportar datos desde QlikView.

Añadir Abre el diálogo Añadir Acción en el que se eligen las diversas acciones para el objeto. Escoja el tipo de acción en las listas. Dependiendo del tipo de acción escogida, los diferentes parámetros aparecerán en la página Acciones. Las acciones se ejecutarán según el orden en que aparecen en la lista.
Eliminar Elimina la acción del objeto.
Ascender Mueve la acción seleccionada un paso hacia arriba en la lista.
Estado Alterno Determina el estado al que hace referencia la acción. Este parámetro solo es relevante para acciones relacionadas con selecciones o marcadores.

Diálogo Añadir Acción

Se pueden añadir las siguientes acciones desde el diálogo Añadir Acción. En todos los campos con el botón ... se puede introducir una fórmula calculada para actualización dinámica.

Sintaxis de Expresión para fórmulas calculadas

Selección

Seleccionar en Campo Selecciona los valores y campos especificados. En la Cadena de búsqueda puede especificar una máscara de búsqueda; por ejemplo, (A|B) seleccionará tanto A como B. El entrecomillado solo se requiere con valores no numéricos y se puede omitir con valores numéricos.
Seleccionar Valores Excluidos Selecciona los valores excluidos en el campo especificado.
Seleccionar Valores Posibles Selecciona los valores posibles en el campo especificado.
Alternar Select Alterna entre la selección actual y el valor de Campo y Cadena de Búsqueda especificado. En la Cadena de Búsqueda puede especificar una máscara de búsqueda, por ej. (A|B) seleccionará tanto A como B.
Adelante Avanza un paso en la lista de selecciones.
Atrás Retrocede un paso en la lista de selecciones.
Pareto Select Realiza una selección pareto en el campo especificado, basada en una expresión y un porcentaje. Este tipo de selección se emplea para seleccionar aquellos indicadores que contribuyan de manera fundamental a una medida, normalmente según una regla general de 80/20. Por ejemplo, para hallar los principales clientes que contribuyen al 80% de la facturación total, debemos emplear Cliente como campo, sum(Facturación) como expresión y 80 como porcentaje.
Bloquear Campo Bloquea las selecciones en el campo especificado.
Bloquear Todo Bloquea todos los valores de todos los campos.
Desbloquear Campo Desbloquea las selecciones en el campo especificado.
Desbloquear Todo Desbloquea todos los valores de todos los campos.
Desbloquear y Borrar Todo Desbloquea todos los valores y elimina todas las selecciones de todos los campos.
Borrar Otros Campos Borra todos los campos relacionados excepto el que se especifique.
Borrar Todo Borra todas las selecciones excepto las bloqueadas.
Eliminar Campo Borra un determinado campo.
Copiar Contenidos de Estado Copia las selecciones del Estado Fuente al Estado Destino. Sólo está disponible si se han definido estados alternos.
Intercambiar Contenidos de Estado Intercambia las selecciones del Estado 1 con las del Estado 2. Sólo está disponible si se han definido estados alternos.

Diseño

Activar Objeto Activa el objeto especificado por ID de Objeto. Esta función no está operativa en el cliente Ajax.
Activar Hoja Activa la hoja especificada por ID de Hoja.
Activar Hoja Siguiente Abre la siguiente hoja del documento.
Activar Hoja Anterior Abre la hoja previa en el documento.
Minimizar Objeto Minimiza el objeto especificado por ID de Objeto.
Maximizar Objeto Maximiza el objeto especificado por ID de Objeto.
Restaurar Objeto Restaura el objeto especificado por el ID de Objeto.
Fijar Nombre de Estado Aplica el Estado especificado al objeto definido por ID de Objeto. Sólo disponible cuando se hayan definido estados alternos.

Marcador

Aplicar Marcador

Aplica un marcador especificado por el ID de Marcador. Si dos marcadores tuvieran el mismo ID, se aplicará el marcador de documento. Para aplicar el marcador del servidor especifique Server\bookmarkID. 

Crear Marcador

Crea un marcador a partir de la selección actual. Especifique ID de Marcador y Nombre de Marcador. Seleccionar Oculto para crear un marcador oculto.

Reemplazar Marcador

Reemplaza el marcador especificado mediante el ID de Marcador, por la selección actual.

Imprimir

Imprimir Objeto

Imprime el objeto especificado por ID de Objeto. Especifique el Nombre de impresora si el objeto debería enviarse a otra impresora distinta de la especificada por defecto. (No disponible como disparador de hoja o de documento).

Imprimir Hoja

Imprime la hoja especificada por el ID de Hoja. (No disponible como disparador de documentos y hojas). Esta función no está operativa en el cliente AJAX.

Imprimir Informe

Imprime el informe especificado por ID de Informe. Especifique el Nombre de impresora si el informe debería enviarse a otra impresora distinta de la especificada por defecto. Marque la casilla de verificación Mostrar Diálogo de Impresión si desea que aparezca el diálogo de impresión de Windows. (No disponible como disparador de hoja o de documento).

Externo

Exportar

Exporta una tabla con un conjunto específico de campos, pero únicamente se exportarán aquellos registros que son aplicables según la selección efectuada. Pulse el botón Configuración de la página Acciones para abrir el diálogo Exportar Configuraciones de Acción. (No disponible como disparador de documentos y hojas)

Lanzar

Lanza un programa externo. En el diálogo Acciones se pueden configurar los siguientes parámetros:
Aplicación
Haga clic en Explorar... para buscar la aplicación que desee lanzar. (No disponible como disparador de hoja o de documento).
Nombre de archivo
Introduzca la ruta al archivo que deberá abrirse con la aplicación anteriormente especificada. (No disponible como disparador de hoja o de documento).
Parámetros
Especifique los parámetros para la línea de comandos desde la que se inicia la aplicación. (No disponible como disparador de hoja o de documento).
Directorio de Trabajo
Establece el directorio de trabajo para la aplicación que se va a lanzar. (No disponible como disparador de hoja o de documento).
Salir de la aplicación al cerrar QlikView
Fuerza el cierre de la aplicación cuando se sale de QlikView. (No disponible como disparador de hoja o de documento).
Esta función no está operativa en el cliente AJAX.

Abrir URL

Puede usar Abrir URL para abrir una URL a un documento QlikView desde otro documento QlikView (encadenar documentos). Este parámetro abre la URL en el navegador establecido por defecto. Esta función no se puede utilizar como un disparador de documentos y hojas. Si utiliza Abrir URL, asegúrese de introducir el nombre del documento en la cadena de acción en minúsculas.

Cuando sea posible, utilice Abrir Documento QlikView en lugar de Abrir URL.

Abrir Documento QlikView

Puede usar Abrir Documento QlikView para abrir un documento QlikView desde dentro de otro documento QlikView (encadenar documentos). Ha de incluirse la extensión del archivo de destino. Esta función no se puede utilizar como un disparador de documentos y hojas. Las rutas relativas para navegar de un documento QlikView a otro se admiten en todos los clientes siempre que los documentos encadenados se almacenen en la misma estructura de carpetas (montaje).

Ejemplos

Los siguientes ejemplos muestran cómo escribir la ruta de archivo al archivo de destino para configurar el encadenamiento de documentos usando Abrir Documento QlikView.

Example: Archivo ubicado en la misma estructura de carpetas (mismo montaje).

  • Si el archivo de destino está en la misma carpeta:
    DestinationDoc.qvw
  • Si el archivo de destino está en una subcarpeta:
    SubFolder/DestinationDoc.qvw
  • Si el archivo de destino está en una carpeta superior:
    ../DestinationDoc.qvw
  • Si el archivo de destino está en una carpeta superior y paralela:
    ../ParallelFolder/DestinationDoc.qvw

Example: Archivo ubicado en una estructura de carpetas diferente (diferente montaje).

La ruta relativa entre diferentes montajes solo se admite en el cliente Ajax.

  • Si el archivo de destino está en un montaje diferente:
    ../DifferentMount/DestinationDoc.qvw

Example: Usar la ruta del montaje para apuntar a un documento QlikView

La configuración de la ruta a las carpetas montadas solo se admite en el cliente Ajax.

  • Si el archivo de destino está en la misma carpeta montada:
    \Mount\DestinationDoc.qvw
  • Si el archivo de destino está en una carpeta montada diferente:
    \DifferentMount\DestinationDoc.qvw
Nota: El encadenamiento de documentos con carpetas montadas no funciona con el complemento de Internet Explorer (IE).

Example: Usar la ruta absoluta para apuntar a un documento QlikView

El uso de rutas absolutas para el encadenamiento de documentos se admite en el cliente Ajax y en QlikView Desktop.

  • Ruta absoluta a la carpeta raíz local o al montaje:
    C:\...\DestinationDoc.qvw
  • Ruta absoluta a una red compartida:
    \\SharedStorage\...\DestinationDoc.qvw

Seleccione Transferir Estado para transferir las selecciones del documento original al documento de destino. El documento de destino primero verá borrarse sus selecciones.
Seleccione la opción Aplicar estado encima del actual para conservar las selecciones del documento de destino y aplicar las selecciones del documento original sobre las del primero.

Nota: Usar Aplicar estado encima del actual puede devolver resultados inesperados si las selecciones realizadas en los dos documentos se encuentran en conflicto.

Seleccione Abrir en la misma ventana para abrir el documento nuevo en la misma pestaña del navegador cuando se esté usando el cliente AJAX ZFC.

Nota: La acción Abrir Documento QlikView no es posible para usuarios de dominio cuando se trabaja con el plugin de Internet Explorer (IE).

Ejecutar Macro

Introduzca la ruta y el nombre de la macro que se habrá de ejecutar. Puede introducir cualquier nombre para el que posteriormente creará una macro en el diálogo Editor de Módulo, o una expresión calculada para actualización dinámica.

Fijar Variable

Asigna un valor a la variable especificada.

Mostrar Información

Muestra la información asociada, como un archivo de texto o una imagen para el campo especificado por Campo. Esta función no está operativa en el cliente AJAX.

Cerrar Este Documento

Cierra el documento Qlikview activo.

Recargar

Efectúa una recarga del documento. Esta función no está disponible ni en el cliente AJAX ni en el plugin de IE.

Actualización Dinámica.

Lleva a cabo una actualización dinámica de los datos en el documento actual cargado. La sentencia para la actualización dinámica se debe introducir en el campo Sentencia.

La utilización intencionada de la Actualización Dinámica permite a un Administrador QlikView introducir cantidades limitadas de datos en un documento QlikView desde un sistema de control de versiones sin tener que efectuar una recarga del documento. El análisis puede ser realizado a continuación por múltiples clientes conectados al QlikView Server.

Nota: La información cargada se almacena únicamente en la RAM, así que cualquier dato incorporado o actualizado mediante Actualización Dinámica se perderá si se efectúa una recarga del documento.

La gramática a continuación describe las posibles sentencias y sus componentes, los cuales pueden utilizarse con la funcionalidad de Actualización Dinámica:

  • statements ::= statement { “;” statement }
  • statement ::= insert_statement | update_statement | delete_statement | begin_transaction_statement | commit_transaction_statement
  • insert_statement ::= "INSERT" "INTO" ("*" | table_name) field_list "VALUES" value_list {"," value_list} ["KEY" ["AUTO" | (" (" field_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]{"," value_list}
  • update_statement ::= "UPDATE" ("*" | table_name) set_clause {"," | set_clause} "WHERE" condition ["AUTO" "INSERT"]
  • delete_statement ::= "DELETE" "FROM" ("*" | table_name] "WHERE" condition
  • begin_transaction_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans_name]
  • commit_transaction_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans_name]
  • table_name ::= identifier | quoted_name
  • field_list ::= "(" field_name {"," field_name} ")"
  • value_list ::= "("value {"," value} ")"
  • set_clause ::= "SET" field_name "=" any_valid_non_aggregated_qlikview_expression
  • field_name ::= identifier | quoted string
  • value ::= identifier | any_qlikview_number | quoted string
  • condition ::= any_valid_non_aggregated_qlikview_expression
  • identifier ::= any_qlikview_identifier
  • quoted_string ::= "[" [^]]+ "]"

Example:  

UPDATE AbcTable SET Discount = 123 WHERE AbcField=1

Nota: Para utilizar esta funcionalidad, la Actualización Dinámica debe estar habilitada tanto en el Documento como en el Servidor.
Nota: Las acciones que disparan otras acciones, las denominadas "acciones en cascada", pueden traer consecuencias imprevisibles y no se permiten por tanto.
Nota:

Existen limitaciones en cuanto al comportamiento de ciertos disparadores de macros cuando se trabaja con documentos en QlikView Server.

Utilización de Macros en Documentos QV del QV-Server

Diálogo Exportar Configuraciones de Acción

Selección

En este grupo se establece qué campos deben seleccionarse para exportar.

Campos En el recuadro campos se encuentra una lista con los campos disponibles.
Exportar Filas En este cuadro se encuentran los campos que ha seleccionado para exportar. Los campos para los que ha permitido varios valores están marcados con un asterisco.
Añadir >> Añade campos a la ventana Exportar Filas.
<< Eliminar Retira los campos de la ventana Exportar Filas.
Ascender Mueve el campo seleccionado un paso hacia arriba, es decir un paso hacia la izquierda en la tabla de exportación.
Descender Mueve el campo seleccionado un paso hacia abajo, es decir un paso hacia la derecha en la tabla de exportación.
Valor Múltiple (*) Al marcar un campo en la ventana Exportar Filas y al marcar este control, permitirá que un campo tenga varios valores en la lista de exportación.

Exportar a

En este grupo puede elegir si desea exportar los valores a un archivo o al portapapeles.

Archivo

Si desea exportar a un archivo deberá marcar esta casilla e introducir el nombre del archivo. Si no figura ningún nombre, los valores se exportarán al portapapeles. El nombre de archivo introducido puede ser una fórmula calculada.

Sintaxis de Expresión para fórmulas calculadas

Examinar Abre el diálogo Exportar Archivo, el cual le permitirá buscar un archivo al que exportar los valores.
Portapapeles Configuración por defecto. Si no se especifica ningún archivo, los valores se exportarán al portapapeles.
Selecciones de Campo Si está marcada esta opción, el archivo de exportación tendrá, para cada campo seleccionado, una fila con todos los valores de campo posibles en una fila separada por tabuladores.
Incluir Etiquetas Si está marcada esta opción, los nombres de los campos figurarán en la primera posición en la fila (si está marcada la opción Selecciones de Campo ) o el primer registro (si está marcada la opción Registros).
Registros Si está marcada esta opción, el archivo de exportación tendrá una columna para cada campo seleccionado, separado por etiquetas.
Anexar al Archivo Existente Si está marcada esta opción, la exportación se anexará al archivo de exportación, si existe el archivo. Las etiquetas no serán exportadas cuando añadimos a un archivo existente. Si no existe el archivo de exportación, esta opción no tiene sentido.

Formato Numérico

Algunos programas pueden tener problemas a la hora de manejar los formatos numéricos correctamente. QlikView ofrece tres opciones para exportar los formatos numéricos de datos numéricos a archivos o al portapapeles.

Los nuevos botones de exportación heredarán la configuración de la página Preferencias de Usuario: Exportar. No obstante, es posible establecer para cada botón de exportación una configuración individual.

Formato completo Indica a QlikView que exporte los datos numéricos con su formato numérico completo, tal como se muestra en el objeto de hoja del documento.
Separador de Miles sin especificar Elimina de los datos numéricos todo separador de miles.
Sin Formato Elimina todos los formatos numéricos y exporta los números tal cual, sin formato. El separador de decimales será el definido en la configuración del sistema operativo (Panel de Control).
Nota:

Existen limitaciones en cuanto al comportamiento de ciertos disparadores de macros cuando se trabaja con documentos en QlikView Server.

Utilización de Macros en Documentos QV del QV-Server

Fuente

Aquí se puede establecer la Fuente, el Estilo de Fuente y el Tamaño de la fuente que se empleará.

La fuente se puede configurar para un único objeto cualquiera (en Propiedades de Objeto: Fuente), o para todos los objetos de un documento (Aplicar a Objetos en Propiedades de Documento: Fuente).

Además, las fuentes predefinidas para nuevos objetos se pueden configurar en Propiedades de Documento: Fuente. Hay dos fuentes predefinidas:

  1. La primera fuente predefinida (Cuadros de Lista, Gráficos, etc.) es la que se emplea en la mayoría de los objetos, incluidos los cuadros de lista y los gráficos.
  2. La segunda fuente predefinida (Objetos de Texto / Botones) es la que se utiliza para los botones y cuadros de texto, que son objetos que normalmente necesitan un tipo de letra de mayor tamaño.

Por último, las fuentes predefinidas para nuevos documentos se pueden fijar en Preferencias de Usuario: Fuente.

Para los gráficos, botones y objetos de texto (excepto los objetos de búsqueda) también se puede especificar un Color de fuente. El color puede ser Fijo o Calculado dinámicamente desde una expresión. La expresión deberá ser una representación válida de color, la cual se crea empleando las funciones de color. Si el resultado de la expresión no es una representación válida de color, la fuente de color volverá al negro por defecto.

Funciones de color

Otros parámetros adicionales son:

Sombreado Si está marcada esta opción, se añadirá un sombreado al texto.
Subrayado Si está marcada esta opción, el texto se subrayará.

Un ejemplo de la fuente seleccionada se muestra en el panel de vista previa.

Diseño

Un parámetro de diseño solo se aplicará al objeto actual si se realiza desde la página de Propiedades del Objeto.
Un parámetro de diseño se aplicará a todos los objetos de los tipos especificados en el documento, si se realiza desde la página de Propiedades del Documento.

Utilizar Bordes

Habilite este parámetro si desea utilizar un borde alrededor del objeto de hoja. Especifique el tipo de borde seleccionándolo en el menú desplegable.

Intensidad de Sombreado El menú desplegable Intensidad de Sombreado permite establecer la intensidad del sombreado que rodea a los objetos de hoja. También existe la opción de Sin Sombreado.
Estilo de Borde Están disponibles los siguientes tipos de borde predefinidos:
Sólido
Un borde de un solo color.
Hundido
Un borde que da la impresión de hundir el objeto de hoja desde el fondo.
Elevado
Un borde que da la impresión de elevar el objeto de hoja desde el fondo.
Enmarcado
Un borde que de la impresión de un muro alrededor del objeto de hoja.
Ancho de Borde Esta opción está disponible para todos los tipos de borde. El ancho puede especificarse en mm, cm, pulgadas ("), píxeles (px,pxl,pixel), puntos (pt, pts, point) o unidades de documento (du, docunit).
Color Haga clic en este botón para abrir un cuadro de diálogo que permite elegir un color de base apropiado en la paleta de colores para todos los tipos de borde.
Arcoiris Crea un borde con los colores del arco iris para todos los tipos de borde. El arco iris comenzará con el color básico seleccionado en la parte superior del objeto de hoja.

Cuando Simplificado es el Modo de Asignación de Estilo elegido en Propiedades de Documento: General, no hay elección posible en cuanto al tipo de borde, solo está el menú desplegable Intensidad de Sombreado y el parámetro Ancho de Borde.

Esquinas Redondeadas

En el grupo Esquinas Redondeadas se puede definir la forma general de un objeto. Estas configuraciones permiten trazar objetos de hoja que van desde círculos perfectos hasta formas elípticas o rectangulares: Esquinas Redondeadas solo está disponible si hemos seleccionado antes Avanzado en Modo de Asignación de Estilo, en Propiedades de Documento: General.

Esquinas Redondeadas Si marca esta opción, podrá hacer las esquinas redondeadas.
Esquinas Las esquinas que no tengan la opción marcada se dibujarán como rectangulares.
Inclinación Es un número variable entre 2 y 100 donde 100 define un rectángulo con esquinas cuadradas y 2 corresponde a una elipse perfecta (un círculo elipsoide con un ratio de aspecto de 1:1). Una inclinación entre 2 y 5 es óptima para conseguir esquinas redondeadas.
Ángulo de Redondeo Este parámetro determina el radio de las esquinas en distancia fija (Fijo) o como un porcentaje del cuadrante total (Relativo (%)). Este parámetro le permitirá controlar hasta qué punto se verán afectadas las esquinas por la forma general definida en Inclinación. La distancia se puede especificar en mm, cm, pulgadas, ('', pulgada), píxeles (px,pxl,pixel), puntos (pt, pts, punto) o unidades de documento (du, docunit).

Capa

En el grupo Capa, un objeto puede definirse como residente en una de estas tres capas:

Inferior Un objeto de hoja con la propiedad de capa Inferior nunca podrá hacer sombra o tapar a objetos que pertenezcan a las capas Normal y Superior. Solo podrá ubicarse sobre otros objetos de hoja de la misma capa Inferior.
Normal Al crearse, los objetos de hoja residen en la capa Normal (capa intermedia). Un objeto de hoja en la capa Normal nunca podrá ser oscurecido por objetos de hoja de la capa Inferior y nunca podrá tapar a objetos de hoja de la capa Superior.
Superior Un objeto de hoja en la capa Superior no puede ser nunca tapado por objetos de hoja de las capas Normal e Inferior. Sin embargo, es posible ubicar otros objetos de hoja de la capa Superior encima de él.
Personalizado Las capas Superior, Normal e Inferior se corresponden con las capas internamente numeradas 1, 0 y -1 respectivamente. De hecho se aceptan todos los valores entre -128 y 127. Escoja esta opción para introducir un valor de su elección.

Plantillas...

Abre el asistente de Creación de Plantillas con el que podrá crear una plantilla de diseño.

Aplicar Plantilla…

Puede aplicar una plantilla de diseño al objeto, la hoja o el documento.

Plantillas de Diseño

Mostrar

En el grupo Mostrar se puede especificar una condición bajo la que se mostrará el objeto de hoja:

Siempre El objeto de hoja siempre se mostrará.
Condicional

El objeto de hoja se mostrará u ocultará dependiendo de una función condicional que será evaluada continuamente dependiendo por ej. de las selecciones efectuadas, etc. El objeto de hoja solo se ocultará cuando la condición devuelva FALSO.

Funciones condicionales

Nota:

Los usuarios con privilegios de administrador sobre el documento pueden omitir todas estas condiciones seleccionando Mostrar todas las hojas y objetos de hoja en la página Propiedades de Documento: Seguridad. Esta funcionalidad se puede cambiar pulsando Ctrl+Mayús+S.

Propiedades de Documento: Seguridad

Opciones

En el grupo Opciones se puede desactivar la posibilidad de mover y redimensionar el objeto de hoja. Las configuraciones de este grupo solo son relevantes si están habilitadas las correspondientes casillas de verificación en Propiedades de Documento: Diseño y Propiedades de Hoja: Seguridad.

Permitir Mover/Ajustar Si se ha desmarcado esta opción será imposible mover o ajustar el objeto de hoja.
Permitir Copiar/ Clonar Si se ha desmarcado esta opción será imposible hacer una copia del objeto de hoja.
Permitir Información

Cuando utilice la función info, se mostrará un icono de información en la barra de título del objeto siempre que un valor de campo tenga información asociada al mismo. Si no quiere que aparezca el icono de información en la barra de título, puede deseleccionar esta opción.

Info

Ajustar a Datos Normalmente los bordes en torno a cualquier tipo de objeto de tabla en QlikView se encogen cuando las selecciones obligan a que el tamaño de la tabla sea menor que el espacio asignado para el objeto de hoja. Al desmarcar esta casilla este ajuste automático de tamaño se desactivará, quedando el espacio sobrante en blanco.

Barras de Desplazamiento

En el grupo Barras de Desplazamiento hallará diversos controles para cambiar el formato de las barras de desplazamiento:

Preservar Posición de Desplazamiento

Con esta opción habilitada, QlikView tratará de mantener la posición de desplazamiento de tablas y gráficos que tengan una barra de desplazamiento cuando se efectúe una selección en otro objeto. La opción debe estar habilitada también en Preferencias de Usuario: Objetos.

Las posiciones de desplazamiento no se mantendrán si cierra el documento.

Botones de Desplazamiento Determina el color del botón de desplazamiento. Seleccione un color haciendo clic en el botón. Observe que los tonos intermedios de gris a menudo son los que mejor resultado dan en el caso de las barras de desplazamiento. Se puede definir cualquier color como color sólido o un degradado mediante el diálogo Área de Color, que se abre haciendo clic en el botón correspondiente.
Fondo de Barra de Desplazamiento

Define el color de fondo de la barra de desplazamiento. Seleccione un color haciendo clic en el botón.

Ancho de Barra de desplazamiento Este control afecta tanto al ancho como al tamaño relativo de los símbolos de las barras de desplazamiento.
Estilo de Desplazamiento

Establece el estilo de la barra de desplazamiento. Seleccione un estilo en el control desplegable. El estilo Clásico corresponde a las barras de desplazamiento 4/5 de QlikView. El estilo Estándar confiere un aspecto más moderno. El estilo Ligero corresponde a una barra más fina, más ligera.

El Modo de Asignación de Estilo debe configurarse como Avanzado para que el estilo de la barra de desplazamiento esté visible. Este parámetro se encuentra en la pestaña General, abriendo el menú desplegable Configuración y seleccionando Propiedades de Documento.

Aplicar a... Abre el diálogo Propiedades de Título y Borde, en el que podrá definir dónde aplicar las propiedades que se establecieron en la página Diseño.

Título

Una configuración de Título solo se aplicará al objeto actual si se realiza desde la página de propiedades del Objeto.
Una configuración de Título se aplicará a todos los objetos del(os) tipo(s) especificado(s) en el documento, si ésta se realiza desde la página de Propiedades del Documento.

En la página Título podrá especificar opciones de diseño que son completamente diferentes a las del diseño general del objeto.

Mostrar Título Cuando se selecciona esta opción, se crea un título en la parte superior del objeto de hoja. Los cuadros de lista y otros "objetos de cuadro" tendrán la opción activada por defecto, mientras que los botones, objetos de texto y objetos de línea/flecha no.
Texto de Título En el cuadro de texto puede introducir un título que se mostrará en el título del objeto de hoja. Utilice el botón Fuente... si desea cambiar el tipo de letra del título.

Puede establecer los colores del título en sus diversos estados. Las configuraciones de Colores Activos y Colores Inactivos se pueden activar indistintamente unas de otras.

Pulse el botón Color de Fondo o Color de Texto para abrir el diálogo Área de Color. El Color de Fondo puede definirse como un color sólido o degradado en el diálogo Área de color. Se puede definir el Color de Texto como Fijo o Calculado utilizando las funciones de color.

Funciones de color

Dividir Texto Si se marca esta opción, el título se mostrará en dos o más filas.
Altura de Título (Líneas) En este cuadro de edición se fija el número de líneas del título.

El tamaño y la posición exactos del objeto QlikView pueden determinarse y ajustarse mediante los parámetros de Tamaño/Posición para el objeto de hoja QlikView Normal o Minimizado. Éstos parámetros se miden en píxeles:

Coord. X Fija la posición horizontal del lado izquierdo del objeto de hoja, en relación con el borde izquierdo de la hoja.
Coord. Y Fija la posición vertical del lado superior del objeto de hoja, en relación con el borde superior de la hoja.
Ancho Fija el ancho del objeto de hoja QlikView.
Altura Fija la altura del objeto de hoja QlikView.

La orientación de la etiqueta de título puede modificarse mediante las opciones de Alineación de Título:

Horizontal La etiqueta puede alinearse horizontalmente a la: Izquierda, Centrado o a la Derecha dentro del área de título.
Vertical La etiqueta puede alinearse verticalmente de forma: Superior, Centrado o Inferior dentro del área del título.

Iconos especiales
Muchos de los comandos de menú de los objetos de hoja pueden configurarse como iconos de título. Seleccione los comandos que se mostrarán como iconos de título marcando la casilla de verificación que aparece a la izquierda de cada comando en la lista.

Nota: Utilice los iconos especiales de título con cuidado. Demasiados iconos pueden confundir al usuario.
Permitir Minimizar Cuando se marca esta opción, se mostrará un icono de minimizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea minimizable. Además, esto hará que el objeto se pueda minimizar haciendo doble clic sobre su título.
Minimizado Automático Esta opción estará disponible cuando Permitir Minimizar esté marcado. Si marca la opción Minimizado Automático para varios objetos de hoja de una misma hoja, se minimizarán automáticamente todos menos uno en cualquier momento. Esto puede resultar útil para, por ejemplo, mostrar de forma alternativa diversos gráficos en una misma área de hoja.
Permitir Maximizar Si marca esta opción se mostrará un icono de maximizado en el título de la ventana del objeto de hoja, siempre y cuando el objeto sea maximizable. Además, esto hará que el objeto se pueda maximizar haciendo doble clic sobre su título. Si están marcados tanto Permitir Minimizar como Permitir Maximizar a la vez, hacer doble clic dará como resultado un objeto minimizado.
Texto de Ayuda

Aquí podrá introducir un texto de ayuda para mostrarlo en una ventana emergente. El texto de ayuda puede definirse como una fórmula calculada. Esta opción no está disponible a nivel de documento. Haga clic en el botón ... para abrir el cuadro de diálogo Editar Expresión para una edición más fácil de fórmulas largas.

Sintaxis de Expresión para fórmulas calculadas

Puede introducir, por ejemplo, una descripción del objeto de hoja. Se añadirá un icono de ayuda al título de la ventana del objeto. Cuando el puntero del ratón esté sobre el icono, el texto se mostrará en una ventana emergente.