Crear una tabla dinámica usando columnas de tabla de Excel

Puede crear tablas dinámicas de Excel usando niveles. No obstante, le recomendamos el método siguiente, que es más sencillo y rápido.

Se requiere Excel 2007 o posterior para seguir los procedimientos que a continuación se detallan.

Crear un nuevo informe de Excel

Haga lo siguiente:

  1. Seleccione Informes en el menú principal de Qlik NPrinting y después haga clic en el botón Crear informe.
  2. Escriba un Título para el informe. Pivot table report using Excel table.
  3. Seleccione Excel en la lista desplegable Tipo.
  4. Seleccione una app en la lista desplegable App.
  5. Haga clic en Crear para crear el informe.
  6. Haga clic en Editar plantilla para abrir el Editor de plantillas.

Añadir un objeto como tabla y cambiar la propiedad Keep Source Formats

Haga lo siguiente:

  1. Haga clic con el botón derecho en el nodo Tablas y seleccione Añadir objetos.
  2. Seleccione la Conexión al documento QlikView que contiene el objeto que desea.
  3. Añada CH205 a la plantilla como una tabla.

    Solo puede utilizar tablas simples de QlikView para crear su plantilla. Si desea utilizar una tabla pivotante de QlikView, debe convertirla en una tabla simple, o bien, si desea preservar el original, clonarla y convertir la tabla clonada. Después añada la tabla convertida a su plantilla.

  4. Haga clic con el botón derecho en CH205 en el nodo Tablas y después seleccione Propiedades.
  5. Desmarque la casilla Keep Source Formats de CH205.

Construir una tabla a partir de columnas

Construya la tabla básica arrastrando las columnas por separado a la plantilla y soltándolas en celdas vacías. Puede utilizar todas o algunas columnas.

Haga lo siguiente:

  1. Expanda las columnas CH205.
  2. Pulse la tecla Mayús y seleccione todas las columnas.
  3. Arrastre todas las columnas y suéltelas en celdas vacías de la plantilla.
  4. Abra la Excel Cinta haciendo clic en el icono Barra de herramientas del grupo Ver de la barra de herramientas del Editor de plantillas.
  5. Ajuste y dé formato a los encabezados de columna según lo necesite.
  6. Resalte el encabezado de columna, la etiqueta y una fila por debajo de las celdas para seleccionarlas.
  7. Seleccione la pestaña Insertar de la Barra de herramientas.
  8. Haga clic en Tabla en el grupo Tablas de la Barra de herramientas.
  9. Asegúrese de que la casilla Mis cabeceras de tabla esté seleccionada.
  10. Pulse Aceptar.
  11. Arrastre y suelte una etiqueta deleterow a la columna A de la primera fila vacía bajo la tabla para eliminarla.

Convertir en tabla pivotante

Haga lo siguiente:

  1. Resalte la etiqueta de columna y las celdas de encabezamiento para seleccionarlas, si lo necesita.
  2. Seleccione la pestaña Diseño bajo Herramientas de tabla en la Barra de herramientas.
  3. Haga clic en Resumir con Tabla pivotante en el grupo Herramientas.
  4. Pulse Aceptar.

    La nueva tabla pivotante se creará en una nueva hoja de cálculo. También puede añadir la tabla pivotante en la misma hoja de cálculo de los datos originales, y, por ejemplo, ocultar la columna con los datos.

  5. Arrastre el campo Year al recuadro Columnas.
  6. Arrastre los campos Salesman y Country al recuadro Etiquetas de fila.
  7. Arrastre el campo Sales al recuadro Valores y haga clic sobre él.
  8. Haga clic en Contador deTotal sales para abrir el menú.
  9. Seleccione Configuraciones de campo de valores.
  10. Seleccione Suma en la pestaña Resumir valores por en la ventana del cuadro de diálogo Configuraciones de campo de valores.
  11. Pulse Aceptar.

Configurar los datos para que se actualicen

Haga lo siguiente:

  1. Haga clic en el menú desplegable Opciones bajo la pestaña Herramientas de la Tabla pivotante - Analizar.
  2. Seleccione la pestaña Datos.
  3. Seleccione la casilla Actualizar datos al abrir el archivo.
  4. Configure el Número de elementos que conservar por campo como None (ninguno).
  5. Haga clic en Aceptar en la parte inferior del cuadro de diálogo Opciones de tabla pivotante.

Si no sigue estos pasos, verá una tabla pivotante vacía en el informe creado.

Vista previa y guardar

Haga lo siguiente:

  1. Haga clic en Vista previa.
  2. Revise el informe, ciérrelo y después edite la plantilla de nuevo si lo necesita.
  3. Haga clic en Guardar y cerrar para guardar la plantilla y cerrar el Editor de plantillas.