Dar formato a los informes Word

Cuando creamos plantillas para la generación de informes Word, el parámetro de formato por defecto es el formato de QlikView o Qlik Sense. No obstante, también podemos utilizar las herramientas de formato de Word.

Nota: El formateado de tablas utilizando las herramientas de Word solo funciona si guarda su plantilla en formato .docx y no como .doc. Guarde las plantillas de Word en formato .doc solo si lo necesita para temas de compatibilidad con versiones anteriores.

Permitir la aplicación de formato Word a todo el gráfico

Tras haber añadido un objeto QlikView como una tabla, por ejemplo CH184 en Crear informes de Word, haga lo siguiente:

  1. En el Editor de plantillas, haga clic en el nodo CH184 del objeto que acaba de añadir.
  2. En la ventana de Propiedades, desmarque la casilla Keep Source Formats.

    Esto hará que los contenidos de todas las celdas en todas las columnas de la tabla se exporten desde QlikView sin formato.

  3. Haga clic en el botón Barra de herramientas.

La funcionalidad Dividir Texto

Seleccionar Wrap Text hace que Qlik NPrinting automáticamente cree dos líneas si la celda es demasiado pequeña. Esto solo funciona cuando Keep Source Formats no está seleccionado. Wrap Text es una propiedad de tabla que afecta a todas las columnas de la tabla.

Aplicar el formato de Word a toda la tabla

Antes de añadir la tabla a la plantilla, haga lo siguiente:

  1. Seleccione la pestaña Insertar en la barra de herramientas.
  2. Seleccione Tabla.
  3. Seleccione la celda situada más arriba a la izquierda para insertar una tabla de 1x1 en la plantilla.

Añadir su tabla a la plantilla

Haga lo siguiente:

  1. Expanda el nodo CH184.

  2. Arrástrelas y suéltelas en la celda de tabla de la plantilla. Puede seleccionar múltiples valores manteniendo Ctrl o Mayús pulsados a la vez que selecciona las columnas.

    Esto creará todas las etiquetas y las insertará en una serie horizontal de celdas. Las celdas podrían exceder el espacio de la página, nos ocuparemos de esto en la próxima sección.

Configurar la tabla para que ajuste automáticamente las columnas

Haga lo siguiente:

  1. Seleccione la pestaña Diseño en la sección Herramientas de Tabla de la barra de herramientas.
  2. Haga clic en Ajustar automáticamente en la sección Tamaño de celda de la barra de herramientas.
  3. Seleccione Ajustar automáticamente contenidos.

Aplicar estilo de tabla

Tras haber seleccionado la tabla, haga lo siguiente:

  1. Seleccione la pestaña Diseño en la sección Herramientas de Tabla de la barra de herramientas.
  2. Seleccione un estilo general en la sección Estilos de Tabla de la barra de herramientas.

Vista previa y guardar

Haga lo siguiente:

  1. Haga clic en Vista previa.
  2. Revise el informe, ciérrelo y después edite la plantilla de nuevo si lo necesita.
  3. Haga clic en Guardar y cerrar para guardar la plantilla y cerrar el Editor de plantillas.