Requisitos del sistema de Qlik NPrinting Engine

Los requisitos de Qlik NPrinting Engine son para configuraciones en las que cada componente de Qlik NPrinting se instala en un equipo diferente.

Si instala más de un componente (por ejemplo, el servidor y el motor) en el mismo equipo, los requisitos mínimos de hardware se incrementan.

Qlik NPrinting Engine se puede instalar tanto en máquinas físicas como virtuales. En ambas configuraciones no se admiten aplicaciones virtualizadas. Por ejemplo, el motor Qlik NPrinting Engine no funcionará si está instalado en un equipo distinto de QlikView Desktop y se distribuye como una aplicación virtualizada.

Por defecto, solo hay disponible un motor Qlik NPrinting Engine para cada licencia de Qlik NPrinting Server. Si desea añadir motores adicionales a su entorno de Qlik NPrinting debe adquirirlos.

Requisitos del sistema
Componente Requerido
Plataformas
  • Microsoft Windows Server 2008 R2 solo se admite si no se está conectando a Qlik Sense.
  • Microsoft Windows Server 2012
  • Microsoft Windows Server 2012 R2
  • Microsoft Windows Server 2016

Solo se permite una arquitectura de 64 bits.

Procesadores (CPU) Procesadores compatibles multinúcleo x64 con un mínimo de dos núcleos.
Memoria

Se requieren 2 GB para cada núcleo con un mínimo de 4 GB de RAM en total.

QlikView Desktop debe tener suficiente memoria para gestionar los documentos QlikView que utilice como fuentes de datos para los informes. Tenga en cuenta que si crea informes MultiDoc todos los documentos QlikView empleados como fuentes de datos se abrirán a la vez. Un informe MultiDoc es un informe con datos de muchos documentos QlikView.

Espacio en disco 300 MB mínimo
Almacenamiento Solo se permite almacenamiento de Windows local o compartido.
QlikView Desktop
  • Las versiones QlikView Desktop 11.20 SR15 o superior y 12.00 SR5 son compatibles.
  • QlikView Desktop 12.10 SR1 o superior es compatible desde la versión Qlik NPrinting 17.2.2 e incluye también informes de On-Demand.
  • QlikView Desktop November 2017 o superior es compatible para su uso con Qlik NPrinting 17.3.1 o posterior.
  • QlikView Desktop Personal Edition no es compatible.

Se requiere QlikView Desktop en el equipo de Qlik NPrinting Engine. QlikView Server y QlikView Desktop deben ser exactamente la misma versión, incluido el número de compilación. QlikView Desktop debe instalarse localmente en el mismo equipo, físico o virtual, en el que se haya instalado Qlik NPrinting Engine. No se requiere QlikView Desktop si solo está conectando con apps de Qlik Sense.

Relojes del servidor

Los relojes de los servidores Qlik NPrinting Server y Qlik NPrinting Engine Windows deben estar sincronizados dentro de una tolerancia de 2 segundos.

Un servidor de Windows sincroniza su reloj con el controlador de dominio uno, por lo que, si Qlik NPrinting Server y Qlik NPrinting Engine están en el mismo dominio, esto debería asegurar la sincronización de los relojes. Le sugerimos que no elimine esta opción manualmente. Si instala Qlik NPrinting Server y Qlik NPrinting Engine en servidores Windows de diferentes dominios, debe asegurarse de que los relojes se sincronicen dentro de una tolerancia de 2 segundos.

Seguridad de la plataforma TLS 1.2 debe estar habilitado.

Software adicional instalado

El software siguiente se instala durante la configuración de Qlik NPrinting Engine, si aún no se ha instalado. No debe eliminarse:

  • PDF X-CHANGE 5.0.269
  • .NET framework: 4.6.2 o superior.

    .NET framework versión 4.6.2 se instala al instalar Qlik NPrinting Server, Qlik NPrinting Engine o Qlik NPrinting Designer. La instalación de .NET framework versión 4.6.2 requiere una conexión activa a Internet. Si no hay una versión de .NET framework 4.6.2 o posterior ya instalada en un equipo sin conexión a Internet, la instalación fallará. Debe instalar la versión .NET framework 4.6.2 o posterior en equipos sin conexión a Internet antes de instalar Qlik NPrinting Server, Qlik NPrinting Engine o Qlik NPrinting Designer.Si no hay una conexión a Internet disponible en un equipo con la versión .NET framework 4.6.2 o posterior ya instalada, el instalador se saltará esta parte de la instalación.