Publicar un informe sencillo desde un documento QlikView

Este tutorial le mostrará cómo crear y publicar un informe sencillo de Qlik NPrinting PowerPoint utilizando datos de QlikView.

Qlik NPrinting tiene muchas funciones. Este tutorial se ha diseñado para ayudar a nuevos usuarios a crear su primer informe. No detalla cada tipo de informe, elemento de diseño u opción de publicación. Al final de este tutorial, habrá creado, editado y publicado un informe de PowerPoint que podrán ver los usuarios que usted seleccione.

Otros tutoriales de Qlik NPrinting:

Nota: Microsoft Office debe estar instalado para poder editar y crear informes en formatos de archivo de Office.

En este tutorial, verá:

Acceder a un documento QlikView

Los informes necesitan datos. Vea cómo descargar e importar un documento de muestra de QlikView.

Conectar Qlik NPrinting con un documento QlikView

Qlik NPrinting necesitar conectar con su documento QlikView. Vea cómo configurar Qlik NPrinting para que pueda acceder a un documento de muestra, o sus datos actuales en QlikView.

Crear una nueva plantilla de informe en Qlik NPrinting

Las plantillas de informe controlan el diseño y el formato de salida de los informes. Esta sección le mostrará cómo hacer una nueva plantilla.

Editar la plantilla de informe

Los informes ofrecen muchas opciones de formato. En esta sección, añadirá un título, imágenes, una tabla y páginas a su informe.

Publicar en NewsStand y correo electrónico

NewsStand es una consola web a la que sus usuarios pueden acceder para ver informes. Vea cómo publicar su informe en NewsStand y por correo electrónico.

Acceder a un documento QlikView

Los documentos de QlikView contienen los datos y visualizaciones que Qlik NPrinting utiliza para generar informes. Hay varias formas de acceder a un documento QlikView.

  • Puede descargar un documento QlikView del sitio de ayuda de Qlik y guardarlo en una carpeta de su equipo.
  • Puede usar su propio documento QlikView , y saltar a Conectar Qlik NPrinting con un documento QlikView. Si está usando su propio documento para hacer este tutorial, elija uno sencillo. Qlik NPrinting tarda más tiempo en cargar documentos QlikView complejos.

Descargar un documento QlikView del sitio de ayuda de Qlik y guardarlo en su equipo.

Haga lo siguiente:

  1. En el sitio de ayuda de Qlik NPrinting, vaya a Archivos de muestra y descargue el archivo Examples en una ubicación de su preferencia en el equipo en que Qlik NPrinting esté instalado.
  2. En Windows, descomprima Sales Demo.qvw y guárdelo en la carpeta C:\Program Files\QlikView\Examples\. Cree la carpeta, si es que no existe ya.

    Si guarda los archivos en un lugar diferente, esta ubicación debe sustituirse por C:\Program Files\QlikView\Examples\ o donde se especifique en la ayuda de Qlik NPrinting.

Advertencia: Las unidades de red mapeadas, como Z:\NPrintingServer\QlikViewDocuments, no las admite Qlik NPrinting. Debe utilizar rutas UNC (Universal Naming Convention) en vez, como \\ServerName\NPrintingServer\QlikViewDocuments

Conectar Qlik NPrinting con un documento QlikView

Ahora crearemos una app de Qlik NPrinting y la conectaremos con su documento QlikView.

Las apps de Qlik NPrinting contienen informes, filtros y conexiones a las apps de Qlik Sense o documentos QlikView. Permiten a Qlik NPrinting Designer acceder a sus datos para que la información se pueda usar en un informe.

Haga lo siguiente:

  1. Inicie sesión en la consola web de Qlik NPrinting.
  2. En el menú principal, haga clic en el menú desplegable Apps y seleccione Apps.
  3. Haga clic en el botón Crear app.
    1. Escriba un nombre para esta nueva app. Por ejemplo: Beginner's Tutorial NP App - QV.
    2. Asegúrese de que la casilla Habilitado esté seleccionada. De lo contrario, su app será ignorada por el motor Qlik NPrinting Engine.
    3. Haga clic en Crear.

      Ahora podrá ver la app Beginner's Tutorial NP App - QV en Apps.

  4. En el menú principal, haga clic en el menú desplegable Apps y seleccione Conexiones.
    1. Haga clic en el botón Crear conexión.
    2. En el recuadro Nombre, escriba un nombre para la conexión. Conexión Beginner's Tutorial - QV.
    3. En la lista desplegable App, seleccione la app de Qlik NPrinting que creó previamente: Beginner's Tutorial NP App - QV.
    4. En Origen seleccione QlikView.
    5. En TipoT seleccione Local.
    6. En Ruta del documento, escriba la ubicación del documento QlikView al que desee conectarse.

      Por ejemplo: C:\Program Files\QlikView\Examples\Sales Demo.qvw

      Advertencia: Las unidades de red mapeadas, como Z:\NPrintingServer\QlikViewDocuments, no las admite Qlik NPrinting. Debe utilizar rutas UNC (Universal Naming Convention) en vez, como \\ServerName\NPrintingServer\QlikViewDocuments
    7. Si su documento QlikView requiere autenticación, asegúrese de que la opción La conexión requiere autenticación esté marcada.

      Vea: Section access.

    8. Haga clic en el botón Ejecutar verificación. Esto garantiza que su conexión sea válida.

      Si la conexión es válida, verá un mensaje de "Verificación satisfactoria". Si no, verá el siguiente mensaje: "Errores detectados. Verifique los detalles a continuación."

    9. Una vez que se haya verificado la configuración de conexión, haga clic en Crear. Volverá automáticamente al menú Conexiones.
    10. Su nueva conexión tendrá un Estado de caché - Generando. Esto significa que Qlik NPrinting se está conectando a QlikView e importando metadatos. Si tiene un documento QlikView muy grande, esto puede llevar varios minutos.
      Nota:

      Cada vez que agregue nuevos objetos a su documento QlikView, debe volver a cargar sus metadatos de conexión.

    11. Una vez que el estado de la caché muestre Generado, puede crear una nueva plantilla de informe. Si obtiene un estado de Error, compruebe la información de su conexión.

Ahora podrá ver su nueva conexión en la pantalla Conexiones.

Si tiene problemas para conectarse a su documento QlikView, vea:

Crear una nueva plantilla de informe en Qlik NPrinting

Las plantillas de informes controlan el formato y diseño de los informes. Puede colocar los objetos y dar formato a las páginas usando las opciones estándar del tipo de informe que elija. Por ejemplo, un informe de PowerPoint tendrá las mismas opciones de formato e interfaz que una baraja de PowerPoint.

Haga lo siguiente:

  1. En la consola web de Qlik NPrinting, haga clic en Informes en el menú principal.
  2. Pulse el botón Crear informe.
  3. Escriba un título en el campo Título. Por ejemplo: Beginner's Tutorial NP PowerPoint.
  4. En la lista desplegable Tipo, seleccione PowerPoint.
  5. En la lista desplegable App, seleccione Beginner's Tutorial NP App - QV.
  6. En las opciones de Plantilla, haga clic en Archivo vacío.
  7. Asegúrese de que la casilla Habilitado esté seleccionada. De lo contrario, su informe será ignorado por el motor Qlik NPrinting Engine.
  8. Haga clic en Crear.

Ahora podrá ver Beginner's Tutorial NP PowerPoint en Informes.

Editar la plantilla de informe

Hay muchas maneras de editar una plantilla de informe. Añadiremos:

  • Títulos: texto simple utilizado para organizar su informe. Se pueden modificar utilizando el formato estándar de PowerPoint.
  • Tablas: tome sus datos de QlikView y preséntelos en forma de tabla.
  • Imágenes: tome sus datos de QlikView y preséntelos como una imagen .png.
  • Gráficos: tome los datos de su tabla QlikView y preséntelos como un gráfico de PowerPoint.

  • Páginas: subdivida sus datos por una dimensión. Se pueden aplicar a tablas e imágenes. Dividiremos Year y Category Name.

Esta sección no describe todo lo que se puede hacer en Qlik NPrinting Designer. Si desea información acerca de las funciones avanzadas de informes de PowerPoint, vea: Informes PowerPoint.

Nota: La vista previa de su informe puede variar respecto a la imagen que se muestra a continuación, dependiendo del formato que le haya dado. Algunos de los objetos pueden tener nombres ligeramente diferentes, según el orden en que fueron seleccionados.

Haga lo siguiente:

  1. En la consola web de Qlik NPrinting, haga clic en Informes en el menú principal.
  2. En la pantalla Informes, haga clic en su informe.
  3. Haga clic en el botón Editar plantilla para abrir el editor de plantillas de Qlik NPrinting Designer.

  4. Se abre el asistente Qlik NPrinting Designer. Como está haciendo un informe de PowerPoint, verá la interfaz estándar de PowerPoint. La mayoría de las características de formato de PowerPoint se pueden aplicar a su informe usando esta interfaz.
  5. Escriba un título:
    1. En la primera diapositiva, escriba un título: Por ejemplo, "Sales Trends by Product Category".
    2. Escriba un subtítulo o elimine el cuadro de texto del subtítulo.

      Sugerencia: Puede usar las opciones de formato de PowerPoint para cambiar el aspecto de estos títulos. Por ejemplo, puede cambiar el tamaño y el color de la fuente.
  6. Añadir imágenes:
    1. En la barra de herramientas de PowerPoint, haga clic en la pestaña Insertar.
    2. Haga clic en el botón Nueva diapositiva.
    3. Escriba un título: por ejemplo: "Top Selling Products". Elimine el segundo cuadro de texto vacío.
    4. En el panel izquierdo, haga clic con el botón derecho en Imágenes y seleccione Añadir objetos.

    5. Se abrirá una nueva ventana. Seleccione Products y Sales by Category for 2014 vs 2013, y haga clic en Aceptar.

      Puede seleccionar varias opciones manteniendo pulsado el botón CTRL.

    6. Arrastre SH02 - Products a la diapositiva.

    7. En la barra de herramientas de PowerPoint, haga clic en la pestaña Insertar.
    8. Haga clic en el botón Nueva diapositiva.
    9. Escriba un título: por ejemplo: "Sales by Category: 2013 vs 2014". Elimine el segundo cuadro de texto vacío.
    10. Arrastre CH212 - Sales by Category for 2014 vs 2013 a la diapositiva.

  7. Añadir una tabla:
    1. En el panel izquierdo, haga clic con el botón derecho en Tablas y seleccione Añadir objetos.
    2. Se abrirá una nueva ventana. Seleccione Sales by Category: 2013 vs 2014. Haga clic en Aceptar.

    3. Arrastre CH212_1 - Sales by Category for 2014 vs 2013 a la diapositiva.

  8. Añada un nuevo gráfico nativo de PowerPoint:
    1. En la barra de herramientas de PowerPoint, haga clic en la pestaña Insertar.
    2. Haga clic en el botón Nueva diapositiva.
    3. Escriba un título: por ejemplo: "Sales Trends:". Elimine el segundo cuadro de texto vacío.
    4. En el panel izquierdo, haga clic con el botón derecho en Tablas y seleccione Añadir objetos.

    5. Se abrirá una nueva ventana. Seleccione CH326 - Sales by YearMonthNum. Haga clic en Aceptar.

    6. En la barra de herramientas de PowerPoint, seleccione la pestaña Insertar.
    7. En la sección Ilustraciones haga clic en Gráfico.
    8. Se abrirá una nueva ventana. En Columna, seleccione el primer gráfico de barras y después haga clic en Aceptar.

    9. Se abrirá una hoja de cálculo de Excel. Esta es la fuente de datos para su tabla.

      Tendremos que insertar etiquetas de Qlik NPrintingen esta hoja y eliminar algunos datos innecesarios.

    10. En el panel izquierdo de la interfaz de PowerPoint, expanda el nodo CH326 - Sales by YearMonthNum.
    11. Seleccione las etiquetas YearMonthNum y Sales.

      Puede seleccionar varias opciones manteniendo pulsado el botón CTRL.

    12. Arrastre y suelte la etiqueta Year MonthNum en la hoja de Excel, en la celda A1. Esto lo convertirá en el eje y. Arrastre las etiquetas Sales a la celda B1. Esto lo convertirá en el eje x.

    13. Seleccione y elimine las columnas C y D.

      Los números reales son innecesarios, porque Qlik NPrinting usará las etiquetas para construir el gráfico.

    14. Seleccione y elimine las filas 3, 4 y 5.

    15. Cierre Excel.

      Sus cambios se guardarán automáticamente.

    16. Es posible que deba ajustar el tamaño de su tabla para que quepa en la diapositiva. Puede usar las flechas de tamaño.

    17. En el menú del editor de plantillas de Qlik NPrinting, haga clic en la pestaña Archivo. Haga clic en Guardar.
    18. Haga clic en la pestaña Plantilla y clic en el botón Vista previa para acceder a una vista previa de su informe.

      Su presentación de diapositivas tiene cuatro diapositivas por el momento.

  9. Añadir páginas:
    1. Vaya a la diapositiva donde desee agregar la página. En este caso, la cuarta diapositiva.

      Las páginas solo se aplican a la diapositiva actual.

    2. En el panel izquierdo haga clic con el botón derecho en Página y seleccione Añadir página a la hoja actual.
    3. Se abrirá una nueva ventana. Seleccione CategoryName. Haga clic en Aceptar.

      Nota: Nota: Si agrega una segunda página a una diapositiva, se sobrescribirá la página anterior.
    4. Expanda el nodo CategoryName_Page - CategoryName. Arrastre la etiqueta CategoryName a la diapositiva.

      Esta etiqueta dividirá sus datos por categoría, con cada categoría en una diapositiva independiente. El texto <CategoryName> cambiará para coincidir con la categoría de cada diapositiva. En lugar de una diapositiva que dice "Sales Trends:", tendrá varias diapositivas con títulos únicos: "Sales Trends: Baby Clothes", "Sales Trends: Women's Shoes".

      La etiqueta <CategoryName> aparecerá como un nuevo cuadro de texto. Si corta y pega este nuevo texto en el cuadro de texto del título, puede darle formato para que coincida con el título de forma fácil.

    5. Vaya a la segunda diapositiva, "Top Selling Products".
    6. En el panel izquierdo haga clic con el botón derecho en Página y seleccione Añadir página a la hoja actual.
    7. Se abrirá una nueva ventana. Seleccione Year. Haga clic en Aceptar.
    8. Expanda el nodo Year_Page - Year. Arrastre la etiqueta Year a la diapositiva.

      Aparecerá como un nuevo cuadro de texto. Si corta y pega este nuevo texto en el cuadro de texto del título, puede darle formato para que coincida con el título de forma fácil.

    9. En la barra de herramientas de PowerPoint, haga clic en la pestaña Insertar.
    10. Haga clic en el botón Número de diapositiva.
    11. Se abrirá una nueva ventana. Haga clic en las casillas de verificación Fecha y hora, Número de diapositiva y No mostrar en diapositiva. Haga clic en Aplicar a todo.

  10. En el menú del editor de plantillas de Qlik NPrinting, haga clic en la pestaña Archivo. Haga clic en Guardar.
  11. Haga clic en la pestaña Plantilla y clic en el botón Vista previa para acceder a una vista previa de su informe.

    Puede que tarde varios minutos en cargar la vista previa, dependiendo del tamaño de su informe.

    Ahora tiene un informe con 13 diapositivas. Las diapositivas con páginas aplicadas se han expandido a nuevas páginas con información dividida por las categorías de página que ha aplicado.

    En este ejemplo, las diapositivas 2-4 muestran los datos filtrados por Year y las diapositivas 6-13 muestran los datos filtrados por CategoryName.

    Advertencia: Los cambios realizados en el modo de vista previa no se guardarán.
  12. Si desea seguir haciendo cambios, cierre la ventana de vista previa y dé formato a su informe en el editor de plantillas.
  13. Cuando haya terminado de hacer cambios haga clic en Guardar y cerrar.

La plantilla de informe se guarda ahora y está lista para compartir con los usuarios.

Publicar en NewsStand y correo electrónico

Los informes deben ser publicados para que los usuarios puedan acceder a ellos. Vamos a publicar en NewsStand y por correo electrónico.

NewsStand es un portal web que permite a los usuarios acceder a una vista previa y descargar informes y suscribirse a actualizaciones automáticas. Vea: Vista general de NewsStand

Los correos electrónicos contienen sus informes como archivos adjuntos. Sus contenidos se pueden personalizar agregando texto e imágenes. Vea: Distribuir informes por correo electrónico.

Nota: Debe configurar su servidor de correo SMTP para que envíe correos electrónicos desde Qlik NPrinting. Vea: Configurar el servidor SMTP.

Haga lo siguiente:

  1. En la consola web de Qlik NPrinting, en el menú principal, haga clic en Tareas y seleccione Tarea de publicación.
  2. Haga clic en el botón Crear tarea.

    1. Escriba un nombre. Por ejemplo: Publish Beginner's Tutorial NP PowerPoint.
    2. Seleccione su app de la lista desplegable: Beginner's Tutorial NP App - QV.
    3. Deje los valores predeterminados de las demás opciones. Haga clic en Crear.
  3. Haga clic en la pestaña Informes.
    1. Haga clic en el botón Añadir informe.

    2. Seleccione Beginner's Tutorial - NP PowerPoint en la lista desplegable Elegir informe.
    3. Seleccione PPTX en la lista desplegable Formato de salida.
    4. Asegúrese de que las casillas Adjuntar al correo electrónico y Habilitado estén seleccionadas.
    5. Haga clic en Añadir informe.

  4. Haga clic en la pestaña Usuarios/grupos.
    1. Haga clic en el botón Añadir usuario o grupo.
    2. Seleccione un usuario o grupo de la lista desplegable Elegir destinatario.

      Si desea aprender a crear nuevos usuarios, vea: Crear usuarios.

    3. Seleccione las casillas Habilitado, Destino de NewsStand y Destino del correo electrónico.
    4. Haga clic en Añadir destinatario.
  5. Haga clic en la pestaña Destinos.
    1. En la columna NewsStand, haga clic en la casilla Publicar para todos.
    2. En la columna Email, haga clic en la casilla Publicar para todos.
    3. Haga clic en Guardar.
  6. Se le enviará de nuevo a la pestaña General.
  7. Haga clic en el botón Ejecutar ahora.

    Una vez que la tarea esté completa, aparecerá un mensaje de confirmación en la parte superior de la página.

Sus destinatarios pueden ir ahora a NewsStand en sus navegadores y ver su informe. También recibirán una copia en su correo electrónico.

Sugerencia: En instalaciones estándar, puede cambiar de la consola web de Qlik NPrinting a su NewsStand cambiando el puerto 4993 a 4994 en la barra del navegador. Por ejemplo, si su consola web es https://YourServerName:4993, entonces su NewsStand es https://YourServerName:4994.