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1   About this document

1 About this document
Visualizations are used to present the data that is loaded into the app. The selections you make in
the app are reflected in all associated visualizations on all sheets.

Read and learn how to create and customize sheets and visualizations in your app. You will also
learn about creating reusable master items, and about expressions in visualizations.

This document is derived from the online help for Qlik Sense. It is intended for those who want to
read parts of the help offline or print pages easily, and does not include any additional information
compared with the online help.

You find the online help, additional guides and much more at help.qlik.com/sense.
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2   Creating apps

2 Creating apps
Qlik Sense apps are purpose-built applications created with data. App users explore
the data through visualizations selected and enhanced by app developers.

Apps are created by three primary methods depending on skill level and how much data
manipulation is required upon dataload. Options from basic to advanced include:

1. Uploaded once and never modified.
2. Modified manually through Data manager.
3. Replaced or refreshed with net new changes.

The foundation of an app is the data model and load script. Measures and dimensions are reusable
data items used to build charts. Sheets and stories display and organize your visualizations.
Discoveries can be made by applying filters and selections.

A Qlik Sense app with selections applied

Permissions are required to create and interact with apps. If app functionality is not available to you,
contact your administrator for appropriate permissions.

Qlik Sense apps contain data, and use visualizations to explore that data. Make
discoveries by applying selections to visualizations.
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The foundation of an app is the data model and load script. Measures and dimensions are reusable
data items used to build charts. Sheets and stories display and organize your visualizations.
Bookmarks are an easy way to save a specific selection state on a sheet

Whoever creates an app is automatically designated as its owner. An app can be re-used, modified,
and shared with others, depending on access rights. Different actions can be carried out depending
on whether the app is published or not.

The .qvf file format is a proprietary format.

Qlik Sense apps are purpose-built applications created with data. App users explore the data
through visualizations selected and enhanced by app developers. Apps are created by three
primary methods depending on skill level and how much data manipulation is required upon
dataload. Options from basic to advanced include:

2.1 Foundations

Data manager and Data load editor
The Data manager lets you quickly add and transform data. You can also associate data tables. The
Data load editor uses scripts to connect to a data source and retrieve the data.

Measures
Measures are calculations used in visualizations. Measures are created from an expression
composed of aggregation functions, such as Sum or Max, combined with one or several fields.

Dimensions
Dimensions are fields used in visualizations. Dimensions determine how the data in a visualization is
grouped. For example: total sales per country or number of products per supplier.

2.2 Structure and visuals

Sheets
Sheets contain data visualizations, such as charts and tables. You create structure in your app by
grouping visualizations on sheets. For example, you could have a sheet for North American sales,
and a different sheet for Europe.

Bookmarks
Bookmarks are shortcuts to a certain set of selections and chart expansions.
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Stories
Stories are based on snapshots of visualizations. You present your data by creating a story that
guides you to new insights by combining snapshots of data at specific times and selection states.

In Qlik Sense Desktop, apps are typically stored in <user>\Documents\Qlik\Sense\Apps,
as <Appname>.qvf, where <Appname> is the name of the app. If you rename an app in
Qlik Sense Desktop, the .qvf is not updated.

2.3 Structuring an app using sheets
Sheets structure your ideas and purpose of your app. When you create an new app, it is
good practice to first build a structure of empty sheets, where each sheet represents
an idea or a goal. This gives a good overview of the app.

Overview
For example, you are creating an overview of your company's key metrics, sales, and margins by
state, region, and product. Instead of having all this information in one place, you could structure it
by having one sheet for each purpose.

Each sheet has a purpose and an idea of its own.

A sheet is where charts and tables for data visualization are placed. An app can include several
sheets. The selections that you make affect visualizations regardless of which sheets they are on.

An example of a sheet with boxes on the left to select and filter out the data to be presented in the
visualizations on the right.
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Creating a new sheet
You can create a new sheet from the app overview or from the assets panel.

You access the sheet navigator from the sheet view by clicking in the toolbar.

Do the following:

1. From the app overview, click to view the sheets.

2. Click Create new sheet.
3. Give your sheet a title and add a description.
4. Click outside the text area to save the title and description.

A new sheet is created.

Changing the title and description of a sheet
You can change the title and description of your sheets. You can either use a fixed sheet title, or a
dynamic sheet title based on an expression.
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Do the following:

1. In the app overview, click to view the sheets.

2. Do one of the following:
l If you are in grid view, , click the sheet title followed by clicking .

l If you are in list view, , click .

3. Edit Title and Description.
4. Click outside the text area.

The changes you made are saved.

You can also change a sheet’s title and description in the Sheet properties panel.

Using a dynamic sheet title
You can set a dynamic sheet title based on an expression in the Title expression property of the
sheet properties panel. You can use any valid chart expression.

If you set a dynamic sheet title, the fixed title (Title) is not used.

Setting a show condition for a sheet
You can set a condition in Show condition to show or hide a sheet in an app depending on if an
expression evaluates as true or false. The sheet is only shown if the expression evaluates as true.
Hiding a sheet does not hide or exclude data in an app.

For example, you could create a sheet that is only available if certain values are present in your
data. Typically, you should use an if function.

Changing the sheet thumbnail
You can replace the default thumbnail, to make it easier to distinguish between sheets in the app
overview and in the assets panel. You can use one of the default images, or an image of your own.

Note the following:

l The following formats are supported: .png, .jpg, .jpeg, and .gif.
l The optimal aspect ratio of a thumbnail is 8:5 (width:height).
l You can only add or change the thumbnail of an unpublished sheet.

Do the following:

1. In the app overview, click to view the sheets.

2. Do one of the following:
l If you are in grid view, , click the sheet title followed by clicking .

l If you are in list view, , click .
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3. Click on the default thumbnail.
The Media library opens.

4. Click on a folder in the media library, for example In app or Default.
5. Select the image you want to use as a thumbnail for the sheet and click Insert.

6. Click  to stop editing.

The image you selected is now used as a thumbnail for the sheet, and is visible in the assets panel
and in the app overview.

You can also change a sheet’s thumbnail in the assets panel or in the Sheet properties
panel.

The following formats are supported: .png, .jpg, .jpeg, and .gif.

For Qlik Sense: You can upload images to the In app folder in the media library. You need to use the
Qlik Management Console to upload images to the default folder.

For Qlik Sense Desktop: You can place images in the following folder on your computer:
C:\Users\<user>\Documents\Qlik\Sense\Content\Default. Images will be available in the default
folder in the media library. When moving an app between installations, the images that you use in
the app are saved in the qvf file together with the app. When you open the app in a new location,
the images will be in the In app folder in the media library for the app.

Changing the grid sizing of a sheet
You can adjust the grid sizing of the sheet to be able to fit more visualizations on a sheet, or have
more control over how visualizations are positioned. The grid displays when you are adding,
moving, or resizing a visualization.
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Grid size can be changed in the Sheet properties pane
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Do the following:

1. Go to the Grid spacing setting under Sheet properties.
2. Change spacing from Wide (the default option) to Medium, Narrow, or Custom.
3. If you choose Custom, a slider will appear. Use the slider to change the grid size. The higher

the number, the more narrow the grid spacing is.

Customizing sheet size

By default, Qlik Sense uses a responsive layout for sheets that adjusts the sheet to the dimensions
of the user’s screen. You can set a custom width and height for the sheet if you want to use a non-
responsive layout for your sheets. This ensures that your dashboard will be presented to users
exactly as you created them, with no adjustments for responsiveness. You can set the height and
width of a sheet anywhere between 300 pixels and 4,000 pixels.

If the PDF download of your sheet appears overly zoomed in, switching the Sheet size from
Responsive to Custom is recommended.

Changing the Sheet size from Responsive to Custom may impact the interactive
experience for business users. If report output formatting is particularly important,
consider creating a report-specific app for better control over themes and layout.

When a sheet is using a custom size, you can change the grid spacing, but you cannot use Extend
sheet to change the size.

For Responsive sheets that are not extended, the exported PDF of the sheet will be:
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o Landscape orientation: 1680 by 1120 pixels
o Portrait orientation: 1120 by 1680 pixels

If you are using a Custom sheet size, the PDF output of the sheet will keep the custom pixel values
for width and height.

Changing the Sheet size from Responsive to Custom may impact the clarity of the PDF output. If
you are manually exporting a custom-sized sheet as a PDF, the best practice is:

l Portrait orientation: values of 1680 by 1120 pixels, or a ratio of 1:1.5
l Landscape orientation: values of 1120 by 1680 pixels, or a ratio of 1.5:1

Extended sheets and custom-sized sheets may have a lower-resolution PDF output if the sheet is
too large to clearly display on a single PDF page.

Do the following:

1. Change the Sheet size setting from Responsive to Custom.
2. Enter a width for the sheet in pixels.
3. Enter a height for the sheet in pixels.

Changing the small screen layout
By default, sheets are displayed in List view when viewed on small screens. You can change them
to display as a grid. Sheets must be set to responsive layout to display as grid on small screens.

A sheet viewed on a small screen in List view (left) and Grid view (right)

Grid view shows a small preview of your visualizations. List view only shows the visualization titles.
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Do the following:

1. Under Sheet properties, go to Small screen layout.
2. From the drop-down, select Grid view.

Extending the sheet area
You can extend the area of a sheet vertically if you need to add more visualizations than what can
fit on a screen.

Downloaded extended sheets may have a lower quality PDF output if the sheet is too
large to clearly display on a single PDF page.

Note the following:

l You need to activate Extend sheet under Sheet properties.
l Each extension adds 50% of the original sheet height.
l If you have visualizations that scroll, this can interfere with scrolling of an extended sheet.

You should leave some empty space that allows for scrolling when you design the sheet.

You can extend the sheet in two different ways:

Do the following:

l Drag an object to the bottom of the sheet and drop it on the drop zone that appears.
l Toggle Extend sheet under Sheet properties.

The sheet is now expanded by 50% of the original height. You can scroll vertically in the sheet to
access all content.

Adding actions to sheets
You can add actions to sheets that trigger when users navigate to those sheets. For example, you
could automatically clear selections in the app when users navigate to a particular sheet.

For more information, see Adding actions to sheets (page 20).

Adding a background color or image
You can customize the background of a sheet. You can chose a specific background color, or color
by expression. Any image in the media library can be set as a background. The image can be
positioned and resized so it does not fill the entire background.
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The following formats are supported: .png, .jpg, .jpeg, and .gif. If you use a .gif, it can be animated or
static.

Do the following:

1. Open the sheet in Edit mode.
2. Under Sheet properties, click Styling.
3. Set Background to Custom. The default is Auto.
4. Background color:

l Single color: Choose a color using the color picker.
l By expression: Set a color using a user-defined expression. For more information, see

Examples (page 624).
5. Background image: Select Image from media library. The default is None.

6. Click on the default thumbnail.
The Media library opens.

7. Click on a folder in the media library, for example In app or Default. You can also choose to
Upload media, if the image you want is not already in the media library.

8. Select the image you want to use and click Insert.
9. Use the drop down to change the size of your image:

l Original size
l Always fit
l Fit to width
l Fit to height
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l Stretch to fit
l Always fill

10. Under Position, you can change the alignment of the image. For example, the image can be
centered on the sheet, or in the top-right corner.

The image and background color you selected is now visible on the sheet.

Sheet in Edit mode, with a background image set on the left

Copying, replacing and moving items on sheets
You can copy, replace, and move items on a sheet and between sheets. You can do this in the
following ways:

l Using the edit bar on the sheet ( , and ).

l Using the edit bar on the sheet ( , and ).
l By right-clicking and selecting Cut, Copy and Paste.
l With the keyboard shortcuts Ctrl+C, Ctrl+X and Ctrl+V.

Duplicating a sheet
You can duplicate any sheet, regardless of whether it is a sheet that belongs to the app or a sheet
you have created yourself. The purpose of duplicating sheets is to save time by reusing content,
and to allow you to modify the duplicate so that it fits your needs better.A duplicated sheet contains
the same visualizations as the original sheet, and is linked to the same master items. The duplicated
sheet is a standalone sheet with no connection to the original sheet. Duplicated sheets appear
under My own in app overview and in Sheets in the assets panel.

You can duplicate a sheet in the following ways:
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l Click Duplicate in the shortcut menu of a sheet in the app overview or in the sheet navigator.
l Click Duplicate sheet in the global menu in the app overview or in sheet view.

Adding actions to sheets
You can set actions to sheets that trigger when users navigate to the sheet. Sheet
actions are useful when you want to assist app users with predefined selection or
selection controls when they navigate to a sheet. For example, a sheet could
automatically apply a bookmark or clear all selections when users navigate to the
sheet.

Sheet actions can be configured in the properties panel. You can add multiple actions to a sheet.
The actions are performed in the order they are listed under Actions. You can change the order of
an action by dragging it.

For a visual demo about adding actions to sheets, see Adding actions to sheets.

All expressions used in sheet actions are evaluated before the actions are performed.
For example, you could not use an expression in an action that selects results from a
previous action as the expression evaluates before the selection is made by the action.

Sheet actions are not triggered if the sheet is an embedded sheet or in a mashup.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click Actions in the properties panel of the sheet.
3. Click Add action.
4. Select the action you want to use.

For some actions you need to provide details for the action. For example, for the Select
values in a field action, you need to select a field, and which value to select in the field.

5. Optionally, after Label, enter a name for the action.

Available sheet actions
You can add one or more actions to be performed when users navigate to the sheet. For some
actions, you need to provide details for the action.

Apply bookmark
You can apply the selection that is defined in a bookmark that you choose.

Create apps and visualizations - Qlik Sense, November 2024 20

https://share.vidyard.com/watch/P2LTiTvmDTMcbkDuSxqVtG?


2   Creating apps

Clear all selections
You can clear all selections in all states in the app. You can optionally overwrite locked selections.

Clear selections in other fields
You can clear selections from all fields except the one you specify. You can optionally overwrite
locked selections.

If no selections are made in the specified field, all values in this field will be selected.
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Move forwards in your selections
You can move one step forwards in your selection history.

Move backwards in your selections
You can move one step backwards in your selection history.

Clear selections in field
You can clear all selections from a field that you specify.

Lock all selections
You can lock all selections in the app.

Lock a specific field
You can lock selections in a field that you specify.

Unlock all selections
You can unlock all selections in the app.

Unlock a specific field
You can unlock selections in a field that you specify.
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Select all values in a field
You can select all values in a field that you specify. You can optionally overwrite locked selections.

Select values in a field
You can select a list of values in a field that you specify. Separate the values to select with a semi
colon. You can optionally overwrite locked selections.

It is not possible to use fields with date, timestamp, or money data type.

Create apps and visualizations - Qlik Sense, November 2024 23



2   Creating apps

This button action does not select numeric values that are stored or classified as text.
For this purpose, use the Select values matching search criteria action instead.

Select values matching search criteria
You can select all values that match the search results from a search criteria that you specify. You
need to specify the search criteria as a string. You can optionally overwrite locked selections.

l If you want to use an expression, you need to enclose it in single quotes, for example,
='=Sum([Sales Amount]) > 200000'.

l If you want to search for a partial string, you need to use wild cards (*, ?,^). If you do not use
wild cards, only strings that match exactly are selected.

Select alternatives
Select all alternative values in a field that you specify. You can optionally overwrite locked
selections.

Select excluded
Select all excluded values in a field that you specify. You can optionally overwrite locked selections.

Select possible values in a field
Select all possible values in a field that you specify. You can optionally overwrite locked selections.

Toggle field selection
You can set the button to toggle between the current selection, and a selection that adds selections
defined by a search string. You can use wild cards in the search string. If you want to define a list of
values you need to use the format (A|B), where A and B are values to select.
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Set variable value
You can assign a value to a variable.

Grouping sheets
Organize sheets in the assets panel using grouping.

You can group sheets in the assets panel. Groups are collapsible, allowing you to organize large
numbers of sheets into a manageable hierarchy. You can make groups public or private.
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Grouped sheets in the assets panel
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Adding sheets to a group

Do the following:

1. In the assets panel, right-click a sheet in My own and select Add to group.
2. Select a group or create a new group.

Alternatively, in the app overview or assets panel, you can click and drag a sheet into a group.

Removing sheets from a group

Do the following:

1. In the assets panel, right-click a sheet and select Remove from group.
2. Select a group or create a new group.

Alternatively, in the app overview or assets panel, you can click and drag a sheet out from a group.

Limitations
Groups have the following limitations:

l Groups do not display in Qlik Sense Mobile. Sheets in groups will be displayed in one list
instead. The order of sheets in the list in Qlik Sense Mobile may be different than the order
defined in the groups.

l You cannot publish groups in published apps. You can publish sheets in the group's contents,
however.

2.4 Managing apps
Once you have created and built an app with the sheets and visualizations you want it
to have, you may want to fine-tune it to make it easy and efficient to use, not only for
yourself but also for other people.

The following actions are available to app owners:

l Apply app styling (logo and header)
l Create reusable master items (visualizations, dimensionsand measures
l Add bookmarks to keep track of important and interesting data selections and connections
l Making apps available in Insight Advisor Chat
l Turn off Insight Advisor
l Change the app’s title and description, and also add a thumbnail to it
l Reload app data
l Manage app reload tasks
l Publish your own apps
l Move your own published apps between streams
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Creating an app
The first thing you need to do when building an app is to create an empty placeholder for it. You
create the app placeholder from the hub

Do the following:

1. Click Create new app in the hub.
2. Give your app a name.
3. Click Create.

The app is created.
4. Click Open app.

The app opens in the app overview.

The next step is to add data to the new app.

On-demand apps
On-demand apps enable you to load and analyze big data sources in Qlik Sense.

Trying to analyze an entire big data store at one time is highly inefficient. Nevertheless, to make
representative visualizations, all the data must be discoverable. Qlik Sense on-demand apps give
users aggregate views of big data stores and allow them to identify and load relevant subsets of
the data for detailed analysis.

On-demand apps are made up of several building blocks or components, and some of those
components are built by users with advanced scripting skills.

Generating an on-demand app
You generate an on-demand app when you have selected a manageable subset of data using an
on-demand selection app. Any selection app that you are working with will contain one or more
navigation links for generating on-demand apps in the App navigation bar.

The on-demand apps shown on the App navigation bar have completion indicators that start to
turn green as you make selections in the selection app. Each on-demand app on the app navigation
bar has a limit on the amount of data it can contain. When selections are made in the selection app,
the completion indicator shows when the amount of data selected is within the bounds set for the
on-demand app.

Once an on-demand app's indicator turns completely green, you can generate that app with the
currently selected data. You can also choose to open a previously generated instance of that app.
Every on-demand app in the app navigation bar can be generated multiple times, and those
generated apps remain accessible. When the maximum number of apps has been generated, you
must delete an existing app before you can generate a new on-demand app. On-demand apps also
may have an expiration time after which they are automatically deleted.
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Anonymous users can only generate on-demand apps that are published automatically.
Because anonymous users can only use published apps, they cannot use an on-demand
app unless it is published automatically when it is generated. If an anonymous user
attempts to generate an on-demand app that is not set for automatic publication, a
message displays indicating that the user cannot generate an app from that particular
on-demand app navigation point.

The maximum number of apps and the retention time are set on the on-demand app navigation link.
The app navigation link is one of the building blocks of on-demand apps, and it is usually added by
the creator of the selection app.

Do the following:

1. Open an on-demand selection app.
2. Select from the visualization objects in the selection app.
3. When the completion indicator on an on-demand app in the App navigation bar turns

completely green, click the on-demand app.
You can select an on-demand app in the App navigation bar to open its generation panel.
There you can click the to see the Constraint (maximum number of records allowed) and
the number of records currently selected. You can also see the number of values selected for
each field and any constraints on the fields. When on-demand apps are created, constraints
can be placed on individual fields. For example, a field for Year might be limited so that no
more than two values can be selected.
When the number of records (Row count) currently selected is less than or equal to the
maximum number of records allowed, the completion indicator turns completely green. An
app cannot be generated, however, until all the constraints have been met. If the row count is
within the constraint but one or more of the fields have not met the requirements of their
constraints, the Generate new app button will not be enabled.

If you select Generate new app when constraints panel is open, you will not see
the generated app. Click the to close the panel, and you will see the new app
listed if it generated successfully.

4. Click the Generate new app button to create a new instance of the on-demand app with the
data currently selected.
The new instance of the app is generated and appears in the generation panel above the
Generate new app button.
To see more about the generated app, open its detail panel.
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In this view, you can also rename the on-demand app. By default, on-demand apps are
assigned the name of the navigation point from which they are generated, and the user's
name is appended. For example, when the name of the navigation point is "Ox Sample
Detail," the default name of the generated on-demand app would be "Ox Sample Detail_
John-Doe" for user "John Doe." In the illustration above, the name of the on-demand app has
been changed to "Ox Sample Detail_Airlines." You can rename an on-demand app even if it
has been published.

On-demand apps generated by anonymous users are given default names
indicating that they were generated by an anonymous user rather than a
registered user. Anonymous users can change the names of generated apps just
as registered users can change the names of their apps.

The Apply button applies the selections listed on the generated on-demand app's
Selections tab to the selection app.
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5. Select Open app from the > menu to open the generated app.
You can also reload data and regenerate an on-demand app. The Reload menu is available
when the detail panel is open:

The selections on the Reload menu work as follows:
l Reload: reloads the data based on the current selections that have been made within

the on-demand app.
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l Regenerate using current selections: regenerates the on-demand app using the
current selections that have been made within the selection app.

The Apply button on the Selections tab applies the on-demand app's
selections to the selection app. The on-demand app's selections are those
listed as Selections made when this app was generated. For more
information, see the illustration above.
This is the reverse of what is done when Regenerate using current
selections is used.

l Regenerate copy using the current selections: generates a new on-demand app
using the current selections that have been made within the selection app. The
previously generated on-demand app remains in its current state.

Exploring a published on-demand app
Most users who use on-demand apps to explore big data sets access them as published apps.
There are two points at which most users will use on-demand apps:

1. In a published on-demand selection app, where the user selects data and generates an on-
demand app from the App navigation bar.

2. In a stream where a generated on-demand app is published.

Published on-demand apps have a preselected subset of data from a very large data source. You
can explore that data through the visualization objects in the on-demand app. In that way, on-
demand apps are like apps created with data from any other source.

You cannot change them after they have been published, though like other published apps, you can
add private sheets and stories if you have the correct access rights. You work with published on-
demand apps the same way you work in other published apps.

Styling an app
You can apply styling to customize the app based on your company standards. The
selected styling will be applied to all sheets in the app. Once the app has been
published, you cannot change the app styling.
Styling an app
The following styling options are available:

l Changing the direction of the characters in strings of text or numbers.
l Changing the default app theme.
l Toggling the context menu on or off for all visualizations.
l Toggling the hover menu on or off for all visualizations.
l Changing the background color for the sheet titles.
l Changing the sheet title font color.
l Adding and aligning an image, such as a logo.
l Toggling the toolbar and header on or off for all sheets.
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More styling can be applied to an app by a developer through custom theme extensions.

Custom styling on individual objects override app styling.

Opening app options
You can open app options from anywhere in an unpublished app.

Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Click   to close app options.

App options are not available on a mobile device.

As of Qlik Sense June 2018, app options is not available on a published apps even when
having custom security rules defined with Update action on App resources.

Changing the reading order

Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Under Appearance > Right-to-left, select On or Off.

If a visualization is shared using Qlik Sense Charts, changing the reading order in the app
will also affect the reading order in the shared chart. .

Changing the default app theme
You can apply one of the default Qlik themes or any custom theme that you have created and
installed.

The default Qlik themes are: 

l Sense Horizon - This is the default theme when you create a new app.
l Sense Classic - Provides a more compact view of objects, and limits the space between

them.
l Sense Focus - Adjusts the padding and spacing around objects as well as provides

designated spaces for titles.
l Sense Breeze - Based on Sense Focus but with different color settings.
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Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Select the theme to apply from the App Theme drop-down menu.

You cannot change themes in published apps.

Custom themes
You can also create custom themes based on your company standards. With themes you can
precisely style an app by changing the colors, adding images and backgrounds as well as
specifying the fonts, font sizes, font weights and font styles on a global or granular basis
throughout your app. You can also define color palettes and customize the specifications for
margins, padding and spacing.

Custom themes are supported when exporting sheets and charts in PDF format. This
applies to manually exported PDFs, as well as to PDFs exported automatically using
subscriptions or via Qlik Reporting Service. However, a PDF generated from an app that
uses a custom theme may look different than seen in the app.

Custom themes are not dependent on the app. This means that if you for example
change the colors defined in a custom theme these will be updated in all apps using the
theme, even if the app is published.

When you have created a custom theme, you store it in Qlik Sense as an extension. The JSON file
and any additional resources, such as CSS files, are zipped and imported as an extension in the Qlik
Management Console (QMC). This enables that security rules can be added in the QMC for
controlling which themes specific users have access to.

Custom themes appear under Custom in the App theme drop-down menu.
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App theme drop-down menu

Turning off the hover menu and context menu
The hover and context menus are interactive elements that are displayed when users interact with
charts. Both menus provide access to the options menu, where the user can perform various
actions related to a chart. See: Options menu

You can turn off one or both of these menus to customize the interactive experience for app users.

Turning off the hover menu
You can choose to turn off the hover menu that appears on visualizations when users place their
cursor over them. This will affect all visualizations in the app.

Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Turn off the Show hover menu for visualizations setting.

You can turn off the hover menu for a single visualization in edit mode.

Do the following:

1. In edit mode, select the visualization.
2. In the properties panel, go to Appearance > General.
3. Turn off the Show hover menu setting.

Create apps and visualizations - Qlik Sense, November 2024 36

/en-US/sense/Subsystems/Hub/Content/Sense_Hub/Sheets/sheet-view.htm


2   Creating apps

Turning off the context menu
The context menu is shown when a user right-clicks a chart, or when a user has activated Touch
screen mode and long touches a chart. You can turn off the context menu for all visualizations.

Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Click Context menu for visualizations.

Changing the chart animations
Chart animations are the gradual transitions in a visualization from the old view to the new view
when data has been changed, after for example a selection has been made.

Chart animations can be turned off in the app settings. They are available for the following chart
types:

l Bar charts
l Bullet charts
l Combo charts
l Line charts
l Pie charts
l Scatter plots
l Funnel charts (Visualization bundle)
l Grid charts (Visualization bundle)
l Sankey charts (Visualization bundle)

Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Under Appearance > Chart animations, select On or Off.

Hiding toolbar, sheet header, and app navigation bar options
You can hide the toolbar and sheet header in your app. This means that these areas will not display
on any sheet, for any user, regardless of permissions. Any user with Can edit rights in the app can
toggle these elements on or off. You can also hide individual elements in your app navigation bar,
toolbar, and sheet header.

Toolbar
The toolbar is the area above the sheet that contains the following buttons:

l Assets
l Bookmarks
l Sheets
l Insight Advisor
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l Selections (shown with icon)
l Edit sheet

You can optionally hide Assets, Bookmarks, and Sheets in the toolbar.

Do the following:

1. In the navigation bar, click the app name, and then click  to open app options.

2. Under Appearance, after UI settings, click .

3. Do one of the following:
l To hide the toolbar, turn off Toolbar.
l To hide Assets, under Toolbar, select Assets.
l To hide Bookmarks, under Toolbar, select Bookmarks.
l To hide Sheets, under Toolbar, select Sheets.

4. Click Done.

Sheet header
The sheet header is the area on the sheet that contains the sheet title, title image, and the sheet
navigation arrows.

If you hide the sheet header, the navigation arrows move to the toolbar.

You can optionally hide the sheet title.

Do the following:

1. In the navigation bar, click the app name, and then click  to open app options.

2. Under Appearance, after UI settings, click .

3. Do one of the following:
l To hide the sheet header, turn off Sheet header.
l To hide the sheet title, under Sheet header, select Sheet title.

4. Click Done.

App navigation bar
You can optionally hide the following options in the app navigation bar for your app:

l Logo
l Navigation
l Ask Insight Advisor
l Resource center
l Notifications
l Profile
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Do the following:

1. In the navigation bar, click the app name, and then click  to open app options.

2. Under Appearance, after UI settings, click .

3. Under App navigation bar, select the options you want to hide in the app navigation bar.
4. Click Done.

When to use it

Advantages
Hiding the toolbar and sheet headers creates more space for charts, filter panes, and other objects.

Turning off sheet headers means that this area will not appear when you download or share sheets,
send subscriptions, or generate Qlik Application Automation reports. This is helpful if you are using
your sheets to create PowerPoint presentations or dashboards.

Removing the toolbar means app developers have more control over which features other users
can access easily. For example, hiding the Edit sheet button might discourage other app
developers from editing the app.

Disadvantages
Hiding the toolbar does not completely remove capabilities such as bookmarks, notes, Insight
Advisor, or sheet editing. For example, bookmarks can still be found in the app overview. However,
app consumers may think that these features are no longer available.

If you hide the toolbar and sheet header, the only way to navigate between sheets is by using
keyboard shortcuts or button objects.

If the selections area is hidden, users may not realize that selections have been applied to the app.
You may need to add filter panes to your sheets or filters to individual charts.

Examples
A sheet displaying the toolbar and sheet header. The toolbar shows Notes, Insight Advisor, current
selections, and more. The sheet header contains the title image, sheet title, and navigation arrows.
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The same sheet as above, but the toolbar is visible and the sheet header is hidden. Users can no longer see
the title image, sheet title, or navigation arrows.

The same sheet as above, but the sheet header is visible and the toolbar is hidden. Users cannot see which
selections have been applied.

The same sheet as above, but the header and toolbar have both been hidden.

Changing sheet title colors
The sheet title background color can be set to a solid color or a gradient of colors by selecting two
colors. The sheet title font can only be set to a solid color.

If you are using a mobile device, the sheet title background is displayed as one solid
color even if two colors has been set.

When choosing colors, you have the following options: 

l Choose a color from the default color palette.
l Set a Hex color by typing 6 characters in the # input field.
l Click the palette to show more color options:

l Click the color wheel to select color.
l Drag the slider to change the color saturation.

Create apps and visualizations - Qlik Sense, November 2024 40



2   Creating apps

Choosing a color from the default color palette

Do the following:

1. Click   in a color drop-down.
The dialog opens and displays the default colors.

2. Click one of the colors in the palette.
The color is selected.

3. Click outside the dialog.
The dialog is closed.

Now you have set a color by selecting in the default color palette.

Color dialog with the default color palette and a blue color selected.

Typing a Hex color

Do the following:

1. Click   in a color drop-down.
The dialog opens and displays the default colors.

2. Type 6 characters in the Hex input field #.
The color is selected in the palette.

3. Click outside the dialog.
The dialog is closed.

Now you have set a color by typing the 6 hexadecimal digits.
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Using the advanced color options

Do the following:

1. Click   in a color drop-down.
The dialog opens and displays the default colors.

2. Click   at the bottom of the dialog.
The dialog changes and displays the advanced options.

3. Do one of the following:
l Click in the color wheel.

The color changes and the Hex color code updates accordingly.
l Drag the slider.

The saturation changes and the Hex color code updates accordingly.
Either way a color is selected.

4. Click outside the dialog.
The dialog is closed.

Now you have set a color by using the color wheel and/or the slider.

Color dialog with the advanced options and a blue color selected.

Adding an image
You can add an image to the sheet title, such as a logo. The following formats are supported: .png,
.jpg, .jpeg, and .gif.

Do the following:

1. Click the image placeholder next to Image.
The Media library opens.
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2. Click on a folder in the media library (for example, In app or Default).
3. Select the image that you want to add to the sheet title.

A preview of the image is shown.
4. Click Insert.

The image is added.

Now you have added an image to the sheet title.

Reloading app data
Apps in the hub do not automatically update when their data sources are updated.
Reloading an app updates it with the latest data from the app data sources. The first
time you reload an app, a reload task is automatically created with a once-only trigger.

Do the following:

l Right-click the app and select Reload.

Manage the new reload task in the hub by right-clicking the app and selecting Manage
reload tasks. For example, you can view, stop, or start the reload task. For more
information about managing and scheduling reload tasks in the hub, see Managing app
reload tasks (page 43). Administrators can also schedule app reloads in QMC. For more
information, see Creating reload tasks.

App reload permissions
To reload an app in the hub, you must have update access to the app and the appropriate
permissions, set by an administrator in the QMC. For more information, see Configuring reload task
management for the hub.

Managing app reload tasks
View and manage app reload tasks from the hub. Manually start reload tasks or create
new reload tasks with scheduled triggers to execute the reload automatically. You can
also edit and delete reload tasks.

App reload tasks that are created by an administrator in QMC also display in the hub. To view the
reload tasks for an app in the hub, right-click the app and select Manage reload tasks.

You must have the appropriate permissions, set in the QMC, to manage app reload tasks
in the hub. For more information, see Configuring reload task management for the hub.

Manage reload tasks displays the following information and options:
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l Name: Task name.
l Enabled: If the reload task is enabled or disabled. Disabled tasks cannot be managed or

enabled from the hub.
l Status: Displays the current status of the task. You can click to view a summary of the

latest task execution. You can also click Download script log to download the script log.
l Last execution: Displays when the task was last executed.
l Next execution: Displays when the task is next scheduled to run.
l Actions: Management option for the task. You can click to start tasks or click to stop

tasks. Click to edit a task or to delete a task.
l Create task: Add a new app reload task and set task properties including creating scheduled

triggers.

You can click to refresh the task view.

Creating app reload tasks
Create an app reload task in the hub. When executed, the reload task fully reloads the data in an
app from the source. Any old data is discarded. App reload tasks must include a scheduled trigger
to execute the reload task automatically. The trigger determines the number of times the task will
run (from one to infinity) and the frequency of the reload (once, daily, weekly, or monthly). For
example, you can create a trigger to reload task to run 56 times, an app on a weekly basis. Create
scheduled triggers for your tasks to reload app data at a specific time, date and frequency.

For information about creating app reload tasks in QMC, see Creating reload tasks.

You must have the appropriate permissions, set in the QMC, to create app reload tasks
in the hub. For more information, see Configuring reload task management for the hub.

Do the following:

1. In the hub, right-click the app that you want to create a reload task for, and then click
Manage reload tasks.

2. Click Create task.
3. Enter a name for the task in the Name field.
4. Under Execution, review the default settings and edit any of the following properties:

a. Select or clear Enabled to enable or disable the task. The task is Enabled by
default.

b. Task session timeout (minutes): The maximum period of time before a task is
aborted if the session times out. The default setting is 1440 minutes.

c. Max retries: The maximum number of times the scheduler will try to rerun a failed
task. The default setting is 0.

5. Click Create.

6. In the Tasks list, under Actions, click to open the task properties.
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7. Click Create scheduled trigger and select the properties that you want to set for the trigger.
Scheduled triggers

Property Description

Trigger
name

Name of the trigger. Mandatory.

Enabled Status of the trigger. When selected, the trigger is active.

Time zone The time zone of your operating system, at the time you create the trigger.
When you save a trigger, the settings are kept, and if you move to a
different time zone, the original values are still displayed. If you want to
change the time zone and start time of a trigger, you need to do that
manually.

For a trigger that was created before the introduction of the time
zone setting, all times and dates are by default presented in
Coordinated Universal Time (UTC).

Daylight
saving time

Way to account for daylight saving time.
Observe daylight saving time: This option takes daylight saving time
(DST) into account. If DST is in use in the selected time zone, the execution
time and date are adjusted accordingly.
Permanent standard time: This option does not take DST into account. If
DST is in use in the selected time zone, the execution time and date are not
adjusted.
Permanent daylight saving time: This option takes DST into account. If a
time zone uses DST, execution time and date are always according to DST,
even during periods when DST is not in use.

For time zones not using DST, always select Permanent
standard time.

Example:

You created a trigger for an event at 10:00 AM, while you were working in
Ottawa, Canada, in January. The time zone is (GMT-0500) Eastern Time
(US & Canada) and DST is used between March and November.
If you select Observe daylight saving time, a trigger set to start at 10:00
will always start at 10.00.
If you select Permanent standard time, a trigger set to run at 10:00 will run
at 10:00 in the winter but at 09:00 in the summer.
If you select Permanent daylight saving time, a trigger set to run at 10:00
will run at 11:00 in the winter and at 10:00 in the summer.

Scheduled trigger properties in the hub
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Property Description

Start Start time and date:
l Start time: (hh:mm)
l Start date: (YYYY-MM-DD)

End End time and date:
l End time: (hh:mm)
l End date: (YYYY-MM-DD)

Select Infinite to create a trigger with no end date.

Schedule Frequency of the trigger:

l Once.

l Hourly. Time period between executions of the trigger. Edit Repeat
after each by typing the values for:

l hour(s) (default is 1)
l minute(s) (default is 0)

l Daily. Time period between executions of the trigger. Type a value
for Every day(s) (default is 1). For example, type 2 to repeat the
trigger every second day.

l Weekly. Time period between executions of the trigger:
l Type a value for Every week(s) (default is 1).
l Select one or more days under On these weekdays to

determine which days the trigger is repeated (on the weeks
you have specified). For example, type 3 and select Mon to
repeat the trigger on Mondays every third week.

l Monthly. Select one or more days under On these days to define the
days when the trigger is repeated every month.

If you have selected Monthly and want to be sure that a
trigger is repeated every month, you need to select a day
no later than the 28th.

8. Click Create, and then click Apply to add the trigger to the reload task.

After adding a trigger for a reload task, click Refresh task list in the notification
message or click in the task list to see the next execution time for the reload task in
task list.
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Editing app reload tasks
Edit app reload tasks in the hub. For example, create a new scheduled trigger, update the task
name or execution details, or edit the properties of a scheduled trigger.

You must have the appropriate permissions, set in the QMC, to edit app reload tasks in
the hub. For more information, see Configuring reload task management for the hub.

Do the following:

1. In the hub, right-click the app with the reload task that you want to edit, and then click
Manage reload tasks.

2. In the Tasks list, under Actions, click to open the task properties.

3. Edit the task properties.
a. You can change the task name in the Name field.
b. You can change the Execution properties.

l Select or clear Enabled to enable or disable the task. The task is Enabled by
default.

l Task session timeout (minutes): The maximum period of time before a task is
aborted if the session times out. The default setting is 1440 minutes.

l Max retries: The maximum number of times the scheduler will try to rerun a
failed task. The default setting is 0.

c. Create a new trigger. Select Create scheduled trigger, set the properties (see
descriptions below) for the new trigger, and then click Create to add the trigger to the
reload task.

d. Edit a scheduled trigger. In the Triggers list, under Actions, click . Set the
properties (see descriptions below) and click OK to save your changes.
Scheduled Trigger

Property Description

Trigger
name

Name of the trigger. Mandatory.

Enabled Status of the trigger. When selected, the trigger is active.

Scheduled trigger properties in the hub
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Property Description

Time zone The time zone of your operating system, at the time you create the
trigger. When you save a trigger, the settings are kept, and if you
move to a different time zone, the original values are still displayed. If
you want to change the time zone and start time of a trigger, you
need to do that manually.

For a trigger that was created before the introduction of
the time zone setting, all times and dates are by default
presented in Coordinated Universal Time (UTC).

Daylight
saving time

Way to account for daylight saving time.
Observe daylight saving time: This option takes daylight saving
time (DST) into account. If DST is in use in the selected time zone, the
execution time and date are adjusted accordingly.
Permanent standard time: This option does not take DST into
account. If DST is in use in the selected time zone, the execution time
and date are not adjusted.
Permanent daylight saving time: This option takes DST into
account. If a time zone uses DST, execution time and date are always
according to DST, even during periods when DST is not in use.

For time zones not using DST, always select Permanent
standard time.

Example:

You created a trigger for an event at 10:00 AM, while you were
working in Ottawa, Canada, in January. The time zone is (GMT-0500)
Eastern Time (US & Canada) and DST is used between March and
November.
If you select Observe daylight saving time, a trigger set to start at
10:00 will always start at 10.00.
If you select Permanent standard time, a trigger set to run at 10:00
will run at 10:00 in the winter but at 09:00 in the summer.
If you select Permanent daylight saving time, a trigger set to run at
10:00 will run at 11:00 in the winter and at 10:00 in the summer.

Start Start time and date:
l Start time: (hh:mm)
l Start date: (YYYY-MM-DD)
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Property Description

End End time and date:
l End time: (hh:mm)
l End date: (YYYY-MM-DD)

Select Infinite to create a trigger with no end date.

Schedule Frequency of the trigger:

l Once.

l Hourly. Time period between executions of the trigger. Edit
Repeat after each by typing the values for:

l hour(s) (default is 1)
l minute(s) (default is 0)

l Daily. Time period between executions of the trigger. Type a
value for Every day(s) (default is 1). For example, type 2 to
repeat the trigger every second day.

l Weekly. Time period between executions of the trigger:
l Type a value for Every week(s) (default is 1).
l Select one or more days under On these weekdays to

determine which days the trigger is repeated (on the
weeks you have specified). For example, type 3 and
select Mon to repeat the trigger on Mondays every third
week.

l Monthly. Select one or more days under On these days to
define the days when the trigger is repeated every month.

If you have selected Monthly and want to be sure
that a trigger is repeated every month, you need to
select a day no later than the 28th.

4. Click Apply to save your changes.

If you modified a task trigger, click Refresh task list in the notification message. You can
also click to refresh the task list.

Deleting app reload tasks
You must have the appropriate permissions to delete app reload tasks in the hub. For more
information, see Configuring reload task management for the hub.

Do the following:
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1. In the hub, right-click the app with the reload task that you want to delete, and then click
Manage reload tasks.

2. In the Tasks list, under Actions, click .

Converting a QlikView document into a Qlik Sense app
If you have a QlikView document, you can reuse part of your work in Qlik Sense. The load script and
data model can be used to create an app in Qlik Sense. Visualizations, dimensions and measures,
however, have to be created in Qlik Sense.

After converting the document to an app, you may need to adapt the load script to be able to reload
the script in Qlik Sense. In some cases, you may need to make some changes in the QlikView script
before you convert the document.

Qlik Sense provides a tool to help convert a QlikView document (QVW file) to a Qlik Sense app. The
tool converts visualizations, dimensions, measures, and variables. You must have access to the Dev
Hub To use the QlikView to Qlik Sense converter.

Instructions for how to use the converter tool are provided on the Qlik Sense Developer site.
≤ For more information, see QlikView converter.

If you do not have access to the Dev Hub, you can convert a QlikView document manually.

We recommend that you make changes only in a duplicate of any app that you convert,
so that your changes are not overwritten by a later conversion.

Manually converting a QlikView document into a Qlik Sense app
You can manually convert a QlikView document (QVW file) to a Qlik Sense app. If you
have access to the Dev Hub, you can use the QlikView to Qlik Sense converter tool to
simplify the process.

The QlikView to Qlik Sense converter is described on the Qlik Sense Developer site.

Prerequisites
l You need to have Qlik Sense Desktop installed to be able to convert a QlikView document

into a Qlik Sense app.
l Your computer must have sufficient memory, at least 32 GB, when converting a large

QlikView document.
l If the QlikView document contains hidden script or uses section access, you need to have full

access to the hidden script and section access of the document.
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Before converting the document
The Always One Selected Value property for QlikView list boxes or multi boxes must be disabled
in order to clear selections in the Qlik Sense app. If your QlikView document contains hidden script
or uses section access, you need to adapt the document before you convert it.

Converting hidden script tabs
When a QlikView document with hidden script is converted, the hidden script part will be
disregarded and not included in the Qlik Sense script. If you want to convert the entire script, do the
following before converting the document. This requires that you have access to the hidden script
in the QlikView document.

Do the following:

1. Open the document in QlikView Script Editor.
2. Copy the code from the hidden script tabs and paste it into regular script tabs.
3. Save the document.

It is not possible to hide script code in Qlik Sense.

Removing section access code
A QlikView document with section access cannot be imported to Qlik Sense, as there are
differences in format and supported functionality. You can still convert the document manually.

Do the following:

1. Remove the section access code in QlikView Script Editor before converting the document.
This requires that you have full access to the script of the document.

2. Convert the document into an app.
3. Reapply section access in the Qlik Sense app. There are some differences that you may need

to take account for:
l User authentication is changed. The USERID field is now used to authenticate all

users, and the NTNAME and PASSWORD fields are not supported anymore.
l If you have access to the script, but not to the data, you can open the app without data

and edit the script, including the section access.
l Section access is applied using strict exclusion in Qlik Sense. This means that you can

only see data that you have been specifically granted access to.

QlikView variables excluded from export
A number of variables are not exported from a QlikView document (QVW) as they are only relevant
for QlikView or is handled differently in Qlik Sense.

The following variables are not exported from a QlikView document:
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l All variables starting with CD
l All variables starting with FLOPPY
l QvPath
l QvRoot
l QvWorkPath
l QvWorkRoot
l WinPath
l WinRoot
l ErrorMode
l StripComments
l ScriptErrorCount
l ScriptError
l ThousandSep
l DecimalSep
l MoneyThousandSep
l MoneyDecimalSep
l MoneyFormat
l TimeFormat
l DateFormat
l TimestampFormat
l MonthNames
l DayNames
l ScriptErrorDetails
l ScriptErrorList
l OpenUrlTimeout
l HidePrefix
l FirstWeekDay
l BrokenWeeks
l ReferenceDay
l FirstMonthOfYear
l CollationLocale
l LongMonthNames
l LongDayNames

Converting the document into an app

Do the following:

1. Copy the QlikView document (qvw format) to the directory where your apps are located.
This is usually <user>\Documents\Qlik\Sense\Apps, but the location of the Apps directory
depends on where you installed Qlik Sense Desktop.
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2. Start Qlik Sense Desktop.
You now see the QlikView document as an app in the hub, with the name ending with (qvw).

3. Click on the app to open it.

The app is saved into the Qlik Sense format (qvf file) in the folder where your QlikView document
(qvw file) was stored. Also, the QlikView document file (qvw) is removed from the folder and
automatically converted into a backup file (qvw.backup) stored here:
<user>\Documents\Qlik\Sense\AppsBackup.

You have now migrated a QlikView document into a Qlik Sense app. The app contains the data
model, including the loaded data, and the data load script.

You can use the data model to build visualizations, copy it or import it into your server environment
through the Qlik Management Console (QMC), but you need to adapt the load script before you can
reload the data model.

You can also drag and drop a qvw file from a folder onto the Qlik Sense Desktop hub, to
open it as a Qlik Sense app. If the Qlik Sense app (qvf file) becomes stored in another
folder than <user>\Documents\Qlik\Sense\Apps, move it to the Apps folder to make it
available from the hub.

Adapting the data load script in Qlik Sense
Qlik Sense and QlikView data load scripts are compatible in general, but there are some differences
that you may need to take account for and adapt the script in the data load editor before you can
reload data. You can adapt the script directly in Qlik Sense Desktop, or you can import the app into
Qlik Sense and then adapt the script.

Change file path references to data connections
QlikView uses absolute or relative file paths which are not supported in Qlik Sense standard mode,
so you need to use folder data connections to point to file locations instead.

Do the following:

1. Create folder data connections for all file paths that are used in the data load script.
You need to check statements and functions that refer to files. LOAD statements are the
most common ones, but there is a complete list available.

2. Replace all references to absolute or relative file paths in the script with lib:// references to
the data connections you created.
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Original script in QlikView Adapted Qlik Sense script

LOAD * FROM [C:\data\Tutorials

source\Sales rep.csv];

LOAD * FROM [lib://Tutorials

source/Sales rep.csv];

In this case, the Tutorials source folder
data connection should be pointing to
C:\data\Tutorials source\, or where the
data is located if you have moved the app
to another computer or a Qlik Sense
server.

FileSize('C:\data\Tutorials source\Sales

rep.csv')

FileSize('lib://Tutorials source/Sales

rep.csv')

for each Dir in dirlist

('C:\data\Tutorials source\*' )

for each Dir in dirlist

('lib://Tutorials source/*' )

Examples

Handling features that are not supported or recommended
There are some features in QlikView that are not supported or recommended in Qlik Sense, for
example:

l Input fields
l Message boxes
l Bundle and Info load
l ALL qualifier

We recommend that you check your script code against these lists of statements and functions that
are not supported or recommended, and adapt the code according to recommendations.

Installing custom connectors
If your QlikView document uses custom connectors to access data, you should be able to use them
to load data in Qlik Sense as well without changes in the script. This requires that the same
connector is installed on the Qlik Sense computer.

If you want to make any changes in the data selection by the custom connector, you need to install
a version of the custom connector adapted for Qlik Sense.

Changing the title and description of an app
You can change the title and description of your apps. When creating a new app the
name of the app is used as its title. When you change the title, the name of the app is
not changed.

Do the following:
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1. In the app overview, click in the app details area.

2. Edit Title and Description.

3. Click  to stop editing.

The changes you made are saved.

You can only change the title and description of an unpublished app.

You can open or close the app details area by clicking the app name in the navigation
bar.

Changing the thumbnail of an app
You can replace the default thumbnail of an app with another thumbnail, to make it easier to
distinguish between apps in the hub. You can use one of the default images, or an image of your
own.

Do the following:

1. In the app overview, click in the app details area.

2. Click on the default thumbnail.
The Media library opens.

3. Click on a folder in the media library, for example In app or Default.
4. Select the image you want to use as a thumbnail for the app and click Insert.

5. Click  to stop editing.

The image you selected is now used as a thumbnail for the app.

The optimal aspect ratio of a thumbnail is 8:5 (width:height).

The following formats are supported: .png, .jpg, .jpeg, and .gif.

For Qlik Sense: You can upload images to the In app folder in the media library. You need to use the
Qlik Management Console to upload images to the default folder.

For Qlik Sense Desktop: You can place images in the following folder on your computer:
C:\Users\<user>\Documents\Qlik\Sense\Content\Default. Images will be available in the default
folder in the media library. When moving an app between installations, the images that you use in
the app are saved in the qvf file together with the app. When you open the app in a new location,
the images will be in the In app folder in the media library for the app.

You can only change the thumbnail of an unpublished app.
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You can open or close the app details area by clicking the app name in the navigation
bar.

Duplicating an app
You can duplicate an existing app, to create a copy to develop further. You can only duplicate an
app that you have created yourself unless your administrator has assign you a security role with
duplication enabled.

If you have an admin role, giving you the administration rights needed, you can create duplicates of
apps from the QMC.

When you duplicate a published app, only the base sheets and stories will be included in
the copy.

Do the following:

l In the hub, right-click the app you want to duplicate and select Duplicate.
A toast notification is displayed for a while, at the bottom of the screen, when the duplication
starts. A new toast notification will be displayed when the app has been duplicated and give
you the possibility to update the app list. If the duplication fails, an error message will be
displayed.

A copy of the app is created under Work. You can click the app to open it and start adapting it
according to your preferences.

Because of how the synchronization of data works in multi-node sites, apps containing
images may display broken thumbnails or images inside the apps if opened right after
being duplicated or imported. The broken images are restored when the synchronization
is complete. To check if the images have been restored, refresh the browser window.

Making apps available in Insight Advisor Chat
You can make your apps available in Insight Advisor Chat in the hub.

When your app is available, users with access to that app can search Insight Advisor in your app
with Insight Advisor Chat.
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Apps that use Section Access require additional configuration for service users to be
available in Insight Advisor Chat. If you have sensitive information in app names, field
names, or master item names, these may be exposed by making apps using Section
Access available for Insight Advisor Chat. App suggestions for queries include apps in
streams to which users have access. These may include apps to which users do not
have access in an app's Section Access. Selecting these apps will do nothing, however.
When clicking Dimensions or Measures to view the available items from an app using
Section Access, users may see items to which they do not have access. Clicking on
these items will not provide any data to the users, however.

App content availability in Insight Advisor Chat
What users can search for and access with the Measure and Dimension buttons with Insight
Advisor Chat depends on if the app is published and if there is a logical model applied to your app.

For your own unpublished apps, you can search for fields and master items from the app. For
published apps, users can search for only master items. If you have business logic applied to an
unpublished or published app, then users can search for available fields and master items based on
the logical model.

Clicking the Measure or Dimension button (or entering show measure or show dimension) will
show the corresponding master items. If the app has no master items, fields related to measures or
dimensions are shown instead. Fields or master items hidden in the logical model will not appear
when the button is clicked, but can be searched for in a query.

Turning on Insight Advisor Chat

Do the following:

1. In your app, click the app name in the navigation bar.

2. In the app details area, click .

3. Turn on Insight Advisor in hub.

Turning on chart level scripting
By default, chart level scripting is disabled in apps. You can turn it on in app details.

Do the following:

1. In your app, click the app name in the navigation bar.

2. In the app details area, click .

3. Turn on Chart scripting.
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Turning off Insight Advisor
By default, Insight Advisor Search and Insight Advisor Analysis Types are enabled in
apps. You can turn off Insight Advisor to prevent users from accessing these features.

Do the following:

1. In your app, click the app name in the navigation bar.

2. In the app details area, click .

3. Turn off Insight Advisor in this app.

Deleting an app
You can delete an app that you no longer need.

From the hub, you can only delete apps that you have created and that have not yet
been published.

If you have published an app, the published version is locked and can only be deleted from the Qlik
Management Console. The published version is a duplicate of the original app. The original version
of the app can be deleted from your personal work in the hub.

Do the following:

1. Right-click the app in the hub and select Delete.
A confirmation dialog opens.

2. Click Delete.
A toast notification is displayed for a while, at the bottom of the screen, when the app is
being deleted. If the deletion fails, an error message will be displayed.

You can delete a published app from the Qlik Management Console.

If an app is being deleted by someone else from the stream you are currently viewing, a toast
notification will be displayed and give you the possibility to update the app list.

Uploading image files to media library
You can upload images to the media library. Because of limitations in the web browsers supported
by Qlik Sense, it is recommended to keep the height and width as well as the file size of the images
as small as possible. The maximum file size is 5 MB.

The following formats are supported: .png, .jpg, .jpeg, and .gif.

For Qlik Sense: You can upload images to the In app folder in the media library. You need to use the
Qlik Management Console to upload images to the default folder.
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For Qlik Sense Desktop: You can place images in the following folder on your computer:
C:\Users\<user>\Documents\Qlik\Sense\Content\Default. Images will be available in the default
folder in the media library. When moving an app between installations, the images that you use in
the app are saved in the qvf file together with the app. When you open the app in a new location,
the images will be in the In app folder in the media library for the app.

You can open the media library in several ways:

l From the app details area. Do the following:
1. In an app, click the app name in the navigation bar at the top of the screen.

2. Click in the app details area.

3. Click on the app thumbnail.
l When editing a sheet. For example:

l Double-click a Text & image visualization on the sheet and click .

l Click the title area on a sheet. Next, in the properties panel, click under Thumbnail.

l Follow the procedure for adding a background image to a chart or sheet, then click .
Example, for bar chart: Customizing the background (page 183)

l In Storytelling view, click in the toolbar.

The Media library dialog opens and now you can upload images.

Do the following:

1. Select Upload media.
2. Do one of the following:

l Drop one or more image files onto the designated area.
l Click the designated area to open the upload dialog, browse and select images, and

click Open.
An upload indicator is displayed while the image file is being uploaded. You can cancel an
ongoing upload by clicking on on the image.

You cannot upload a file if its file name already exists in the media library.

Now you have added images to the media library. Click the image and select to insert the image.

Deleting image files from media library
You can delete images from the media library in Qlik Sense.

You can open the media library in several ways:

l From the app details area. Do the following:
1. In an app, click the app name in the navigation bar at the top of the screen.

2. Click in the app details area.
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3. Click on the app thumbnail.
l When editing a sheet. For example:

l Double-click a Text & image visualization on the sheet and click .

l Click the title area on a sheet. Next, in the properties panel, click under Thumbnail.

l Follow the procedure for adding a background image to a chart or sheet, then click .
Example, for bar chart: Customizing the background (page 183)

l In Storytelling view, click in the toolbar.

The Media library dialog opens and now you can delete images.

Delete images

Do the following:

1. Select the In app folder.
2. Select the file you want to delete.

3. Click .
A confirmation dialog is displayed.

4. Click Delete.

Now you have deleted images from the media library.

You can also right-click on an image file and select Delete.

For Qlik Sense: You need to use the Qlik Management Console to delete images from the
default folder, or other folders that were created from the Qlik Management Console.

Delete images using Qlik Sense Desktop
You can delete images from the default folder by removing the files from this location:
<user>\Documents\Qlik\Sense\Content\Default.

The images in the In app folder are bundled images, saved in the qvf file together with the rest of
the contents of the app. If a bundled image is no longer used in the app, the image will be deleted
from the qvf file when saving the app.

Best practices for designing accessible apps
Analytics apps support several accessibility features. App creators can also take extra
steps to improve accessibility and make sure that all users can access the information
in their analytics apps.

Analytics apps support the following accessibility features:
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l Default color schemes with high contrast
l Keyboard navigation and keyboard shortcuts
l Screen reader support

When designing apps for accessibility, there are design best practices you should follow.
Additionally, there are specific apps settings you can use to help make your apps more accessible.

Design best practices
When designing for accessibility, follow these best practices:

l Keep a flat sheet structure
l Provide an overview first
l Use accessible colors
l Select visualizations for accessibility
l Avoid storytelling

Keep a flat sheet structure
When adding visualizations to your sheets, use a flat structure with few columns and rows. A flat
structure improves readability for your users. Additionally, it also makes keyboard navigation
easier, as keyboard navigation moves from the top left to bottom right.

Complex sheet layouts with many columns and rows are both harder to understand and harder to
navigate with a keyboard. When designing a sheet, try to navigate it with your keyboard to see how
users may perceive your app.
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A flat sheet layout
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A complex sheet layout

Provide an overview first
When creating sheets, provide an overview first and then provide details. This makes it easier for
users to consume information in your sheets. For example, start by providing summaries and KPIs in
your sheets, and then provide more detail-heavy tables or other visualizations. You can also place
details on another sheet. Alternatively, you could resize the sheet so that it is scrollable and put
additional details further down the sheet.

Select the right visualizations
Analytic apps provide a range of visualizations for use in analytics. Some visualizations are better
choices that other when designing accessible apps. Keep the following in mind when selecting
visualizations:

l Use charts with data view
l Use the straight table from the Visualization bundle
l Avoid using map charts
l Avoid using custom objects
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Use charts with data view
When designing your app, use charts with data view. Data view lets users change the chart to a
table, helping them to inspect and select values.

A pie chart with the same pie chart in data view

Data view is available in the following charts:

l Bar chart
l Box plot (with one or more dimensions)
l Combo chart
l Distribution plot
l Histogram
l Line chart
l Pie chart
l Pivot table
l Scatter plot
l Treemap

Use the straight table from the Visualization bundle
The straight table from the Visualization bundle has an improved navigation experience compared
to the current table visualization. When adding tables to an accessible app, use it instead of the
standard table visualization.

For more information, see Straight table (page 516).

Avoid using map charts
The map chart is not navigable with keyboard navigation. When creating accessible apps, consider
using alternative ways of presenting your geographic data.

Avoid using custom objects
The charts in the Dashboard or Visualization bundles, aside from the straight table, may not be as
accessible as other charts. They are not recommended for use in accessible apps. Additionally, if
you do use extensions, test them to confirm they are accessible for your users.
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Use accessible colors
The spectrum of colors is narrower for people with color-based visual impairment. They may
interpret your visualizations differently than you intended. For example, some users may have
difficulty with reds and greens in your visualizations. Lines, bars, and pie slices can also be difficult
to distinguish when the colors do not have enough contrast.

It is best to use a simple color scheme in your app. The default app color schemes each have 12
colors that contrast with each other. It is better to use three to five colors if possible, or even a color
scheme based on a single color. You can create your own custom color schemes and use them in all
your accessible apps. For more information, see Create custom themes.

You can also set some colors manually, separately from themes. For dimensions, you can set assign
colors to values in master dimensions. For more information, see Assigning colors to master
dimension values (page 145). You can also color by expressions to set colors. For more information,
see Examples (page 624). To learn more about coloring options for visualizations, see Coloring a
visualization (page 616).

Adding shapes as performance indicators in KPIs
Consider adding shapes as performance indicators in your KPIs. These add context and make your
KPIs more accessible. For example, you could use a red empty circle to denote bad results, a green
full circle for good results, and a triangle as a warning symbol that only appears when a KPI status is
at an unacceptable level. For more information, see Adding shapes to KPIs (page 67).

KPI using performance indicator shapes

Avoid storytelling
While stories are useful for presenting discoveries, sheets are more accessible for keyboard
navigation and screen readers. In apps designed for accessibility, it is better to use sheets to
present your discoveries.
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Accessible app settings
Analytics apps have a range of settings that can help improve the accessibility of your apps.

Sheet settings
There are several settings you can change in your sheets to improve accessibility:

l Improve sheet title contrast
l Turn off the hover menu

Improving sheet title contrast
You can improve the visibility of sheet titles by styling them to contrast with your sheets.

Do the following:

1. In the app navigation bar, click your app title.

2. Click to open settings.

3. Under Sheet title styling, adjust your color settings to improve contrast.

Turning off the hover menu.
Turning off the hover menu allows for a smoother navigation experience. There is no loss of
functionality as the options are also available through the context menu and keyboard shortcuts.

Do the following:

1. In the app navigation bar, click your app title.

2. Click to open settings.

3. Under Appearance, turn off Show hover menu for visualizations.

Chart settings
Some charts have options that can help make them more accessible to users. You can:

l Provide text descriptions
l Limit dimension values in visualizations
l Add shapes to KPIs

Providing text descriptions
Visualizations come with fields for titles, subtitles, and footnotes. Providing accurate text
descriptions can help your users navigate your visualizations and provide context to your sheets.
Without context, it can take users longer to find the information that interests them in your sheets.
Titles, subtitles, and footnotes are all read by screen readers as well.

In standard edit mode, when selecting a visualization, you can find titles, subtitles, and footnotes in
Properties, under Presentation > Labels.

In advanced edit mode, you can find titles, subtitles, and footnotes in the properties panel, under
Appearance > General.
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Limit dimension values in visualizations
When working with nominal data in dimensions, try to find hierarchies or make aggregations if the
number of categories is greater than 10. For example, displaying the top 10 values, with the rest
categorized as others, makes your data easier to understand and read aloud. If you need to include
full details, you can include them at the end of the sheet or other sheets.

Do the following:

1. In edit mode, click Advanced options.
2. Select a visualization.
3. In the properties panel, under Data, select your dimension.
4. Under Limitation, select one of the following:

l Fixed number: Select to display the top or bottom values. Set the number of values.
You can also use an expression to set the number. Click to open the expression
editor.

l Exact value: Use the operators and set the exact limit value. You can also use an
expression to set the number. Click to open the expression editor.

l Relative value: Use the operators and set the relative limit value in percent. You can
also use an expression to set the number. Click to open the expression editor.

Abbreviate numbers
Reading, listening to, and understanding long numbers can be a challenge. Where possible,
abbreviate your numbers to keep the number of digits and decimals low.

You can use functions such as Ceil and Round to round numbers. For example, if you wanted to
round measure values to the millions with one decimal place, you could use =Round(Sum

(Sales)/1000000, 0.1).

Adding shapes to KPIs
If you are using conditional coloring for your KPIs, you can add symbols in addition to the color.
Symbols can be used to provide additional performance indicators.

Do the following:

1. Select a KPI visualization, and switch to the properties panel in the advanced edit mode.
2. Select Appearance and expand Color.
3. If necessary, turn off Library colors and turn on Conditional colors.
4. Click Add limit to create a new limit. Multiple limits can be added to a single KPI chart.
5. Specify a value for the limit, or enter an expression using the expression editor.
6. On the Value color bar, click the range area of the KPI you would like to modify.
7. Under Colors, select a preset color or use a custom color.
8. Select Symbols and choose the symbol displayed when your KPI falls within the specified

limit.
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Use dynamic titles
When making visualizations, use dynamic titles to capture the essence of the chart. Rather than just
a generic title, consider building an expression for the title that provides information dynamically
based on user selections.

By using set analysis combined with max(), min(), rank(), and correl() to build the titles, you can
present more dynamically descriptive charts.

For example, this visualization has a static title.

Static title

If dynamic expressions were added to the title and subtitle, the chart would express information
more dynamically and provide users with more information.

Dynamic title and subtitles
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The advantage of the dynamic titles is that it changes based on user selections. In the visualization
below, the three top countries for sales have been selected, changing the title and subtitle of the
visualization.

Dynamic title and subtitles after selections

2.5 Troubleshooting - Creating apps
This section describes problems that can occur when creating apps and visualizations in Qlik
Sense.

Images are not included in an app that has been moved from one
Qlik Sense environment to another

Possible cause

You have created an app in Qlik Sense and moved the app to another Qlik Sense environment.

When you move apps between Qlik Sense environments, images may not have been moved
automatically. The images have to be handled manually, in different ways depending on between
which environments the app has been moved.

Proposed action

Import the images from the Qlik Sense environment where the app was created to the target
location using the Qlik Management Console.

Images are not included in an app that has been imported from Qlik Sense
Desktop to Qlik Sense

Possible cause

You have created an app in Qlik Sense Desktop and imported the app to Qlik Sense.
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When you move apps between Qlik Sense environments, images may not have been moved
automatically. The images have to be handled manually, in different ways depending on between
which environments the app has been moved.

Proposed action

Import the images from the images folder of the Qlik Sense Desktop app using the Qlik Management
Console.

Images are included automatically only when you move an app from one Qlik Sense
Desktop installation to another.

The default location of the images in Qlik Sense Desktop is
<user>\Documents\Qlik\Sense\Content\Default.

If you have organized images in subfolders in the Content\Default folder in Qlik Sense
Desktop, these have to be added manually to the app and its sheets, stories and text &
image objects after importing the images.

Images are not included in an app that has been moved from one
Qlik Sense Desktop installation to another

Possible cause

You have moved an app between Qlik Sense Desktop installations.

When you move apps between Qlik Sense environments, images may not have been moved
automatically. The images have to be handled manually, in different ways depending on between
which environments the app has been moved.

Proposed action

Do the following:

l Copy the images from the PC where the app was created and paste into the images folder of
the target location.

The default location of the images in Qlik Sense Desktop is
<user>\Documents\Qlik\Sense\Content\Default.

The image I want to use does not seem to work
Images are part of apps as thumbnails of the apps, sheets and stories, in the text & image object
and in story slides.

Possible cause

You are using an image in a format that is not supported.
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Proposed action

Do the following:

l Convert the image to one of the supported formats (png, jpg, jpeg or gif).

Using Insight Advisor impacts system performance
Insight Advisor uses master items as fields in recommended charts.

Possible cause

The charts generated by the Insights are choosing fields that end up with costly charts.

Proposed action

Do the following:

l Change what fields are exposed to published app users.

I cannot find Reload when I right-click on an app
I want to reload my app, but I do not see Reload when I right-click on my app.

Possible cause

You are do not have one or more of the following permissions set in QMC:

l Update access to the app.
l Read access to the HubSection_Task resource filter.
l HubAdmin role or Read and Create access to the ReloadTask resource filter.

Proposed action

Contact a QMC administrator to be assigned the HubAdmin role or to get create and read access to
the ReloadTask resource filter.

I cannot manage my app reload tasks in the hub
I want to view my app reload tasks in the hub, but I do not see Manage reload tasks when I right-
click an app.

Possible cause

The security rule HubSectionTask is disabled or you do not have read access to the HubSection_
Task resource filter. Alternatively, you may not have read access to app reload tasks in the hub
configured in QMC.
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Proposed action

Contact a QMC administrator to get read access to HubSection_Task and either read access to app
reload tasks in the hub or to be assigned the HubAdmin role. The HubAdmin role, dy default, has
read access to app reload tasks in the hub.

Thumbnails are not included when copying a sheet

Possible cause

You have copied a sheet from another app. Thumbnails are stored as app resources and are not
included when you copy a sheet. Copying sheets within an app works fine.

Proposed action

You can copy an entire app and use that as starting point. This will include all resources, such as
images.

Right-to-left reading order works for some visualizations, but not
others

Possible cause

You might notice some visualizations in Qlik Sense can display right-to-left languages such as
Arabic or Hebrew without right-to-left reading order being activated in the app. However, to
guarantee that the right-to-left reading order is applied correctly at all times and to all visualizations
in the app, you need to activate this setting in the app.

Proposed action

Activate right-to-left reading order in the app to ensure the setting is applied to all visualizations in
the app.

Do the following:

1. In an unpublished app, click   and then click   to open app options.

2. Under Appearance > Right-to-left, select On or Off.

If a visualization is shared using Qlik Sense Charts, changing the reading order in the app
will also affect the reading order in the shared chart. .

2.6 Optimizing app performance
App performance can be improved with reduced app size, simplified data models, and
strategic use of set analysis. This section will help you avoid performance issues by
pointing out areas where performance can be impacted and how you can evaluate and

Create apps and visualizations - Qlik Sense, November 2024 72



2   Creating apps

monitor app performance.

App complexity
These are loose categories that can help diagnose issues. The most complex apps have the lowest
performance.

Simple apps:

l Do not include complex set analysis or If() statements.
l Do not include large tables.
l Have a simple data model.
l Contain simple calculations.
l May have large data volumes.

Moderate apps:

l Have a data model with many tables, but follow best practices.
l Use set analysis and several If() statements.
l Have large or wide tables on sheets (15 columns or more).

Complex apps:

l Have a very complex data model.
l Connect to large data volumes.
l Contain complex calculations, charts, and tables.

App details
You need to consider your hardware environment in relation to app size, because it affects the
performance of your Qlik Sense deployment. For example, if you do not optimize your apps, they
may require more hardware resources.

Monitoring app size will help you:

l Understand current performance.
l Understand the performance impact of deploying a new app.
l Understand the performance impact of modifying an existing app.
l Resolve performance issues.
l Plan for future growth.

Qlik provides tools that can help you asses your apps. For more information, see: Performance and
scalability in Qlik Sense Enterprise.

These are the basic app elements that can affect performance:
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Feature Description

App disk size (MB) You can find app size in the QMC. Go to Apps, and open the Column
selector on the right hand side next to Actions. Click the radio button
next to File size (MB). If you are using Qlik Sense Desktop, you can find
app size in Windows Explorer. The default folder is
%USERPROFILE%\Documents\Qlik\Sense\Apps. The Apps folder lists
all app names and file sizes.

App size in RAM (GB) You can determine an app's base RAM footprint by:

1. Restarting the Qlik Sense server.
2. Noting the current RAM usage.
3. Opening up the Qlik Sense app.
4. Recording the difference in RAM.

You can use the App Metadata Analyzer to find this metric if you are
using Qlik Sense June 2018 or later.

App total rows (M) You can use system fields to calculate total rows. Create a KPI with the
measure Sum($Rows).

App total fields You can use system fields to calculate total fields. Create a KPI with the
measureSum($Fields).

App total tables You can use system fields to calculate total tables. Create a KPI with
the measure Count(DISTINCT $Table).

App details that can affect performance

Monitoring your app
The Qlik Management Console (QMC) provides apps for monitoring system performance and usage
on Qlik Sense Enterprise on Windows:

l The Operations Monitor app provides information about hardware utilization, such as server
memory and CPU usage, active users, and reload task activity. It also provides summary and
detailed information about errors, warnings, and log activities in the Qlik Sense server
environment.

l The License Monitor app tracks license usage, and facilitates monitoring changes to license
allocation.

l The Log Monitor app presents nearly all log data available and enables trend analysis and
troubleshooting.

l The Sessions Monitor app shows log data about usage of apps.
l The Reloads Monitor app presents detailed information about reload data, both from the

QMC and apps open in the hub.
l The Sense System Performance Analyzer app displays Qlik Sense performance across all

nodes.
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l The Sense Connector Logs Analyzer app provides insights into usage and errors of specific
Qlik connectors.

l The App Metadata Analyzer app provides a holistic view of all your Qlik Sense apps, including
granular level detail of an apps data model and its resource utilization.

Large data volumes
You can employ these architecture strategies when you are connecting to large data volumes.

Segmentation
You can segment QVDs by dimensions such as time frame, region or aggregation level. For
example, you can have:

l A QVD that contains data from the two most recent years.
l A QVD that contains historical data further than two years.
l A QVD that contains all data aggregated on a higher level. For example, per month instead of

date, or per country instead of individual customers.
l One large QVD with all the data, which is only used by a small subset of users.

You can segment the apps in a similar way. Smaller apps will address the analytical needs of most
users. This saves memory.

You can also have multiple apps focused on different regions. This way, users will not open an app
with data that they are not interested in or do not have rights to access. Data that is not accessible
via section access still affects memory.

On-Demand App Generation (ODAG)
Qlik Sense on-demand apps give users aggregate views of big data stores. They can identify and
load relevant subsets of the data for detailed analysis.

From a user perspective, there are two apps:

1. A shopping cart with aggregated data.
2. An empty template app used to display detail.

The user makes selections in the shopping cart app. Once a threshold has been met, a custom
LOAD script is created which populates the template app with the requested details.

Application chaining
Application chaining (known as document chaining in QlikView) means that there is an aggregated
app, which users consume regularly. If a user needs more detail, selections can be passed from the
aggregated app to a detail app, so that they can view a lower level of granularity. This saves
memory, because users are not loading unnecessary detail. Application chaining can be performed
by adding button objects to a sheet. For more information, see Button (page 388).

Application chaining is also supported via APIs. For example, you can use the App Integration API to
create custom application chaining. For more information, see App Integration API.
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Data model performance
These are indicators that can impact data model performance. Each one is a best practice that will
improve app usability.

Action Description

Synthetic keys removed Qlik Sense creates synthetic keys when
two or more data tables have two or
more fields in common. This may mean
that there is an error in the script or the
data model.

Circular references
removed from data model

Circular references occur when two
fields have more than one association.
Qlik Sense will attempt to resolve these
by changing the connection to one of
the tables. However, all circular
reference warnings should be resolved.

Appropriate granularity of
data

You should only load data that is
necessary. For example: a group of
users only need data divided by week,
month, and year. You can either load in
the aggregated data or aggregate the
data within the load script to save
memory. If a user does need to visualize
data at a lower level of granularity, you
can use ODAG or document chaining.

QVDs used where possible A QVD is a file containing a table of data
exported from Qlik Sense. This file
format is optimized for speed when
reading data from a script, but is still
very compact. Reading data from a QVD
file is typically 10-100 times faster than
reading from other data sources.

Data model performance best practices
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Action Description

QVD files optimized on
load

QVD files can be read in two modes:
standard (fast) and optimized (faster).
The selected mode is determined
automatically by the script engine.
There are some limitations regarding
optimized loads. It is possible to rename
fields, but any of these operations will
result in a standard load:

l Any transformations on the fields
that are loaded.

l Using a where clause causing
Qlik Sense to unpack the records.

l Using Map on a field that is
loaded.

Incremental loads
leveraged

If your app connects to a large amount
of data from databases that are
continuously updated, reloading the
entire data set can be time consuming.
Instead, you should use incremental
load to retrieve new or changed records
from the database.

Snowflake model
consolidated

If you have a snowflake data model, you
may be able to reduce the number of
data tables by joining some of them
using the Join prefix or other mapping.
This is especially important for large
fact tables. A good rule of thumb is to
have only one large table.

Tables that have a small
number of fields are
denormalized

If you have two tables with few fields, it
may improve performance to join them.
.

Denormalized lookup (leaf)
tables with mapping loads

You should not use the Join prefix if you
only need to add one field from a table
to another. You should use the
ApplyMap lookup function.
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Action Description

Time stamps removed or
decoupled from date field

Date fields can fill up space when the
timestamp is present as the string
representation is larger, and the number
of distinct values is larger. If the
precision is not necessary for your
analysis, you can round the timestamp
to e.g. the nearest hour using
Timestamp(Floor
(YourTimestamp,1/24)) or remove the
time component completely using Date
(Floor(YourTimestamp)).

If you want the timestamp, you can
decouple it from the date itself. You can
use the same Floor() function, and then
create a new field with the extracted
time by using something along the lines
of: Time(Frac(YourTimestamp)).

Unnecessary fields
removed from data model

You should only load necessary fields in
your data model. Avoid using Load *
and SELECT. Make sure you keep:

l Fields that are necessary for your
analysis.

l Fields that are actually being
used in the app.

Link tables avoided when
dealing with high data
volumes

You should use link tables where
possible. However, if you are dealing
with large data volumes, concatenated
tables can out-perform link tables.

Concatenated dimensions
broken to new fields

You should break apart concatenated
dimensions into separate fields. This
reduces the number of unique
occurrences of values in your fields.
This is similar to how timestamps can
be optimized.

AutoNumber used where
possible

You can create an optimized load by
loading your data from a QVD file first,
and then using the AutoNumber
statement to convert values to symbol
keys.

Create apps and visualizations - Qlik Sense, November 2024 78



2   Creating apps

Action Description

Data islands avoided Data islands can be useful, but they
usually affect performance. If you are
creating islands for selection values,
use variables.

QVDs are stored based on
incremental timeframes

You should store QVD in segments,
such as monthly. These smaller monthly
QVD can then support many different
apps that might not need all of the data.

Sheet performance
These are best practices that will improve performance of sheets and visualizations.

Action Description

The If() function is avoided
where possible

If the If() function is used inside an
aggregation function, it will operate at
the record level and be evaluated many
times.

For example, if you have 1000 records in
an aggregation, an If() condition will be
evaluated 1000 times. This could
cascade rapidly if you nest statements.
You should use set analysis instead. A
set analysis filter is applied before the
aggregation, resulting in a faster
response. These responses can also be
cached via set analysis, where If()
cannot. You could also consider other
functions and modifications to the data
model.

Sheet performance best practices
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Action Description

Fields from different tables
inside an aggregation table
are avoided where
possible.

When an aggregation is evaluated, the
calculation runs through two steps:

1. The first step is finding the
relevant combinations on which
the to make the calculation. This
step is single-threaded.

2. The second step is performing
the calculation. This step is multi-
threaded.

The single-threaded part can affect
performance considerably. One
example is if you have multiple fields
inside the aggregation, for example,
Sum(Quantity*ListPrice). If Quantity is in
the fact table, and ListPrice is in the
master products table, the engine first
needs to join the two tables to find the
combinations before it can start to sum
the product. The joining is the single-
threaded part, and the summing is
multi-threaded. If both fields are found
in the same table, no join is necessary,
and the aggregation is evaluated
considerably faster.

Aggr() and nested Aggr()
functions are used
minimally

The Aggr() function greatly affects
performance. Incorrect use can give
inaccurate results. For example, in a
table with dimensions that vary from the
dimensions within the Aggr() function.

Set analysis is used where
possible

You can use set analysis to define a set
of data values that is different from the
normal set defined by the current
selections.

String comparisons
avoided where possible

String comparisons are not as efficient
as set analysis. For example, you should
avoid Match(), MixMatch(), WildMatch(),
and Pick(). Create flags in the script or
use set analysis instead.
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Action Description

Calculation conditions are
used on objects containing
intensive calculations

You may have visualizations with many
records when there are no selections.
As a best practice, add calculation
conditions to objects so that they only
render after certain selections have
been made. This stops the creation of
very large hypercubes. For example:
GetSelectedCount([Country])=1 OR
GetPossibleCount([Country])=1. In this
scenario, the visualizationwill not render
unless the user selects a single country,
or makes other selections where only a
single country is possible.

Measures are pre-
calculated in the script
where possible

Any measure that is at the lowest level
of granularity of the data model should
be calculated in the script. For example,
if in the same record in a table you have
Sales and Cost, you could derive the
margin by calculating Sales - Cost AS
Margin. You can also aggregate other
values in advance if you know that they
will not vary based on selection, or that
are bound to a different level of
granularity.

Tables have less than 15
columns and have
calculation conditions

A table with 15 columns could be
considered wide. If your tables consist
of many records, you should use
calculated conditions on the table
object so that it only renders after
certain selections or criteria have been
met. If your table is very wide, consider:

l Creating multiple smaller tables
that show conditionally.

l Using methods to conditionally
show columns.

l Keeping your tables limited to
only what fields are necessary for
your analysis.
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Action Description

Sheets do not have an
excessive number of
objects

Objects are calculated when the user
navigates to the sheet. Every time a
user makes a selection on that sheet,
each object will be recalculated if that
current state does not exist in the
cache. If you have a sheet with many
charts, the user will have to wait for
every object to calculate on nearly
every selection. This puts significant
load on the engine. As a best practice,
follow the
Dashboard/Analysis/Reporting (DAR)
concept to develop a clean and minimal
app.

Numeric flags are
leveraged in the script for
use in set analysis

Set analysis with flags can be more
efficient than using string comparisons
or multiplication.

Master items or
variablesused for
expressions

Master items enable drag and drop of
governed metrics and guarantee that
expressions will be cached. For
example, Sum(Sales) is different from
SUM(Sales). Expressions are cached on
spelling and case, and need to match
verbatim in order to be reused.
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3 Visualizations
Visualizations let you present data so that your apps users can interpret and explore it.
For example, a bar chart that compares sales numbers for different regions, or a table
with precise values for the same data. Good visualizations help you quickly and
accurately interpret displayed data.

Visualizations are easy to add and customize. They can take the form of charts, such as bar charts,
pie charts,, tables, gauges, or treemaps. Each chart type has unique functionality. Qlik Cloud
Analytics automatically highlights items associated with your selections so you can drill-down and
filter.

3.1 Select visualization types that align with your
purpose

Each visualization type has a specific goal. You need to think about the purpose of your
visualization, and pick a visualization type that lets you explore your data for that purpose
effectively.

For example: You want to show how a measure, quarterly sales, behaves over time. You should
create a line chart, because one of its strengths is displaying how measure values change over
time. Alternatively, you can start with the type of analysis you want to make.

If you are unsure of what visualization types to use with your data, Qlik Sense offers two methods of
creating visualizations with assistance:

l You can use Insight Advisor to let Qlik Sense analyze your data and generate visualizations
based on your searches or selections. You can then choose to add these visualizations to
your sheets.

l You can also create visualizations using chart suggestions by dragging a field onto the sheet
from the assets panel and then dragging additional fields that you want in the visualization
onto the first field. Qlik Sense then creates a suggested visualization based on the fields
selected for the visualization.

3.2 Data assets in visualizations
Visualizations use data in many different ways. How your data is comprised or created
impacts your visualizations. Primarily, your data assets become dimensions and
measures in your visualizations, defining the categories in your visualizations and the
measurements of those categories. A field can be used to group data, or it can be
transformed with an aggregate function to provide a measurement in data categories.
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The types of data you have in your tables and fields also impacts whether they can be used as
dimensions or measures, as well as what sorting options are most effective. For example,
quantitative data and qualitative data have different recommended uses when they are used as
either dimensions or measures.

In addition to providing the data to display, data assets can be used to control what data is
displayed and how it is presented. For example, you can color a visualization using a dimension or
measure not present in the visualization. For more information, see Changing the appearance of a
visualization (page 607).

The assets panel contains the different data sources you can use in your visualizations.

Data assets
The following data assets are available when creating visualizations:

l Fields
l Measures
l Dimensions
l Master items

Fields
Fields hold the data loaded into Qlik Sense. Fields contain one or more values and correspond to
columns in a database table. The field data can be qualitative or quantitative.

When creating visualizations, you use fields to create your dimensions and measures. You can also
use fields in different ways when you add visualizations to your app. Some visualizations, such as
tables, can present fields in an unmodified state.

Some fields require extra considerations, such as date or time fields.

For more information, see Fields (page 86).

Measures
Measures are the data that you want to show. Measures are created from an expression composed
of aggregation functions, such as Sum or Max, combined with one or several fields.

For more information, see Measures (page 105).

Dimensions
Dimensions determine how the data in a visualization is grouped. For example: total sales per
country or number of products per supplier. Dimensions display the distinct values from the field
selected as a dimension. Dimensions can also be calculated using an expression.

For more information, see Dimensions (page 99).
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Master items
Master items are dimensions, measures, or visualizations that can be reused in other visualizations
and sheets in your app. Updating a master item updates every instance of it. This means you could
have the same measure in 5 visualizations, and they would all update whenever the master item is
changed.

Master items also have more design options available. You can, for example, assign colors to a
master dimension distinct values so that the distinct values are consistent across visualizations.

Master items also include special dimensions such as drill-down dimensions and calendar
measures.

For more information, see Reusing assets with master items (page 117).

Expressions
An expression is a combination of functions, fields, and mathematical operators (+ * / =).
Expressions are used to process data in the app in order to produce a result that can be seen in a
visualization.

Expressions are used primarily used to create measures. They can also be used to build calculated
dimensions, or to set properties within different visualizations. For example, you can use
expressions to define range limits for gauges, or reference lines for bar charts.

For more information, see Using expressions in visualizations (page 155).

Data types in visualizations
Different types of data have different properties; certain data may work better as dimensions, and
some as measures. Similarly, as dimensions or measures, certain kinds of data may work better as a
dimension in some visualizations better than others, or as a measure with certain aggregation
functions.

The data in your fields can be quantitative or qualitative. Quantitative data values are measured
numerically on an ascending scale. Quantitative data can be ratios or intervals:

l Ratio: Ratios are quantitative data that you can perform arithmetic operations on, such as
cost or age.
For example, you can sum sales values for the month to get totals.

l Interval: Intervals are quantitative data that you cannot perform arithmetic operations on.
For example, you cannot calculate a sum of temperatures during the week, but you can
calculate the average temperature per day, and the high/low for each day.

Qualitative data can not be measured numerically, but can be described through language.
Qualitative data can be nominal or ordinal:

l Nominal: Fields with nominal data have distinct qualitative values, but without a set order.
For example, product names or customer names are nominal data, as they have distinct
values, but do not have a required order.
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l Ordinal: Fields with ordinal data have qualitative values that have a ranked or positioned
value. Ordinal data should be sorted by its order as opposed to alphabetically.
For example, low, medium, high are ordinal values. Small, medium, and large are also ordinal
values.

The following table contains a general overview of recommended visualization types and
aggregation functions for data types. These recommendations should not be considered absolute.

Data type
Recommended aggregation
functions

Non-recommended aggregation
functions

Nominal Count Average

Median

Sum

Ordinal Count

Median

Average

Sum

Ratio Count

Average

Median

Sum

Interval Count

Average

Median

Sum

-

Visualization recommendations for data types as measures

Fields
Fields hold the data that is used in Qlik Sense. Fields can be thought of as the data
loaded from the load script.

Fields contain one or more values, called field values, and at the basic level, correspond to columns
in a database table, but can also exist in more than one table. Field values consists of numeric or
alphanumeric data. When loaded from the load script, fields can be represented as a table
visualization.

Example of data in a load script:

Temp:

LOAD * inline [

Customer Product UnitSales UnitPrice

Imagine Film 4 16

Imagine Film 10 15

Imagine Shutter 9 9
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PhotoInc Shutter 5 10

PhotoInc Lens 2 20

PhotoInc Magnifier 4 25

Gallery Film 8 15

Gallery Lens 7 19

] (delimiter is ' ');

The fields represented in a data model table after having loaded the data:

The same fields as columns in a table visualization on a sheet:

Date & time fields
If you are working with fields containing date or timestamp information in your app, you can define a
number of related attributes of a date, for example, year or week, and use them in your
visualization.

Creating date fields in Data manager
Date fields are created automatically for all data fields recognized as a date or a timestamp when
you use Add data with data profiling enabled to build your data model in Data manager, or when
you click Load data in Data manager.

Date fields created in Data manager are automatically added to autoCalendar.

If the date or timestamp field is not recognized automatically, you can adjust the input format in the
Data manager table editor. You can also set the display format to use in visualizations.
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Which date & time fields are automatically recognized?
Date & timestamp fields will be recognized automatically based on your system locale settings.
Additionally, the following formats are recognized:

l M/D/YYYY h:mm
l D/M/YYYY h:mm TT
l M/D/YYYY
l D/MM/YYYY
l YYYYMMDD
l YYYYMMDDhhmmss
l YYYYMMDDhhmmss.fff
l YYYYMMDDhhmmssK
l YYYY-MM-DD
l YYYY-MM-DDThh:mm:ss
l YYYY-MM-DD-Thh:mm:ss.fff
l YYYY-MM-DD-Thh:mm:ssK

Format specifier Description

YYYY Year

M, MM Month

D, DD Day

hh Hour

mm Minute

ss Second

fff Millisecond

TT AM or PM

K Timezone

T Divider between date and time. T can not be replaced with another
character.

Date & time formats

Creating date & time fields in the data load script
If you use Data load editor to build your data model, you need to create a calendar template where
you define which fields to derive in the data load script. The derived date & time fields will be
generated when the script is run and data is reloaded.
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Using date & time fields in your app

Date & time fields in visualizations

All date or timestamp fields in the assets panel Fields tab are marked with  , and you can expand
them to use the generated date & time fields. You can use them in visualizations, just like any other
data field.

Date & time fields in dimensions
You can also use date & time fields when you create a dimension. The date & time fields are listed
under the field that they have been generated from.

Date & time fields in expressions
You can use date & time fields in all expressions, for example when you create a measure. The date
& time fields are named according to:

[field name].autoCalendar.[date & time field].

l [field name] is the name of the data field that was used to generate date & time fields.
l [date & time field] is the date & time field you want to use, for example, Year.

Example:

Date.autoCalendar.Year

Date & time fields in calendar measures
Calendar measures use date & time fields created in autoCalendar. Each of these date & time fields
is calculated by a set analysis expression that determines whether or not data falls within the time-
to-date period, or if dates are within a defined relative position to the current date. These date &
time fields are relative and return results based on the current date. You can use these fields
independently of calendar measures.

Calendar field date & time fields are formatted as follows:

[field name].autoCalendar.[date & time field]={[value]}

l [field name] is the name of the date field used to generate date & time fields.
l [data & time field] is the name of the date & time field used, for example, InYTD.
l [value] is the value for the date & time field’s set analysis expression and determines which

dates are included.

Example:

Date.autoCalendar.YearsAgo={1}

The following are the available date & time fields with sample values:

InYTD
This date & time field determines whether or not dates are within the year-to-date range or outside
the year-to-date range.
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Example Result

Date.autoCalendar.InYTD=

{0}
Returns all dates that fall in the year-to-date time range.

For example, if the current date was the 54th day of the year, the
dates within the first 54 days of every year in the date field would
be included.

Date.autoCalendar.InYTD=

{1}
Returns all dates outside the year-to-date time range.

For example, if the current date was the 54th day of the year, all
the dates after the first 54 days of every year in the date field
would be included.

InYTD

YearsAgo
This date & time field determines whether or not dates are from a specific year relative to the
current date.

Example Result

Date.autoCalendar.YearsAgo={0} Returns all dates from this year.

Date.autoCalendar.YearsAgo={1} Returns all dates from last year.

Date.autoCalendar.YearsAgo={8} Returns all dates from eight years ago.

YearsAgo

InQTD
This date & time field determines whether or not dates are within the quarter-to-date range or
outside the quarter-to-date range, relative to the current date.

Example Result

Date.autoCalendar.InQTD=

{0}
Returns all dates from all quarters that are within the quarter-to-
date range.

For example, if the current date was the 14th day of Quarter 1, the
first 14 days of every quarter in the date field would be included.

Date.autoCalendar.InQTD=

{1}
Returns all dates from all quarters that are outside the current
quarter-to-date range.

For example, if the current date was the 14th day of Quarter 1, all
dates after the first 14 days of every quarter in the date field would
be included.

InQTD
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QuartersAgo
This date & time field determines whether or not dates are from a specific quarter relative to the
current date.

Example Result

Date.autoCalendar.QuartersAgo={0} Returns all dates from the current quarter.

Date.autoCalendar.QuartersAgo={1} Returns all dates from the last quarter.

Date.autoCalendar.QuartersAgo={8} Returns all dates from eight quarters ago.

QuartersAgo

QuarterRelNo
This date & time field determines whether or not dates are from a specific quarter relative to the
current date.

Example Result

Date.autoCalendar.QuarterRelNo=

{0}
Returns all dates from each instance of the current quarter.

For example, if the current date was in Quarter 4, all dates
from each Quarter 4 in the date field would be included.

Date.autoCalendar.QuarterRelNo=

{3}
Returns all dates from each instance of the quarter two
quarters prior to the current quarter.

For example, if the current date was in Quarter 4, all dates
from each Quarter 1 in the date field would be included

QuarterRelNo

InMTD
This date & time field determines whether or not dates are within the month-to-date range or
outside the month-to-date range, relative to the current date.

Example Result

Date.autoCalendar.InMTD=

{0}
Returns all dates from all months that are within the current
month-to-date range.

For example, if the date was November 15, 2016, dates from the
first 15 days of every month in the date field would be included.

Date.autoCalendar.InMTD=

{1}
Returns all dates from all months that are outside the current
month-to-date range.

For example, if the date was November 15, 2016, dates after the
first 15 days to the end of the month of every month in the date
field would be included.

InMTD
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MonthsAgo
This date & time field determines whether or not dates are from a specific month relative to the
current date.

Example Result

Date.autoCalendar.MonthAgo={0} Returns all dates from the current month.

Date.autoCalendar.MonthAgo={1} Returns all dates from the last month.

Date.autoCalendar.MonthAgo={8} Returns all dates from eight months ago.

MonthsAgo

MonthRelNo
This date & time field determines whether or not dates are from a specific month relative to the
current date.

Example Result

Date.autoCalendar.MonthRelNo=

{0}
Returns all dates from each instance of the current month.

For example, if the current month was June, all dates in every
instance of June in the date field would be included.

Date.autoCalendar.MonthRelNo=

{1}
Returns all dates from the each instance of the previous
month.

For example, if the current month was June, all dates in every
instance of May in the date field would be included.

MonthRelNo

InWTD
This date & time field determines whether or not dates are within the week-to-date range or outside
the week-to-date range, relative to the current date.

Example Result

Date.autoCalendar.InWTD=

{0}
Returns all dates from all weeks that are within the current week-
to-date range.

For example, if the current date was the third day of a week, dates
from the first three days of every week in the date field would be
included.

Date.autoCalendar.InWTD=

{1}
Returns all dates from all months that are outside the current
month-to-date range.

For example, if the current date was the third day of a week, dates
from the last four days of the every week in the date field would be
included.

InWTD
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WeeksAgo
This date & time field determines whether or not dates are from a specific week relative to the
current week.

Example Result

Date.autoCalendar.WeeksAgo={0} Returns all dates from the current week.

Date.autoCalendar.WeeksAgo={8} Returns all dates from eight weeks ago.

WeeksAgo

WeekRelNo
This date & time field determines whether or not dates are from a specific week relative to the
current date.

Example Result

Date.autoCalendar.WeekRelNo=

{0}
Returns all dates from each instance of the current week.

For example, if the current week was the second week of the
year, dates from the second week of every year in the date
field would be included.

Date.autoCalendar.WeekRelNo=

{1}
Returns all dates from each instance of the previous week.

For example, if the current week was the second week of the
year, dates from the first week of every year in the date field
would be included.

WeekRelNo

Always one selected value
You can select the Always one selected value for a field in an app. The value specifies
that one, and only one, value is always selected for a field. You can use this value to
specify, for example, that one currency is always selected for a field.
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Consider the following when using the Always one selected value:

l You can use the Always one selected value on one or more fields.
l You cannot clear the Always one selected value setting when viewing a sheet. You can,

however, clear the setting by editing the sheet in your workspace.
l When you publish an app with the Always one selected value selected, the value is applied

to all sheets in the app. The app consumer cannot clear the value.
l When you duplicate an app, the Always one selected value is duplicated with the app.
l When you export an app without data, the Always one selected value is not exported with

the app.
l The Always one selected value is not supported for derived fields.

You can use the value with a default bookmark in to highlight specific selections for your app
consumer.

Set the Always one selected value

Do the following:

1. Open a sheet in an app.

2. Click Edit sheet.

3. Click Fields.
4. Right-click a field, and then click Field settings.
5. In the window that opens, select the Always one selected value check box, and then save.
6. Exit sheet edit mode. The value appears as a tab in the top toolbar. Unlike a bookmark, there

is no option to clear the selection.
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The Always one selected value in the toolbar

The Always one selected value defaults to the first entry in the field. In the example above,
the value is applied to Region. Asia is the region that is selected by default. You or your app
consumer can change this selection, in this case to a different region.

7. To test that the Always one selected value is working properly, close and then reopen the
app. The value should be shown in the top toolbar.

To remove the Always one selected value for a field, right-click the field in Edit mode, click Field
settings, and deselect the Always one selected value check box.

Always one selected value and default bookmark example: Controlling selections to
guide app consumers to insights
In this example, we set Always one selected value for a field. We then specify a default bookmark
for the app. By specifying a default bookmark, and enabling Always one selected value, we control
what our app consumers see when they open our published app.

1. Here is a sheet in our app before the Always one selected value and a default bookmark are
applied. This should be the sheet that you want app consumers to see as a landing page
when they open the app.
App in sheet analysis mode

The chart in the app is built using Country as a dimension, and Sum([Total Revenue]) as a
measure.

2. To ensure that one, and only one, value is always selected for the Region field, we edit the
sheet, click Fields, and then right-click Region.

Create apps and visualizations - Qlik Sense, November 2024 95



3   Visualizations

3. Click Field settings.
4. We then select the Always one selected value checkbox and save.

Turning on the Always one selected value setting

5. When we close Edit mode for the sheet, the Always one selected value value appears as a
tab in the top toolbar. The value defaults to the first entry in the field. In this case, the default
value is Asia.
App in sheet view with default value selected for Always one selected value field

6. However, we want to show revenue for sub-Saharan Africa when the app is opened. So we
select Sub-Saharan Africa from the Region field, and then click Bookmarks to create a new
bookmark for Region("Sub-Saharan Africa"). We then right-click the Region("Sub-Saharan
Africa") bookmark, and click Set as default bookmark.

Now, when we open the app, or publish the app for an app consumer, the app opens with one value
selected, and the default bookmark is shown. The app is opened on the sheet of the bookmark
instead of the app overview.
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App opened with default bookmark, using the defined selection Sub-Saharan Africa

Data used in example
Load script
You can add the paste the data table below into your load script to try this example out in your own
app.

Sales:

LOAD * INLINE [

Region,Country,Item Type,Sales Channel,Order Priority,Order Date,Order ID,Ship Date,Units

Sold,Unit Price,Unit Cost,Total Revenue,Total Cost,Total Profit

Central America and the

Caribbean,Honduras,Household,Offline,H,2/8/2017,522840487,2/13/2017,8974,668.27,502.54,5997054

.98,4509793.96,1487261.02

Asia,Mongolia,Personal

Care,Offline,C,2/19/2014,832401311,2/23/2014,4901,81.73,56.67,400558.73,277739.67,122819.06

Asia,Sri

Lanka,Cosmetics,Offline,M,11/19/2016,419123971,12/18/2016,6952,437.20,263.33,3039414.40,183067

0.16,1208744.24

Asia,Turkmenistan,Household,Offline,L,12/30/2010,441619336,1/20/2011,3830,668.27,502.54,255947

4.10,1924728.20,634745.90

Central America and the

Caribbean,Honduras,Snacks,Online,L,6/30/2016,795490682,7/26/2016,2225,152.58,97.44,339490.50,2

16804.00,122686.50

Australia and Oceania,Australia,Office

Supplies,Online,C,10/27/2015,158535134,11/25/2015,2924,651.21,524.96,1904138.04,1534983.04,369

155.00

Europe,United

Kingdom,Household,Online,L,1/5/2012,955357205,2/14/2012,282,668.27,502.54,188452.14,141716.28,

46735.86

Sub-Saharan
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Africa,Djibouti,Cosmetics,Offline,H,4/7/2014,259353148,4/19/2014,7215,437.20,263.33,3154398.00

,1899925.95,1254472.05

Australia and

Oceania,Australia,Cereal,Offline,H,6/9/2013,450563752,7/2/2013,682,205.70,117.11,140287.40,798

69.02,60418.38

Middle East and North

Africa,Libya,Clothes,Offline,H,10/30/2010,705784308,11/17/2010,6116,109.28,35.84,668356.48,219

197.44,449159.04

Central America and the

Caribbean,Haiti,Cosmetics,Offline,H,10/13/2013,505716836,11/16/2013,1705,437.20,263.33,745426.

00,448977.65,296448.35

Central America and the

Caribbean,Belize,Clothes,Offline,M,7/25/2016,807025039,9/7/2016,5498,109.28,35.84,600821.44,19

7048.32,403773.12

Europe,Lithuania,Office

Supplies,Offline,H,10/24/2010,166460740,11/17/2010,8287,651.21,524.96,5396577.27,4350343.52,10

46233.75

Asia,Turkmenistan,Office

Supplies,Online,M,4/23/2013,462405812,5/20/2013,5010,651.21,524.96,3262562.10,2630049.60,63251

2.50

Middle East and North

Africa,Libya,Fruits,Online,L,8/14/2015,816200339,9/30/2015,673,9.33,6.92,6279.09,4657.16,1621.

93

Sub-Saharan

Africa,Djibouti,Cereal,Online,H,5/20/2017,555990016,6/17/2017,8656,205.70,117.11,1780539.20,10

13704.16,766835.04

Middle East and North

Africa,Pakistan,Cosmetics,Offline,L,7/5/2013,231145322,8/16/2013,9892,437.20,263.33,4324782.40

,2604860.36,1719922.04

North

America,Mexico,Household,Offline,C,11/6/2014,986435210,12/12/2014,6954,668.27,502.54,4647149.5

8,3494663.16,1152486.42

Australia and Oceania,Federated States of

Micronesia,Beverages,Online,C,10/28/2014,217221009,11/15/2014,9379,47.45,31.79,445033.55,29815

8.41,146875.14

Australia and

Oceania,Samoa,Cosmetics,Online,H,7/20/2013,670854651,8/7/2013,9654,437.20,263.33,4220728.80,25

42187.82,1678540.98

Europe,Spain,Household,Offline,L,10/21/2012,213487374,11/30/2012,4513,668.27,502.54,3015902.51

,2267963.02,747939.49

Middle East and North

Africa,Lebanon,Clothes,Online,L,9/18/2012,663110148,10/8/2012,7884,109.28,35.84,861563.52,2825

62.56,579000.96

Sub-Saharan

Africa,Kenya,Vegetables,Online,L,3/18/2012,827844560,4/7/2012,6457,154.06,90.93,994765.42,5871

35.01,407630.41

North America,Mexico,Personal

Care,Offline,L,2/17/2012,430915820,3/20/2012,6422,81.73,56.67,524870.06,363934.74,160935.32

Australia and

Oceania,Australia,Beverages,Offline,H,7/7/2014,240470397,7/11/2014,9389,47.45,31.79,445508.05,

298476.31,147031.74

North America,Mexico,Personal

Care,Offline,M,7/30/2015,559427106,8/8/2015,5767,81.73,56.67,471336.91,326815.89,144521.02

Sub-Saharan

Create apps and visualizations - Qlik Sense, November 2024 98



3   Visualizations

Africa,Mozambique,Household,Offline,L,2/10/2012,665095412,2/15/2012,5367,668.27,502.54,3586605

.09,2697132.18,889472.91

];

Dimensions
Dimensions determine how the data in a visualization is grouped. For example: total
sales per country or number of products per supplier. You typically find a dimension as
the slices in a pie chart or on the x-axis of a bar chart with vertical bars.

Dimensions are created from fields in the data model tables.

Example:

Product Type is a field in the Product table that is loaded into the app. The values of this field are
the different types that products are grouped into.

You can, for example, create a bar chart to visualize the cost of each type, by adding the Product
Type dimension to the chart. To complete the visualization, you must add a measure (in this case
Cost), which is grouped by the Product Type dimension.

Bar chart with the dimension Product Type and measure Cost.

You can also create different types of master dimensions:

l Drill-down groups (page 100)
l Cyclic dimensions (page 101)

Creating dimensions
When you load data into an app, all data is loaded as fields. At the same time, Qlik Sense identifies
the fields from the data model that can be used as dimensions. These are shown to you as you
populate visualizations with data or create master items.
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The process of creating a dimension depends on whether you want to customize how data is
grouped. Follow these guidelines:

l To simply use a certain field to group data in your visualization, add the field as a dimension
when you create the visualization. No additional configuration is needed.

l Create a master dimension in the app if you want to:
l Create a standalone entity in the app that is easily recognized as a useful way to group

data.
l Enhance and expand how the dimension fields group data. For example, you can

create a drill-down or cyclic dimension for specific behavior, or set a specific color for
the dimension.

l Allow re-use of the dimension across the app, including by others.
After creating the master dimension, it can be added to any applicable charts as you
configure them.
Reusing dimensions with master dimensions (page 119)

Field groups as dimensions
One main difference between Qlik Sense and many other database viewers and online analytical
processing tools (OLAP systems), is that in Qlik Sense, you do not need to predefine any hierarchies
in the input data. The unique internal logic of Qlik Sense gives you the complete freedom to access
any field as a full dimension in any order you like.

For most purposes, the built-in functionality is fully satisfactory, but in some situations, a
predefined hierarchy can help you to display data more efficiently. In Qlik Sense, you can achieve
this by defining hierarchic groups of fields as drill-down dimensions.

Any fields or calculated dimensions can be grouped together.

Drill-down groups
When several fields form a natural hierarchy, it can make sense to create a drill-down
group.

Example 1:

Organization: Company, Department, Employee

Example 2:

Geography: Continent, Country, State, City

When you use a drill-down group as a dimension in a chart, the chart uses the first field in the
group's list of fields that has more than one possible value. If the currently made selections cause
the field to have only one possible value, the next field in the list is used instead, provided that it has
more than one possible value. If no field in the list has more than one possible value, the last field is
used anyway.
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In the first example above, Company will be used as chart dimension until a single company is
selected. The chart will then show Department. If a single department is selected, the chart will
switch to Employee.

As selections are reverted, so that more than one value becomes possible in the upper fields of the
group's field list, the chart is automatically drilled back up.

Drill-up
The drill-up function is available in bar charts, pie charts, and line charts. Other visualizations reflect
the changes made in the charts, but cannot themselves be used to drill up through the different
dimensions. When you drill down in a dimension group, breadcrumbs provide links back to the
previous dimensions. Click the dimension that you want to drill up to.

In the following bar chart, the breadcrumbs Year > Quarter > Month enable drilling up.

Cyclic dimensions
Group non-hierarchical fields together as a master dimension so they can be cycled
through in a visualization.
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Cyclic dimensions allow users to quickly change between fields displayed as dimensions in
visualizations. Users can cycle through the fields in the cyclic dimension using a button. Unlike drill-
down dimensions, fields grouped in a cyclic dimension do not need a hierarchical relationship. Their
only relationship is that they are all of interest with similar measures in a chart.

When a cyclic dimension is used as a visualization dimension, the visualization will use the first
dimension in the list. Users can switch to the next dimension in the order they appear in the cyclic
dimension's list. If you are using a cyclic dimension in multiple visualizations, all the fields in each
visualization using the cyclic dimension will change when you switch to the next field.

You can switch dimension by:

l Clicking in the visualization.
You can also select a specific field from the cyclic dimension by clicking on the field name
label in the axis.

l Clicking a button with the action Step cyclic dimension.
For more information, see Button (page 388).

Create apps and visualizations - Qlik Sense, November 2024 102



3   Visualizations

Chart using a cyclic dimension

Limitations
Cyclic dimensions have the following limitations:

l The cycle button ( ) is only available in the following visualizations:
l Bar charts
l Bullet charts
l Combo charts
l Grid charts
l Line charts
l Pie charts

l Qlik Sense Mobile has the following limitations with cyclic dimensions:
l Buttons with the action Step cyclic dimension will only cycle dimension if the button

is in a container.
l In offline mode, buttons with the action Step cyclic dimension do not cycle the

dimension.
l In offline mode, any visualization with a cyclic dimension will only display the first

dimension in the cycle. The cyclic dimension cannot be cycled.
l Custom objects may not work with cyclic dimensions.
l Cyclic dimensions are not supported with the following Qlik Dashboard bundle objects:
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l Date picker
l Line
l Text
l Variable input
l Video player

l Cyclic dimensions are not supported with the following Qlik Visualization bundle objects:
l Trellis container

l Cyclic dimensions do not support assigning colors to dimension values
l In the storytelling view, while snapshots display correctly, clicking Go to source will not

apply the cyclic dimension state from the snapshot.
l If a field is removed from the data model but not from a cyclic dimension, the cyclic

dimension will continue to work until it steps to the removed field.

Calculated dimensions
You can use expressions to create calculated dimensions. A calculated dimension
consists of an expression involving one or more fields. All standard functions may be
used.

For performance reasons, it is recommended to perform all calculations in the data load
editor. When dimensions are calculated in the chart, Qlik Sense first calculates the
dimension values, and then aggregates the measures for these calculated values, which
affects the performance more than calculations in the load script.

There are cases when calculated dimensions are powerful in data analysis, for example, if you want
to generate the dimensions values during analysis, when dimension values are dependent on the
selections.

Calculated dimensions are also useful if you want to modify a field.

Once you have created a calculated dimension, you can use it as any other dimension.

Example:

You have a field called Calendar Month that includes each of the months of the year. In your app,
you want include a table that shows the sales for each of the first 6 months of the year. For the rest
of the months, you want to see a total. You can use an expression to create this calculated
dimension.

Syntax:
If ([Calendar Month] <7, [Calendar Month], 'Rest')
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Measures
Measures are calculations used in visualizations, typically represented on the y-axis of
a bar chart or a column in a table. Measures are created from an expression composed
of aggregation functions, such as Sum or Max, combined with one or several fields.

A measure must have a name, and may also be supplied with descriptive data such as description
and tags.

Example:

You can, for example, create a bar chart to visualize the cost of each type, by adding the Product
Type dimension to the chart, and the measure Cost, which is made from the expression Sum(Cost),
that is the result of the calculation of the aggregation function Sum over the field Cost. The results
are grouped by the Product Type dimension.

Bar chart with the dimension Product Type and the measure Cost.

Creating measures
When you load data into an app, all data is loaded as fields. When you add a measure to a chart or
create a master measure, these fields can be used in aggregations to perform specific calculations.

The process of creating a measure depends on whether you want to customize or standardize a
particular calculation. Follow these guidelines:

l To simply add a calculation to a chart, enter the measure expression when configuring the
chart. No additional configuration is needed.

l Create a master measure in the app if you want to:
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l Create a standalone entity in the app that is easily recognized as a useful calculation.
l Enhance and expand the definitions of a calculation. For example, you can define

colors and label expressions so they are added whenever the measure is used, rather
than configuring these properties separately in each instance.

l Allow a centralized definition of a measure, so a change in the central definition will
propagate through the app to all objects where the measure is referenced.

l Allow re-use of the measure across the app, including by others.
After creating the master measure, it can be added to any applicable charts as you configure
them.
Reusing measures with master measures (page 126)

Modifiers
Measures are calculations based on fields, for example Sum(Cost). You can use
modifiers to change how the measure is calculated over the available dimensions.

For example, you can have the values of a measure accumulate over one or two dimensions, or you
can calculate the average of your measure over a specific number of steps.

For information about how to apply a modifier to measure, see Applying a measure modifier (page
606).

Which visualizations have modifiers

Visualization Accumulation Difference
Moving
average

Relative
numbers

Bar chart Yes Yes Yes Yes

Combo chart Yes Yes Yes Yes

Line chart Yes Yes Yes Yes

Table Yes Yes Yes Yes

Straight table (Visualization
bundle)

Yes Yes Yes Yes

Visualizations comparison

Accumulation
The accumulation modifier allows you to accumulate the values of a measure over one or two
dimensions. Accumulating values makes it easy to visualize how the effect of the measure builds up
over a dimension.

In the following combo chart, the bars and lines accumulate over time.
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A combo chart where the line shows the accumulated profit margin and the bars show the accumulated
sales figures.

Syntax:
RangeSum(Above {$M,0,Steps})

Difference
The difference modifier allows you to visualize the difference between consecutive values of a
measure over one or two dimensions. The difference modifier is useful when you want to visualize
the change in direction of grouped data.

In the following bar chart, any drops in yearly profits over a 10 year period appear as negative bars.
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A bar chart showing the profit differences from one year to the next.

Syntax:
$M - Above($M)

Moving average
The moving average modifier allows you to see the average values of a measure over a specific
period. You can use it to filter out the action from short-term value fluctuations. You can change the
number of steps over which the averaging takes place, depending on how strongly you want your
modifier to follow the changes in your data. A moving average is commonly used with time series
data to highlight longer-term trends or cycles.
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In the following line chart moving averages with two difference ranges are shown, one with a 20
step range, and one with a full range.

A line chart showing the price of a product over a five month period.

Syntax:
RangeAvg(Above ($M,0,Steps))
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Relative numbers
The relative numbers modifier allows you to see relative percentages. You can use it to see the
impact of specific selections, relative to the selection, relative to the total, or relative to other fields.
You can change the basis upon which the relative number is calculated.

In the following table a column with sales of each year of a specific selection, and three columns
with relative numbers are shown, one relative to current selection, one relative to total sales for all
years, and one relative to the sales of each year.

A table showing different sales percentages relative to current selection, relative to total sales, and relative
to each year's sales.

The following is an example of the syntax of the modifier relative to the total selection.

Syntax:
$M / Sum( total Aggr( $M, dim ) )

Trend lines
A trend line is a visual representation of the direction of values over a period of time.
Trend lines show trends over time, by visualizing the direction of values and how fast
the values change.

For information about how to create trend lines, see Adding trend lines to visualizations (page 599).
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Which visualizations have trend lines

Visualization Trend lines

Bar chart Yes

Line chart Yes

When to use trend lines
A single trend line can be added to a chart to smooth out fluctuations in data, and to show any
trends more clearly.

More than one trend line can be added to a chart, showing different types of trends or different
values.

Types of trend lines

Average
An average trend line shows the average value of the data, for the time period being analyzed.
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A bar chart showing sales per month. An average trend line is shown with a dashed red line.

Linear
A linear trend line shows increase or decrease of values at a steady rate. Linear trend lines are
usually used with simple linear data sets.
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A bar chart showing sales per month. An linear trend line is shown with a dashed red line.

Polynomial (second, third, fourth degree)
A polynomial trend line is a curved line used on fluctuating data.

The number of data fluctuations can determine the order of the polynomial. A second degree
polynomial trend line has one hill or valley, a third degree polynomial trend line has up to two hills or
valleys, and a fourth degree polynomial has up to three hills or valleys.
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A bar chart showing sales per month. Polynomial trend lines of second, third, and fourth degree are shown
with dashed red, yellow, and green lines respectively.

Exponential
An exponential trend line is a curved line used when data values rise or fall at increasingly higher
rates.
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A bar chart showing sales per month. An exponential trend line is shown with a dashed red line.

Logarithmic
A logarithmic trend line is a curved line used when the rate of change in data increases or
decreases quickly, before leveling out.
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A bar chart showing sales per month. A logarithmic trend line is shown with a dashed red line.

Power
A power trend line is a curved line used with data sets that compare measurements that increase at
specific rates.
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A bar chart showing sales per month. A power trend line is shown with a dotted red line.

Reusing assets with master items
When you create and build your visualizations, you can save assets to reuse in other visualizations
and on other sheets. You can save visualizations, dimensions, and measures as master items in the
assets panel. When your app gets published these master items will be available to others as ready-
to-use visualizations, dimensions, and measures.

Any updates you make to the master item are applied everywhere the master item is used. For
example, you could use a master measure in as many of your visualizations as you like while only
having to update it in a single instance to update all instances of the measure in your visualizations.

One of the purposes with creating and maintaining master items is for other users to explore their
own ways and directions in the data, on top of what you have provided in the app as pre-made
sheets with visualizations. The users will be able to create their own visualizations with your pre-
made master dimensions and master measures, for example.

Reusing dimensions with master dimensions (page 119)

Reusing measures with master measures (page 126)

Reusing visualizations with a master visualization (page 118)
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Reusing visualizations with a master visualization
You can create a master visualization to be able to reuse it. Users of a published app
will have access to the master visualization but will not be able to modify them.

You can only create master visualizations when you are working with an unpublished
app. Visualizations with Chart suggestions enabled cannot be made into a master
visualization.

Do the following:

1. While editing a sheet, drag a visualization from the sheet to the master items.
If you have given the visualization a title, this is automatically added as the name of the
master visualization.

2. Add a name, or change the name if you want to.
3. Type a description for the visualization (optional).
4. Add tags (optional).
5. Click Add.

The visualization is now saved to the master items tab.

You can also add a visualization to the master items by right-clicking it on the sheet, and
selecting Add to master items.

Editing a master visualization
When you update a visualization in the master items, the changes will be reflected in all instances of
the master visualization.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click the visualization that you want to edit.
The preview opens.

4. Click   at the bottom of the preview.

If the visualization is used on a sheet, a dialog is displayed to inform you that any changes to
the master visualization will be applied to all its instances on the sheets.

5. Click OK.
The visualization opens for editing.
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You can also right-click the master item, and then click Edit.

6. Make the changes you want, and click Done in the upper right corner of the visualization to
finish editing.

The visualization is updated and reflected in all its instances.

You can also edit a master visualization by selecting a linked visualization on a sheet,
and clicking Edit in the properties panel. You must be in sheet edit mode.

Reusing dimensions with master dimensions
When you are working with an unpublished app, you can create master dimensions so
that they can be reused. Users of a published app will have access to the master
dimensions, but will not be able to modify them.

You can create a master dimension in different ways.

You can also create drill-down groups and cyclic dimensions:

l Creating a drill-down dimension (page 121)
l Creating a cyclic dimension (page 122)

Creating a master dimension from a field
When you are working with an unpublished app, you can create master dimensions so
that they can be reused. You can create a master dimension from the Fields section of
the assets panel.

Do the following:

1. Click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Fields in the assets panel.

3. Click the field you want to use to create a dimension.
The preview opens.

4. Click at the bottom of the preview.
The Create new dimensions dialog opens with the field you selected. The field name is also
used as the name of the dimension.

5. Select if the dimension is to be single, cyclic, or drill-down.
6. Edit the name if you want to.
7. Type a description for the dimension (optional).

8. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:
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l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field: #.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
9. Add tags (optional).

10. Click Create.
11. Click Close.

The dimension is now saved in the Dimensions category in the master items, and you can use it in
visualizations.

You can quickly add several dimensions as master items by clicking Add dimension
after adding each dimension. Click Done when you have finished.

Direct Discovery fields are indicated by in the Fields section of the assets panel.

Creating a master dimension from the assets panel

Do the following:

1. Click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click the Dimensions heading to expand the category.
4. Click Create new.

The Create new dimensions dialog opens.
5. Select if the dimension is to be single, cyclic, or drill-down.
6. Click a field on the left-hand side to select it.

The name of the field is automatically added as the name of the dimension.
7. Change the name if you want to.
8. Type a description for the dimension (optional).

9. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:

l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field: #.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
10. Add tags (optional).
11. Click Create.
12. Click Close.
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The dimension is now saved in the Dimensions category in the master items, and you can use it in
visualizations.

You can quickly add several dimensions as master items by clicking Add dimension
after adding each dimension. Click Done when you have finished.

Creating a drill-down dimension
When adding a dimension, you can select between creating a single or a drill-down
dimension.

The following description explains how to create a drill-down group from the Create new
dimensions dialog.

If selections cause the current drill-down dimension field to have only one possible
value, the next field in the list is used instead.

Do the following:

1. Select Drill-down as dimension type.
2. Click at least two fields from the fields list on the left-hand side to insert them as the

referenced fields.

You can filter which table to select fields from in the drop-down list.

You can rearrange the order of the fields you have selected by dragging them to
new positions in the list of selected fields.

3. Optionally, add labels for the fields added to your drill-down dimension.
Click in Label to add an expression for the label. The expression must start with =.

4. Type a name for the dimension.
5. Type a description for the dimension (optional).

6. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:

l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field: #.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
7. Add tags (optional).
8. Click Create.
9. Click Close.

Create apps and visualizations - Qlik Sense, November 2024 121



3   Visualizations

The drill-down dimension is now saved in the Dimensions category among the master items.

When you click the dimension in the panel on the left-hand side, the preview displays the dimension
type and which fields are included in the drill-down dimension.

The preview displays the dimension type and which fields are included in the drill-down dimension.

Creating a cyclic dimension
When adding a dimension, you can select between creating a single, drill-down, or
cyclic dimension.

The following description explains how to create a cyclic dimension from the Create new
dimensions dialog.

Do the following:

1. Select Cyclic as dimension type.
2. Click at least two fields from the fields list on the left-hand side to insert them as the

referenced fields.

You can filter which table to select fields from in the drop-down list.

You can rearrange the order of the fields you have selected by dragging them to
new positions in the list of selected fields.
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3. Optionally, add labels for the fields added to your cyclic dimension.
Click in Label to add an expression for the label. The expression must start with =.

4. Type a name for the dimension.
5. Type a description for the dimension (optional).

6. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:

l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field: #.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
7. Add tags (optional).
8. Click Create.
9. Click Close.

Creating a calculated dimension
You can create a calculated dimension from the Master items tab in the assets panel.
The expression editor opens from the Create new dimensions dialog.

Do the following:

1. Click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click the Dimensions heading on the Master items tab to expand the category.
4. Click Create new.

The Create new dimensions dialog opens.

5. Click in the Field text box to open the Add expression dialog.

You will now be able to add expressions in different ways, depending on you preferences and of
different levels of complexity.

You can also add an expression by typing directly into the Field text box , but you will
then not be provided with syntax highlighting and syntax check.

Using a common function
1. Select a field from the drop-down list.
2. Click the aggregation function you want to use.
3. Click Insert to insert the function and the field into the expression editor.

You can insert just a function or just a field by selecting only one of them.
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4. Click Apply to close the Add expression dialog.
Continue by adding the descriptive data for the dimension.

Adding an expression by typing
1. Type the expression directly in the expression editor.

The field names you use in the expression are checked, and the syntax of the expression is
validated.

As you type in the expression editor, the expression is validated continuously. If
there is an error, you see a hint about what is incorrect. Additional error
information may be available by clicking the icon next to the hint.

Each line in the expression editor is numbered and syntax highlighting is used.
2. Click Apply to close the Add expression dialog.

For a measure, you continue by adding the descriptive data for the measure.

Adding an expression through the properties panel
You can add an expression to a visualization through the properties panel.

1. Open the sheet with the visualization that you want to edit.

2. Click Edit sheet to open the properties panel. (If it is hidden, click Show properties in
the lower right-hand corner to open it.)

3. Click the visualization that you want to edit.
The properties panel for that visualization is displayed on the right-hand side.

4. Under Data, click Add data and select Dimension.
A dimension text box is displayed.

5. Type your expression. The expression must begin with an equals sign (=), otherwise the
string will be interpreted as text.

Detailed syntax help
You can open the online help with the full description of how to use the current function by double-
clicking the function name in the expression editor and pressing Ctrl+H on the keyboard. This
feature becomes available after having entered the first parenthesis of the expression after the
function name.

This feature is supported only when using a computer with a keyboard.

Adding the descriptive data for the dimension
After having entered the expression, you need to add some descriptive information.

1. Type a name for the dimension.
2. Type a description for the dimension (optional).

3. Optionally, click in the color drop down and select a color through one of the following
methods:
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l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field: #.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
4. Add tags (optional).
5. Click Create.
6. Click Close.

The calculated dimension is now saved in the Dimensions category of the Master items, and you
can use it in visualizations.

Editing a master dimension
When you update a master dimension, the changes will be reflected in all its instances, including all
visualizations that use it.

Edit a master dimension from the assets panel or while editing visualization properties.

Editing a master dimension from the assets panel
Use the assets panel to edit a master dimension when you want to preview the dimension or edit
several master dimensions

Do the following:

1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click the Dimensions heading on the Master items tab to expand the category.
4. Click the dimension that you want to edit.

The preview opens.

5. Click   at the bottom of the preview.
If the dimension is used on a sheet, a dialog is displayed to inform you that any changes to
the master dimension will be applied to all its instances on the sheets.

6. Click OK.
The Edit dimension dialog opens, where you update the field or expression, name,
description and tags.

7. Click Save.

The master dimension is now updated.

You can also right-click the master item, and then click Edit.
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Editing a master dimension from visualization properties
When a dimension in a visualization is linked to a master dimension, you can edit the master
dimension from the properties panel. All visualizations in the app that use the master dimension will
be updated. To edit a linked dimension only in this visualization, without affecting the master item,
you must first unlink it from the master. See Unlinking from a master item (page 152).

Do the following:

1. In edit mode, select the visualization.
2. In the properties panel, click the Data tab.

If it is hidden, click Show properties in the lower right-hand corner.

3. Under Dimensions, click the linked dimension to edit.
4. Under Master item, click Edit.

A dialog is displayed to inform you that any changes to the master dimension will be applied
to all visualization that use the dimension.

5. Make your changes to the master dimension, and then click Save.

Reusing measures with master measures
When you are working with an unpublished app, you can create master measures so
that they can be reused. Users of a published app will have access to the master
measures, but will not be able to modify them.

A master measure is a combination of an expression and descriptive data, such as name,
description and tags. You can create a master measure in different ways.

You can also create a master measure based on a measure created in a visualization. Under the
measure in the properties panel of a visualization, click Add new under Master items.

Master measure formatting
Number formatting, color, and label can be configured for a master measure. These properties are
not applied to a visualization if you reference the master measure using an expression. To apply
these properties in a visualization, create a direct link to the master measure when configuring the
visualization.

Do the following:

1. Expand Data > Measures in the properties panel.
2. Click Add.
3. In the drop down menu, under Measures, select the master measure.

A direct link is now created to the master measure.
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Creating a master measure from a field
When you are working with an unpublished app, you can create master measures so
that they can be reused. You can create a master measure from the Fields section of
the assets panel.

When naming an entity, avoid assigning the same name to more than one field, variable, or
measure. There is a strict order of precedence for resolving conflicts between entities with identical
names. This order is reflected in any objects or contexts in which these entities are used. This order
of precedence is as follows:

l Inside an aggregation, a field has precedence over a variable. Measure labels are not
relevant in aggregations and are not prioritized.

l Outside an aggregation, a measure label has precedence over a variable, which in turn has
precedence over a field name.

l Additionally, outside an aggregation, a measure can be re-used by referencing its label,
unless the label is in fact a calculated one. In that situation, the measure drops in significance
in order to reduce risk of self-reference, and in this case the name will always be interpreted
first as a measure label, second as a field name, and third as a variable name.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Fields in the assets panel.

3. Click the field you want to use to create a measure.
The preview opens.

4. Click at the bottom of the preview.
The Create new measure dialog opens with the field you selected as the name of the
measure and as a part of the expression.

5. Right-click the field you want to use as a measure and click Create measure.
The Create new measure dialog opens with the field you selected. The field name is also
used as the name of the measure.

6. Click in the Expression field to open the Edit expression dialog.

7. Type the expression directly in the expression editor (the main window).
The field names you use in the expression are checked, and the syntax of the expression is
validated.

As you type in the expression editor, the expression is validated continuously. If
there is an error, you see a hint about what is incorrect in the lower left-hand
corner. Additional error information may be available by clicking the icon next to
the hint.

Each line in the expression editor is numbered and syntax highlighting is used.
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You can open the online help with the full description of how to use the current
function by double-clicking the function name in the expression editor and
pressing Ctrl+H on the keyboard. This feature becomes available after having
entered the first parenthesis of the expression after the function name, and only
when using a computer with a keyboard.

8. Click Apply to close the Add expression dialog.
Now you need to add some descriptive data for the measure.

9. Edit the name if you want to.
10. Type a description for the measure (optional).

11. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:

l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
12. Add tags (optional).
13. Under Number formatting, you can choose:

l Auto
l Number
l Money
l Date
l Duration
l Custom
l Measure expression

14. Click Create.

The measure is now saved in the Measures category in the master items, and you can use it in
visualizations.

Direct Discovery fields are indicated by in the Fields section of the assets panel.

Creating a master measure with a common aggregation function
When you are working with an unpublished app, you can create master measures so
that they can be reused. You can easily create a measure using one of the most
common aggregation functions by selecting the function and the field from drop-down
lists.
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When naming an entity, avoid assigning the same name to more than one field, variable, or
measure. There is a strict order of precedence for resolving conflicts between entities with identical
names. This order is reflected in any objects or contexts in which these entities are used. This order
of precedence is as follows:

l Inside an aggregation, a field has precedence over a variable. Measure labels are not
relevant in aggregations and are not prioritized.

l Outside an aggregation, a measure label has precedence over a variable, which in turn has
precedence over a field name.

l Additionally, outside an aggregation, a measure can be re-used by referencing its label,
unless the label is in fact a calculated one. In that situation, the measure drops in significance
in order to reduce risk of self-reference, and in this case the name will always be interpreted
first as a measure label, second as a field name, and third as a variable name.

Do the following:

1. Click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click the Measures heading to expand that category.
4. Click Create new.

The Create new measure dialog opens.

5. Click in the Expression field to open the Add expression dialog.
You find drop-down lists for selecting a field and a common function on the right-hand side.

6. If you want to show fields from a particular table, select this table in the top drop-down list
(optional).

7. Select a field from the Field drop-down list.
8. Select a function from the bottom drop-down list.

You can insert just a field by not selecting a function.

9. Click Insert to insert the field and the function into the expression editor.

You can open the online help with the full description of how to use the current
function by double-clicking the function name in the expression editor and
pressing Ctrl+H on the keyboard. This feature becomes available after having
entered the first parenthesis of the expression after the function name, and only
when using a computer with a keyboard.

10. Click Apply to close the Add expression dialog.
Now you need to add some descriptive data for the measure.

11. Type a name for the measure.
12. Type a description for the measure (optional).
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13. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:

l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
14. Add tags (optional).
15. Under Number formatting, you can choose:

l Auto
l Number
l Money
l Date
l Duration
l Custom
l Measure expression

16. Click Create.

The measure is now saved in the Measures category in the master items, and you can use it in
visualizations.

Creating a master measure by typing the expression
When you are working with an unpublished app, you can create master measures so
that they can be reused. You can add complex expressions by typing the expression
into the expression editor.

1. Click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click the Measures heading to expand that category.
4. Click Create new.

The Create new measure dialog opens.

5. Click in the Expression field to open the Add expression dialog.

6. Type the expression directly in the expression editor (the main window).
The field names you use in the expression are checked, and the syntax of the expression is
validated.

As you type in the expression editor, the expression is validated continuously. If
there is an error, you see a hint about what is incorrect in the lower left-hand
corner. Additional error information may be available by clicking the icon next to
the hint.

Each line in the expression editor is numbered and syntax highlighting is used.
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You can open the online help with the full description of how to use the current
function by double-clicking the function name in the expression editor and
pressing Ctrl+H on the keyboard. This feature becomes available after having
entered the first parenthesis of the expression after the function name, and only
when using a computer with a keyboard.

7. Click Apply to close the Add expression dialog.
Now you need to add some descriptive data for the measure.

8. Type a name for the measure.
9. Type a description for the measure (optional).

10. If you want to specify a color, click in the color drop down and select a color through one
of the following methods:

l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
11. Add tags (optional).
12. Under Number formatting, you can choose:

l Auto
l Number
l Money
l Date
l Duration
l Custom
l Measure expression

13. Click Create.

The measure is now saved in the Measures category in the master items, and you can use it in
visualizations.

Editing a master measure
When you update a master measure, the changes will be reflected in all its instances, including all
visualizations that use it.

Edit a master measure from the assets panel or while editing visualization properties.

Editing a master measure from the assets panel
Use the assets panel to edit a master measure when you want to preview the measure or edit
several master measures.

Do the following:
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1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Under Measures, click the measure that you want to edit.
The preview opens.

4. Click   at the bottom of the preview.

You can also right-click the master item, and then click Edit.

A dialog is displayed to inform you that any changes to the master measure will be applied to
all visualizations that use the measure.

5. Click OK.
The Edit measure dialog opens, where you update the expression, name, description, color,
and tags.

6. Click Save.

The measure is now updated.

Editing a master measure from visualization properties
When a measure in a visualization is linked to a master measure, you can edit the master measure
from the properties panel. All visualizations in the app that use the master measure will be updated.
To edit a linked measure only in this visualization, without affecting the master item, you must first
unlink it from the master. See Unlinking from a master item (page 152).

Do the following:

1. In edit mode, select the visualization.
2. In the properties panel, click the Data tab.

If it is hidden, click Show properties in the lower right-hand corner.

3. Under Measures, click the linked measure to edit.
4. Under Master item, click Edit.

A dialog is displayed to inform you that any changes to the master measure will be applied to
all visualizations that use the measure.

5. Make your changes to the master measure, and then click Save.

Using master measures in expressions
You can use master measures in expressions. You can use the master measure by
itself, or use it to build a more complex expression.
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When you type in the Expression editor, an auto-complete list of matching master measures
opens.

Master measure in Expression editor

Considerations
When working with master measures, consider the following:

l If the master measure is renamed or deleted, references in expressions are not automatically
updated. The old reference will return NULL in the expression as there is no measure by that
name.
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Master measure formatting
Number formatting, color, and label can be configured for a master measure. These properties are
not applied to a visualization if you reference the master measure using an expression. To apply
these properties in a visualization, create a direct link to the master measure when configuring the
visualization.

Do the following:

1. Expand Data > Measures in the properties panel.
2. Click Add.
3. In the drop down menu, under Measures, select the master measure.

A direct link is now created to the master measure.

Example: Using a master measure in an expression
This example creates a master measure, and then uses the master measure in a chart expression.

1. Create the master measure.
i. Click Master items in the assets panel.
ii. Under Measures, click Create new.

Create new measure button

iii. In the Create new measure dialog box, enter a Name for the master measure, and
then click to open the Expression editor.
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Create new measure dialog box

iv. In the Expression editor, create the expression.
You can type the expression, or use the options available in the expression builder
panel.
Insert the expression using the expression builder Count(distinct item), and then click
Apply.
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Add expression in Expression editor

v. In the Create new measure dialog box, click Create.
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Create measure

The new master measure is created.
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New master measure
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2. Use the master measure in a chart expression.
i. Add a KPI chart to a sheet in an app.

New KPI

ii. Click Add measure, and then click to open the Expression editor for the KPI.
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Open Expression editor

iii. Type the master measure into the expression. As you type, you will get an auto-
complete list of any available master measures. If required, the master measure can be
used to build more complex expressions in the Expression editor.
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Add expression for KPI

iv. Close the Expression editor to view the KPI. You can change properties for the KPI,
including the label, in the properties panel.
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Master measure in KPI

Assigning colors to master items
You can assign colors to your master items. Colors assigned to master dimensions and
master measures persist across all instances of those master items in all visualizations.

If you change the color used for the master item, the color will be updated across all instances of
that master item. Optionally, master item colors can be disabled for individual visualizations.

Visualizations use master dimension colors when Single color is selected in the Colors and legend
section of the visualization properties panel. Master measure colors are used when Single color or
Multicolored are selected in the Colors and legend section of the visualization properties panel.

By default, if a visualization's default Auto settings use the Single or Multicolored, master item
colors will be applied automatically. If they do not, you must switch to Custom and select a
supported setting. Master item colors can be disabled in individual visualizations.

In a visualization with colors specified for both master dimension and master measure, Qlik Sense
defaults to the master dimension color. Master measure colors can be applied using the Use library
colors drop-down and selecting Measure in the Colors and legend section of the visualization
properties panel. In visualization with a mix of master measures with assigned colors and measures
without assigned colors, the other measures will use the default palette colors.

Master dimensions can have colors assigned to their distinct values.
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Master measures can have custom color gradients applied to their values in visualizations. .

When assigning colors to your master items, you have the following options:

l Choose a color from the default palette
l Type a hexadecimal color code
l Choose a color using advanced color options

Assigning a color from the default color palette
Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click   to display the master items.

3. Select a master item from your library.

4. Click .

5. Click in the color drop-down.

6. Select one of the colors in the palette.
7. Click outside the dialog.
8. Click Save.

The color dialog with the default color palette and a blue color selected.

Assigning a color using a hexadecimal color code
Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click   to display the master items.

3. Select a master item from your library.

4. Click .
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5. Click in the color drop-down.

6. Type a 6 character color code in the input field: #.
7. Click outside the dialog or press Enter.
8. Click Save.

Assigning a color using advanced color options
Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click   to display the master items.

3. Select a master item from your library.

4. Click .

5. Click in the color drop-down.

6. Click at the bottom of the dialog.
The dialog displays the advanced options.

7. Select a color in the color wheel.
The selected color changes and the Hex color code updates accordingly.

8. Optionally, adjust the color saturation using the slider.
The saturation changes and the Hex color code updates accordingly.

9. Click outside the dialog.
10. Click Save.

The color dialog with the color wheel in the advanced options and a blue color selected.
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Assigning colors to master dimension values
You can assign colors to the distinct values contained in a master dimension. This
ensures that the distinct values of your dimensions use the same colors in all
visualizations.

Colors assigned to values are used when you choose to color By dimension and have Library
colors enabled. If you choose to color by Single color, the master dimension's color is used instead.

Assigning colors to master dimension values has the following limitations:

l A maximum of 100 colors can be assigned to a dimension's values.
l Dimension values cannot be longer than 1024 characters. Longer values are disabled in the

list of values.
l Drill-down and cyclic dimensions do not support assigning colors to dimension values

Do not assign colors to master dimension values if you use section access or work with
sensitive data, because the values might be exposed by the color configuration.

The Value colors section of Edit dimensions contains the options for assigning colors to a
dimension's distinct values. You can search the list of values with .

Qlik Sense automatically applies an auto fill to your values to provide a default color. The auto fill is
either a single color or a color scheme. Changing your auto-fill settings will not change colors you
have assigned to values.

In addition to distinct values, you can set colors for the values classified as others in a visualization,
that is, the collection of distinct values that fall outside the displayable values in a dimension. You
can also set colors for null values.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click   to display the master items.

3. Select a master dimension from your library.

4. Click .

5. Click Value colors.
6. If you want to change the auto fill settings, set Auto fill to Custom , select the auto fill

method, and either select a single color or color scheme.
7. Select a value and do one of the following:

l Select a color in the color wheel, and optionally adjust the saturation slider.
l Type a 6 character color code in the Hex input field: #.

Values assigned colors display the icon.
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8. If you want to remove an assigned color, select the value and click .

9. Optionally, to assign a color to Others or Null values, click and do one of the following:
l Click one of the colors in the palette.
l Type a 6 character color code in the Hex input field: #.
l Click at the bottom of the dialog, select a color in the color wheel, and optionally

adjust the saturation slider.
10. Click Save.

Assigning colors to master measure values
You can assign a color gradient or segment scheme to a master measure, enabling you
to color visualizations by measure, using colors other than the default color schemes.

If you choose to color by single color, the master measure's color is used instead of the color
scheme.

To assign custom segment or gradient colors to the values in a master measure, do the following:

1. Access and enable segment colors.
2. Select the template scheme.
3. Select the segment format.
4. Optionally, add or remove limits.
5. Optionally, edit your segment limits.
6. Assign colors to your segments.
7. Save.
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Accessing and enabling segment colors

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click   to display the master items.

3. Select a master measure from your library.

4. Click .

5. Click on the Segment colors tab.
6. Set the Segment colors button to Custom coloring.

Selecting the template scheme
The template scheme provides a default template to edit. You can choose from the default classes
and gradients.

Do the following:

l Under Select a template scheme, select a template scheme.

Selecting the segment format
The segment format determines how colors will be applied. Percentage adds value classes based
on where values fit into the percentile of their value. Fixed value uses defined values to set the
limits of each segment.

Do the following:

l Set Segment format to Fixed value or Percentage.

Adding, editing and removing limits
By default, the number of segments depends on the scheme selected. You can create additional
segments by adding limits. When a new segment is created a pointer marks the value of its limit.

Do the following:

l Click on the Add limit button to add a limit to the gauge.
l Use the slider to change the value of a limit. You can also type a value for the selected limit.
l Click on the Remove limit button to remove the selected limit.

Editing segments
By default, segment colors depend on the scheme selected. You can change the color of a segment
and its ending.
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Do the following:

l Click the segment to change colors.
l Select Gradient to use different shades of colors in the transition between segments for the

selected limit.

Create calendar measures
To analyze data over relative time ranges, use calendar measures. For example, you
might want to compare current year-to-date sales figures with figures from the same
period the previous year.

Calendar measures aggregate data from a field over a time range, and are saved in the Measures
category in the master items. Calendar measures comprise a field to be aggregated, an
aggregation, a date field, and a time range for that date field that sets which data is included in the
aggregation. You create calendar measures under Fields in the Assets panel, using the Create
calendar measures dialog.

You can aggregate fields from tables loaded in Data manager or from a script in Data load editor,
as long as the field is in the same table as the date field, or is in an associated table.

However, the date field must be from a table that has been loaded using Data manager, because
calendar measures use expressions tagged as date & time fields that are declared in autoCalendar,
and date fields are only mapped to autoCalendar when loaded in Data manager. Calendar
measures support the following aggregations with the aggregated field: Sum, Count, Avg, Min, and
Max.

Calendar measures do not support calendars created using the Data load editor. If you
use calendars created using Data load editor and want to create calendar measures,
you must load a table containing a date field using Data manager for use with your
tables loaded using Data load editor.

If your date field is subject to more than one calendar and both calendars are qualified
for use with calendar measures, then the first calendar loaded in the data load script is
used in the calendar measures.

A calendar measure can use one of the following time ranges are available for use with calendar
measures: weekly, monthly, quarterly, and yearly. Within each time range, different measures exist
for periods such as current month, year-to-date, and current week last year. The following time
ranges and measures are available for creating calendar measures:
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Measure Description

YTD The year to date for all years.

YTD Current Year The year to date for the current year.

YTD Last Year The year to date for last year.

Calendar measures for time range Yearly

Measure Description

MTD The month to date for all months and years.

MTD Current Month The month to date for the current month.

MTD Last Month The month to date for last month.

Current Month All dates this month.

Current Month Last Year All dates this month last year.

Last Month All dates last month.

Calendar measures for time range Monthly

Measure Description

QTD The quarter to date for all years.

QTD Current Quarter The quarter to date for the current quarter.

QTD Last Quarter The quarter to date for the last quarter.

Current Quarter All dates in the current quarter.

Current Quarter Last Year All dates in the current quarter last year.

Last Quarter All days for the last quarter.

Calendar measures for time range Quarterly

Measure Description

WTD The week to date for all weeks across all years.

WTD Current Week This week to date for the current week.

WTD Last Week The week to date for the last week.

Current Week All dates this week.

Current Week Last Year All dates this week last year.

Last Week All dates last week.

Calendar measures for time range Weekly
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Once created, calendar measures are treated identically to master measures. That is, calendar
measures are reusable and editable while an app is unpublished. Users of a published app will have
access to the calendar measures, but will not be able to modify them.

Creating a calendar measure from a field
On a sheet in edit mode with the Fields tab open, do the following:

1. Right-click a field and select Create calendar measures.
By default, the field you right-clicked will be included as the Aggregated field.

2. Select a date field from the Date field drop-down list.
3. Select a field from the Aggregated field drop-down list.
4. Select an aggregation from the Aggregation drop-down list.
5. Select a time range from the Time range drop-down list.

A list of the available measures displays under Preview of measures.
You can toggle the display of the measures' expressions by selecting the Preview of
measures switch.

6. Select the calendar measures to add to your master items.
By default, all measures are selected.

7. Click Save to master items.
8. Click Close.

Tagging master items
You can use tags to organize master items. You will find matches in tags when searching in the
assets panel. You can also tag master items with synonyms for Insight Advisor. Use the format
alt:<term> in synonym tags. For example, alt:cities.

Each tag can contain a maximum of 31 characters, and each master item can have up to 30 tags.

Adding tags to a master item
You can add tags when creating or editing a master item.
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Adding tags while creating a new measure

You can add tags by clicking or by pressing Enter.

Previewing tags
In the assets panel, tags are displayed when previewing dimensions, measures, and visualizations.
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The preview displays the dimension type, which fields are included in the drill-down dimension and tags.

Unlinking from a master item
Unlink a dimension or measure in a visualization from its master item to edit only the current
instance of the dimension or measure. Unlinking removes the connection to the master item, and
the dimension or measure becomes independent. If you want to update all instances of a linked
dimension or linked measure, you must edit the master item. For more information, see Editing a
master dimension (page 125) or Editing a master measure (page 131).

Unlinking from the properties panel
Unlink from a master dimension or master measure in a visualization using the properties panel.

Do the following:

1. Click Edit sheet.
The properties panel opens on the right-hand side.

2. Select the visualization on the sheet.
The properties for the selected visualization are displayed in the properties panel.

3. Under Data, locate and click the dimension or measure.
A linked dimension or measure is indicated by the symbol .

4. Click .
A dialog is displayed that you are about to unlink from a master item

5. Click OK.

You can now edit the dimension or measure in the visualization without affecting any visualization
that use the master items.

You can only unlink from a single dimension, not a drill-down dimension.
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Unlinking from a master visualization
Unlink a visualization from its master visualization to edit only the current instance.
Unlinking removes the connection between the visualization on your sheet and the
master item. The current visualization becomes independent. To edit all visualizations
that are linked to a master visualization, see Editing a master visualization (page 118).

Do the following:

1. Click Edit sheet.

2. Click in the top right corner of a linked visualization, and then click Unlink visualization.
A dialog is displayed that you are about to unlink from a master visualization.

3. Click OK.

The visualization on the sheet can now be edited and the changes will not affect any other
visualizations.

You can also right-click the linked visualization, and then click Unlink visualization from
the shortcut menu.

Deleting a master dimension or master measure
You can delete dimensions and measures from the master items as long as the app is not published.

If you delete a master dimension or master measure the visualizations that use the
deleted master items will not work unless you replace it with a new dimension or
measure.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Click Dimensions or Measures to expand the corresponding category.
4. Click the dimension or measure that you want to delete.

The preview opens.

5. Click at the bottom of the preview.
A dialog is displayed stating that all visualizations that use the dimension or measure will stop
working.

6. Click OK.

The dimension or measure is deleted from the master items, and all visualizations on the sheets that
used the deleted item do not work anymore. You see the text Dimension not found or Measure not
found on those visualizations.
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A visualization that is lacking both a dimension and a measure, both which have been deleted from the
master items.

Replacing an invalid dimension or measure
When a dimension or measure has been deleted from the master items, all visualizations that
reference to the deleted master item will not work anymore, until the missing dimension or measure
is replaced.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Master items in the assets panel.

3. Drag a dimension or measure from the Dimensions or Measures sections to the visualization
on the sheet.
The shortcut menu opens.

4. Select Replace invalid dimension or Replace invalid measure.

The visualization is complete and works again.

Deleting a master visualization
You can delete visualizations from the master items as long as the app is not published.

Do the following:
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1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. Click Advanced options.

3. Click   to display the master items.

4. Click the visualization that you want to delete.
The preview opens.

5. Click at the bottom of the preview.
A dialog is displayed stating that wherever this visualization is used on sheets there will be
invalid instances of it.

6. Click OK.

The visualization is deleted from the master items, and on all sheets where this visualization was
used, you see invalid visualizations. You now need to replace the invalid visualization with other
ones, or delete the instances.

You can also delete visualizations from the preview that is displayed when clicking the
visualization in the master items.

Replacing an invalid visualization on a sheet
The representation of the invalid visualization is there to tell you that there used to be a
visualization at a certain location on the sheet, but the invalid visualization serves no purpose.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.
The assets panel opens on the left-hand side. Click   to display the master items.

2. Drag a visualization from the master items to the location of the invalid visualization on the
sheet.

The invalid visualization is replaced.

Deleting an invalid visualization
1. In sheet view, click Edit sheet in the toolbar.

2. Right-click on the invalid visualization and select Delete in the shortcut menu.

The invalid visualization is deleted.

Using expressions in visualizations
Visualizations in Qlik Sense are built from charts, which in turn, are built from
dimensions and measures, depending on the type of chart. Visualizations can have
titles, subtitles, footnotes, and other elements to help convey information. All of the
elements that make up a visualization can be simple: a dimension consisting of a field
representing data, a title consisting of text, for example.
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For visualizations that contain measures, the measures are aggregations based on fields.
Specifically, the measures are calculations that span multiple records. For example Sum(Cost)
means all the values of the field Cost are aggregated using the function Sum. In other words, Sum
(Cost) is an expression.

What is an expression?
An expression is a combination of functions, fields, and mathematical operators (+ * / =), and other
measures. Expressions are used to process data in the app in order to produce a result that can be
seen in a visualization. They are not limited to use in measures. You can build visualizations that are
more dynamic and powerful by using expressions for titles, subtitles, footnotes, and even
dimensions.

This means, for example, that instead of the title of a visualization being static text, it can be made
from an expression whose result changes depending on the selections made.

Where can I use expressions?
Expressions can be used in a visualization wherever the symbol   is seen in the properties panel

while editing a visualization. The   symbol indicates an expression field. By clicking  , you enter
the expression editor, which is designed to help you build and edit expressions. Expressions can
also be entered directly into the expression field, without using the expression editor.

An expression cannot be saved directly as a master item but if an expression is used in a measure
or dimension, which is then saved as a master item, with its descriptive data, such as name,
description, and tags, the expression in the measure or dimension is preserved.

Expressions are used both in scripts and in chart visualizations. They can be simple, involving only
basic calculations, or complex, involving functions fields and operators. Expressions can be used in
several different situations. The difference between measures and expressions is that expressions
have no name or descriptive data.

In a script, an expression is evaluated as the script execution passes it by. In
visualizations (including charts and tables), expressions are evaluated automatically
whenever any of the fields, variables or functions that the expression contains change
value or logical status. A few differences exist between script expressions and chart
expressions in terms of syntax and available functions.

For detailed reference regarding script functions and chart functions, see the Script
syntax and chart functions.

Working with the expression editor
You can enter the expression editor to add or edit an expression wherever you see the symbol in

the properties panel while editing a visualization. The symbol indicates an expression field. Click
to enter the expression editor.
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You can add expressions in two ways. Expressions can be created using the Fields, Functions,
Variables, and Set expressions sections by making selections and inserting them into the
expression field. You can edit the inserted expressions and add more complex expressions by
typing directly into the expression field. You can undo an action by clicking the Undo button .

Inserting an expression using Fields
You can insert an expression by making selections from the Fields section at the right-hand side of
the expression editor dialog.

Do the following:

1. If you want to limit the available fields to those from a particular table in your data model,
select a table from the Filter by table drop-down list.

2. Select a field from the Field drop-down list.
3. Select the aggregation function you want to use. The functions available are from the group

of basic aggregation functions.
4. If you want to insert the current selection as a set expression in your aggregation, use the

Set expression check box. The current selection is always based on the default state.
5. If you want to insert a Distinct or a Total clause together with the aggregation function, use

the check boxes for each clause. Each clause can be used separately.
6. Click Insert to insert the field and the function into the expression field.

If you do not select an aggregation function, only the field will be inserted into the
expression. Clauses can only be added if you select an aggregation function.

7. Click Apply to close the Add expression dialog.
For a dimension or measure, you continue by adding descriptive data for the dimension or
measure.

Inserting a function using Functions
You can insert more than the basic aggregation functions by making selections from the Functions
section at the right-hand side of the expression editor dialog.

1. If you want to filter the list of available functions, select a function category from the
Function category drop-down list.

2. Select a function from the Function name drop-down list.
You see a preview of the function.

3. Click Insert to insert the function and the first parenthesis into the expression field.
4. Type the rest of the expression in the expression editor according to the syntax.
5. Click Apply to close the Add expression dialog.

For a dimension or measure, you continue by adding descriptive data for the dimension or
measure.
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Inserting a variable using Variables
You can insert a variable by making selections from the Variables section at the right-hand side of
the expression editor dialog.

1. If you want system variables to appear in the list of available variables use the Show system
variables check-box.

2. Select a variable from the Variable drop-down list.
You see a Definition and Value of the variable, if available.

3. Click Insert to insert the variable into the expression field.
4. Click Apply to close the Add expression dialog.

For a dimension or measure, you continue by adding descriptive data for the dimension or
measure.

Inserting a set expression using Set expressions
You can insert a set expression by making selections from the Set expressions section at the right-
hand side of the expression editor dialog.

1. Select whether to Use current selections or Use bookmark, as a set expression.
You can only Use current selections if a selection has been made in the app. You can only
Use bookmark if a bookmark is available. Use the Bookmark drop-down menu to choose
between bookmarks.

2. If you have defined alternate states, you can change the alternate state which the set
expression is based on. Select the alternate state from Alternate state drop-down menu.

3. Click Insert to insert the set expression into the expression field.
4. Click Apply to close the Add expression dialog.

For a dimension or measure, you continue by adding descriptive data for the dimension or
measure.

Adding or editing an expression by typing

Do the following:

1. Type the expression directly in the expression field.
The field names you use in the expression are checked, and the syntax of the expression is
validated.

As you type in the expression editor, the expression is validated. If there is an
error, you see a hint about what is incorrect. Additional error information may be
available by clicking the icon next to the hint.

When you type the name of a function in the expression, a tooltip appears that provides
information to help you enter the function correctly, including argument names and qualifiers.
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The tooltip for some chart functions shows the ALL qualifier. It is recommended
that you do not use the ALL qualifier. Instead, use the set expression {1}.

Each line in the expression editor is numbered and syntax highlighting is used.
2. Click Apply to close the Add expression dialog.

For a dimension or measure, you continue by adding descriptive data for the dimension or
measure.

Autocomplete, evaluation and color coding
When typing in the expression editor, you get an autocomplete list of matching fields, variables and
functions to select from. The list is narrowed down as you continue to type. The color coding helps
you to see where fields, variables and functions are used in the expression.

The color coding applies both in the autocomplete list and in the expression itself.

You can verify that any dollar-sign expansions added in your expression give the correct result, by
checking the expression evaluation, in the dollar-sign expansion preview.

Search and replace
When using the expression editor, you can open the search and replace toolbar by clicking . Type
in the string you want to look for in the Search for field, using the Match case option if necessary.
All the matching occurrences in the expression will be highlighted and you can navigate between all
of them using the Previous and Next arrows. You can then optionally replace one or all of the
occurrences with the string you enter in the Replace with field.

Detailed syntax help
You can activate help mode by clicking the Help button . When active, all functions in the
expression editor act like hyperlinks. Clicking on a function opens a browser tab to the online help
section with the full description of how to use the specific function. When a function is clicked, help
mode is exited.

References to fields, measures, and variables
An expression can contain references to fields, variables, and measures.

In most cases, expressions are aggregations, that is calculations that potentially can span multiple
records. This means that all field references in an expression must be wrapped in an aggregation
function. If no aggregation function is used, the Only() function is used.

When the name of a measure is used inside an expression, it is interpreted as an alias for the
measure. This allows you to re-use an already defined entity. You can use the labels of master
measures and chart measures in this way. However, the chart measure must be in the same chart.
You cannot use labels of measures in other charts.

You can define a measure recursively. In other words, the measure can contain a reference to itself.
However, you should only do this in charts with few rows. Performance degrades if the chart has
many rows. If there are hundreds of rows, the recursive definition will stop working altogether.
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A variable can be used in two different ways: in a direct reference or in a dollar-sign expansion. If
you use a direct reference, the variable value will be used in the calculation. If you use a dollar-sign
expansion, the entire dollar-sign expansion will be replaced by the variable value before the
expression is parsed. Therefore, the two different methods may return different results.

How names are interpreted
A name inside an expression can be a reference to a field, a variable, a function, or a measure.
Depending on situation, the name is interpreted differently.

Example:

The string XXX represents a field, a variable, a function, or a measure. XXX will be interpreted as one
of these depending on how you create the expression.

Expression XXX interpreted as

XXX measure, variable, or field

$(XXX) variable

Count(XXX) field or variable

XXX() function

Examples of how names are interpreted

You should not use the same name for a field and a variable (or a measure). But if you do and there
is ambiguity, the following order of precedence is used:

l If the name is found inside an aggregation function, a field has precedence over a variable.
l If the name is found outside an aggregation function, a measure label has precedence over a

variable name, which in turn has precedence over a field name.

Rules for expressions
The following rules apply for chart expressions:

l If a field reference isn’t wrapped in an aggregation function, the Only() function is used by the
engine.

l All expressions return a number and/or a string, whichever is appropriate.
l Logical functions and operators return 0 for False, -1 for True. Number-to-string conversions

and string-to-number conversions are implicit.
l Logical operators and functions interpret 0 as False and all else as True.
l Expressions that cannot be correctly evaluated, for example as a result of incorrect

parameters or functions, return NULL.

Using functions in charts
A function is a type of procedure or routine that performs a specific task on data in apps. Qlik Sense
contains several hundred ready-made functions that can be used in charts when creating
visualizations. Functions can be, for example, mathematical, logical, can operate on financial or
date and time information, can be used to manipulate strings, and other situations.
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Functions can be grouped into the types:

l Aggregation functions, which use several records as input and produce a single value result.
l Scalar functions, which take a single input and produce a single output.
l Range functions, which produce a single value based on a range of input values.
l Range-producing functions, which are like range functions, but produce a range of values as

output.

Many of the functions can be used in both chart expressions and scripts, but some are specific for
chart expressions.

The following list shows some examples of functions:

l Max: an aggregation function that can be used in scripts and charts.
For example: Max(Sales) calculates the highest value in the field Sales.

l IF: a conditional function that can be used in scripts and charts.
For example: IF(Amount>0, 'OK','Alarm') determines if the condition 'is the value of Amount
greater than zero?' is met. If it is, OK is written, otherwise Alarm is written.

l Date#: an interpretation function that can be used in scripts and charts.
For example: Date#(A) takes the input value A and evaluates it as a date.

A few differences exist between script expressions and chart expressions in terms of
syntax and available functions. The most important difference is the role of the
aggregation functions and the use of field references. The basic rule is that any field
name in a chart expression must be enclosed by exactly one aggregation function. An
aggregation function can never have another expression containing an aggregation
function as argument.

For detailed reference regarding script functions and chart functions, see the Script
syntax and chart functions.

Using variables in expressions
A variable in Qlik Sense is a container storing a static value or a calculation, for example a numeric
or alphanumeric value. When you use the variable in the app, any change made to the variable is
applied everywhere the variable is used. You can define variables in the variables overview, or in
the script using the Data load editor. You set the value of a variable using Let or Set statements in
the data load script.

When using variables in expressions, you can change the expression used in a range of
charts simultaneously simply by editing the variable.

You open the Variables overview by clicking in the edit bar when editing a sheet.
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The Variables overview is not available in published apps. If you need to add or change
variables in an published app, use the variable input control available with the Dashboard
bundle.

The following actions are available in the variables overview:

l Create a new variable.
l Edit the selected variable.
l Delete the selected variable.

To edit or delete a variable that is defined in the script, you must edit the script.

Getting an overview of all variables in an app
You can get an overview of all variables in an unpublished app.

Do the following:

l When editing a sheet, click in the edit bar on the sheet to open the variables dialog.
The variables dialog opens and displays a list of all variables in the app and their definitions 
(if any).

Examples
For examples of how to use variables in expressions, see Example: Using a variable with dollar-sign
expansion (page 164).

See also:

Working with the expression editor (page 156)

Creating a variable
A variable in Qlik Sense is a named entity, containing a data value. When a variable is
used in an expression, it is substituted by its value or the variable's definition. 
Variables are defined using the variables dialog or in the script using the data load
editor.

You can create a new variable from the variables dialog, when editing a sheet in an unpublished
app.

You can duplicate an existing variable by clicking and selecting Duplicate.

For a visual demo about creating variables, see Creating a variable.
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Do the following:

1. When editing a sheet, click in the edit bar on the sheet to open the variables dialog.
The variables overview opens.

2. Click Create new.
The following input fields for the variable are displayed:

l Name (mandatory)
l Definition
l Description
l Tags

Press Esc or click Cancel if you want to cancel creating the new variable.
3. Type a name for the variable (mandatory). Use the following guidelines when choosing a

name:
l You cannot change the name once you have created the variable.
l Use a letter as the first character, do not use a number or a symbol.
l It is not recommended to name a variable identically to a field or a function in Qlik

Sense.
For more information, see How names are interpreted (page 166).

l Do not use the following characters when naming a variable: $ ( ) [ ] "

l The name must be unique. You cannot name a variable using a name used for a
reserved variable or a system variable. These variables are not listed in the variables
dialog, but if you are not allowed to use a certain name, even though you cannot find a
duplicate in the variables dialog, a reserved variable or a system variable already has
this name.

l A long name is not recommended. If a variable's name is too long, the name cannot be
fully displayed in the variables overview.

4. Optionally, type a description for the variable.

5. Create a definition for the variable. You can enter the expression editor by clicking .
For more information, see Working with the expression editor (page 156).

Example:

Set the variable's value to today's date, presented as a number: 
Num(Today())

6. Optionally, enter tags for the variable.
7. Click Create to save the variable.

Editing a variable
You can edit variables from the variables dialog.

You can edit variables defined in the script in the variables dialog. If you reload the
script, however, your changes will be undone.
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Do the following:

1. When editing a sheet, click in the edit bar on the sheet to open the variables dialog.
The variables dialog opens.

2. In the row of the variable you want to delete, click and select Edit.

3. Edit the variable as desired.
4. Click Save.

Deleting a variable
You can delete variables, from an unpublished app, by deleting them from the variables
dialog.

Do the following:

1. When editing a sheet, click in the edit bar on the sheet to open the variables dialog.
The variables dialog opens.

2. Select the variables you want to delete and click Delete. You can select up to 20 variables.
You can also click in the row of the variable you want to delete and select Delete.

If you remove a variable from the script and reload the data, the variable stays in
the app. If you want to fully remove the variable from the app, you must also
delete the variable from the variables dialog.

Deleting a variable cannot be undone.

3. Click Delete.

Examples of using a variable in an expression
A variable in Qlik Sense is a named entity, containing a data value. When a variable is
used in an expression, it is substituted by its value or the variable's definition.

Ways to use variables in an expression
A variable can be used in two different ways: in a direct reference or in a dollar-sign expansion. If
you use a direct reference, the variable value will be used in the calculation. If you use a dollar-sign
expansion, the entire dollar-sign expansion will be replaced by the variable value before the
expression is parsed. Therefore, the two different methods may return different results.

Example: Using a variable with dollar-sign expansion
The variable x contains the text string Sum(Sales).

In a chart, you define the expression $(x)/12. The effect is exactly the same as having the chart
expression Sum(Sales)/12.
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However, if you change the value of the variable x to for example Sum(Budget), the data in the
chart are immediately recalculated with the expression interpreted as Sum(Budget)/12.

When using variables in expressions, you can change the expression used in a range of
charts simultaneously simply by editing the variable.

Example: Variable with dollar-sign expansion in pivot table
Suppose you have a Pivot table or Pivot object that contains the following:

l Dimensions are Product Type and Product Name.
l Measures are Sum(Sales) and Count (distinct InvoiceNumber).
l The items under Columns are Values (default) and the field Quarter.

You can use variables to encourage interactive analysis. Suppose you also create a variable
vUserInteraction with a blank definition. Then, you create two Button charts on your sheet,
configured with the Set variable value action:

l Show more detail: Clicking this button sets vUserInteraction to a value of ='Yes'.
l Show less detail: Clicking this button sets vUserInteraction to a value of ='No'.

In your pivot table, you could add a number of additional measures to the chart, such as Count
(Quantity) and Sum(Cost). Then, configure each measure column to have the following value for
Show column if:

'$(Reference)'='Yes'

This allows the chart to adapt to whether or not the user wants additional information. If the user
clicks the Show more detail button, additional measures are added to the table. If not, or if they
click Show less detail, the additional measures are removed.

More examples: Using variables in dollar-sign expansions
Dollar-sign expansions are a versatile and powerful tool in Qlik Sense, with many possible uses. For
more examples, see Dollar-sign expansions.

Example: Directly referencing a variable in an expression
Using a variable as a direct reference is less common, but still useful. For example:

Suppose you have a field TransactionSummary in your data model that contains free text
summaries of transactions. This field could contain supplemental information about transactions.
For example, a transaction could have a summary to document that the customer purchased an
item with a store credit, or to document any issues that came up during the sale.

In your app, you might want to use TransactionSummary but you want to put the data into context
without affecting the data model or load script, and without storing it elsewhere in the chart.

You could do the following:
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1. Create a variable named vIntroStatement in the variables dialog with the following definition:
='The following summary was provided by the vendor: '

2. Add the following measure to a Text & image chart:
vIntroStatement & TransactionSummary

Storing the introductory statement as a variable allows you to centrally control the use of a value.
For example, the variable vIntroStatement could be used in multiple charts, and within a number of
different measures (for example, there could be a separate chart that sometimes contains text
describing how many units were sold during the transaction). By using a variable, you can simplify
the process of updating expressions in the app. To make a change to the wording, simply update
the variable and the changes are reflected across the app.

How names are interpreted
It is not recommended to name a variable identically to a field or a function in Qlik Sense. But if you
do, you must know how to use them in an expression.

Example:

The string XXX represents a field, a variable, a function, or a measure. XXX will be interpreted as one
of these depending on how you create the expression.

Expression XXX interpreted as

XXX measure, variable, or field

$(XXX) variable

Count(XXX) field or variable

XXX() function

Examples of how names are interpreted

When naming an entity, avoid assigning the same name to more than one field, variable, or
measure. There is a strict order of precedence for resolving conflicts between entities with identical
names. This order is reflected in any objects or contexts in which these entities are used. This order
of precedence is as follows:

l Inside an aggregation, a field has precedence over a variable. Measure labels are not
relevant in aggregations and are not prioritized.

l Outside an aggregation, a measure label has precedence over a variable, which in turn has
precedence over a field name.

l Additionally, outside an aggregation, a measure can be re-used by referencing its label,
unless the label is in fact a calculated one. In that situation, the measure drops in significance
in order to reduce risk of self-reference, and in this case the name will always be interpreted
first as a measure label, second as a field name, and third as a variable name.

As a best practice, consider using a standardized naming convention for the variables you create in
an app. For example, you could make sure all of your variable names start with v. For example:
vUserText. This helps to ensure variables are recognized quickly as variables and differentiated
from measures, fields, and functions.
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Variable calculation
There are several ways to use variables with calculated values in Qlik Sense, and the result
depends on how you define it and how you call it in an expression.

This example requires the following data is loaded in the data load editor:

LOAD * INLINE [

Dim, Sales

A, 150

A, 200

B, 240

B, 230

C, 410

C, 330

];

Let's define two variables, from the variables dialog:

l Name vSales Definition'Sum(Sales)'
l Name vSales2 Definition'=Sum(Sales)'

In the second variable, we add an equal sign before the expression. This will cause the variable to
be calculated before it is expanded and the expression is evaluated.

If you use the vSales variable as it is, for example in a measure, the result will be the string Sum
(Sales), that is, no calculation is performed.

If you add a dollar-sign expansion and call $(vSales) in the expression, the variable is expanded,
and the sum of Sales is displayed.

Finally, if you call $(vSales2), the variable will be calculated before it is expanded. This means that
the result displayed is the total sum of Sales. The difference between using =$(vSales) and
=$(vSales2) as measure expressions is seen in this chart showing the results:

Dim $(vSales) $(vSales2)

A 350 1560

B 470 1560

C 740 1560

Results

As you can see, $(vSales) results in the partial sum for a dimension value, while $(vSales2) results in
the total sum.

See also:

Working with the expression editor (page 156)
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Using chart level scripting in visualizations
With chart level scripting, you can add script-like functionality to the results of a
visualization. It complements chart expressions, as chart level scripting include control
statements, such as loops and recursive actions, for more complex mathematical
calculations. You can also modify multiple columns, as long as a placeholder exists in
the chart, and add new rows to a result.

You can use chart level scripting on most visualization types and you access it from the properties
panel. Some visualizations or specific configurations, do not support chart level scripting. In those
cases, you cannot access chart level scripting from the properties panel, or you will receive an error
message.

When modifying chart data, you use a sub-set of the Qlik Sense script which consists of a number
of statements. See Chart level scripting.

You enable chart level scripting in the app settings. When enabled, a Scripts control is available on
the Data section of the properties panel for a visualization. See Turning on chart level scripting.

Even when disabled, existing chart scripts will be processed. Disabling once authored content has
been developed is a useful way of preventing new chart scripts being created by other users.

Adding a chart script to a visualization
You can add chart scripts to existing visualizations, or when you create new visualizations.

Chart level scripting must be enabled in the app before you can add a chart script to a visualization,
see Turning on chart level scripting.

You must be in Edit sheet mode with Advanced options turned on to be able to add a chart
script to a visualization.

Adding chart scripts to a new visualization

Do the following:

1. Drag the visualization from the assets panel onto the sheet, or double-click the visualization.
2. On the Data tab, add dimensions and measures to the visualization.
3. Also on the Data tab, add a chart script in the Scripts section.

You can add maximum five chart scripts per visualization.

Adding chart scripts to an existing visualization

Do the following:

1. When in Edit sheet mode, select the visualization.

2. On the Data tab, add a chart script in the Scripts section.
You can add maximum five chart scripts per visualization.
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Example
This example assumes that you have created a visualization, for example a bar chart, and that you
have added a dimension and a measure.

This example takes the values of the first dimension and puts them in the first measure in reverse
order.

Let P = HCNoRows();

For J = 1 to P

Put #hc1.measure.1(J) = HCValue(#hc1.dimension.1, P - J + 1);

Next

Limitations of chart level scripting
Chart level scripting cannot be used in the standard edit mode.

Chart level scripting does not work for visualizations with Chart suggestions enabled.

You can add maximum five chart scripts per visualization.

Chart level scripting is not available for the following visualizations:

l Bar charts in stacked mode
If you have created a chart script in grouped mode and switch to stacked mode, an invalid
hypercube error will be shown.

l Box plot
l Button
l Distribution plot
l Filter pane
l Line charts with two dimensions
l Pivot table
l Text & image
l Treemap
l Grid Chart (Visualization bundle)
l Trellis Container (Visualization bundle)

Searching in the assets panel
Find assets using the search field. As you type in the search field, items that have a
name or a tag that contain the search string are presented.

The search function is not case sensitive.

When editing a sheet, use the assets panel to search for items you can use for building the app.

When a matching string is found in a tag, it is indicated by a tag icon in the search result. Click an
item in the list of results to preview it.
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Searching for "inv" among the measures presents any measure that contains that string in its name or a tag.

Searching in sheet analysis mode
Search for exploration-related assets when you are viewing a sheet in analysis mode. For example,
you search for sheets, bookmarks, notes, or key driver analyses.
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Searching for sheets in the assets panel

Designing visualizations with Direct Discovery
Designing visualizations from Direct Discovery fields requires some background
knowledge about the nature of the field types that can be used.
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Direct Discovery fields in visualizations

DIMENSION
l The Direct Discovery DIMENSION field type can be used in the same way as any other

dimension.

MEASURE
l A Direct Discovery MEASURE must be aggregated with one of the common functions before

it can be used in a visualization.
l A regular field that is dropped onto a sheet becomes a filter pane, but not a Direct

Discovery MEASURE as it must be aggregated first.

DETAIL
The Direct Discovery DETAIL field type can only be used in tables, and not in combination with a
measure.

When creating a table using a Direct Discovery DETAIL field, and the number of rows
being retrieved exceeds a value defined in the load script (by default, 1000 rows), you
may see a warning message and the table may appear to be invalid. To make the table
work normally, try making selections in the app to reduce the data set.

This functionality is not available in all editions of Qlik Sense.

3.3 Best practices for choosing visualization types
A good visualization clearly presents relationships among many values, and lets you
analyze data at a glance. Qlik Cloud Analytics offers a range of Qlik Sense
visualizations and charts. Each chart excels at visualizing data in different ways for
different purposes. You should select your charts by deciding what you want to see
from the data in your charts.

If you are unsure of what visualizations to use, Qlik Sense can offer recommendations. For more
information, see Creating visualizations with Insight Advisor (page 560) and Creating visualizations
using Insight Advisor chart suggestions (page 585).

The following lists the purposes for viewing data and the chart type recommended to achieve that
purpose:

Viewing comparisons
Comparison charts are used to compare values against each other. They show the differences in
values, such as the difference between categories, or how values are changing over time.

Questions that might be answered by comparison charts include:
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l What product has the highest total sales this year?
l How have product sales risen or fallen over the last 24 months?

Chart type Common purpose

Bar chart (page 179) Comparing categories against the same measure or measures.

Line chart (page 244) Comparing trends over time.

Combo chart (page 206) Comparing measures that are different in scale.

Chart types for viewing comparisons

If you want to compare different values of the same dimension, you can use alternate states.

Viewing relationships
Relationship charts are used to explore how values relate to each other. A relationship chart allows
you to find correlations, outliers, and clusters of data.

Questions that might be answered by relationship charts include:

l Is there a correlation between advertising spending and sales for our products?
l How do expenses and income vary per region?

Chart type Common purpose

Scatter plot (page
345)

Viewing the relationship between two or three measures for a
dimension.

Chart types for viewing relationships

Viewing compositions
Composition charts take a total value and discover what component values make up that total.
Composition charts can be static, showing the current composition of a total value, or they can
show how the composition of a total value changes over time. Composition charts can display
compositions either by percentage of the total value or the fixed values in the total value.

Questions that might be answered by composition charts include:

l What percentages of our total sales come from which regions?
l What is each department's allotment of our total quarterly budget over the past year?

Chart type Common purpose

Bar chart (page 179) Viewing the changing composition of a value over a short period of time.

Line chart (page 244) Viewing the changing composition of a value over a long period of time.

Pie chart (page 327) Viewing the static composition of a value.

Chart types for viewing compositions
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Chart type Common purpose

Waterfall chart (page
382)

Viewing the static composition of a value with accumulation or
subtraction to the total.

Treemap (page 375) Viewing the static composition of a value's accumulation to the total.

Viewing distributions
Distribution charts are used to explore how the values within data are grouped. Distribution charts
show you the shape of your data, the range of its values, and possible outliers.

Questions that might be answered by distribution charts include: 

l What is the number of customers per age group?
l What cities have the highest use of our services?

Chart type Common purpose

Histogram (page 235) Viewing the how data is distributed over intervals.

Scatter plot (page 345) Viewing the distribution of two measures.

Distribution plot (page 216) Viewing the distribution of measure values in a dimension.

Box plot (page 195) Viewing the range and distribution of numerical data.

Chart types for viewing distributions

Viewing performances
Performance charts provide a quick view of a performance measure. Looking at a performance
chart, a user can quickly identify the measure value and whether the results are as expected or not.

Questions that might be answered by performance charts include:

l What are the current total sales for this quarter?
l Are current total sales for this quarter meeting the projected sales for the quarter?
l How is performance for this product line compared with other product lines?

Chart type Common purpose

Bullet chart (page 201) Comparing performance of a measure for several dimensions.

Gauge (page 231) Viewing a performance value to understand performance immediately.

KPI (page 239) Viewing one or two performance measures.

Text & image (page 371) Viewing text or several measures with an image.

Chart types for viewing performances
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Viewing data
Data charts present detailed data rather than a visualization of the data. Data charts are useful
when you need to view precise values, and when you want to compare individual values.

Questions that might be answered by data charts include:

l What are the records for each transaction for this month?
l What are the quantity and sales for each item in each product group for each of our

customers?

Chart type Common purpose

Table (page 353) Viewing precise values from your data without trends or patterns.

Pivot table (page 333) Viewing precise value for several dimensions and measures.

Chart types for viewing data

Viewing geography
Geographical charts let you visualize your data by geography, displaying your data on a map either
as points or areas.

Common questions that might be answered by geographical charts include:

l What cities have the highest use of our services?
l Which countries have the most customers?

Chart type Common purpose

Map chart (page 251) Viewing data represented geographically by point or area.

Chart types for viewing geography

What if no standard chart suits my purpose?
You can use controls or objects from a bundle supplied by Qlik:

l Dashboard bundle (page 411)
l Visualization bundle (page 447)

You can also create custom visualization objects if none of the standard charts provided fit your
requirements for visualizing your data.

For more information, see Creating a visualization using a custom object (page 597).
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3.4 Visualizations
You can use visualizations to present the data that is loaded into the app. For example,
you can use a bar chart to compare sales numbers for different regions, or use a table
to show precise values for the same data.

The selections you make in a visualization are reflected in all associated visualizations on all sheets.

Creating a visualization
You create visualizations from predefined charts or custom objects. You must be in Edit mode to
be able to add a visualization to the sheet.

1. Drag the visualization from the assets panel onto the sheet, or double-click the visualization.
2. Add dimensions and measures to the visualization. The number of dimensions and measures

that are required depends on which visualization you selected.
Dimensions determine how the data in a visualization is grouped. For example: total sales per
country or number of products per supplier. For more information, see Dimensions (page 99).
Measures are calculations used in visualizations, typically represented on the y-axis of a bar
chart or a column in a table. Measures are created from an expression composed of
aggregation functions, such as Sum or Max, combined with one or several fields. For more
information, see Measures (page 105).

3. Adjust the presentation, for example sorting, coloring, or labeling.

You can convert from one visualization type to another by dragging a new chart to a visualization on
a sheet.

For other methods of creating a visualization, see Creating and editing visualizations (page 555).

Reusing a visualization
If you have created a visualization that you want to reuse in other sheets of the app, you can save it
as a master visualization. You can only create master visualizations in an unpublished app. When
the app is published, all users can add the visualization to their own sheets, but not modify it.

Right-click on a visualization and select Add to master items to save it as a master
visualization.

You can find master visualizations under in the assets panel.

Which visualizations are available?
There are two basic types of visualizations available in the assets panel.

l Charts illustrate the data with visual elements like bars, lines, or points.
l Text-based visualizations presents data in text form, for example, tables or filters.
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There are dashboard objects available in the assets panel.

The best choice of chart type depends on the purpose of the visualization.

If the predefined visualizations does not fill your purpose, you can use a visualization extension.
You find them in the assets panel under .

Chart Icon Description

Bar chart The bar chart displays a bar for each
dimension value. The bar length corresponds
to its numerical measure value.

Box plot The box plot is suitable for comparing range
and distribution for groups of numerical data,
illustrated by a box with whiskers, and a
center line in the middle.

Bullet chart Bullet charts can be used to visualize and
compare performance of a measure to a
target value and to a qualitative scale, such
as poor, average, and good.

Combo chart The combo chart combines bars and lines in
the same chart. The bars and lines have
different axes to enable comparing
percentages and sums.

Distribution plot The distribution plot is suitable for comparing
range and distribution for groups of
numerical data. Data is plotted as value
points along an axis.

Gauge The gauge is used to display the value of a
single measure, lacking dimensions.

Histogram The histogram is suitable for visualizing
distribution of numerical data over a
continuous interval, or a certain time period.
The data is divided into bins.

Line chart The line chart displays data lines between
values. Line charts are often used to visualize
a trend in data over intervals of time.

Map The map is used to combine geospatial data
and measure values, such as the sales for a
region or a store.

Charts
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Chart Icon Description

Navigation menu The navigation menu adds a sheet navigation
options into your sheet.

Pie chart The pie chart shows the relation between a
single dimension and a single measure.

Scatter plot The scatter plot presents values from two
measures. This is useful when you want to
show data where each instance has two
numbers, for example, country (population
and population growth). An optional third
measure can be used and is then reflected in
the size of the bubbles. When showing large
data sets colors will be used instead of
bubble size to represent the measure size.

Treemap The treemap shows hierarchical data. A
treemap can show a large number of values
simultaneously within a limited space.

Waterfall chart The waterfall chart illustrates how an initial
value is affected by intermediate positive and
negative values.

Visualization
bundle (page 447)

The Visualization bundle is a set of charts
that can be used to enhance and increase
your Qlik Sense app's charting capacity.

Chart Icon Description

Filter pane The filter pane allows you to control what data
that is shown in the visualizations on a sheet. A
filter pane can filter the data of several
dimensions at once.

KPI The KPI is used to present central performance
figures. You can add a link to a sheet.

Pivot table The pivot table presents dimensions and
measures as rows and columns of a table. The
pivot table allows you to analyze data in
multiple dimensions at a time. The data in a
pivot table may be grouped based on a
combination of the dimensions, and partial
sums can be shown.

Text-based visualizations
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Chart Icon Description

Table The table displays values in record form, so that
each row of the table contains fields calculated
using measures. Typically, a table includes one
dimension and multiple measures.

Text & image You can use the text & image visualization to
add text, images, measures and links to a
webpage.

Object Icon Description

Button You can use buttons to add quick links for easy
selection and navigation in your app.

Container You can add visualizations in a limited space and
show or hide the visualizations inside the
container based on conditions.

Dashboard
bundle (page 411)

A set of controls that you can use to enhance
navigation and selection in your Qlik Sense app.

Dashboard objects

Bar chart
The bar chart is suitable for comparing multiple values. The dimension axis shows the
category items that are compared, and the measure axis shows the value for each
category item.
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In the image, the dimension values are different regions: Nordic, USA, Japan, UK, Spain, and
Germany. Each region represents a dimension value, and has a corresponding bar. The bar height
corresponds to the measure value (sales) for the different regions.

You can make more complex comparisons of data by using grouped or stacked bars. This requires
using two dimensions and one measure. The two example charts use the same two dimensions and
the same measure:

Grouped bars: With grouped bars, you can easily compare two or more items in the same
categorical group.
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Stacked bars: With stacked bars it is easier to compare the total quantity between different months.
Stacked bars combine bars of different groups on top of each other and the total height of the
resulting bar represents the combined result.

The bar chart can be displayed horizontally or vertically, as in the example below:

When to use it
Grouping and stacking bars makes it easy to visualize grouped data. The bar chart is also useful
when you want to compare values side by side, for example sales compared to forecast for
different years, and when the measures (in this case sales and forecast) are calculated using the
same unit.

Advantages: The bar chart is easy to read and understand. You get a good overview of values when
using bar charts.
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Disadvantages: The bar chart does not work so well with many dimension values due to the
limitation of the axis length. If the dimensions do not fit, you can scroll using the scroll bar, but then
you might not get the full picture.

Creating a bar chart
You can create a simple bar chart on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty bar chart to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field.

In a bar chart you need at least one measure.

You can include up to two dimensions and one measure, or one dimension and up to 15 measures in
a bar chart. Each bar corresponds to a dimension, and the values of the measures determine the
height or length of the bars.

You can also create a bar chart with no dimension and up to 15 measures. In this case, one bar is
displayed for every measure. The value of the measure determines the height or length of a bar.

Dimensions Measures Result

1 dimension 1 measure A simple bar chart with one bar for each dimension value.

2 dimensions 1 measure A grouped or a stacked bar chart with one bar for each value of
the two dimensions.

No dimension up to 15
measures

A simple bar chart with one bar for each measure.

1 dimension up to 15
measures

A grouped or a stacked bar chart with one bar for each value of
each measure.

Creating a bar chart

When you have created the bar chart, you may want to adjust its appearance and other settings in
the properties panel.

Styling the bar chart
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).
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Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Value labels: Style the labels which display the measure value for each dimension

value.
When using the Stacked presentation option, this setting controls Segment labels
(measure values for each dimension value) and Total labels (combines the measure
values for each dimension value).

l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.
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Customizing the bar segment outline and bar width
You can adjust the outline surrounding each bar segment in the chart, as well as the width of the
bars.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, under Outline, set the thickness and color of the
outlines.

4. Adjust the slider for Bar width to set the width of the bars.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Adding trend lines
You can add trend lines to the chart. Use trend lines to visualize how data changes over time.

For more information about trend lines, see Trend lines (page 110).

Do the following:

1. In the properties panel, expand the Data section.
2. Under Measures, expand the measure for which you are adding trend lines.
3. Under Trend lines, click Add trend line.
4. Define the Label and Type for the trend line.
5. Use the Colors slider to define Custom or Auto coloring.
6. Use the checkbox to toggle a Dashed appearance on or off.

Showing or hiding dimensions and measures depending on a condition
You can show or hide a dimension or measure depending on if a condition is true or false. This is
known as a show condition, and is entered as an expression. The dimension or measure is only
shown if the expression is evaluated as true. If this field is empty, the dimension or measure is
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always shown. Expand the dimension or measure in the Data section of the properties panel and
enter an expression under Show dimension if or Show measure if.

Custom tooltips are disabled for a bar chart if any of the dimensions in the chart are
using a show condition.

Let's say you have a dataset with the fields City, Manager, and Sales, among others. You could
configure your bar chart so that aggregated sales are displayed along a dimension called City. You
can add a second dimension, Manager, but only organize the data by this dimension if there are more
than three manager names associated with your sales data.

Do the following:

1. In edit mode, turn on the advanced options.
2. Drag a bar chart from the assets panel onto the sheet.
3. Add City as a dimension.
4. Add Manager as a second dimension from the properties panel.
5. Add Sum(Sales) as a measure.
6. In the properties panel, expand the dimension Manager. Under Show dimension if, add the

following expression:
Count(distinct Manager)>3

If your data only contains two manager names, the bar chart will not organize sales by manager,
since the expression is evaluated as false. If the data contains three or more unique Manager values,
sales will be organized by both City and Manager.

Display limitations

Displaying large numbers of dimension values
When the number of dimension values exceeds the width of the visualization, a mini chart with a
scroll bar is displayed. You can scroll by using the scroll bar in the mini chart, or, depending on your
device, by using the scroll wheel or by swiping with two fingers. When a large number of values are
used, the mini chart no longer displays all the values. Instead, a condensed version of the mini chart
(with the items in gray) displays an overview of the values, but the very low and the very high
values are still visible. 
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You can exchange the mini chart with a regular scrollbar, or hide it, with the Scrollbar
property.

Displaying out of range values
In the properties panel, under Appearance, you can set a limit for the measure axis range. Without a
limit, the range is automatically set to include the highest positive and lowest negative value, but if
you set a limit you may have values that exceed that limit. A bar that exceeds the limit will be cut
diagonally to show that it is out of range.

When a reference line is out of range, an arrow is displayed together with the number of reference
lines that are out of range.

Displaying large amounts of data in a stacked bar chart
When displaying large amounts of data in a stacked bar chart, there may be cases when not each
dimension value within a bar is displayed with correct color and size. These remaining values will
instead be displayed as a gray, striped area. The size and total value of the bar will still be correct,
but not all dimension values in the bar will be explicit.
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To remove the gray areas, you can either make a selection or use dimension limits in the properties
panel.

The approximate limit for how many stacked bars that can be displayed without gray areas is 5000
bars, assuming that each bar consists of 10 inner dimension values and one dimension value and
one measure value for the whole bar.

The initial data load is 500 dimension values or dimension stacks. (The value 500 refers to the outer
dimension values, not each dimension value in a stack.) When you have scrolled past those 500
values, an incremental load is performed, where values are instead loaded based on the current
view or scroll position.

Displaying large amounts of data in a bar chart with continuous scale
If the chart uses a continuous scale, a maximum of 2000 data points can be displayed. The actual
maximum number of data points in the chart is affected by the distribution of the data. Above that
number, data points are neither displayed, nor included in selections made in the chart. Additionally,
only twelve dimension values are displayed for the second dimension in a chart with two
dimensions and continuous scale.

To avoid displaying limited data sets, you can either make a selection or use dimension limits in the
properties panel.

Colors and legend
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.
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Stacked bar charts and number formatting by measure expression
Stacked bar charts ignore number formatting by measure expression and instead will always us the
default formatting to make it consistent with the formatting of totals.

Comparing categories against a measure with a bar chart
This example shows how to make a bar chart to visualize sales data and how to
compare different product groups against the same measure.

Dataset
In this example, we'll use two data files available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial, and the files are available in the Tutorials source folder:

l Sales.xls
l Item master.xls

To download the files, go to Tutorial - Building an App.

Add the two data files to an empty app and make sure that they are associated by Item Number.

The dataset that is loaded contains sales data. The Item master table holds the information about
the items ordered, such as product groups.

Measure
We use the sales volume as the measure, by creating a measure in Master items with the name
Sales, and the expression Sum(Sales).

Visualization
We add a bar chart to the sheet and set the following data properties:
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l Dimension: Product Group (product group).
l Measure: Sales; the measure that was created as a master item.

The following bar chart is created, with a bar showing the sales for each product group:

But we want to have some more detailed information about the product sales, by adding the
Product Sub Group as a dimension. The Product Sub Group field divides the product groups into
sub groups. By default, a grouped chart is selected when adding the second dimension. We want to
display a stacked chart instead, that is changed under Appearances in the properties panel.
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Discovery
The bar chart visualizes the sales volume of different product groups, divided into product sub
groups. The visualization is sorted in order of sales volume per product. You can hover the mouse
pointer over a product sub group and view the details.

In the bar chart we can see that Produce has the highest sales volume. One of the sub products
contribute to most of the Produce sales, if we hover over that part of the bar we can see it is Fresh
Vegetables.

Accumulating values over a dimension in a bar chart
This example shows how to use a bar chart to visualize sales data which accumulate
over a dimension.
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Dataset
In this example, we will use a data file available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial. The file is available in the Tutorials source folder: Sales.xls

To download the file, go to Tutorial - Building an App.

Add the data file to an empty app. The dataset that is loaded contains sales data.

Measure
We use the sales volume as the measure that we create in Master items:

l Sales with the expression Sum(Sales). This is the sum of the sales volume.

Visualization
We add a bar chart to the sheet and set the following data properties:

l Dimension: Month (Date.Month).
l Measure: Sales; the measure that was previously created.

The following bar chart is created, with a bar showing the sum of sales for each month.
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Accumulation
To have our sales data accumulate over one dimension, we need to apply a modifier to our Sales
measure.

Do the following:

l Under Measure: Sales set the Modifier to Accumulation. This will set the measure to
accumulate over one dimension.

Our bar chart becomes as follows, with the sales accumulating from one month to the next.
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We want to achieve a visual separation of the periods of time, by adding the Quarter as a second
dimension. The Quarter fieldgroups the month bars into larger groups. By default, a grouped chart
is selected when adding a second dimension.

Do the following:

1. Add Dimension: Quarter (Date.Quarter).
2. Under Measure: Sales set the Modifier>Dimension to Month. This sets the dimension over

which the accumulation will take place.

If Across all dimensions is turned on, the accumulation continues across all quarters.
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Notice how the bars of the previous two bar charts are the same.

If Across all dimensions is turned off, the accumulation starts again at the beginning of each
quarter. Our bar chart becomes as follows, with the sales accumulating from one month to the next,
inside each quarter.
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It is good practice to have the title of your charts represent their content. So consider changing the
title of your new bar chart to reflect that the bars are now an accumulation of sales.

Discovery
The bar chart visualizes the sales volume of each month, grouped into quarters. By having the sales
accumulate inside each quarter, we get a better understanding of the volume of sales for each
quarter. You can hover the mouse pointer over a month and view the details.

In the bar chart we can see that Q1 has the highest sales volume. We can also see that even though
Q4 had the lowest sales volume, the first two months of the quarter were better than the ones from
Q3.

Box plot
The box plot is suitable for comparing range and distribution for groups of numerical
data, illustrated by a box with whiskers, and a center line in the middle. The whiskers
represent high and low reference values for excluding outlier values.
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You can define the box start and end points, and whiskers ranges with a few different presets, or
define your own settings using expressions.

1. First whisker
2. Box start
3. Center line
4. Box end
5. Last whisker

You can hover over a box to display a popup showing the respective values of the box
plot elements.

When to use it
The box plot is suitable for comparing range and distribution for groups of numerical data.

Advantages: The box plot organizes large amounts of data, and visualizes outlier values.

Disadvantages: The box plot is not relevant for detailed analysis of the data as it deals with a
summary of the data distribution.

Creating a box plot
You can create a box plot on the sheet you are editing.

Create apps and visualizations - Qlik Sense, November 2024 196



3   Visualizations

In a box plot you need to use one or two dimensions, and one measure. If you use a single
dimension you will receive a single box visualization. If you use two dimensions, you will get one box
for each value of the second, or outer, dimension.

By default, the Standard (Tukey) preset is used.

You cannot use calculated dimensions in a box plot.

Do the following:

1. From the assets panel, drag an empty box plot to the sheet.
2. Add the first dimension.

This is the inner dimension, which defines a box.
3. Add a second dimension.

This is the outer dimension, which defines the boxes shown on the dimension axis.
4. Click Add measure and create a measure from a field. The measure does not have to contain

an aggregation.

When you have created the box plot, you may want to adjust its appearance and other settings in
the properties panel.

When you have created the bar chart, you may want to adjust its appearance and other settings in
the properties panel.

Styling the box plot
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Changing the definition of the box plot
You can use one of the three presets, found under Box plot elements in the properties panel, to
define your box plot.
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l Standard (Tukey)
This preset is based on the original box plot definition by J. Tukey. The center line represents
the median (second quartile), and the box start and end points represent the first and third
quartiles. Whisker length can be set to 1, 1.5 or 2 inter-quartile ranges. An inter-quartile range
represents the difference between the first and third quartiles.

l Percentile-based
This preset is also defined with the box start and end points representing the first and third
quartiles, and the center line representing the median, but the whisker length is adjusted by
setting a percentile based whisker position.

l Standard deviation
This preset is based on standard deviations, with the center line representing the average
value, and the box start and end points representing one standard deviation variance. You
can set the whisker length to a multiple of standard deviations.

You can also define a custom box plot where you set the value of each box plot element using an
expression.

Visualizing range and distribution of numerical data with a box plot
This example shows how to make a box plot to visualize range and distribution of
numerical data using daily temperature measurements.

Dataset
In this example, we'll use the following weather data.

l Location: Sweden > Gällivare Airport
l Date range: all data from 2010 to 2017
l Measurement: Average of the 24 hourly temperature observations in degrees Celsius
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The dataset that is loaded contains a daily average temperature measurement from a weather
station in the north of Sweden during the time period of 2010 to 2017.

Measure
We use the average temperature measurement in the dataset as the measure, by creating a
.measure in Master items with the name Temperature degrees Celsius, and the expression Avg

([Average of the 24 hourly temperature observations in degrees Celsius]).

Visualization
We add a box plot to the sheet and set the following data properties:

l Dimension: Date (date) and Year (year). The order is important; Date needs to be the first
dimension.

l Measure: Temperature degrees Celsius; the measure that was created as a master item.

In this example we use the default box plot preset, Standard (Tukey) with the whisker length 1.5
interquartile range.

Discovery
The box plot visualizes the distribution of the daily temperature measurements. The visualization is
sorted in mean temperature order. The mean temperature for each year is illustrated by the middle
line in each box. The box stretches from the first quartile to the third quartile, and the whiskers
stretch 1.5 inter-quartile ranges. There are also a number of outlier values, the points that are
placed outside the whiskers. You can hover the mouse pointer over an outlier point and view the
details.

In the box plot we can see that the year 2010 has the longest box and whiskers. That shows that the
year 2010 has the largest distribution of temperatures measured. It also seems to be the coldest
year in average.
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The range of 2017 is small, as the dataset only contains measurements from the first months of the
year.

Bullet chart
The bullet chart displays a gauge with extended options. Bullet charts can be used to
visualize and compare performance of a measure to a target value and to a qualitative
scale, such as poor, average, and good.

In a bullet chart you need one measure, which determines the length of the bar.

You can also add a dimension. This will show one gauge for every dimension value. If you do not
define a dimension, the chart will show a single gauge.

Example:

A bullet chart showing sales performance for each value of the dimension (quarter)

The example shows a bullet chart with sales performance for each quarter. It also shows the
performance relative to target and performance range, which are different for each quarter.

When to use it
Bullet charts let you compare and measure performance with more enriched information than a
common gauge. This is helpful when comparing performance according to a target and a simple
performance rating. For example: you can show how sales relate to a target value, and in context of
poor, good, and stretched performance.

Creating a bullet chart
You can create a bullet chart on the sheet you are editing.
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Do the following:

1. From the assets panel, drag an empty bullet chart to the sheet.
2. Click Add dimension to select the dimension that define how many gauges are shown.
3. Click the Add measure button to select the value measure of the chart that defines the

length of the bar.
Once the measure is selected the bullet chart is displayed with default settings. Each gauge
is displayed with an individual range. If you want to use a common range, you can set it with
Appearance>Y-axis>Common range.

4. To add a target value, click Target under the measure. You can define a fixed value or use a
measure with target values.

5. To add performance ranges, set Use segments under the measure to On.
Click Add limit to set a range limit for the segments. You can adjust the color of each
segment by clicking on it.
You can define a fixed limit value or an expression.

The bullet chart is now displayed with the dimension and measure you selected.

When you have created the bullet chart, you might want to adjust its appearance and other settings
in the properties panel.

Styling the bullet chart
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Value labels: Style the labels which display the measure value for each dimension

value.
Click the checkbox for Auto contrast color to automatically override the selected
color with the default color for the app's theme. This only applies to value labels inside
the bars or inside white rectangles outside the bars.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.
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Setting a target value
You can add a target value which is displayed as a marker line. If the measure contains sales
numbers, this could be budgeted sales for example.

You can define a fixed value or use a measure with target values.

Setting performance ranges
To add performance ranges, set Use segments under the measure to On.

You need to add the limits for the ranges you want to use for showing indicators with Add limit. You
can set a limit value in three ways.

l Use the slider.
l Type a value in the text box.
l Set an expression that returns the limit value.

Changing the color scheme
You can change color scheme of the value bar and the target by setting Appearance > Colors >
Colors to Custom. You can set single colors or use an expression.

It's a good idea to use a bar color that is visually dominant to the range colors.

When you have added the limits, you can select the color and the symbol of the indicator for each
defined range.

Adding a custom tooltip
You can add measures, charts, and images as tooltips. To add custom tooltips, select
Appearance>Tooltip>Custom.

l If you want to add a measure as a tooltip, you can add it from a field using From a field. You
can also use an expression to add a measure. Click to open the expression editor. The
existing expression is displayed by default. You can add a title and description to the tooltip.
You can change the label of the tooltip using Label as well as its formatting using Number
formatting.

l If you want to add a chart as a tooltip, select a master visualization from the list of Master
items.

l Set the size of the tooltip container. Qlik Sense fits the chart into the container.
o Small. Sets the width and height of the container to 140 pixels.
o Medium. Sets the width and height of the container to 200 pixels.
o Large. Sets the width and height of the container to 340 pixels.

After you add the chart, you can edit it by clicking Edit master item. See
Editing a master visualization (page 118).

Create apps and visualizations - Qlik Sense, November 2024 204



3   Visualizations

l If you want to add an image as a tooltip, choose whether to add an image from your Media
library or from a URL.

o Set the size of the tooltip container. Qlik Sense fits the image into the container.
o Small. Sets the width and height of the container to 50 pixels.
o Medium. Sets the width and height of the container to 200 pixels.
o Large. Sets the width and height of the container to 340 pixels.
o Original. Qlik Sense fits the image into the container. If the image is larger than

340 pixels, it is scaled down.
o Media library: Appears when you choose Media library for Type. Click to select an

image from your media library.
o URL: Appears when you choose URL for Type. Enter a URL.

Setting the scale of the axis
If you use a dimension to show several gauges, you can select how to show the scale of the axis
with Appearance>Y-axis>Common range.

l If you want each dimension gauge to use the same scale, enable Common range. If the
range measure depends on the dimension value, the range bars will have different lengths.
This is useful when you want to be able to compare the actual values.
You can also set a common axis for all gauges with Appearance>Y-axis>Common range.

l If you want each range bar to be equally long, disable Common range.
This is useful when you want to be able to compare the relative performance of each
dimension value.

Changing the orientation of the labels
To change the orientation of the chart's labels, the chart's presentation must be vertical. This can
be set with Appearance > Presentation > Vertical. Label orientation can then be selected with
Appearance > X-axis > Label orientation. The following orientations are available:

l Auto: Automatically selects one of the other options depending on the space available on the
chart.

l Horizontal: Labels are arranged in a single horizontal line.
l Tilted: Labels are stacked horizontally at an angle.
l Layered: Labels are staggered across two horizontal lines.

To view examples of label orientation, see X-axis and Y-axis (page 611).

Limitations
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.
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Combo chart
The combo chart is suitable for comparing two sets of measure values that are usually
hard to compare because of the differences in scale. It is basically a bar chart
combined with a line chart.

A typical example is when you have a bar chart with sales figures and want to combine these
figures with the margin values (in percent). In a regular bar chart, the bars for sales would be
displayed as usual, but the margin values would be almost invisible because of the very large
difference between the numeric values for sales and margin.
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A combo chart with the margin values (in percent) and bars with sales figures.

With a combo chart you can combine these values by, for example, using bars for the sales values
and a line for the margin values. By default, the bars have the measure axis on the left and the
margin values have a separate axis to the right. The two measures use the same dimension
(YearMonth).

If you have yet another measure, for example, gross sales, with values that are roughly in the same
range as the sales values, you can add the third measure as bars and either stack or group the new
measure values with the sales values. With grouped bars, you can easily compare two or more
items in the same categorical group. Stacked bars combine bars of different groups on top of each
other and the total height of the resulting bar represents the combined result.

Create apps and visualizations - Qlik Sense, November 2024 207



3   Visualizations

A combo chart with three measures; the margin values (in percent), bars with sales figures and the measure
Gross sales grouped with the sales values.

The combo chart can only be displayed vertically.

When to use it
With the possibility to have different measure scales, one to the left and one to the right, the combo
chart is ideal when you want to present measure values that are normally hard to combine because
of the significant difference in value ranges.

But a combo chart can also be quite useful when comparing values of the same value range. In the
image above, the combo chart only has one measure axis, but the relationship between the two
categories sales and cost is clear.

Advantages
The combo chart is the best choice when combining several measures of different value ranges.

Disadvantages
The combo chart only supports one dimension, and can therefore not be used when you need to
include two or more dimensions in the visualization.

Creating a combo chart
You can create a combo chart on the sheet you are editing. In a combo chart, you need at least one
dimension and one measure.
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Do the following:

1. From the assets panel, drag an empty combo chart to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field. Select to show

the measure as a bar.
4. Add another measure by selecting Add under Height of line. Enter an expression, or master

measure item, or a field with an aggregation function applied. By default a line will appear as
the measure.

5. When you are done adding measures, configure each measure to display as bars, lines, or
markers. For more information, see Configuring the presentation of measures (page 212).

You can only have one dimension, but you can continue adding up to 15 measures. You can only
have two measure axes though. This means, if you add three or more measures with a large
difference in value range it can be hard to display all measures with a good distribution of values.

When you have created the combo chart, you might want to adjust its appearance and other
settings in the properties panel.

Styling the combo chart
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the labels shown on the chart depends on how you configure the measure values to
be displayed, as well as other chart-specific settings and label display options. Configure a
measure to be shown as Bars, Line, or Marker by expanding the measure under Data > Measures,
and clicking More properties. Configure additional chart and label options under
Appearance > Presentation.

You can style the text that appears in the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, expand the Bars section. This section appears if any of the measures are
being displayed as bars.

5. Under Bar labels, style the labels for measure values configured as Bars. You can select the
font, font size, and color.
When using the Stacked presentation option, this setting controls Segment labels (measure
values for each dimension value) and Total labels (combines the measure values for each
dimension value).

6. Expand the Lines section of the Chart tab. This section appears if any of the measures are
being displayed as lines.

7. Under Point labels, style the labels for measure values configured as Line. You can select
the font, font size, and color.

8. On the Chart tab, expand the Markers section. This section appears if any of the measures
are being displayed as markers.

9. Under Marker labels, style the labels for measure values configured as Marker. You can
select the font, font size, and color.

10. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.
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Customizing the bar segment outline and bar width
If your combo chart contains measure data represented as bars, you can adjust the outline
surrounding each bar segment in the chart, as well as the width of the bars.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab, expand the Bars section.
4. Under Outline, set the thickness and color of the outlines.
5. Adjust the slider for Bar width to set the width of the bars.

Customizing the lines and data points
If your combo chart contains measure data represented as lines, you can customize the
appearance of the lines and data points in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab, expand the Lines section.
4. Under Data point size, adjust the slider to change the size of the data points in the chart.
5. Under Line options, adjust the line thickness, line type (solid or dashed), and line curve

(linear or monotone).

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Configuring grid line spacing
You can change the placement of grid lines on the chart. Select whether to show grid lines based on
the primary or secondary axis, and adjust the spacing. You can also turn off grid lines if desired.
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Do the following:

1. In the properties panel, expand the Appearance section.
2. Expand Appearance > Presentation.
3. Toggle Grid line spacing from Auto to Custom.
4. Use the drop down menu to select whether the grid lines are placed along the Primary axis

or Secondary axis.
Depending on the scale used by each axis, you might not notice any difference between
these settings.

5. Use the second drop down menu to select the spacing, or choose No lines to remove grid
lines.

Configuring the presentation of measures
Optionally, you can change the presentation of measures between bars, lines, or markers.
Additional options are also available.

Do the following:

1. In the properties panel, under Measures, select More Properties in a measure.
2. Choose the Presentation of the measure. You can:

l Change the presentation of measures between bars, lines, or markers. For markers
you can choose between several different shapes.

l Select drop-down options to switch between the Primary axis or the Secondary axis.

The primary axis is on the left side of the chart, and the secondary axis in
on the right side. Right and left axes are reversed if Right-to-left is turned
on in App settings.

Adding bar and marker labels
If any measures in the chart are configured as bars or markers, you can show or hide their value
labels. Bar and marker labels can be configured separately from one another.

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Presentation, do one or both of the following:

l Set Bar labels to Auto.
l Set Marker labels to Auto.

Adding segment and total labels
For combo charts with a specific configuration, you can add segment and total labels. Segment
labels show values for each measure segment in a chart. Total labels show values for an entire set
of measures arranged along a single axis.
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You can add segment and total labels if all of the following apply:

l Two or more measures on the same axis are configured as bars.
l The combo chart uses the Stacked presentation option. This setting is located under

Appearance > Presentation.

The Stacked presentation option becomes available when two or more measures
have the following settings under Data > More properties:

l The measures are configured as Bars.
l The measures appear on the same axis.

For more information, see Configuring the presentation of measures (page 212).

l Bar labels are set to Auto.

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Presentation, set Bar Labels to Auto.
3. Do one or both of the following:

l Set Segment labels to Auto.
l Set Total labels to Auto.

Display limitations

Displaying out of range values
In the properties panel, under Appearance, you can set a limit for the measure axis range. Without a
limit, the range is automatically set to include the highest positive and lowest negative value, but if
you set a limit you may have values that exceed that limit. A bar that exceeds the limit will be cut
diagonally to show that it is out of range. For a line data point value that is out of range, an arrow
indicates the direction of the value.

Displaying large amounts of data in a combo chart
If the chart uses a continuous scale, a maximum of 2000 data points can be displayed. The actual
maximum number of data points in the chart is affected by the distribution of the data. Above this
actual maximum number of data points, data points are neither displayed, nor included in selections
made in the chart.

To avoid displaying limited data sets, you can either make a selection or use dimension limits in the
properties panel.

Colors and legend
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.
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Comparing measures with a different scale using a combo chart
This example shows how to make a combo chart that visualizes sales data. You will
also compare different product groups against two measures with a different scale.

Dataset
In this example, we will use two data files from the Qlik Sense Tutorial - Building an App. To
download the files, go to Tutorial - Building an App. Download and unzip the tutorial, and find the
files in the Tutorials source folder:

l Sales.xls
l Item master.xls

Create a new app and add the two data files. Make sure that they are associated by Item Number.

The dataset that is loaded contains sales data. The Item master table holds the information about
the items ordered, such as product groups.

Measures
We need to create two measures in Master items:

l Sales volume: with the name Sales, and the expression Sum(Sales).
l Sales margin in percent: with the name Margin %, and the expression Avg(Margin/Sales)*100.

Visualization
We add a combo chart to the sheet and set the following data properties:

l Dimension: Product Group (product group).
l Measure: Sales (the master measure you created).
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The following chart is created, with a bar showing the sales for each product group. It is a bar chart
at this stage.

But we also want to show the sales margin, which has a different scale than the sales volume. Sales
volume is in the scale of millions, while the margin is a percentage between 0 and 100. If we add
margin as a bar next to sales volume, it would be too small to distinguish.

In the properties pane, go to Measures > Height of line. Use the drop down to add Margin % as a
measure.
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Discovery
The combo chart visualizes the sales volume and margin of different product groups. You can hover
the mouse pointer over a product group and view the details. The bars show the sales volume with
the scale to the left, and the line shows the margin with the scale to the right.

In the chart we can see that Produce and Canned Products have the highest sales volumes. Both
groups have a lower margin than most other product groups.

Some product groups with low sales volume, like Eggs and Seafood, have a significantly higher
margin.

Distribution plot
The distribution plot is suitable for comparing range and distribution for groups of
numerical data. Data is plotted as value points along an axis.

You can choose to display only the value points to see the distribution of values, a bounding box to
see the range of values, or a combination of both as shown here:
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When to use it
The distribution plot is suitable for comparing range and distribution for groups of numerical data.

Advantages
The distribution plot visualizes the distribution of data.

Disadvantages
The distribution plot is not relevant for detailed analysis of the data as it deals with a summary of
the data distribution.

Creating a distribution plot
You can create a distribution plot on the sheet you are editing.

In a distribution plot you need to use one or two dimensions, and one measure. If you use a single
dimension you will receive a single line visualization. If you use two dimensions, you will get one line
for each value of the second, or outer, dimension.

Do the following:

1. From the assets panel, drag an empty distribution plot to the sheet.
2. Add the first dimension.

This is the inner dimension, which defines the value points.
3. Add a second dimension.

This is the outer dimension, which defines the groups of value points shown on the
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dimension axis.
4. Click Add measure and create a measure from a field.
p Viewing the distribution of measure values in a dimension with a distribution plot (page 219)

When you have created the distribution plot, you might want to adjust its appearance and other
settings in the properties panel.

Styling the distribution plot
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Display limitations

Displaying large amounts of data in a distribution plot
When displaying large amounts of data in a distribution plot, the message "Currently showing a
limited data set." is shown to indicate that not all data is displayed.

l If the chart uses more than one dimension, 3000 data points are displayed.

Colors and legend
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.

Viewing the distribution of measure values in a dimension with a distribution
plot
This example shows how to make a distribution plot to view the distribution of measure
values in a dimension using weather data as an example.
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Dataset
In this example, we'll use the following weather data.

l Location: Sweden > Gällivare Airport
l Date range: all data from 2010 to 2017
l Measurement: Average of the 24 hourly temperature observations in degrees Celsius

The dataset that is loaded contains a daily average temperature measurement from a weather
station in the north of Sweden during the time period of 2010 to 2017.

Measure
We use the average temperature measurement in the dataset as the measure, by creating a
.measure in Master items with the name Temperature degrees Celsius, and the expression Avg

([Average of the 24 hourly temperature observations in degrees Celsius]).

Visualization
We add a distribution plot to the sheet and set the following data properties.

l Dimension: Date (date) and Year (year). The order is important, Date needs to be the first
dimension.

l Measure: Temperature degrees Celsius, the measure that was created as a master item.

Create apps and visualizations - Qlik Sense, November 2024 220



3   Visualizations

Distribution plot with the dimensions Date (date) and Year (year) and the measure Temperature degrees
Celsius.

Discovery
The distribution plot visualizes the distribution of the daily temperature measurements. The
visualization is sorted by year, and each point represents a temperature measurement.

In the visualization we can see that the year 2012 has the lowest extreme temperature
measurement, close -40 degrees Celsius. We can also see that the year 2016 seems to have the
largest distribution of temperature measurements. With this many points in the distribution plot, it
can be hard to spot clusters and outliers, but the year 2017 has two low temperature measurements
that stand out. You can hover the mouse pointer over a point and view the details.

Filter pane
You can add a filter pane to control what data that is shown in the visualizations on a
sheet. A filter pane can filter the data of several dimensions at once.

For example, if you have a chart of sales over time, you can use a filter pane to limit the data in the
chart to only show sales from a selected time period, from certain product categories, and from a
certain region.

When a dimension is added, it is placed to the right of the previous dimensions, or below,
depending on the available space. As long as there is enough space, the dimensions are displayed
as expanded lists. If there is not enough space, the dimensions that were added first are turned into
filter panes.
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Selections have been made in the dimensions Year, Quarter, and Month.

When to use it
With filter panes, you can easily make several selections to define your data set exactly like you
want it. With your well-defined data set, you can explore data of particular interest.

By using the selection menu options in the filter panes (select possible, select alternative, and
select excluded), you can make adjustments to the data set and compare the results with the
previous selection.

Advantages
Filter panes are good for making selections and defining data sets. But they also show the
relationship between different values, the associations. The green, white, and gray colors reflect
the data associations that exist - and that do not exist. And by analyzing those associations, you
can make new discoveries, for example, that a sales representative has too many customers, or
that a region lacks a sales representative.

Disadvantages
When the dimensions contain a very large amount of values, it may be hard to manage the data.
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Creating a filter pane
You can create a filter pane on the sheet you are editing.

In a filter pane you can use up to 1000 dimensions.

Do the following:

1. From the assets panel, drag an empty filter pane to the sheet.
2. Click Add dimension and select a dimension or a field.
3. If you want to add more dimensions, click Add dimension again.

When you have created the filter pane, you may want to adjust its appearance and other settings in
the properties panel:

l Styling the filter pane (page 223)
l Customizing individual listboxes in a filter pane (page 226)

If you double-click or drag a field or a dimension from the assets panel, a filter pane is
added to the sheet using the dimension. If you then double-click more dimensions, they
are automatically added to the new filter pane.

Styling the filter pane

You have a number of styling options available under Appearance in the properties panel.
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Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the Filter pane and Listboxes tabs. Settings on
the Filter pane tab applies styling for the filter pane and settings on the Listboxes tab applies
styling for all listboxes inside the filter pane.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles in
both Filter pane and Listboxes.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Filter pane tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Listboxes tab, set the font, emphasis style, font size and color for the following text
elements:

l Header: Style the text of the headers for the listboxes.
l Content: Style the text of the listbox values.

Click the checkbox for Auto contrast color to automatically override the selected
color with colors that have higher contrast with the selection state of the listbox value.

Customizing the background
You can customize the filter pane background, the background of the header area, as well as the
background of the listboxes. The filter pane and the listbox background can be set by color and
image, while the background of the header area can be set to a single color.

In the styling panel, you can configure background options.

Setting the filter pane background
The filter pane background of the chart includes the title area, as well as the filter pane itself, which
is partially covered by the listboxes.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Filter pane tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Setting the listbox background
You can style the background of the listboxes. This styling applies to all listboxes in the filter pane.

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Listboxes tab of the styling panel, you can select a background color (single color or
expression), and also set the background to an image from your media library.
When using a background image, you can adjust image sizing and position.

Coloring the selection states
Each selection state of a listbox value can be assigned a specific color. This coloring is applied to
the background of the listbox value.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Listboxes tab of the styling panel, under Selection state, set colors for each of the
selection states:

l Selected
l Alternative
l Excluded
l Selected excluded
l Possible

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Filter pane tab of the styling panel, under Border, adjust the Outline size to increase
or decrease the border lines around the chart.
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4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the Filter pane tab, select a shadow size and color. Select None to remove

the shadow.

Customizing individual listboxes in a filter pane
A filter pane can contain one or more listboxes to filter dimension values over specified fields. Add
fields to the filter pane, then re-arrange them in the properties panel in an order that meets your
preferences.

Each field in the filter pane has its own listbox, which shows the individual field values. Each listbox
in a filter pane can be customized with its own unique properties. To customize a listbox, you need
to turn on the Advanced options when editing the sheet.

Do the following:

1. Create a filter pane on a sheet.
2. Add a field to the filter pane to create a new listbox for that field.
3. In the properties panel, under Data, click the field you just added.

This expands the Listbox properties panel, where you can customize the design of the listbox.

Listbox properties panel for a single listbox in a filter pane.
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Configuring search options
In Listbox properties, you can choose whether or not users can search for individual field values in
each listbox within the filter pane. You can also switch the default Search mode from Normal to
Wildcard. Wildcard adds default wildcard symbols (*) to the search field.

Condensing information in the filter pane
There are multiple settings available in Listbox properties to help you customize how much space
each listbox occupies in the filter pane.

Enabling compact view
To remove space between each dimension value, select the Compact view checkbox under
Presentation.

Adjusting the collapse behavior
You can adjust whether the listbox is shown as expanded or collapsed in the filter pane. When a
listbox is collapsed, you can click to expand it temporarily to view and apply selections.

Regardless of the collapse behavior selected, the exact behavior of each listbox within a filter pane
depends on a number of factors. These include its configuration in relation to other listboxes in the
filter pane, and available space. For more information, see Display limitations (page 229).

To adjust the collapse behavior, select an option in the Collapse listbox drop down menu. This is
located under Presentation.The following options are available:

l Auto: The listbox automatically adjusts to be expanded or collapsed, based on available
space and configuration in relation to other listboxes in the filter pane. The listbox defaults to
this option.

l Always: The listbox always collapses. It might be placed inside the drop down menu for
additional dimensions.

l Never: The listbox never collapses. It might still be placed inside the drop down menu for
additional dimensions.

Changing selection behavior
You can adjust several different settings in Listbox properties to customize how selections are
made in the listbox.

Enabling checkbox mode
If you select Checkbox mode under Presentation in Listbox properties, the listbox switches to a
view where each dimension value is represented by a checkbox. In this mode, selections are made
by clicking the checkbox next to each item, rather than the default behavior allowing clicking and
dragging to select multiple values at once.

If you have applied Always one selected value for the field within the assets panel, radio buttons
are used instead of checkboxes. The functionality is the same.

Toggling selection toolbar
By default, a selection toolbar appears when you make selections in a listbox. This toolbar allows
you to explore other options for selections, as well as clear, cancel, or confirm the selections.
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In Listbox properties, the Show selection toolbar checkbox is checked by default. Clear this
checkbox if you want the toolbar not to appear above the listbox when you make selections.

If you toggle this setting off, selections are confirmed when you press Enter or click outside the
listbox.

Displaying dimension value frequencies
Under Presentation in Listbox properties, click the checkbox next to Histogram to display bars
underneath each dimension value to represent how frequently each value appears in the data.

Switching to grid layout
By default, a listbox for a field in a filter pane is set to show data in a single column. Alternatively,
you can show data in a grid layout. Under Presentation, in Listbox properties, switch the
parameter for Show data in from Single column to Grid.

In the grid layout, you can also configure how the data is ordered (by Row or Column), and
customize the maximum visible rows or columns in the grid.

Showing the frequency of values
You can show the frequency next to each value, either as an absolute number or as a percentage.
You select this by opening Listbox properties, expanding the Presentation section, and selecting
an option in Show frequency.

In some cases the frequency cannot be calculated and is displayed as -. One example of
this is for key fields.

Selections in filter panes
During analysis, you make selections in a filter pane listbox. Click a collapsed filter pane dimension
to open a selection listbox.

When you make a selection, it is reflected in the small bars at the bottom of each filter pane
dimension. Four states can be displayed in the bars: selected (green), possible (white), alternative
(light gray), and excluded (dark gray). Locked values are indicated by a lock icon. The details of the
selections are displayed in the selections bar, above the sheet. You can click an item to see the
details and change your selection.

You can customize the selection behavior for each individual listbox in a filter pane. For more
information, see Changing selection behavior (page 227).

Fields are filtered out from each dimension to be shown in the visualizations on the sheet.
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Making selections in filter pane lists
When there is space enough in a filter pane, the dimension values are displayed in a listbox. In
listboxes, you can click to select a single value or draw to select several values. On a touch device,
you can two-finger-tap in the listbox to select a range of values.

Germany, Japan, and Nordic selected in the Region filter pane.

The selections tool
The selections tool offers an option to get an overview of the fields and dimensions in an app. In the
selections tool you can make selections in all the fields and dimensions in the app, regardless of
whether they are used in the app or not.

During analysis, click to open selections view.

Selection locking and unlocking
In a filter pane, locked selections are indicated by a lock icon. You can lock and unlock selections in
the selections bar above the sheet.

Display limitations

Responsive design
The filter pane has a responsive design and renders as many dimensions as possible. When space
is limited, this could involve reducing the size of each dimension so that all dimensions are
displayed.

Example:

The following image shows a filter pane while it is being edited. Only three out of five dimensions
are displayed. There is an additional item below the displayed dimensions. When this is clicked, the
remaining dimensions are listed.

Filter pane in edit mode.

When you have finished editing the filter pane and enter analysis mode, you will see the filter pane
with all the dimensions displayed. If all items cannot be shown due to lack of space, click below
the displayed dimensions to view the remaining dimensions.
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Filter pane in analysis mode, with expanded drop down list showing additional dimensions.

Full screen view
In full screen view, the filter pane is maximized and displays as many dimensions as possible
expanded. When not all dimensions can be displayed expanded, the priority order is that the most
recently added dimensions are expanded to the right. You can change the priority order in the
properties panel, under Dimensions. Drag the dimensions to change the order.

Keyboard navigation
You can use your keyboard to navigate a filter pane. Use the arrow keys or the Tab key to alternate
between the different objects on the sheet. Once you have moved the focus to the filter pane, use
the Enter, Space and Esc keys to move the focus between the following levels:

l Entire filter pane
l Listboxes inside the filter pane
l Values inside each listbox

Keyboard
navigation

Description

Space or
Enter

Moves focus to the first listbox in the filter pane. Another key press brings the
focus to the first value inside that listbox.

If the focus is on a collapsed listbox, press Enter to open the listbox in a pop-
over.

Esc Moves focus back one level (from the values to the listbox to the filter pane
object).

Right arrow If the focus is on an individual listbox within the filter pane, the right arrow key
moves the focus to the next listbox on the right.

If the focus is on a value inside a listbox, the right arrow key moves to the next
value in the listbox.

Left arrow If the focus is on an individual listbox within the filter pane, the left arrow key
moves the focus to the next listbox on the left.

If the focus is on a value inside a listbox, the left arrow keymoves to the previous
value in the listbox.

Keyboard controls in filter panes
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Keyboard
navigation

Description

Up arrow If the focus is on an individual listbox within the filter pane, the up arrow key
moves the focus to the previous listbox (to the left, or above, the current listbox).

If the focus is on a value inside a listbox, the up arrow key moves to the previous
value in the listbox.

Down arrow If the focus is on an individual listbox within the filter pane, the down arrow key
moves the focus to the next listbox (to the right, or below, the current listbox).

If the focus is on a value inside a listbox, the down arrow key moves to the next
value in the listbox.

Gauge
The gauge shows a single measure value and visualizes how to interpret that value.
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When to use it
The gauge is often used to present KPIs, for example, on an executive dashboard, and together
with segmenting and color coding, it is an effective way of illustrating a performance result.

It is important to set relevant max and min values to support the interpretation of the value. You can
use a reference line to provide additional context.

Advantages
A gauge is easy to read and understand and gives an instant indication of the performance within
an area.

Disadvantages
The gauge is quite space-demanding in relation to the single value it visualizes.

Although visually compelling, the gauge is not always the best choice for presenting a single
measure value. Problems when deciding the max and min values can indicate that some other
visualization should be used.

If you only want to show a performance value, without a gauge, consider using a KPI instead.

Creating a gauge
You can create a gauge on the sheet you are editing. In a gauge you can only have one measure and
no dimensions.
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Do the following:

1. From the assets panel, drag an empty gauge to the sheet.
2. Click Add measure and select a measure or create a measure from a field.

When you have created the gauge, you may want to adjust its appearance and other settings in the
properties panel.

The following settings are used by default in a gauge:

l A radial gauge.
l A single (blue) color.
l Range limits: min (0), max (100).
l No segments.
l Label and title are displayed in medium scale.

For example, you can change the radial gauge to a bar, and use a color gradient.

Styling the gauge
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the labels and other titles on the chart depends on how it has been configured
outside of the styling panel. For a gauge, these display options can be configured in other areas the
Appearance section.

You can style the text that appears in the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font and font color for the following text elements:
l Axis title: Style the title for measure displayed in the gauge.
l Axis label: Style the labels for gauge's range limits.
l Value label: Style the label displaying the measure value.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.
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Display limitations
When a measure value is outside the range limits, an arrow indicates whether the measure value is
higher or lower than the range values.

Histogram
The histogram is suitable for visualizing distribution of numerical data over a
continuous interval, or a certain time period. The data is divided into bins, and each bar
in a histogram represents the tabulated frequency at each bin.
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When to use it
The histogram is suitable for visualizing distribution of numerical data over a continuous interval, or
a certain time period.

Advantages
The histogram organizes large amounts of data, and produces a visualization quickly, using a single
dimension.

Disadvantages
The histogram is not relevant for detailed analysis of the data as it deals with a summary of the data
distribution.

Creating a histogram
You can create a histogram on the sheet you are editing. You can only apply a single dimension to a
histogram. Histograms do not need a measure, as the frequency of the binned data is automatically
calculated.

Do the following:

1. From the assets panel, drag an empty histogram to the sheet.
2. Add the dimension to calculate the frequency on.

When you have created the histogram, you may want to adjust its appearance and other settings in
the properties panel.

Dimension limitations
There are some limitations to the dimension used in a histogram.

l The dimension must be a numerical field.
l You cannot use a master dimension that was created using the expression editor, even if the

resulting field is numeric.
l The dimension cannot be based on an aggregation function.

Styling the histogram
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Create apps and visualizations - Qlik Sense, November 2024 236



3   Visualizations

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Value label: Style the labels displaying the frequency value of each dimension value

bin.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Viewing the distribution of data over intervals with a histogram
This example shows how to make a histogram to the distribution of data over intervals,
using weather data.

Dataset
In this example, we'll use the following weather data.

l Location: Sweden > Gällivare Airport
l Date range: all data from 2010 to 2017
l Measurement: Average of the 24 hourly temperature observations in degrees Celsius

The dataset that is loaded contains a daily average temperature measurement from a weather
station in the north of Sweden during the time period of 2010 to 2017.

Visualization
We add a histogram to the sheet and add the field Average of the 24 hourly temperature
observations in degrees Celsius as dimension.

The visualization creates a frequency measure automatically, and sorts the temperature
measurements into a number of bars according to frequency distribution.
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We can adjust the size of the bars to get even intervals, by setting Bars to Custom and Bar width
(x-axis) with a width of 5. This adjusts the bars to be intervals of 5 degrees Celsius as shown
below:

Discovery
The histogram visualizes the frequency distribution of the temperature measurements. You can
hover the mouse over a bar to see more details of the frequency.

We can see that most days, the temperature is between -5 and 15 degrees Celsius. There are days
below -30, but they are not many.

KPI
The KPI visualization can show one or two measure values, and is used to track
performance.

A KPI visualization with two measure values, using conditional colors and symbols.
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When to use it
Use KPIs to get an overview of performance values that are central to an organization. Use color
coding and symbols to indicate how the figures relate to the expected results.

Advantages
KPIs give a quick understanding of the performance within an area.

Disadvantages
The KPI is somewhat limited when it comes to graphical components. You can use symbols to help
illustrate the performance, but if you want a more conspicuous component, consider using a gauge.

Creating a KPI
You can create a KPI visualization on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty KPI chart to the sheet.
2. Click Add measure and select a measure or create a measure from a field.

In a KPI visualization, you can have one or two measures and no dimensions. With two measures,
the second value automatically becomes a complementary value and is shown with a smaller font
size. You can easily switch their order by dragging the measures in the properties panel under
Measures.

When you have created the KPI visualization, you might want to adjust its appearance and other
settings in the properties panel.

The following settings are used by default in a KPI visualization:
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l Centered alignment.
l Black text color.
l No background color.
l Responsive layout behavior.
l Medium font size.
l No titles.
l Measure label displayed.
l Conditional colors and symbols are turned off.
l No link to sheet.

If you double-click or drag a measure from the assets panel, a KPI visualization is added
on the sheet using the measure.

Styling the KPI
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

In a KPI, you can style the text in the following components of the chart:

l Title area: Includes the chart title, subtitle, and footnote.
l Chart area: Includes measure titles and measure values.

Styling the title, subtitle, and footnote
You can customize the text displayed in the title area of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:
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l Title
l Subtitle
l Footnote

Styling the chart text
The data displayed in a KPI chart consists of text. The appearance of this text can be customized
separately from the title area.

You can set the text alignment for the chart. Choose between left-aligned, centered, or right-
aligned text.

You can also select between several layout behavior options. The layout behavior defines how the
size of the text adapts given the configured font size, chart size, and text length. The following
options are available:

l Responsive: You can adjust the font size, with additional text size adjustments applied
based on chart size and text length. Adjustments are made to fit all text content into the KPI.

l Fluid: You can adjust the font size, with additional text size adjustments applied based on
chart size only. This re-scaling of the text is independent of text length. If the text is too long,
an ellipsis is inserted at the end.

l Fixed: You can adjust the font size, but it does not automatically adapt to chart size or text
length. It remains at the same size regardless of changes to these components.

Additionally, you can show or hide each of the measure titles in the KPI, and set the font size for the
chart text.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Navigate to the Chart tab.
4. Under Alignment, set the text alignment. Choose between left, centered, or right alignment.
5. Under Layout behavior, adjust how text size adapts to chart size and text length. The

appearance of each setting depends on the Font size you set for the chart.
6. Under Show, select whether to show or hide each KPI title in the chart.
7. Under Font size, adjust the size of the text that displays the measure titles and values.

For further customization settings, you can set the Styling mode to Advanced options to style
each measure title and measure value individually.

Do the following:

1. In the Chart tab of the styling panel, under Styling mode, turn on Advanced options.
2. Under First measure title, configure the following settings:

l Set Show title on or off to display or hide the measure title.
l Style the text. Choose the font, emphasis style, font size, and color.
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3. Under First measure value, set the font, emphasis style, and font size.
4. Repeat the steps above to customize the Second measure title and Second measure value.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Using conditional colors and symbols
You can set your KPI visualization to display in different colors, and with different symbols,
depending on the value of the selected measure. Conditional colors and symbols can be configured
in the properties panel.

You can do this by adding multiple range limits to the KPI, creating subsections that indicate
performance. For example, you can set your KPI so that it displays in:

l Green with a check mark symbol when performance is strong.
l Yellow with a caution symbol when performance falls below expectations.
l Red with an X symbol when performance is low.

You can also set range limits with expressions, rather than defining a single value.
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Do the following:

1. In the properties panel for a KPI visualization, select Appearance and expand Color.
2. If necessary, turn off Library colors and turn on Conditional colors.
3. Click Add limit to create a new limit. Multiple limits can be added to a single KPI chart.
4. Specify a value for the limit, or enter an expression using the expression editor.
5. On the Value color bar, click the range area of the KPI you would like to modify.
6. Under Colors, select a preset color or use a custom color. Toggle, if needed, to Symbols to

choose the symbol displayed when your KPI falls within the specified limit.

Linking to another sheet
You can link from the KPI visualization to a sheet in the app. When making data analysis and clicking
the visualization, you can click a second time to go to a predefined sheet. The sheet is opened in a
new tab. When hovering over , the name of the sheet is displayed. The icon is only displayed
when Show title is selected, under Presentation.

Line chart
The line chart is used to show trends over time. The dimension is always on the x-axis,
and the measures are always on the y-axis.

Your data set must consist of at least two data points to draw a line. A data set with a single value is
displayed as a point.

If you have a data set where data is missing for a certain month, you have the following options for
showing the missing values:

l As gaps
l As connections
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l As zeros

When a month is not present at all in the data source, it is also excluded from the presentation.

When to use it
The line chart is primarily suitable when you want to visualize trends and movements over time,
where the dimension values are evenly spaced, such as months, quarters, or fiscal years.

Advantages
The line chart is easy to understand and gives an instant perception of trends.

Disadvantages
Using more than a few lines in a line chart makes the line chart cluttered and hard to interpret. For
this reason, avoid using more than two or three measures.

Creating a line chart
You can create a line chart on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty line chart to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field.

In a line chart you need at least one dimension and one measure.
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You can include up to two dimensions and one measure, or one dimension and up to 15 measures in
a line chart.

Dimensions Measures Result

1 dimension 1 measure A simple line chart with a single line.

2 dimensions 1 measure A line chart with the first dimension on the X-axis, and a line for
each value of the second dimension.

1 dimension up to 15
measures

A line chart with one line for each measure.

Creating a line chart

When you have created the line chart, you may want to adjust its appearance and other settings in
the properties panel.

Styling the line chart
You have a number of styling options available in the properties panel. Click Styling under
Appearance > Presentation to style the text, background, data point size, and lines at the chart
level (for the entire chart). The styling panel contains various sections under the General and Chart
tabs. You can reset your styles by clicking next to each section. Clicking Reset all resets
styles for all available tabs in the styling panel. Any customization you apply here overrides the
styling set in the app theme.

You can also set line styling options individually for each measure in the chart. These options are
available for each measure in the Data section of the properties panel. When you style an individual
measure, the settings you choose override both the chart-level settings and the app theme for that
specific measure only.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:
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l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Value label: Style the labels for the measure values that are configured as Lines.
l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the data points at the chart level
You can set the size of the data points. The settings defined here apply to all measures in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, under Data point size, adjust the slider to change the
size of the data points in the chart.

Customizing the measure lines at the chart level
You can customize the appearance of the lines in the chart. The settings defined here apply to all
measures in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Switch to the Chart tab of the styling panel.
4. In the Line options section, adjust the line thickness, line type (solid or dashed), and line

curve (linear or monotone).
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Styling each measure individually
Each measure line in the chart can be styled with separate settings. For each measure, you can
customize the data point size, line thickness, line type, and line curve.

Do the following:

1. In the properties panel, expand the Data section.
2. Click the measure you want to customize.
3. Under Styling, click Add.
4. Adjust the data point size, line thickness, line type (solid or dashed), and line curve (linear or

monotone).

Repeat these steps for each individual measure you need to customize separately from the app
theme or chart-level style settings.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Showing or hiding dimensions and measures depending on a condition
You can show or hide a dimension or measure depending on if a condition is true or false. This is
known as a show condition, and is entered as an expression. The dimension or measure is only
shown if the expression is evaluated as true. If this field is empty, the dimension or measure is
always shown. Expand the dimension or measure in the Data section of the properties panel and
enter an expression under Show dimension if or Show measure if.

Custom tooltips are disabled for a line chart if any of the dimensions in the chart are
using a show condition.

Let's say you have a dataset with the fields Sales, Quarter, Year, and Order Number, among others.
You could configure your chart so that sales are displayed along a time-based dimension for yearly
aggregations. You can add a second dimension for quarterly aggregations but only organize the
data by this dimension if the total number of orders received by your company has reached a target
goal of 100,000.
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Do the following:

1. In edit mode, turn on the advanced options.
2. Drag a line chart from the assets panel onto the sheet.
3. Add Quarter as a dimension.
4. Add Year as a second dimension from the properties panel.

Each distinct year in the data model becomes a separate line in the chart.
5. Add Sum(Sales) as a measure.
6. In the properties panel, expand the dimension Manager. Under Show dimension if, add the

following expression:
Count([Order Number])>100000

If your data contains 50,000 order records, the chart will not organize sales by quarter, since the
expression is evaluated as false. If the data contains 100,000 or more order records, sales will be
organized by both Year and Quarter.

Adding trend lines
You can add trend lines to the chart. Use trend lines to visualize how data changes over time.

For more information about trend lines, see Trend lines (page 110).

Do the following:

1. In the properties panel, expand the Data section.
2. Under Measures, expand the measure for which you are adding trend lines.
3. Under Trend lines, click Add trend line.
4. Define the Label and Type for the trend line.
5. Use the Colors slider to define Custom or Auto coloring.
6. Use the checkbox to toggle a Dashed appearance on or off.

Display limitations

Displaying large numbers of dimension values
When the number of dimension values exceeds the width of the visualization, a mini chart with a
scroll bar is displayed. You can scroll by using the scroll bar in the mini chart, or, depending on your
device, by using the scroll wheel or by swiping with two fingers. When a large number of values are
used, the mini chart no longer displays all the values. Instead, a condensed version of the mini chart
(with the items in gray) displays an overview of the values, but the very low and the very high
values are still visible.  Note that for line charts with two dimensions, the mini chart is only available
in stacked area mode.
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Line chart with a mini chart, since the dimension values exceeds the width of the visualization.

Displaying out of range values
In the properties panel, under Appearance, you can set a limit for the measure axis range. Without a
limit, the range is automatically set to include the highest positive and lowest negative value, but if
you set a limit you may have values that exceed that limit. When a data point value cannot be
displayed, due to the range limits, an arrow indicates the direction of the value.

When a reference line is out of range, an arrow is displayed together with the number of reference
lines that are out of range.

Displaying large amounts of data in a line chart
If the chart uses a continuous scale, you can set the maximum number of visible points and lines. In
the properties panel, go to Presentation. Then adjust the following:

l Max visible points: Set the maximum number of points that will be displayed. The default is
2,000. The maximum is 50,000. If you set a number less than 1,000, the line chart will behave
as if the maximum is 1,000 visible points. The actual maximum number of data points in the
chart is affected by the distribution of the data, and could be lower than the value you
configure with this setting. When there are more data points than the value you have set,
data points are neither displayed, nor included in selections made in the chart.

l Max visible lines: Set the maximum number of lines that will be displayed. The default is 12.
The maximum is 1,000.

If there are more data points than the number set in Max visible points, you will not see any points,
only lines. If there are more than 5,000 visible points, then labels will not be shown. If you have a
large number of lines, not all lines will be displayed, or lines may overlap.

If you have a large number of points or lines, it may take your chart longer to render when you zoom
or pan. You cannot make selections when the line chart is rendering.
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A line chart with a large data set. This chart is set to display 50 lines, and 20,000 data points.

To avoid displaying limited data sets, you can either make a selection or use dimension limits in the
properties panel.

Colors and legend
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.

Map chart
Maps enable you to view your data geographically.

Maps have many ways to present your data. You can add multiple layers to your map to display
different types of information on the same map. You can set a custom scope for locations so that if
two locations have the same name, you display the locations and their data correctly. You can use
drill-down dimensions to create a hierarchy of geographic areas for selection. You can limit the pan
of a map to a specific view and scope of the map, such as a region of interest, out of which users
cannot pan or zoom out. You can add custom base maps to your map and use non-WGS-84
coordinates.
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Map with density layer displaying number of global volcanic eruptions.

When to use maps
You can use a map to show the geographical distribution of offices, stores, and other sites of
business interest. You can visualize not only locations but also sales values and other measures and
display the value differences by bubble size or color.

Advantages
The map is a versatile visualization that efficiently presents the geographical distribution of key
values related to location or area.

Disadvantages
With a large number of values, it may be hard to get a good overview. Values may be placed on top
of each other and not visible until zoomed in.

Server connection requirements
In order for a Qlik Sense map chart to be able to perform location lookup and show a background
map (base map and layers), your web browser needs to be able to establish a connection with both
of the following servers on port 443 (HTTPS):

l maps.qlikcloud.com (required for location lookups and background map)
l ibasemaps-api.arcgis.com (required for Satellite base map)

For more information, refer to the Map service connection requirements on Ports used by user web
browser.

If you are instead using an on-premise GeoAnalytics server, your map chart will not need access to
maps.qlikcloud.com and can function without an internet connection. However, in this setup, the
Satellite base map will not be displayed as it requires a connection with ibasemaps-api.arcgis.com.
For more information, see Using GeoAnalytics with Qlik Sense map.
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Base map
The base map provides the background for the data contained in your layers. You can select your
base map in Map settings. Qlik Sense has four default base maps:

l Default: An OpenStreetMap-based map.
l Pale: A paler version of Default.
l Dark: A darker version of Default.
l Satellite: A satellite image map.
l None: No base map.

As of December 7, 2021 the map tile service used by Qlik Sense for satellite base maps
changed from services.arcgisonline.com to ibasemaps-api.arcgis.com. If your maps are
not functioning as expected, contact your Qlik administrator. They might need to allow
this new service.

Additionally, custom base maps can be added using background layers to add your own custom
base maps. For example, you could add the floor plan of an airport or office as a custom base map.

Layers
Layers contain visualized dimension and measure data that is displayed over your map. You can
stack layers on top of each other. You can also control at what zoom levels different layers appear
in or have layers that appear only if other values in a drill-down dimension are selected. This
enables you to create different levels of detail as you make selections and zoom in and out of areas
of interest on your map. The following layers are available:

l Point layer: A point layer overlays individual locations on a map, representing them with
shapes.
Point layers (page 258)

l Area layer: An area layer presents areas on your map, such as countries or states. With
polygon geometry loaded into a field, it can present any custom area.
Area layers (page 260)

l Line layer: A line layer enables you to display lines between points on your map.
Line layers (page 261)

l Density layer: A density layer enables you to visualize the density of points in an area using a
color ramp.
Density layers (page 264)

l Chart layer: A chart layer enables you to display small pie charts or bar charts over locations
in your map.
Chart layers (page 266)

l Background layer: Background layers enable you to display a custom base map for your
map visualization.
Background layers (page 268)
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Layers that use drill-down dimensions can be used to create drill-down layers. Drill-down layers
enable you to drill-down different hierarchical dimensions in a single layer or in multiple layers. You
could, for example, switch between area and point layers as selections are made. For more
information, see Drill-down layers (page 271). For an example map that uses drill-down dimensions
and layers, see Controlling visible map data with drill-down layers (page 272).

Location data for map layers
Maps support several ways for determining locations in a layer. You can use the dimension added
to the layer. You can alternatively specify fields containing location data for the layer, if the layer
dimension does not contain geographic data. In the Location properties, you can specify additional
parameters for the location field, such as adding additional fields that include country or
administrative area information. For example, if you have a field containing custom area geometries
and a field containing the names of the custom areas, you can set the name field as the dimension
and then set the area geometry field as the location field in Location in the map properties.

Locations can be either geometries or names of locations such as names of countries, regions,
cities, postal codes etc. Layer locations can be defined using fields that contain names and codes.
Qlik Sense can identify the following types of locations: 

l Continent names
l Country names
l ISO alpha 2 country codes
l ISO alpha 3 country codes
l First-order administrative area names, such as a state or province names
l Second-order administrative area names
l Third-order administrative area names
l Fourth-order administrative area names
l Postal codes or ZIP Codes
l City, village, or other populated place names
l IATA airport codes
l ICAO airport codes

Availability of locations may vary by country. If the named location is not available, use
coordinate or area data for the location.

Qlik Sense uses map and location data obtained from recognized field leaders who use
accepted methodologies and best practices in marking borders and naming countries
within their mappings. Qlik Sense provides flexibility to enable users to integrate their
own, separate background maps. If the standard maps do not fit, Qlik Sense offers the
option to load customer provided background maps, borders, and areas.

Create apps and visualizations - Qlik Sense, November 2024 254



3   Visualizations

Geometries can either be added at load time by the data preparation service or loaded from
geographic sources such as KML. Point layers also support latitudes and longitudes in separate
fields. For area layers, areas can be defined using geometries from a geographic data source such
as KML files. Line layers support the same point data as point layers. Line layers also support
strings with line geometries in GeoJSONLineString or MultiLineString formats.

If you are using a custom map in a background layer that uses non-WGS-84 coordinates, you can
use a field with locations defined in the coordinate system the map uses (either degrees or meters).
For more information, see Using non-WGS-84 coordinate systems (page 258).

Creating maps
You can add a map to the sheet you are editing.

You can create several map visualizations based on different point data or area data,
which use the same dimension data.

Do the following:

1. From the assets panel, drag an empty map to the sheet.
2. From Map settings, select the Base map.
3. From Layers in the properties panel, add layers to your map.

Layers are placed above layers of the same type. You can set the order of layers by dragging
layers up and down in the list. The layer at the top of your list is also overlaid on top of the
other layers on your map.
For information on configuring layers, see:

l Point layers (page 258)
l Area layers (page 260)
l Line layers (page 261)
l Density layers (page 264)
l Chart layers (page 266)
l Background layers (page 268)

Once the map is created, you can adjust its appearance and other settings for the map and its
layers in the properties panel.

will appear in the top-left corner of your map if there is an issue with the added layer.
Click the icon to see the error message.

Styling the map
There are options available in the properties panel for styling the text in the map chart.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).
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Customizing the text in the title area
Click Styling under Appearance > Presentation to customize the styling of the chart's title area

(title, subtitle, and footnote). You can reset your styles by clicking next to each section. Clicking
Reset all resets styles for all available tabs in the styling panel.

You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

You can style the text of the title information for the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the text in the map layer labels
The font, font size, and text color for the layers of individual layers can be customized. You can
style the text for the following types of map layers:

l Area layers
l Point layers
l Line layers
l Chart layers

Do the following:

1. Under Layers in the properties panel, click the layer for which you want to style the text.
2. Under Options > General, toggle on the Show label setting.
3. Use the options under Label font family to change the font for the layer labels.
4. Use the options under Label font size to adjust the text size of the layer labels.
5. Select a color for the label text under Label font color.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

Create apps and visualizations - Qlik Sense, November 2024 256



3   Visualizations

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limiting location scope in map layers
By default, Qlik Sense searches a broad scope of locations for the location field when names are
used. In cases where there are multiple possible matches, you may need to limit the scope of
locations searched to ensure Qlik Sense displays the desired location.

Do the following:

1. From Layers in the properties panel, click Location.
2. Set Scope for location to Custom.
3. After Location type, select the type of data contained in the field or expression selected as

Location field.
4. Optionally, after Country, enter a field, expression, or text indicating the country the

locations in the Location field are located.
5. Optionally, after Administrative area (Level 1), enter a field, expression, or text indicating

the first-level administrative area the locations in the Location field are located.
6. Optionally, after Administrative area (Level 2), enter a field, expression, or text indicating

the second-level administrative area the locations in the Location field are located.

Limiting panning in your map
You can limit the panning settings in your map to keep the view in your map limited to a set area,
such as a specific region of interest. When you limit the panning in a map, you lock the map to the
current view. The map will not zoom out further than the current view. You cannot pan the map
beyond the limits of the current view. If you zoom in, you can pan, but you are limited by the
boundaries of the pan limit.

Do the following:

1. From the properties panel, click Appearance.
2. In Presentation, set Limit pan navigation to Custom.
3. Set your map to the view you want to which you want to limit the pan.
4. Click Set pan limit.

You can toggle the set pan limit on and off with Limit pan navigation. You can clear the saved pan
limit by clicking Clear pan limit.
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Using non-WGS-84 coordinate systems
If you have data and a background map in a projection other than WGS-84, you should set the base
map to None, add your background map as a background layer, and then set your projection to use
undefined degrees or meters depending on the unit of length used in your base map.

When using non-WGS-84 coordinates, you must use geometries loaded into a field. Location names
cannot be used.

Do the following:

1. From the properties panel, click Map settings.
2. In Base map, select Empty (undefined degrees) or Empty (undefined meters).
3. Select Background layer.
4. After URL, enter the URL to a slippy map server.

For example, http://a.tile.opencyclemap.org/cycle/${z}/${x}/${y}.png .
5. After Attribution, enter the attribution string for the map.

For example, &copy; <a href='http://www.opencyclemap.org/' target='_
blank'>OpenCycleMap</a>. Map data &copy; <a
href='http://www.openstreetmap.org/copyright' target='_blank'>OpenStreetMap</a>
contributors.

6. From Layers, click Add layer.
7. Select your layer type.
8. In Dimensions, click Add and select a field containing data in your map's coordinate system.

Limitations
The map chart is not navigable with keyboard navigation. When creating accessible apps, consider
using alternative ways of presenting your geographic data.

Point layers
A point layer overlays individual locations on a map, representing them with shapes.
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By default, point layers use circular bubbles, but you can also use several other shapes. You can
also use custom images as the points in a point layer. The size of the points in your layer can be
fixed or you can specify a measure or expression to set the sizes of the different points. You can
highlight these differences in values further by coloring by measure.

Map with point layer displaying cities in Atlantic Canada colored and sized by population.
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Adding a point layer

Do the following:

1. Drag and drop a field onto the map, select Add as new layer, and select Add as point layer.
2. From Layers in the properties panel, click Add layer and select Point layer. In Dimensions,

click Add and select a field containing point data to use as the dimension.
3. If there are issues with the point locations, adjust the location settings in Locations in the

properties panel.
For more information, see Limiting location scope in map layers (page 257).

Once the layer is added, you can adjust settings for the layer in the properties panel.

Area layers
An area layer presents areas on your map, such as countries or states. With polygon
geometry loaded into a field, it can present any custom area.

With an area layer, each dimension value corresponds to a presented area. By using colors with
your area layer, you can present different measure values for the areas. In the properties panel,
under Appearance > Colors and legend, switch Colors to Custom where the options By measure
and By expression are available.
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Map with area layer displaying Australian states and territories colored by population.

Adding an area layer

Do the following:

1. Do one of the following:
l Drag and drop a field onto the map, select Add as new layer, and select Add as area

layer.
l From Layers in the properties panel, click Add layer and select Area layer. In

Dimensions, click Add and select a field containing area data to use as the dimension.
2. If there are issues with the point locations, adjust the location settings in Locations in the

properties panel.
Limiting location scope in map layers (page 257)

Once the layer is added, you can adjust settings for the layer in the properties panel.

Line layers
A line layer enables you to display lines between points on your map.
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For example, you can use a line layer to show aircraft flights between cities. With a line layer, you
can use two fields containing point data to define the start points and end points for lines in the
layer. Alternatively, you can use a field containing line geometry in either GeoJSON LineString or
MultiLineString format. You can customize the width and curvature of lines in the line layer and add
directional arrows to your lines.
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Map with line layer displaying departing flights between airports in Europe.

Adding a line layer
Line layers display lines using either start and end points, where two fields are used to determine
where lines start and end, or using line geometries in GeoJSONLineString or MultiLineString format.

If you are using a start and end point line layer, the dimension you select for your line layer should
represent the fields selected as the start and end points in your Location settings. For example, if
you wanted to visualize where your shipments are being sent, you could set Shipments as the
dimension and then use Distribution Center Location and Shipping Destination as the start point
and end point in Location.

Alternatively, you can add two dimensions to the line layer and use these as the start and end
points. This is useful if you want to display lines between all locations in the first dimensions to all
locations in the second dimension, which has an association to the first dimension.

Adding a line layer with start and end points

Do the following:

1. Do one of the following:
l Drag and drop a field containing start point data onto the map, select Add as new

layer, and select Add as line layer.
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l From Layers in the properties panel, click Add layer and select Line layer. In
Dimensions, click Add and select a field to use as the dimension.

2. If your dimension contains start point data, add a field containing end point data. Do one of
the following: 

l Drag and drop a field containing end point data onto the map, select Use in <layer
name>, and select Add <field name> as a second dimension.

l In Data, click Add and select a field containing end point data.
3. If your dimension does not contain start or end point data, in Location, add the fields

containing the start point data and end point data as location fields.
4. If there are issues with the start and end point locations, adjust the location settings in

Location in the properties panel.
Line layers using start point field and end point fields each have separate location settings in
Location.
For more information, see Limiting location scope in map layers (page 257).

Once the layer is added, you can adjust settings for the layer in the properties panel.

Adding a line layer with line geometries

Do the following:

1. Do one of the following:
l Drag and drop a field containing line geometries onto the map, select Add as new

layer, and select Add as line layer.
l From Layers in the properties panel, click Add layer and select Line layer. In

Dimensions, click Add and select a field to use as the dimension.
2. In Location, select Line geometry and then select a field in Line geometry field.

By default, your dimension is selected as the Line geometry field.

Once the layer is added, you can adjust settings for the layer in the properties panel.

Density layers
A density layer enables you to visualize the density of points in an area using a color
ramp.
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Each point influences a circular area, with the highest influence at the center and declining towards
its outer perimeter. You can specify the influence radius of the points, change its color and scale it
to suit your visualization. Density layers can be used to show hotspots of activity, population
densities and more.

Map with density layer displaying number of global volcanic eruptions.
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Adding a density layer

Do the following:

1. Do one of the following:
l Drag and drop a field containing point data onto the map, select Add as new layer,

and select Add as density layer.
l From Layers in the properties panel, click Add layer and select Density layer. In

Dimensions, click Add and select a field containing point data to use as the
dimension.

2. If there are issues with the point locations, adjust the location settings in Locations in the
properties panel.
For more information, see Limiting location scope in map layers (page 257).

Once the layer is added, you can adjust settings for the layer in the properties panel. .

Chart layers
A chart layer enables you to display small pie charts or bar charts over locations in your
map. It uses one dimension to identify the locations and a second dimension to create
the pie or bar charts.

You can label the charts and use an expression to control their size. The info bubble displays useful
information about the contents of the selected chart.
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Map with chart layer displaying source of funds in European Union countries as pie charts. The size of each
pie chart shows average absorption rate of funds.

Adding a chart layer

Do the following:

1. Do one of the following:
l Drag and drop a field containing point data onto the map, select Add as new layer,

and select Add as chart layer.
l From Layers in the properties panel, click Add layer and select Chart layer.

2. In Dimensions, under Location, click Add and select a field containing point data to use as
the locations on your map. Click Add and select a field containing data to use as the
dimension on your charts.

3. In Measures, click Add and select a field containing data to use as the measure on your
charts.

4. If there are issues with the point locations, adjust the location settings in Location in the
properties panel.
Limiting location scope in map layers (page 257)

Once the layer is added, you can adjust settings for the layer in the properties panel.
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Background layers
Background layers enable you to display a custom base map for your map visualization.

A background layer could, for example, be a map of an airport that then has a point layer with
WIFI hotspot locations overlaid on it. If the custom base map format supports transparency, you can
overlay it on top of another map. Qlik Sense supports the following custom maps formats as
background layers:

l Slippy or tile map services (TMS)
l Web Map Service (WMS)
l Image URL (Image)

Maps services must be located on their own server. Unlike other layers, the background layer uses
no dimensions or measures and only displays an external base map.

If your WMS contains areas with no data, you can set the areas with no data to be transparent. This
enables the WMS background layer to be overlaid on another base map or background layer. You
can also choose which WMS layers to include in the background layer.

You can insert an image as a background layer. This can be used as a custom base map. You could
add an image of a floor plan and use it as a custom base map. An image background layer can also
be overlaid on top of another background layer. For example, you could insert an image of a
detailed local map as a background layer over top another map. Background layers support the
following image types:

l .png
l .jpg
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l .jpeg
l .gif

Map with background layer displaying a TMS OpenStreetMap map.

Adding a background layer
Background layer configuration varies depending on the type of background map.

Adding a TMS background layer

Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Background layer.
3. After Format, select TMS.
4. After URL, enter the URL to a tile or slippy map server.

For example, http://a.tile.opencyclemap.org/cycle/${z}/${x}/${y}.png.
5. After Attribution, enter the attribution string for the map.

For example, &copy; <a href='http://www.opencyclemap.org/' target='_
blank'>OpenCycleMap</a>. Map data &copy; <a
href='http://www.openstreetmap.org/copyright' target='_blank'>OpenStreetMap</a>
contributors.

Once the layer is added, you can adjust settings for the layer in the properties panel.
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Adding a WMS background layer

Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Background layer.
3. Under Format, select WMS.
4. Click WMS setup.
5. Under WMS server URL, enter the URL.
6. Under Version, select the WMS version.
7. Click Load WMS.
8. After CRS, enter the coordinate reference system used by the WMS map.
9. Select Transparent to generate map images that are transparent where there is not data.

This is not supported by all WMS.

10. Under Image format, select the WMS image format.
11. Under Layers, select the map layers that your WMS server supports.
12. Click Save.
13. After Attribution, enter the attribution string for the map.

For example, &copy; <a href='http://www.opencyclemap.org/' target='_
blank'>OpenCycleMap</a>. Map data &copy; <a
href='http://www.openstreetmap.org/copyright' target='_blank'>OpenStreetMap</a>
contributors.

Once the layer is added, you can adjust settings for the layer in the properties panel.

Adding an image background layer
Images can be used as a custom base map, such as for floor plans. When using an image
background layer as a custom base map, set Base map in Map settings to None. Select Undefined
meters or Undefined degrees as the projection. The location data for your other layers must use
same coordinate system as this background layer.

When you add an image background layer for a smaller geographic area as a custom
base map, add a layer containing data, such as a point layer, at the same time. This lets
the map automatically zoom in to the position of your image background layer.

The lowest unit in the scale bar is 10 meters. If this measurement is too large for your
image, you can disable the scale bar in Presentation and then proportionally adjust up
your image in the background layer to the scale you want. Scale the location data you
want to use in other layers as well.
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Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Background layer.
3. Under Format, select Image.
4. After URL, enter the URL of the image.
5. Position your image by entering the coordinates for the top left and bottom right corners of

the image.
Coordinates must be in the same coordinate type as was selected in Projection.

If you are unsure of the coordinates in your image background layer, enable Show
debug info. This will display the coordinates for the current center of your map.

6. After Attribution, enter the attribution string for the image.
For example, &copy; <a href='http://www.opencyclemap.org/' target='_
blank'>OpenCycleMap</a>. Map data &copy; <a
href='http://www.openstreetmap.org/copyright' target='_blank'>OpenStreetMap</a>
contributors.

Once the layer is added, you can adjust settings for the layer in the properties panel. For image
background layers being used as custom base maps, it is recommended that you change the Limit
zoom levels and Limit pan navigation settings to set the focus on your custom map.

Drill-down layers
When creating a map that has multiple points of data located in a wide geographical
area, you can use drill-down dimensions to display your layers in a selection hierarchy.

This enables you to use different layers at different levels within your map, ensuring only the most
relevant information is being displayed.

As you make selections in a drill-down layer, the dimension used for locations changes to the next
dimension in the drill-down dimension. The drill-down happens across layers that use the same
drill-down dimension. If you have an area and point layer that use the same drill-down dimension,
you can set which layer displays with which dimension from the drill-down dimension.

If selections cause the current drill-down dimension field to have only one possible
value, the next field in the list is used instead.

Drill-down dimensions used for drill-down layers should have the fields in order of highest
geographical area to smallest geographical area.

For information on creating drill-down dimensions, see Creating a drill-down dimension (page 121).
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Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Point layer, Area layer, Line layer, Density layer, or Chart layer.
3. Click Dimensions, click Add and select your drill-down dimension.
4. In your layer, click Options.
5. Click Layer display.
6. After Visible drill-down levels, select which dimensions to display in the layer.

Controlling visible map data with drill-down layers
This example will show you how to build a map with a top-level area layer that drills
down into with two point layers.

When creating a map that has multiple points of data located in a wide geographical area, you can
use drill-down dimensions to display your layers in a hierarchy. As users make selections in a layer,
the dimension displayed in the layer changes to the next dimension in the drill-down dimension.
This enables you to use display data at different selection levels within your map, ensuring only the
most relevant information is being displayed.

We have a list of all historical sites in the United States National Park Service's National Register of
Historic places. When we add the cities that historical sites are located in to a map as a point layer,
we get accurate locations for our bubbles. It could be made more understandable with better
organization, however.
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How then can we organize this information better, especially if we also want to add in another point
layer containing airports to help plan how to get to the different sites?

To solve this problem, we will create a map of the United States of America with a layer of states
that drills down to the county level. Drilling down to the county level will also show the cities that
contain the historical sites as data points, as well as all airports for that state and the surrounding
states.
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Dataset
This example uses two sets of data:

l Federal listings: National Register of Historic Places listed properties from federal agencies
(federal_listed_20190404.xlsx)
This data set is available from the National Park Service National Register of Historic Places.
It contains data about all registered history places, their location, and the federal agencies
associated to them.
≤ federal_listed_20190404.xlsx.

l Airport data
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This table contains data for airports in the United States. It consists of each airport's
International Air Transport Association (IATA) code, city, and state or territory.
You must import this data into Qlik Sense either by adding to a spreadsheet that you then
import into Qlik Sense or by importing the table from this help page as a web file.
Airport data

Airport AirportCity AirportState

ABE Allentown/Bethlehem/Easton, PA PA

ABI Abilene, TX TX

ABQ Albuquerque, NM NM

ABR Aberdeen, SD SD

ABY Albany, GA GA

ACT Waco, TX TX

ACV Arcata/Eureka, CA CA

ADK Adak Island, AK AK

ADQ Kodiak, AK AK

AEX Alexandria, LA LA

AGS Augusta, GA GA

ALB Albany, NY NY

ALO Waterloo, IA IA

AMA Amarillo, TX TX

ANC Anchorage, AK AK

APN Alpena, MI MI

ART Watertown, NY NY

ASE Aspen, CO CO

ATL Atlanta, GA GA

ATW Appleton, WI WI

AUS Austin, TX TX

AVL Asheville, NC NC

AVP Scranton/Wilkes-Barre, PA PA

AZO Kalamazoo, MI MI

BDL Hartford, CT CT

BET Bethel, AK AK

Airport data
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Airport AirportCity AirportState

BFL Bakersfield, CA CA

BGR Bangor, ME ME

BHM Birmingham, AL AL

BIL Billings, MT MT

BIS Bismarck/Mandan, ND ND

BJI Bemidji, MN MN

BKG Branson, MO MO

BLI Bellingham, WA WA

BMI Bloomington/Normal, IL IL

BNA Nashville, TN TN

BOI Boise, ID ID

BOS Boston, MA MA

BPT Beaumont/Port Arthur, TX TX

BQK Brunswick, GA GA

BQN Aguadilla, PR PR

BRD Brainerd, MN MN

BRO Brownsville, TX TX

BRW Barrow, AK AK

BTM Butte, MT MT

BTR Baton Rouge, LA LA

BTV Burlington, VT VT

BUF Buffalo, NY NY

BUR Burbank, CA CA

BWI Baltimore, MD MD

BZN Bozeman, MT MT

CAE Columbia, SC SC

CAK Akron, OH OH

CDC Cedar City, UT UT

CDV Cordova, AK AK

CEC Crescent City, CA CA
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Airport AirportCity AirportState

CHA Chattanooga, TN TN

CHO Charlottesville, VA VA

CHS Charleston, SC SC

CIC Chico, CA CA

CID Cedar Rapids/Iowa City, IA IA

CLD Carlsbad, CA CA

CLE Cleveland, OH OH

CLL College Station/Bryan, TX TX

CLT Charlotte, NC NC

CMH Columbus, OH OH

CMI Champaign/Urbana, IL IL

CMX Hancock/Houghton, MI MI

COD Cody, WY WY

COS Colorado Springs, CO CO

COU Columbia, MO MO

CPR Casper, WY WY

CRP Corpus Christi, TX TX

CRW Charleston/Dunbar, WV WV

CSG Columbus, GA GA

CWA Mosinee, WI WI

CVG Cincinnati, OH KY

DAB Daytona Beach, FL FL

DAL Dallas, TX TX

DAY Dayton, OH OH

DBQ Dubuque, IA IA

DCA Washington, DC VA

DEN Denver, CO CO

DFW Dallas/Fort Worth, TX TX

DHN Dothan, AL AL

DIK Dickinson, ND ND
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Airport AirportCity AirportState

DLH Duluth, MN MN

DRO Durango, CO CO

DSM Des Moines, IA IA

DTW Detroit, MI MI

EAU Eau Claire, WI WI

ECP Panama City, FL FL

EGE Eagle, CO CO

EKO Elko, NV NV

ELM Elmira/Corning, NY NY

ELP El Paso, TX TX

EUG Eugene, OR OR

EWN New Bern/Morehead/Beaufort, NC NC

EWR Newark, NJ NJ

EVV Evansville, IN IN

EYW Key West, FL FL

FAI Fairbanks, AK AK

FAR Fargo, ND ND

FAT Fresno, CA CA

FAY Fayetteville, NC NC

FCA Kalispell, MT MT

FLG Flagstaff, AZ AZ

FLL Fort Lauderdale, FL FL

FNT Flint, MI MI

FOE Topeka, KS KS

FSD Sioux Falls, SD SD

FSM Fort Smith, AR AR

FWA Fort Wayne, IN IN

GCC Gillette, WY WY

GCK Garden City, KS KS

GEG Spokane, WA WA
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Airport AirportCity AirportState

GFK Grand Forks, ND ND

GGG Longview, TX TX

GJT Grand Junction, CO CO

GNV Gainesville, FL FL

GPT Gulfport/Biloxi, MS MS

GRB Green Bay, WI WI

GRI Grand Island, NE NE

GRK Killeen, TX TX

GRR Grand Rapids, MI MI

GSO Greensboro/High Point, NC NC

GSP Greer, SC SC

GTF Great Falls, MT MT

GTR Columbus, MS MS

GUC Gunnison, CO CO

GUM Guam, TT TT

HDN Hayden, CO CO

HIB Hibbing, MN MN

HLN Helena, MT MT

HNL Honolulu, HI HI

HOB Hobbs, NM NM

HOU Houston, TX TX

HPN White Plains, NY NY

HRL Harlingen/San Benito, TX TX

HSV Huntsville, AL AL

IAD Washington, DC VA

IAH Houston, TX TX

ICT Wichita, KS KS

IDA Idaho Falls, ID ID

ILG Wilmington, DE DE

ILM Wilmington, NC NC
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Airport AirportCity AirportState

IMT Iron Mountain/Kingsfd, MI MI

IND Indianapolis, IN IN

INL International Falls, MN MN

ISN Williston, ND ND

ISP Islip, NY NY

ITO Hilo, HI HI

JAC Jackson, WY WY

JAN Jackson/Vicksburg, MS MS

JAX Jacksonville, FL FL

JFK New York, NY NY

JLN Joplin, MO MO

JNU Juneau, AK AK

KOA Kona, HI HI

KTN Ketchikan, AK AK

LAN Lansing, MI MI

LAR Laramie, WY WY

LAS Las Vegas, NV NV

LAW Lawton/Fort Sill, OK OK

LAX Los Angeles, CA CA

LBB Lubbock, TX TX

LCH Lake Charles, LA LA

LEX Lexington, KY KY

LFT Lafayette, LA LA

LGA New York, NY NY

LGB Long Beach, CA CA

LIH Lihue, HI HI

LIT Little Rock, AR AR

LMT Klamath Falls, OR OR

LNK Lincoln, NE NE

LRD Laredo, TX TX
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Airport AirportCity AirportState

LSE La Crosse, WI WI

LWS Lewiston, ID ID

MAF Midland/Odessa, TX TX

MBS Saginaw/Bay City/Midland, MI MI

MCI Kansas City, MO MO

MCO Orlando, FL FL

MDT Harrisburg, PA PA

MDW Chicago, IL IL

MEM Memphis, TN TN

MFE Mission/McAllen/Edinburg, TX TX

MFR Medford, OR OR

MGM Montgomery, AL AL

MHK Manhattan/Ft. Riley, KS KS

MHT Manchester, NH NH

MIA Miami, FL FL

MKE Milwaukee, WI WI

MKG Muskegon, MI MI

MLB Melbourne, FL FL

MLI Moline, IL IL

MLU Monroe, LA LA

MMH Mammoth Lakes, CA CA

MOB Mobile, AL AL

MOD Modesto, CA CA

MOT Minot, ND ND

MQT Marquette, MI MI

MRY Monterey, CA CA

MSN Madison, WI WI

MSO Missoula, MT MT

MSP Minneapolis, MN MN

MSY New Orleans, LA LA
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Airport AirportCity AirportState

MTJ Montrose/Delta, CO CO

MYR Myrtle Beach, SC SC

OAJ Jacksonville/Camp Lejeune, NC NC

OAK Oakland, CA CA

OGG Kahului, HI HI

OKC Oklahoma City, OK OK

OMA Omaha, NE NE

OME Nome, AK AK

ONT Ontario, CA CA

ORD Chicago, IL IL

ORF Norfolk, VA VA

ORH Worcester, MA MA

OTH North Bend/Coos Bay, OR OR

OTZ Kotzebue, AK AK

PAH Paducah, KY KY

PBI West Palm Beach/Palm Beach, FL FL

PDX Portland, OR OR

PHF Newport News/Williamsburg, VA VA

PHL Philadelphia, PA PA

PHX Phoenix, AZ AZ

PIA Peoria, IL IL

PIH Pocatello, ID ID

PIT Pittsburgh, PA PA

PNS Pensacola, FL FL

PPG Pago Pago, TT TT

PSC Pasco/Kennewick/Richland, WA WA

PSE Ponce, PR PR

PSG Petersburg, AK AK

PSP Palm Springs, CA CA

PVD Providence, RI RI
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Airport AirportCity AirportState

PWM Portland, ME ME

RAP Rapid City, SD SD

RDD Redding, CA CA

RDM Bend/Redmond, OR OR

RDU Raleigh/Durham, NC NC

RHI Rhinelander, WI WI

RIC Richmond, VA VA

RKS Rock Springs, WY WY

RNO Reno, NV NV

ROA Roanoke, VA VA

ROC Rochester, NY NY

ROW Roswell, NM NM

RST Rochester, MN MN

RSW Fort Myers, FL FL

SAF Santa Fe, NM NM

SAN San Diego, CA CA

SAT San Antonio, TX TX

SAV Savannah, GA GA

SBA Santa Barbara, CA CA

SBN South Bend, IN IN

SBP San Luis Obispo, CA CA

SCC Deadhorse, AK AK

SCE State College, PA PA

SDF Louisville, KY KY

SEA Seattle, WA WA

SFO San Francisco, CA CA

SGF Springfield, MO MO

SGU St. George, UT UT

SHV Shreveport, LA LA

SIT Sitka, AK AK
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Airport AirportCity AirportState

SJC San Jose, CA CA

SJT San Angelo, TX TX

SJU San Juan, PR PR

SLC Salt Lake City, UT UT

SMF Sacramento, CA CA

SMX Santa Maria, CA CA

SNA Santa Ana, CA CA

SPI Springfield, IL IL

SPS Wichita Falls, TX TX

SRQ Sarasota/Bradenton, FL FL

STL St. Louis, MO MO

STT Charlotte Amalie, VI VI

STX Christiansted, VI VI

SUN Sun Valley/Hailey/Ketchum, ID ID

SUX Sioux City, IA IA

SWF Newburgh/Poughkeepsie, NY NY

SYR Syracuse, NY NY

TLH Tallahassee, FL FL

TOL Toledo, OH OH

TPA Tampa, FL FL

TRI Bristol/Johnson City/Kingsport, TN TN

TTN Trenton, NJ NJ

TUL Tulsa, OK OK

TUS Tucson, AZ AZ

TVC Traverse City, MI MI

TWF Twin Falls, ID ID

TXK Texarkana, AR AR

TYR Tyler, TX TX

TYS Knoxville, TN TN

VLD Valdosta, GA GA
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Airport AirportCity AirportState

VPS Valparaiso, FL FL

WRG Wrangell, AK AK

XNA Fayetteville, AR AR

YAK Yakutat, AK AK

YUM Yuma, AZ AZ

Instructions
Once you have loaded the data sets into a new app in Qlik Sense, you can begin building your map.
To make the example map, you must complete the following tasks: 

1. Create the drill-down dimensions.
2. Add the map to our sheet.
3. Add the State-County area layer.
4. Add the State-City point layer.
5. Add the State-Airport point layer.
6. Add the Resource filter pane.

Creating the drill-down dimensions
First, you need to create three drill-down dimensions. This will create the relationships between
State and the fields County, City, and Airport, enabling the County, City, and Airport layers to
become visible after a state from the State layer has been selected.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click   to display the master items.

3. Click Dimensions.
4. Click Create new.
5. Select Drill-down.
6. Add the field State to the dimension.
7. Add the field County to the dimension.
8. After Name, type State-County.
9. Click Create..

10. Add the field State to the dimension.
11. Add the field City to the dimension.
12. After Name, type State-City.
13. Click Create..
14. Add the field State to the dimension.
15. Add the field Airport to the dimension.
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16. After Name, type State-Airport.
17. Click Create..

18. Click Done editing.

Adding the map to the sheet
The next step is to add a map to your sheet.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. From the assets panel, drag an empty map to the sheet.

Adding the State-County area layer
The first layer you add is an area layer to which you add the dimension State-County. In addition,
you set the country as 'USA' to ensure we map to the state of Georgia rather than the nation of
Georgia.

Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Area layer.
3. In Dimensions, click Add and select State-County.
4. Click Location.
5. Set Scope for locations to Custom.
6. After Country, enter 'USA'.
7. After Administrative area (Level 1), select State.
8. Click Colors.
9. Set Colors to Custom, select By dimension, and select 100 colors.

10. Select Persistent colors.
11. Adjust the Opacity slider to half opacity.

12. Click Done editing.

Adding the State-City point layer
The next layer you add is a point layer. You add State-City as the dimension and then set the
country as 'USA' and then set State as the first-level administrative area, as some counties cities in
different states have the same names.

Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Area layer.
3. In Dimensions, click Add and select State-City.
4. Click Location.
5. Set Scope for locations to Custom.
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6. After Country, enter 'USA'.
7. After Administrative area (Level 1), select State.
8. Click Colors.
9. Set Colors to Custom, select Single color, and select a color.

10. Click Options.
11. In Layer display, set Visible drill-down levels to Custom.
12. Clear State.

13. Click Done editing.

Adding the State-Airport point layer
The final layer you add to the map is a point layer to which you add the State-Airport field as the
dimension. Qlik Sense recognizes IATA codes for placement, ensuring the airports are located in
their actual position rather than just in their city.

Do the following:

1. From Layers in the properties panel, click Add layer.
2. Select Area layer.
3. In Dimensions, click Add and select State-Airport.
4. Click Location.
5. Set Scope for locations to Custom.
6. After Country, enter 'USA'.
7. After Administrative area (Level 1), select State.
8. Click Size & Shape.
9. From Shape, select Triangle.

10. Click Colors.
11. Set Colors to Custom, select Single color, and select a color.
12. Click Options.
13. In Layer display, set Visible drill-down levels to Custom.
14. Clear State.

15. Click Done editing.

Add the Resource filter pane
Finally, you can optionally add a filter pane containing the field Resource. This provides you with a
list of the available historical sites as you make selections within your map.

Do the following:

1. In the assets panel, drag and drop a filter pane into the sheet.
2. Click Add dimension.
3. Add a filter pane containing the field Resource.
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Creating a map with an image background layer
You can use images as custom base maps in map visualizations. You may want to
display data over a floor plan.

This example map chart displays an office floor plan with a point layer. Each bubble is positioned
over an employee's desk. The weekly average of customer issues handled per day by the employee
determines the size and color of each bubble.

Map example with floor plan image background with a point layer showing employees sized by the number
of customer issues they have resolved

This example hides the default scale. Images do not have a consistent size scale. Image size in a
map background layer is also dependent on what coordinates the user sets for the corners of the
image.

Dataset
This example uses two tables and a background image. You can import the two tables into your app
using the web file connector.

CustomerIssues

Date EmployeeNumber CustomerIssues

8/1/2019 1 24

8/1/2019 2 31

8/1/2019 3 21

CustomerIssues
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Date EmployeeNumber CustomerIssues

8/1/2019 4 42

8/1/2019 5 24

8/1/2019 6 40

8/1/2019 7 40

8/1/2019 8 19

8/1/2019 9 23

8/1/2019 10 47

8/1/2019 11 38

8/1/2019 12 21

8/1/2019 13 22

8/1/2019 14 15

8/1/2019 15 30

8/1/2019 16 46

8/1/2019 17 41

8/1/2019 18 31

8/1/2019 19 50

8/1/2019 20 27

8/1/2019 21 35

8/1/2019 22 38

8/1/2019 23 37

8/1/2019 24 31

8/1/2019 25 13

8/1/2019 26 11

8/2/2019 1 35

8/2/2019 2 31

8/2/2019 3 33

8/2/2019 4 14

8/2/2019 5 24

8/2/2019 6 33

8/2/2019 7 40

8/2/2019 8 14
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Date EmployeeNumber CustomerIssues

8/2/2019 9 44

8/2/2019 10 24

8/2/2019 11 37

8/2/2019 12 39

8/2/2019 13 49

8/2/2019 14 16

8/2/2019 15 42

8/2/2019 16 13

8/2/2019 17 45

8/2/2019 18 48

8/2/2019 19 46

8/2/2019 20 18

8/2/2019 21 18

8/2/2019 22 45

8/2/2019 23 47

8/2/2019 24 31

8/2/2019 25 10

8/2/2019 26 21

8/3/2019 1 16

8/3/2019 2 34

8/3/2019 3 15

8/3/2019 4 44

8/3/2019 5 49

8/3/2019 6 18

8/3/2019 7 16

8/3/2019 8 41

8/3/2019 9 27

8/3/2019 10 46

8/3/2019 11 21

8/3/2019 12 49

8/3/2019 13 38
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Date EmployeeNumber CustomerIssues

8/3/2019 14 30

8/3/2019 15 48

8/3/2019 16 17

8/3/2019 17 42

8/3/2019 18 48

8/3/2019 19 44

8/3/2019 20 44

8/3/2019 21 12

8/3/2019 22 44

8/3/2019 23 17

8/3/2019 24 24

8/3/2019 25 25

8/3/2019 26 33

8/4/2019 1 20

8/4/2019 2 45

8/4/2019 3 32

8/4/2019 4 37

8/4/2019 5 32

8/4/2019 6 50

8/4/2019 7 41

8/4/2019 8 14

8/4/2019 9 37

8/4/2019 10 39

8/4/2019 11 28

8/4/2019 12 35

8/4/2019 13 24

8/4/2019 14 19

8/4/2019 15 25

8/4/2019 16 26

8/4/2019 17 23

8/4/2019 18 45
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Date EmployeeNumber CustomerIssues

8/4/2019 19 48

8/4/2019 20 36

8/4/2019 21 40

8/4/2019 22 21

8/4/2019 23 10

8/4/2019 24 42

8/4/2019 25 35

8/4/2019 26 26

8/5/2019 1 24

8/5/2019 2 28

8/5/2019 3 44

8/5/2019 4 19

8/5/2019 5 34

8/5/2019 6 37

8/5/2019 7 14

8/5/2019 8 26

8/5/2019 9 38

8/5/2019 10 25

8/5/2019 11 41

8/5/2019 12 35

8/5/2019 13 48

8/5/2019 14 36

8/5/2019 15 36

8/5/2019 16 37

8/5/2019 17 31

8/5/2019 18 44

8/5/2019 19 21

8/5/2019 20 28

8/5/2019 21 13

8/5/2019 22 10

8/5/2019 23 50
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Date EmployeeNumber CustomerIssues

8/5/2019 24 35

8/5/2019 25 11

8/5/2019 26 39

8/6/2019 1 26

8/6/2019 2 14

8/6/2019 3 45

8/6/2019 4 27

8/6/2019 5 33

8/6/2019 6 21

8/6/2019 7 14

8/6/2019 8 45

8/6/2019 9 41

8/6/2019 10 35

8/6/2019 11 35

8/6/2019 12 13

8/6/2019 13 35

8/6/2019 14 26

8/6/2019 15 40

8/6/2019 16 14

8/6/2019 17 20

8/6/2019 18 23

8/6/2019 19 11

8/6/2019 20 23

8/6/2019 21 31

8/6/2019 22 48

8/6/2019 23 39

8/6/2019 24 50

8/6/2019 25 47

8/6/2019 26 40

8/7/2019 1 49

8/7/2019 2 39
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Date EmployeeNumber CustomerIssues

8/7/2019 3 16

8/7/2019 4 28

8/7/2019 5 46

8/7/2019 6 37

8/7/2019 7 36

8/7/2019 8 15

8/7/2019 9 18

8/7/2019 10 25

8/7/2019 11 12

8/7/2019 12 37

8/7/2019 13 40

8/7/2019 14 35

8/7/2019 15 11

8/7/2019 16 12

8/7/2019 17 22

8/7/2019 18 16

8/7/2019 19 46

8/7/2019 20 39

8/7/2019 21 41

8/7/2019 22 26

8/7/2019 23 25

8/7/2019 24 34

8/7/2019 25 50

8/7/2019 26 41

EmployeeData

Employee EmployeeNumber Latitude Longitude

Nehru Pollard 1 2.1 -2.1

Duncan Bell 2 1.675 -2.1

Arthur Miller 3 2.1 -1.6

Latifah Randall 4 1.675 -1.6

EmployeeData
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Employee EmployeeNumber Latitude Longitude

Glenna Giles 5 2.1 -1.1

Chaim Gates 6 1.675 -1.1

Elijah Mcgowan 7 2.1 -0.585

Serina Richards 8 1.675 -0.585

Nora Odonnell 9 2.1 0.595

Fiona Craig 10 1.675 0.595

Kirestin Mcguire 11 2.1 1.155

Francesca Wilkerson 12 1.675 1.155

Virginia Sanford 13 2.1 1.6

Beau Weeks 14 1.675 1.6

Justin Cook 15 2.1 2.2

Lisandra Sloan 16 1.675 2.2

Brody Ball 17 2.1 2.6

Kirk Welch 18 1.675 2.6

Julian Mcgee 19 0.7 3.25

Geoffrey Wheeler 20 0.7 3.7

Carter Leonard 21 0.14 3.25

Noel Watson 22 0.14 3.7

Damian Everett 23 -0.3 3.25

Justina Frazier 24 -0.3 3.7

MacKenzie Garcia 25 -0.85 3.25

Germane Carey 26 -0.85 3.7
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Background image
Example background image

How I built this

Do the following:

1. Add the data sources to your app and associate the tables using the EmployeeNumber fields
in each table.

2. In a sheet, add a map chart.
3. In Map settings, do the following:

l Change Base map to None.
l Change Projection to User defined (degrees).

4. In Appearance > Presentation, do the following:
l Toggle the Scale bar to Off.
l Set Limit zoom levels to Custom and set the zoom to 7x zoom - 8x zoom.

5. Add a background layer to the map chart and in Data, do the following:
l In Format, select Image.
l Set the URL to https://help.qlik.com/en-

US/sense/Subsystems/Hub/Content/Resources/Images/ui_map-image-background-
example.png.

l Set the Top left corner to 2.5 for Top (latitude) and -4.1 for Left (longitude).

Create apps and visualizations - Qlik Sense, November 2024 296



3   Visualizations

l Set the Bottom right corner to -2.5 for Bottom (latitude) and 4.1 for Right
(longitude).

At this point in the example, the image does not appear yet. After you add a point
layer with the next step, the map updates with the correct scale and image
position.

6. Add a point layer to the map chart and do the following:
l In Data, add Employee as the field.
l In Location, select Latitude and longitude fields. Set Latitude as the Latitude field

and Longitude as the Longitude field.
l In Size & Shape, set Size by Avg(CustomerIssues).
l In Colors, do the following:

l Set Colors to Custom and color By measure.
l Select Avg(CustomerIssues) as the measure.
l Select Diverging classes as the color scheme.

To get the same look and feel as the image at the top of the page, set the app theme to Sense
Classic.

Creating a map focused on a region
You can configure your map charts to stay focused on a region of interest, such as a
country. You can also set the minimum and maximum zoom levels of your map. This
controls how far the Qlik Sense zooms into the map when you make selections.

The following example explains how to make a map with the focus locked on a single region and
with a custom maximum zoom level.

The map chart with panning limited to just the region of interest
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This map has set a pan limit so users cannot pan the focus of the map visualization away from the
region of interest. Users can drill down between separate map layers, but they cannot scroll outside
of the initial view.

This map visualization uses a point layer and an area layer with two drill-down dimensions. One
drill-down dimension enables the area layer to display counties after states are selected. The other
drill-down dimension enables the point layer to display cities as a points after a state is selected in
the area layer.

A zoom limit is applied to the map chart. When a state is selected in the area layer, the map drills
down to display the counties in the area layer and the cities in a separate point layer. The map
remains zoomed a level appropriate for a general regional overview.

A map chart with a state selection applied

Dataset
This example uses two sets of data. You must import this data into Qlik Sense. You can add the data
to a spreadsheet and import it into Qlik Sense. You can also import the table from this help page as
a web file.

City data

City
City
Code

County State Latitude Longitude

New York 1 New York County US 40.730599 -73.986581

Los Angeles 2 Los Angeles County CA 34.053678 -118.242702

Chicago 3 Cook County IL 41.875555 -87.624421

Philadelphia 5 Philadelphia County PA 39.952335 -75.163789

Sample city data
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City
City
Code

County State Latitude Longitude

Phoenix 6 Maricopa County AZ 33.446768 -112.075672

San Antonio 7 Bexar County TX 29.4246 -98.49514

San Diego 8 San Diego County CA 32.717421 -117.162771

Dallas 9 Dallas County TX 32.776196 -96.796899

San Jose 10 Santa Clara County CA 37.34385 -121.883135

Austin 11 Travis County TX 30.271129 -97.7437

Indianapolis 12 Marion County IN 39.76838 -86.158045

Jacksonville 13 Duval County FL 30.332184 -81.655651

Columbus 15 Franklin County OH 39.96226 -83.000706

Charlotte 16 Mecklenburg County NC 35.227087 -80.843127

Detroit 17 Wayne County MI 42.348664 -83.056738

Memphis 18 Shelby County TN 35.149022 -90.051628

Seattle 19 King County WA 47.603832 -122.330062

Denver 20 Denver County CO 39.739154 -104.984703

Boston 22 Suffolk County MA 42.360482 -71.059568

Nashville 23 Davidson County TN 36.162226 -86.774342

Baltimore 24 Baltimore City
County

MD 39.290861 -76.610807

Portland 25 Multnomah County OR 45.520247 -122.674195

Las Vegas 26 Clark County NV 36.166286 -115.149225

Milwaukee 27 Milwaukee County WI 43.034993 -87.922497

Albuquerque 28 Bernalillo County NM 35.084103 -106.650985

Tucson 29 Pima County AZ 32.221742 -110.926476

Fresno 30 Fresno County CA 36.73082 -119.699202

Sacramento 31 Sacramento County CA 38.581572 -121.4944

Kansas City 32 Jackson County MO 39.084469 -94.56303

Colorado
Springs

33 El Paso County CO 38.833958 -104.825348

Atlanta 34 Fulton County GA 33.749099 -84.390185

Omaha 35 Douglas County NE 41.258732 -95.937873
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City
City
Code

County State Latitude Longitude

Raleigh 36 Wake County NC 35.780402 -78.639078

Miami 37 Miami-Dade County FL 25.774266 -80.193659

Minneapolis 38 Hennepin County MN 44.9773 -93.265469

Tulsa 39 Tulsa County OK 36.152436 -95.990409

Cleveland 40 Cuyahoga County OH 41.505161 -81.693445

New Orleans 41 Orleans Parish LA 29.949932 -90.070116

Customer

Customer Customer Number City Code

A Superior System 10000453 1

Beech Aircraft Corporation 10003882 1

Deere and Company 10009863 1

Gailey Enterprises 10012851 1

J.A. Bauer Pottery Company 10017852 1

Old Towne Creations 10020715 1

Real World 10022755 1

ValueClick 10025878 1

A&G 10000457 2

Bell Canada Enterprises 10004207 2

Échange CAC Exchange 10010832 2

Gainunion 10012885 2

J.M. Haggar 10018129 2

OnDeck Systems 10020849 2

Reflex Presentations 10022962 2

Wasabi 10026294 2

Aadast 10000471 3

Bendix Corporation 10004255 3

ECI com 10010855 3

Galaxy Marketing Associates 10012907 3

Johnson and Higgins 10018352 3

Sample customer data
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Customer Customer Number City Code

One Planet Solutions 10020864 3

Relcom 10022978 3

Wayne'sWorld 10026334 3

ABI TruTrac 10000488 5

Best Way! Imaging 10004602 5

Ed Stefanov 10010881 5

Gamacles 10013011 5

Joy Line 10018371 5

Onebox 10020907 5

SageGroup 10023511 5

VEI 10026023 5

AboveNet 10000496 6

Bezeq 10005043 6

EDA Today 10010882 6

Gamma One Conversions 10013039 6

K 10018518 6

Keystroke Quality 10019420 6

Outsource Documents 10020982 6

PAGE 10021240 6

Sarcom 10023703 6

Systems of Missouri 10024915 6

Velos Medical Informatics 10026038 6

Abplus 10000497 7

BF Datacom 10005099 7

Edmark 10010923 7

GammaGraphX (GGX) 10013052 7

K&K Enterprises 10018603 7

Overdreams 10021006 7

SAS Institute 10023757 7

Ventana s Group 10026081 7
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Customer Customer Number City Code

ABSolute 10000499 8

BH Feldman Consulting 10005236 8

Elbit Oy 10010990 8

Gammel Group 10013061 8

Karickal Exports 10018868 8

Owl's Eye Productions 10021015 8

SAT-SAGEM (usa) 10023780 8

White Oak Interactive 10026365 8

Absolute Magic 10000501 9

Bibb Manufacturing Company 10005376 9

Eloi Companies 10011018 9

Gandalf Systems 10013079 9

KAT Micro Distributing 10018877 9

P.C'S 10021111 9

Science Applications International (SAIC) 10023964 9

Xcert 10026521 9

Abstract 10000502 10

BidCast 10005620 10

Elucidex 10011052 10

Ganymede 10013080 10

Kendrick Jansen 10018950 10

P.C.G. Associates 10021107 10

Screen Digest 10024016 10

Xyratex 10026868 10

AC Exchange 10001103 11

Bien Logic 10005688 11

Embedded Support Tools (EST) 10011089 11

Garbee and Garbee 10013127 11

Kennecott Copper Corporation 10018957 11

Pacific Bell 10021160 11
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Customer Customer Number City Code

Smith Manufacturing Company 10024477 11

Yurie Systems 10027119 11

AC&E 10001263 12

Acara 10001786 12

Big 10005810 12

Big Picture Technologies 10005919 12

EMC 10011093 12

Garlin Imports 10013137 12

KENROB and Associates 10019066 12

Packet Design 10021232 12

Sterling Armament Company 10024704 12

Zero G 10027370 12

Acacia 10001784 13

Big Mountain Multi 10005861 13

Emergency 10011286 13

Gate9th 10013312 13

Kerite Company 10019194 13

PADL 10021239 13

Sun Microsystems 10024880 13

Acc Tonec 10001818 15

Big Planet 10005922 15

Enterprises 10011355 15

Gatierf Publications 10013341 15

kGS 10019469 15

Page Marketing 10021242 15

T & S 10024916 15

Accel Partners 10002114 16

Biz-comm 10006836 16

Equitable Life Assurance Society 10011360 16

GCC Technologies 10013376 16
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Customer Customer Number City Code

KillerGraffix 10019502 16

Page Research 10021270 16

T.F.C. 10024918 16

Accent Interactive 10002115 17

Boott Cotton Mills Corporation 10006916 17

Farmland Industries 10011499 17

GDC 10013426 17

Kim Tom Co 10019512 17

PageBoy 10021283 17

T.J.T. International 10024919 17

Accent Systems 10002117 18

Borden Company 10006917 18

Farrell Lines Company 10011546 18

GEAR 10013538 18

Kimball (W.W.) Company 10019514 18

PagePoint 10021286 18

T.M. Denton Consultants 10024924 18

Access Point 10002128 19

Accidental 10002137 19

Boston and Albany Railroad Company 10006919 19

Bre-X 10007117 19

FCS 10011600 19

Federated Co-Operatives Limited 10011732 19

GearSource 10013572 19

Gehlken Enterprises 10013670 19

Levi Strauss and Company 10019783 19

Lobster Productions 10019952 19

PageSites 10021297 19

PageWeavers 10021302 19

T3West 10024930 19
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Customer Customer Number City Code

Tag Systems 10024942 19

AccessWare 10002136 20

Brazilian Traction, Light and Power Company 10006977 20

Federal Express Corporation 10011623 20

Gebbie Press 10013574 20

Lewis Grocer Company 10019812 20

PageWave 10021300 20

Tadpole 10024940 20

ACCPAC International 10002138 22

Brentano's 10006983 22

FenP Innovators 10011821 22

Greymac Trust Company 10013870 22

Lucky 10020080 22

Pallister Management 10021305 22

Take 3 10025022 22

Accrue 10002139 23

C&C 10007134 23

Fentek Industries 10011842 23

Grove Farm Co., Inc. 10013871 23

Market 10020181 23

Palo Alto 10021331 23

Talarian 10025024 23

Accton 10002140 24

C. Hoelzle Associates 10007163 24

Fenwick & West 10011870 24

Grumman Corporation 10013899 24

Maui Island(MIC) 10020193 24

Panasonic 10021350 24

Target 10025052 24

AccuCom 10002142 25
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Customer Customer Number City Code

C.O.F. 10007183 25

Ferrari 10011918 25

Guarantee Mutual Life Company 10014043 25

MaxBan 10020227 25

Pangaea Systems 10021380 25

Taroch 10025063 25

ACCUCOMP 10002144 26

C3 Development 10007253 26

FiberPlex 10011979 26

GURUs 10014059 26

MaXpeed 10020239 26

Panix 10021411 26

Tartanchase 10025086 26

AccuLAN 10002149 27

C3I 10007258 27

FICOM 10012023 27

H.H. Robertson Company 10014064 27

MAXSTRAT 10020247 27

Paraclipse 10021494 27

Taskers of Andover, Ltd. 10025158 27

Accumedic Systems 10002150 28

Cabco West 10007268 28

Fifth Generation 10012128 28

HarborGroup 10014238 28

Maxtor 10020256 28

Parian Development Group 10021575 28

Tatters 10025213 28

Ace Equipment 10002153 29

Cadtex 10007309 29

Fifth Moon 10012157 29
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Customer Customer Number City Code

HarveyOpolis 10014540 29

Maxwell Laboratories 10020266 29

Password Busters 10021641 29

Teamaker 10025239 29

Acer 10002154 30

Cajun 10007448 30

Filene’s 10012158 30

HBS 10014802 30

Mb digital marketing 10020281 30

Patrick Townsend & Associates 10021677 30

Teammax 10025241 30

ACES Research 10002155 31

CalComp 10007457 31

Filetron 10012161 31

Hederman Brothers 10015011 31

McGraw-Hill Publishing Company 10020306 31

Patton Enterprises 10021736 31

Teamsolve 10025242 31

ACI 10002159 32

Caleidoscopio S.r.l. 10007468 32

Emergent 10011345 32

FIND/SVP 10012305 32

GateMaster 10013332 32

Hekimian Laboratories 10015253 32

Mead Corporation 10020323 32

Paul Budde 10021750 32

Todd Shipyards Corporation 10025267 32

ACME Laboratories 10002161 33

Calypso 10007536 33

Finder 10012328 33
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Customer Customer Number City Code

Helfand Enterprises 10015267 33

Medics 10020332 33

PayMaxx 10021794 33

Transylvania Company 10025288 33

Acsior 10002412 34

Camelot IT 10007591 34

Finest Host 10012369 34

Helius 10015325 34

Melville Shoe Corporation 10020340 34

Payton Group International 10021800 34

UBF 10025304 34

Action Systems 10002501 35

Camros 10007866 35

Finisar 10012399 35

Hercules Incorporated 10015686 35

Mersey Docks 10020364 35

Pick Professionals 10021802 35

UK Total.net 10025353 35

ActivCard 10002520 36

Champion International 10009606 36

Firehole 10012514 36

hesketh.com 10015789 36

Nancy Leffingwell Enterprises 10020449 36

Picka 10021804 36

UKnames.net 10025359 36

Active 10002526 37

Dan River Mills, Inc. 10009633 37

FireTrans 10012600 37

Hewlett Packard 10015886 37

Nbase 10020491 37
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Customer Customer Number City Code

PLAINFIELD ROOFING AND SHEET METAL 10026438 37

Ultimate Group 10025392 37

Aberdeen 10000486 38

Ad-vantage 10003687 38

Besicorp 10004516 38

Data General Corporation 10009639 38

ECS Associates 10010865 38

Galaxy Systems 10012927 38

G-Com International 10013397 38

Hidden Oak 10015956 38

Jones and Laughlin Steel Corporation 10018363 38

NBTel 10020492 38

One World 10020868 38

QualityLogic 10022166 38

Safe 10023495 38

Ultra-Image 10025418 38

Vectrix 10026009 38

Ad Agency 10003554 39

Day and Zimmermann, Inc. 10009645 39

G.R. Barron 10012761 39

Hill and Knowlton, Inc. 10016113 39

NBX 10020515 39

Quallaby 10022167 39

Underwriters Laboratories 10025467 39

Associates 10003749 40

Dayton Rubber Company 10009650 40

Gadzoox Microsystems 10012792 40

iBEAM 10016780 40

Nematron 10020662 40

Quantum 10022201 40
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Customer Customer Number City Code

Universal Access 10025608 40

Beckman Instruments, Inc. 10003857 41

De Postel 10009669 41

Gaecom 10012799 41

Id 10017290 41

Oki 10020672 41

Rdlabs 10022746 41

Userland 10025737 41

How I built this

Do the following:

1. Import the data into Data manager.
2. Make the recommended associations between the two tables in Data manager.
3. Create two drill-down dimensions, one of State and County and one of State and City.
4. Add a map and in Presentation, set a Custom zoom level with a maximum zoom of 7x zoom.
5. Add a point layer with State -City as the dimension. Set the following properties:

l In Location, set the scope to Custom and enter 'USA' in Country.
l In Size & Shape, set Size by to Count(Distinct(Customer)).
l In Colors, color by measure using Count(Distinct(Customer)).
l In Options>Layer display, set Visible drill-down levels to Custom and select City.

6. Add an area layer with State-County as the dimension. Set the following properties:
l In Location, set the scope to Custom, enter 'USA' in Country, and State in

Administrative area (Level 1).
l In Colors, color by measure using Count(Distinct(Customer)) and set the Opacity

slider to 40%.
7. Center the region in the map and then set Limit pan navigation to Custom and click Set pan

limit.

Mekko chart
The mekko chart is suitable for comparing groups, while being able to compare
category items contained within these groups. Mekko charts are also known as mosaic
plots, Marimekko charts, and Mondrian diagrams. The dimension axis shows the
groups, while the measure axis shows the normalized percentage value for each
category item. The size of each group shows its value.
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In this image, the dimensional groups represent different yearly quarters. The width of each quarter
shows the normalized percentage value of the sum of sales, for that quarter. Each quarter is divided
in several product categories, such as Produce, Canned Products, and Frozen Foods. The height of
each product category corresponds to the normalized percentage value of the sum of sales of that
product category, within that quarter. This allows you to easily compare between product
categories inside a specific quarter, and between different quarters.

Sorting is automatic according to size. By default, the coloring is by dimension, with 12 colors, but
that can be changed in the properties panel. You can decide which dimension to color by. In this
example, the coloring is by product category to clearly distinguish the different categories and how
their contribution to the sales change in each quarter.

If the data set contains negative values, a text message is shown stating that the negative values
cannot be displayed.
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When to use it
Use a mekko chart when you need to visualize normalized percentage values of grouped data.
Mekko charts should primarily be used with values that can be aggregated.

Advantages
The mekko chart is easy to read and understand. You get a good comparison between groups, and
a comparison of the impact of categories within each group.

Disadvantages
The mekko chart does not work so well with many dimension values due to the limitation of the axis
length.

Mekko charts are not good when there is a big difference in the magnitude of the measure values.
Nor is a mekko chart the right choice when mixing absolute and relative values.

Negative values cannot be displayed in mekko charts.

Creating a mekko chart
You can create a simple mekko chart on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty mekko chart to the sheet.
2. Click Add dimension and select a dimension or a field. This dimension defines the grouping.
3. Add a second dimension in the order of hierarchy level. The second dimension you add
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defines the categories.
4. Click Add measure and select a measure or create a measure from a field.

In a mekko chart you need two dimensions and one measure.

Each bar corresponds to the first dimension, divided into smaller categories based on the second
dimension. The values of the measures determine the relevant height of the categories inside each
bar, as well as the size of the bars.

When you have created the chart, you might want to adjust its appearance in the properties panel.

Styling the mekko chart
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis label: Style the labels on the axes.
l Value label: Style the labels for the dimension and measure values, including the

percentage contributed by each value towards the total of the grouping above it in the
hierarchy.
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l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.

Comparing groups and group categories against a measure with a mekko
chart
This example shows how to make a mekko chart to compare the sales between
different years as well as the impact specific product groups have on a year's sales,
and how that compares to other years.
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Dataset
In this example, we will use two data files available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial, and the files are available in the Tutorials source folder:

l Sales.xls
l Item master.xls

To download the files, go to Tutorial - Building an App.

Add the two data files to an empty app and make sure that they are associated by Item Number.

The dataset that is loaded contains sales data. The Item master table holds the information about
the items ordered, such as product groups.

Measure
We use the sales volume as the measure by creating a measure in Master items with the name
Sales, and the expression Sum(Sales).

Visualization
We add a mekko chart to the sheet and set the following data properties.

l Dimension: Date.autoCalendar.Quarter (year).
l Dimension: Product Group (product group)
l Measure: Sales; the measure that was created as a master item.

The following mekko chart is created:
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The size of each column represents the volume of sales for each year. The size of the different
sections inside each column represent the volume of sales for each specific product group during
that year.

Notice how the sum of all three yearly percentages adds up to 100%. The same applies to the
percentages of the product groups section of each year. This is because the percentages are
normalized, so the size of each section is relevant to the total.

We want to have a better overview of how each product group's sales change from one year to the
next. This is not obvious for product groups such as Baking Goods, Dairy, or Beverages which do
not sit side by side from one column to the next. We want to display a different sorting, one based
on the product groups.

This can be changed under Sorting in the properties panel.

Set the sorting order to the following:

1. Date.Year
2. Product Group
3. Sum(Sales)

The chart becomes as follows:
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Discovery
The mekko chart visualizes the normalized percentage of sales per year for different product
groups, as well as the normalized percentage of sales of each year. The visualization is sorted in
order of product group, per year. You can hover the mouse pointer over a product group and view
the details.

In the mekko chart we can see that Produce has the highest sales volume throughout the three
years.

Navigation menu
The navigation menu adds sheet navigation options into your sheet.

Users can navigate between sheets from the assets panel. You can also add a sheet navigation
menu to allow users to navigate directly in the sheets, without needing to open the assets panel.

By default, the navigation menu displays all public sheets and groups in an app.
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Navigation menu

You can choose to have the navigation menu open a drawer menu over the app. When this is
selected, the navigation menu become an icon ( ).

Drawer navigation menu

The navigation menu can only be added in advanced edit mode.
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When to use it
The navigation menu is useful when you want to provide an alternative method of navigating sheets
in an app.

Creating navigation menus
You can format and color the text in the menu. The background image has sizing and positioning
options.

Do the following:

l From the assets panel, drag a navigation menu on to the sheet.

Styling the navigation menu
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Menu tab, set the font, font size, and color for the following text elements:
l Labels: Style the labels of the individual items.
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Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

4. On the Menu tab of the styling panel, select a default color for the menu items, a highlight
color, and a hover color.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.
7. On the Menu tab, under Border, adjust the Outline size to increase or decrease the border

lines around the chart.
8. Select a color for the border.
9. Adjust the Corner radius to control the roundness of the border.

10. Under Shadow in the Menu tab, select a shadow size and color. Select None to remove the
shadow.

Setting navigation menus as drawer menus
You can make your navigation menu a drawer menu. When set as a drawer menu, the navigation
menu acts as a button that opens a menu over the whole app listing sheets. You can optionally add
a menu icon ( ) to the navigation menu.

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Appearance > Presentation, turn on Drawer menu.
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3. Optionally select Show drawer icon.

Styling drawer menus
You can style your drawer button and panel.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Click Menu.
4. Under Drawer button, optionally customize the colors and add a background image.
5. Under Drawer panel, optionally customer the color and background image used by the

panel.

Setting orientation and layout

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Appearance > Presentation, under Orientation, select Vertical or Horizontal.
3. Under Layout, select Fill or Minimal.
4. Under Position, select the position of the menu items in the navigation menu.
5. If you selected Horizontal or Minimal, optionally select Same item width to make all tabs

have the same size.

Separating items in navigation menus

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Appearance > Presentation, turn on Separate items.

Showing large items

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Appearance > Presentation, select Show large items.

Showing item icons

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Appearance > Presentation, select Show item icons.
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NL insights
The NL insights visualization displays natural language insights and information about
selected dimensions and measures.

NL insights uses Insight Advisor to generate natural language information about the dimensions
and measure added to the chart. The chart updates the insights as selections are made in the app.

Native NL insights object displaying natural language insights with full verbosity

NL insights is a native chart type replacing the deprecated NL Insights control from the Dashboard
bundle.

By default, NL insights generates insights for all analysis types supported for the selected fields.
The classification of fields in your app logical model determines which fields are available as
dimensions or measures.

When to use it
Use NL insights when you want to include a narrative or analytical summary of your data. For
example, on a sheet focused on sales, you might want narratives summarizing key ranking,
correlation, and comparison analyses for sales to complement your other visualizations.

It is also helpful to pair NL insights with another chart containing the same dimensions and
measures. This provides additional context and information for the chart. To do this, configure the
NL insights object to use an input chart that has already been created on the current sheet. The
dimensions and measures from that input chart are used to generate the natural language insights,
and the NL insights will update based on changes you make in the input chart.
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NL insights with natural language insights generated directly from input bar chart

Migrating from the Dashboard bundle to native object
NL Insights extension objects from the Dashboard bundle must be migrated to native charts if they
appear on a public (base) sheet or published (community) sheet. To do this, follow the applicable
steps to make the sheet private, then publish and/or make it public again.

An alternative to the following instructions is to duplicate the app in the stream, open the
sheet in the duplicated app to ensure proper chart migration, and then re-publish the
app to the stream.

Public sheets

Do the following:

1. Open the app overview, or open Sheets from sheet view.

2. Right-click the public sheet and select Unapprove.
3. Right-click the community sheet and select Unpublish.
4. Open the private sheet and ensure the chart has been migrated.
5. Right-click the sheet and then select Publish.
6. Right-click the community sheet and select Approve.
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Published sheets

Do the following:

1. Open the app overview, or open Sheets from sheet view.

2. Right-click the community sheet and select Unpublish.
3. Open the private sheet and ensure the chart has been migrated.
4. Right-click the sheet and then select Publish.
5. Right-click the community sheet and select Approve.

Creating NL insights
You need at least one dimension or one measure to create the chart. Combine dimensions and
measures as needed. If you use an existing chart to generate the content of your NL Insights, the
dimensions and measures from that input chart are used and will be dynamically updated if you
change the input chart.

Do the following:

1. From the assets panel, drag an empty NL insights chart to the sheet.
2. Click Add chart to use natural language insights from an existing chart in the NL insights

visualization. Choose from any of the supported charts in the current sheet.
Alternatively, click Add dimension or Add measure to add natural language insights from a
dimension or measure into the chart.

3. In the properties panel, add or remove dimensions and measures from the chart.

You cannot add or remove dimensions and measures if you have chosen to use
insights from an existing chart.

When you have created the NL insights visualization, you might want to adjust its appearance and
other settings in the properties panel.

Styling NL insights
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).
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Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, style the following text elements:
l Analysis type: Set the font, font size, and color of the headers displaying the analysis

types of the insights.
l Style: Set the font, font size, and color of the narrative insights.
l Structure: Set how the narrative insights in the chart should be presented. Choose

bullet points or sentences.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Adjusting the verbosity
You can control the verbosity of the natural language insights. Verbosity can be full or brief. Full
verbosity groups natural language insights by analysis type. Brief verbosity displays all natural
language insights as a list.

Verbosity can be configured under Appearance > Presentation in the properties panel.

Removing analysis types
You can remove unwanted analysis types from NL Insights under Appearance > Presentation in
the properties panel.

Changing the language of the natural language insights
You can change the language of the generated natural language insights under
Appearance > Presentation in the properties panel.

NL insights has the same language supports as natural language insights in Qlik Sense
within Qlik Cloud Analytics. For information, see Supported languages.

Considerations
The analysis types and number of narrative insights generated in the NL insights chart depend on
the volume and variety of data that belongs to the fields selected. A limited number of analysis
types and insights might be displayed in the following scenarios:

l The selected items use the same underlying field with aggregations or selections.
l The selected items include only measures and no dimensions.
l The selected items are mostly unrelated.

Limitations
The NL insights object has the following the limitations:
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l You cannot use the following chart types for direct input into the NL insights chart:
l Animator
l Button
l Container
l Date picker
l Filter pane
l Text & image
l Video player

l The NL insights chart does not provide natural language insights for the following analysis
types (even if it uses an input chart generated from these analysis types):

l Clustering (k-means)
l Overview
l Period changes
l Process control (rolling mean)
l Year to date

l Expressions with modifiers, either applied directly to the chart or via an input chart, might not
provide correct values in natural language insights.

l The number format accompanying an expression is only applied to narrative statements
generated using that expression. Additional narratives that are generated might not adhere
to the expression's number format.

l When using an existing chart as the input for an NL insights object, certain actions taken on
the input chart will not result in the natural language insights being updated automatically.
Specifically, switching to alternative measures or dimensions, or customizations made
through chart exploration in analysis mode, do not update natural language insights unless
those changes are applied and made available for all users.

l Changing the number format of a measure might not always result in this formatting being
changed in all available insights.

Pie chart
The pie chart displays the relation between values as well as the relation of a single
value to the total. You can use a pie chart when you have a single data series with only
positive values.

In the pie chart, the dimensions form sectors of the measure values. A pie chart can have one
dimension and up to two measures. The first measure is used to determine the angle of each slice in
the chart.
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Sales per region in a pie chart.

Optionally, a second measure can be used to determine the radius of each pie slice. This style of pie
chart is also known as a rose chart.
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Sales by product sub group in a pie chart with the average sales per invoice sales determining slice radius

In the pie presentation of the pie chart, negative values in the radius measure are not supported and
will be excluded. Negative values in the radius measure are supported in the donut presentation
and will point in towards the center of the pie chart.
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Sales by product sub group in a pie chart with radius measure containing a comparison of sales from the
previous year

When to use it
The primary use of a pie chart is to compare a certain sector to the total. The pie chart is particularly
useful when there are only two sectors, for example yes/no or queued/finished.

We do not recommend that you compare the results of two pie charts with each other.

Advantages
The pie chart provides an instant understanding of proportions when few sectors are used as
dimensions. When you use 10 sectors, or less, the pie chart keeps its visual efficiency.

Disadvantages
It may be difficult to compare different sectors of a pie chart, especially a chart with many sectors.
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The pie chart takes up a lot of space in relation to the values it visualizes.

Creating a pie chart
You can create a pie chart on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty pie chart to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field.

The following settings are used by default in a pie chart:

l The top 10 sectors are presented in descending size order, clockwise.
l Colors are presented by dimension.
l Value labels are presented in percent.

After you have created the pie chart, you may want to add a radius measure or adjust its
appearance and other settings in the properties panel.

Styling the pie chart
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:
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l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Dimension label: Style the label for the dimension shown in the chart.
l Dimension value label: Style the individual dimension values.
l Value label: Style the labels which display the measure value (displayed as a value or

relative percentage) for each dimension value.
l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the outline and shape
You can customize the outline surrounding the chart, as well as the shape and thickness of the
slices.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, under Outline, set the thickness and color of the
outlines of the slices.

4. Under Corner radius, set the roundness of the corners of the slices.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.

Pivot table
The pivot table presents dimensions and measures as rows and columns in a table. In a
pivot table you can analyze data by multiple measures and in multiple dimensions at
the same time.

You can rearrange measures and dimensions by pivoting rows and columns.

When to use it
The pivot table is useful when you want to include several dimensions or measures in a single table,
and then want to reorganize them to see different subtotals.

Advantages
The pivot table is very powerful when you want to analyze multiple dimensions and measures at
once, and then reorganize them to get a different perspective on your data. You can expand the
rows you are interested in while keeping the rows in the rest of the table collapsed.
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Disadvantages
The pivot table may seem a bit complicated, and does not give insights at a glance.

Creating a pivot table
You can create a new pivot table on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty pivot table to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field.

You can adjust appearance and other settings in the properties panel.

Column width is automatically set to keep columns together for improved readability.
You can adjust the width of the dimension column by dragging the header divider. The
width of individual measure columns will still be automatically set. Double-click the
header divider to reset to automatic column width.

Styling the pivot table
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font size and color for the following text elements:
l Header: Style the text of the headers for each column to the right of the first column.
l Content: Style the text of the first column, as well as each cell in the table itself.

Additionally, you can customize how the text appears when a user hovers over a row. See
Customizing the hover behavior and scrollbar (page 335).

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

If a cell in the pivot table has a null value, it is colored separately from the background settings
applied in the styling panel (it appears in a white color).

Customizing the hover behavior and scrollbar
You can set display options for when a user hovers over a row in the table. You can also set the
scrollbar size.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, under Row hover, adjust the following settings:
l To highlight rows in the table when a user hovers over them, set the switch to On.

Switch the behavior off according to preference.
l Row hover color: Set the color to highlight the row when a user hovers over it.
l Row hover font color: Set the color of the text in the highlighted row when a user

hovers over it.
4. Under Scrollbar size, set the size of the scrollbar in the chart (you can select Small, Medium,

or Large).
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Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Pivoting your data in the table
When you want to rearrange your data, drag the items to a new column or row.

In the following pivot table, the dimension Customer has been dragged to the position after Product
Group. The dimension Item Desc has been moved to the position before Product Group. As a
consequence, the dimensions are now sorted by Item, primarily. Focus has shifted from Customer
to Item Desc. You can find out the quantities and sales for each customer by clicking . This will
expand a dimension.

By moving the dimension Customer from rows to columns, you retain focus on the dimension Item
Desc, but you also get the distribution of items per customer. The move has made the pivot table
more information dense.
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Measure grouping
As you may have noticed, Quantity and Sales are not presented as separate measures in the top
column row. Next to the dimension Customer, you find an item called Values. When you use more
than one measure, they are automatically grouped together forming a measure group, Values. This
group can be added to the rows section or the columns section. The measure group cannot be
edited or selected in the table. You cannot split up the measure item and use one measure as a row
and another as a column.

Pivoting your data in the properties panel
In the properties panel, you can add measures and dimensions to the pivot table, and also pivot
rows or columns.

Data
In the data pane, you can add dimensions and measures. You can move items between rows and
columns. You can also change item order inside rows or columns. When you use more than one
measure, they are grouped and a Values item is created.
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Sorting
On the sorting pane, you can change the internal order of dimensions and measures.

When sorting pivot tables, NULL values are always displayed first.

Sort by first measure
If you have more than one measure, a measure group is created. Turn on Sort by first measure to
sort dimension values by the numeric value of the first measure. You can choose between
Ascending and Descending sort order.

This sort order will affect all dimensions, and take precedence before any other sort order defined
under the dimensions.

For example, you have two measures: Quantity and Sales. In the properties pane, under Data>
Measures, Quantity is listed first. If you Sort by first measure in descending order, your table is
sorted starting with the dimension with the highest Quantity.

If Sort by first measure is turned off, the table uses the sort order configured for the dimensions.
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Pivot table in edit mode. Sort by first measure has been toggled on.

Limitations:

l This option is only supported if subtotals are calculated. You can calculate subtotals by doing
one of the following:

o In the properties pane, go to Data, and click on a dimension. Toggle on Show totals.
o In the properties pane, go to Appearance > Presentation. Toggle on Indent rows.

l This option is not supported for calculated dimensions.
l This option is only supported if all dimensions are in the Row section and all measures are in

the Column section.

Dimension sorting
With Sort by first measure turned off, the table can be sorted by dimension values. Each
dimension can have Auto or Custom sorting. With Auto sorting, field values are sorted
alphabetically and numerically in ascending order. With Custom sorting, you can turn each of the
following settings on or off:

l Sort by expression: Sorts by custom expression. Sort by expression overrides the Sort
numerically and Sort alphabetically settings. This option should only be used with the first
(outermost) dimension in the table.

l Sort numerically: Sorts field values starting with a number.
l Sort alphabetically: Sorts field values starting with a letter.

Ascending and Descending options are available for all three settings.

Sorting in search
The user can click a dimension name in the table to expand a listbox. In the listbox, the user can
search and select individual dimension values. The Sorting in search setting controls the sort order
of the values in a dimension listbox.
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You have the following options for the listbox sort order:

l Auto: Uses the default sort order. Numbers are sorted numerically in ascending order. Text is
sorted alphabetically in ascending order.

l Inherit from dimension: Uses the sort order defined for the individual dimension.

Global grouping
Global grouping lets you create a limited data set, and within that data set, single out values that
you want to focus on. For example: the best quarters, the top sales people, or the worst selling
products.

Example:

In the following pivot table, no limitation is applied. The values are sorted on Sales, descending. The
list is long and the values for 2013 are not shown.

In the following pivot table, a limitation has been applied to the (inner) dimension Sales Rep Name,
so that only the top five sales representatives for the years 2013 and 2014 are shown.
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The next step is to select global grouping in the properties panel. The option Global grouping is
only available after you have applied a limitation on the dimension.

When global grouping is selected, the limitation on the top five sales representatives is applied
again, but this time the dimension Year is ignored. The five sales representatives with the highest
sales (either in 2013 or 2014) are the only ones that will be presented in the final pivot table.

The following image shows the six highest results for 2014 and 2013. The top four results are from
2014, but the fifth (John Greg) is from 2013. Because five other sales representatives have higher
sales than Brenda Gibson (who was number five in 2014), she is removed.

The following image shows the pivot table with global grouping applied. The pivot table only
contains the sales results for the top five sales representatives. Even though Brenda Gibson had a
better result in 2014 than John Greg, his result for 2013 qualified him for the top five list.
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Creating a bookmark with an expanded pivot table
By default, if you create a bookmark that contains a pivot table, the pivot table will be shown
collapsed. If you expanded any rows using , they will not be shown. However, you can choose to
show the pivot table as expanded.

Do the following:

1. Click in the toolbar.

2. Click Create new bookmark.
Change the name and description, if desired.

3. Toggle on Save layout.
4. Click Save.

Comparing straight tables and pivot tables
You can see the efficiency of a pivot table if you compare it to a regular table that has
the same data.

Straight table
In the following table, you have:

l Three dimensions: Customer, Product Group, and Item Desc
l Two measures: Quantity and Sales
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The table shows food product sales. If you want to rearrange the data to simplify analysis, your
options are limited. You can change the order of the columns, but that does not improve the
overview. You can also set the sorting order, either in the sorting section in the properties panel, or
by clicking the dimension columns. However, the problem persists. The customers, product groups,
and items are all displayed more than once. It is not possible to get a good summary of the data.

Pivot table
We add a pivot table to the sheet and use the same info:

l Three dimensions: Customer, Product Group, and Item Desc
l Two measures: Quantity and Sales
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Discovery
As you can see, the pivot table presents the data in a much more condensed way. Compared to the
regular table, the number of rows has been halved and the number of columns is three instead of
five.

One of the advantages of a pivot table is the interchangeability: the ability to move row items to
columns and column items to rows. You can rearrange the data and have several different views of
the same data set. You can move dimensions and measures to bring forward data of interest and
hide data that is either too detailed, or irrelevant to the analysis.

The pivot table shows the dimensions Customer, Product Group, and Item Desc, and the measures
Quantity and Sales. In this view, you have a summary of quantity and sales for each customer. If you
want to know which items and product groups that the customers bought, you can expand the
customer fields by clicking . A icon indicates that a field can be further expanded and present

more details, while a icon indicates that the field can be collapsed, to reduce the number of
fields and details.

Scatter plot
The scatter plot presents pairs of values from two or three measures.

This is useful when you want to show data where each instance has two numbers, for example, the
relationship between Sales and Quantity per Customer. In the scatter plot below, a third measure
(Cost) is used to generate the bubble size.
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Scatter plot displaying the relationship between Sales and Quantity per Customer.

The scatter plot presents values from different measures over one dimension as a collection of
points. In most charts you find your dimension on one of the axes, but for a scatter plot, the
dimension is represented by the points in the chart and the measures are found on each of the two
axes. When a third, optional, measure is used, its value is reflected in the bubble size. If you are
analyzing large data sets and view compressed data, the density of the data points is reflected by
color.

When to use it
The scatter plot helps you find potential relationships between values, and to find outliers in data
sets. The scatter plot is useful when you want to show data where each instance has at least two
metrics, for example, average life expectancy and average gross domestic product per capita in
different countries.

Create apps and visualizations - Qlik Sense, November 2024 346



3   Visualizations

Advantages
The scatter plot is a great way to visualize the correlation of two or more measures at the same
time. The third measure is an efficient way of differentiating between values and simplifying the
identification of, for example, large countries, large customers, large quantities, and so on.

Disadvantages
The scatter plot may be difficult to understand for an inexperienced user, because it has measure
value on both axes, and the third, optional, measure adds complexity to the interpretation. Make
sure a novice can interpret the scatter plot correctly. Using descriptive labels is a good way to make
the visualization easier to interpret.

Values may be placed on top of each other and are then not visible until you zoom in.

Creating a scatter plot
You can create a scatter plot on the sheet you are editing.

In a scatter plot you need one dimension and at least two measures. You can have maximum one
dimension and three measures, where the third measure is visualized as bubble size.

Do the following:

1. From the assets panel, drag an empty scatter plot to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field.
4. Click Add measure and select a measure or create a measure from a field.
5. Optionally, if you want bubble size to be set according to a third measure:

Click Add measure and select a measure or create a measure from a field.

When you have created the scatter plot, you might want to adjust its appearance and other settings
in the properties panel.

Styling the scatter plot
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.
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The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
l Value label: Style the labels for the bubbles representing each dimension value.
l Legend title: Style the title of the legend.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.

Create apps and visualizations - Qlik Sense, November 2024 348



3   Visualizations

5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Display limitations

Large data sets in scatter plots
You can set the maximum number of visible bubbles in a scatter plot if you are using advanced edit
mode. Go to Presentation > Max visible bubbles. The default is 2,500. The maximum is 50,000. If
you set a number less than 1,000, the scatter plot will behave as if the maximum is 1,000 visible
bubbles.

If the number of displayed data points is less than Max visible bubbles, the data will be shown as
individual bubbles. If there are more data points than the number set in Max visible bubbles, you
will see an overview of your dataset as a table with colored boxes. This switch between
compressed view and bubble view is done automatically. If there are more than 5,000 visible
bubbles, then bubble labels and out of bound bubbles will not be shown.

Scatter plot with compressed data in a bubble view.

Zooming and panning
In a scatter plot, you can zoom and pan around in your data. The interaction differs depending on
what device you are using. If you are zooming in you can see where in the data set you are located
by looking at the mini chart in the bottom right corner. If you zoom in on large data sets you will be
able to see the data shown as boxes with values inside. The values represent the number of points
in each box.
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You cannot make selections when the scatter plot is rendering during a pan or zoom.

Zooming and panning is not possible when you have made a selection in the compressed data view.

You can change the compression resolution in the visual exploration menu or in the properties
panel.

Scatter plot with compressed data in a compressed view.

Colors and legends
Compressed scatter plots are always auto-colored by the primary data color. That means that any
custom color definition made will not affect compressed data. The density of the data points is
reflected by color. More dense data will be displayed in a darker color.

However, if you zoom or make selections so that the number of displayed data points is reduced to
less than Max visible bubbles, the data will be colored as defined.

When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.

Correlating two measures with a scatter plot to find outliers
This example shows how to make a scatter plot to correlate two measures. We want to
compare how the average sales volume correlates with the average margin for a group
of sales persons, and find the outliers.
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Dataset
In this example, we'll use two data files available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial, and the files are available in the Tutorials source folder:

l Sales.xls
l Sales rep.csv

To download the files, go to Tutorial - Building an App.

Add the two data files to an empty app and make sure that they are associated by Sales Rep ID -
Sales Rep Number.

The dataset that is loaded contains sales data. The Sales rep table holds the information about the
sales persons.

Measures
We need two measures that we create in Master items:

l AverageSales with the expression Avg(Sales). This is the average of the sales value for all
orders.

l AverageMargin with the expression Avg(Margin/Sales). This is the average of the sales
margin for all orders.
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Visualization
We add a scatter plot to the sheet and set the following data properties.

l Dimensions > Bubble: Sales Rep Name (sales person)
l Measures > X-axis: AverageSales
l Measures > Y-axis: AverageMargin

A scatter plot is created, with a bubble for each sales person.

But we also want to have information about the total sales for each sales person, by adding the
third measure Avg(Sales). The size of each bubble reflects the total sales for each sales person.

Discovery
The scatter plot visualizes the average sales versus average margin for each sales person, and we
can see which sales persons distinguish themselves in performance. You can hover the mouse
pointer over a sales person and view the details.

In the chart, we can see that Lee Chin has the highest average sale value. Stewart Wind has the
largest total sales volume, followed by Judy Thurman. Cheryle Sincock has a significantly smaller
average margin than other sales persons, while outperforming most of them in average sales
volume.
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Table
The table shows several fields simultaneously, where the content of each row is
logically connected. Typically, a table consists of one dimension and several measures.

You only make selections in the dimension columns. All dimension columns have a search icon in
the header.

When to use it
Use a table, when you want to view detailed data and precise values rather than visualizations of
values. Tables are good when you want to compare individual values. Drill-down group dimensions
are very efficient in tables. Within a limited space, you can drill down to the next level of detail and
analyze the updated measure values.

Advantages
You can filter and sort the table in different ways. Many values can be included in a table, and when
you drill down in a table, you make good use of the limited space on a sheet. A table is excellent
when you want to see exact values rather than trends or patterns.

Disadvantages
If the table contains many values, it is difficult to get an overview of how values are related. It is also
hard to identify an irregularity within the table.

Creating a table
You can create a new table on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty table to the sheet.
2. Click Add dimension and select a dimension or a field.
3. Click Add measure and select a measure or create a measure from a field.

Create apps and visualizations - Qlik Sense, November 2024 353



3   Visualizations

When you have created the table, you may want to adjust its appearance and other settings in the
properties panel.

Column width is automatically set to keep columns together for improved readability.
You can adjust the width of a column by dragging the header divider. Double-click the
header divider to reset to the default width.

Styling the table
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font size and color for the following text elements:
l Header: Style the text of the column headers.
l Content: Style the text of the table content. If you have selected to show a Totals row,

it will be styled using these settings, in addition to its text being bold.

Additionally, you can customize how the text appears when a user hovers over a row. See
Customizing the hover behavior and scrollbar (page 355).
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Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Setting the row height
You can adjust the height of the rows in the table.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab, under Row height (in lines), enter a positive integer value representing
how many originally sized rows should fit into one newly sized row, height-wise.

Customizing the hover behavior and scrollbar
You can set display options for when a user hovers over a row in the table. You can also set the
scrollbar size.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, under Row hover, adjust the following settings:
l To highlight rows in the table when a user hovers over them, set the switch to On.

Switch the behavior off according to preference.
l Row hover color: Set the color to highlight the row when a user hovers over it.
l Row hover font color: Set the color of the text in the highlighted row when a user

hovers over it.
4. Under Scrollbar size, set the size of the scrollbar in the chart (you can select Small, Medium,

or Large).

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Aligning data
If Text alignment is set to Auto, column data is aligned according to data type: text values are left-
aligned and number values, including date related values, are right-aligned. If you set it to Custom,
you can align the data to the left, center, or right.

Sorting the table
You can adjust the sorting of the table in several ways:

l Column sorting: adjust the order of the dimensions and measures from left to right
l Row sorting: adjust the sorting priority order of the rows
l Internal sorting: use the internal sorting order of dimensions and measures
l Interactive sorting: during analysis you can click on a column header to sort the table

Column sorting
By default, the order in which columns are sorted is set by the order in which dimensions and
measures are added to the table. If you add the measure Sales first, it is presented first (leftmost) in
the table. The next dimension or measure that is added is presented in the second column, and so
on. The column sorting order can be changed in the properties panel, under Columns.

Row sorting
By default, rows are sorted by the first added dimension or measure, numeric values descending,
text values ascending. A small arrow under the column header shows by which column the table is
sorted.

You can change the row sorting in the properties panel, under Sorting. Drag the dimensions and
measures to change the sorting priority order. In many cases, sorting is not only affected by the
first dimension or measure in Sorting, but also the following ones.

Example:

In the following screenshot, the rows are first sorted by Customer, then by Month, and then by
Product Type. As you can see, the columns Customer and Month have several rows with the same
values (A-2-Z Solutions and Month). The rows in Product Type are ordered alphabetically, but only
those that were sold in January to the customer A-2-Z Solutions are displayed.
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By changing the sorting order, so that secondary sorting is by Product Type, followed by Month, all
Product Type items sold to the customer A-2-Z Solutions are presented in alphabetical order,
whereas only the months when they were sold are displayed under Month.
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Internal sorting
Each dimension and measure has a default (Auto) internal sorting order, which can be changed.
Under Sorting, click the item you want to change and click the button to switch to Custom sorting.
Changes made to the internal sorting of an item may not have any effect if the sorting is in conflict
with an item with higher priority.

Interactive sorting
During analysis, you can set which column to sort on by clicking the column header. The first click
sorts the table according to the default sorting of the selected item. A second click reverses the
sorting order. Interactive sorting is session based and is not saved. If you want your changes to the
sorting to be persistent, you need to make the changes in the properties panel.

Displaying totals
By default, the totals of numeric values are displayed under the column names. In the properties
panel, you can change this to display the totals at the bottom of a column, or not at all.

Displaying more data
The chart can be configured to display more data, or to show it in different ways. Under
Appearance > Presentation in the properties panel, you can:
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l Freeze the first column from scrolling.
For app consumers who have Touch screen mode activated in the navigation menu, you
need to turn on Enable on touchscreen to support the freezing of the first column for these
consumers.

l Select to wrap multiline text in headers and cells separately.
l Turn off horizontal scrolling and turn on the column picker feature. This lets app consumers

change table column order.

Adding a trend indicator to a measure
You can add a trend indicator to a measure column. This will show a symbol next to the measure
value. You can define the ranges that determine which symbol is displayed and in which color it is
displayed. You enable the indicator by setting Representation to Indicator in the measure
properties.

Setting the indicator limits
You need to add the limits for the ranges you want to use for showing indicators with Add limit. You
can set a limit value in three ways.

l Use the slider.
l Type a value in the text box.
l Set an expression that returns the limit value.

When you have added the limits, you can select the color and the symbol of the indicator for each
defined range.

Styling the indicator
You can style the way the indicator is displayed.

l You can show both the indicator and the measure value by selecting Show values.
l You can set the value color to the same as the indicator color with Apply color to value.
l You can display the indicator to the right or to the left of the value with Indicator position.

Example
In this example, we added a trend indicator to the Sales measure to indicate which values are below
the target value. The indicator limits are:

l For values below 3000000 a red flag is displayed.
l For values in the range of 3000000 to 3500000 a yellow flag is displayed.
l For values above 3500000 a green check-mark is displayed.
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Adding a mini chart to a measure
You can add a mini chart to a measure column. This will show a small chart visualization instead of
the measure value. You can define the dimension that determines what data is displayed and in
which color it is displayed. You enable the indicator by setting Representation to Mini chart in the
measure properties.

The mini chart popup only shows the value of the measure, and is not broken down by
individual dimension point values.
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Setting the mini chart type
After specifying which dimension the mini chart will be based on, you must select a Mode.

l Bars creates a bar chart.
l Dots creates a dot chart.
l Sparkline creates a sparkline chart. You can show dots at each data point along the sparkline

chart by selecting Show dots.
l Positive/negative creates a chart with each value represented by a dot above or below the

zero.

When you have selected the mode, you can specify the Y-axis of the Mini chart at the bottom of the
mini chart options.

Styling the mini chart
You can set the color of bars or lines for Bars, Dots, and Sparkline.

l You can optionally set the Max value color and Min value color, which will highlight the
highest and lowest visible chart values.

l You can optionally set the Highlight first and Highlight last colors, which will highlight the
first and last visible chart values.

You can set the positive and negative color for a Positive/negative mini chart.

Display limitations

Number of rows and columns
In a table, you can have millions of rows and virtually any number of columns with dimensions and
measures. But because huge tables are impractical and hard to manage, the limit for what is
practical is far less than the theoretical maximum. In most cases, it is desirable to see all the
columns without scrolling horizontally.

Tables with content of mixed sizes
In a table you can have both columns where the content fits on one row within the cell, and columns
containing wrapped multiline text. In some cases you will see a shift in alignment and number of
rows when the multiline column is scrolled in and out of view. When the view only contains content
that fits on one row, the table will adjust and show all content on single line rows, which means
more rows are displayed.

We recommend that you disable multiline text wrapping in these cases to avoid confusion for the
user.

Searching in tables
In a table, you can search the dimension columns, and make selections in the resulting
list.

Do the following:
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1. Click in the dimension column that you want to search in.
A selection popup is displayed with a list of all values of the field. This includes values that
are excluded by selections. Excluded values are dark gray.

2. Type your search string. You can use any of the available search types. See Searching within
selections or visualizations.
While you type, the list is filtered to only display matching items.

3. Make a selection by clicking or drawing.
4. Confirm your selection.

You can confirm the selection of all matching items by pressing Enter.

The new selection is active and reflected in all associated visualizations.

You can remove the search string by clicking or pressing Esc. The search string is
always removed when you press Enter.

Selections in tables
You can make selections in a table by clicking or drawing in the dimension columns.

Measure values cannot be selected. When you make a selection, it is always the dimension values
that you select. You can only make selections in one column at a time.

Table with three selected fields in the dimension Customer.
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To deselect a row, click it. To confirm a selection, click or click outside the visualization. You can

also press Enter. To cancel, click or press Esc. If you confirm, the selection is reflected in all
visualizations associated with the table.

You cannot select dimension values that are null. Null values in a table are presented as dashes (-).
Rows without valid dimension values will not be included in the selection.

Accumulating values over a dimension in a table
This example shows how to use a table to compare data which accumulate over a
dimension.

Dataset
In this example, we will use a data file available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial. The file is available in the Tutorials source folder: Sales.xls

To download the file, go to Tutorial - Building an App.

Add the data file to an empty app. The dataset that is loaded contains sales data.

Measure
We use the sales volume as the measure that we create in Master items:

l Sales with the expression Sum(Sales). This is the sum of the sales volume.
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Visualization
We add a table to the sheet and set the following data properties:

l Dimension: Year (Date.Year).
l Dimension: Month (Date.Month).
l Measure: Sales; the measure that was previously created.

The following table is created, with columns showing the year, the month, and the sum of sales for
each month.

Make sure to set the Sorting with Year > Month > Sales.

Accumulation
To have our sales data accumulate over one dimension, we need to set an additional data property:

l Measure: Sales; the measure that was previously created.

We add this measure twice to reuse it for accumulation. To do this we need to apply a modifier to
our Sales measure.
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Do the following:

1. Under Measure: Sales set the Modifier to Accumulation. This will set the measure to
accumulate over one dimension.

2. Set the Modifier>Dimension to Month. This sets the dimension over which the accumulation
will take place.

3. Make sure Across all dimensions is turned off. We want the accumulation to restart at the
beginning of each year.

In Accumulation there is the option to select Show excluded values. When turned on,
your visualization includes any dimensional values that do not have data. This ensures
that all values, including months with no sales data, are counted in the accumulation.

Our table becomes as follows, with the last column showing sales accumulating from one month to
the next, for each year.

It is good practice to have the title of your charts represent their content. So consider changing the
titles of the columns of your table to reflect that the last column contains an accumulation of sales.

Our data for the year 2014 is insufficient as it stops at June. In order to achieve a better comparison
between the accumulated sales of all three years we will choose a more appropriate range of
months, from January to June.
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Do the following:

1. Click Done.
2. Select all months from January to June and confirm your selection.

Our table becomes as follows, with the sales accumulating from January to June, inside each year.

Discovery
The table shows the sales volume of each month, grouped into years. By having the sales
accumulate inside each year, we get a better understanding of the volume of sales for each year.
We have made a selection of the months from January to June, to compare the same range of
months between the three years. In the last column of the table we can see that the accumulated
sales for 2014 so far have been higher than the accumulated sales for 2012, but not as high as the
ones for 2013.

Using relative numbers in a table to calculate contribution
This example shows how to use the relative numbers modifier to calculate contribution
in a one dimensional table.
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Dataset
In this example, we will use a data file available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial. The file is available in the Tutorials source folder: Sales.xls

To download the file, go to Tutorial - Building an App.

Add the data file to an empty app. The dataset that is loaded contains sales data.

Measure
We use the sales volume as the measure that we create in Master items:

l Sales with the expression Sum(Sales). This is the sum of the sales volume.

Visualization
We start by adding a filter pane to the sheet and set the following data properties:

l Dimension: Product Group.

We also add a table to the sheet and set the following data properties:

l Dimension: Year (Date.Year).
l Measure: Sales; the measure that was previously created.

The following table is created, with columns showing the year, and the sum of sales for each year.

Make sure to set the Number formatting to Money, and the Format pattern to $ #,##0;-$ #,##0.

It is good practice to have the title of your charts represent their content. Additionally, consider
changing with the title of each column to reflect what it represents. The first column that we added
is the Year, and the second column contains the Sales per year.
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Relative numbers
We could use the filter pane to select specific product groups and see their yearly sales and their
total sales. That would not provide a good comparison to their contribution. Instead we will use
relative numbers to get percentages as an indication of the product group contribution. By
changing the parameters upon which the relative numbers calculation is based, we will get different
contributions and gain more insight.

Contribution of a year to the sales of product group
To see how much each year has contributed to the total sales of a specific product group when we
make a selection, we need to add a third column:

Do the following:

l In the properties panel right-click on Sales per year and select Duplicate.

To use this duplicate measure as a relative number we will apply a modifier.

Do the following:

1. Under Measure: Sales per year set the Modifier to Relative numbers. This will set the
measure to act as a relative number.

2. Set the Modifier>Selection scope to Current selection. This sets the modifier to be
calculated relative to any selection made.

3. The Modifier>Dimensional scope is set to Disregard dimension by default. This sets the
modifier to be calculated relative to the total.

4. Set the Number formatting to Custom, and the Format pattern to #,##0%.
5. Change the Label to something meaningful such as Contribution to total sales of current

selection.

Our table becomes as follows, with the last column showing the contribution of each year to the
total sales of the selected product group.

Contribution of a product group to total sales
To see how much each year's sales of a specific product group have contributed to the total sales
of all product groups, we need to add a fourth column:
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Do the following:

l In the properties panel right-click on Contribution to total sales of current selection and
select Duplicate.

We will apply the Relative numbers modifier again, but with different properties this time.

Do the following:

1. Set the Modifier>Selection scope to Disregard selection. This sets the modifier to be
calculated disregarding any selection made.

2. The Modifier>Dimensional scope is already set to Disregard dimension. This sets the
modifier to be calculated relative to the total.

3. Change the Label to something meaningful such as Contribution to total sales from all years.

The Number formatting and the Format pattern are already set, since we duplicated the previous
measure.

Our table becomes as follows, with the last column showing the contribution of the selected
product group to the total sales from all three years.

Since we have not made any selections yet, the last two columns have the same values.

Contribution of a product group to yearly sales
To see how much the sales of a specific product group have contributed to that year's sales
compared to all the other product groups, we need to add a fifth column:

Do the following:

l In the properties panel right-click on Contribution to total sales from all years and select
Duplicate.

We will apply the Relative numbers modifier again, but with different properties this time.

Do the following:

1. Set the Modifier>Selection scope to Disregard selection. This sets the modifier to be
calculated disregarding any selection made.
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2. The Modifier>Dimensional scope is already set to Respect dimension. This sets the
modifier to be calculated relative to each dimensional value.

3. Change the Label to something meaningful such as Contribution to sales of each year.

Our table becomes as follows, with the last column showing the contribution of the selected
product group to the total sales from all three years.

Since we have not made any selections yet, the last column shows the yearly contribution of all
product groups for each year.

Making a selection
We can now start making selections to change our relative numbers to something that provides
more insight.

Do the following:

1. Click Done editing in the toolbar.

2. Select Canned Products from the product group filter pane.

Our table becomes as follows.

Discovery
The table shows the relative sales for each year. By having the different contribution columns, using
the relative numbers as a measure modifier, we get a better understanding of the contribution of
each product group to the total sales. From the Contribution to total sales of current selection
column we can see that 40% of the Canned Product sales happened in 2012, with a dramatic drop in
2014. The Contribution to total sales from all years column shows that 8% of the total sales from all
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three years came from the 2012 sales of Canned Product. The Contribution to sales of each year
column also tells us that for 2012 the Canned Product sales contributed 21% of the sales of that
year, and the same applies to the sales of 2014.

Text & image
The text & image visualization complements other visualizations by offering options to
add text, images, hyperlinks, and measures.

You can format and color the text and align the paragraphs. The background image has sizing and
positioning options. You can also set the responsive behavior for text and images.

The text & image visualization is only available in the advanced edit mode.

When to use it
The text & image visualization is intended for presentation purposes, and does not support
selections. However, the measures in the text & image visualization are updated when selections
are made. Some typical uses:

l Use it on the first sheet of an app for essential information.
l Display a company image, or use a background image together with formatted text and

measure values to present figures in a compelling way.
l Link to sites with additional information.
l Use the responsive behavior to ensure that the visualization renders well on all devices.

Advantages
The text & image visualization contrasts with the other visualizations. You have many options for
making the text & image visualization stand out next to more regular charts.

Disadvantages
You are limited to a few measure values and rather short texts, otherwise the text & image
visualization will be cluttered.

Creating a text & image
You can create a text & image visualization on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty text & image chart to the sheet.
2. Click the text & image chart to open the editing toolbar.
3. Add and format text, images, hyperlinks or measures to the text & image chart.
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If you double-click a text & image chart in the assets panel, it is added to the sheet
immediately.

Styling the text & image
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
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When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

In a text & image object, you can also set a background image outside of the styling panel. Setting a
background image in this way will not exclude or negate any background modifications you have
made in the above procedure.

Do the following:

1. In the properties panel, expand the Appearance section.
2. Under Background image, toggle on Use background image.
3. Add an image from your media library. You can select from a number of size and position

options.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Editing a text & image
In the text & image visualization you can add and format text, images, measures, and links in various
ways.

When you are editing a sheet and the text & image visualization does not have focus, you need to
click twice to open the editing toolbar. In the editing toolbar, you can format text properties such as
color, size, and style, and also align the text. Additionally, you have options for adding links and
images.

Creating a link
You can mark a text section and use it for a link.

If you do not add a prefix, http:// is added automatically, assuming that you are adding a web
address.

Do the following:
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1. Select the text section that you want to use for the link.

2. Click in the editing toolbar to open the link dialog.

3. Enter the web address that you want to link to.

4. Click .

Removing a link
You can remove a link from a text section.

Do the following:

1. Click the link so that the cursor is somewhere inside it.

2. Click in the editing toolbar to open the link dialog.

3. Click .

The link is removed, but not the text.

Adding an image
You can add an image through the editing toolbar. You can use one of the default images, or an
image of your own.

Do the following:

1. Click in the editing toolbar.
The Media library opens.
The following formats are supported: .png, .jpg, .jpeg, and .gif.
For Qlik Sense: You can upload images to the In app folder in the media library. You need to
use the Qlik Management Console to upload images to the default folder.
For Qlik Sense Desktop: You can place images in the following folder on your computer:
C:\Users\<user>\Documents\Qlik\Sense\Content\Default. Images will be available in the
default folder in the media library. When moving an app between installations, the images
that you use in the app are saved in the qvf file together with the app. When you open the
app in a new location, the images will be in the In app folder in the media library for the app.

2. Click on a folder in the media library, for example In app or Default.
3. Select the image that you want to add.
4. Click Insert.

Alternatively, right-click the image file you want to add and select Insert.

In the properties panel, you can add a background image, which, for example, can be
used when you want to insert text in the image. The images added through the editing
toolbar are not background images.

Adding a measure
You can add a measure in the following ways:
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l By dragging a field from the assets panel and adding it as a measure.
l By dragging a measure from Master items.
l By adding a measure (existing or new) from the properties panel.

When you are editing the measure, it is displayed as a token, which can be styled and moved
around in the visualization. You can also apply number formatting to it. When you leave the editor,
the measure value is displayed . Values that cannot be aggregated are shown as a hyphen (-).

Deleting a measure
You can delete a measure in the following ways:

l Place the cursor before the token and press Delete.
l Place the cursor after the token and press Backspace.
l In the properties panel, right-click the measure and select Delete in the dialog.
l In the properties panel, click the measure and click Delete .

Treemap
Treemaps display hierarchical data by using nested rectangles, that is, smaller
rectangles within a larger rectangle.

In this image you have several product groups, such as Produce, Canned Products, and Frozen
Foods. Each product group consists of a large rectangle. You can regard the product groups as
branches of the tree. When you select a product group, you drill down to the next level, the product
type, for example, Vegetables, Meat, and Dairy. You can regard the product types as sub-branches
of the tree. The branches have leaves. A leaf node's rectangle has an area proportional to a
specified dimension of the data. In this example, the items Ebony Squash, Bravo Large Canned
Shrimp, Red Spade Pimento Loaf, and so on, are the leaves. The leaf nodes are colored to show a
separate dimension of the data.
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Sorting is automatic according to size. By default, the coloring is by dimension, with 12 colors, but
that can be changed in the properties panel. When you have more than one dimension, you can
decide which dimension to color by. In this example, the coloring is not by dimension, but by
expression (Avg(Margin)), a calculated measure and by using this expression, you can see which
items have the highest average margin. The darker the color, the higher the average margin.

If the data set contains negative values, a text message is shown stating that the negative values
cannot be displayed.

When to use it
Use a treemap when space is constrained and you have a large amount of hierarchical data that you
need to get an overview of. Treemaps should primarily be used with values that can be aggregated.

Advantages
Treemaps are economical in that they can be used within a limited space and yet display a large
number of items simultaneously.

When there is a correlation between color and size in the tree structure, you are able to see
patterns that would be difficult to spot in other ways, for example, when a certain color is
particularly relevant.

Disadvantages
Treemaps are not good when there is a big difference in the magnitude of the measure values. Nor
is a treemap the right choice when mixing absolute and relative values.

Negative values cannot be displayed in treemaps.
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Creating a treemap
You can create a treemap on the sheet you are editing.

Do the following:

1. From the assets panel, drag an empty treemap to the sheet.
2. Click Add dimension and select a dimension or a field. This should be the highest level in the

hierarchy. It will be displayed as the main group in the chart.
3. Click Add measure and select a measure or create a measure from a field. The measure will

define the size of a rectangle.
4. Add more dimensions in the order of hierarchy level . The last dimension you add defines the

rectangles. The other dimensions define the grouping of the rectangles.

In a treemap you need at least one dimension and one measure, but to make full use of the treemap
it is preferable to have two or three dimensions. You can only have one measure, but up to 15
dimensions. We do not recommend using more than three dimensions as the treemap may become
unmanageable.

When you have created the treemap, you may want to adjust its appearance and other settings in
the properties panel.

Styling the treemap
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and any other applicable properties for the following
text elements:

l Header labels: Style the header labels. You can customize the font, font size, and
color.

l Leaf labels: Style the labels for the leaf elements.
l Legend title: Style the title of the legend. You can customize the font, font size, and

color.
l Legend labels: Style the labels of the individual legend items. You can customize the

font, font size, and color.

Customizing the background
You can customize the general background and the background of the header area. The general
background can be set by color and image, while the background of the header area can be set to a
single color.

In the styling panel, you can configure background options.

Setting the general background
The general background of the chart includes the title area, as well as the chart itself, which might
be partially covered by the header.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Setting the header background
The header area is a branch-like frame surrounding the hierarchy of rectangles when two or more
dimensions are added to the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the Chart tab of the styling panel, select a background color under Header background
color.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Display limitations

Large amounts of data
When displaying large amounts of data in a treemap, there may be cases when not each dimension
value within a rectangle is displayed with correct color and size. These remaining values will instead
be displayed as a gray, striped area. The size and total value of the rectangle will still be correct, but
not all dimension values in the rectangle will be explicit.

To remove the gray areas, you can either make a selection or use dimension limits in the properties
panel.

Colors and legend
When coloring by dimension is used in this chart, a maximum of 100 unique dimension values and
100 unique colors can be plotted on the legend.

Displaying hierarchical data with a treemap
This example shows how to make a treemap to view hierarchical data. You can display
a large number of values in limited space and detect patterns that could be hard to
spot with other charts.

We will look at sales numbers for different products which are categorized in four levels.

l Product group
l Product sub group
l Product item
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Dataset
In this example, we'll use two data files available in the Qlik Sense Tutorial - Building an App.
Download and expand the tutorial, and the files are available in the Tutorials source folder:

l Sales.xlsx
l Item master.xlsx

To download the files, go to Tutorial - Building an App.

Add the two data files to an empty app and make sure that they are associated by Item Number.

The dataset that is loaded contains sales data for food and beverage products. The Item Master
table holds the information about the product categories.

Visualization
We add a treemap to the sheet and set the following dimensions and measures.

l Dimensions > Group: Product Group (product group)
l Dimensions > Group: Product Sub Group (product sub group)
l Dimensions > Rectangle: Item Desc (product item description)
l Measures > Size: Sum(Sales) (sum of sales)

A treemap is created, with a rectangle for each product item. Rectangles are sized according to
sales and grouped according to Product Group and Product Sub Group.
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But we also want to add some more information to the chart. The rectangles are colored by the
product group dimension, but we want to color them by margin to also see which items are most
profitable. You can do this in Appearance > Colors and legend.

l Set Colors to Custom.
l Set Color by measure to Avg(Margin/Sales)

We also want to see the sales values in the chart. You can turn them on with Value labels
Appearance > Presentation.

Discovery

We can see in the chart that Produce has the largest sales, followed by Canned Products. The
coloring by margin allows you to identify product items or groups that stand out. You can drill down
in the tree by selecting a product group.
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Here we have selected Produce, then Fresh Fruit. Tell Tale Red Delicious Apples are the number
one sellers, but margins are higher on Ebony Red Delicious Apples.

Waterfall chart
The waterfall chart is suitable for illustrating how an initial value is affected by
intermediate positive and negative values. The starting and the final values are
represented by whole bars, and intermediate values by floating bars. You can also
show subtotals in the chart.
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Waterfall chart displaying Sales, Sales cost, and Sales margin.
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When to use it
The waterfall chart is suitable for illustrating how an initial value is affected by intermediate positive
and negative values. One example of this is an income statement, when you want to show the
positive and negative contributions of different accounts.

Advantages
The waterfall chart provides a quick understanding of the transition of a value.

Disadvantages
The waterfall chart is not relevant for detailed analysis of the data as you can't make selections in
the chart or expand the data.

Creating a waterfall chart
You can create a waterfall chart on the sheet you are editing.

In a waterfall chart you need to use one measure for each bar in the chart. The order of the
measures defines the order of the bars in the chart. For each measure, you need to define how it
affects the previous value. You can add up to 15 measures in a waterfall chart.

Do the following:

1. From the assets panel, drag an empty waterfall chart to the sheet.
2. Add the first measure.

This is the first bar of the chart. By default, it will use the measure operation Add, and show a
positive value.

3. Add a second measure.
This is the second bar of the chart. If you want to show this measure as a negative
contribution, change Measure operation to Subtract.

4. Continue to add measures, setting Measure operation to Add or Subtract in the advanced
properties panel depending on how you want them to contribute.

5. Add subtotals. There are two ways of adding subtotal bars to the chart:
l If you have a data field containing subtotal data, add a measure with the subtotal data

and select Subtotals as Measure operation.
l If you don't have a data field containing subtotal data, you can add an automatically

calculated subtotal by selecting the Subtotals check box of the measure before where
you want the subtotal bar.

When you have created the waterfall chart, you may want to adjust its appearance and other
settings in the properties panel.

Defining your measures
You can use the Measure operation option of each measure to set how it affects the previous
value.
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l Add
The measure value adds to the previous bar. If this is the first measure, a whole bar is shown
starting at 0.

l Subtract
The measure value subtracts from the previous bar.

If the data already contains a negative sign, the result of subtraction will be a
positive change.

l Subtotals
The measure value is considered a subtotal.

If you do not have sub-totals as a field, you can add subtotals automatically by
enabling Subtotals in the measure before you want the subtotal.

In the waterfall chart shown above, the first bar, Sales, is defined as Add. The second bar, Sales
cost, is defined as Subtract, and the third bar, Sales margin, is defined as Subtotals.

Styling the waterfall chart
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:
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l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis label: Style the labels on the axes.
l Value label: Style the labels for the measure values.
l Legend labels: Style the labels of the individual legend items.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Visualizing positive and negative contributions to the result with a waterfall
chart
This example shows how to make a waterfall chart to visualize how positive and
negative values contribute to the final result.

We want to see the positive contributions to CO2 in the atmosphere, such as oil or gas, in relation to
negative factors, such as land sink.
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Dataset
In this example, we will use a simple dataset that you can copy to a text file to use as data source. It
contains the atmosphere CO2 level in ppm from 1870, as well as the positive and negative
contributors to CO2 in the atmosphere in the time between 1870 and 2017.

Atmosphere 1870,Coal,Oil,Gas,Cement,Land,Imbalance,Land sink,Ocean sink,Atmosphere 2017

288,94,72,31,5,88,-12,-89,-72,405

(Source: CDIAC/GCP/NOAA-ESRL/UNFCCC/BP/USGS)

Add the text file as data source in an empty app and load the data. Make sure that you use comma
as field delimiter.

Visualization
We add a waterfall chart to the sheet and add the fields as measures in the following order. Edit the
label for each measure to remove the Sum() part.

l Sum(Atmosphere1870)
l Sum(Coal)
l Sum(Oil)
l Sum(Gas)
l Sum(Cement)
l Sum(Land)
l Sum(Imbalance)
l Sum(Land_sink)
l Sum(Ocean_sink)
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To add a bar that shows the calculated result, the CO2 level for 2017, open the final measure and
select Subtotals. You can set Subtotal label to Atmosphere 2017.

Discovery
.As you can see in the chart, the CO2 level in the atmosphere is higher in 2017 than in 1870. Coal is
the main contributor of CO2. Some of the increase is offset by carbon sinks that absorb CO2, for
example, the ocean. As we can see, this is unfortunately not enough to stop the increase of CO2 in
the atmosphere

Button
You can use buttons to:

l add quick links for easy selection and navigation in your app
l reload data

When to use it
The button is useful when you want to help the app user by providing:

l predefined selections or selection controls
l navigation links to other sheets, stories, or websites
l reload data functionality in an app

You can reload data in an app that you own. App users need the appropriate access rights.
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Example of buttons in use on a sheet

Creating a button
You can create a button on the sheet you are editing. This shows how to create a button that makes
a selection and then navigates to another sheet. It is also possible to create a button that just
performs the action, or that navigates.

Do the following:

1. In the Assets panel under Charts, drag a Button object to the sheet.
2. Click Add action under Actions in the properties panel.
3. Select the action you want to use.

For some actions you need to provide details for the action. For example, for the Select
values in a field action, you need to select a field, and which value to select in the field.

4. Select which navigation option to use under Navigation. You can navigate to another sheet,
a story or a website.

5. Set the label of the button in Label under General in the properties panel.

You will now have a button that makes a data selection and then navigates to the place in the app
you selected.

Setting the action
You can add one or more actions to be performed when the button is clicked. For some actions you
need to provide details for the action.

The actions are performed in the order they are listed under Actions. You can change the order of
an action by dragging it.
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Toggle Runtime evaluation on or off to change when the expressions in the button are evaluated. If
this setting is turned off, the expressions in the button (for example, the value expression for a
variable) are evaluated independently of one another. With the setting turned on, the expressions
for each action are evaluated at the action's runtime. This allows expression values set in an action
to be carried forward for future actions in the chain.

You do not have to add an action if you just want the button to perform navigation.

Related video content
Configuring an action for a button is similar to setting sheet actions. The main differences are:

l Sheet actions are configured under Actions in the properties panel when the sheet is the
object in focus.

l Button actions are configured under Actions and navigation in the properties panel when
the button is selected.

l There are some differences between which actions are available for buttons and sheets.

For video content describing the action configurations for sheets, see Adding actions to sheets
(page 20).

Apply bookmark
You can apply the selection that is defined in a bookmark that you choose.

Clear all selections
You can clear all selections in all states in the app. You can optionally overwrite locked selections.

Clear selections in other fields
You can clear selections from all fields except the one you specify. You can optionally overwrite
locked selections.

If no selections are made in the specified field, all values in this field will be selected.

Move forwards in your selections
You can move one step forwards in your selection history.

Move backwards in your selections
You can move one step backwards in your selection history.

Clear selections in field
You can clear all selections from a field that you specify.

Lock all selections
You can lock all selections in the app.

Lock a specific field
You can lock selections in a field that you specify.
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Unlock all selections
You can unlock all selections in the app.

Unlock a specific field
You can unlock selections in a field that you specify.

Select all values in a field
You can select all values in a field that you specify. You can optionally overwrite locked selections.

Select values in a field
You can select a list of values in a field that you specify. Separate the values to select with a semi
colon. You can optionally overwrite locked selections.

It is not possible to use fields with date, timestamp, or money data type.

This button action does not select numeric values that are stored or classified as text.
For this purpose, use the Select values matching search criteria action instead.

Select values matching search criteria
You can select all values that match the search results from a search criteria that you specify. You
need to specify the search criteria as a string. You can optionally overwrite locked selections.

l If you want to use an expression, you need to enclose it in single quotes, for example,
='=Sum([Sales Amount]) > 200000'.

l If you want to search for a partial string, you need to use wild cards (*, ?,^). If you do not use
wild cards, only strings that match exactly are selected.

Select alternatives
Select all alternative values in a field that you specify. You can optionally overwrite locked
selections.

Step cyclic dimension
Cycle fields in a selected cyclic dimension forward or backward.

Limitations
Step cyclic dimension has the following limitations:

l In Qlik Sense Mobile, buttons with the action Step cyclic dimension will only cycle dimension
if the button is in a container.

l In Qlik Sense Mobile, buttons with the action Step cyclic dimension do not cycle the
dimension in offline mode.
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Set active field
Set the active field in a cyclic dimension.

Limitations
Set active field has the following limitations:

l Set active field uses the position of the selected field in the cyclic dimension. If the fields are
reordered in the cyclic dimension, Set active field will use the field in the same position as
the originally selected field. To resolve this, select the field again in the button properties.

Select excluded
Select all excluded values in a field that you specify. You can optionally overwrite locked selections.

Select possible values in a field
Select all possible values in a field that you specify. You can optionally overwrite locked selections.

Toggle field selection
You can set the button to toggle between the current selection, and a selection that adds selections
defined by a search string. You can use wild cards in the search string. If you want to define a list of
values you need to use the format (A|B), where A and B are values to select.

Set variable value
You can assign a value to a variable.

Reload data
You can run the load script to reload data.

You can also select Partial reload.
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Refresh dynamic views
Refreshes the displays of all dynamic objects on the sheet based on the current selection.

Navigation
You can choose to navigate to another sheet, a story, or a website when the button is clicked. You
do not have to specify an action if you want to create a simple navigation button. A button can only
have one navigation option at a time.

Navigation is not supported in stories.

Go to next sheet
Navigate to the next sheet sequentially.

Go to previous sheet
Navigate to the previous sheet sequentially.

Go to last sheet
Navigate to the last sheet.

Go to first sheet
Navigate to the first sheet.

Go to a sheet
Navigate to a specific sheet, and optionally highlight a specific chart on the sheet.

Under Sheet, enter the name of the desired sheet or select it from the list. Under Chart ID, enter the
object ID for the chart or select the desired chart from the list.

You can obtain the object ID with either of the following methods:

l Add /options/developer to your URL. Next, right-click the chart and click
Developer.

l For certain chart types, you can use the ObjectId chart function. For example, add
=ObjectId() as a dimension along with any measure. The chart ID is displayed and
you can write it down for future reference. For more information, see ObjectId -
chart function.

Go to a sheet defined by sheet ID
Navigate to a specific sheet. Enter the sheet ID of the desired sheet. You can find the ID of a sheet
in the URL of the browser with the sheet open. The sheet ID follows after /sheet/ followed by /.

Example: Sheet URL

qlik.com/sense/app/8f8ffa0e-3fde-48a5-a127-59645923a1fc/sheet/7300b241-f221-43db-bb8b-

8c8cc1887531/state/analysis
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The ID of the sheet is 7300b241-f221-43db-bb8b-8c8cc1887531 in this example.

Go to a story
Navigate to a specific story. Enter the name of the desired story, or select it from the list.

Open a website or email
Open a specified website or email client. Enter the URL to navigate to. Optionally, select Open in
same window to have the website or email client open in the same window.

Generate on-demand app
Creates an on-demand app based on the current selection. You must select an on-demand app
navigation link . The status of the app is displayed as the app is created.

Styling the button
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Adding an icon
You can add an icon to the button under Appearance > Icon. Choose from a number of preset
options.

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, switch the Show titles setting to off.

Additionally, you can set the text for the button Label.

You can style the text that appears in the chart.

Do the following:

1. Under Appearance > Presentation, click Styling.

2. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

3. On the Chart tab, set the text properties for the button Label. Set the font, emphasis style,
text alignment, font size, and color.
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You can also choose from a number of text layout options for this label under Layout
behavior. The following options are available:

l Responsive: You can adjust the font size of the Label, with additional text size
adjustments applied based on button size and text length. Adjustments are made to fit
all text content into the button.

l Fluid: You can adjust the font size of the Label, with additional text size adjustments
applied based on button size only. This re-scaling of the text is independent of text
length. If the text is too long, an ellipsis is inserted at the end.

l Fixed: You can adjust the font size of the Label in pixels. If the text is too long, an
ellipsis is inserted at the end.

Customizing the background
You can customize the general background, as well as the background of the button itself. The
background of each can be set by color and image. Background options can be configured by
expanding Appearance > Presentation in the properties panel, then clicking Styling.

Setting the general background
The general background of the button includes the title area, as well as the chart itself, which is
partially covered by the button itself.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Setting the background of the button
The background of the button includes the portion that the user can click to execute the action.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, you can select a background color (single color or
expression), and also set the background to an image from your media library.
When using a background image, you can adjust image sizing and position.

Adjusting the border of the interactive portion of the button
You can adjust the border of the part of the button the user interacts with to perform intended
action.
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Do the following:

1. Under Appearance > Presentation, click Styling.

2. On the Chart tab, under Border, switch the border On to display it on the button.
3. Adjust the corner radius and width.
4. Set the color of the border, either a single color or with an expression.

Customizing the border and shadow of the entire object
You can customize the border and shadow of the entire object in which the button is located. Note
that you can also adjust the border of the clickable button itself.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Disabling and enabling the button
You can set a calculation condition to enable the chart under Enable chart. If the condition is
evaluated to 0, the button is disabled.

Converting from the Button for navigation in the Dashboard bundle
You can convert an existing Button for navigation control into a button. There are some limitations
when you do the conversion.

l The navigation option to switch to edit mode (Switch to edit mode) is not supported.
l The action to select a value and then lock the field (Select a value and lock field) is not

supported. This will be converted into two consecutive actions, Select values in a field and
Lock a specific field.

Tab container
The tab container is an object that lets you add visualizations in a limited space. You
can also show or hide the visualizations inside the tab container based on conditions.

The tab container replaces the previous container. The container is available from the
Dashboard bundle. For more information, see Container (page 416).
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When to use it
The tab container is useful when you want to quickly switch between different visualizations on a
dashboard with limited space. You can also use a tab container to show different visualizations
based on:

l Which user is accessing the chart.
l The value of a variable.
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l The possible number of values in a field by using the GetPossibleCount() function in the
condition expression.
Displaying different charts based on selections with a tab container (page 401)

Creating a tab container
You can create a tab container on the sheet you are editing.

Do the following:

1. From the assets panel, drag a Tab container object to the sheet.
2. Click Add under Content in the properties panel.
3. Select a master visualization in Master items, or create a new visualization in Charts.

Alternatively: you can add content to your tab container by dragging available visualizations
from your sheet, or from your Master items, directly on the tab container.

4. Drag the charts in the property panel to set the tab order.

You now have a container with a tab for each visualization you added. You can switch between tabs
to show different visualizations.

Adding show conditions
You can add show conditions on the tabs you have created.

Do the following:

1. Click on the chart you want to add a show condition to, under Content in the property panel.
2. Add a show condition for the chart in Show condition. Typically you would use an If()

function.
3. Add another show condition to a different chart.

The charts will now be shown or hidden depending on the result of the conditions you added.
If the condition of a chart results in True, it is shown, and if it is False, it is hidden.

Changing the tab orientation
Tabs can be orientated vertically or horizontally.

Do the following:

1. Go to Appearance > Presentation in the property panel.
2. Under Orientation, select the position of tabs in the tab container.

Changing the default active tab
By default, the first tab is displayed when you view a tab container. You can change this in the
property panel.
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Do the following:

1. Go to Appearance > Presentation in the property panel.
2. Use the Default tab dropdown to select which chart displays when users view a sheet. The

dropdown lists the available charts in the same order they are arranged in the container.
3. If you want to see the new default tab setting take effect, close and re-open your browser.

Styling the tab container
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Tab tab, set the font, font size, and color for the following text elements:
l Label: Style the labels on the axes.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Under Border, set the border outline and corner radius.

Adding a shadow

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Under Shadow, set the shadow size and color.

Setting tab width

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Click Tabs.
4. Under Width, set the width to be in percentage or pixels.
5. Under Min/Max, set the maximum and minimum sizes of the tabs.

Setting the selected tab indicator color

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Click Tabs.
4. Under Indicator, select to use a single color or color by expression.
5. If using a single color, select a color.
6. If using an expression, enter an expression.

Styling icons
If you turn on Show icons, you can style the icons.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Click Tabs.
4. Under Icon, set the size, color, and position of chart icons.

Customizing tab background colors

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. Click Tabs.
4. Under Background color, select the colors for tabs, selected tabs, and when tabs are being

hovered over. You can color by a single selected color or by expression.

Creating a bookmark with a tab container
By default, if you create a bookmark that contains a tab container object with selections, the first
tab will be active when the bookmark is selected. To save a different default active tab for the tab
container, you can toggle on Save layout when creating the bookmark with that tab open. If you set
that bookmark as the default bookmark by right-clicking and selecting Set as default bookmark in
the bookmark list, the sheet will open to the selections and tab that were active when the bookmark
was created.

Do the following:

1. Click in the toolbar.

2. Click Create new bookmark.
Change the name and description, if desired.

3. If you want a tab other than the default tab to be the active tab, toggle on Save layout with
that tab open. This will override the Default tab setting in the property panel.

4. Click Save.

Display limitations
l You cannot use a master visualization that has a tab container inside another container.
l You cannot add the same master visualization twice in a tab container.
l You cannot create a chart inside a tab container by dropping measures or dimensions on the

container.

Displaying different charts based on selections with a tab container
This example shows how to display different chart content based on user selections
using a tab container.
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l When a single product group is selected a chart for product sub groups is displayed.
l When more than one product group is selected a chart for product groups is displayed.

Dataset
In this example, we will use two data files from the Qlik Sense Tutorial - Building an App. To
download the files, go to Tutorial - Building an App. Download and unzip the tutorial, and find the
files in the Tutorials source folder:

l Sales.xls
l Item master.xls

Create a new app and add the two data files. Make sure that they are associated by Item Number.

The dataset that is loaded contains sales data. The Item master table holds the information about
the items ordered, such as product groups.

Measures
We need to create two measures in Master items:

l Sales volume: with the name Sales, and the expression Sum(Sales).
l Sales margin in percent: with the name Margin %, and the expression Avg(Margin/Sales)*100.

Visualizations
We need two different master visualizations based on product group selections. One of them with
product group as dimension, the other with product sub group as dimension.

Product group visualization
This is the visualization we want to show when more than one product group is selected.

We add a combo chart to the sheet and set the following data properties:

l Dimension: Product Group (product group).
l Measure: Sales (the master measure you created).

The following chart is created, with a bar showing the sales for each product group. It is a bar chart
at this stage.
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But we also want to show the sales margin, which has a different scale than the sales volume. Sales
volume is in the scale of millions, while the margin is a percentage between 0 and 100. If we add
margin as a bar next to sales volume, it would be too small to distinguish.

In the properties pane, go to Measures > Height of line. Use the drop down to add Margin % as a
measure.

Product sub group visualization
This is the visualization we want to show when a single product group is selected.

Make a copy of the product group visualization, and change the dimension to Product Sub Group.
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Master visualizations
You need to create two master visualizations to use in the tab container.

l Add the product group visualization as a master visualization with name Product Group -
sales and margin.

l Add the product sub group visualization as a master visualization with name Product Sub
Group - sales and margin

You can now delete the two visualizations you created earlier, they are saved as master
visualizations.

Tab container
You need to add a tab container to the sheet. Add the two visualizations to the tab container.

l Product Group - sales and margin
Set Show condition to =GetPossibleCount([Product Group])>1

l Product Sub Group - sales and margin
Set Show condition to =GetPossibleCount([Product Group])=1

You can also hide the selection tabs of the tab container under Appearance>Container>Tabs.

To demonstrate how it works, you can add a filter pane with Product Group.

Discovery
You can now make selections in Product Group. When a single product group is selected, the chart
displays data for product sub groups of that product group. Otherwise, the chart displays data for
product groups.

Reference lines
A reference line is a line intersecting the chart area from a given point on the measure
axis.

For information about how to create reference lines, see Adding reference lines to visualizations
(page 599).
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You can use a reference line to indicate a certain level of chart data. The reference line is only
drawn if it falls within the current range of the measure axis. You can have several reference lines in
the same chart.

Bar chart Top 5 customers with a reference line at 5M.

Reference lines are available in the following visualization types:

l Bar chart
l Box plot
l Combo chart
l Distribution plot
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l Gauge
l Histogram
l Line chart
l Scatter plot
l Waterfall chart

Reference line expression
You can either set the reference line expression to an absolute numeric value, or enter an arbitrary
numeric expression.

Dimensional reference lines
You can also add reference lines along the dimension axis. Both continuous and discrete axes are
supported. It is possible to enter text values for discrete dimensional axes, and numerical values or
expressions for continuous axes. On a time axis it is possible to enter an expression that gives a
time-based result like a date or a month.
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Line chart average sales per month, with a reference line at 3.5k and a dimensional reference line in
September.

Dimensional reference lines are available in the following visualization types:

l Bar chart
l Combo chart
l Line chart

Creating custom tooltips
Create a custom tooltip to add extra information to a visualization. You can include
measures a master visualization chart or an image. Tooltips display when you hover
over a visualization.
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Custom tooltip over a pie chart slice
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Custom tooltips are available with the following visualization types:

l Bar chart
l Bullet chart
l Combo chart
l KPI
l Line chart
l Map
l Pie chart
l Scatter plot
l Treemap

Creating a custom tooltip
Tooltips can contain measures, a chart, or an image. Add a measure from a field or using an
expression. Select a chart from the master visualizations available in the app. Choose an image
from the media library or by URL. You can also hide the basic rows that appear in a tooltip by
default.

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Select the chart to edit.
3. In the properties panel, click Appearance, and then click Tooltip.
4. Set the toggle to Custom.
5. Optionally, enter a Title and Description for the tooltip.

Click to use the expression editor if you need to add more than 512 characters.

You can remove basic tooltip rows that appear by default by clicking Hide basic
rows.

6. If you want to add a measure, under Measures, click Add measure. Select a measure from a
field using From a field, or use an expression. The existing expression displays by default, or
you can create a custom expression. Click to open the expression editor. You can change
the label of the tooltip using Label as well as its formatting using Number formatting.

7. If you want to add a chart, under Chart, click Add chart.
l From the Master items list, select the master visualization to add to the tooltip.
l Under Chart size, select the size of the chart container in the tooltip.

l Small. Sets the width and height of the container to 140 pixels.
l Medium. Sets the width and height of the container to 200 pixels.
l Large. Sets the width and height of the container to 340 pixels.
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After you add the chart, you can edit it by clicking Edit master item. See
Editing a master visualization (page 118).

8. If you want to add an image, under Images, Click Add an image.
l  Under Type, select whether to add the image from your Media library or from a URL.

l Media library: Select the image from the media library.
l URL: Enter a URL.

l Under Size, select the size of the image container in the tooltip.
l Small. Sets the width and height of the container to 50 pixels.
l Medium. Sets the width and height of the container to 200 pixels.
l Large. Sets the width and height of the container to 340 pixels.
l Original. Qlik Sense fits the image into the container. If the image is larger than

340 pixels, it is scaled down.

Limitations
Custom tooltips have the following general limitations:

l Custom tooltips are disabled for a bar or line chart if any of the dimensions in the chart are
using a show condition.

Limitations of charts in custom tooltips
Charts have the following limitations with custom tooltips:

l Charts will not appear in custom tooltips when selecting visualizations on touch devices.
l Treemap chart must have only one dimension to use the chart in a custom tooltip.
l Chart in tooltip is not supported in Storytelling.
l Using container and trellis container charts inside a custom tooltip is not supported.

Null values in visualizations
Data is sometimes missing or cannot be calculated, because the fields contain values that are null
or not a number (NaN). In the visualizations null and NaN values are displayed in different ways,
according to the following table.

Visualization
type

Null values in
dimensions

NaN values in measures

Bar chart – – ( when labels are enabled in the properties panel,
otherwise empty)

Box plot – No representation

Combo chart – A combination of the NaN value for the bar and the
line.

How Null and NaN values are displayed
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Visualization
type

Null values in
dimensions

NaN values in measures

Distribution plot – No representation

Filter pane No representation N/A

Gauge N/A –

Histogram – No representation

KPI N/A –

Line chart – Empty

Map No representation Gray

Pie chart – Empty

Scatter plot – Empty

Table – –

Text & image N/A –

Treemap – Empty

Dashboard bundle
Dashboard bundle is a set of controls that you can use to enhance navigation and
selection in your Qlik Sense app. The controls are optional. You do not have to install or
enable them to use Qlik Sense.

Enabling Dashboard bundle
You can install the Dashboard bundle when you install Qlik Sense. If you need to adjust your
installation, see: Modifying an object bundles installation.

Dashboard bundle controls
Dashboard controls are in the asset panel under Custom objects.

The following controls are included:

l Animator (page 414)
You can animate changes in your visualizations over a period of time.

l Container (page 416)
Add multiple visualizations to a container to save space.

l Date range picker (page 422)
You can select a single date or a range of dates from a calendar.

l Layout containers allow you to add visualizations in a limited space. You can also show or
hide the visualizations inside the layout container based on conditions. (page 429)
Add and arrange visualizations in a container.

l Add lines to your sheets with the Line control. (page 425)
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Add vertical and horizontal lines to a sheet.
l On-Demand reporting control (page 432)

You can add a button that creates a Qlik NPrinting report using the current selections in the
app.

l Text objects complements other visualizations by offering options to add text, hyperlinks,
and measures. You can also add background images. (page 437)
A text object allows app developers to create and format text.

l Variable input control (page 440)
You can set the value of a variable.

l Video player (page 443)
You can add a video to your sheet.

Deprecated controls
These controls have been deprecated by the addition of a native control. Unless otherwise stated,
existing instances of these controls will still function. However, new instances cannot be added. We
recommend that you replace deprecated controls with the native control.

Share button control
If you need to configure existing instances of this control, please refer to the last version of the help
before deprecation.

Show/hide container
Deprecated by Container.

If you need to configure existing instances of this control, please refer to the last version of the help
before deprecation.

Tabbed container
Deprecated by Tab container.

If you need to configure existing instances of this control, please refer to the last version of the help
before deprecation.

Navigation button
Deprecated by Button.

If you need to configure existing instances of this control, please refer to the last version of the help
before deprecation.

NL Insights
Deprecated by native NL insights object. Existing instances may need to be migrated manually.

Limitations
When you use objects from Dashboard bundle there are some limitations compared to built-in
controls. The following limitations are valid for all controls from Dashboard bundle:
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l The user interface of the visualization is not localized to the language that Qlik Sense is
using.

l Right-to-left reading order is not supported.
l Accessibility features are not supported.
l It is not possible to edit objects from an object bundle supplied by Qlik with Dev Hub.

The following table shows which additional features are supported, or not supported, for all
bundled objects:

l Qlik NPrinting
There is an On-Demand reporting control (page 432). However, visualizations made in some
objects cannot be used in Qlik NPrinting reports.
On-Demand reporting control is not supported on mobile devices. An On-Demand reporting
control button only works when accessed through a personal computer.

l Download
Downloading as image, PDF, or Excel.

l Storytelling
Using a snapshot of a visualization created with an object in a story.

l Alternate states
Making different selections on the same dimension and comparing the selections in a single
visualization or in two or more visualizations side by side.

l Qlik Sense Client-Managed Mobile offline

Control
Qlik
NPrinting

Download Storytelling
Alternate
states

Qlik Sense Client-
Managed Mobile
offline

Animator Not
applicable

Excel only Not applicable Yes Yes

Date picker Not
applicable

Not
applicable

Not applicable Yes Yes

Layout
container

Yes Image and
PDF only

Yes Yes Not applicable

Line Not
applicable

Image and
PDF only

Yes Yes Yes

On-demand
reporting

Yes Not
applicable

Not applicable Not
applicable

Not applicable

Text Yes Yes Yes Yes Yes

Variable
input

Not
applicable

Not
applicable

Not applicable Not
applicable

Yes

Video player Not
applicable

Not
applicable

Yes Yes Not applicable

Dashboard bundle capability support

Create apps and visualizations - Qlik Sense, November 2024 413



3   Visualizations

Animator
The animator control animates the changes in values in your visualizations over a range
of values. For example, you could view changes in your visualizations over a period of
time. It is included in the Dashboard bundle.

The animator control adds a button and progress slider to the sheet. When pressed, animator
cycles through the values of its dimension. Users can use the slider to manually pick values from
the dimension to display.

Animator

When to use it
The animator is useful when you want to see your visualizations change over a specified range,
such as over a period of time. For example, you could use the animator control to view how
visualizations in your sheet change month to month over a period of a year. Animator can be used
to animate any dimension values. You could, for example, animate how your sales visualizations
change city to city by selecting a dimension containing city vales to use with animator.

The selections animator makes while running through values are applied to your current selections.

Creating animators
You can create an animator on the sheet you are editing. The dimension you select to use with
animator contains the range of values you want animated. By default, every value in the dimension
will be used as a step. You can customize the number of steps used in the animation as well as how
quickly animator moves between steps. Animator runs through dimension values by the order in
Sorting.

Do the following:

1. In the assets panel, open Custom objects > Dashboard bundle and drag a Animator object
to the sheet.

2. Select a field to add as the dimension.

Once you have created the animator, you may want to adjust its animation options and other
settings.

Setting animator options
Animator options are set in Animator Options in the Properties pane.
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You can control how fast an animator transitions between values in the selected dimension in Time
Between Steps. Time Between Steps requires values be set in milliseconds.

It is not recommended to set Time Between Steps lower than 300 milliseconds.

You can set the total steps the animator runs through in Total Steps. The animator will divide the
total steps evenly across the dimension values. For example, if there are 10 values in the time
dimension selected and Total Steps is set to 5, animator will go to values 2, 4, 6, 8, 10). If Total
Steps is set to 0, the animator will use every value.

If you want the animation to show the total building over time for your selected values, select
Aggregate. When Aggregate is selected, each step is aggregated to the previous step.

By default, the animator will run through steps in a loop. You can control this with the Loop option.

You can control whether or not the dimension and current value displays in the animator as it runs
with Show Dimension Label and Show Dimension Value.

Customizing styling
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote
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Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
Animator has the following limitations:

l Animator does not support drill-down dimensions as the dimension.
l Animator does not support animating trellis charts.

Container
The container is an object that lets you add visualizations in a limited space. You can
also show or hide the visualizations inside the container based on conditions.

The container has been replaced by the tab container. For more information,
see Tab container (page 396).
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When to use it
The container is useful when you want to quickly switch between different visualizations on a
dashboard with limited space. You can also use a container to show different visualizations based
on:

l Which user is accessing the chart.
l The value of a variable.
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l The possible number of values in a field by using the GetPossibleCount() function in the
condition expression.
Displaying different charts based on selections with a tab container (page 401)

Creating a container
You can create a container on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Dashboard bundle and drag a Container object
to the sheet.

2. Click Add under Content in the properties panel.
3. Select a master visualization in Master items, or create a new visualization in Charts.

Alternatively: you can add content to your container by dragging available visualizations from
your sheet, or from your Master items, directly on the container.

4. Drag the charts in the property panel to set the tab order.

You now have a container with a tab for each visualization you added. You can switch between tabs
to show different visualizations.

Adding show conditions
You can add show conditions on the tabs you have created.

Do the following:

1. Click on the chart you want to add a show condition to, under Content in the property panel.
2. Add a show condition for the chart in Show condition. Typically you would use an If()

function.
3. Add another show condition to a different chart.

The charts will now be shown or hidden depending on the result of the conditions you added.
If the condition of a chart results in True, it is shown, and if it is False, it is hidden.

Changing the default active tab
By default, the first tab is displayed when you view a container. You can change this in the property
panel.

Do the following:

1. Go to Appearance > Container in the property panel.
2. Use the Default tab dropdown to select which chart displays when users view a sheet. The

dropdown lists the available charts in the same order they are arranged in the container.
3. If you want to see the new default tab setting take effect, close and re-open your browser.
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Creating a bookmark with a container object
By default, if you create a bookmark that contains a container object with selections, the first tab
will be active when the bookmark is selected. To save a different default active tab for the
container, you can toggle on Save layout when creating the bookmark with that tab open. If you set
that bookmark as the default bookmark by right-clicking and selecting Set as default bookmark in
the bookmark list, the sheet will open to the selections and tab that were active when the bookmark
was created.

Do the following:

1. Click in the toolbar.

2. Click Create new bookmark.
Change the name and description, if desired.

3. If you want a tab other than the default tab to be the active tab, toggle on Save layout with
that tab open. This will override the Default tab setting in the property panel.

4. Click Save.

Display limitations
l You cannot use a master visualization that has a container inside another container.
l You cannot add the same master visualization twice in a container.
l You cannot create a chart inside a container by dropping measures or dimensions on the

container.

Displaying different charts based on selections with a container
This example shows how to display different chart content based on user selections
using a container.

l When a single product group is selected a chart for product sub groups is displayed.
l When more than one product group is selected a chart for product groups is displayed.

Dataset
In this example, we will use two data files from the Qlik Sense Tutorial - Building an App. To
download the files, go to Tutorial - Building an App. Download and unzip the tutorial, and find the
files in the Tutorials source folder:

l Sales.xls
l Item master.xls

Create a new app and add the two data files. Make sure that they are associated by Item Number.

The dataset that is loaded contains sales data. The Item master table holds the information about
the items ordered, such as product groups.

Measures
We need to create two measures in Master items:
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l Sales volume: with the name Sales, and the expression Sum(Sales).
l Sales margin in percent: with the name Margin %, and the expression Avg(Margin/Sales)*100.

Visualizations
We need two different master visualizations based on product group selections. One of them with
product group as dimension, the other with product sub group as dimension.

Product group visualization
This is the visualization we want to show when more than one product group is selected.

We add a combo chart to the sheet and set the following data properties:

l Dimension: Product Group (product group).
l Measure: Sales (the master measure you created).

The following chart is created, with a bar showing the sales for each product group. It is a bar chart
at this stage.

But we also want to show the sales margin, which has a different scale than the sales volume. Sales
volume is in the scale of millions, while the margin is a percentage between 0 and 100. If we add
margin as a bar next to sales volume, it would be too small to distinguish.

In the properties pane, go to Measures > Height of line. Use the drop down to add Margin % as a
measure.
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Product sub group visualization
This is the visualization we want to show when a single product group is selected.

Make a copy of the product group visualization, and change the dimension to Product Sub Group.

Master visualizations
You need to create two master visualizations to use in the container.

l Add the product group visualization as a master visualization with name Product Group -
sales and margin.

l Add the product sub group visualization as a master visualization with name Product Sub
Group - sales and margin

You can now delete the two visualizations you created earlier, they are saved as master
visualizations.

Container
You need to add a container to the sheet. Add the two visualizations to the container.

l Product Group - sales and margin
Set Show condition to =GetPossibleCount([Product Group])>1

l Product Sub Group - sales and margin
Set Show condition to =GetPossibleCount([Product Group])=1

You can also hide the selection tabs of the container under Appearance>Container>Tabs.

To demonstrate how it works, you can add a filter pane with Product Group.
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Discovery
You can now make selections in Product Group. When a single product group is selected, the chart
displays data for product sub groups of that product group. Otherwise, the chart displays data for
product groups.

Date range picker
The date range picker (Date picker) lets you select a single date or a range of dates
from a calendar. It is included in Dashboard bundle.

Date picker has two modes:

l In single date mode, you select from a simple calendar.
l In date interval mode, you can select a range from the calendar, or any of the predefined

ranges that are available.

Dates associated to data appear in black in the calendar. Dates with no associated data appear in
grey. Users can select any date.

When to use it
The date range picker is useful when you have one or more date fields that you need to use to filter
your selections. Unlike a filter pane, a date range picker will only display date fields.

Creating a date range picker
You can create a date range picker on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Dashboard bundle and drag a Date picker
object to the sheet.

2. Select the date field to use as filter in Date field.
The list contains only fields that are recognized as a date field by Qlik Sense.

If you want to use a timestamp field, you need to convert it to a date. Use the
expression =date(floor(myTimeStamp_Field)) instead of myTimeStamp_Field.

3. Select if you want to be able to pick a single date or a date interval in Single date / interval.
Date interval lets you pick a range of dates.
Single date lets you pick a single date only.

When you have created the date range picker, you may want to adjust its appearance and other
settings.

Setting the available date range
You can set the range of dates available to pick by setting the option Advanced setup to On. You
can use expressions or explicit date values. The expressions used below refer to a field named
DateField.
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l Set the first date of the calendar with Min date.
Default value is =Min( {1} [DateField]). This expression returns the first date in DateField in
the full data set.

l Set the last date of the calendar with Max date.
Default value is =Max( {1} [DateField]). This expression returns the last date in DateField in
the full data set.

l Set the date to show when the date range picker is opened with Start date.
Default value is =Min([DateField]). This expression returns the first date in DateField in the
current selection.

Setting locale of the calendar
You can set the locale of the calendar to get local names for days and months. Change the setting
Locale under Calendar Settings > Language and labels to the two-letter code of the locale you
want to use. For example, you can change the default value of en for English to de for German.

Using predefined ranges
In date interval mode there are a number of predefined ranges available to pick if Show predefined
ranges is set to On. You can customize the text labels for the predefined range selections with the
settings under Calendar Settings > Predefined ranges:

l Custom Range represents the option where you select a date interval freely from the
calendar. Default value is Range.

l Today represents the date value of today. Default value is Today.
l Yesterday represents the date value of yesterday. Default value is Yesterday.
l Last $ days represents the two options for showing the last 7 or 30 days. $ is replaced by 7

or 30 in the string. Default value is Last $ days.
l This represents the current period. By default Month is selected. You can select:

l Day
l Month
l Quarter
l Year
l None

l Last represents the previous period. By default Month is selected. You can select:
l Day
l Month
l Quarter
l Year
l None

You can specify how many of the previous periods to include in Last number of.
You can include the current period by selecting Include current.

Customizing text labels
You can customize the text labels that are shown when the date range picker is used.
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You change the text prompt shown when the date range picker is minimized with the setting
Default Text under Calendar Settings > Language and labels. The default setting is 'Select date
range'.

Customizing styling
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
The date range picker cannot filter date ranges greater than 28 years or that contain 10,000 or
more values. If your date range contains a large number of dates, use another object such as a line
chart.

For information about general limitations, see Limitations (page 412).

Date format limitations
Dates in the format YYYYMMDD cannot be used in the date range picker. If your app has date
values in this format, change the date format in the load script. Examples are shown below.

Examples: Transforming dates for compatibility with date range picker
For the example script below, consider the following:

l original_date is the original date field in YYYYMMDD format.
l new_date1, new_date2, and new_date3 are updated date fields that will be in compatible date

formats.
l original_table is the table in which the original_date field was loaded (not shown). For the

purposes of the example showing a complete LOAD statement, we perform the
transformation on this existing field by using a RESIDENT load. However, your own data can
be loaded in many different ways depending on your use case.

SET DateFormat='M/D/YYYY';

Load

Date(Date#(original_date, 'YYYYMMDD'),'YYYY/MM/DD') as new_date1,

Date(Date#(original_date, 'YYYYMMDD')) as new_date2,

Date(Date#(original_date, 'YYYYMMDD'),'YYYY-MM-DD') as new_date3

RESIDENT original_table;

Line
Add lines to your sheets with the Line control.
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With Line controls, you can add vertical and horizontal lines to your sheets. They can be dotted or
solid.

Line in a sheet dividing visualizations
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When to use it
The Line control is useful for helping to group or divide sheet objects, as well as decorating sheets
to help improve visual appeal.

Creating lines

Do the following:

1. In the advanced edit mode assets panel, open Custom objects > Dashboard bundle and
drag Line to the sheet.

2. Adjust the Line on the grid.
3. In the properties panel, in Presentation under Orientation, select Vertical or Horizontal.
4. Under Alignment, select:

1. Leading: Line is placed to the left (vertical orientation) or top (horizontal orientation) of
Line on the grid.

2. Center: Line is placed in the center of Line on the grid.
3. Trailing: Line is placed to the right or bottom of Line on the grid.

5. Under Stroke, set the following line styling options.
l Color: Select the color of the line.
l Width: Set the width of the line.
l Dash: Set whether the line is solid or dashed. If the line is dashed, the following

options are available:
l Dash length: Set the length of dashes in the line.
l Dash spacing: Set the gap between dashes in the line.

6. Optionally, to add a title, subtitle, or footnote, under General, select Show titles.

Styling Line controls
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General tab. You can reset your styles by
clicking next to each section.

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
Line has the following limitations:

l You cannot connect the lines in separate Line controls together. If you want to have
intersecting lines in your sheet, consider using a background image with the lines on the
sheet instead.
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Layout container
Layout containers allow you to add visualizations in a limited space. You can also show
or hide the visualizations inside the layout container based on conditions.

Layout container

A layout container can hold a range of visualizations while occupying a small amount of space on a
sheet. When expanded to full sheet, each chart expands as well.

When to use it
The layout container is useful when you want to build a custom display containing multiple charts as
a single unit. Unlike the container, which uses tabs to cycle through charts, the layout container is a
space where you are free to customize your own layout of the charts in the layout container. As the
layout container offers sheet-like arrangement of visualizations, you can functionally store multiple
sheets within a sheet that can be expanded for more detail.

You can place visualizations on top of one another. You can use conditions in the layout container
to control which visualizations display. For example, you could show visualizations based on:

l Which user is accessing the chart.
l The value of a variable.

As a best practice, be aware the more visualizations that are added to a container, the longer is can
take to display visualizations. Too may objects in a layout container might overwhelm the user and
make the app slower to render visualizations.
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Creating a container
You can create a container on the sheet you are editing.

Do the following:

l In the advanced edit mode assets panel, open Custom objects > Dashboard bundle and
drag Layout container to the sheet.

You now have a layout container. You can start adding and configuring charts to your layout
container.

Adding charts to a layout container

You can copy and paste charts in and out of the layout container, but you must use the
right-click context menu.

Do the following:

1. Select a layout container.
2. Click Add under Content in the properties panel.

Alternatively, click Add content in the layout container.
3. Select a visualization in Charts.
4. Click Add dimension and Add measure to add data to the chart.
5. To resize the chart, do one of the following:

l Click and drag the corners or edge of the chart.
l In properties, enter the width and height of the chart in percent.

6. To reposition the chart, do one of the following:
l Click and drag the chart into position.
l In properties, enter the x-axis and y-axis positions of the chart, in percent.

To show grid lines for layout, in properties, under Presentation > Styling, turn on Show grid
lines. You can also set the number of rows and columns in the grid, and snap visualizations to
the grid lines.
To keep charts within the borders of the layout container, under Presentation > Styling, turn
on Keep charts within bounds.

7. To reorder the layers of visualizations in the layout container, right-click on the visualization
in the layout container, select Reorder chat layers, and choose to bring the visualization
forward or back. Alternatively, click and drag the visualizations in the properties panel.

8. To configure the chart with all properties available for that chart type, click Edit properties.
9. Repeat for any additional charts you want to add to the layout container.

Adding show conditions
You can add show conditions on the tabs you have created.
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Do the following:

1. Click on the chart you want to add a show condition to, under Content in the property panel.
2. Add a show condition for the chart in Show condition. Typically you would use an If()

function.
3. Add another show condition to a different chart.

The charts will now be shown or hidden depending on the result of the conditions you added.
If the condition of a chart results in True, it is shown, and if it is False, it is hidden.

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
Layout containers have the following limitations:

l You cannot create a chart inside a layout container by dropping measures or dimensions on
the container.

l You cannot add a container, trellis container, or layout container inside a layout container.
l Keyboard shortcuts are not supported for copying and pasting charts in a layout container.

On-Demand reporting control
The On-Demand reporting control adds a button to create Qlik NPrinting reports on
demand. It is included in Dashboard bundle.

Requirements
l Qlik NPrinting Server (September 2019 or later) with a Qlik NPrinting app that is connected to

the Qlik Sense app that you are designing. This Qlik NPrinting app contains your report
templates.

l All users generating On-Demand reports need to be added as users in Qlik NPrinting, with a
security role that supports running On-Demand reports.

l Users must be logged into Qlik Sense via NTML (Windows) authentication in order to
generate reports or create reporting buttons.

When to use it
The On-Demand reporting control is useful when you want the user to be able to print predefined
Qlik NPrinting reports within Qlik Sense, using their selections in the app as a filter.

Installing the Dashboard bundle
You can install the Dashboard bundle when you install Qlik Sense.

You can add or remove object bundles from your Qlik Sense deployment at any moment. If you
have a multi-node installation, object bundles are installed on the central node.
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You can see which extensions are installed in your deployment by checking the
Extensions section in the Qlik Management Console (QMC).

Do the following:

1. In Windows Control Panel, open Programs and Features.
2. In the list of programs, double-click the object bundle that you want to modify.

3. The Object Bundle Setup Wizard opens. Click Next.
4. Select Change.
5. On the Custom setup screen, click on the bundle icon to select how to modify the bundle

installation:
o If the bundle is installed, select Entire feature will be unavailable to uninstall it.
o If the bundle is not installed, select Entire feature will be installed on local hard

drive to install it.
Then, click Next.

6. Click Change.
Once the modification if complete, you are required to manually restart the Qlik Sense
Repository Service.

7. Click Finish to close the Object Bundle Setup Wizard.
8. Manually restart the Qlik Sense Repository Service to apply the changes.

You can verify that the changes have been correctly applied by checking the Extensions section in
the QMC.

Adding a server as a trusted origin
If you are creating On-Demand reports in Qlik Sense or a QlikView Web Server hosted QlikView
AccessPoint, you must add these servers as a trusted origin in Qlik NPrinting web console.

For each server path used to access the Qlik NPrinting web console, you must add a trusted origin.
For example, if your server can be accessed through a local domain, a shortened host, or fully
qualified URLs, a trusted origin must be added for each of those server paths.
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How you enter the server paths in the Address field of the trusted origin depends on your security
configuration.

Configuration 1: SSL security not setup with Qlik NPrinting web console
A trusted origin is required for each server path used to log onto the Qlik NPrinting web console. For
example, if your server is qlikserver1 and has an IP address of 192.168.0.101, you would add the
following trusted origins:

l http://qlikserver1
l http://qlikserver1.domain.local
l http://192.168.0.101

Configuration 2: SSL security setup with Qlik NPrinting web console and third-party
A trusted origin is required for each server path used to log onto the Qlik NPrinting web console.
URLs must use HTTPS. For example, if your server is qlikserver1 and has an IP address of
192.168.0.101, you would add the following trusted origins:

l https://qlikserver1
l https://qlikserver1.domain.local
l https://192.168.0.101

Adding a trusted origin
Do the following:

1. In Qlik NPrinting, click Admin > Settings.
2. Click On-Demand Settings.
3. Click Add trusted origin.
4. After Name, enter a name for the trusted origin.
5. After Description, enter a description for the trusted origin.
6. After Address, enter the URL for the QlikView Server.

The URL must be the base URL (scheme and host) only. For example, http://qlikserver1
rather than http://qlikserver1/qlikview/index.htm.

7. Click Create.

Configuring On-Demand settings on Qlik NPrinting Server
You must configure these settings on your Qlik NPrinting Server:

l You must have a connection to a QlikView Server or a Qlik Sense server.
QlikView Server and QlikView Cluster connections are supported with On-Demand. Local
connections are not supported. See: Creating connections.

l If you are connecting to a QlikView Server or Cluster with a QlikView Server Extranet License,
the following options must be enabled when configuring the connection:

o Connection requires authentication
o Apply user section access for reports

l You must enable your Qlik NPrinting reports for On-Demand.
l You can limit On-Demand report creation through security roles. See: Role based security.
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On-Demand is compatible with Chrome, Firefox, and Explorer. It will not run in Microsoft
Edge, because the certificates will not download.

Enabling Qlik NPrinting reports for On-Demand creation
Qlik NPrinting reports must be manually enabled for On-Demand creation. Reports must be
assigned to the QlikView document or Qlik Sense app with which you want to generate On-Demand
reports. On-Demand creation can be enabled during the creation of a new report.

Do the following:

1. In Qlik NPrinting web console, click Reports.
2. Open a report or create a new report.
3. Select an app from the App drop-down list is connected to the QlikView document or Qlik

Sense app for which you want to generate a report.

On-Demand requests only work with reports based on a single connection.
MultiDoc reports are not supported.

4. Select the Enable On-Demand check box.
5. Click Save.

The report template is now available.

Accepting the Qlik NPrinting web console certificate
The default installation certificate for Qlik NPrinting web console may be registered as invalid by
your browser. If your browser registers the Qlik NPrinting web console certificate as invalid, you
must accept the certificate before you can use On-Demand in QlikView AccessPoint or Qlik Sense.

If you switch to a different browser or clear your browser’s cache, you will have to re-
accept the Qlik NPrinting certificate. On-Demand works in Chrome, Firefox, and
Explorer. It does not run in Microsoft Edge, because the certificates will not download.

Do the following:

1. Open the Qlik NPrinting web console.
2. Depending on your browser, do one of the following:

l Choose to continue to the Qlik NPrinting web console.
l Add a security exception and continue to the Qlik NPrinting web console.

3. Log into your Qlik NPrinting web console.

You can now use Qlik NPrintingOn-Demand using this browser.

Creating an On-Demand reporting button
You can create an On-Demand reporting button on the sheet you are editing.
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Do the following:

1. From the assets panel, under Custom objects > Dashboard bundle drag On-demand
reporting to the sheet.

2. In the property panel, under NPrinting Connection > NPrinting server URL, set the server
connection. The URL must end with /.
For example: https://<server name>:4993/

3. Under NPrinting App, select the Qlik NPrinting app that contains the report template.
4. Under NPrinting connection, select the Qlik NPrinting connection.

As the default, the list only shows Qlik NPrinting connections to the Qlik Sense app you are
working in. You can use the App/Connection filter toggle to display connections not
associated with the current Qlik Sense app.

5. Under Report Configuration > Choose Report, select the report you want to connect to the
button.

6. In Default Export Format, select a default export format.
7. Under Appearances > Button Label, set the button label. For example: Generate report.

You have now created an On-Demand reporting button.

Generating a report
You can generate a report that is filtered according to the current selections in the Qlik Sense app.
You need to be in analysis mode.

You can only filter on fields that are included in the Qlik NPrinting report template, or the
report will fail. It is not possible to filter on selections using an expression.

Do the following:

1. Click on the button that you created.
The Export dialog opens.

2. There are two buttons to choose from:
a. Quick Report: generates a single report with the default output format.
b. New Report: choose from a list of reports that have been made available to you. You

can also choose the output format.
3. When the report is generated a download button is activated. Click the Download button to

download the report.

Limitations
For information about general limitations, see Limitations (page 412).

App selections and set analysis
When you generate a report using the On-Demand reporting control, only the possible values from
the combination of all current selections are sent to Qlik NPrinting. As a result, any selected
excluded values are not included. This can lead to unexpected results when chart or report
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elements use set expressions or refer to the default state using alternate states.

Additionally, if the Qlik NPrinting report template contains a filter, it is not possible to make
conflicting selections in the Qlik Sense app, or the report will fail.

Other limitations
l If the Qlik NPrinting report template contains a filter, it is not possible to make conflicting

selections in the Qlik Sense app, or the report will fail.
l When you use the On-Demand reporting control in a mashup, you need to use Windows

authentication. Header authentication is not supported.
Additionally, if the mashup contains multiple apps, you can only use the app where on-
demand originates from to filter on-demand reports.

l On-Demand reporting control is not supported on mobile devices. An On-Demand reporting
control button only works when accessed through a personal computer.

Text
Text objects complements other visualizations by offering options to add text,
hyperlinks, and measures. You can also add background images.

You can format and color the text and align the paragraphs. The background image has sizing and
positioning options.

Text is only available in the advanced edit mode.

When to use it
Text is intended for presentation purposes, and does not support selections. However, the
measures in Text are updated when selections are made. Some typical uses:

l Use it on the first sheet of an app for essential information.
l Display a company image as a background image together with formatted text and measure

values to present figures in a compelling way.
l Link to sites with additional information.

Advantages
Text contrasts with the other visualizations. You have many options for making Text stand out next
to more regular charts.

Disadvantages
When organizing content within the chart, it is advised to use only a few measure values and
shorter texts. Otherwise, Text will be cluttered.

Creating Text objects
You can create a Text on the sheet you are editing.

Create apps and visualizations - Qlik Sense, November 2024 437



3   Visualizations

Do the following:

1. In the advanced edit mode, drag an empty Text to the sheet from the assets panel.
2. Click Text to open the editing toolbar.
3. Add and format text, tables, hyperlinks or measures to Text.

If you double-click a Text in the assets panel, it is added to the sheet immediately.

Styling and formatting text in Text
Text offers several editing and formatting options for text. You can format your text using several
styles:

l Paragraph
l Quote
l Heading 1
l Heading 2
l Heading 3
l Unordered list
l Ordered list

You can also select font families and size. You can apply emphases to your text and change text
color. You can also add hyperlinks.

Styling and formatting tables in the Text
You can insert tables into Text from the toolbar. You can resize column and rows and hide borders.
You can insert additional tables inside table cells.

Styling Text
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs. You can reset your
styles by clicking next to each section. Clicking Reset all resets styles for all available tabs in
the styling panel.

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

You can style the text that appears in the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Creating a link
You can mark a text section and use it for a link.

Do the following:
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1. Select the text section that you want to use for the link.

2. Click in the editing toolbar to open the link dialog.

3. Enter the web address that you want to link to.

4. Click .

Removing a link
You can remove a link from a text section.

Do the following:

1. Click the link so that the cursor is somewhere inside it.

2. Click in the editing toolbar to open the link dialog.

3. Click .

The link is removed, but not the text.

Adding a measure
You can add a measure in the following ways:

l By dragging a field from the assets panel and adding it as a measure.
l By dragging a measure from Master items.
l By adding a measure (existing or new) from the properties panel.

When you are editing the measure, it is displayed as a value with a grey background, which can be
styled and moved around in the visualization. You can also apply number formatting to it. When you
leave the editor, the measure value is displayed . Values that cannot be aggregated are shown as a
hyphen (-).

Deleting a measure
You can delete a measure in the following ways:

l Place the cursor before the token and press Delete.
l Place the cursor after the token and press Backspace.
l In the properties panel, right-click the measure and select Delete in the dialog.
l In the properties panel, click the measure and click Delete .

Limitations
You can add a maximum of 10 measures to this chart.

Variable input control
You can use the variable input control to set the value of a variable. It is included in
Dashboard bundle.
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When to use it
If you have visualizations with expressions that contain a variable, you can use the variable input
control to let the user control the variable value.

Creating a variable input control
You can create a variable input control on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Dashboard bundle and drag a Variable input
object to the sheet.

2. Select the variable to use in Name under Appearance > Variable in the property panel.
3. Select how you want to input data in Show as:

l Buttons lets you add a number of buttons with one button for each defined variable
value.
You can select how to display the buttons in Display, select Row to show them in a
horizontal row or Column to show them in a vertical column.
You can define the buttons in two different ways, fixed (Fixed) or (dynamic) Dynamic
with the Fixed or dynamic values setting under Values.
If you select to use fixed values, you need to add each button with Add Alternative
and define a value (Value) and a label (Label) for each button.
If you use dynamic values, you define the buttons with a string in Dynamic values.Use
| to separate buttons, and ~ to separate value from label. For example,
'Germany~GER|France~FRA' will create two buttons labelled GER and FRA. The first
will change the variable value to Germany, and the second changes the value to
France. You do not need to specify labels if you want to use values as labels.

l Drop down adds a drop down with one item for each defined variable value.
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You can define the items in two different ways, fixed (Fixed) or (dynamic) Dynamic
with the Fixed or dynamic values setting under Values.
If you select to use fixed values, you need to add each item with Add Alternative and
define a value (Value) and a label (Label) for each item.
If you use dynamic values, you define the items with a string in Dynamic values.Use |
to separate items, and ~ to separate value from label. For example,
'Germany~GER|France~FRA' will create two items labelled GER and FRA. The first will
change the variable value to Germany, and the second changes the value to France.
You do not need to specify labels if you want to use values as labels.

l Input box provides a simple input box that will update the variable value.
l Slider creates a slider that updates the variable value. You define the minimum setting

with Min and the maximum setting with Max under Values. You can also set the step
to use with Step. If you select Slider label, the selected value is displayed when you
drag the slider.
The variable value is updated when you stop dragging the slider, but you can select
Update on drag if you want the variable value to be updated while you drag. This can
be useful when you want visualizations based on the variable to update dynamically
when dragging the slider. Use this option with caution, as the constant redrawing of
charts can be annoying.

Customizing styling
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

Create apps and visualizations - Qlik Sense, November 2024 442



3   Visualizations

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 412).

l The slider label can only display numeric values. This means, if the value is a date the
numeric value of the date is displayed. If the value is a percentage value, the percentage
character is not displayed.

Video player
The video player lets you play videos in different formats from external sources. It is
included in the Dashboard bundle.

The following video formats are supported.

l MP4
l OGG
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l WEBM
l YouTube

Video player
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When to use it
The video player is useful when you want to include a video in your application. For example, you
want to show a demo or a training video, add a tutorial, or present corporate news.

Adding videos
You can add video player object to a sheet that you are editing. Add or paste a video link into the
video object. The video is streamed from a source; it is not uploaded to Qlik Sense. By default, the
video format of the link will be auto-detected, the video will not auto-play, and video controls will be
available to app consumers.

Do the following:

1. In the assets panel, open Custom objects > Dashboard bundle and drag a Video player
object to the sheet, or click Add to Sheet.

2. Add a video as a URL in the video player object field Add URL, or in the properties panel
under Video > URL. You can format the URL field as an expression.

3. Autodetect format is default setting and it will adjust accordingly based on the URL. You can
also turn off Autodetect, and then select the correct supported video format.

Once you have added the video, you may want to adjust its options.

Setting video options
Video options are set in the Properties pane.

Click Auto play if you want the video to automatically start when viewed in analyzer mode. Auto
play is turned off by default. When Auto play is selected, the video starts but it is muted. The app
user has to select Unmute to turn the sound on.

Click Hide Controls to turn off video controls in analyzer mode. By default, video controls are
visible.

You can add a Poster image. By default, the poster image is turned off. For Source, select an
external URL that directs to an image, or add an image from your media library.

If a poster image is selected, the selected image is displayed before the video starts playing. Poster
alignment specifies how the poster image will align inside the video player.

You cannot play the video in edit mode. The video restarts when you switch between analyzer
mode and edit mode.

In analyzer mode, you start the video with the play button. You can pause, switch between mute
and unmute, and view the video in full screen. You can also share the video player object, and Take
snapshot.

In edit mode, the right-click context menu provides options for Qlik Sense. In analyzer mode, the
context menu provides options for YouTube.

The app developer (edit mode) or app c+onsumer (analyzer mode) must allow YouTube videos to
play in Qlik Sense.
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Customizing styling
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
The video player has the following limitations:

l Safari does not support OGG and WEBM formats.
l Qlik Sense Desktop cannot play MP4 format due to limitations in Chromium.
l Qlik Sense Client-Managed Mobile on iOS can only play MP4 compressed in H.264 or MPEG-

4 format, but not other MP4, OGG and WEBM formats due to limitations in iOS.
l Qlik Sense Client-Managed Mobile offline is not supported for video playing.
l iPhone adds native video controls. It does not use video player controls, therefore Hide

Controls will not turn off controls.
l Android does not support OGG format.
l When exporting or printing a sheet that includes a video player object, the video player

object will not be included.
l Qlik NPrinting does not support the video player object.

Visualization bundle
Visualizations are an important means of conveying information from massive data.
The Visualization bundle is a set of charts that can be used to enhance and increase
your Qlik Sense app's charting capacity. The charts are optional. You do not have to
install or enable them to use Qlik Sense.

Enabling Visualization bundle
You can install the Visualization bundle when you install Qlik Sense. If you need to adjust your
installation, see: Modifying an object bundles installation.

Visualization bundle charts
Visualization bundle charts are in the asset panel under Custom objects.

The following charts are included:

l Funnel chart (page 450)
A funnel chart is a visual representation of the connected stages of a linear process.
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l Grid chart (page 458)
A chart that displays comparative data and with the values represented as colors.

l Multi KPI chart (page 464)
A chart that shows KPI for multiple dimension values to quickly understand and track
performance.

l Network chart (page 475)
Creates a cluster diagram representing a graphical chart of a computer network.

l P&L pivot chart (page 485)
Creates a pivot table that you can style, for example for profit and loss reporting.

l Pivot table (page 492)
Creates a pivot table with additional styling options not available in the pivot table
visualization.

l Radar chart (page 505)
Creates a two-dimensional chart using radial axes to show the scoring of a measure in one
dimension or another.

l Sankey chart (page 510)
A flow chart diagram chart visually emphasizing major transfers or flows within defined
system boundaries.

l Straight table (page 516)
A table that allows app developers to create tables that can be customized by users who do
not have edit permissions.

l Trellis container (page 530)
Creates a trellis chart based on a master visualization.

l Variance waterfall chart (page 545)
Shows the variance between two measures over the different values of a dimension.

l Word cloud chart (page 549)
A cloud chart of words with their size based on measure value.

Deprecated charts
These charts have been deprecated. Existing instances of these charts will still function, but new
ones cannot be added.

Bar & area chart
New bar & area charts are no longer supported as of May 2021. If you need to configure existing
instances of this chart, please refer to the last version of the documentation before support ended: .

Bullet chart
Deprecated by addition of native Bullet chart. For new charts, we recommend that you use the
native Bullet chart instead of this object. If you need to configure existing instances of this chart,
please refer to the last version of the documentation before the introduction of the native chart: .
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Heatmap chart
As of February 2022, the Heatmap extension is no longer supported. Apps that use the Heatmap
extension will continue to function. If you need to configure existing instances of this chart, please
refer to the last version of the documentation before support ended: .

Limitations
Visualization bundle visualizations have more limitations than built-in visualizations, such as bar
charts. The following limitations are valid for all visualizations from Visualization bundle:

l The user interface of the visualization is not localized to the language that Qlik Sense is
using.

l Right-to-left reading order is not currently supported.
l For accessible visualization options, the straight table with the pagination setting turned on

is the recommended chart choice from this bundle. Other charts from this bundle have more
limitations for accessibility.

l Accessibility features are not currently supported.
l It is not possible to edit objects from an object bundle supplied by Qlik with Dev Hub.

The following table shows which additional features are supported, or not supported, for all
bundled objects.

l Printing
Printing a visualization made in an object.

l Qlik NPrinting
There is an On-Demand reporting control (page 432). However, visualizations made in some
objects cannot be used in Qlik NPrinting reports.

l Download
Download as image, PDF, or Excel.

l Storytelling
Using a snapshot of a visualization created with an object in a story.

l Alternate states
Making different selections on the same dimension, and comparing the selections in a single
visualization or in two or more visualizations side by side.

Exported radar charts will not include the chart legend.

Chart Printing
Qlik
NPrinting

Download Storytelling
Alternate
states

Funnel Yes Yes Yes Yes Yes

Grid chart Yes Yes Yes Yes Yes

Multi KPI No No Yes Yes Yes

Visualization bundle capability support

Create apps and visualizations - Qlik Sense, November 2024 449



3   Visualizations

Chart Printing
Qlik
NPrinting

Download Storytelling
Alternate
states

Network Yes No Yes Yes Yes

Org chart Yes Yes Yes Yes Yes

P&L pivot Yes No Yes Yes Yes

Pivot object Yes Yes Yes Yes Yes

Radar Yes Yes Yes Yes Yes

Sankey Yes Yes Yes Yes Yes

Straight table Yes Yes Yes Yes Yes

Trellis container No No No No No

Variance
waterfall

Yes Yes Yes Yes Yes

Wordcloud Yes No Yes Yes Yes

Funnel chart
The Funnel chart (Funnel chart) lets you add a sequential chart showing the
connected stages of a process. Each stage will decrease and should contain a subset
of the previous stage. The decrease is gradual, giving the chart an ever narrower
funnel.
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A funnel chart displaying the conversion rates of prospects to customers in a sales process.

Funnel charts show values across multiple stages in a process. They can represent anything that is
decreasing in size. The funnel chart shows a process that starts at 100% and ends with a lower
percentage. Each chart segment represents the value of a specific item and can influence the size
of other segments. The Funnel chart is included in the Visualization bundle.

l The chart requires one dimension and one measure.
l Unlike bar charts, funnel chart segments are centered to create a funnel shape.
l A chart with increasing stages instead of decreasing is a pyramid graph.
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When to use it
The funnel chart is useful to illustrate the stages of a process and the overall decrease of each step,
for example:

l Represent a sales process showing the amount of potential revenue for each stage.
l Illustrate the number of sales prospects at each stage in a sales pipeline, i.e. the process

from prospective customer to made purchase.
l Identify potential problem areas and bottlenecks of a sales process.
l Communicate a sales process to new team members and vendors.
l Illustrate website visitor trends – from visitor homepage hits to other areas, for example

downloads, etc.
l Show order fulfillment with initiated orders at the top, followed by for example, orders in

delivery, delivered, canceled and returned.
l Showing the flow of information from top secret to unclassified.
l Representing knowledge areas from general knowledge to expert knowledge.

Creating a funnel chart
You can create a funnel chart on the sheet you are editing.

l The dimension decides how it should be grouped in segments. By default, dimension values
are displayed in descending order by measure value.

l The measure is the value that decides the size of each segment.
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Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Grid chart
object to the sheet.

2. Click the top Add dimension button and select the target dimension (usually target market)
of the chart.

3. Click the Add measure button to select the measure (what is to be measured) of the chart.
Once dimensions (dimension label) and measure (value label) have been selected the funnel
chart displays automatically (in color) in the chart field.

4. Click Done to revert to the main display field.
5. Click applicable region under Region. The chart field will update displaying chosen

parameters and details.

Dimension, measure and region details will continue to display in the chart field even when reverting
to Edit mode.

Changing the appearance of the chart
You can customize your chart with one or more features.

Funnel mode
You can set the shape of the funnel with Appearance > Presentation > Funnel Mode.

Area
The area of each item is proportionate to the measure. Only the height of the individual segment is affected
- not the overall chart or contents.

Create apps and visualizations - Qlik Sense, November 2024 453



3   Visualizations

Height
The height of each item is proportionate to the measure. Only the height of the individual segment is
affected - not the overall chart or contents.

Width
The width of the upper edge is proportionate to the maximum value of the measure. The top segment is
always 100% and the following segments are relative in size to the first. The lowest segment is rectangular.
This affects the shape of the funnel and each segment has its individual slope.
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Ordering
The measure only orders the segments with largest value at the top. The ordering is fixed so the shape of
the funnel is not affected.

Colors
You can choose how to color the funnel chart by changing the Appearance > Colors setting from
Auto to Custom.

Single color
You can use a single color for the entire funnel chart by selecting Single color in Colors.
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Color by dimension
You can also color your entire funnel chart by dimension by selecting By dimension in Colors.
There are two gradient color schemes available:

l 12 colors
l 100 colors

You can also select to keep persistent colors with Persistent colors.

Color by measure
You can color your funnel chart by measure by selecting By measure in Colors. The measure of the
chart is selected as default, but you can change it under Select measure. This measure must be
unlinked before a new can be selected. You can also change the measure using an expression in
the Expression editor ( ).

You can choose between four color schemes. It is also possible to reverse the colors.

l Sequential gradient
l Sequential classes
l Diverging gradient
l Diverging classes

You can also set a color range for your chart based on your measure by setting Range to Custom.
Set the range in Range > Min and Range > Max. You can use a number or an expression that
evaluates as a number.

Color by expression
You can color your funnel chart by measure by selecting By expression in Colors. You can color it
in two ways.

l The expression evaluates as a valid CSS color to color the chart. The expression is a color
code should be checked.

l The chart is colored by the expression value according to a color scheme. The expression is
a color code should be unchecked.
You can also set the range of the colors.

Sorting
Funnel chart elements are automatically sorted from largest to smallest. You can change the sort
order in the properties panel. Go to Sorting, and drag your dimensions and measurements into the
desired order.

Styling and formatting
The position and order of labels for dimension and measure values can be displayed in different
ways. You can for example hide the dimension value or display measures as values or as a
percentage.
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Additionally, you configure the title label to display for the dimension under Data in the properties
panel. Change the styling of these text elements in the styling panel. See Using the styling panel to
further customize the appearance (page 457).

Dimension label
You can choose if you want to show the dimension title label or not with Appearance >
Presentation > Dimension title

Value labels
You can choose how to show value labels for each segment by setting Appearance > Presentation
> Value labels to Custom.

l None hides the value labels.
l Share displays the values as percentage.
l Values displays the actual measure values.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
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l Dimension title: Style the text of the dimension title that is displayed above the
visualization.

l Dimension value label: Style the text of the labels displaying the individual dimension
values.

l Value Label: Style the text of the measure value labels.
Use the Auto contrast color setting to automatically override the selected value label
color with a color that better contrasts the funnel colors.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 449).

Grid chart
The grid chart (Grid chart) uses symbols of varying size sorted in a grid. The grid chart
is included in the Visualization bundle.

Grid charts must have two dimensions and one measure. The dimension values are the x and y
axes. The measure is the metric that determines the size of the symbol in each crossing.
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Grid chart with circles. Circle color is set by dimension (Quarter) and circle size is based on measure (Sum of
Sales)

When to use it
A grid chart is useful when you need to quickly find measure values that stand out from other
values. For example: you want to see which products sell well in some months, but poorly in others.

Grid charts do not work well when the measure has:

l Many duplicate values.
l Values that are numerically close to each other.

Creating a grid chart
You can create a grid chart on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Grid chart
object to the sheet.

Create apps and visualizations - Qlik Sense, November 2024 459



3   Visualizations

2. Click the Add Dimension button to select the x axis value of the chart.
3. Click the second Add Dimension button to select the y axis value of the chart.
4. Click the Add Measure button to select the metric being weighed.

The grid chart is now displayed with the dimensions and measures you selected.

Sorting
Grid chart elements are automatically sorted alphabetically or numerically from smallest to largest
on the x axis. You can change the sort order of either axes in the property panel.

Do the following:

1. In the property panel, go to Appearance>Sorting.
2. Click on a dimension.
3. Toggle Sorting from Auto to Custom.
4. You can choose any of these options:

l Sort by expression: Ascending or Descending.
l Sort numerically: Ascending or Descending.
l Sort alphabetically: Ascending or Descending.

Changing the appearance of the chart
You can customize the appearance of your grid chart.

Grid chart with stars. Star color and size is set by measure (Gross Sales).

Customizing the symbols
You can change the shape and size of the symbols from the Appearance>Presentation tab in the
property panel:

l Use the Symbol size slider to change size.
l Use the Symbol dropdown to change symbol type.
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Placing labels on symbols
You can place the individual values of symbols directly onto the chart. From the
Appearance> Presentation tab, toggle the Labels from Off to Auto.

Using a grid chart as a heat map
You can change the layout of a grid chart to a heat map from the Appearance>Presentation tab in
the property panel. From the Layout dropdown menu, choose:

l Standard: The chart will show individual symbols.
l Heatmap: The chart will display data in a grid with a legend ordered by color.

For a visual demo about using a grid chart as a heatmap chart, see Creating a heatmap using a grid
chart.

Changing the color scheme
You can change the color scheme of the symbols from the Colors and legend tab. Set Colors to
Custom. From the dropdown menu, choose:

l Single color: You can choose any color.
l By dimension: Under Color scheme, you can change how many different colors are used.
l By measure: Under Color scheme, you can alter the color gradient. Click the Reverse colors

check box to flip the gradient order. The colors used are based on your app theme.
l By expression: You can have a color code in the expression. Or, deselect the The

expression is a color code check box, and you can alter the color gradient. Click the
Reverse colors check box to flip the gradient order. The colors used are based on your app
theme.

Changing the range limits
You can customize the limits of the ranges if you color by measure or expression. The full range is
defined by the value of the dimensions. Go to Appearance > Colors and legend > Range in the
properties panel:

l Min: Defines the lower limit of the range.
l Max: Defines the upper limit of the range.

Changing the scale of the axes
You can customize the presentation of the x and y axes. Go to Appearance > X-axis: [dimension]
or Appearance > Y-axis: [dimension] in the properties panel. You can set:

l Labels and title: Select what labels and title to display.
l Label orientation: Select how to display the labels. The following options are available:

o Auto: Automatically selects one of the other options depending on the space available
on the chart.

o Horizontal: Labels are arranged in a single horizontal line.
o Tilted: Labels are stacked horizontally at an angle.
o Layered: Labels are staggered across two horizontal lines.
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To view examples of label orientation, see X-axis and Y-axis (page 611).
l Position: Select where to display the dimension axis.
l Number of axis values:

o Auto: The number of visible bars is determined by the number of dimensions and
measures used.

o Max: The number of visible bars is set to maximum.
o Custom: When custom is selected, you can directly set the upper limit to the number

of visible bars using Maximum number, or by entering an expression. Click
Expression to open the Expression editor.

l Show grid lines: Select whether to display grid lines.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Axis title: Style the titles on the axes.
l Axis label: Style the labels on the axes.
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l Value label: Style the labels which display the measure value for each dimension
value.

l Legend title: Style the title of the legend. The legend is only available for the Heatmap
configuration.

l Legend labels: Style the labels of the individual legend items. The legend is only
available for the Heatmap configuration.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 449).

l The Number of axis values setting in the property panel has a limit of 55 per axis.
l Sometimes when you set dimension limits on a grid chart, chart labels will incorrectly display

more items than requested.
l When coloring by dimension is used in this chart, a maximum of 100 unique dimension values

and 100 unique colors can be plotted on the legend.
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Multi KPI chart
The Multi KPI chart (Multi KPI) is a visualization that allows you to show multiple KPI
values for different dimension values. The values can be individually customized using
various conditional formatting settings. This enables an easy view and tracking of
goals. It is included in the Visualization bundle.

l The chart shows KPIs using measures and one dimension.
l Up to 15 measures and 80 values can display simultaneously.
l All KPI values can be grouped or displayed individually.
l Each value can be independently customized using for example, colors, icons, labels, font

sizes, alignments, styles, links to different sheets, etc.
l The chart supports adding graphics, embedding objects into a chart and to display measures

infographically.

When to use it
The multi KPI chart is useful when you want to easily view, understand and track the performance of
your goals. It is also helpful when you want to customize individual KPI values using conditional
formatting. You can link KPIs to separate sheet and insert objects to represent information or data.

Creating a multi KPI chart
You can create a multi KPI chart on the sheet you are editing.
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Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Multi KPI
object to the sheet.

2. Click the Add measure button and select the main measure of the KPI chart. The main
measure and a KPI value for the chosen measure is displayed.

3. Click Add under Data > Dimensions in the property panel and select dimension.

When you have selected measure and dimension, a multi KPI chart is displayed.

Example:

A chart with the measure (Margin %) shown for different values of the dimension (City).

Adding additional measures
You can add additional measures to your chart in property panel under Data > Dimensions. The
chart updates to reflect the added measures. Up to 15 measures and 80 values can display
simultaneously. The main measure is always the top measure listed for each dimension. When you
add more measures, they appear under the initial KPI value in the order they are entered.

Example:

A chart with a two measures (Margin %, Quantity) grouped per dimension (City).

Customizing the KPIs
You can customize your KPI values and measures with one or more conditional settings. You can
add several KPIs together, group them and link to different sheets. You can also configure KPI
values independently by differentiating them with one or more conditional settings such as text,
color, icons, graphics, etc.

For conditional settings options, see Changing a measure/label color (page 468).

Customizing styling
You have a number of styling options available under Appearance in the properties panel.
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Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 449).

Multi KPI charts cannot be used in Qlik NPrinting reports.

Customizing your KPIs
With the Multi KPI chart (Multi KPI) values and measures can be customized using one
or more conditional settings. You can add several KPIs together, group them, and link
to different sheets. KPI values can also be customized independently by differentiating
them using one or more CSS-properties such as text color, fonts, sizes, icons, labels,
graphics.

KPI values can also be customized independently by differentiating them using one or more css-
properties such as text color, background color, fonts, sizes, icons, labels, graphics.

KPI values using icons, different colors, fonts, Master Visualizations

Coloring a Multi KPI
The color option enables all KPI values (measures and labels) to be differentiated by colors. You can
change the colors of text, icons and background color. The colors should be valid css-colors.

You can choose from the following options:

l The color palette with a set of predefined colors.
l The color circle (click the easel symbol in the color palette and choose individually).
l Enter a color code string in the field next to the easel symbol.
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Changing a measure/label color

Do the following:

1. Click Data > Measures in the property panel.
2. Click applicable measure and select to color the value (Value color) or the label (Label

color).
3. Select color from the color palette that opens.

Changing background color

Do the following:

1. You can also set your own color by clicking the easel symbol in the color palette and select
color or enter a color code string in the field next to the easel symbol. The colors should be
valid css-colors.

2. Click Appearance > Styles in the property panel.
3. Click the Background color box.
4. Select color from the color palette that opens and the chart updates.

Changing sizes of a Multi KPI
The size of dimensions, measures, labels and icons can be configured using predefined sizes
available from a drop-down menu:

l Dimension labels: Select the size of the labels from the drop-down menu under Appearance
> Dimensions > Size in the property panel.

l Measure labels: All measures can have individual sizes.

Do the following:

1. Select the size of the measures in the property panel under Data > Measures.
2. Select measure and click the Override parameters box.

Create apps and visualizations - Qlik Sense, November 2024 468



3   Visualizations

3. Enter the label type as a string or in the expression under Label and select the size from the
options in the drop-down menu under Size.

Icons: All icons can be differentiated by applying different colors.

Do the following:

1. Go to Data > Measures in the property panel.
2. Select measure and choose icon from the icon option.
3. Then choose icon size from the drop-down menu under Icon.

Changing the fonts of a Multi KPI
You can change the font-family of all labels if you go to Data > Measures in the property panel and
select applicable measure. Under Font style enter a label string and press Enter.

You can also change the font using an expression in the Expression editor ( ) or apply individual
font css properties entered through Appearance > Styles > Styles (CSS) in the property panel.

Changing icons
You can set a predefined icon to represent a value and/or label by selecting from the icon set. The
icons can then be further customized by differentiating using the colors, fonts, labels and sizes
options.

Do the following:

1. Click Data > Measures in the property panel.
2. Check the Select icon box and click applicable icon from the icons set that opens.

3. Click OK. The pop-up will close and your chart update.
4. Choose whether to configure your label or value by selecting Label or Value under Icon

position.
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You can also change a value/label to an icon by entering an icon string under Icon (Data >
Measures > applicable measure in the property panel) and then press Enter. Thereafter click Label
or Value under Icon position depending on which you want to configure. It is also possible to
change an icon using an expression in the Expression editor ( ). The icons should be valid
CSSicons.

Using infographic mode
The infographic mode allows you to show each measure graphically as an appropriate number of
icons.

Do the following:

1. Click the applicable measure under Data > Measures in the property panel and click the Icon
button.

2. Select an icon to represent a measure from the predefined icon set (Icons) that opens.
3. Click the Infographic mode button. The resulting KPI chart updates and graphically shows

the measures with applicable number of icons (max. 100 icons per measure).
You can also select an icon using an expression in the Expression editor ( ).

Embedding a master visualization
To graphically illustrate the KPI object, you can embed a master visualization.

Do the following:

1. In the in the property panel go the Data > Measures and click Add.

2. Click the Expression editor ( ) button.

3. Enter the string ='Drag and Drop here' into the Expression editor and click Apply.
4. Drag and drop a master visualization object into the value region of each measure

placeholder.

You can also change insert the object ID string into the expression in the Expression editor ( )
under Visualization for each measure (Data > Measures > applicable measure in the property
panel).
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Using Styles (CSS) properties
You can further configure your measures using non-predefined Styles (CSS) property for each
measure. This can be icons, changing color of text/icons, label, font, background color, size, etc.
Copy and paste the styles into the Styles (CSS) field (under Appearance > Styles in the property
panel).

For icons, enter appropriate classes in the Icon field of the chosen measure under Data >
Measuresin the property panel. You can also enter the icon string using an expression in the
Expression editor ( ).

Formatting your KPIs
You can format the chart layout to be presented in different ways.

Alignment
You can configure the main chart text alignment by selecting applicable box under Alignment of
chosen measure under Data > Measures in the property panel.

All KPIs can also be vertically aligned. This alignment can be adjusted to align top, bottom and
center or as stretched. Select applicable alignment from the Vertical alignment menu under
Appearance > Styles in the property panel. It is also possible to center align labels by checking the
Center align labels in the property panel under Appearance > Dimensions.

Number formatting
You can also custom format the KPI number values. Different formatting can be applied to the same
values. The chart updates to reflect the changed number type.

Create apps and visualizations - Qlik Sense, November 2024 471



3   Visualizations

Do the following:

1. Click Data > Measures in the property panel and select applicable measure.
2.  Select applicable number formatting from the Number formatting menu.

Format pattern
The text of a specific measure can be changed or removed.

Do the following:

1. Click Data > Measures in the property panel.
2. Click applicable measure and enter/remove the applicable format string under Format

pattern and press Enter.

Segment/card
It is also possible to configure the layout of the KPI chart where dimensions and values display in a
segment or card layout.

Do the following:

1. Click Appearance > Dimensions in the property panel.
2. Choose Segment or Card layout from the Show as menu. The chart will update.
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The segment layout can be configured horizontally or vertically under Appearance > Dimensions >
Orientation in the property panel. Click either the Horizontal or the Vertical buttons.

Items per row
It is also possible to decide the number of items (KPIs) per line in a chart in the property panel under
Appearance > Measures. Use the default Auto or select applicable number from the Items per row
menu (between 1-8).

Borders
You can hide external and internal borders of the chart. By default all borders are visible. To
configure borders go to Appearance > Dimensions in the property panel and check , as
applicable, Hide external borders or Hide internal borders.

Value/Label layout and formatting
The position and order of labels for both dimension and measure values can be altered and
displayed in different ways. Labels can be hidden or displayed vertically or horizontally. By default
Horizontal is selected.
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Dimension label layout

Do the following:

1. Click Appearance > Measures in the property panel.
2. Click either Horizontal or Vertical under Labels orientation to select how the labels should

display.

Measure value layout
 Measure value layout can be set in two different ways.

Do the following:

1. Existing parameters:
a. Click Appearance > Measures in the property panel.
b. Click either Horizontal or Vertical under Labels orientation to select how the labels

should display.
2. New parameters:

a. Click Data > Measures in the property panel.
b. Click applicable measure and check the Override parameters box.
c. Enter the label string under Label and press Enter.

Label order
You can also adjust the order in which measure value labels appear.

Do the following:

1. Click Appearance> Measures in the property panel.
2. Click either Label, Value or Value, Label under Labels orientation to select how the labels

should display.

Icon order
You can decide where to show icons - before or after a value. In the property panel under
Appearance > Measures go to Icon order and click either the Icon, Value or Value, Icon buttons
to select which displays first in the chart.

Hide Labels
l Measure labels: This option hides the measure label of each KPI. To hide the labels click

Data > Measures in the property panel and select applicable measure. Then check the Hide
labels box.

l Dimension labels: This option hides the dimension label of each KPI. To hide the labels click
Appearance > Dimensions in the property panel. Then check the Hide labels box.
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Hide Values
This option hides the value for each KPI. To hide the value, click Data > Measures in the property
panel. Then check the Hide values box.

Group KPI values
All KPI values can be grouped or displayed individually per measure. Go to the Data> Measures in
the property panel. Choose applicable measure and check the Group by dimension box.

Another option is to enter a dimension value string under Dimension value and press Enter. The
chart will update. You can also enter the dimension value using an expression in the Expression
editor ( ). The values should be valid CSS values.

Link to a separate sheet
Each measure can be linked to another sheet.

Do the following:

1. Click Data > Measures in the property panel and select applicable measure.
2. Move the Link to sheet slider to the right to turn the option on.
3. Click the Select sheet button and from the Select sheet pop-up click the page you want a

link to. The sheet will close and your pages link.

Limitations
For information about general limitations, see Limitations (page 449).

Network chart
The network chart (network chart) lets you draw a network of connected nodes and
edges from a data set to a sheet. A network chart shows how information flows, how
components interact, and where components exist in the network. The network chart
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is included in the Visualization bundle.

A network chart can provide a broad overview or be very detailed. Nodes represent system
components, and edges show the movement of information from one component to another.
Network nodes are connected to the nodes they interact with the most. This visualization uses
different styles, colors, sizes, and images to represent different levels of a network.

Interact with the network chart by making selections one at a time.

What it contains
You need to define three dimensions with a fourth optional dimension:

l Node identifier: This dimension controls which nodes are presented in the chart.
l Node label: This dimension sets the label of each node.
l Node parent: This dimension sets the parent of a node, and controls the relationships

between nodes. It needs to contain the value of the node identifier of the parent to connect
to.

l Node group (optional): You can use this dimension to group nodes. All nodes in the same
group will have the same color.

You can use up to three measures to enhance the diagram. All measures are optional, but you need
to add them in the following order:

1. Tooltip: You can set a measure value that is displayed in a tooltip when hovering over a node.

2. Node size: You can set the size of the node according to a measure.
3. Edge size: You can set the width of the lines between nodes according to a measure.
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You need to add a tooltip before you can set node size. You can set edge size after
adding a tooltip and node size.

When to use it
Network chart diagrams can illustrate computer or telecommunications networks. They show the
components of a network and how they interact. For example, a group of connected computers,
printers, modems, hubs, and routers. This type of chart is helpful when:

l Planning the structure of a network.
l Coordinating updates to an existing network.
l Reporting and troubleshooting network problems .
l Keeping track of components.
l Documenting detailed network documentation.

Formatting your data
A network chart requires data that is structured consistently according to a network data model
where each record can have multiple parents and children. Each record needs to contain at least:

l A field that identifies the node, the node identifier. Node identifier values must be integer
values, starting from 0 and in sequential order.

l A field with the name of the node.
l A field that defines the parent node. This value needs to be the node identifier of another

node. If this field is empty, and no other record refers to this node, a disconnected node is
created.

It is also possible to use a hierarchical data model where each node has a single parent.
This will create a tree-shaped chart.

Here is some example data that you can save in a text editor and load in a new app. You need to
load both example files. The example shows passenger flows between different airports.

l ID is the identifier of an airport node.
l Name is the name of an airport node. This is used as label of the node.
l LinkTo contains the node identifier of the parent node.
l Group states the group of a node. This can be used to color the nodes according to group.
l Volume is the passenger flow volume between ID and LinkTo. This can be used as a measure

in edge size.
l NodeVolume is the total passenger flow volume for a node. This is loaded in a separate table

as the chart cannot aggregate the volumes automatically.

Example 1: Airports1.csv

ID;Name;LinkTo;Group;Volume

0;Frankfurt;;0;
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1;London;0;1;5

2;Madrid;0;1;4

2;Madrid;1;1;8

3;Warsaw;0;1;7

4;Arlanda;0;1;1

3;Warsaw;1;1;5

4;Arlanda;1;1;6

5;Tunis;0;2;8

5;Tunis;2;2;4

6;Berlin;0;1;6

6;Berlin;4;1;4

7;Rome;0;1;6

7;Rome;6;1;3

8;San Francisco;0;3;2

9;New York;0;3;9

Example 2: Airports2.csv

ID,NodeVolume

0,48

1,24

2,16

3,12

4,11

5,12

6,13

7,9

8,2

9,9

Creating a network chart
This example of a network chart illustrates how different airports are connected worldwide based
on base data set. It uses the example data set from Formatting your data. Prepare by saving the
example data set in a text file, creating a new app and loading the example data set.

Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Network chart
object to the sheet.

2. Click the top Add dimension button and select ID as the node identifier.
3. Click the second Add dimension button and select Name as the node label.
4. Click the third Add dimension button and select LinkTo as the parent node.
5. Click Data in the properties panel. Click the Add button under Node group and select Group

as the group dimension.
6. Under Measure, click the Add button under Tooltip, and select Volume > Sum

(NodeVolume).
7. Click the Add button under Node size, and select Volume > Sum(NodeVolume).
8. Click the Add button under Edge size, and select Volume > Sum(Volume).
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The chart displays:

Changing the appearance of the chart
You can customize your chart with one or more features.

Configuring edge type
You can configure the shape of the curve between chart nodes under Settings > Edge Type in the
properties panel. Select the shape option of the chart curves from the menu.

Examples:

A chart with dynamic edge type (curves).
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The same chart with curved CW edges.

Toggling edge value
The edge value represents value of the curves between chart nodes and their width. This option
hides the numerical value of each curve. To hide the value move the slide button under Settings >
Display edge value in the properties panel to the left to turn the option off.

Configuring edge label
The edge label value is the numerical value of each chart curve. You can change the position of
these or hide the labels.

l Hide edge label value: This option hides the edge label of the network chart. Toggle the
slide button under Settings > Display edge value in the properties panel.

l Edge label position: This option decides where on each chart curve the edge value displays,
for example: above or below. Select applicable option from the menu.

Configuring node shape
You can customize the shape of the nodes, for example: dot, square, diamond, or triangle. Go to
Settings > Node shape in the properties panel, and select the node shape from the menu.

Toggling shadow option
This option lets you turn off the shadow effects behind chart curves and nodes (used to highlight
background). Toggle the slide button under Settings > Display shadow in the properties panel.

Sorting
Sorting is set to Auto with the system choosing the sorting order as the default (under Sorting >
chosen dimension or measure in the properties panel) for all dimensions and measures. You can
change them individually by expression.
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Do the following:

1. Open the dimension or measure menu under Sorting in the properties panel.
2. Move Sorting slide button to the left to turn the option from Auto to Custom.
3. Click the Sort by expression check box.
4. Enter an order string under Expression and press Enter. You can also change the color using

an expression in the Expression editor ( ).

5. Choose start order by selecting Ascending or Descending for the menu below.

Number formatting
It is possible to format the measure value. Different formatting can be applied to the same value, for
example: money, data,or duration. The chart updates to reflect the changed number type.

Do the following:

1. Click Data > Measures in the properties panel and click chosen measure.
2. Select applicable number formatting form the Number formatting menu.
3. Enter details in the panel fields. These display when choosing an option other than Auto

when to configuring the chart.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:
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l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 449).

l Network chart visualizations cannot be used in Qlik NPrinting reports.
l The maximum size of the data set displayed in the network chart is 1400 rows. If the selected

data set is larger, nodes and links can be omitted from the chart.
Use a smaller data set or employ selections to limit the data set.

Org chart
You can use the org chart (Org chart) to create organization charts from data with a
tree structure. You can navigate through the hierarchy by expanding and collapsing the
tree. The org chart is included in the Visualization bundle.

You need to use a data set with two dimensions that define the tree structure.
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l The first dimension needs to be the ID of the node. This would typically be an employee ID in
a traditional organization chart.

l The second dimension needs to be the ID of the parent node. This would typically be the
employee ID of a manager.
This connects to the first dimension to create a tree structure.
If this value is empty or points to a node that does not exist, the node becomes a root node at
the top of the tree.

EmployeeID ManagerID Name Title

A101 Mary Bell CEO

A102 A101 John Bialik Executive secretary

O101 A101 Lee Mayer COO

I101 A101 Wendy Sanderson CIO

T101 A101 Asim Nawrat CTO

T102 T101 Emily Diaz VP Products

T103 T101 Christine Nemic VP R & D

Example data set for an org chart

You can also add a measure that is used as a card description.

Preparing the dataset
There are some things you need to consider when preparing the dataset for an org chart.
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l You need to use a dataset with less than 33000 rows.
If you use a larger dataset, the excess rows will be ignored. This can result in a tree with
incorrect structure. A message is displayed: The maximum data limit is reached. The tree
may display incorrectly.

l Make sure that the data does not contain circular references.
Circular references can result in nodes being omitted, or creation of multiple root nodes. One
of these messages is displayed:
Data contains circular references, nodes are omitted.
No root node, check your data for circular references.

l If a node has more than 99 children, the excess children nodes will not be rendered.
A message is displayed: Maximum number of child nodes reached, nodes are omitted.

l You should avoid having a large number of rows that do not have a parent node. These will
be shown as root nodes. The maximum number of root nodes is 99.

Creating an org chart
You can visualize the example data set using an org chart. Every employee is shown as a card in a
tree structure that you can expand and collapse.

Do the following:

1. Add an Org chart to your sheet.
2. Set the first dimension to be EmployeeID.
3. Set the second dimension to be ManagerID.
4. Add labels to the cards. Expand the EmployeeID dimension to see the label properties.

a. Set Card title to Name.
b. Set Card sub-title to Title.

Changing the appearance of the chart
You can customize the appearance of your org chart.
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Adding a measure to set a description
You can display a description by adding a measure. This will replace the value set in the property
Card description.

Changing the presentation mode
You can set how the org chart displays in Appearance > Presentation > Presentation mode. Org
charts can either display the entire tree, or they can collapse and expand. If an org chart is set to
Expand/collapse, you can also set the org chat to automatically resize to fit every time it is
expanded or collapsed.

Changing the colors
You can change the color of the card background in two different ways:

l Expand the first dimension and set an expression that returns a color or a color code under
Card background color. You can refer to data fields in the expression.

l Set a background color under Appearance > Presentation > Background color. You can set
all cards to a single color, or use an expression. If you use an expression you cannot refer to
data fields.

You can also set the color of the text with Appearance > Presentation > Font color.

Changing card borders
You can choose if org chart cards have borders and top bars under Card appearance. If you
choose to include borders, you can set a border color in Appearance > Presentation > Border
color. You can set borders to a single color or use an expression. If you use an expression, you
cannot refer to data fields.

Selections in the org chart
You can select cards in the org chart. Selecting a card will include all child nodes below a card in the
selection.

For information about general limitations, see Limitations (page 449).

P&L pivot chart
You can use the P&L pivot chart to create a pivot table with a layout for profit and loss
reporting. You can color cells according to performance and style the chart with
custom fonts and alternating row colors. You can also download the chart to Excel
including formatting. The P&L pivot chart is included in the Visualization bundle.
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Dimensions Measures Result

1 dimension up to 9
measures

A table with one row for each dimension value and one column
for each measure.

2 dimensions up to 8
measures

A pivot table with one row for each value of the first dimension
and one column for each measure pivoted using the second
dimension.

P&L pivot chart dimensions and meaures
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Coloring cells to show performance
You can color cells to show performance according to a scale of Poor, Fair and Good. All rows and
columns are colored by default, but you can choose which columns and rows to color if you want to.

Do the following:

1. Make sure that Enabled is set to On under Appearance > Color by condition.
2. Select which rows to color by performance.

Set Color all rows by condition to Specified rows.
Add rows to color by name (dimension value) with Add row to color.

3. Select which measures to color by performance.
Set Color all measures to Specified measures.
Add a list of measures by number in Measure indices with the first measure of the chart
numbered zero. Separate the measures with a comma.

Example: Color the first, third, and fifth measure.

0,2,4
4. Set performance limits and colors.

You can set the range limits for Poor and Fair.
l All cells with a value lower than the Poor range limit are displayed with the background

color and text color set for Poor.
l All cells with a value lower than the Fair range limit, but higher than Poor, are displayed

with the background color and text color set for Fair. You should set the Fair range
limit higher than Poor.

l All other cells are displayed with the background color and text color set for Good.
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Styling the chart using a style template
You can create a layout for the chart, for example to show a profit and loss report, using a style
template.

You need to be able to add and load a CSV file to the app.

Do the following:

1. Create a style template as a CSV file. Use the style template format described below.
2. Load the style template to your app as one field. When you add the file, do not use semicolon

as field separator, each row should be loaded as one field.
3. Set Style template field under Appearance > Table format to the name of the template field

you added.

You can load several style templates in your app, and change the layout with Style template field.

Style template format
The style template is created as a comma separated text file (CSV) using UTF-8 encoding.

The style template rows need to align to the data in your first dimension. You need to refer to a
dimension value in the template. The dimension value should be first in every row. You do not need
to specify all rows/dimension values in the template. The style template can contain maximum 5000
rows.

Each row in the template should be in the following format. It is not required to use a header row.

DimensionValue;Bold;Background;FontStyle;TextColor;Align;FontSize;Comment

l DimensionValue
The dimension value of the row that you want to style.

l Bold
Set to <bold> if you want bold text.

l Background
Set a background color. You can use <dark>, <night>, <soft>, <red>, <orange>, <violete>,

<blue>, <green> or a color code in RGB format, for example rgb(183,219,255). The default
background color is white.

l FontStyle
You can set the font style to <italic> or <oblique>.

l TextColor
You can set the color of the text to <white>. The default background color is black.

l Align
You can center align the text with <center>. The default alignment is left for text and right for
numeric values.

l FontSize
You can set the font size to <large>, <medium> (default) or <small>.

l Comment
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You can use the <comment> tag to replace all zero values with a space. This is useful when you
want to include a sub header row. without values.

You can also use the style tags in any order, and exclude tags that are not used. These rows will
give the same result:

Operating expenses;<bold>;;<italic>;;;;

Operating expenses;<italic>;<bold>

Style template example for profit and loss reporting
Cost of goods sold;<bold>;RGB(225,226,226);;;;;

Extraordinary items after tax;<bold>;RGB(193,216,47);;;<center>;<large>;

Extraordinary items;<bold>;;<italic>;;<center>;;<comment>

Financial revenue & expenses;<bold>;;<italic>;;<center>;;<comment>

General & administrative expenses;<bold>;;<italic>;;<center>;;<comment>

Gross profit;<bold>;RGB(193,216,47);;;<center>;<large>;

Income before tax & extraordinary items;<bold>;RGB(193,216,47);;;;<large>;

Manufacturing overhead;<bold>;;<italic>;;<center>;;<comment>

Net costs of goods sold;<bold>;RGB(225,226,226);;;;;

Net gain on sale of land;<bold>;RGB(193,216,47);;;<center>;<large>;

Net Income (Profit);<bold>;#191970;;<white>;<center>;<large>;

Net mfr overhead;<bold>;RGB(225,226,226);;;;;

Net sales revenues;<bold>;RGB(225,226,226);;;;;

Operating expenses;<bold>;;<italic>;;;;

Operating income before taxes;<bold>;RGB(193,216,47);;;;<large>;

Other general & admin expenses;<bold>;rgb(128, 191, 255);<white>;;<center>;<large>;

Revenues;<bold>;;<italic>;;<center>;;<comment>

total general & admin expenses;<bold>;#efefef;;;;;

total operating expenses;<bold>;rgb(128, 191, 255);<white>;;;;

Total selling expenses;<bold>;RGB(225,226,226);;;;;

To use this template, you need a data file where the first dimension contains values that correspond
to the first item of each row, for example Cost of goods sold.
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P&L pivot chart styled with the layout template in the example

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Downloading the chart in Excel format
You can download the P&L pivot chart as an Excel file. When you download the chart using the
Export as XLS option, the exported .xls file includes custom formatting applied to the chart.

Do the following:

1. Right-click a P&L pivot chart, or hover over the chart and click .

2. Select Export as XLS.
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Alternatively, select Download as... > Data to download the chart as an .xlsx file.
When using the Download as... > Data option, custom formatting applied to the
P&L pivot chart is not included in the Excel file.

3. Select a location on your computer where you want to store the file.

Limitations
For information about general limitations, see Limitations (page 449).

l There is a limitation for data transfer between Qlik Engine and P&L pivot. This limits each
request for data to 10000 elements, for example, 1000 rows and 10 columns. P&L pivot can
make automatic requests for more data using pagination.
You can set the limit of how much data to request with Pagination > Max pagination loops.
The default value is 20000 elements (20k cells) and the maximum value is 40000 elements.
You can also modify the error message displayed to the user when the data limit is exceeded.
The recommended workaround when the data limit is exceeded is to apply filters to the data
to limit the data transfer.

l It is not possible to convert a P&L pivot chart to another visualization or convert another
visualization to a P&L pivot chart.

Pivot table
The pivot table (Pivot) presents dimensions and measures as rows and columns in a
table. In a pivot table you can analyze data by multiple measures and in multiple
dimensions at the same time.

Pivot table, with expansions
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When to use it
Pivot tables are useful when you want to include several dimensions or measures in a single table,
and then want to reorganize them to see different subtotals. The Qlik Visualization bundle pivot
table offers several different layout and styling options than the pivot table visualization, including:

l Headers for all dimensions
l Header menu options for all dimensions
l Custom null representation
l Customizable column widths by pixel or percentage
l Adjust column widths using mouse
l Totals at top or bottom

Creating pivot tables

Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag Pivot to the
sheet.

2. Click Add and select a field or master dimension for the row dimension.
Optionally, add more dimensions as rows. The pivot table drills down rows in the order they
are added. You can click and drag the dimensions to reorder them.

3. Click Add and select a field or master measure for the measure.
Optionally, add more measures.

You can adjust appearance and other settings in the advanced properties panel.

Pivoting your data in the properties panel
In the properties panel, you can add measures and dimensions to the pivot table, as well as pivot
rows or columns.

Data
In the data pane, you can add dimensions and measures. You can move items between rows and
columns. You can also change item order inside rows or columns. When you use more than one
measure, they are grouped and a Values item is created.
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Sorting
On the sorting pane in advanced properties, you can change the internal order of dimensions and
measures.

When sorting pivot tables, NULL values are always displayed first.

Sort by first measure
If you have more than one measure, a measure group is created. Sort by first measure will sort
dimension values by the numeric value of the first measure. This sort order will affect all dimensions
and take precedence before any other sort order defined under the dimensions.
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For example, you have two measures: Quantity and Sales. In the properties pane, under Data>
Measures, Quantity is listed first. If you Sort by first measure in descending order, your table is
sorted starting with the dimension with the highest Quantity.

If Sort by first measure is turned off, the table uses the sort order configured for the dimensions.

Pivot table in Edit mode. Sort by first measure has been toggled on.

Limitations:

l This option is only supported if subtotals are calculated. You can calculate subtotals by doing
one of the following:

o In the properties pane, go to Data, and click on a dimension. Toggle on Show totals.
o In the properties pane, go to Appearance > Presentation. Toggle on Indent rows.

l This option is not supported for calculated dimensions.
l This option is only supported if all dimensions are in the Row section and all measures are in

the Column section.

Dimension sorting
With Sort by first measure turned off, the table can be sorted by dimension values. Each
dimension can have Auto or Custom sorting. With Auto sorting, field values are sorted
alphabetically and numerically in ascending order. With Custom sorting, you can turn each of the
following settings on or off:
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l Sort by expression: Sorts by custom expression. Sort by expression overrides the Sort
numerically and Sort alphabetically settings. This option should only be used with the first
(outermost) dimension in the table.

l Sort numerically: Sorts field values starting with a number.
l Sort alphabetically: Sorts field values starting with a letter.

Ascending and Descending options are available for all three settings.

Sorting in search
The user can click a dimension name in the table to expand a listbox. In the listbox, the user can
search and select individual dimension values. The Sorting in search setting controls the sort order
of the values in a dimension listbox.

You have the following options for the listbox sort order:

l Auto: Uses the default sort order. Numbers are sorted numerically in ascending order. Text is
sorted alphabetically in ascending order.

l Inherit from dimension: Uses the sort order defined for the individual dimension.

Formatting dimension and measure columns
You can format your dimension and measure columns with additional options. You can:

l Limit displayed dimensions
l Format dimension representation
l Format measure numbers
l Create conditional columns
l Set background color of cells using expressions
l Set text color with expressions
l Setting column width

Limiting displayed dimensions
Limit the number of displayed values for a dimension. When you set a limitation, the only
dimensions displayed are those where the measure value meets the limitation criterion.

Do the following:

1. Under Data, select a dimension and expand the properties.
2. Under Limitation, select one of the following limitations:

l No limitation: The default value.
l Fixed number: Select to display the top or bottom values. Set the number of values.

You can also use an expression to set the number. Click to open the expression
editor.

l Exact value: Use the operators and set the exact limit value. You can also use an
expression to set the number. Click to open the expression editor.
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l Relative value: Use the operators and set the relative limit value in percent. You can
also use an expression to set the number. Click to open the expression editor.

Formatting dimension representation
You can format dimension columns to show values, links, or images using Representation in the
properties panel. You can select the following representations: 

l Text: Displays the dimension values as text. This is the default value.
l Link: Displays values as clickable links. Either the dimension value is used or the URL or you

can add other URLs to the displayed dimension values.
l Image: Displays values that contain an absolute URL to an image display as images.

Formatting links

The character ; is not supported as a query parameter separator in a URL.

Do the following:

1. Under Data, select a dimension and expand the properties.
2. Under Representation, select Link.
3. Under Link setting, select one of the following:

l Add label: The dimension contains the destination URL in either the dimension
expression or the data table. The links are displayed and ordered by destination
URL expression.
Under Link label, enter a descriptive text label for the destination URL. Click to
open the expression editor.

l Add URL: The dimension values become selectable text links that are labels for the
URLs.
Under Link URL, enter the destination URL expression. Click to open the
expression editor.

Formatting images

Images in pivot tables are only accessible from servers and domains that have been
safe-listed. Administrators make these resources available in the Management Console
by adding Content-Security-Policies (CSP) for each server or domain. CSP helps to
prevent cross-site scripting attacks by controlling what resources a browser can
request from a server.

The character ; is not supported as a query parameter separator in a URL.
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Do the following:

1. Under Data, select a dimension and expand the properties.
2. Under Representation, select Image.
3. Under Image setting, select one of the following:

l Add label: The dimension contains the absolute URL to the image in either the
dimension expression or the data table. The links are displayed and ordered by the
URL expression.
Under Image label, enter a descriptive text label for the image that displays as
alternative text when the image is hovered over. Click to open the expression
editor.

l Add URL: The dimension values become labels for the alternative text that displays
when the image is hovered over.
Under Image URL, enter the destination URL expression. Click to open the
expression editor.

4. Under Sizing, select one of the following sizing options:
l Always fit
l Fit to width
l Fit to height
l Stretch to fit
l Original size

5. Under Position, select the image position within the cell.

Formatting measure numbers
You can format measure numbers under Number formatting in the properties panel.

If you want to change the number format at app level, and not just for a single measure, it is better
to do that in the regional settings in the SET statements at the beginning of the script in the data
load editor.

Do the following:

1. Under Data, select a measure and expand the properties.
2. Under Number formatting, select the format:

l Auto: Qlik Sense automatically sets a number formatting based on the source data.
To represent numeric abbreviations, the international SI units are used, such as k
(thousand), M (million), and G (billion).

l Number: By default, the formatting is set to Simple, and you can select the formatting
from the options in the list. Change to Custom to and enter the format pattern under
Format pattern.

Create apps and visualizations - Qlik Sense, November 2024 499



3   Visualizations

Examples:

l # ##0 describes the number as an integer with a thousands separator. In this
example " " is used as a thousands separator.

l ###0 describes the number as an integer without a thousands separator.
l 0000 describes the number as an integer with at least four digits. For example,

the number 123 will be shown as 0123.
l 0.000 describes the number with three decimals. In this example "." is used as a

decimal separator.
If you add the percent sign (%) to the format pattern, the measure values are
automatically multiplied by 100.

l Money: By default, the format pattern used for money is the same as set up in the
operating system. Use Format pattern to change the format pattern.

l Date: By default, the formatting is set to Simple, and you can select the formatting
from the options in the list. Change to Custom to and enter the format pattern under
Format pattern.

l Duration: By default, the format pattern used for duration is the same as set up in the
operating system. Duration can be formatted as days, or as a combination of days,
hours, minutes, seconds and fractions of seconds. Use Format pattern to change the
format pattern.

l Custom: By default, the format pattern used for custom is the same as set up in the
operating system. Use Format pattern to change the format pattern.

Creating conditional columns
Columns can be conditional, so that they only appear when certain conditions are met.

Do the following:

1. Under Data, select a dimension or measure and expand the properties.

2. Under Show column if, click to open the expression editor.

3. Enter the expression to determine the conditions for the column to appear.
4. Click Apply.

Example
Suppose you have a Pivot table or Pivot object that contains the following:

l Dimensions are Product Type and Product Name.
l Measures are Sum(Sales) and Count (distinct InvoiceNumber).
l The items under Columns are Values (default) and the field Quarter.
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Part 1: Conditional column based on user selections

You might have a large number of years of data in your app, so you do not want to add too much
clutter to the visualization. At the same time, you want to encourage granular and interactive
analysis.

For the Quarter column, you could add the following expression for Show column if:

GetSelectedCount(Year)=1

With this expression, if the user selects a single year in the app, the pivot table breaks down each
measure by quarter. If not, the total measure values are shown.

Part 2: Conditional columns using variables

You can use variables to encourage interactive analysis. Suppose you also create a variable
vUserInteraction with a blank definition. Then, you create two Button charts on your sheet,
configured with the Set variable value action:

l Show more detail: Clicking this button sets vUserInteraction to a value of ='Yes'.
l Show less detail: Clicking this button sets vUserInteraction to a value of ='No'.

In your pivot table, you could add a number of additional measures to the chart, such as Count
(Quantity) and Sum(Cost). Then, configure each measure column to have the following value for
Show column if:

'$(Reference)'='Yes'

This allows the chart to adapt to whether or not the user wants additional information. If the user
clicks the Show more detail button, additional measures are added to the table. If not, or if they
click Show less detail, the additional measures are removed.

l Show more detail: Clicking this button sets vUserInteraction to a value of ='Yes'.
l Show less detail: Clicking this button sets vUserInteraction to a value of ='No'.

In your pivot table, you could add a number of additional measures to the chart, such as Count
(Quantity) and Sum(Cost). Then, configure each measure column to have the following value for
Show column if:

'$(Reference)'='Yes'

This allows the chart to adapt to whether or not the user wants additional information. If the user
clicks the Show more detail button, additional measures are added to the table. If not, or if they
click Show less detail, the additional measures are removed.

Setting background color with expressions
You can define the background color for a column using expressions. For example, you can have
cells in the column change background color depending on the values in the column cell. The text
color automatically changes to white when a dark background color is used.
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Do the following:

1. Under Data, select a dimension or measure and expand the properties.

2. Under Background color expression, click to open the expression editor.

3. Enter the expression to determine the conditions for the column to appear.
4. Click Apply.

Setting text color with expressions
You can define the text color for a column using expressions. For example, you can have cells in the
column change text color depending on the values in the column cell.

Do the following:

1. Under Data, select a dimension or measure and expand the properties.

2. Under Text color expression, click to open the expression editor.

3. Enter the expression to determine the conditions for the column to appear.
4. Click Apply.

Setting column width
By default, column width is automatically set. You can manually set column width by:

l Content
l Pixels
l Percentage

You can also manually size the columns by dragging the header borders.

Do the following:

1. Under Data, select a dimension or measure and expand the properties.
2. Under Column width, select how you want to set column width:

l Fit to content: Columns are sized by the width of the content in the column.
l Pixels: Set the width of the column in pixels.
l Percentage: Set the width of the column by percent.
l Auto: Automatically set the column width with Qlik Sense.

Customizing styling
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.
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Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, emphasis style, font size, and color for the following text
elements:

l Header: Style the text of the headers for all dimensions.
l Dimension values: Style the text dimension values.
l Measure values: Style the text of the measure values.
l Measure labels: Style the text of the measure headers.
l Total values: Style the text of the totals.
l Null values: Style the text of the null values.

Customizing the background
You can customize the background of the chart. You can also color individual dimensions or
measures by expression.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

4. On the Chart tab, customize the background color for the following elements:
l Header
l Dimension values
l Measure values
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l Measure labels
l Total values
l Null values

Customizing the grid
You can customize the pivot table grid.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab, customize the grid with the following elements:
l Row height: Set the height of rows in lines.
l Border: Set the color of the cell borders.
l Divider: Set the color of the divider between that divides both dimensions and

measures as well as header and rows.
l Background: Set the color of the empty area created when you have dimensions in

Column.

Customizing null values
You can change how null values are represented in the pivot table.

Do the following:

1. Click Appearance > Presentation in the properties panel.
2. Under Null value text, enter the text you want to replace null values with.

Expanding the pivot table fully
You can set the pivot table to always be fully expanded.

Do the following:

1. Click Appearance > Presentation in the properties panel.
2. Select Fully expanded.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
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5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
Pivot tables have the following limitations:

l You cannot pivot data in your Visualization bundle pivot table when your sheet is in analysis
mode as you can with the visualization pivot table.

Radar chart
The Radar chart (Radar chart) displays a two-dimensional chart using radial axes to
chart one or more groups of values over multiple variables. Radar charts can be used to
visualize and compare performance to a set standard or to a group's performance. The
Radar chart is included in the Visualization bundle.

Radar charts requires two dimensions and one measure. The y-axis goes from the center to the
perimeter and the x-axis is the perimeter of the chart. Each value represents the distance from the
center of the chart, and displays on axes starting from the center. The center of the chart
represents the minimum value, and the edge the maximum value.

A radar chart can show multiple series, each separately connected with their values. The data only
goes around the chart once. Adding values only increases the chart's granularity.

A selection that is made in a radar chart is confirmed instantly. When applicable, make additional
selections one at a time.
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Understanding a radar chart
A radar chart consists of evenly spaced segments (axes) arranged radially around a point. There is
one segment for each data value of the second dimension. The value of each measure is shown by
a node on applicable axis. A line connects the values that belong to the same series creating the
chart’s star-like shape.

A radar chart with one axis for each month of the Date.Month dimension.

When to use it
Radar charts let you compare and measure data with an arbitrary number of variables. This is
helpful when comparing something's features or performance over several metrics. For example:
before buying a computer, you can compare different computers across several features, such as
memory storage processing, and screen size. A radar chart is also useful when:

l Measuring quality improvements and performance.
l Comparing allocated amount versus actual spending in an organization.
l Identifying outliers, commonality, and clusters of data with similar values and features.
l Charting an athlete's strengths and weaknesses.
l Comparing results of small-to-moderate-sized multivariate data sets.

Creating a radar chart
You can create a radar chart on the sheet you are editing.
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Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Radar chart
object to the sheet.

2. Click the top Add dimension button and select the first dimension category to be measured
(x-axis).

3. Click the second Add dimension button to select the second dimension (y-axis).
4. Click the Add measure button to select the measure of the chart.

Once dimensions and measure have been selected the radar chart displays automatically (in color)
in the chart field

A radar chart with two dimensions and one measure.

Changing the appearance of the chart
You can customize your radar chart with one or more features.

Changing the color scheme
You can change color scheme of your chart by choosing from four predefined options.
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Do the following:

1. Click Appearance > Design in the property panel.
2. Select a color scheme under Color.

Changing the stroke type
You can also customize the shape line connecting each node under Appearance > Design >
Stroke type in the properties panel. Select the shape from the menu.

Toggling the legend
The legend provides a small text description of each node of the chart. The legend expands to
show its text, and the chart shrinks to accommodate the legend. To toggle the legend, move the
slide button under Appearance > Design > Legend in the properties panel.

Limiting dimensions
You can set limits on your dimension values. To change limitations and terms go to Data >
Dimensions in the properties panel. Click dimension, and under Limitation choose a limitation from
the menu.

Toggling titles
This option can hide the name of the radar chart. To toggle the name, click Appearance > General
in the properties panel. Move the Show titles slide button.

Number formatting
The default setting for Number formatting for measures and dimensions is Auto. You can change
this setting to Number, and then select a number format.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.
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Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

Create apps and visualizations - Qlik Sense, November 2024 509



3   Visualizations

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
Radar charts have the following limitations:

l Radar charts can only process 100 unique values per dimension.
l Exported radar charts will not include the chart legend.
l For information about general limitations, see Limitations (page 449).

Sankey chart
The Sankey chart (Sankey chart) lets you add a specific type of flow chart to the sheet
you are editing. The chart visually emphasizes major transfers or flows within defined
system boundaries. The width of the chart arrows is shown proportionally to the flow
quantity. The Sankey chart is included in the Visualization bundle.

l A minimum of two dimensions and one measure is required. You can use up to five
dimensions, but only one measure.

l The dimensions do not need to be of equal size on each side of the diagram.
l You can use the dimension values to set the color of the flows in the chart.
l Link colors can be based on source or target anchor.
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A chart with a source dimension (Quarter) and the target dimension (Year).

When to use it
The sankey chart is useful when you want to locate the most significant contributions to an overall
flow. The chart is also helpful when you want to show specific quantities maintained within set
system boundaries.
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Creating a sankey chart diagram
You can create a sankey chart on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Sankey chart
object to the sheet.

2. Click the top Add dimension button and select the source dimension for the flow of the chart
(appears to the left).

3. Click the second Add dimension button to select the target dimension for the flow of the
chart (appears to the right).

4. Click the Add measure button to select the measure of the chart.

Once dimensions and measure have been selected the sankey chart diagram displays automatically
(in color) in the chart field.

Adding additional dimensions
You can add up to five dimensions to your chart in property panel under Data > Dimensions. The
chart updates to reflect the added dimensions. The dimensions are displayed from left to right, with
the first entered dimension always being the source dimension. The target dimension is always
displayed to the to the right. When you add more dimensions, they are added to the right in the
order they are entered.

A chart with three dimensions: the source dimension (Origin), the target dimension (Decision) and one
additional (Destination).
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Sorting
Sankey chart elements are automatically sorted from largest to smallest flow. You can change the
sort order in the property pane.

Do the following:

1. Click Sorting under Appearance in the property panel.
2. Toggle Sorting from Auto to Custom.
3. You can toggle Sort numerically:

l Toggle on: Sort numerically by Ascending or Descending.
l Toggle off: Drag your dimensions and measurements into the desired order.

Changing the styling and appearance
You can customize your chart with one or more features. Your chart automatically updates.

Link colors
The colors of chart links are based on either the source or target anchors. To apply the source or
target anchor color to chart links either use the string ='SOURCE' or ='TARGET'. You can also select
a separate color by entering a color code string. The color should be a valid CSS color.

Do the following:

1. Click Presentation under Appearance in the property panel.
2. Enter the applicable string under Link color.
3. Press Enter and the chart updates.

You can also change the link colors using an expression in the Expression editor ( ). It is also
possible to color a link that has its intensity based on the Margin % of the dimension values it
represents.

Example:

Enter the string =rgb(round(Avg ([Margin %])*255), 100, 100) where Margin % is a value between
0-1 and the link will display as red in the chart.

Link opacity
You can adjust link opacity by moving the slide button of the link opacity slider under Appearance >
Link opacity in the property panel. Also, setting opacity to 1 (furthest right) allows the setting to
drop a shadow, giving links a more individually distinct appearance.

Node colors
You can change the node colors of each dimension value. The color should be a valid CSScolor.
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Do the following:

1. Select applicable dimension under Data > Dimensions in the property panel.
2. Enter the color code string under Node color and press Enter. The chart will update.

For example: To use the color Aqua (#00ffff) set the color code string to ='#00ffff'. You can
also set the node colors using an expression in the Expression editor ( ).

Node padding and width
You can set both the vertical distance between nodes ("node padding") and the horizontal width of
chart nodes ("node width").

Do the following:

1. Click Presentation under Appearance in the property panel.
2. Move applicable slide button of the Node padding and/or Node width sliders to adjust node

settings.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).
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Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, font size, and color for the following text elements:
l Node title: Style the text of the header for each node in the chart.
l Node label: Style the text of the labels displaying the individual values of the nodes.

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
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5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 449).

Straight table
The Straight table shows several fields simultaneously, where the content of each row
is logically connected. A table can consist of as many dimensions and measures as
needed. The Straight table is included in the Visualization bundle.

App creators can add many fields simultaneously, customize the table at the column-level, add
alternative dimensions and measures, set column width, apply pagination and turn on chart
exploration.

Chart exploration allows users that do not have edit rights to customize the original straight table
when they are in analysis mode. These users can add or remove columns, change sort order, re-
arrange columns, and make selections. They can then share, download, subscribe, or bookmark the
new table layout. The changes made in chart exploration mode by a user are not seen by other
users analyzing the sheet.

This page is about the Visualization bundle straight table. For information on the native
table object, see Table (page 353).
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When to use it
Use a straight table when you want to view detailed data and precise values rather than
visualizations of values. Tables are good when you want to compare individual values. Drill-down
group dimensions are very efficient in tables. Within a limited space, you can drill down to the next
level of detail and analyze the updated measure values. Use this table when you want users to be
able to create custom tables in analysis mode.

Advantages
You can filter and sort the table in different ways. Many values can be included in a table, and when
you drill down in a table, you make good use of the limited space on the sheet. A table is excellent
when you want to see exact values rather than trends or patterns. Tables are an easy way to export
data into other programs.

Disadvantages
If the straight table contains many values, it is difficult to get an overview of how values are related.
It is also hard to identify an irregularity within the table.

Best practices for optimizing tables
If a table has too many dimensions and measures, it may load slowly. As a best practice, add the
majority of your fields and expressions as Alternative columns. This encourages users to add only
the fields they need using chart exploration.

You can also increase performance by ensuring a table has 10 columns or less.

Tables that extract fields from a single data source will perform better than tables that contain
fields from multiple data sources.

Creating a straight table
You can create a straight table on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Qlik Visualization bundle and drag a Straight
table object to the sheet.

2. Click Add columns to add items to the table. A dropdown will open:
l Fields & master items: Opens a searchable dialog box displaying every field and

master item. You can choose to add any item as a dimension or measure.
l Custom expression: Opens a dialog box where you can type in an expression, or open

the expression editor .

3. In the properties panel, under Data, click to add more dimensions or measures to the
table.

When you have created the table, you may want to adjust its appearance and other settings in the
properties panel.
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By default, column widths are all set to one value, so that the sum of them equals the
width of the chart. You can adjust the width of a column by dragging the header divider.
Double-click the header divider to reset to the default width.

Working with table items

Do the following:

1. In the Data tab of the properties panel, under Columns and Alternative columns, click the
checkbox next to any item. Click to perform actions such as cut, paste, and delete. Click
the checkbox next to Columns or Alternative columns to select all items in the list. Use the
arrow icons to move items between each section.

Alternative columns are columns that users can choose to add to the table when
using Using chart exploration (page 526).

2. To change the column order, click next to a field or expression and drag the item.

3. Click on an item name to open its individual properties. Here you can change the label, set a
background color for the column, control text alignment, set column width, and more. For
more information, see the sections below.

If Text alignment is set to Auto, column data is aligned according to data type:
text values are left-aligned and number values, including date related values, are
right-aligned. If you set it to Custom, you can align the data to the left, center, or
right.
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Data tab in the properties panel when a straight table is selected. The Customer field was clicked, so related
dimension properties are displayed on the left.

Create apps and visualizations - Qlik Sense, November 2024 519



3   Visualizations

Defining column text style with an expression
For each column, you can set a separate expression to define how the column text is styled. If you
style a column's text with an expression, this expression overrides the app theme, and any custom
styling applied to the visualization, for that column.

You can use the following syntax in your expression to define the styling (the letter in the tag is not
case sensitive):

l <B>: Bold
l <I>: Italics
l <U>: Underlined
l <S>: Strikethrough

More than one of the options above can be applied at a time.

Examples:

if(avg(Sales) > 300, '<B>')
if(count(OrderID) = 0, '<S>')
if(sum(Sales) > 100000, '<B><U>', '<I>')

Do the following:

1. Under Data, select a column and open Presentation in the properties.

2. Under Text style expression, enter the expression. Click to open the expression editor.

Formatting dimension representation
You can format dimension columns to show values, links, or images using Representation in the
properties panel. You can select the following representations: 

l Text: Displays the dimension values as text. This is the default value.
l Link: Displays values as clickable links. Either the dimension value is used or the URL or you

can add other URLs to the displayed dimension values.

Formatting links

The character ; is not supported as a query parameter separator in a URL.

Do the following:

1. Under Data, select a dimension and open Presentation in the properties.
2. Under Representation, select Link.
3. Under Link setting, select one of the following:

l Add label: The dimension contains the destination URL in either the dimension
expression or the data table. The links are displayed and ordered by destination
URL expression.
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Under Link label, enter a descriptive text label for the destination URL. Click to
open the expression editor.

l Add URL: The dimension values become selectable text links that are labels for the
URLs.
Under Link URL, enter the destination URL expression. Click to open the expression
editor.

Formatting images

Images in straight tables are only accessible from servers and domains that have been
safe-listed. Administrators make these resources available in the Management Console
by adding Content-Security-Policies (CSP) for each server or domain. CSP helps to
prevent cross-site scripting attacks by controlling what resources a browser can
request from a server.

The character ; is not supported as a query parameter separator in a URL.

Do the following:

1. Under Data, select a dimension and open Presentation in the properties.
2. Under Representation, select Image.
3. Under Image setting, select one of the following:

l Add label: The dimension contains the absolute URL to the image in either the
dimension expression or the data table. The links are displayed and ordered by the
URL expression.
Under Image label, enter a descriptive text label for the image that displays as
alternative text when the image is hovered over. Click to open the expression
editor.

l Add URL: The dimension values become labels for the alternative text that displays
when the image is hovered over.
Under Image URL, enter the destination URL expression. Click to open the
expression editor.

4. Under Sizing, select one of the following sizing options:
l Always fit
l Fit to width
l Fit to height
l Stretch to fit
l Original size

5. Under Position, select the image position within the cell.

Sorting the table
You can adjust the sorting of the table in several ways:
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l Column sorting: Adjust the order of the dimensions and measures from left to right .
l Row sorting: Adjust the sorting priority order of the rows.
l Internal sorting: Use the internal sorting order of dimensions and measures.
l Interactive sorting: During analysis, you can click on a column header to sort the table.

Column sorting
By default, the order in which columns are sorted is set by the order in which dimensions and
measures are added to the table. If you add the measure Sales first, it is presented first (leftmost) in
the table. The next dimension or measure that is added is presented in the second column, and so
on. The column sorting order can be changed in the properties panel, under Columns.

Row sorting
By default, rows are sorted by the first added dimension or measure, numeric values descending,
text values ascending. A small arrow under the column header shows by which column the table is
sorted.

You can change the row sorting in the properties panel, under Sorting. Drag the dimensions and
measures to change the sorting priority order. In many cases, sorting is not only affected by the
first dimension or measure in Sorting, but also the following ones.

Example:

In the following screenshot, the rows are first sorted by Customer, then by Month, and then by
Product Type. As you can see, the columns Customer and Month have several rows with the same
values (A-2-Z Solutions and Month). The rows in Product Type are ordered alphabetically, but only
those that were sold in January to the customer A-2-Z Solutions are displayed.
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By changing the sorting order, so that secondary sorting is by Product Type, followed by Month, all
Product Type items sold to the customer A-2-Z Solutions are presented in alphabetical order,
whereas only the months when they were sold are displayed under Month.

Internal sorting
Each dimension and measure has a default (Auto) internal sorting order, which can be changed.
Under Sorting, click the item you want to change and click the button to switch to Custom sorting.
Changes made to the internal sorting of an item may not have any effect if the sorting is in conflict
with an item with higher priority.

Interactive sorting
During analysis, you can set which column to sort on by clicking the column header. The first click
sorts the table according to the default sorting of the selected item. A second click reverses the
sorting order. Interactive sorting is session based and is not saved. If you want your changes to the
sorting to be persistent, you need to make the changes in the properties panel.

Users with the ability to edit the sheet can sort interactively using chart exploration, click Edit
sheet, and save those changes to the original table.

Working with add-ons
Straight tables have the following options under Add-ons in the properties panel:

Data handling: 
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l Include zero values: When unselected, measures that have the value ‘0’ are not included in
the presentation. If there is more than one measure value, all the measure values must have
the value ‘0’ to be excluded from the presentation.

l Calculation condition: Specify an expression in this text field to set a condition that needs to
be fulfilled (true) for the object to be displayed. The value may be entered as a calculated
formula. For example: count(distinct Team)<3. If the condition is not fulfilled, the message or
expression entered in Displayed message is displayed.
A calculation condition is useful when a chart or table is slow to respond due to a large
amount of data. You can use the calculation condition to hide an object until the user has
filtered the data to a more manageable level by applying selections. Use the Displayed
message property to guide the user to filter the data.
Using Calculation Conditions

Styling the straight table
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

4. On the Chart tab, set the font, emphasis style, font size, and color for the following text
elements:
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l Header: Style the text of the headers for the dimensions and measures.
l Dimension values: Style the text dimension values.
l Measure values: Style the text of the measure values.
l Totals: Style the text of the totals, if you have selected to show a Totals row under

Appearance > Presentation.
l Null values: Style the text of the null values.

5. On the Chart tab, customize the Null values styling. You can change emphasis style and
color.

You can also style the text for each column in the table. You can configure text color, style, and
alignment. These settings are configured in the Data tab of the properties panel. If you have styled
a column individually, this styling will override any text styling applied at the chart level. For more
information, see Working with table items (page 518).

Additionally, you can customize how the text appears when a user hovers over a row. See
Customizing the hover behavior (page 526).

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background. The
chart header always displays with 100% opacity.
When using a background image, you can adjust image sizing and position.

4. On the Chart tab, customize the background color for the following elements:
l Header (100% opacity is used)
l Dimension values
l Measure values
l Measure labels
l Totals (100% opacity is used)
l Null values

Customizing the grid
You can customize the table grid.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the Chart tab, customize the grid with the following elements:
l Row height: Set the height of rows in lines.
l Border: Set the color of the cell borders.
l Divider: Set the color of the divider between that divides the header and body of the

table.

Customizing the hover behavior
You can set display options for when a user hovers over a row in the table.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the Chart tab of the styling panel, under Row hover, adjust the following settings:
l To highlight rows in the table when a user hovers over them, set the switch to On.

Switch the behavior off according to preference.
l Row hover color: Set the color to highlight the row when a user hovers over it.
l Row hover font color: Set the color of the text in the highlighted row when a user

hovers over it.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Using chart exploration
Chart exploration allows app consumers and other users that do not have edit rights to customize
the original straight table when they are in analysis mode. It is available in the menu under
Chart exploration.

App consumers and viewers can use chart exploration to add or remove columns from a table, re-
sort columns, change column width, and apply selections. You cannot change the size or layout of
the entire table on the sheet in chart exploration mode.
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Chart exploration mode is a great way to quickly remove or add data, and then share it, download it,
or bookmark the new table state. It is very helpful in apps that have many viewers with different
needs. The chart exploration panel is not shown in the resulting table that you have shared or
downloaded.

If you customize a table using chart exploration mode, other users cannot see your changes, unless
you save them as a public bookmark. This means that several users can alter the same table, at the
same time. Your changes will remain visible to you if you refresh your browser page, but will be lost
if you log out or your session times out. If this occurs, the table will return to its default state, as set
by the person who created the straight table. If you want to save your table layout, create a
bookmark.

Users with the ability to edit the sheet can make changes to the table using chart exploration, click
Edit sheet, and save those changes to the original table.

App developers can turn on Chart exploration in the properties panel:

l Enable chart exploration: Toggle this on to allow chart exploration.
l Visibility option:

o Auto: Chart exploration panel is visible when users open the sheet.
o Minimized: Chart exploration is turned on, but not visible when users open the sheet.

Users can open it in the hover menu by clicking and then Chart exploration.

For a table item to be available in chart exploration mode, the table creator (or a user who can edit
the sheet) must have added those fields, master items, or expressions to the table as columns or
alternative columns. For more information, see Working with table items (page 518).
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Chart exploration of a straight table. The table has three columns: Customer, Region, City.
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Chart exploration of the same table as above, but with two measures added to the table: Sales and Cost.
The background colors are the result of an expression.

Limitations

Chart exploration not available if table is embedded in certain charts
Chart exploration is not available if the table is embedded inside any of the following objects:

l An existing container object that has not been replaced with a tab container. The tab
container became the native container object in the November 2024 releases of Qlik Sense
Enterprise on Windows and Qlik Sense Desktop.
Chart exploration is also not available in existing instances of the deprecated ShowHide
container and Tabbed container objects. However, converting these objects to tab
containers is not recommended. Instead, create a new tab container from scratch in order to
access chart exploration in straight tables.
Container (page 416)

l Trellis container
Trellis container (page 530)

Number of rows displayed
If pagination is turned on, you can only display 100 rows at a time. If pagination is turned off, you
can display up to 250 000 rows at a time. If your table has more than 250 000 rows, pagination will
be applied.
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Because huge tables are impractical and hard to manage, the limit for what is practical is far less
than the theoretical maximum. In most cases, it is desirable to see all the columns without scrolling
horizontally.

Accessibility
The straight table is only fully accessible if pagination if turned on.

Trellis container
You can use the Trellis container to show a trellis chart based on a master visualization.
The trellis chart shows a grid of the same chart for different dimension values. You can
use the trellis chart to compare metrics for different groups of data. The Trellis
container is included in the Visualization bundle.

Trellis chart based on a bar chart of sales data, shown for different product categories
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Creating a trellis chart
You can create a trellis chart on the sheet you are editing. The chart that you want to repeat for
different dimension values must be a master visualization.

Do the following:

1. Create the chart that you want to repeat for different dimension values and save it as a
master visualization.

2. In the assets panel, open Custom objects > Visualization bundle and drag a Trellis
container object to the sheet.

3. Select which master visualization to show in Appearance > Trellis options > Base
visualization in the property panel.

4. Select the dimension that you want to use as the first grid dimension in Data > Dimensions.
5. Optionally, add a second grid dimension to create a grid with one dimension in each axis.

If any of the grid dimensions are calculated dimensions, toggle on
Calculated Dimension in the settings for the dimension.

You will now see a grid of charts each based on the grid dimensions you selected.

Troubleshooting
I do not see a grid of charts, and receive this message: Too many dimension values!

Possible cause

There are more dimension values than the maximum number of charts allowed in the grid.

Proposed action

You can increase the number of charts allowed in Appearance > Trellis options > Maximum
number of charts.

Changing the appearance of the chart
You can customize your chart with one or more features.

Setting the number of columns
You can set the number of columns in the chart grid with Appearance > Trellis options > Number
of columns.

Setting the y-axis range of charts
You can select which y-axis range to show for the charts in the trellis chart with Appearance >
Trellis options > Auto range.

l On will show the same range for all charts. This is the best option if you want to compare
values between different charts.

l Off will show an optimized range for each chart.
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Show border
You can show a border for the trellis chart with Appearance > Trellis options > Border. You can
adjust width, color and style. It is also possible to define a custom border.

Slide mode
You can view the charts in slide mode instead of a grid by setting Appearance > Trellis options >
Slide mode to On. In slide mode, you view one chart at a time. You can scroll between the charts.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.
The styling panel contains various sections under the General and Chart tabs.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.
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3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Configuring how null values are represented

Null measure values
To configure the representation of null measure values for a dimension value, use Appearance >
Trellis options > Show all possible dimensions. With Show all possible dimensions, you have the
following options:

l On: The container shows a measure value of 0 for a dimension value where no measure data
is present. Suppose that the master visualization aggregates sales by month and there are
no sales in October. Here, the Trellis container will still list October as a dimension in the
charts (with a value of 0 as applicable).

l Off: The container does not show dimension values where no measure data is present.
Suppose that the master visualization aggregates sales by month and there are sales in all
months except October. Here, the Trellis container will list each month except October in the
charts.

Null values in the grid dimensions
It could happen that there are null values in the grid dimension. If you want the Trellis container to
visualize these null values, toggle on the Include null values setting.

Do the following:

1. In the properties panel, expand Data.
2. Expand the dimension for which you want to show null values.
3. Turn on Include null values.
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Best practices for creating the master visualization
Here are some tips for creating a master visualization that will work well in a trellis chart:

l Show the title in the master visualization. In the trellis chart, the title is replaced with the grid
dimension value of each chart.

l If you use expressions: create a label to hide the set expression.
l If you are using a combo chart: use only one axis, and set the minimum and maximum of the

y-axis.
l If you are using a box plot: set the minimum and maximum of the y-axis.
l If you are using a scatter plot: set the x-axis.
l If you are using a map: use advanced mode, and set the layer color and title. For an example,

see Example 2: Coloring on a map chart (page 540).

Using advanced mode
Use advanced mode to customize the set expressions and dimension values that will be shown in
the Trellis container. Advanced mode allows you to use placeholder values to allow dynamic output
tailored to the dimension being shown in each chart in the container.

Activate advanced mode by setting Appearance > Trellis options > Advanced mode to On.
Advanced mode allows you to:

l Use advanced expressions for labels, titles, subtitles, and footnotes.
l Use advanced expressions to define the data shown in the visualization. For example:

l if expression as chart measure
l Coloring by measure
l Joining the Trellis set expression with other set expressions

Do the following:

1. In the properties panel for the master visualization, go to Appearance > Trellis options, and
set Advanced mode to On.

2. Use the placeholders in the table below in expressions for measures, coloring, chart text, and
other properties. They will be replaced in the Trellis container by the corresponding values.

Placeholder Replaced by value

$(vDim) Dimension Name

$(vDimValue) Dimension Value

$(vDimSet) ,[Dimension Name]={'Dimension Value'}

$(vDimSetFull) {<[Dimension Name]={'Dimension Value'}>}

Advanced mode value replacements in a trellis chart
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Use cases and examples

$(vDim)
$(vDim) is useful as an expression for labels, titles, subtitles, or footnotes in the master
visualization. For example, in a subtitle:

='This chart presents the aggregation by ' & $(vDim)

$(vDimValue)
$(vDimValue) is useful in many scenarios:

l Expressions for measure data in the master visualization. For example, as a measure in a
Text & image or Text object:
=if(GetSelectedCount([Product Category])=1, Sum({<Region={$(vDimValue)}>} Sales),

'Please select a product category.')

l Expressions for label, titles, subtitles, or footnotes in the master visualization. For example,
as a footnote:
='This chart presents sales data for' & $(vDimValue) & '.'

$(vDimSet)
$(vDimset) is useful when you need to join multiple set expressions together. This can be used in an
expression for measure data in the master visualization. For example:

=sum({<ProductName={'Bike Helmet'} $(vDimSet)>} Sales)

For the example above, the Trellis container would restrict the data to ProductName values of Bike
Helmet. A separate chart would be shown for each unique value in the dimension used in the Trellis
container.

$(vDimSetFull)
$(vDimSetFull) is useful for setting chart coloring by measure in the master visualization. For
example:

=Sum($(vDimSetFull) Sales)

Long-form examples
For step-by-step examples showing how to use advanced mode, see Add the data (page 536).

Limitations
For information about general limitations, see Limitations (page 449).

Unsupported visualizations
You cannot use the following visualizations in a trellis chart:

l Filter pane
l Histogram
l Container
l Layout container
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Multi KPI visualizations with embedded master visualizations
It is not possible to use a Multi KPI chart that contains an embedded master visualization.

Selecting by dimension
If you make a selection on the dimension that is used as grid dimension in the trellis chart, the
selection is not reflected in the trellis chart.

Example:

You have a filter pane with countries, and a trellis chart with country as the first grid dimension.
When you select a country in the filter pane, the trellis chart will still show a chart for each country
and ignore the selection.

Coloring by master measure color
Colors assigned to master measures in a trellis container do not appear unless the trellis container
is using the advanced mode.

Trellis container advanced mode examples
This help topic shows examples of how you can use a Trellis container in advanced
mode to configure advanced expressions in your charts.

The following variables are shown in this help topic:

l $(vDim)
l $(vDimValue)
l $(vDimSetFull)

For additional examples, see Using advanced mode (page 534).

Example 1: Conditional measure expression
This example shows you how the $(vDimValue) variable can be added to measure expressions to
make the Trellis container compatible with advanced expressions. The expression used in this chart
is a conditional if expression.

Add the data
Create a new app and add the load script below into the Data load editor. Then, load the data.

Load script
Sales:

LOAD * INLINE [

Region,Country,Item Type,Sales Channel,Order Priority,Order Date,Order ID,Ship Date,Units

Sold,Unit Price,Unit Cost,Total Revenue,Total Cost,Total Profit

Central America and the

Caribbean,Honduras,Household,Offline,H,2/8/2017,522840487,2/13/2017,8974,668.27,502.54,5997054

.98,4509793.96,1487261.02

Asia,Mongolia,Personal

Care,Offline,C,2/19/2014,832401311,2/23/2014,4901,81.73,56.67,400558.73,277739.67,122819.06

Asia,Sri
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Lanka,Cosmetics,Offline,M,11/19/2016,419123971,12/18/2016,6952,437.20,263.33,3039414.40,183067

0.16,1208744.24

Asia,Turkmenistan,Household,Offline,L,12/30/2010,441619336,1/20/2011,3830,668.27,502.54,255947

4.10,1924728.20,634745.90

Central America and the

Caribbean,Honduras,Snacks,Online,L,6/30/2016,795490682,7/26/2016,2225,152.58,97.44,339490.50,2

16804.00,122686.50

Australia and Oceania,Australia,Office

Supplies,Online,C,10/27/2015,158535134,11/25/2015,2924,651.21,524.96,1904138.04,1534983.04,369

155.00

Europe,United

Kingdom,Household,Online,L,1/5/2012,955357205,2/14/2012,282,668.27,502.54,188452.14,141716.28,

46735.86

Sub-Saharan

Africa,Djibouti,Cosmetics,Offline,H,4/7/2014,259353148,4/19/2014,7215,437.20,263.33,3154398.00

,1899925.95,1254472.05

Australia and

Oceania,Australia,Cereal,Offline,H,6/9/2013,450563752,7/2/2013,682,205.70,117.11,140287.40,798

69.02,60418.38

Middle East and North

Africa,Libya,Clothes,Offline,H,10/30/2010,705784308,11/17/2010,6116,109.28,35.84,668356.48,219

197.44,449159.04

Central America and the

Caribbean,Haiti,Cosmetics,Offline,H,10/13/2013,505716836,11/16/2013,1705,437.20,263.33,745426.

00,448977.65,296448.35

Central America and the

Caribbean,Belize,Clothes,Offline,M,7/25/2016,807025039,9/7/2016,5498,109.28,35.84,600821.44,19

7048.32,403773.12

Europe,Lithuania,Office

Supplies,Offline,H,10/24/2010,166460740,11/17/2010,8287,651.21,524.96,5396577.27,4350343.52,10

46233.75

Asia,Turkmenistan,Office

Supplies,Online,M,4/23/2013,462405812,5/20/2013,5010,651.21,524.96,3262562.10,2630049.60,63251

2.50

Middle East and North

Africa,Libya,Fruits,Online,L,8/14/2015,816200339,9/30/2015,673,9.33,6.92,6279.09,4657.16,1621.

93

Sub-Saharan

Africa,Djibouti,Cereal,Online,H,5/20/2017,555990016,6/17/2017,8656,205.70,117.11,1780539.20,10

13704.16,766835.04

Middle East and North

Africa,Pakistan,Cosmetics,Offline,L,7/5/2013,231145322,8/16/2013,9892,437.20,263.33,4324782.40

,2604860.36,1719922.04

North

America,Mexico,Household,Offline,C,11/6/2014,986435210,12/12/2014,6954,668.27,502.54,4647149.5

8,3494663.16,1152486.42

Australia and Oceania,Federated States of

Micronesia,Beverages,Online,C,10/28/2014,217221009,11/15/2014,9379,47.45,31.79,445033.55,29815

8.41,146875.14

Australia and

Oceania,Samoa,Cosmetics,Online,H,7/20/2013,670854651,8/7/2013,9654,437.20,263.33,4220728.80,25

42187.82,1678540.98
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Europe,Spain,Household,Offline,L,10/21/2012,213487374,11/30/2012,4513,668.27,502.54,3015902.51

,2267963.02,747939.49

Middle East and North

Africa,Lebanon,Clothes,Online,L,9/18/2012,663110148,10/8/2012,7884,109.28,35.84,861563.52,2825

62.56,579000.96

Sub-Saharan

Africa,Kenya,Vegetables,Online,L,3/18/2012,827844560,4/7/2012,6457,154.06,90.93,994765.42,5871

35.01,407630.41

North America,Mexico,Personal

Care,Offline,L,2/17/2012,430915820,3/20/2012,6422,81.73,56.67,524870.06,363934.74,160935.32

Australia and

Oceania,Australia,Beverages,Offline,H,7/7/2014,240470397,7/11/2014,9389,47.45,31.79,445508.05,

298476.31,147031.74

North America,Mexico,Personal

Care,Offline,M,7/30/2015,559427106,8/8/2015,5767,81.73,56.67,471336.91,326815.89,144521.02

Sub-Saharan

Africa,Mozambique,Household,Offline,L,2/10/2012,665095412,2/15/2012,5367,668.27,502.54,3586605

.09,2697132.18,889472.91

];

Create the master visualization

Do the following:

1. Open a sheet in edit mode.
2. Drag a bar chart onto the sheet.
3. Add Item Type as a dimension to the bar chart.
4. Add the following expression as a measure:

=if(Sum([Units Sold])>=40000, Sum({<Region={$(vDimValue)}>} [Total Profit]), Sum

({<Region={$(vDimValue)}>} [Units Sold]))

In the Trellis container, this expression will show:
l If there are 40,000 or more units sold: The total profit for each distinct region.
l If there are less than 40,000 units sold, or if the data is null: The total number of units

sold for each distinct region.
For each chart in the container, the $(vDimValue) variable will be replaced by the dimension
value name for Region.

5. For the measure you just added, add the following Label:
=if(Sum([Units Sold])>=40000, 'Total Profit', 'Items Sold')

6. In the properties panel, expand Sorting. Adjust the sorting so that the chart sorts primarily by
the measure value in descending order.

7. In the properties panel, under Appearance, expand Colors and legend.
8. Set Colors to Custom and choose the option to color the chart By dimension.
9. Turn on Persistent colors.

10. Right-click the chart, or use the button, and click Add to master items.

11. Give the master item a Name (for example, BarChartExample), and click Add.
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Create the Trellis container

Do the following:

1. Drag a Trellis container onto the sheet.
2. Click Add dimension, and select Region.
3. Click Add master visualization. In the drop down menu, select the BarChartExample master

item.
4. In the properties panel for the Trellis container, under Appearance, expand Trellis options.
5. Set Advanced mode to On.
6. In the properties panel for the Trellis container, under Appearance, expand General.
7. Toggle on Show titles if needed. Add the following expression for the Title of the chart:

=if(Sum([Units Sold])>=40000, 'Total Profit, by Region and Item Type', 'Total Items

Sold, by Region and Item Type')

Resize the Trellis container on the sheet so that it has enough space to show all data. Your chart
should now look something like the following image.

Example result with no selections made in the app

If you make selections in the app (for example, by selecting a specific Order Priority), the measure
shown in the chart could change given the lower order volume.
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Example result with a selection made in the app

Example 2: Coloring on a map chart
This example will show you how to configure a Trellis container in Advanced mode to color a map
chart by measure expression. Specifically, it shows the following:

l Using $(vDimSetFull) to color map charts by measure.
l Using $(vDim) and $(vDimValue) in text within the charts (in this case, for the chart subtitles).

Add the data
Create a new app and the load script below into the Data load editor. Then, load the data.

Load script
SET DateFormat='MM/DD/YYYY';

[Regional Sales]:

Load RowNo() as OrderID, Year(OrderDate) as Year, * Inline [

Country,OrderDate,Sales

Peru,01/15/2022,227752.86

India,09/24/2023,273204.8

United Kingdom,10/12/2020,196509.42

Brazil,04/09/2022,62936.87

Peru,06/19/2023,343348.25

France,10/08/2021,137087.24

Brazil,04/02/2023,364144.83

France,01/18/2021,147458.3

France,07/31/2021,131735.39

France,08/28/2021,175657.49

Mexico,11/29/2023,347796.5

Brazil,10/22/2021,156415.67

United States,06/26/2022,71698.01

Mexico,07/06/2021,302858.53
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United States,09/02/2023,380184.4

Japan,12/17/2023,138012.27

Spain,01/06/2022,360035.92

Nigeria,07/26/2020,117583.51

India,08/27/2022,319078.12

Nigeria,05/10/2021,185315.61

France,01/22/2021,79605.99

Mexico,11/08/2022,410677.64

United Arab Emirates,01/21/2022,304060.08

Japan,05/01/2020,382370.67

Peru,10/07/2020,163162.77

Japan,10/28/2023,116031.67

Japan,08/13/2021,202813.87

Brazil,12/18/2020,116177.28

France,08/05/2023,251482.97

United States,11/30/2023,354524.01

Brazil,02/27/2022,333082.0

Japan,03/02/2024,272875.61

Japan,10/05/2022,241957.76

Mexico,10/13/2020,415713.42

France,02/01/2021,278095.0

Brazil,04/21/2023,32234.39

United States,03/06/2020,31705.72

Japan,10/16/2021,397489.08

Peru,01/24/2021,164315.87

Peru,08/10/2021,39399.43

Japan,08/19/2021,55312.24

United States,06/19/2021,47950.8

France,04/05/2020,66698.87

Chile,02/05/2023,209699.99

Canada,04/03/2022,40362.07

India,05/07/2023,448813.12

France,11/21/2023,382234.7

United States,05/22/2020,454589.09

Brazil,12/20/2021,46482.62

Peru,04/18/2023,196877.9

Canada,12/22/2021,292966.22

France,12/05/2020,441694.97

Brazil,02/14/2023,172206.44

Mexico,04/11/2022,302489.06

Peru,05/12/2022,293993.12

Peru,04/24/2022,248774.21

Canada,06/04/2024,392124.04

Mexico,03/04/2020,142287.51

Japan,02/27/2022,75894.1

Brazil,05/07/2021,52657.97

Mongolia,01/31/2020,447353.36

France,04/05/2022,275954.94

Brazil,03/03/2022,86689.07

United States,01/27/2023,304884.26

Spain,05/03/2021,143572.48

Australia,03/28/2022,132283.75

Japan,04/20/2021,259819.31

Canada,06/12/2020,366820.82

France,09/15/2020,337837.91
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Japan,07/09/2020,95159.91

Japan,10/19/2021,149382.85

Brazil,09/09/2021,325617.68

Mexico,06/06/2021,324661.14

Brazil,09/28/2022,366444.31

Mexico,05/26/2023,394055.4

Japan,05/30/2021,77322.47

Japan,02/06/2023,187484.72

United States,11/13/2022,307780.43

France,03/26/2022,438656.23

Japan,03/16/2020,237080.43

United Kingdom,12/31/2022,372867.22

Mexico,12/23/2022,251630.19

Kenya,09/11/2023,167978.34

Peru,08/12/2022,174796.28

Brazil,03/20/2020,360178.71

Nigeria,06/04/2024,236178.16

United States,06/19/2022,230182.87

Brazil,12/30/2021,128965.58

Nigeria,07/26/2023,96338.83

Peru,05/16/2021,354580.5

Spain,02/21/2024,107994.23

Mongolia,05/19/2022,240049.35

United States,10/20/2022,302237.71

Brazil,02/11/2022,162125.17

Brazil,02/20/2023,223010.48

Nigeria,06/20/2024,206926.14

Mexico,02/27/2023,378327.98

France,03/07/2022,432543.14

France,05/20/2020,61227.11

Japan,08/26/2020,46839.45

France,01/18/2024,193017.69

France,11/25/2020,290340.4

Canada,08/08/2022,385273.52

United States,09/26/2021,204250.05

United States,08/04/2022,223287.59

Mexico,11/14/2022,256152.68

Brazil,01/15/2020,242880.01

Mexico,11/25/2020,430857.71

United States,06/05/2021,378069.6

France,01/03/2022,316563.84

United Kingdom,05/19/2021,243918.77

United States,05/17/2023,204355.25

Nigeria,03/13/2020,293234.49

Mongolia,06/24/2022,245425.64

Australia,12/19/2020,379893.22

United States,01/01/2021,288622.04

Brazil,05/03/2022,242795.62

Mexico,04/07/2021,227912.73

Japan,11/26/2021,144015.86

Canada,09/17/2020,126427.98

Mexico,08/04/2021,170917.99

Brazil,09/16/2021,302048.81

Japan,12/16/2020,271152.67

Peru,09/10/2021,384189.71
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United States,04/29/2020,454328.73

Peru,08/27/2020,190456.76

Canada,09/29/2022,296216.69

United States,06/20/2020,293064.04

Nigeria,07/21/2023,329696.64

France,03/29/2022,125031.6

Canada,11/28/2020,334136.19

India,01/27/2023,364236.69

United States,04/05/2024,146632.59

Brazil,11/23/2021,442283.3

Canada,09/17/2020,149007.7

Brazil,03/15/2023,170612.37

Peru,02/09/2021,156444.13

Brazil,03/17/2021,217404.08

Mongolia,04/26/2020,312406.89

Canada,10/08/2020,381041.07

Brazil,06/11/2022,347838.35

Peru,01/24/2022,250253.73

Canada,11/30/2020,54392.41

Brazil,12/14/2020,301046.63

United Kingdom,11/30/2023,23456.55

United States,11/18/2021,411647.97

Mexico,10/27/2022,35642.56

Nigeria,01/12/2021,310103.2

Mongolia,04/24/2023,66497.07

Japan,03/01/2020,115616.07

Brazil,11/11/2021,427971.79

Australia,04/30/2020,224772.13

Mongolia,10/31/2020,99216.73

Peru,08/21/2020,403962.65

Peru,01/30/2023,185795.36

Japan,01/25/2023,123502.1

Nigeria,01/12/2024,203772.15

United States,11/13/2020,148393.65

Brazil,12/06/2020,112804.31

United States,07/14/2022,301281.13

Peru,04/09/2020,250693.79

Peru,05/21/2024,393405.04

Japan,03/26/2022,52544.23

Brazil,01/16/2023,90154.56

Mexico,01/22/2023,26075.54

Brazil,11/28/2021,23825.06

Peru,11/09/2020,161572.89

Mexico,07/28/2021,49412.07

Japan,01/11/2021,307169.36

Canada,09/06/2021,73335.63

Nigeria,04/14/2023,1187523.85

France,10/22/2021,72831.06

Brazil,03/07/2020,369401.17

Canada,06/04/2020,341681.27

Brazil,06/20/2021,386016.82

Peru,10/26/2022,32322.15

Canada,04/16/2021,345333.21

Japan,03/24/2020,205311.36

Japan,09/29/2023,415385.44
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Nigeria,03/28/2023,449452.09

France,10/04/2020,95167.1

Japan,08/14/2021,358862.28

Mongolia,06/24/2024,329040.71

France,03/02/2023,132649.55

France,09/20/2022,408825.94

Canada,05/22/2021,423239.99

Spain,09/06/2020,47063.8

Brazil,05/11/2024,393786.01

Mexico,06/02/2023,34370.17

Brazil,01/31/2024,284225.11

Peru,04/17/2023,404147.81

Brazil,11/25/2022,190314.55

Peru,12/03/2021,141599.92

Chile,10/29/2021,244343.67

Japan,09/11/2022,448202.62

United States,02/11/2020,120006.54

France,12/11/2021,97129.11

Peru,01/30/2021,312698.45

France,09/24/2023,195299.87

France,04/10/2024,448665.96

];

Create the master visualization

Do the following:

1. Open a sheet in edit mode.
2. Drag a map chart onto the sheet.
3. In the properties panel, create a new area layer for the chart.
4. Add Country as the dimension for the area layer.
5. In the Country area layer, expand Colors.
6. Set Colors to Custom and select the By measure color setting.
7. Add the following expression for Select measure:

=Sum($(vDimSetFull) Sales)

8. Add the following Label to the measure color: Total Sales
9. Expand the Appearance > General section in the properties panel.

10. Enter the following expression for the chart Subtitle:
='Total Sales, ' & $(vDim) & ': ' & $(vDimValue)

This expression returns an error in the master visualization, but in the Trellis container, it
functions intended. For each unique Year value, the title of the chart will be Total Sales,
Year: <year>.

11. Right-click the chart, or use the button, and click Add to master items.

12. Give the master item a Name (for example, MapChartExample), and click Add.
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Create the Trellis container

Do the following:

1. Drag a Trellis container onto the sheet.
2. Click Add dimension, and select Year.
3. Click Add master visualization. In the drop down menu, select the MapChartExample

master item.
4. In the properties panel for the Trellis container, under Appearance, expand Trellis options.
5. Set Advanced mode to On.
6. Set Number of columns to a value that works best for your sheet and screen size. To match

the image below, set this to 5.
7. In the properties panel for the Trellis container, under Appearance, expand General.
8. Add the following Title for the chart: Total Sales by Country
9. Resize the chart if needed so that it occupies the entire length of the sheet.

10. Exit sheet edit mode.

To get the same color scheme as shown in the image below, set the app theme to Sense Classic.

Example result

Variance waterfall chart
You can use the variance waterfall chart (Variance waterfall) to show the variance
between two measures over the different values of a dimension. The variance waterfall
chart is included in the Visualization bundle.

You need to use two measures, start value and end value, and one bridge dimension.
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Variance waterfall chart showing spending over fiscal quarters

Creating a variance waterfall chart
You can create a variance waterfall chart on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Variance
waterfall object to the sheet.

2. Click the Add dimension button to select the bridge dimension.
3. Click the first Add measure button to select the measure to use as start value.
4. Click the second Add measure button to select the measure to use as end value.

The variance waterfall chart is now displayed with one bar for the start value measure and one bar
for the end value measure. Between the measure bars you will see the variance for each value of
the bridge dimension.

Changing the appearance of the chart
You can customize the appearance of your chart.

Labels
You can turn off value labels by setting Appearance > Presentation > Value labels to Off.

Legend
You can customize the legend labels by setting Appearance > Presentation > Labels to Custom.
You can set a custom text for the following legend labels:

l Start value (Start value)
l End value (End value)
l Positive variance (Positive label)
l Negative variance (Negative label)
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You can also hide the legend by setting Appearance > Colors and legend > Show legend to Off or
change the position of the legend with Appearance > Colors and legend > Legend position.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Example of a variance waterfall chart
In this simple example we will show how quarterly sales numbers contribute to sales compared to
budget.

Dataset
The dataset we use contains sales numbers and budgeted sales for each quarter. You can paste it
into a text file and load it in Qlik Sense.

Quarter,Sales,Budget

Q1,9,10

Q2,14,12

Q3,12,12

Q4,18,14

Visualization
You can now create a variance waterfall chart.

l Add Quarter as dimension.
l Add Sum(Budget) as the first measure.
l Add Sum(Sales) as the second measure.

The variance waterfall chart is created. We have adjusted the labels and colors in the example.
You can clearly see that Q1 had sales below budget, but the year ended with sales over budget, and
that Q4 was the largest contribution.
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Variance waterfall chart showing spending over fiscal quarters

Limitations
For information about general limitations, see Limitations (page 449).

l It is not possible to use a variance waterfall chart in a Trellis container.
l You need to use the same number format for both measures to get correct number format for

the dimension variance bars.

Word cloud chart
The Word cloud chart (Word cloud chart) lets you visualize text data. Text values are
displayed with their size based on a measure value. The measure can be anything you
want to measure against, for example: times used, alphabetically, by importance, or by
context. You can customize your chart with different shapes, fonts, layouts, and color
schemes. It is included in the Visualization bundle.
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A word cloud chart displaying food items in different sizes and colors.

Requirements
Word cloud charts must have one dimension and one measure. 
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When to use it
A word cloud chart lets you visualize and identify the importance of a value against a measure. The
more important the value is against the measure, the larger it displays in the cloud.

Creating a word cloud chart
You can create a word cloud on the sheet you are editing.

Do the following:

1. In the assets panel, open Custom objects > Visualization bundle and drag a Word cloud
chart object to the sheet.

2. Click the Add dimension button and select the dimension.
3. Click the Add measure button to select the measure of the chart.

Once a dimension and a measure have been selected, the word cloud chart displays automatically.

Changing the appearance of the word cloud
You can customize your word cloud with one or more features.

Changing the orientation
You can set the number of orientations with Appearance > Design > Orientations in the
properties panel. You can set an integer from 1 to 10.

l 1 will display all words in the same direction, set with Appearance > Design > Start angle.
l 2 will display words in two orientations, Appearance > Design > Start angle and

Appearance > Design > End angle.
l 3-10 will display words in the same number of orientations between Appearance > Design

> Start angle and Appearance > Design > End angle.

Create apps and visualizations - Qlik Sense, November 2024 551



3   Visualizations

Example:

A word cloud chart displaying food items in different orientations.

Adjusting the start and end angles
You can adjust the starting point (angle) parameter of the word cloud under Appearance > Design
> Start angle, and the end point under Appearance > Design > End angle in the properties panel.
The angles can have positive or negative numbers.

Changing font size
You can set maximum word font sizes under Appearance > Design > Font max size and the
minimum under Appearance > Design > Font min size in the properties panel.

If you set a large font size, this can result in the larger words not being displayed in the chart as they
do not fit.

Changing scale
The word could chart scale can be either in linear or in log scale. Select scale Linear or Log under
Appearance > Design > Scale in the properties panel. Only positive values can be used for the log
scale. Zero or negative values return nothing.

Setting custom ranges
You can also specify a range of colors or select from a predefined color scheme.
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Do the following:

1. Click Appearance > Design in the properties panel.
2. Ensure that the Enable color range is set to On (default).
3. Click the color palette beside From, and choose a color.
4. Click the color palette beside To, and choose a color.

You can set your own color range by clicking the easel symbol in the color palette, and selecting a
color. You can also enter a color code string in the field next to the easel symbol. The colors should
be valid CSS colors.

Do the following:

1. Click Appearance > Design in the properties panel.
2. Move the Enable custom range slide button to the left to turn the option off.
3. Select a color scheme under Scale color.

A word cloud chart displaying food items in different sizes and colors.

Formatting numbers
It is possible to format the measure value. Different formatting can be applied to the same value, for
example as money, date, duration. The chart updates to reflect the changed number type.

Do the following:

1. Click Data > Measures in the properties panel and click a measure.
2. Select applicable number formatting form the Number formatting menu.
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3. Enter details in the panel fields. These display when choosing an option other than Auto
when further configuring the chart.

Using the styling panel to further customize the appearance
You have a number of styling options available under Appearance in the properties panel.

Click Styling under Appearance > Presentation to further customize the styling of the chart.

You can reset your styles by clicking next to each section. Clicking Reset all resets styles for
all available tabs in the styling panel.

For general information about styling an individual visualization, see Applying custom styling to a
visualization (page 638).

Customizing the text
You can set the text for the title, subtitle, and footnote under Appearance > General. To hide these
elements, turn off Show titles.

The visibility of the different labels on the chart depends on chart-specific settings and label
display options. These can be configured in the properties panel.

You can style the text that appears in the chart.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab, set the font, emphasis style, font size, and color for the following text
elements:

l Title
l Subtitle
l Footnote

Customizing the background
You can customize the background of the chart. The background can be set by color and image.

Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, you can select a background color (single color or
expression). You can also set the background to an image from your media library or from a
URL.
When using a background color, use the slider to adjust the opacity of the background.
When using a background image, you can adjust image sizing and position.

Customizing the border and shadow
You can customize the border and shadow of the chart.
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Do the following:

1. In the properties panel, expand the Appearance section.

2. Under Appearance > Presentation, click Styling.

3. On the General tab of the styling panel, under Border, adjust the Outline size to increase or
decrease the border lines around the chart.

4. Select a color for the border.
5. Adjust the Corner radius to control the roundness of the border.
6. Under Shadow in the General tab, select a shadow size and color. Select None to remove

the shadow.

Limitations
For information about general limitations, see Limitations (page 449).

l The word cloud chart can handle maximum of 100 words per entry.
l Words that take up more space than the chart are not displayed. You can adjust the font size

to show more values, but we do not recommend that you use fields with long text values.
l Word cloud charts cannot be used in Qlik NPrinting reports.

3.5 Creating and editing visualizations
You create visualizations from predefined charts, fields, or custom objects. Once
added to your sheet, you can edit and refine your visualizations.

Your visualization design is guided by the data in your fields and the unlimited potential for
exploring associations and correlations through measures and dimensions.

Get started here: Creating visualizations (page 555).

After creating a visualization, you may want to make adjustments to improve how it conveys
information to users. For example, you can change the data used, or adjust the appearance of the
visualization. You can add more dimensions or measures for further depth of information or remove
some to improve clarity. Learn more about editing your visualizations here: Editing visualizations
(page 556).

Adherence to design principals and clear communication of information is key to creation of apps
that engage and invite data discovery. All skill levels will benefit from reviewing best practices for
designing visualizations. See Best practices for designing visualizations (page 557).

Creating visualizations
You create visualizations by dragging the chosen type of visualization onto the sheet from the
assets panel and configuring its properties settings. For instructions on creating specific types of
visualizations, see that visualization type in Visualizations (page 176).
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Do the following:

1. Drag the visualization from the assets panel onto the sheet, or double-click the visualization.
2. Add dimensions and measures to the visualization.

You can add dimensions and measures using the buttons on the visualization. Or you can
drag a field from the Fields tab of the assets panel, and then select it to use it as a dimension
or measure. The number of dimensions and measures that are required depends on which
visualization you select.

3. Adjust the presentation: for example: sorting, coloring, or labeling.
For more information, see Changing the appearance of a visualization (page 607).

You can also add a visualization by copying visualizations. This is useful if you want to
use existing visualization settings in another visualization type. For more information,
see Copying a visualization from an existing visualization (page 598)

Custom objects are added in a similar manner. You start creating a visualization by dragging a
visualization extension onto the sheet. For more information, see Creating a visualization using a
custom object (page 597).

You can use containers to save space on your dashboard, by quickly switching between tabs with
different visualizations.

The types of data you have in your tables and fields impacts whether they can be used as
dimensions or measures.

l Dimensions determine how the data in a visualization is grouped. For example: total sales per
country or number of products per supplier. For more information, see Dimensions (page 99).

l Measures are calculations used in visualizations, typically represented on the y-axis of a bar
chart or a column in a table. Measures are created from an expression composed of
aggregation functions, such as Sum or Max, combined with one or several fields. For more
information, see Measures (page 105).

Editing visualizations
After creating a visualization, you may want to make adjustments to improve how it conveys
information to users. For example, you can change the data used, or adjust the appearance of the
visualization. You can add more dimensions or measures for further depth of information, or remove
some to improve clarity, and streamline a visualization.

The data in a visualization can be changed. For example, you might correct an invalid dimension or
measure, or unlink a measure from a master measure so you can modify it without changing the
master measure. For more information, see Changing the data of a visualization (page 601).

The appearance of a visualization can be edited to improve design and enhance understanding.
There are a number of different ways you can adjust the appearance of your visualizations:
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l Colors: Coloring is one of the best ways to highlight values in your visualizations. Qlik Sense
provides a range of different coloring options.
For example, you can assign specific colors to the distinct values in a master dimension to
ensure that those values use the same colors across all your visualizations.
For more information, see Coloring a visualization (page 616).

l Sorting: The sorting of your dimensions and measures helps ensure that content is presented
in a logical and understandable manner.
For more information, see Change the sorting of a visualization (page 612).

l Titles and labels: Titles and labels can be changed for clarity and detail.
For example, in a pie chart showing sales by region, you could add an expression providing
the total sales sum.
For more information, see Changing the appearance of a visualization (page 607).

l Presentation: Different visualizations have different options that can be adjusted to enhance
the display of data.
For example, you can set bars in a bar chart to display as grouped or stacked, as well as
vertically or horizontally.
For more information, see Changing the appearance of a visualization (page 607).

You can convert a visualization into another visualization type, and preserve your settings. For more
information, see Converting a visualization to another kind of visualization (page 639).

You edit visualization properties in the properties panel.

Do the following:

1. Click Edit sheet in the toolbar.
The properties panel for the sheet opens to the right.
If it is hidden, click Show properties in the lower right-hand corner.

2. Click the visualization that you want to edit.
The properties panel now shows the properties of the visualization.

3. Make your changes under Properties.
4. Make your changes in the properties panel.

5. Click Done editing in the toolbar.

Best practices for designing visualizations

Decluttering your apps
Too much information in an app makes it difficult to see what is important. Today’s modern user
interface style is a cleaner, simpler, flatter style of design. A simplified design subtly guides the
reader and allows them to stay focused.

Less is more
Users often try to include too much information in one app. Line charts with several measures can
be confusing and difficult to interpret. Try creating several smaller visualizations to spread this
information out onto the page. It also allows the reader to efficiently compare and contrast
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visualizations that are side-by-side. You can also use alternative dimensions and measures to allow
the reader to quickly switch between measures without overcrowding a visualization. For more
information, see Changing the data of a visualization (page 601).

There are number of different ways you can improve the aesthetics and functionality of your app.
Depending on your audience and what data you want to highlight, the way you design your
visualization may have a serious impact on the reader's interpretation of the data.

Know your limits
Consumers of your visualizations may be working with limited screen space or resolution. Qlik
Sense uses responsive design to address these limitations. However, if screen space or resolution
is too limited, certain design accommodations are necessary. These can include:

l A subset of data being displayed in bar charts and line charts. When the number of
dimension values exceeds the width of the visualization, a mini chart with a scroll bar is
displayed.

l Collapsed menus for selecting data filters. When the number of dimension values exceeds
the space available for the filter pane, the menu is collapsed. App consumers have to click on
the dimension name in the title of the filter pane to open a new pane. They can then make
their selections in the new pane. Additionally, when there is limited space, dimension names
may appear as ellipses in filter pane titles. App consumers have to click on the ellipses to
view the name of the filter pane.

l Truncated names in chart legends. Names that are too long for the space available for
dimensions and measures are truncated. An ellipses is added to the end of truncated name.
App consumers can hover their mouse pointer over the truncated name to view the complete
name.

l Missing legends, labels and titles.

App consumers can expand visualizations to address some of these issues. However, we
recommend that you test your apps on devices where the apps may be consumed. You can also
use various tools to test, such as responsive design mode in Firefox (Ctrl + Shift + M). If necessary,
you can move visualizations to new sheets reduce the amount of data shown in visualizations, and
so on.

Color accessibility
The spectrum of colors is narrower for people who have color-based visual impairment. They may
interpret your visualization differently than you intended.

For example, some people see the colors red and green more as yellow or brown. This form of red-
green color vision deficiency is the most common. This is worth noting since red often carries a
negative connotation in data visualizations, especially in finance.

A red or green KPI status can be confusing. You can use shapes with colors as performance
indicators to make your designs more accessible. For example, use a red empty circle to denote
bad, a green full circle for good, and a triangle as a warning symbol that only appears when a KPI
status is at an unacceptable level.

Lines, bars, and pie slices can be difficult to distinguish when the colors are distorted.
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For more information, see Changing the appearance of a visualization (page 607).

Filter and icon placement
Filers and icons are an essential part of data visualization, but it can be difficult to know where to
place them or how to sort them. You can often anticipate where the user will begin to read based on
a few well-established design principles.

Left placement
Several popular websites use left-side navigation tiles and filters. This is due to the fact that many
languages read from left to right. As a result, the left-side of the screen is where these readers look
most frequently. Users who are scanning for content tend to gravitate toward the left side of the
screen. The farther to the right objects are, the less users will look at them. If all your filters and
icons are stacked vertically on the left, it gives them equal weight.

Alternately, with languages where text is written right to left, the opposite of this is true. This should
be kept in mind if your apps are translated into these languages.

Top placement
Another common placement option for icons and filters is along the top of an app. By not placing
filters or icons on the left it gives more space for larger visualizations with distracting menus. When
filters and icons are placed above visualizations they are also seen as separate from the content
below. This can help show the reader that you are prioritizing the filters or icon. If all your filters and
icons are side-by-side at the top, the one furthest to the left carries more weight and is prioritized
by the reader.

For more information, see Structuring an app using sheets (page 10).

Information hierarchy
Sometimes you want your reader to prioritize certain visualizations over others. You can show
hierarchy of information by using a few key design best practices. For example, you can use
different sizes to emphasize some visualizations. Larger information is seen as more important: by
increasing the font or chart size, you can show the reader where to look first.

Page placement also plays a part in information hierarchy. The information at the top of a page is
perceived as more important than information at the bottom of the page because it is read first.
Information on the first page is perceived as more important than information on the last page.

Adding context to KPIs
KPIs are a great way to communicate some of the big ideas inside your app. However, KPI values do
not provide any context to the numbers and calculations that are happening behind the scenes. A
green light next to a KPI does not tell the reader if the goal was barely achieved, or if you greatly
surpassed it.

To help bring context to your KPIs, include supporting information next to the value in smaller text.
For example, you can compare the current KPI value with the value from the previous year. You can
also add a small bar chart without axes or values to provide information about the current trend.
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Avoid the pitfalls of data visualization
To experience the benefits of data visualizations you must avoid the pitfalls. Here are some
common ones:

Color abuse
Do not overdo colors. Be aware that the wrong color in the wrong place might cause confusion
rather than clarity. Also, the same color may mean different things in different parts of the world.

Misuse of pie charts
Avoid having pie charts side by side to compare. Try not to squeeze too much information into
them.

Visual clutter
Too much information defeats the purpose of clarity. Use a maximum of nine KPIs, and remove all
visual clutter.

Style over substance
A beautiful visualization is not necessarily the most effective. Use design best practices at all times.

Bad data
Spot and correct issues with your data before you present it. Do not let your visualization take the
blame for bad information.

Creating visualizations with Insight Advisor
Explore your data and create visualizations with Insight Advisor Analysis Types and
Insight Advisor Search. Insight Advisor creates visualizations for you using the Qlik
cognitive engine and your app logical model. Click Insight Advisor in a sheet to use
Insight Advisor Search and Insight Advisor Analysis Types.
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Insight Advisor Analysis Types
Select the type of analysis you want to see, such as breakdown, trend over time, or mutual
information. Then select the data you want used in the analysis. Insight Advisor generates charts
using your choices. Insight Advisor Analysis Types is the fastest way to create charts when you
know what you want to see and the data sources to use, but not how to build the analysis yourself.

Creating analyses by selecting analysis types (page 562)

Navigating Insight Advisor (page 570)

Insight Advisor Search
Enter a natural language question or statement. Insight Advisor then uses the Qlik cognitive engine
to interpret your question and create visualizations to answer your questions from your data model.
Insight Advisor Search is the fastest way to create charts when you have a specific question to
answer.

You can also select fields and master items from the assets panel. Insight Advisor generates results
based on your selections.

Creating analyses using search (page 564)

Creating analyses by asset selection (page 565)

Navigating Insight Advisor (page 570)

Users can also access Insight Advisor in the hub with Insight Advisor Chat.
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Insight Advisor and the logical model
Insight Advisor creates visualizations using the Qlik cognitive engine and a logical model of your
data. The logical model defines how fields in your data model should be used a dimensions or
measures, as well as the relationships between fields. By default, Insight Advisor builds a logical
model by learning from user interactions. If you add charts to sheets or edit charts, Insight Advisor
learns these preferences.

You can also create your own custom logical model for the app. Business logic lets you to define the
relationship and use of data in your logical model. When business logic is turned on, precedent-
based learning is not available. If you define calendar periods and set them as default periods,
period analysis and period performance analysis types are available.

As of August 2022, Insight Advisor, including business logic, is no longer supported with
Qlik Sense Desktop. In November 2022, Insight Advisor will be upgraded to a new
experience. This will only be available on Qlik Sense Enterprise on Windows. Users who
want to continue using Insight Advisor and business logic on Qlik Sense Desktop should
not upgrade to August 2022.

Creating visualizations with Insight Advisor Analysis Types and Insight
Advisor Search
You can generate charts using Insight Advisor in three ways:

l Select the type of analysis you want to see and the fields or master items that should be used
with it. Insight Advisor Analysis Types then generates matching analyses .

l Ask Insight Advisor a question and let Insight Advisor Search generate charts using natural
language analytics.

l Select fields or master items and let Insight Advisor Search generate charts through auto-
analysis of your data.

The data assets available to you in Insight Advisor depend on if the app uses business logic to
define its logical model and your space permission. If you have Can view permission will only be
able to see master items, unless the app defines its logical model with business logic.

Creating analyses by selecting analysis types
Pick an analysis type and then add fields to create analyses with Insight Advisor Analysis Types.
This is a fastest method of creating visualizations when you know what analyses you want to see
and the data you want to use, but not how to build the analyses yourself.

Click Create an analysis on the Insight Advisor start page. In Analysis options, all available
analysis types display with descriptions of their use.
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Analysis options

After selecting an analysis type, you then select fields or master items to use in the analysis. Insight
Advisor offers suggestions of assets to use for each parameter. You can change analysis types by
selecting a new analysis type from the dropdown or clicking View all analyses to view the analysis
options. You can clear your selections by clicking Reset analysis.

Building an analysis

Do the following:

1. In a sheet, click Insight Advisor.
2. Click Create an analysis.
3. Under Analysis options, select your analysis type.
4. Add the required fields or master items for your analysis type.

When you have added the required fields, Insight Advisor generates your charts.
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Creating analyses using search
Ask Insight Advisor Search natural language questions and it generates relevant charts using field
names, field values, and master items. You can search Insight Advisor in the following ways:

l Enter a natural language question or statement, such as what are the top products for sales
or Show me Product by Revenue in Sweden. Natural language questions work best when
they refer to field or master items directly.
For guidelines on using natural language in your searches, see Using natural language with
Insight Advisor (page 574).

l For information about language support in Insight Advisor Search, see Supported languages
(page 569).

l If your browser's voice-to-text capability is supported in Insight Advisor, you can click the
microphone icon to ask Insight Advisor your question.

Qlik Sense Desktop does not support voice-to-text capabilities for questions.

Insight Advisor uses the fields or terms you specify. It may use additional fields in the generated
visualizations. Insight Advisor uses any precedents you have given it for hiding charts, setting fields
as dimensions or measures, or excluding fields from analysis. In Qlik Sense Enterprise, Insight
Advisor can use precedents learned from other published apps if they use a similar or identical data
model.

For natural language questions, Insight Advisor tries to find a matching Insight chart result. If one is
found, it shows related results as well. You can click to view how Insight Advisor generated
results from your question. .

Matching result with natural language insights

If you receive the following error message: "Unable to generate insights - Please try
again later," you might not meet the CPU requirements for Insight Advisor.

Create apps and visualizations - Qlik Sense, November 2024 564



3   Visualizations

Do the following:

l In a sheet, enter a question or statement in the Ask Insight Advisor search bar and click .
Alternatively, click Insight Advisor, enter a question in the Insight Advisor search bar and
click .

Creating analyses by asset selection
Select fields and master items to use in charts and let Insight Advisor Search auto-generate charts,
select assets to use from the assets panel. You can also enter asset names in the Insight Advisor
search bar. Insight Advisor then uses the fields you selected to generate charts. It may use
additional fields in the generated visualizations.

Insight Advisor uses any precedents you have given it for hiding charts, setting fields as dimensions
or measures, or excluding fields from analysis. In Qlik Sense Enterprise, Insight Advisor can use
precedents learned from other published apps if they use a similar or identical data model.

Insight Advisor analyses generated by selection

Do the following:

1. In a sheet, click Insight Advisor.
2. In the assets panel, select fields and master items to create analyses.

Alternatively, enter field or master item names in the search bar.
As you select assets, Insight Advisor generates visualizations.

Voice-to-text data transfer considerations
In many internet browsers, Insight Advisor voice-to-text search functionality uses the Web Speech
API for external processing of voice-to-text data. This is used by both Insight Advisor Search and
Insight Advisor Chat. The user’s internet browser may send the audio recorded by the browser API
to an external source for transcription. Voice processing will be handled by the web service chosen
by the user’s web browser. As a result, the captured information could be sent to a third-party
server. Qlik is not responsible for the data processing by this third-party.
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If users want to restrict this information flow to their relevant third-party browser (turn off the
voice-to-text feature), this might be achieved through specific controls, including settings within
their browser of choice and other security configurations.

Using Insight Advisor analyses
You can expand an Insight Advisor analysis by selecting it or clicking . You can then make
selections in the analysis.

Note the following regarding selections:

l Selections apply to all analyses.
l Selections made in charts from your sheets are kept when you open Insight Advisor.
l Selections do not affect the charts created by Insight Advisor.

If an analysis is new, you can add it to your sheets. If the chart exists in a sheet, you can click the
sheet name at the bottom of the chart to go to that sheet.

Some analysis types, such as period over period dashboard, provide multiple related visualizations
rather than a single chart. These show a preview of the kind of visualizations included in the
analysis. Click Open analysis to view the analysis with data.

A period over period dashboard analysis

You can view additional options by clicking . The following options are available:
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l Full screen: Expand a chart to make selection.
l Edit analysis properties: Edit the chart properties to change dimensions, measures, and the

chart type.
Editing Insight Advisor analysis properties (page 567)

l Add to sheet...: Add the chart to a new or existing sheet.
l Add to new sheet: Add the charts to a new sheet (period changes, period changes

(detailed), period over period, period over period (selected) analysis types only).
l Download: Download the chart as an image, PDF, or data.
l Hide: Hide charts that you do not want Insight Advisor to use again. You can view the charts

hidden from your current search in General properties.

Hide is not available in apps using business logic.

Editing Insight Advisor analysis properties
Edit Insight Advisor analysis by selecting a chart and clicking . The following properties are
available in Analysis properties:

l Chart type: If available, select a different chart type. For an outline of the alternate chart
types available for the different analyses, see Insight Advisor analysis types (page 575).

l Favorable trend: (Rank analysis only) Indicate if the favorable trend for ranking is to increase
or decrease.

l Parameters: Make adjustments to parameters specific to the analysis type of the chart.
l Dimensions and Measures: Change the fields used as Dimensions or as Measures. You can

change the measure aggregation. Reorder measures or dimensions by dragging them.
Dimensions and measures from Insight Advisor analysis can be added to your master items.
Click a dimension or measure and then click Add new.
If you specified filters in a natural language question, such as specific field values, you can
modify them as well.

l Details: View information about why the chart was generated and the precedents Insight
Advisor has learned from a chart. Select details by clicking them to change or reject them.
You can set fields as dimensions or measures or exclude fields from future analysis. You can
hide charts from future analysis by selecting We suggested a chart for this combination of
data and clicking Hide this chart.

l Analysis period: Change which period from business logic calendar periods is applied to the
chart. You can adjust the analysis period by selecting new values from Period 1 or Period 2.
Select an analysis period for rank type charts to view period and period performance analysis
types.

Analysis period is only available when business logic is turned on and calendar
periods have been created for the app. If there is no business logic, Analysis
period is available if the app has date/time fields with autoCalendar derivations in
the load script.
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Editing calendar period Insight Advisor analyses
If a default calendar period is assigned to a group, additional period analysis types are available for
Insight Advisor analysis. Default calendar periods are created in business logic. These have
different properties than other charts. The following types are available:

l Period changes: Shows the change of a measure from the current or latest period in the
selected analysis period.

l Period changes (detailed): Compares a change in a measure from the current period to the
previous period. The change is measured using a forecasted target value. You define the
percentages for meeting the target, almost meeting the target, and missing the target.

l Period over period: Compares a change in a measure of the current period versus the
previous period.

l Period over period (detailed): Compares changes in a measure over time between periods.
It includes a filter pane for exploring dimension values period over period.

These analysis types have unique properties. Period changes and Period over period (detailed)
have the following properties:

l Breakdown: Select the dimension to use with the measure to view the period changes.
l Measures: Select the measure for which you want to see period changes.
l Analysis period: Select the analysis period. You can adjust the analysis period by selecting

new values from Period 1 or Period 2.

Period over period has the following properties:

l Measures: Select the measure for which you want to see period changes.
l Analysis period: Select the analysis period. You can adjust the analysis period by selecting

new values from Period 1 or Period 2.

Period over period (detailed) has the following properties:

l Parameters: Set the percentage limits, expected change margin, and expected change rate.
l Favorable trend: Indicate if the favorable trend for the measure is to increase or decrease.
l Breakdown: Select the dimension to view the detailed period changes with the measure.
l Measures: Select the measure for which you want to see period changes.
l Analysis period: Select the analysis period. You can adjust the analysis period by selecting

new values from Period 1 or Period 2.

These analysis types have unique properties. Period changes and Period over period (detailed)
have the following properties:

Insight Advisor learns your preferences for that chart if you add it to a sheet or click Learn after
editing the chart. Precedents set by a user only apply to that user's instance of Insight Advisor.

Managing general properties
In General properties, you can view and edit your hidden and learned charts and the precedents
you have set for generating charts.
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General properties are not available when business logic is turned on.

The following properties are available:

l Hidden recommendations contains charts you have hidden from searches. You can click
to show the chart again in searches.

l Learned recommendations contains charts you selected Learn on after editing. You can
delete learned charts by clicking .

l Your defined preferences shows all the preferences Insight Advisor has learned. You can
delete preferences by clicking .

You can clear all hidden charts, learned charts, and preferences by clicking Clear all.

Supported languages
Qlik Sense supports English natural language questions.

If your Qlik Sense deployment includes access to a Qlik Sense SaaS tenant, administrators can
enable additional support for the following languages:

l German
l Spanish
l French
l Italian
l Dutch
l Polish
l Portuguese
l Russian
l Swedish

English is used by default for browsers not set to a supported language. The language used for
questions can be changed by selecting a new language from the Language button. For more
information, see Enabling multi-language natural language questions in Qlik Sense Enterprise on
Windows.

Limitations
The following section lists limitations for Insight Advisor.

General limitations
Insight Advisor has the following general limitations:

l Insight Advisor supports master items that use dollar-sign expansions in their expressions
with the following limitations:
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l Expressions and captions for master items are expanded once and the results are
cached. The dollar-sign expressions are not reevaluated until the expressions change
or the cache expires (usually 30 days after the evaluation).

l Dollar-sign expressions that are defined in a way that expands to values, such as =sum

(Sales), are not supported. These expressions cannot be combined with filters in
Insight Advisor. Dollar-sign expressions must expand to expressions to be used in
Insight Advisor.

l In published apps, only master items are available for use in Insight Advisor. Insight Advisor
Chat can use fields from published apps when creating Insights charts. If you go to Insight
Advisor using from Explore this further, your search may not be available.

l If a field name contains only numerical values, that field will be used when generating results
from a natural language question instead of a superlative (such as top or bottom with the
same numerical value).
For example, if you searched for top 3 service providers and one of your fields was named 3,
3 will be used in the results instead of the top 3 results for service providers.

l English questions using the trend keyword with one measure and a time filter are not
supported.

Limitations for natural language insights
The following limitations apply to natural language insights in Insight Advisor:

l Natural language insights are not always included with supported analysis types, depending
on how a natural language question is processed and the data being used.

l Natural language insights only provide a general statement when the question includes more
than two filters or more than two data value filters on a dimension. The filters used are
included in the response, however.

l Natural language insights are available for the following analysis types:
l Ranking
l Trend over time
l Comparison
l Breakdown (geospatial)
l Clustering
l Correlation
l Process control (mean)

Navigating Insight Advisor
Click Insight Advisor in a open sheet to open Insight Advisor Search and Insight Advisor
Analysis Types.

Insight Advisor is available from the sheet view of an app. Click the Insight Advisor button to open
Insight Advisor.

Insight Advisor is not available when a sheet is in edit mode.
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Insight Advisor button

From Insight Advisor, you can start generating analyses with Insight Advisor Search or Insight
Advisor Analysis Types.

Insight Advisor

Enter a question or select fields from the assets panel to start creating analyses with Insight Advisor
Search. Click Create an analysis to start building analyses with Insight Advisor Analysis Types. You
can also select from the common analysis types to start with Insight Advisor Analysis.

Insight Advisor assets panel
In Insight Advisor Search, you can create queries by selecting fields and master items. In Insight
Advisor Analysis Types, you can select fields and master items to use in your analysis.

If the app is published, only master items are available.
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Insight Advisor assets panel
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Insight Advisor search box
You can also access Insight Advisor Search by entering a natural language question in the search
box.

Search box

You can enter your search here, either by entering asset names or using natural language. If you
used a natural language question, you can click to view the filters generated from your question.

Insight Advisor analyses
These are the charts created by Insight Advisor. Insight Advisor Analysis Types shows the primary
chart for your analysis type, with alternative chart types for your analysis beneath. Insight Advisor
Search indicates the number of results and breaks them down as follows:

l How many results are found.
l How many charts already exist in your sheets.
l How many charts are newly generated by Insight Advisor.

Analyses generated by Insight Advisor

Insight Advisor charts can be added to existing or new sheets. Charts can also be downloaded as
an image, PDF, or as an Excel spreadsheet containing the data used in that chart.

Using Insight Advisor analyses (page 566)

Properties panel
The properties panel contains options for editing analysis and changing the precedents you have
set in Insight Advisor.
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Properties panel in Insight Advisor

In General properties, you can view and edit your charts and the precedents you have set for
generating analysis. For more information, see Managing general properties (page 568).

In Analysis properties, you can edit an analysis and view details. You can see the Analysis type
used to create the chart. Click to learn more about the analysis type used. For more information,
see Editing Insight Advisor analysis properties (page 567).

Insight Advisor Analysis Types parameters
When using Insight Advisor Analysis Types, you select the parameters for your analysis. You can
select from the assets panel or from the recommendations for each parameter type.

Parameters for Insight Advisor Analysis Types

Using natural language with Insight Advisor
Insight Advisor supports natural language questions, such as Show me Product
Inventory for Japan under 2500.

Natural language questions support three kinds of filters:

l Time: A unit of time or date. For example, Show me 2019 Sales.
l Category: A value from one of the dimensions. For example, Show me Sales by Product for

Sweden.
l Measure: A value or values from a measure. For example, Show me Sales for Sweden by

Product under 1K.
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You can search for facts, comparisons, and rankings. Facts are statements such as What are my
sales, or Show expenses over time for 2019. You can ask for a comparison by adding vs or compare
to your question. For example, Compare sales to expenses over time. You can ask for rankings by
adding top to your question. For example, Show me top 10 product by sales for 2020.

Qlik Sense supports English natural language queries.

English is used by default for browsers not set to a supported language. The language
used for queries can be changed by selecting a new language from the Language
button. For more information, see Enabling multi-language natural language queries in
Qlik Sense Enterprise on Windows.

If your Qlik Sense deployment includes access to a Qlik Sense SaaS tenant,
administrators can enable support for additional languages. For more information on
supported languages in Insight Advisor Search, see Supported languages.

Natural language searches need to reference field names and values in your data model. You can
also tag master items with synonyms using tags on your master items. Use the format alt:<term> in
synonym tags. If you wanted to use cities as a synonym, you would tag the master item alt:cities.
For more information, see Tagging master items (page 150).

Click on a chart generated by Insight Advisor to provide feedback on the visualization. You can
indicate a positive or negative response, and write a comment.

When searching field values, natural language queries only search the first 100,000
values per field in the question.

For more information about natural language questions, see Qlik Sense Natural Language Query
features.

Insight Advisor analysis types
Insight Advisor provides results using a wide range of analysis types. These analysis
types provide best practice visualizations for generated charts.

Different analysis types are used depending on the inputs of the search and the characteristics of
your data. The Qlik cognitive engine determines the best analysis type for your search depending
on the available data. The following table describes the analysis types. Not all conditions for each
analysis type are listed. The table also lists charts potentially available as alternatives when editing
an Insight Advisor analysis.
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Analysis type Description Dimensions Measures

Breakdown View nested dimensions of data that
provide a breakdown of relative
contributions to a measure.

2-3 1

Breakdown
(geospatial)

Group data by simple and hierarchical
geographic divisions.

1-2 1-2

Calculated
measure (KPI)

Summarize performance in a given
business segment or dimension using a
key performance indicator (KPI).

0 1-2

Clustering (k-
means)

Cluster data points aggregated by
similarities from 2 measures over a
dimension using a machine learning k-
means algorithm.

1 2

Comparison Compare two measures for a dimension. 1 2

Correlation Identify complementary and inverse
relationships between two data values.

0-2 2

Mutual
information

Create a measure of certainty between
pairs of values using a machine learning
algorithm that applies random data
distributions.

The dependency indicator ranges between
0 percent (no dependency) and 100
percent(strong dependency).

Mutual information selects one field
(measure or dimension) as the target and
then selects 1 to 10 dimensions or
measures as drivers.

Results for this analysis type for the same
fields or selections might vary due to the
random data selection.

variable variable

Overview Describe how data ranges relate to each
other in terms of an absolute measure.

1-2 1

Analysis types
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Analysis type Description Dimensions Measures

Period
changes

Build a sheet with measures, rank, and
comparison analysis for dimensions across
different time periods.

Requires a default calendar period set for
the group containing the measure in the
logical model.

1-2 1

Period
changes
(detailed)

Build a sheet with measures, rank, and
comparison analysis for a hierarchy of
dimensions across different time periods.

Requires a default calendar period set for
the group containing the measure in the
logical model.

1 1

Period over
period

Compare dimensions across time periods.

Requires a default calendar period set for
the group containing the measure in the
logical model.

1 1

Period over
period
(selected)

Compare dimensions across time periods.
It includes a filter pane for selecting
dimension values.

Requires a temporal fields with
autoCalendar-derived field selected as a
part of the query.

1-3 1

Process
control
(mean)

Monitor data against expected statistical
ranges based on mean values.

1 date/time
dimension

1

Process
control
(rolling mean)

Monitor data against expected statistical
ranges based on nearby values.

1 date/time
dimension

1

Ranking Rank dimension values by relative
importance with a measure.

1-2 1

Ranking
(grouped)

Rank hierarchical dimension values by
relative importance with a measure.

1-2 1

Relative
importance

Show the size of dimension values that
contribute to the whole. Can also be used
to perform Pareto or 80-20 contribution
analysis.

1 1
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Analysis type Description Dimensions Measures

Trend over
time

Show data trends over time, optionally
broken down by a dimension with low
cardinality.

1 date/time
dimension and
optionally 1 other
dimension

1-3

Values (table) Show data organized in rows and columns
that show measures and dimensions.

0-10 0-10

Year to date Compare dimensions over the same period
in a previous year.

1 1

Using smart sheets in Insight Advisor for period-based analyses
Use smart sheets in Insight Advisor to automatically build full sheets for your Qlik
Sense app. Smart sheets are specifically designed for building period-based analyses.

Smart sheet automatically generated by Insight Advisor

Access the smart sheet builder from Insight Advisor Analysis Types when you select any of the
following analysis types:

l Period over period (selected)
l Period changes
l Period changes (detailed)

The Period over period analysis type is a similar analysis type, but technically only
builds single visualizations. It is mentioned here because the requirements for working
with this analysis type are the same as for the smart sheet-based analysis types.
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Requirements
The following table outlines what you need to be able to use the Period over period, Period over
period (selected), Period changes, or Period changes (detailed) analysis types.

Analysis type Requirements

Period over period At least one calendar period defined using autocalendar.

Period over period (selected) At least one calendar period defined using autocalendar.

Period changes One of the following:

l At least one calendar period defined using autocalendar.
l At least one calendar period defined using a custom

calendar.

Period changes (detailed) One of the following:

l At least one calendar period defined using autocalendar.
l At least one calendar period defined using a custom

calendar.

Requirements for working with period-based analysis types in Insight Advisor

Using calendar periods and autocalendar
Using autocalendar in your app is the easiest way to guarantee you will be able to use all period-
based analysis types. This is because autocalendar automatically adds a number of calendar
periods into the app to make period-based analyses easier.

When you build an app and load data with Data manager, autocalendar is automatically created in
the script if date fields are detected in the data.

If you are not able to use these analysis types in your app, it is because you have not created the
required calendar period. This could be due to a number of reasons, including:

l Your app was built using scripting, and you did not manually insert the autocalendar script
into the load script.

l You do have autocalendar in the app, but all calendar periods were removed in the app's
business logic.

l Your app has at least one calendar period, but it was created using a custom calendar (with
custom calendars, the Period over period and Period over period (selected) analysis types
are not available).

Adding autocalendar to your load script
If you have built your app in Data load editor and have not defined a custom calendar, you can insert
the autocalendar script directly into the app's load script and change the names of the fields you
wish to link to autocalendar.
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Adding or re-adding calendar periods
If calendar periods have been deleted from your app's business logic, add at least one of them back
to access the available period-based analysis types. For autocalendar-defined calendar periods,
these can be either Last sorted value or Relative.

Creating smart sheets
For a full example of how to create a smart sheet and add it to a sheet in a Qlik Sense app, see
Building an app. Look for the section Create a sheet from analysis types.

Editing visualizations created by Insight Advisor
Insight Advisor selects and generates charts driven by analysis types. Analysis types
and chart functions are chosen based on the inputs of the search and characteristics of
the data. Business analysts design the business logic components of apps and can also
edit properties and extend the functions underlying the charts further. For more
information, see Business logic. For more information on analysis types, see .

The following examples show ways that Insight Advisor charts can be edited through properties
and the expression editor to enhance visualizations that best capture and frame your data. These
examples are based on charts that can be generated and then extended from the Insight Advisor
business logic tutorial app. .

Screenshots for these examples are from Qlik Sense SaaS and may differ in Qlik Sense
Enterprise on Windows. Screenshots in the examples may differ depending on the date
on which you loaded the business logic tutorial app.

Mutual Information: Changing measures for improved charts
Statistical dependencies between a specified value (measure) and other selected items is
presented in Insight Advisor by the Mutual Information chart. The dependency ranges between 0%
(no dependency) and 100% (strong dependency). This example shows how you can replace
measures to present more interesting and meaningful relationships in the chart.

Do the following:

1. In the business logic tutorial app, enter the search dependencies in the search box. Look for
a result displaying Mutual dependency between SalesOffice and selected items.
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Default results for Mutual Information search

2. Select Add to sheet in the chart, then Create new sheet.

3. From the app overview, click Sheets to view the sheets. Select My new sheet and give
the sheet a Title and Description. For this example, name the sheet Mutual Information Sales
and an optional description Mutual information between sales fields.

4. Click Edit sheet in the toolbar and select the mutual dependencies chart.

5. Click anywhere in the chart title to change the title from Mutual dependency between
SalesOffice and selected items to Mutual information around sales.

6. Modify the fields analyzed in this chart. Insight Advisor selected four measures to include in
the chart that are related to geography. This was a reasonable interpretation of what
dependencies the field SalesOffice might have because SalesOffice was classified as a city
in the logical model of the app. Modify the measures in the properties panel and change them
to fields that will better reflect how Sales is impacted by variables related to sales quantity,
cost of sales, and sales support.

a. Select Data in the properties panel and in the Measures section; expand the measure
SupplierCountry. Select in the Expression field to open the Edit expression dialog.
Click Apply.
Edit the expression by replacing SalesOffice with Quantity and replace
SupplierCountry with Discount.
Select the Label field. Replace SupplierCountry with Quantity and Sales.
Edit field parameters

b. Expand the measure SalesOffice and PostalCode. Select in the Expression field to
open the Edit expression dialog.
Edit the expression by replacing SalesOffice with Sales and replace PostalCode with
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SupportCalls.
Select the Label field . Replace PostalCode with Support calls and Sales.

c. Expand the measure SalesOffice and City. Select in the Expression field to open
the Edit expression dialog.
Edit the expression by replacing SalesOffice with Discount, and replace City with Cost
of Sale.
Select the Label field. Replace City with Discount and Cost of sale.

d. Delete the measure SalesOffice and Country by right-clicking on the measure and
choosing Delete.

e. Delete the measure SalesOffice and CountryCode by right-clicking on the measure
and choosing Delete.

7. Edit the X-axis range. These three measure comparisons all represent high levels of
dependency. To emphasize the differences in values and make the chart more interesting,
modify the range of the bar chart:

a. Expand the Appearance section and then X-axis.
b. Switch Range from Auto to Custom.
c. Select Min/Max for values to set. Set Min to 0.9 and Max to 1.

8. Select Done editing.
Mutual Information chart after editing

K-Means clustering: Editing the number of clusters and selections
Insight Advisor generates a scatter plot chart driven by k-means functions to group similar items
into clusters. The following example shows how you can specify the number of clusters generated
by the chart and remove outlying datapoints. For more information, see and .
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Do the following:

1. In the business logic tutorial app, enter the search Customer by Sales by Gross Profit in the
search box. Look for the result titled Customer clustered by sum(Sales) and sum(Gross
Profit) (K-Means).
Default results for kmeans search

2. Select Add to sheet in the lower right of this chart, then Create new sheet.

3. From the app overview, click Sheets to view the sheets. Select My new sheet and give
the sheet a Title and Description.For this example, name the sheet Customers clustered by
sales and add the description Kmeans applied to customer data by Sales and Gross Profit.

4. Select Edit sheet in the toolbar and select the k-means cluster chart.

5. Modify the scatter plot chart:
a. Enlarge chart: Make the chart larger to take up the canvas by dragging the lower right

corner.
b. Edit the number of clusters argument. Expand the Appearance section and then

Colors and legend. Insight Advisor has colored the clusters by dimension. Select
under the Select dimension field to open the expression editor. Modify the num_
clusters argument by changing the value 0 to 6 (Insight Advisor utilized auto-
clustering where if 0 is entered for the number of clusters, an optimal number of
clusters for that dataset is automatically determined). Select Apply.
Edit the first parameter in the expression (num_clusters)

c. Edit axis ranges: The default chart that is generated shows range that is less than 0.
Negative numbers are not meaningful in this context and this range takes up space in
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the chart. In the Appearance section, expand X-axis: Sales and change Range from
Auto to Custom. Note that Min automatically resets to 0. Expand Y-axis: Gross Profit
and change Range from Auto to Custom and note that Min automatically resets to 0
for the Y-axis as well.

6. Select Done editing.

7. Deselect data: Data can be excluded from the chart by deselecting items that are not of
interest. Exit edit mode by selecting Done editing and open the Selections tool .
Search for Customer and select all customers except the following customers: Big Foot
Shoes, Boleros, Bond Ltd, El Carnevale, Fritid AB, Las Corbatas, The Fashion, and Vite.
KMeans scatter plot chart after edits

Period over period analysis: Changing the analysis period
Insight Advisor supports creation of behaviors to use a preferred default calendar period with a
measure group. The following example demonstrates how to change the calendar period to view
results for a different period. You can change the calendar period property to generate a Period
over period chart that displays sales over the last year rather than over the last month.

Do the following:

1. From the business logic tutorial app, enter the search Show me sales in the search box.
Locate the Period over period result.
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Period over period result for sales search

2. Select the Period over period chart to display options to the right.
3. Expand Analysis period in the properties panel to display calendar period options.
4. Select Quarter comparison.
5. Change the value in Period 1 to 2020-Q1.
6. Change the value in Period 2 to 2021-Q1.
7. Sales now displays the results for the first quarter of 2021 compared to the first quarter of

2020.
Period analysis chart after changing the Analysis period

Creating visualizations using Insight Advisor chart suggestions
Qlik Sense offers a wide range of visualizations to use with your data. Deciding on the
correct chart type can be challenging when creating your first Qlik Sense app.
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Insight Advisor chart suggestions enable you to select data fields and let Insight Advisor choose the
dimensions, measures, and visualization types. As you add or remove fields, the suggested
visualization adjusts itself based on your changes. You can customize a suggested visualization
with a focused set of properties.

If you started a visualization, enabling Chart suggestions will change your visualization to a
suggested visualization.

If you enable Chart suggestions and then disable them, you will lose changes made to
your visualization. You can restore your old visualization by undoing the changes.
However, if you navigate away from Sheet view or make changes in the assets panel,
you will not be able to undo and restore your visualization.

Creating a new visualization using chart suggestions

Do the following:

1. Click Edit sheet in the toolbar.
The assets panel opens on the left-hand side.

2. From Fields, drag and drop a field into your sheet.
Fields suggested as dimensions are added as tables or histograms. Fields suggested as
measures are added as KPIs.
To add fields as filter panes hold the shift key when you drag and drop the field.

3. Add additional fields by doing one of the following:
l Drag and drop a field onto the visualization created from the first field, or on Suggest

on the right-hand side.
Qlik Sense determines if the field should be used as a dimension or as a measure, and
which measure aggregation to use.

l Click Add on the properties panel and select a field.
l Drag and drop a field on Drop item here under Dimensions or Measures.

The visualization will change as fields are added to it.
4. Optionally, remove unwanted fields.

5. Click Done.

Changing an existing visualization using chart suggestions
You change an existing visualization by adding fields or removing unwanted fields. Enabling Chart
suggestions in the properties panel on the right-hand side changes the selected visualization to a
chart suggestion based on the fields of the visualization. You can change the suggestions made by
Qlik Sense. For example you can:

l Drag fields between Dimensions and Measures to change how a field is used. Moving a field
to Dimensions removes its aggregation. Moving a field to Measures assigns it an
aggregation.
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l Choose a different aggregation for a field used as a measure. Your aggregation choice will be
used whenever you use this field as a measure, while Chart suggestions is enabled.

l Use Change chart type to choose a different type of chart from the one suggested.

Adjusting the settings when using chart suggestions
You can adjust the settings in the properties panel for Data and Appearance. The properties panel
for visualizations created with chart suggestions contains a focused set of properties settings.
Disabling Chart suggestions brings back access to all available properties. For descriptions of the
available fields see the visualization properties topics in Visualizations (page 176).

Limitations when using chart suggestions
l You cannot enable Chart suggestions for a master visualization.
l You cannot enable Chart suggestions for filter panes, histograms or maps.
l Charts with Chart suggestions enabled are not supported in Qlik NPrinting reports. To

include charts created using chart suggestions in Qlik NPrinting reports, disable Chart
suggestions.

l You can only change the aggregation of a measure when its label is the default label.
l You cannot drag a master dimension to Measures. You cannot drag a master measure to

Dimensions.
l You can only drag a field from Measures to Dimensions if its expression is simple. For more

information on how to use expressions in visualizations see Using expressions in
visualizations (page 155).

Guidelines for visualizations, fields, and naming
There are certain conventions and limitations you need to be aware of when working
with Qlik Sense. For example: the maximum number of characters to use in names,
descriptions, and expressions, as well as characters reserved for use by Qlik Sense
only.

Max number of visualizations
The maximum number of visualizations there can be on a sheet is limited to the number of cells on a
sheet: 288 (24x12). The maximum practical number will be less than this because of the limited use
for visualizations that are made up of only 1 cell.

Upper limits on name lengths
The following limits apply to the number of characters that can be used in various situations in Qlik
Sense:
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Situation Upper limit

Names (title, dimension,
footnote...)

Max 255 characters.

Descriptions Max 512 characters.

Expressions Max 64,000 characters.

Tags Max 31 characters per tag and max 30 tags per master
item.

Text & image chart: Max 12,000 characters.

Upper limits on name lengths

Naming conventions
You can refer to a number of entities by their names in Qlik Sense, such as:

l Fields
l Dimensions
l Measures
l Variables
l Bookmarks

Some characters are reserved for system purposes in Qlik Sense. To avoid potential errors, avoid
using the following characters in names:

l :
l =
l [
l ]
l {
l }
l (
l )
l $
l ´
l `
l '

If you use long names for your dimensions and measures they will be displayed truncated. “...” will
be shown to denote that part of the name is hidden.

Max number of characters in expressions
The maximum number of characters that can be written in a vizualization expression is 64,000. If
you attempt to build an expression with more than this number, the expression will be truncated.
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Conventions for number and time formats
In many interpretation and formatting functions it is possible to set the format for numbers and
dates by using a format code. This topic describes the formats for the number, date, time, and
timestamp functions. These formats apply both to script and chart functions.

Number formats
To denote a specific number of digits, use the symbol "0" for each digit.

To denote a possible digit to the left of the decimal point, use the symbol "#".

To mark the position of the thousands separator or the decimal separator, use the applicable
thousands separator and the decimal separator.

The format code is used for defining the positions of the separators. It is not possible to set the
separator in the format code. Use the DecimalSep and ThousandSep variables for this in the script.

It is possible to use the thousand separator to group digits by any number of positions, for example,
a format string of "0000-0000-0000" (thousand separator="-") could be used to display a twelve-
digit part number as "0012-4567-8912".

Examples:

Number
format

Description

# ##0 describes the number as an integer with a thousands separator. In this example " "
is used as a thousands separator.

###0 describes the number as an integer without a thousands separator.

0000 describes the number as an integer with at least four digits. For example, the
number 123 will be shown as 0123.

0.000 describes the number with three decimals. In this example "." is used as a decimal
separator.

Example of number formats

Special number formats
Qlik Sense can interpret and format numbers in any radix between 2 and 36 including binary, octal
and hexadecimal. It can also handle roman formats.

Format Description

Binary format To indicate binary format the format code should start with (bin) or (BIN).

Octal format To indicate octal format the format code should start with (oct) or (OCT).

Special number formats

Create apps and visualizations - Qlik Sense, November 2024 589



3   Visualizations

Format Description

Hexadecimal
format

To indicate hexadecimal format the format code should start with (hex) or
(HEX). If the capitalized version is used A-F will be used for formatting (for
example 14FA). The non-capitalized version will result in formatting with a-f
(for example 14fa). Interpretation will work for both variants regardless of the
capitalization of the format code.

Decimal format The use of (dec) or (DEC) to indicate decimal format is permitted but
unnecessary.

Custom radix
format

To indicate a format in any radix between 2 and 36 the format code should
start with (rxx) or (Rxx) where xx is the two-digit number denoting the radix to
be used. If the capitalized R is used letters in radices above 10 will be
capitalized when Qlik Sense is formatting (for example 14FA). The non-
capitalized r will result in formatting with non-capital letters (for example 14fa).
Interpretation will work for both variants regardless of the capitalization of the
format code. Note that (r02) is the equivalent of (bin), (R16) is the equivalent of
(HEX), and so on.

Roman format To indicate roman numbers the format code should start with (rom) or (ROM). If
the capitalized version is used capital letters will be used for formatting (for
example MMXVI). The non-capitalized version will result in formatting with
lower cap letters (mmxvi). Interpretation will work for both variants regardless
of the capitalization of the format code. Roman numbers are generalized with
minus sign for negative numbers and 0 for zero. Decimals are ignored with
roman formatting.

Examples:

Example Result

num(199, '(bin)') returns 11000111

num(199, '(oct)') returns 307

num(199, '(hex)') returns c7

num(199, '(HEX)' ) returns C7

num(199, '(r02)' ) returns 11000111

num(199, '(r16)') returns c7

num(199, '(R16)' ) returns C7

num(199, '(R36)') returns 5J

num(199, '(rom)') returns cxcix

num(199, '(ROM)' ) returns CXCIX

Examples of special number formats
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Dates
You can use the following symbols to format a date. Arbitrary separators can be used.

Symbols Description

D To describe the day, use the symbol "D" for each digit.

M To describe the month number, use the symbol "M".

Use "M" or "MM" for one or two digits.

"MMM" denotes short month name in letters as defined by the operating system or
by the override system variable MonthNames in the script.

"MMMM" denotes long month name in letters as defined by the operating system
or by the override system variable LongMonthNames in the script.

Y To describe the year, use the symbol "Y" for each digit.

W To describe the weekday, use the symbol "W".

"W" will return the number of the day (for example 0 for Monday) as a single digit.

"WW" will return the number with two digits (e.g. 02 for Wednesday).

"WWW" will show the short version of the weekday name (for example Mon) as
defined by the operating system or by the override system variable DayNames in
the script.

"WWWW" will show the long version of the weekday name (for example Monday)
as defined by the operating system or by the override system variable
LongDayNames in the script.

Symbols to format a date

Examples: (with 31st March 2013 as example date)

Example Result

YY-MM-DD describes the date as 13-03-31.

YYYY-MM-DD describes the date as 2013-03-31.

YYYY-MMM-DD describes the date as 2013-Mar-31.

DD MMMM YYYY describes the date as 31 March 2013.

M/D/YY describes the date as 3/31/13.

W YY-MM-DD describes the date as 6 13-03-31.

WWW YY-MM-DD describes the date as Sat 13-03-31.

WWWW YY-MM-DD describes the date as Saturday 13-03-31.

Examples of date formats
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Times
You can use the following symbols to format a time. Arbitrary separators can be used.

Symbols Description

h To describe the hours, use the symbol "h" for each digit.

m To describe the minutes, use the symbol "m" for each digit.

s To describe the seconds, use the symbol "s" for each digit.

f To describe the fractions of a second, use the symbol "f" for each digit.

tt To describe the time in AM/PM format, use the symbol "tt" after the time.

Symbols to format a time

Examples: (with 18.30 as example time):

Example Result

hh:mm describes the time as 18:30

hh.mm.ss.ff describes the time as 18.30.00.00

hh:mm:tt describes the time as 06:30:pm

Examples of time formats

Time stamps
The same notation as that of dates and times above is used in time stamps.

Examples: (with 31th March 2013 18.30 as example time stamp):

Example Result

YY-MM-DD hh:mm describes the time stamp as 13-03-31 18:30.

M/D/Y hh.mm.ss.ffff describes the time stamp as 3/31/13 18.30.00.0000.

Examples of time stamp formats

Using system fields in a visualization
You can use system fields in a visualization. System fields are created by Qlik Sense when the data
load script is generated, and include information about the fields and tables in the loaded data. A
system field begins with "$", and you need to reference it by typing the field name including the "$"
manually. You can use a system field to create a dimension either as a master item or from the
properties panel.

Preview of a dimension based on a system field .
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A system field added as dimension in the properties panel.

s

Using alternate states for comparative analysis
If you want to perform comparative analysis you can use alternate states in Qlik Sense.
Alternate states allow you to make different selections on the same dimension, and
compare the selections in a single visualization or in two or more visualizations side by
side.

You can use alternate states in visualizations in two different ways:
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l Applying a state to the visualization. This connects the selection of the visualization to the
selection of the state.

l Using states in the set expression of a measure. This is useful to compare measure values of
different states.

Creating alternate states
You can create a new alternate state under Alternate states in Master items:

1. Select Create new.
2. Provide a name for the new state. There are some naming limitations:

l Do not use $, 0, or 1 as a state name.
l Do not use a state name starting with $ or $_ followed by a number, for example, $3.
l Do not use a state name already used as a bookmark name.

You have now created a new alternate state that you can use to perform comparative analysis.
Typically you would want to create another new state to compare the two states.

Applying alternate states to sheets and visualizations
You can apply a state to a visualization or a sheet. If you apply a state to a sheet, all visualizations
on the sheet inherit the state unless you apply another state to a specific visualization. When you
apply a state to a visualization, it reflects the selections made in the state. Any selections you make
will be applied to the state and be reflected in other visualizations that have the same state applied.

The easiest way to apply an alternate state is dropping it on a sheet or a visualization, and then
selecting Apply state.

You can also apply an alternate state with the State setting in the property panel:
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l For a sheet, you find the setting under Alternate states.
l For a visualization, you find the setting under Appearance > Alternate states.

You can select:

l Any alternate state defined in Master items.
l <inherited>, in which case the state defined for the sheet is used.
l <default state>, which represents the state where no alternate state is applied.

Using alternate states in visualizations
Besides applying a state to a visualization you can also use alternate states in the set expression of
a measure. This is useful when you want to compare measure values for different dimension
selections side by side.

You can set the alternate state as an identifier in the set expression. If you want to use the measure
Sum(Sales) in your visualization, for example a bar chart, with a state called Group1 you use the
following expression as measure:

Sum({Group1}Sales)

To compare with a different state called Group2, you can create another measure with the
expression Sum({Group2}Sales).

The bar chart will now show sales for the selection in Group1 side by side with sales for Group2.

Getting information about the selection of an alternate state
You can see the selections of different states in the selections bar.

You may also want to be able to use information about which, and how many selections are made in
a alternate state in labels or titles of visualizations. You can use the following chart functions with
the state_name parameter to return selections associated with the specified state name:

l GetCurrentSelections() to return all current selections.
l GetFieldSelections() to return current selections of a field.
l GetSelectedCount() to return the number of selected values in a field.

Expanding variables in alternate states
You can specify which state to use when expanding a variable. Changes in a specific state do not
affect variable values that are expanded in another state. If you do not specify a state, the variable
is expanded in the default state.

Example:

If you have a state named MyState, and a variable named vMyVar:

l $(vMyVar) expands the variable in the default state.
l $({MyState} vMyVar) expands the variable in the MyState state.
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Limitations
It is not possible to add visualizations to master items if you have set the state of the visualization to
any other value than <inherited>.

Comparative analysis example
In this example we want to be able to compare the sales numbers of product lines for different
selections of sales regions. We want to select the regions we compare dynamically, either as single
regions or a combination of regions.

Dataset and app
If you want to follow this example, you need to download the Qlik Sense Tutorial - Building an App
to get the dataset. If you have completed the tutorial you can use the app you created. Otherwise
you need to create an app, add all six data files in the Tutorials source folder, and associate them
using automatic recommendations in the data manager.

Create alternate states
For this example we need two alternate states. In Master items > Alternate states:

1. Create a new state called Group 1.
2. Create a new state called Group 2.

You have now created the two alternate states we need in this example.

Create filter panes for selection

Do the following:

1. Add a filter pane with the field Region.
2. Edit the label of the filter pane to say =StateName(). This is to make it easier to tell them

apart, as the state is not indicated in the filter pane. The StateName() function returns the
state that is applied to the function.

3. Drop the state Group 1 on the filter pane and select Apply state.
4. Add another filter pane with the field Region.
5. Edit the label of the second filter pane to say =StateName().
6. Drop the state Group 2 on the second filter pane and select Apply state.

You have now created the two filter panes that are used to control the selections of each of the two
states. When you make a selection in the Group 1 filter pane, the same selection is applied to the
state Group 1 which is reflected in all visualizations connected to that state.

Create a bar chart for analysis

Do the following:

1. Create a master item measure with name Group1Sales.
Set Expression to Sum({[Group 1]}[Sales]).
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This expression sums the sales for all selections in the Group 1 state.
Set Label expression to 'Sales '&GetCurrentSelections(chr(13)&chr(10), '=', ','

,9,'Group 1').
We use a label expression to be able to show the current selection of the state as a label in
the chart, instead of the default label.

2. Create another master item measure with name Group2Sales.
Set Expression to Sum({[Group 2]}[Sales]).
Set Label expression to 'Sales '&GetCurrentSelections(chr(13)&chr(10), '=', ','

,9,'Group 2').
3. Add a bar chart to the sheet.
4. Set the Product Line field as dimension.
5. Add the measures Group1Sales and Group2Sales.

You have now created a bar chart that shows the sales by product line for the two groups of
regions selected in the filter panes. When you make a new selection in one of the filter panes, the
corresponding measure value changes according to the new selection.

Discovery
You can now make selections in Group 1 and Group 2, and see the results of the selected
combinations of regions in the bar chart.

Creating a visualization using a custom object
You can enhance your apps with custom-objects.

Custom objects that are available are:

l visualization extensions
l object bundles supplied by Qlik:

o Dashboard bundle (page 411)
o Visualization bundle (page 447)

You can find custom objects in the assets panel under Custom objects when you are editing a
sheet.

You can build your own visualization extensions in the Dev Hub.
≤ For the Dev Hub, see Dev Hub .

Adding a custom object to the sheet
You start creating a visualization by dragging a visualization extension onto a sheet.

Do the following:

1. Click Edit sheet in the toolbar.

2. Click in the panel on the left-hand side to expand custom objects.

3. Drag a visualization extension onto the sheet.
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You can drop it in an empty location on the sheet, split the area of an existing visualization
into two, or replace an existing visualization.

If you double-click a custom object, it is added to the sheet immediately.

4. Change the required settings for the custom object in the properties panel. The required
settings are defined by the extension developer, this can be dimensions, measures, or other
settings.

You now have a complete visualization that you can start using while exploring the data in the app.

Copying a visualization from an existing visualization
You can copy a visualization:

l Within the same sheet.
l Between sheets in the same app.
l Between sheets belonging to different apps (see Considerations (page 598) for more

information).

Do the following:

1. While editing a sheet, click on the item you want to copy.
The item is highlighted.

2. On the edit bar, click .

3. To insert the item on another sheet, navigate to the sheet in the assets panel.

4. Click to paste the item.

The copied item is added to the sheet.

Depending on what situation you are in, different things will happen when you paste the
copied visualization on a sheet:

l If a visualization is selected, then the selected visualization will be replaced.
l If no visualization is selected, then the pasted visualization will be placed in the

largest empty space.
l If there is no empty space, then the largest visualization on the sheet will be split

in half to make space for the pasted visualization.

Considerations
l For a copied visualization to work in a different app, the same dimensions and measures

have to be a part of the target app as well.
l When copying visualizations between two apps, the apps must exist in the same deployment

of Qlik Sense Enterprise on Windows.
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l You cannot copy and paste visualizations between different environment types (for example,
between an app in Qlik Cloud Analytics and an app in Qlik Sense Desktop).

Adding trend and reference lines to visualizations
Use trend lines to visualize changes in measure values over time. Use reference lines
to mark specific measure and dimension values on a chart.

Adding trend lines to visualizations
Trend lines are available for bar charts and line charts. Trend lines are added when you configure a
measure in the chart.

For more information about trend lines, see Trend lines (page 110).

Do the following:

1. Click on an existing bar or line chart.
2. In the properties panel, expand the Data section.
3. Under Measures, expand the measure for which you are adding trend lines.
4. Under Trend lines, click Add trend line.
5. Define the Label and Type for the trend line.
6. Use the Colors slider to define Custom or Auto coloring.
7. Use the Dashed checkbox to give the line a dashed or solid appearance.

Adding reference lines to visualizations
Reference lines can help users interpret a visualization, providing guidance on what to look for
during analysis. Reference lines are separately defined for measures and dimensions.

For more information about reference lines, see Reference lines (page 404).

Adding reference lines for chart measures

Do the following:

1. Click on an existing chart that supports reference lines.
2. In the properties panel, expand the Add-ons section.
3. Expand Reference lines.
4. Click Add reference line.
5. Optionally, define a Show condition and Label.
6. Under Reference line expression ,enter the expression to define the measure value for

which the reference line is shown.
7. Style the reference line with the Color, Line type, and Colored background settings.

To remove an existing reference line, expand the reference line and click Delete.
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Adding dimensional reference lines

Do the following:

1. Click on an existing chart that supports dimensional reference lines.
2. In the properties panel, expand the Add-ons section.
3. Expand Dimension reference lines.
4. Click Add reference line.
5. Optionally, define a Show condition and Label.
6. Under Dimension value, enter the expression to define the dimension value for which the

reference line is shown.
7. Style the reference line with the Alignment, Color, Line type, and Colored background

settings.

To remove an existing dimensional reference line, expand the reference line and click Delete.

Creating time-aware charts
Time-aware charts are visualizations that use a continuous scale to provide a complete
and accurate view of time-based data. That is, when you enable continuous scaling on
the x-axis in a chart with date fields, data points are separated from each other by a
distance relative to their associated time. As well, the axis labels are evenly separated
whether or not there is data for that point and the chart view is compressed to avoid
scrolling.
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Continuous scale is supported for line charts, bar charts, and combo charts.

A continuous scale is most commonly used with date fields such as:

l Second
l Minute
l Hour
l Week
l Month
l YearMonth
l Quarter
l YearQuarter
l Year
l Date
l Timestamp

Adding a continuous scale

Do the following:

1. In sheet view, click Edit sheet in the toolbar.

2. Click the line chart that you want to edit.
3. In the properties panel, click the Appearance tab.
4. In the X-axis section, check Use continuous scale.

The chart is compressed and the data points and labels are readjusted.

Making selections in a time-aware chart
When navigating a time-aware chart, you can zoom into a smaller time span to take snapshots of
the data displayed and select data values. selections made on a time axis using range selection
select all data values (even those that are not visible). Selections made on the measure axis or
using lasso selections only select visible values.

Changing the data of a visualization
The data displayed within a visualization can be changed after the visualization is
created.

For example, you may want to add additional dimensions or measures to a chart to add depth to the
existing data. Alternatively, you may need to correct an invalid dimension or measure.
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Adding dimensions and measures to a visualization
You can add multiple dimensions and measures to a visualization to add depth to the data
displayed. Addition dimensions and measures enabled you to view more information in a single
visualization. For example, the image below contains a visualization with the measure Sales and a
dimension Month.

Line chart with the measure Sales.

You can add a second measure, Gross Sales. The example line chart now gives use more context by
enabling a comparison of Gross Sales to Sales.
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Line chart with the measures Sales and Gross Sales.

Do the following:

1. In the properties panel, click the Data tab.
The Data tab is expanded.

2. In the Dimensions or Measures section, click Add to add a dimension or measure.
A dialog with a text box opens. Below the text box all available dimensions or measures are
listed, grouped into Dimensions or Measures (that is master items) and Fields.

3. Start typing in the text box.
A list of matching fields and dimensions or measures is displayed.

You can also create a dimension by entering an expression directly in the text box,
or by clicking to create a dimension in the expression editor.

If no measure is displayed, you need to create one. You can enter an expression
directly in the text box, or you can click to create a measure in the expression
editor.

4. Select the dimension or measure that you want to use.

The dimension or measure is added to the visualization. The new dimension or measure settings are
shown in the properties panel.
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Adding alternative dimensions and measures to a visualization
Alternative dimensions and measures are dimensions and measures that are added to a
visualization, but are not displayed until a user chooses to switch which dimensions and measures
are being displayed during visual exploration. You can toggle which of your dimensions and
measures are displayed using the exploration menu of a visualization.

Adding alternative dimensions and measures to a visualization

You can add alternative dimensions and measures to all chart types but changing
alternative dimension and measures in the visualization can only be done in bar, line, and
combo charts. Only alternative dimensions can be changed in the pie charts visualization
and only alternative measures in scatter plots.

Alternative dimensions and measures enable you conserve space on your sheets. Rather than make
multiple similar visualizations of the same type, you can use alternative dimensions and measure
with a single visualization. You can then switch between the displayed dimensions and measures.
For example, if you wanted to see total sales by product category and total sales by product
subcategory, you could add product category as a dimension and product subcategory as an
alternate dimension in the same visualization.

Alternative dimensions and measures enable you to have more dimensions and measures
associated to a visualization that the display limit. Many visualizations have limitations on how many
dimensions and measures that can be displayed at the same time. A line chart with two or more
measures can only have one dimension, and a line chart with two dimensions can only have one
measure. Alternative dimensions and measures enable you to exceed that limit.

Alternative dimensions and measures can be added like normal dimensions and measures in the
properties pane. You can also drag dimensions and measures in the Data section of the properties
panel into the Alternative dimensions or Alternative measures section.

Do the following:

1. In the properties panel, click the Data tab.
The Data tab is expanded.

2. In the Dimensions or Measures section, click Add alternative.
A dialog with a text box opens. Below the text box all available dimensions or measures are
listed, grouped into Dimensions or Measures (that is master items) and Fields.

3. Start typing in the text box.
A list of matching fields and dimensions or measures is displayed.

You can also create a dimension by entering an expression directly in the text box,
or by clicking to create a dimension in the expression editor.
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If no measure is displayed, you need to create one. You can enter an expression
directly in the text box, or you can click to create a measure in the expression
editor.

4. Select the dimension or measure that you want to use.

The alternate dimension or measure is added to the visualization.

Editing data in a visualization
You can edit and adjust the data in a visualization. You may need to edit an existing dimension or
measure to adjust it to create a stronger visualization or correct an invalid dimension or measure.
You may also want to edit a master item in a visualization to change the master item across all
visualizations.

Invalid dimensions and measures
Dimensions and measures are invalid when the associated expression cannot be interpreted by Qlik
Sense.

If you create an invalid dimension or edit an existing one so that it becomes invalid, the dimension is
presented in the properties panel as dimmed with a red hue and the text Invalid dimension to
indicate that the dimension is invalid. If you use an invalid dimension in a visualization, the
visualization cannot be displayed.

If you create an invalid measure or edit an existing one so that it becomes invalid, the Expression
text box under Measures in the properties panel is presented with a red border to indicate that the
measure is invalid.

Editing a dimension
You can edit dimensions, including master dimensions. In the properties panel, under Data, select
the dimension that you want to edit.

Dimensions have the following properties:

l Field: Start typing the field name to display a list of matching fields to choose from. You can
also click to open the expression editor, where you can create a calculated dimension.

l Label: Enter a name for the dimension.
l Include null values: When this is checked, the visualization will include the null values of the

dimension, presented as a gap or a dash, depending on the type of visualization. For
example, if you have sales figures but do not have any information about what company the
figures belong to, the figures will be added to the measure value for the null value dimension.

l Limitation: You can limit the number of dimension values that are displayed.
l Show others: When you have set a limitation for the number of dimension values displayed,

you have an option to summarize the measure values for the remaining dimensions by
selecting Show others.
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l Master item: Edit a master dimension to update all instances where the dimension is used, or
create a new master dimension by adding a dimension to the master items.

Editing a measure
You can edit measures, including master measures. In the properties panel, under Data, select the
measure that you want to edit.

Measures have the following properties:

l Expression: Enter the expression. You can also click to open and use the expression
editor. You can also apply a Modifier to automatically adjust the original expression. See
Applying a measure modifier (page 606).

l Label: Enter a name for the measure. The label is not automatically updated when you make
changes in Expression.

l Number formatting: Set the number formatting for the measure values. The options Number
and Date offer custom formatting options for defining your own format pattern.

l Master item: Edit a master measure to update all instances where the measure is used, or
create a new master measure by adding a measure to the master items.

Applying a measure modifier
Using a modifier, a measure expression can be automatically customized for a specific analytical
purpose. For example, you might want an expression in which data is presented as an accumulation
rather than standalone values.

Do the following:

1. In the properties panel, expand the Data section.
2. Under Measures, expand the measure to which you are applying a modifier.
3. Underneath the Expression, click Modifier.
4. Use the drop down menu to select a modifier.
5. Fill in the parameters specific to the modifier you are using.

When you are finished, click Output expression to view how the original expression was modified.

For more information about measure modifiers, see Modifiers (page 106).

Editing master items
Dimensions and measures that are linked to a master item are displayed with a in the properties
panel. You can edit the master item to update all instances that use the dimension or measure, or
you can unlink the item from its master to edit only the current instance of the dimension or
measure.

A visualization that is linked to a master item is indicated by Linked visualization on the sheet.
You can edit a master visualization to update all instances that use the visualization, or you can
unlink a visualization from its master to edit only the current instance of the visualization. Unlinking
a visualization does not unlink any master dimensions or master measures used in the visualization.
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Deleting dimensions and measures
In the properties panel, you can delete a dimension or measure. Long-touch or right-click the
dimension or measure and select Delete in the dialog. Alternatively, click the dimension or measure
and click Delete . If you delete an instance of a master item, the master item is still available in the
assets panel.

You can undo a deletion by clicking . Changing which sheet you are viewing will
prevent you from undoing your deletion.

Changing the appearance of a visualization
The Appearance section in the properties panel offers several options to set and
modify the appearance of a visualization.

Many of the settings have Auto options that support an optimal presentation of the visualization,
taking into account the number of dimensions and measures and the type of data used. Normally,
you do not need to change these settings, unless you have a special reason for doing so, for
example, when space is very limited.

Appearance can be affected by the sorting of the dimensions and measures.

General
Show titles: On by default in all visualizations except filter panes and text & image visualizations.
Filter panes have the name of each dimension and in most cases do not need any additional title.
The text & image visualization includes an editing toolbar with many options to format the text, and
therefore the title field can be used for other purposes.

Title, Subtitle, and Footnote: Apart from the obvious use of title, subtitle, and footnote as text
fields, you can use these fields to also display an expression, which provides additional information
that complements the measure in the visualization. You could, for example, show the totals in the
title field, so that the totals of the selected values are always available.

Example:

In the following image, the total sales are calculated and used in the title. When a selection is made,
the total sales are updated accordingly.
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The following string was used to add the Total Sales expression to the field Title:

='Total Sales: $'& Round(Sum(Sales)/1000000, 0.1) & 'M'.

Because the title field is primarily a text field, it is necessary to start the string with an equals sign
(=), to signify that the strings contains an expression.

Because 'Total Sales: $' is a text string when it is used in an expression, the string must be
surrounded by single quotation marks.

& is used to concatenate the string and the expression.

Round(Sum(Sales)/1000000, 0.1) is the expression. The aggregation Sum(Sales) is divided by
1000000 and the function Round (x,0.1) reduces the number of decimals to one.

& 'M', finally, concatenates the expression with the unit M for million.

For the title there are three options for adding an expression:

l Directly in the title field of a visualization. Start the string with an equals sign (=).
l Directly in the box Title under Appearance in the properties panel. Start the string with an

equals sign (=).
l Through the expression editor in the box Title. Click to open the expression editor. No

equals sign is needed.

For the subtitle and footnote only the last two options are available.

Show details: Hide by default. When set to Show, users can click when analyzing to view details
such as descriptions measures and dimensions.

Presentation and styling
Many of the presentation settings only apply to a certain visualization.
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Visualization Description

Bar chart Set the bars to be displayed grouped or stacked, vertically or horizontally.

Box plot Select to show whisker ticks and grid lines. You can show the visualization
vertically or horizontally.

Combo chart Select whether to show labels for measures added as markers. You can select
to show grid lines based on primary or secondary axis, and adjust spacing
between them.

Distribution plot Select to show point, background or both. You can show the visualization
vertically or horizontally.

Gauge Set the gauge to be displayed as a radial or a bar. You can set range limits and
use segments with limits.

Histogram Select to show grid lines.

Line chart Set the line chart to be displayed as a line or an area.

Pie chart Set the pie chart to be displayed as a pie or a donut.

Scatter plot Turn on/off navigation. Set the size of the bubbles in a scatter plot. Set the
compression resolution for large data sets in scatter plot.

Table Set the totals to be displayed at the top, bottom, or not at all.

Treemap Set the headers, labels, overlay labels, and leaf values. Select to show the data
values.

Presentation settings in visualizations

Example:

A bar chart with two dimensions is by default presented with the bars grouped.
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Let us assume that you want to compare the total monthly quantity for these years. Then it would
be a good idea to switch to a stacked bar chart.

In the properties panel, under Appearance > Presentation there is an option Stacked.

With stacked bars it is easier to compare the quantity between different months.

Now it is quite easy to compare the quantities per month. There is a legend to display the years.

Under Colors and legend, Show legend is set to Auto, which means that the legend is displayed
when there is enough space. In the properties panel, you can also set where to display the legend
and whether to display the legend title.

There is only data for the first half of 2013 (red bars).
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Styling
Apply additional customization to the visualization by using the styling panel. The styling panel is
available in the properties panel. Under Appearance > Presentation, click Styling.

For more information, see Applying custom styling to a visualization (page 638).

Colors and legend
The Colors and legend section of the properties panel sets your color and legend options. Qlik
Sense automatically colors visualizations as they are added to your sheets. As a best practice, it is
recommended to add or change colors only when it serves as purpose in the visualization. Too
many colors or indistinct color choices can make visualizations less clear.

You can manually set the colors and legends by deselecting the Auto option and selecting your
color preferences. Qlik Sense enables you to color your visualizations by:

l Single color
l Multiple colors
l Dimension
l Measure
l Master items
l Expression

For more information on different visualization coloring options, see Coloring a visualization (page
616). For examples of each of these methods of coloring visualizations and the settings used can be
found, see Example 1: Coloring by a dimension in the visualization (page 634).

X-axis and Y-axis
For both the y-axis and the y-axis, you have options for deciding what combination of labels and
title to display, as well as their orientation and position. Sometimes it may feel unnecessary to have
labels and/or a title, because the visualization is self-explanatory and then it would be good to be
able to hide them. Furthermore, when you create a visualization that is very small, for example,
three by three squares, the labels are automatically hidden.

Range: The measure axis (usually the y-axis) has an option to set the range of the axis. By default,
the range is adjusted according to the highest positive or the lowest negative measure value, but if,
for example, a single measure value is much larger than all the other values, you may want to set a
range that is suitable for the lower values. In the properties panel, under Appearance > Y-axis
<measure name>, there is a button for Range, which is set to Auto. Click the button to switch to
Custom. Now you can set the range for Max, Min, or both. In a bar chart, the bars that are out of the
range are cut diagonally to indicate that they are out range. In a line chart, only the parts that are
within the range are visible.

Label orientation: You can change the orientation of data labels on the dimensions axis (usually the
x-axis). In the properties panel, under Appearance > X-axis <dimension name>, there is a drop-
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down menu for label orientation. By default, this is set to Auto. If there is not enough room for a
label to fully appear on the chart, it will be truncated with an ellipsis. The following options are
available:

l Auto: Automatically selects one of the other options depending on the space available on the
chart.

l Horizontal: Labels are arranged in a single horizontal line.
l Tilted: Labels are stacked horizontally at an angle.
l Layered: Labels are staggered across two horizontal lines.

Examples of layered and tilted labels

Change the sorting of a visualization
You can change the sorting order of dimensions and measures so that your data is
presented in the way you intend.

Most visualizations have a Sorting section in the properties panel where you can put the cursor on
the drag bars and drag the dimension or measure to rearrange the sorting order. In visualizations
without a sorting section, you can still adjust the sorting to some extent.
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In the following screenshot, the primary sorting is on the measure Gross Sales.

A bar chart with that sorting order will look as follows.

Since there are two measures, Gross Sales and Sales, the bars are by default grouped. Gross Sales
is presented first, because it has sorting priority 1. If you were to drag Sales to the top of Sorting,
the first bar would be Sales and the second bar Gross Sales.

To sort by Year, instead, you need to drag Year to the top in Sorting. The bar chart is then updated
and sorted by Year.
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In bar charts with multiple dimensions, sorting is locked to the first dimension. This
dimension is what groups and stacks are based on, and sorting on a different dimension
or a measure would break up these groups in an undesirable way. If you still want to sort
by the measure value, try using the option Sort by expression on the first dimension
under Sorting.

Sorting in the dimensions and measures sections
Although it is primarily under Sorting that you set the sorting order, you can also adjust the order in
the properties panel section Data under Dimensions and Measures. In Dimensions you can
change the priority order between the different dimensions by dragging them, and, likewise, in
Measures, you can drag the measures to change the sorting order. Put the cursor on the drag
bars and drag the dimension or measure to rearrange the order. Changes are reflected in the
visualization.

Internal sorting
Apart from setting the sorting order between dimensions and measures, you can also set the
internal sorting order, under Sorting.

Click the dimension or measure name to open the settings and click the sorting button to switch to
Custom sorting. The following table shows the internal sorting priority order and sorting options.
The sorting is either Ascending or Descending.

Sorting options:

l Sort by expression (Enter an expression to sort by. Only available for dimensions.)
l Sort numerically
l Sort alphabetically

Additionally, you can sort by load order by switching to Custom and leaving all sorting options
unselected.

If you have set a custom order for a field that custom order will override any selected internal sort
order in Sorting.

Default sorting
By default, the dimensions and measures are sorted in the order they were added, with the most
recently added item last. Each dimension is sorted internally in the most common way for that type
of data. Numbers are sorted numerically, ascending. Text is sorted alphabetically, ascending.
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Visualization Description

Bar chart By default, a bar chart with one measure and one dimension is presented with
vertical bars sorted descending on the measure.

When a dimension has less than 10 values, the sorting is by dimension,
alphabetically.

Box plot By default, a box plot is sorted by the center line. You can also sort by first
whisker, box start, box end or last whisker.

Combo chart Sorted by the first item added, either the dimension or the measure.

Distribution plot By default, a distribution plot is sorted by the outer dimension.

Filter pane By default, data in filter panes is presented ascending.

Gauge A gauge only uses a single measure value, the first one under Measures.

Histogram The histogram does not have any sorting section.

KPI By default, the first added measure becomes the main value.

Line chart By default, a line chart is sorted by the dimension.

Map A map layer can only have one dimension. Sorting is used to determine the
order points or areas are added to the map.

Pie chart A pie chart uses one measure and one dimension. By default, a pie chart is
sorted by the measure in descending order.

Scatter plot The scatter plot does not have any sorting section, but the order of the
measures decides where they are used. The first measure is used on the x-
axis, the second measure is used on the y-axis, and the third (optional)
measure is used for the bubble size (it is used to set the color on large data
sets) in the scatter plot. You can only have one dimension in a scatter plot.

Table By default, the column presents the dimensions and measures in the order
they were added.

Sorting order of rows: By default, the table is sorted in ascending order by the
first dimension or measure under Sorting. You can temporarily change the
sorting by clicking the header of the row you want to sort on. One click -
ascending order, two clicks - descending order.

Text & image The text & image visualization does not have any sorting section, but you can
drag the measure tokens in the visualization to change the order.

Treemap The treemap does not have any sorting section. The sorting is automatically
by measure size.

Default sorting in visualizations
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Coloring a visualization
Qlik Sense automatically colors visualizations as they are added to your sheets. You
can manually set the colors in your visualizations to meet your requirements or
preferences.

Color options for most visualizations are set in the properties panel, in Appearance > Colors and
legend. By selecting Custom, you can manually apply colors to your visualizations using the
following methods:

l Color by single color
l Color by multiple colors
l Color by dimension

Dimension fields can also be dragged and dropped from the assets panel onto a visualization
to color the visualization by dimension (if supported by the visualization type).

l Color by measure
Measure fields can also be dragged and dropped from the assets panel onto a visualization
to color the visualization by measure (if supported by the visualization type).

l Color by expression

Tables and pivot tables can only be colored by expression. Options for coloring tables and pivot
tables are found in the properties panel in Data.

If you want to keep colors consistent for dimensions or measures between different visualizations,
you can assign specific colors to master items in your library. Most visualizations will use any colors
assigned to master items automatically. In cases where a visualization uses both a master
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dimension and a master measure with assigned colors, the color assigned to the master dimension
is used by default. You can select which master item color to use or disable master item colors
entirely.

For more information, see Assigning colors to master items (page 142).

You can also assign colors to individual master dimension values to ensure the colors of different
values are consistent across visualizations.

For more information, see Assigning colors to master dimension values (page 145).

To keep visualizations clear when you manually set colors, you should select colors for accessibility
and only use different colors when they serve a purpose.

Color by single color
When you color by single color, one color is used for all objects in the chart. Coloring by a single
color is best used for visualizations, such as bar or line charts, with a single dimension and measure.

If you have a master dimension or master measure that has a color assigned to it, you can color the
visualization by that single color. In cases where a visualization uses both a master dimension and a
master measure with assigned colors, the color assigned to the master dimension is used by
default. You can select which master item color to use or disable master item colors entirely.

The following options are available when Single color is selected from Colors in Appearance
> Colors and legend:

Option Description

Use
library
colors

Select to use master item colors. In cases where a visualization has both a master
dimension and a master measure that have colors assigned to them, you can select
which to use in the visualization.

This option is available when a master dimension or master measure used in the
visualization has a color assigned to it.

Color Select a color using the color picker. You can select a color from the default palette,
enter a hex value for a color, or select a color from a color wheel.

Options for color by single color (Advanced)

Color by multiple colors
When you have multiple measures in a visualization, you can select Multicolor to color each
measure with a different color. Qlik Sense offers a 12 color and a 100 color palette to apply to the
visualization. By default, 12 colors is selected as the color scheme dimensions.

If you are using master measures in your visualization, you can also choose to use them in your
visualization. When a visualization is colored by master measures, master measures will use their
assigned colors and any other measures are assigned colors from the 12 colors scheme.

The following options are available when Multicolored is selected from Color:
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Option Description

Use
library
colors

Select to use master item colors. In cases where a visualization has both a master
dimension and a master measure that have colors assigned to them, you can select
which to use in the visualization.

This option is available when a master dimension or master measure used in the
visualization has a color assigned to it.

Options for color by multiple colors

The following options are available when Multicolor is selected from Colors in Appearance
> Colors and legend:

Option Description

Use
library
colors

Select to use master item colors. In cases where a visualization has both a master
dimension and a master measure that have colors assigned to them, you can select
which to use in the visualization.

This option is available when a master dimension or master measure used in the
visualization has a color assigned to it.

Color
scheme

Select the color scheme used in the visualization. The following schemes are
available:

12 colors: The colors are reused when there are more than 12 values. The 12 colors
in this color scheme can all be distinguished by people with a color vision
deficiency.

100 colors: The colors are reused when there are more than 100 values. Not all of
the 100 colors can be distinguished by people with a color vision deficiency.

Options for color by multiple colors (Advanced)

The following options are available when Multicolor is selected from Colors in Appearance
> Colors and legend:

UI item Description

Use
library
colors

Select to use master item colors. In cases where a visualization has both a master
dimension and a master measure that have colors assigned to them, you can select
which to use in the visualization.

This option is available when a master dimension or master measure used in the
visualization has a color assigned to it.

Options for color by multiple colors
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UI item Description

Color
scheme

Select the color scheme used in the visualization. The following schemes are
available:

12 colors: The colors are reused when there are more than 12 values. The 12 colors
in this color scheme can all be distinguished by people with a color vision
deficiency.

100 colors: The colors are reused when there are more than 100 values. Not all of
the 100 colors can be distinguished by people with a color vision deficiency.

Color by dimension
When you color a visualization by a dimension, all values in the visualization are colored by the
corresponding values in the dimension field selected. By default, the visualization is colored by the
primary dimension of the visualization, but you can select other dimensions. Qlik Sense offers a 12
color and a 100 color palette. By default, 12 colors is set as the palette for color by dimensions.

If you are using a master dimension, you can color the visualization using the colors assigned to the
distinct values of that dimension.

Coloring by dimension is useful when you want to keep track of related information in your
visualizations, such as coloring multiple charts by the dimension of Region to clearly see the values
related to each region in each chart.

The following options are available when By dimension is selected from Colors in Appearance
> Colors and legend:

UI item Description

Select
Dimension

Select the dimension used to color this visualization with this field. By default, if
you have already selected a dimension for the visualization, it is set with that
dimension. Click to select a different dimension. You can enter an expression

by clicking to open the expression editor

Persistent
colors

When selected, colors persist between selection states. If cleared, colors will be
changed and reassigned for different dimension values as selections are made in
the visualization.

Color
scheme

Select the color scheme used in the visualization. The following schemes are
available:

12 colors: The colors are reused when there are more than 12 values. The 12
colors in this color scheme can all be distinguished by people with color vision
deficiency.

100 colors: The colors are reused when there are more than 100 values. Not all
of the 100 colors can be distinguished by people with color vision deficiency.

Options for color by dimension
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UI item Description

Library
colors

Select to use master dimension color values.

This option is available when a master dimension is used in the visualization.

Color by measure
When you color a visualization by a measure, all values in the visualization are colored by a gradient
or class based on the values in the selected measure. By default, the visualization is colored by the
primary measure of the visualization, but you can select another measure. There are four available
color schemes.

Coloring by measure is useful when you want to clearly see objects colored by their corresponding
measure value.

The following options are available when By measure is selected from Colors in Appearance
> Colors and legend:

UI item Description

Select
Measure

Select the measure used to color this visualization. By default, if a measure has
been added to the visualization, that measure is selected. Click to select a

measure. You can enter an expression by clicking to open the expression editor

Color
scheme

Select the color scheme used in the visualization. The following schemes are
available:

Sequential gradient: The transition between the different color groups is made
using different shades of colors. High measure values have darker hues.

Sequential classes: The transition between the different color groups is made
using distinctly different colors.

Diverging gradient: Used when working with data that is ordered from low to high,
for instance, to show the relationship between different areas on a map. Low and
high values have dark colors, mid-range colors are light.

Diverging classes: Can be seen as two sequential classes combined, with the mid-
range shared. The two extremes, high and low, are emphasized with dark colors
with contrasting hues, and the mid-range critical values are emphasized with light
colors.

Reverse
colors

Select this option to switch which colors are used for low values and which colors
are used for high values in the selected color scheme.

Options for color by measure
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UI item Description

Range Set the measure value ranges used to color the visualization. When set to Auto,
Qlik Sense creates ranges based on the detected minimum and maximum values.

When set to Custom, Qlik Sense automatically creates ranges based on user-
defined minimum and maximum values. You must enter values or expressions that
calculate those values in the fields Min and Max. You can enter an expression by
clicking to open the expression editor

Color by expression
Coloring by expression applies colors to a visualization based on a user-defined expression. This
enables you to use expressions to define both the colors used and the values upon which the colors
are applied in a visualization. You could, for example, use an expression to set conditional colors in
a chart.

The following options are available when By expression is selected from Colors in Appearance
> Colors and legend:

UI item Description

Expression Enter an expression by clicking to open the expression editor.

For more information, see Examples (page 624).

The
expression is
a color code

Selected by default. In most cases, it is best to keep this setting. When the
selection is cleared, the expression evaluates to a number, which in turn is
plotted against one of the chart gradients.

Label Enter the label to appear for the legend.

This expression is a color code must be cleared.

Options for color by expression
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UI item Description

Color
scheme

Color scheme sets the colors used in the visualization. The following color
schemes are available:

Sequential gradient: The transition between the different color groups is made
using different shades of colors. High measure values have darker hues.

Sequential classes: The transition between the different color groups is made
using distinctly different colors.

Diverging gradient: Used when working with data that is ordered from low to
high, for instance, to show the relationship between different areas on a map.
Low and high values have dark colors, mid-range colors are light.

Diverging classes: Can be seen as two sequential classes combined, with the
mid-range shared. The two extremes, high and low, are emphasized with dark
colors with contrasting hues, and the mid-range critical values are emphasized
with light colors.

This expression is a color code must be cleared.

Reverse
colors

When selected, the color scheme is reversed.

This expression is a color code must be cleared.

Range This setting sets the value ranges for coloring results in the visualization.

Auto: Qlik Sense creates ranges based on the detected minimum and maximum
values.

Custom: Qlik Sense automatically creates ranges based on user-defined
minimum and maximum values. You must enter values or expressions that
calculate those values in the fields Min and Max. You can enter an expression by
clicking to open the expression editor

This expression is a color code must be cleared.

Color by expression in table visualizations
Expressions can be used to color table and pivot table backgrounds and text. This enables you to
use expressions to define both the colors used and the conditional values upon which the colors are
applied in a visualization. You could, for example, use expressions to change text and background
colors depending on the values within different table cells.

The following options are available in Data for coloring table and pivot table visualizations:
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UI item Description

Background
color
expression

Enter an expression by clicking to open the expression editor. The text
color automatically changes to white when a dark background color is used.

For more information, see Examples (page 624).

Text color
expression

Enter an expression by clicking to open the expression editor. If you use the
same expression as in the background color, the text will not be visible.

For more information, see Examples (page 624).

Options for coloring table and pivot table visualizations

Color by expression
Coloring by expression sets colors using a user-defined expression. When coloring by
expression, you can define both what colors to use and which values to use them with,
enabling more control over how colors are used in the visualization.

For example, you might highlight values of particular interest, or differentiate between values within
different value ranges. Coloring by expression can also be used to color a visualization by values
not included within a visualization, such as coloring products and the sum of their monthly sales by
the country of origin for the product.

When you select to color By expression, you can choose to either use the expression as a color
code or to define how By measure color options are applied to the visualization using an
expression.

The following visualizations support color by expression:

l Bar chart
l Combo chart
l KPI chart
l Line chart
l Map
l Pie chart
l Pivot table
l Scatter plot
l Table
l Treemap

You can also use color by expression to set a background color on a sheet. For more information,
see Structuring an app using sheets (page 10).

Legend selection is not available in a visualization when coloring by expression.
Visualizations that are colored by expression with a color code do not support legends.
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Coloring by expression as a color code
By default, if you choose to color by expression, The expression is a color code is enabled. If you
have this option selected, your expression must include a color code in a supported expression
format to define the colors to use. Using this method provides you with manual control over
visualization colors as well as the conditions for the colors being used in a visualization. With tables
and pivot tables, you can use expressions to define the background color and the text color of
columns.

When coloring by expression, objects in visualizations are colored gray if the expression
contains errors or if objects in the visualization have multiple colors they could be
assigned in the expression.

Examples
Here are a few examples to show what you can do with expressions by color.

Example: Coloring by random color range

argb(255,rand()*255,rand()*255,rand()*255)

This example uses ARGB color. It starts with alpha value that sets full opacity, and then uses the
rand() function to generate random values for the red, green, and blue colors, creating a random
color.

Example: Coloring by single measure value

if(sum([Budget Amount]) > 1000000, 'cornflowerblue', magenta())

In this example, there is a condition. If sum([Budget Amount]) is greater than 1 million, the
corresponding measure values will be colored 'cornflowerblue', otherwise they will be colored
magenta.

'cornflowerblue' is the color keyword for the color rgb(100, 149, 227).

magenta() is the Qlik Sense color function that generates a magenta color.

Example: Coloring by single measure value using an aggregated expression

if(avg(Value) > avg(Total aggr(avg(Value), Name)), Blue(), Brown())

In this example, there is a condition. If the avg(Value) value is greater than the aggregated avg
(Value) value of the entire table, then the corresponding measure value is colored blue. If the avg
(Value) value is less than the aggregated avg(Value) value of the entire table, then the
corresponding measure value is colored brown.
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Example: Coloring by multiple measure values

if(Sum(Sales) > 3000000, 'green', if(Sum(Sales) > 2000000, 'yellow', if(Sum(Sales) > 1000000,
'orange', red())))

In this example, there are multiple conditions. If Sum(Sales) is greater than 3,000,000, then
corresponding measure values will be colored green. If Sum(Sales) is between 2,000,000 and
3,000,000, then the corresponding measure values will be colored yellow. If Sum(Sales) is between
1,000,000 and 2,000,000, the corresponding measure values will be colored orange. All other
measure values will be colored red.

Example: Coloring by multiple dimensions

if([CompanyName]= 'A Corp', rgb(100, 149, 227), if([CompanyName]= 'B Corp', rgb(100, 149, 200),
if([CompanyName]= 'C Corp', rgb(100, 149, 175), if([CompanyName]= 'D Corp', rgb(100, 149, 150),
'grey'))))

In this example, the expression is used to define a RGB color for each specific dimension value in
the field CompanyName.

Example: Coloring table object font and background by measure value.

if(Sum([Sales]) < 10000, 'red', green())

if(Sum([Sales]) > 200000, 'gold', )

In this example, two expressions are used to color the background and text of the Sales column.
Measure values in Sales that are lower than $10000 have a red background color, all other values
have a green background. In addition, the values that are higher than $200000 have the text color
'gold'.
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Coloring by expression without a color code
You can color by expression without a color by disabling The expression is a color code when you
enable coloring by expression. In this method of coloring, the expression is used to evaluate to a
numeric value that is plotted against a By measure chart gradient, treating the expression like a
measure when coloring by measure.

When coloring by expression, objects in visualizations are colored gray if the expression
contains errors or if objects in the visualization have multiple colors they could be
assigned in the expression.

Example:

100*Sum([Sales Margin Amount])/Sum([Sales Amount])

In this example, charts would have By measure color gradients applied to them based on the profit
margin percentile calculated in the expression.

Supported expression formats
The following formats are supported when you create your expressions.
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RGB
With RGB colors you enter an integer value between 0 and 255 (or an expression that evaluates to
such a value) for each of the colors red, green, and blue. The resulting color is produced by adding
the three colors together.

Example:

rgb(0,0,255)

This example generates the color blue. Many of the RGB colors have a corresponding keyword in
plain text that can be used instead of the RGB code. If you use 'blue' as expression, you would get
exactly the same color. Hexadecimal numbers are also supported, and the color blue has the string
'#0000ff'.

ARGB
The ARGB color model has the same support as the RGB color model, but extends it with an
additional alpha value to set the opacity of a color.

Example:

argb(125,0,0,255)

The first value (125), sets the alpha value. The value 0 generates full transparency and the value
255 full opacity.

HSL
In HSL, the color is defined by a hue value, a saturation value, and a luminosity value. You use
values between 0 and 1. Hue is represented as an angle of the color circle (that is, the rainbow
represented in a circle). Saturation is full with the value 1 and a shade of gray with the value 0.
Lightness with the value 1 is white, and black with the value 0. The value 0.5 is commonly used.

Example:

hsl(0,0.5,0.5)

This example generates a red color with medium saturation and lightness.

Color keywords
Qlik Sense supports W3C recommended color keywords. With color keywords, specific colors are
defined by a name which corresponds to a RGB hex value. Enter the color name in the expression to
use the color.

Use the following links to find out more about W3C color keywords:
≤ http://www.w3.org/TR/CSS21/syndata.html#value-def-color
≤ https://developer.mozilla.org/en-US/docs/Web/CSS/color_value
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Example:

'cornflowerblue'

This example generates a blue color with the hex value of #6495ed and a RGB value of (100, 149,
237).

Qlik Sense color functions
The following color functions can be used in expressions when coloring by expression.

l black()
l darkgray()
l lightgray()
l white()
l blue()
l lightblue()
l green()
l lightgreen()
l cyan()
l lightcyan()
l red()
l lightred()
l magenta()
l lightmagenta()
l brown()
l yellow()

Creating an expression
You create expressions for colors in the properties panel.

Do the following:

1. In the properties panel, open Appearance > Colors and legend.
2. Click the Colors button to switch to Custom.
3. In the drop-down list, select the option By expression.

An expression text box is opened.

4. Enter your expression in the text box, or click to open the expression editor.

If the expression is valid, the visualization is updated.
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Visualization support for coloring methods
Not all Qlik Sense visualizations support the same coloring options. Additionally, some
visualization types have specific behaviors or limitations when using certain coloring
methods.

Color methods supported by visualizations and their limitations are determined primarily by the
kinds of data the visualizations displays. For example, visualizations that only support displaying
measures cannot be colored by dimension or through using master dimensions.

Color method support by visualization
The following table outlines color method support by visualization type.

Visualizatio
ns

Single
Multicolo
r

Master
measur
e

Master
dimensio
n

Dimensio
n

Measur
e

Expressio
n

Bar chart Yes Yes Yes Yes Yes Yes Yes

Box plot Yes - - - - - -

Combo chart Yes Yes Yes Yes Yes Yes Yes

Distribution
plot

Yes - - - - - -

Filter pane - - - - - - -

Gauge Yes Yes Yes - - -

Histogram Yes - - - - - -

KPI Yes Yes - - - - -

Line chart Yes Yes Yes Yes Yes Yes Yes

Map Yes - - Yes Yes Yes Yes

Pie chart Yes Yes Yes Yes Yes Yes Yes

Pivot table - - - - - - Yes

Scatter plot Yes - - Yes Yes Yes Yes

Table - - - - - - Yes

Text & image - - - - - - -

Treemap Yes Yes Yes Yes Yes Yes Yes

Color methods that are supported in the visualization

Visualization coloring limitations and behaviors
Different visualizations have different behaviors with the methods of setting color in visualizations.
This section outlines specific considerations when coloring different visualizations.
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Line chart

Line charts do not support coloring by measure if they have two or more dimensions.

Map

Colors assigned to master dimensions that contain geopoint data or area data (polygons of
geopoints) cannot be used to color a map.

Pie chart

Pie charts do not use master item colors when Auto is selected under Colors and legend.

Examples of visualization color settings
You can use a number of different methods to control the use of colors in your
visualizations.

You can manually apply colors to your visualizations using the following methods:

l Color by single color
l Color by multiple colors
l Color by dimension
l Color by measure
l Color by expression

In the example dashboard below, each method of setting colors has a corresponding visualization.
This section outlines each example as well as the specific settings used in the properties panel.
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Color by single color
Visualizations can be colored with a single user-defined color. Colors can be selected from a
palette or color wheel or by entering a hex color code.

In this example visualization, a single color has been applied to the line chart.

Properties panel settings

For this visualization, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and Single color. Color set as hex value 4477aa.

Color by multiple colors
Visualizations with multiple measures can have different colors applied to each measure. When a
visualization is colored using Multicolor, colors are automatically applied from a default color
scheme of 12 colors or 100 colors.

In this example visualization, multiple colors have been applied to the measures of Expense Amount
and Budget in the line chart.
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Properties panel settings

For this visualization, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and Multicolored.
l Color scheme: Set to 12 colors.

Color by master item
Colors can be kept consistent across visualizations for dimensions or measures through setting
colors in master items. When set to use master item colors, visualizations will use all colors
associated to the master items in the visualization. Master item colors can be used when Color is
set to Single color or Multicolor.

In these example visualizations, both the bar chart and line chart share a master measure, Revenue,
that is colored orange. In each visualization, the same assigned color is used for each instance of
Revenue. The line chart is colored by a second master measure, Expense Amount, which is colored
blue.
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Master measure settings

For this visualization, the following settings were applied to the master measures in Edit measure:

l Color: Hex color set as f8981d for Revenue and 4477aa for Expense Amount.

For more information, see Assigning colors to master items (page 142).

Properties panel settings

For the bar chart, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and Single color.
l Use library colors: Set to enabled.

For the line chart, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and Multicolor.
l Use library colors: Set to enabled.

Color by measure
When a visualization colored by measure, sequential or diverging gradients or classes are applied to
values in the chart based on the values of the selected measure. Visualizations can be colored by
measures within the visualization or they can be colored with measures associated to values in the
visualization.

In this example, this bar chart is colored by the measure used in the visualization, Revenue. A
diverging gradient has been applied to the values in the chart based on the Revenue value for each
dimension value.
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Properties panel settings

For this visualization, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and By measure. The measure selected is Revenue.
l Color scheme: Set to Diverging gradient.
l Reverse colors: Set to enabled.
l Range: Set to Auto.

Color by dimension
When a visualization is colored by dimension, each value within the visualization is assigned a color
based on an associated value from the coloring dimension. When colored by dimension, colors are
automatically applied from a default palette set of 12 or 100 colors.

Example 1: Coloring by a dimension in the visualization
In this example, the line chart is colored by the dimension of the different sales representatives,
using the 100 colors scheme. Each sales representative has their own distinct color in the
visualization.
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Line chart colored by dimension

Properties panel settings

For this visualization, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and By dimension. The dimension Sales Rep Name is selected.
l Persistent colors: Set to enabled.
l Color scheme: Set to 100 colors.

Example 2: Coloring by a dimension not included in the
visualization
In this example, the bar chart is colored by the dimension of Region, using the 12 colors scheme.
The bar for each sales representative is colored by the region in which they work.
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Properties panel settings

For this visualization, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and By dimension. The dimension Region is selected.
l Persistent colors: Set to enabled.
l Color scheme: Set to 12 colors.

Color by expression
You can use expressions to set specific colors to appear with specific values, enabling conditional
coloring of values in your visualizations. When a visualization is colored by expression, you define
the colors and how the colors are applied to values within the expression.

Example 1: Color by expression in a table
In this example, the table visualization uses two expressions, one for the background color and one
for the text. These expressions apply conditional colors to the background and text based on which
rows contain the top 10 and bottom 10 values for Revenue.
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Properties panel settings

For this visualization, the following properties were set in the properties panel under Data >
Columns:

l Background color expression: if(Rank(Sum([Sales Quantity]*[Sales Price])) <= 10,
'honeydew', if(Rank(-Sum([Sales Quantity]*[Sales Price])) <= 10, 'mistyrose', ))

l Text color expression: if(Rank(Sum([Sales Quantity]*[Sales Price])) <= 10, 'green', if(Rank(-
Sum([Sales Quantity]*[Sales Price])) <= 10, 'red', ))

Example 2: Color by expression in a chart
In this example, the bar chart uses an expression to assign specific colors to different values in
the Customer field.
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Properties panel settings

For this visualization, the following properties were set in the properties panel under Appearance >
Colors and Legends:

l Colors: Set to Custom and By expression.
l Expression: Set to if([Customer]= 'Fill It', rgb(100, 149, 227), if([Customer]= 'Hetrick

Systems', rgb(100, 149, 200), if([Customer]= 'Icon', rgb(100, 149, 175), if([Customer]= 'J. S.
Lee Associates', rgb(100, 149, 150), 'grey')))).

l This expression is a color code: Set to enabled.

Applying custom styling to a visualization
By default, the styling properties of a visualization are determined by the app theme.
You can override the app theme for individual visualizations by using the styling panel.
In the styling panel, you can also style individual charts with properties that are not
available in the app theme.

The styling panel is available in the properties panel. Under Appearance > Presentation, click
Styling. The properties available to customize depend on the chart type.

Examples of styling properties you can customize include, but are not limited to:
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l Chart title, subtitle, and footnote
l Background color and image
l Measure, dimension, and axis labels

For a list of customizable properties available for each chart type, see the corresponding chart-
specific help topic.

Copying and pasting visualization styling
If you have applied custom styling to a visualization, you can copy its styling properties and paste
them onto another visualization. With this option, you can quickly align the styling of your
visualizations without editing them in the properties panel or adding a custom theme.

You can copy and paste styles between different chart types. The entire style definition is applied
to the chart. Therefore, if a chart contains properties that do not apply to the chart receiving the
styling, these properties are still transferred to the receiving chart.

Do the following:

1. In sheet edit mode, right-click a chart or open the options menu by selecting the button
next to it.

2. Click Copy style.

3. Right-click the chart onto which you want to paste the styling, or open its options menu.

4. Click Paste style.

Limitations
l You cannot copy and paste the styling of a master visualization.
l You cannot copy and paste the styling of a map.
l You cannot copy and paste the styling of a button.

App themes
If you are looking to change the styling for all visualizations in the app, it might be easier to change
the app theme. For increased control over specific styling aspects of all app visualizations, consider
developing a custom theme and applying it to the app.

For more information about styling an app, see Styling an app (page 33).

Converting a visualization to another kind of visualization
You can convert from one visualization type to another by dragging a chart from the
assets panel on the left-hand side onto the visualization that you want to convert.

All properties that the original visualization has are transferred to the new type. The new
visualization uses the dimensions, measures, and settings that are applicable to that visualization
type. If a visualization requires an additional primary dimension or measure, the first listed
alternative dimension or measure is used by default. If no alternative dimensions or measures exist
and one is required the new visualization, you will be prompted to add one.
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All properties from the original visualization are saved, even if they are not available or visible in the
new visualization. This means that properties can become available again if you decide to convert
to yet another visualization type where those properties are used.

Do the following:

1. While editing a sheet, drag a new chart from the assets panel onto the visualization that you
want to convert.
The shortcut menu opens.

2. Select the conversion option.

The new visualization is displayed, using the data from the original visualization.

When you convert to a new visualization type, some of the settings from the original
visualization may not be optimal for the new visualization, for example, the sorting order.
Therefore, you may need to make some changes in the properties panel, so that the new
visualization is displayed as you want.

You cannot convert to or from a map or a text & image visualization, nor can you convert
a master visualization.

Embedding a visualization or a sheet in a web page
You can integrate Qlik Sense visualizations or sheets into an iframe element on a web
page with the Single Integration API. This could for example be a web page on your
intranet. You select which visualization or sheet to embed, and make some settings to
customize selections, interaction and appearance. Then you can copy the iframe code
containing the URL of the object and add it to your web page.

The embedded object will be subject to the same access rules as the original object and app. This
means that anyone who wants to view the embedded object must have:

l Access to Qlik Sense.
l Access to the app. If the app is unpublished (in My work), you are the only one with access.
l Access to the sheet. If the sheet is unpublished (in My sheets) in a published app, you are

the only one with access.
l Access to any bookmark used for selection. Private bookmarks will be applied for you, but

not for anyone else.
l Same access to the data used in the selection as you, if section access is used to restrict

data access.

Embedding a sheet
You can embed a sheet in your web page.
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Do the following:

1. Click Embed sheet in the global menu.
2. Customize selections, appearance and interaction options for the embedded sheet.
3. Click Open preview in new tab to see a preview of the embedded sheet.
4. Click Copy.

You now have the iframe code of the sheet in your clipboard, ready to add to your web page.

Embedding a visualization
You can embed a visualization in your web page.

Do the following:

1. Right-click on the visualization or click the hover menu .

2. Select Share. Then choose Embed.
3. Customize selections, appearance and interaction options for the embedded visualization.
4. Click Open preview in new tab to see a preview of the embedded visualization.
5. Click Copy.

You now have the iframe code of the visualization in your clipboard, ready to add to your web page.

Setting appearance and interaction
You can customize how you can interact with the embedded object.

l Allow interaction
You can select if you want the user to be able to interact with the embedded object.

l Enable context menu
You can select if you want the context menu to be available when the embedded object is
right-clicked.

l Language
You can select which language to use in menus for the embedded object.

l Theme
You can select which theme to use for the embedded object.

Selections in the embedded object
You can choose if the user can make selections in the embedded object, and which selection state
to show in the embedded object.

l Use current selections
You can select to use the current selections in the app.

l Show selections bar
You can select to show the selections bar above the sheet.

l Clear app selections on refresh
You can select to clear all selections made in the app when the object is rendered.
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l Apply bookmark
You can select to apply a bookmark and use the selections defined in the bookmark.

When the page containing the embedded object is rendered, the initial selection state is defined by
the order of execution and your settings.

1. Clear app selections on refresh
2. Apply bookmark
3. Use current selections

When you make selections in the embedded object, they will be replicated in the app. If you select
Clear app selections on refresh, for example, and use the embedded object, selections are
cleared in the app.

You can use Open preview in new tab to preview the embedded object, and interact
without affecting selections in the app.

Limitations of embedded objects
l Embed sheet and Embed chart features are not available on devices with a small screen.
l The sheet title is not included when embedding sheets.
l The URL is limited to 2083 characters due to browser limitations. If your URL is too long, this

is most likely due to a large number of individual selections.

You can create a bookmark with the same set of selections, and apply the
bookmark. This will create a shorter URL.

l Depending on the size of the shadow, and the amount of padding around the visualizations
around it, shadows applied to charts can be cut off when the chart with the shadow is
embedded outside of Qlik Sense.

3.6 Troubleshooting - Creating visualizations
This section describes problems that can occur when creating visualizations in Qlik Sense.

I cannot find the fields in the assets panel
I can find Charts and Master items in the assets panel, but not Fields.

Possible cause

You are working with a published app. Some content is not available in the assets panel in a
published app.

My chart is not sorted correctly
I set my chart to sort automatically on the dimension, but the results are not sorted correctly.

Create apps and visualizations - Qlik Sense, November 2024 642



3   Visualizations

Possible cause

The dimension is an expression with a result that has a different data type than the data fields used
in the expression.

Proposed action

Change sorting of the dimension to Custom, and select a sorting option that matches the result of
the expression. For example, if your expression concatenates two fields to a string, like Month

(salesDate)&'/'&Day(salesdate), select to sort alphabetically.

My calendar measures display incorrect aggregations in
visualizations
When I use my calendar measures in visualizations, I see incorrect aggregation results. For
example, calendar measures created from identical fields and aggregations but different time
ranges may display identical totals.

Possible cause

The table containing the aggregated field is not associated to the table containing the date field,
preventing accurate aggregation of the field by the selected time ranges.

Proposed action

Create an association between the table containing the aggregated field and the table containing
the date field. If there is no association possible, in Data manager, add a table that includes a date
field that has an association to the table containing the aggregated field.

There are no time ranges to select in Create calendar measures
When I have a date field selected in the Create calendar measures dialog try to create calendar
measures from a field, there are no time ranges to select in the Create calendar measures dialog.

Possible cause

The selected date field does not have the correct time flags to work with calendar measures. If you
have no valid date fields, you cannot create calendar measures. If you have at least one valid date
field, all date fields will be available in Date field. However, only those with the correct time flags
set in autoCalendar enable the selection of time ranges from the Time Range drop-down list.

Proposed action

Select a date field that uses autoCalendar. If you are unsure which calendar is associated to your
date field, date fields in the Field section of the Assets panel display which calendar it uses when
clicked.
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My date field selected for calendar measures does not use the
correct calendar
I have two calendars to which I have manually added time flags. My time flags have the same names
as those in autoCalendar, making both qualified for use with calendar measures. However, only one
of my calendars has the same definition for the time flags as autoCalendar. I have a date field
associated to both calendars . When I try to create calendar measures using that date field, the
calendar with the correct names but different definitions than autoCalendar is used.

Possible cause

In cases where a date field is associated to multiple calendars and each calendar has the correctly
named time flags set in it, calendar measures uses the first qualified calendars defined in your data
load script.

Proposed action

Move the script section containing the calendar you want to use with calendar measures before
other qualified calendars in your data load script.

I cannot edit a variable value
I cannot edit a variable that is listed in the variables dialog.

Possible cause

The variable is defined in the script.

Proposed action

Edit the variable in the script, using the data load editor, or delete the variable from the script, using
the data load editor, to make the variable editable from the variables dialog.

For more information, see Editing a variable (page 163)

You cannot rename a variable.

The map is placing the locations in my location field incorrectly
When I add a location field to a layer in my map, the locations do not display in the correct places.

Possible cause

The map does not have enough context to locate the locations in your field. This can happen when
a location in the field shares a name with a number of other possible locations on the map.

Proposed action

Set Scope for Location in your layer to Custom and enter additional information. Alternatively,
qualify your location field using an expression that contains additional fields with relevant
geographic information. If your location field contained cities and you had Country and State fields,
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you could use [City]&','&[State]&','&[Country].

No map is displayed
I am using Qlik Geoanalytics server, the background map is not displayed.

Possible cause

Your browser cannot access qlikcloud.com or your firewall settings or proxies prevent the use of
JavaScript from qlikcloud.com. .

Proposed action

Visit the status page from your browser.

If your browser cannot access qlikcloud.com contact your system administrator for assistance.

If the page prints "ok" then your browser can access qlikcloud.com. Make sure that JavaScript from
qlikcloud.com is allowed.

Do the following:

l Add https://*.qlikcloud.com as a trusted site. (recommended)
l Enable JavaScript from untrusted sites. (not recommended)

Error message: The data contains invalid geometries that could
not be shown on the map. Review your data for errors and try
again.
I loaded geoshapes from a KML file to Qlik Sense. When I try to add the field to my map, an error
message tells me that my data contains invalid geometries that could not be shown on the map.

Possible cause

There is an error in your geometries that is preventing Qlik Sense from displaying them on the map
or your geometry data may be in an invalid format.

Proposed action

Review your geometry data for errors and try again.

Error message: The following locations could not be found:
<locations>. Review the values in your data and try again.
I added my location field to my map and I received an error messaging telling me locations in my
location field could not be found.

Possible cause

Qlik Sense could not find the location. There may be a spelling error in the name or the location is
not available in the Qlik Sense location database.
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Proposed action

Review the values in your data for errors and try adding the field again. If a location cannot be
found, you can alternatively manually add it using coordinates for points or geoshapes for areas.

Error message: The following locations could not be located:
<locations>. Review the values in your data and try again.
I added a location field to my layer and I received an error message telling me that certain locations
in my location field could not be located.

Possible cause

Qlik Sense could not find the location. There may be a spelling error in the name or the location is
not available in the Qlik Sense location database.

Proposed action

Review the values in your data for errors and try adding the field again. If a location cannot be
found, you can alternatively manually add it using coordinates for points or geoshapes for areas.

Error message: The following locations had more than one result:
<locations>. Set a custom scope to clarify which locations to
display.
I added a location field to my layer and I received an error message telling me that certain locations
in my field had more than one possible result on the map.

Possible cause

One or more locations in your location field are ambiguous, with multiple possible locations on your
map.

Proposed action

Set Scope for Location in your layer to Custom and enter additional information. Alternatively,
qualify your location field using an expression that contains additional fields with relevant
geographic information. If your location field contained cities, you , such as: [City]&','&
[County]&','&[State].

Error message: Some lines could not be shown because of invalid
data in the width expression. Review your data for errors and try
again.
I entered a field or expression to control the width of the lines on my map and I received an error
message telling me that certain lines have invalid data.
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Possible cause

There is an error in your width expression that is preventing Qlik Sense from displaying specific
lines on the map.

Proposed action

Your expression may contain non-numeric values. Review your data for errors and try again.

Error message: Some density points could no be shown because
of invalid data in the weight expression. Review your data for
errors and try again.
I entered a field or expression to control the density of the points on my map and I received an error
message telling me that certain densities have invalid data.

Possible cause

There is an error in your weight expression that is preventing Qlik Sense from displaying specific
densities on the map.

Proposed action

Your expression may contain non-numeric values. Review your data for errors and try again.

I added an image background layer and cannot see my image
I added an image background layer to my map visualization, but I cannot see it on the map.

Possible cause

Depending on the projection of your map and the scale of the image, the map may be too zoomed
out to see the image.

Proposed action
Do one of the following:

l In Map settings, enable Auto-zoom. Add a layer containing location data that would put it
over the same area as your image background layer.

l In Presentation, enable Show debug info. The map now includes coordinates for the center
of the displayed area.

Create apps and visualizations - Qlik Sense, November 2024 647


	1   About this document
	2   Creating apps
	2.1  Foundations
	Data manager and Data load editor
	Measures
	Dimensions

	2.2  Structure and visuals
	Sheets
	Bookmarks
	Stories

	2.3  Structuring an app using sheets
	Overview
	Creating a new sheet
	Changing the title and description of a sheet
	Setting a show condition for a sheet
	Changing the sheet thumbnail
	Changing the grid sizing of a sheet
	Customizing sheet size
	Changing the small screen layout
	Extending the sheet area
	Adding actions to sheets
	Adding a background color or image
	Copying, replacing and moving items on sheets
	Duplicating a sheet
	Adding actions to sheets
	Grouping sheets

	2.4  Managing apps
	Creating an app
	On-demand apps
	Styling an app
	Reloading app data
	Managing app reload tasks
	Converting a QlikView document into a Qlik Sense app
	Manually converting a QlikView document into a Qlik Sense app
	Changing the title and description of an app
	Changing the thumbnail of an app
	Duplicating an app
	Making apps available in Insight Advisor Chat
	Turning on chart level scripting
	Turning off Insight Advisor
	Deleting an app
	Uploading image files to media library
	Deleting image files from media library
	Best practices for designing accessible apps

	2.5  Troubleshooting - Creating apps
	Images are not included in an app that has been moved from one Qlik Sense env...
	Images are not included in an app that has been moved from one Qlik Sense Des...
	The image I want to use does not seem to work
	Using Insight Advisor impacts system performance
	I cannot find Reload when I right-click on an app
	I cannot manage my app reload tasks in the hub
	Thumbnails are not included when copying a sheet
	Right-to-left reading order works for some visualizations, but not others

	2.6  Optimizing app performance
	App complexity
	App details
	Monitoring your app
	Large data volumes
	Data model performance
	Sheet performance


	3   Visualizations
	3.1  Select visualization types that align with your purpose
	3.2  Data assets in visualizations
	Data assets
	Expressions
	Data types in visualizations
	Fields
	Dimensions
	Measures
	Reusing assets with master items
	Master measure formatting
	Using expressions in visualizations
	Example: Using a variable with dollar-sign expansion
	Example: Variable with dollar-sign expansion in pivot table
	More examples: Using variables in dollar-sign expansions
	Example: Directly referencing a variable in an expression
	Using chart level scripting in visualizations
	Searching in the assets panel
	Designing visualizations with Direct Discovery

	3.3  Best practices for choosing visualization types
	Viewing comparisons
	Viewing relationships
	Viewing compositions
	Viewing distributions
	Viewing performances
	Viewing data
	Viewing geography
	What if no standard chart suits my purpose?

	3.4  Visualizations
	Creating a visualization
	Reusing a visualization
	Which visualizations are available?
	Bar chart
	Box plot
	Bullet chart
	Combo chart
	Distribution plot
	Filter pane
	Gauge
	Histogram
	KPI
	Line chart
	Map chart
	Mekko chart
	Navigation menu
	NL insights
	Pie chart
	Pivot table
	Scatter plot
	Table
	Text & image
	Treemap
	Waterfall chart
	Button
	Tab container
	Reference lines
	Creating custom tooltips
	Null values in visualizations
	Dashboard bundle
	Product group visualization
	Product sub group visualization
	Master visualizations
	Container
	Visualization bundle
	Changing a measure/label color
	Changing background color
	Alignment
	Number formatting
	Format pattern
	Segment/card
	Items per row
	Borders
	Value/Label layout and formatting
	Add the data
	Create the master visualization
	Create the Trellis container
	Add the data
	Create the master visualization
	Create the Trellis container

	3.5  Creating and editing visualizations
	Creating visualizations
	Editing visualizations
	Best practices for designing visualizations
	Creating visualizations with Insight Advisor
	Creating visualizations using Insight Advisor chart suggestions
	Guidelines for visualizations, fields, and naming
	Using alternate states for comparative analysis
	Creating a visualization using a custom object
	Copying a visualization from an existing visualization
	Adding trend and reference lines to visualizations
	Creating time-aware charts
	Changing the data of a visualization
	Changing the appearance of a visualization
	Examples
	RGB
	ARGB
	HSL
	Color keywords
	Qlik Sense color functions
	Example 1: Coloring by a dimension in the visualization
	Example 2: Coloring by a dimension not included in the visualization
	Example 1: Color by expression in a table
	Example 2: Color by expression in a chart
	Converting a visualization to another kind of visualization
	Embedding a visualization or a sheet in a web page

	3.6  Troubleshooting - Creating visualizations
	I cannot find the fields in the assets panel
	My chart is not sorted correctly
	My calendar measures display incorrect aggregations in visualizations
	There are no time ranges to select in Create calendar measures
	My date field selected for calendar measures does not use the correct calendar
	I cannot edit a variable value
	The map is placing the locations in my location field incorrectly
	No map is displayed
	Error message: The data contains invalid geometries that could not be shown o...
	Error message: The following locations could not be found: <locations>. Revie...
	Error message: The following locations could not be located: <locations>. Rev...
	Error message: The following locations had more than one result: <locations>....
	Error message: Some lines could not be shown because of invalid data in the w...
	Error message: Some density points could no be shown because of invalid data ...
	I added an image background layer and cannot see my image



