Upgrading

You can upgrade from Qlik Sense 3.1 SR2 or later to Qlik Sense June 2017 or later using the Qlik Sense setup program. When upgrading, the previous version is completely replaced by the new version.

To upgrade from Qlik Sense 3.1 SR2 or later with a shared persistence model to Qlik Sense June 2017 or later, see Upgrading from Qlik Sense 3.1 SR2 or later to Qlik Sense June 2017 or later.

Warning: Do not uninstall Qlik Sense before upgrading to Qlik Sense June 2017 or later. If you are upgrading to Qlik Sense June 2017 or later, and you have uninstalled Qlik Sense, see Upgrading to Qlik Sense June 2017 or later after uninstalling Qlik Sense 3.1 SR2 or later .

Qlik Sense June 2017 and later versions do not support the synchronized persistence model. To upgrade from Qlik Sense 3.1 SR2 or later to Qlik Sense June 2017 or later and migrate from a synchronized persistence model to a shared persistence model, see Upgrading and migrating from synchronized to shared persistence.

Upgrading from any version of Qlik Sense earlier than 3.1 SR2 to Qlik Sense June 2017 or later cannot be done using the setup program. To upgrade from earlier versions of Qlik Sense with a synchronized persistence model to Qlik Sense June 2017 or later, see Upgrading to Qlik Sense June 2017 or later from Qlik Sense versions earlier than 3.1 SR2.

Note: When you upgrade to a newer version of Qlik Sense, you will not get the option to configure centralized logging in the installer. Instead, if you want to enable centralized logging, you must configure it using the Qlik Logging service. See: Qlik Logging Service
Warning: Qlik Sense November 2017 and later versions do not support soft deleted records. Qlik Sense will clean up all soft deleted records on the first startup of the Qlik Sense Repository Service after an upgrade. For troubleshooting, refer to Failed to remove soft deleted records.
Warning: During upgrade, the Repository.exe.config file located in %ProgramFiles%\Qlik\Sense\Repository is overwritten with default settings.
If the file was manually changed in your previous deployment, you must create a backup of the file before upgrading, and use the backup to restore your customized settings. Once the Repository.exe.config is restored, you must restart the Qlik Sense services.

Qlik Sense apps

When you upgrade Qlik Sense all existing apps need to be migrated to ensure compatibility between the versions. This happens automatically when the system starts the first time after the upgrade. If the migration fails for one or more apps, these apps will not be available in the Hub after the upgrade. Apps that are not migrated are indicated in the Apps section of Qlik Management Console, where you can also perform a manual migration.

Multi-node deployments

In a multi-node deployment, all nodes must run the same version of Qlik Sense to be able to communicate with each other. It is recommended to upgrade with all nodes offline, and to start with the central node.

Warning: When upgrading a rim node, ensure that you use the same log-in account as was used for the initial installation of that node. Failure to do so means that the central node will not find the certificates installed on the node and you will need to perform a clean installation of the node.

Qlik Sense Repository Database

Qlik Sense June 2017 and later versions use PostgreSQL version 9.6 for the Qlik Sense Repository Database. If you upgrade in place without uninstalling Qlik Sense the Qlik Sense Repository Database is upgraded to PostgreSQL version 9.6 and your data, and standard settings are carried forward. If you have made custom configurations to your PostgreSQL installation, those must be recreated in the PostgreSQL after upgrade.

PostgreSQL version 9.6 is installed with the latest version of Qlik Sense. If you have uninstalled Qlik Sense but maintained your PostgreSQL database, and you want to upgrade your Qlik Sense deployment, you must create a database dump file and restore the PostgreSQL database manually. You will also need to manually reconfigure any custom parameters.

The PostgreSQL installation included in the Qlik Sense June 2017 or later setup does not include pgAdmin tools. For information about manually installing the PostgreSQL database, see Installing and configuring PostgreSQL.

Before you upgrade Qlik Sense, do the following:

The

Do the following:

  1. Stop your Qlik Sense services.
  2. Upgrade your central node by launching the Qlik Sense setup file (Qlik_Sense_setup.exe).
  3. Select Upgrade to upgrade your existing shared persistence deployment.
  4. Accept the license agreement and click Next.
  5. On the Service Credentials page, enter the Username and Password for your Windows Qlik Sense service user account.

    If the user is member of a domain, enter the service account as <domain>\<username>. For more information, see User accounts.

  6. On the Ready to upgrade page, select the appropriate check boxes if you want the setup to create desktop shortcuts and automatically start the Qlik Sense services when the setup is complete, and click Upgrade.
  7. Check that all of the Qlik Sense services have started successfully.
  8. Check that all apps have been migrated successfully on the central node. If migration has failed for one or more apps, resolve the issues before continuing.

    Warning: If the node running the app migration goes offline, migration will stop. It will not restart automatically. In a single node environment, all apps will have Migration status set to Unknown. See: Migrating apps. In a multi-node environment with failover nodes, the primary node will be replaced by the next available node, but migration will not restart. See: Failover. To resume migration, you will need to restart the following services, in order: Qlik Sense Service Dispatcher (QSD) and Qlik Sense Repository Service (QRS). See: Services.
  9. Deploy the Qlik Sense upgrade with shared persistence on the remaining nodes.
  10. Note: Any custom manual configurations that you make to the PostgreSQL database must be manually reproduced after the upgrade.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?