Skip to main content

Prerequisites

The following section describes the prerequisites for using Snowflake on Google as a Qlik Replicate target endpoint.

Client prerequisites

  • Qlik Replicate for Windows: Download and install Windows 64-bit ODBC driver 2.24.0 or later.

  • Qlik Replicate for Linux: Download and install Linux 64-bit ODBC driver 2.24.0 or later.
Note:

The expected name for the ODBC driver is SnowflakeDSIIDriver (the default).

Performance and Cloud Services usage optimization

In order to optimize both Snowflake Cloud Services usage and overall performance, it is strongly recommended to enable the Apply batched changes to multiple tables concurrently option in the task settings' Change Processing Tuning tab.

For information about charges incurred when using Snowflake Cloud Services, see Snowflake: Additional Billing (Cloud Services Layer) Impact

Storage integration name

You need to specify a storage integration name in the Snowflake on Google target endpoint settings. Integrations avoid the need for passing explicit cloud provider credentials such as secret keys or access tokens; instead, integration objects reference a Cloud Storage service account.

For more information on creating a storage integration name, see Configuring an Integration for Google Cloud Storage

Firewall prerequisites

Firewall port 443 needs to be opened for outbound communication.