Skip to main content

Prerequisites

Make sure that the following prerequisites have been met:

Qlik Replicate for Windows

For all versions of the source database, install Microsoft ODBC Driver 17.4.2 on the Qlik Replicate Server machine.

Qlik Replicate for Linux

Install Microsoft ODBC Driver 17.4.2 for Linux on the Qlik Replicate Server machine.

General prerequisites

  • A Microsoft SQL Server account with the specific access privileges is required. See Source Permissions for more information.
  • Microsoft SQL Server as a source must be configured for a full backup to work with Qlik Replicate. For more information, see Preparing Microsoft SQL Server backup and recovery.
  • When decompressing a compressed backup transaction log, Replicate writes the decompressed log to the same location as the compressed log. Consequently, the location of the compressed backup transaction log must have enough space to contain the decompressed log as well.
  • If your environment matches the following:

    • Microsoft SQL Server versions 2008, 2012 or 2014
    • Microsoft ODBC Driver 17 installed on Red Hat 8.1

    Then, in order to work with TLS 1.2, you must install a specific Service Pack on the Windows machine where Microsoft SQL Server is installed.

    For more information, see the following Microsoft article.