# Straight Table - AJAX/Webview

In opposition to the pivot table, the straight table cannot display subtotals or serve as a cross table. On the other hand, any of its columns can be sorted and each of its rows contains one combination of dimension(s)+expression(s).

## Straight Table: Object Menu

The object menu can be opened as a context menu by right-clicking on a sheet object, or by clicking the Menu icon in the object caption (if shown).

The commands in the menu may vary depending on whether WebView is used from inside QlikView or opening the document in a web browser. The menu contains the following commands:

Object Menu properties

| Property | Description |
| --- | --- |
| Properties... | Opens the **Properties** dialog for the active sheet object. |
| Notes | Allows creating and sharing notes about the current object. |
| Detach | The chart title is appended with the text “(Detached)” and the chart is no longer updated with selections<br>made in the document (though selections may actually still be made from<br>the chart). The command is available only if the chart is attached. By making a copy of a chart and detaching<br>it, you may make direct comparisons between the copy and the original. |
| Attach | Attaches a detached chart. The chart becomes<br>dynamically linked to the data. The command is available only if the chart<br>is detached. |
| Clear All Selections | Clears all the current selections in the active sheet object. Clicking on the Eraser icon in the object caption (if shown) produces the same result. |
| Copy | Copies the selected sheet object(s) to the clipboard. This function only copies sheet objects, not data or images. |
| Copy cell value to clipboard | Copies the selected cell value to the clipboard. |
| Print... | Opens the selected sheet object(s) in tabular format in another browser window. Clicking on the Printer icon in the object caption (if shown) produces the same result. |
| Send to Excel | Exports possible (including selected) values to Microsoft Excel, which is automatically launched if not already running. The exported values will appear as one column in a new Excel worksheet. For this functionality to work Microsoft Excel 2007 or later must be installed on the computer. Clicking on the Spreadsheet icon in the object caption (if shown) produces the same result. |
| Export... | Opens the Save as dialog where path, file name and (table) file type for the exported data content can be specified. |
| Fast Change | Makes it possible to change the current chart into another chart type. Clicking on the Fast forward icon in the object caption (if shown) produces the same result. Only available if Fast Type Change in Chart has been enabled on the Caption tab of the Properties dialog. |
| Minimize | Iconizes the object. Clicking on the Minimize icon in the object caption (if shown) produces<br>the same result. This<br>command is available only if minimizing is allowed in the object's Properties dialog on the Caption page. |
| Restore | Restores a minimized or maximized object to its previous size and<br>location. Double-clicking the icon of a minimized object or clicking the Restore icon in the object caption (if shown) of a maximized object produces<br>the same result. This command is available only for minimized or<br>maximized objects. |
| Maximize | Enlarges the object to fill the sheet. Clicking on the Maximize icon in the object caption (if shown) produces the same result. This command is available<br>only if maximizing is allowed in the object's Properties<br>dialog on the Caption page. |
| Remove | Removes the selected object from the sheet. |

## Straight Table Properties

The Properties dialog is opened by selecting **Properties** from the **Object** menu. If the **Properties** command is dimmed, you probably do not have the privileges necessary to perform property changes.

### Dimensions

Choose dimensions in the drop-down list. To add a dimension, click the Add icon. Select a dimension in the drop-down. Use the Move icon to move items in the list. The Remove icon removes items from the list. For more information click the More... button.

#### Dimension

* Enable Conditional: Marking this check box hides or shows the dimension dynamically, depending on the value of a condition expression entered, by clicking the FX icon button in the edit box below.
* Dimension: Displays the currently selected dimension.
* Label: The label of the dimension. Enter the name you wish to display in the chart. If no text is entered, the label will be automatically set to the expression text.
  * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Suppress Null Values: If this check box is marked, the field selected in the Used Dimensions above will not be displayed in the chart if its value is NULL.
* Show All Values: Select this box to show all the dimension field values in the chart, including logically excluded values.
* Dropdown Select: If this check box is selected for a field column, a drop-down icon will appear to the left in the column header. By clicking the icon, a list box showing all field values of the field will be opened over the table. It is then possible to make selections and searches in the same manner as if the field had been a row in a multi box.
* Show Column: When the check box is enabled, the column will be visible.
* Conditional: Enable the check box to show or hide the column depending on a condition expression which will be evaluated each time the table is drawn. The column will only be hidden when the condition returns FALSE. Enter the conditional expression in the box below. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Column Alignment: Click the Engine icon to open the popup.
  * Column Alignment Popup:
    * Label: Sets the alignment for the label to Left, Centered, or Right.
    * Data (Numeric): Sets the alignment for the horizontal label to Left, Centered, or Right.
    * Data (Text): Sets the alignment for text data to Left, Centered, or Right.
* Attribute Expression Styles:
  * Background Color: Define an attribute expression for calculating the cell background color of the dimension cell. The expression used should return a valid color representation (a number representing the Red, Green and Blue components as defined in Visual Basic) which is typically achieved by using one of the special chart color functions. If the result of the expression is not a valid color representation, black will be used.
  * Text Color: Define an attribute expression for calculating the cell text color of the dimension cell. The expression used should return a valid color representation (a number representing the Red, Green and Blue components as defined in Visual Basic) which is typically achieved by using one of the special chart color functions. If the result of the expression is not a valid color representation, black will be used.
  * Text Format: Define an attribute expression for calculation of the font style of text in the table cell for each dimension cell. The expression used as text format expression should return a string containing a '&lt;B&gt;' for bold text, '&lt;I&gt;' for italic text and/or '&lt;U&gt;' for underlined text.

#### Sort

Here the sort order of the values in the sheet object, is set. Some sort options may not be available for some sheet objects.

If more than one sort order is specified, the sort order will be state, expression, frequency, numeric, text, load order.

* Primary Sort:
  * Y-Value: Sets whether the dimension values should be sorted according to the numeric value of the y-axis. This option is not available for calculated dimensions.
  * Frequency: Sorts the field values by frequency (number of concurrences in the table).
  * Numeric Value: Sorts the field values by their numeric values.
  * Text: Sorts the field values in alphabetical order.
  * Load Order: Sorts the field values by the initial load order.
* Secondary Sort: Frequency: Sorts the field values by frequency (number of concurrences in the table).   
  Numeric Value: Sorts the field values by their numeric values.  
  Text: Sorts the field values in alphabetical order.  
  Load Order: Sorts the field values by the initial load order.
* Sort by Expression: Sorts the field values according to the expression entered.
  * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Keep Selected on Top: Enable this to keep the selected on top.

#### Limits

Restrict which values are displayed using the first expression

These properties are used to determine how many dimension values are displayed in the chart, according to settings made below.

* Show only:
  * Select this option if you want to show the First, Largest or Smallest x number of values. If this option is set to 5, there will be five values displayed. If the dimension has Show Others enabled, the Others segment will take up one of the five display slots.
    * The First option will return the rows based on the options selected on the Sort tab of the property dialog. If the chart is a Straight Table, the rows will be returned based on the primary sort at the time. In other words, a user can change the values display by double-clicking on any column header and making that column the primary sort.
    * The Largest option returns the rows in descending order based on the first expression in the chart. When used in a Straight Table, the dimension values shown will remain consistent while interactively sorting the expressions. The dimensions values will (may) change when the order of the expressions is changed.
    * The Smallest option returns the rows in ascending order based on the first expression in the chart. When used in a Straight Table, the dimension values shown will remain consistent while interactively sorting the expressions. The dimensions values will (may) change when the order of the expressions is changed.
    * Enter the number of values to display.
  * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
  * Select Include Boundary Values to include the dimension value that contains the comparison value.
* Show only values that are:
  * Select this option to display all dimensions values that meet the specified condition for this option.
  * Select to display values based on a percentage of the total, or on an exact amount.
  * The relative to the total option enables a relative mode which is similar to the Relative option on the Expressions tab of the property dialog.
    * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Show only values that accumulate to:
  * When this option is selected,all rows up to the current row are accumulated, and the result is compared to the value set in the option.
  * The relative to the total option enables a relative mode which is similar to the Relative optino on the Expressions tab of the property dialog, and compares the accumulated values (based on first, largest or smallest values) to the overall total.
  * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Show Others:
  * Enabling this option will produce an Others segment in the chart. All dimension values that do not meet the comparison criteria for the display restrictions will be grouped into the Others segment. If there are dimensions after the selected dimension, Collapse Inner Dimensions will control whether individual values for the subsequent / inner dimensions display on the chart. In the Label field, enter the name you wish to display in the chart. If no text is entered, the label will be automatically set to the expression text.
  * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
  * If there are dimensions after the selected dimension, Collapse Inner Dimensions will control whether individual values for the subsequent / inner dimensions display on the chart.
* Show Total:
  * The chart will display a total for the selected dimension when this option is enabled. This total behaves differently than the expression total, which is still configured on the **Expressions** tab of the property dialog. **Label**: Enter the name you wish to display in the chart. If no text is entered, the label will be automatically set to the expression text.
  * The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Use Global Grouping Mode: The option only applies to inner dimensions. When this option is enabled the restrictions will be calculated on the selected dimension only. All previous dimensions will be ignored. If this is disabled, the restrictions are calculated based on all preceding dimensions.

### Expressions

Choose expressions in the drop-down list. To add a dimension, click the Add icon. Select an expression the drop-down. Use the Move icon to move items in the list. The Remove icon removes items from the list. For more information click the More... button.

#### Expression

* Enable: Marking this check box will enable the selected expression. If the box is not marked, the expression will not be used at all.
* Conditional: Marking this check box hides or shows the expression dynamically, depending on the value of a condition expression entered, by clicking the Function button in the edit box below.
* Label: The label of the expression. Enter the name you wish to display in the chart. If no text is entered, the label will be automatically set to the expression text.
* Expression: The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog. Displays the currently selected expression.
* Comment: Enter a comment to describe the purpose and function of the expression. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Show Column: When the check box is selected, the column is visible.
* Conditional: Enable the check box to show or hide the column depending on a condition expression which will be evaluated each time the table is drawn. The column will only be hidden when the condition returns FALSE. Enter the conditional expression in the box below. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Invisible: Hides the expression.
* Show in Percent (Relative): The chart shows the result in percent instead of absolute numbers.
* Representation:

  Choose a representation in the drop-down list. Depending on which representation is chosen different settings are shown.
  * Text: No other settings
  * Image: Click the Engine icon to open the popup.
    * Image Settings Popup:
      * Image Stretch:No Stretch: Displays the image without stretching. This may cause parts of the picture to be invisible or only part of the object to be filled.  
        Fill: The image is stretched to fit the object area without keeping the aspect ratio of the image.   
        Keep Aspect: The image is stretched as far as possible to fill the object area while keeping the aspect ratio.   
        Fill with Aspect: The image is stretched to fill the object area in both directions while keeping the aspect ratio.   
        Hide Text When Image is Missing: No text will be displayed if QlikView cannot interpret the image reference.

      * Gauge: Settings for the different Gauge alternatives:

        * Gauge Min: Specifies the minimum value of the gauge. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
        * Gauge Max: Specifies the maximum value of the gauge. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.

      * Mini Chart Field: Choose the field for which the expression should be plotted. Click the Engine icon to open the popup.

      * Mini Chart Mode Settings Popup: Mini Chart Mode Settings Popup provides several settings for you to modify.

      * Mode: Set the mini chart as sparklines, lines, dots, bars or whiskers.

      * Color: Opens the Color dialog, where you can set the plot color of the mini chart.

      * Max Value Color: Enable this setting and click the Caption color icon to open the Color dialog. You can set a color for the maximum value.

      * Min Value Color: Enable this setting and click the Caption color icon to open the Color dialog. You can set a color for the minimum value.

        Information noteThis setting is only available when Mode is set to Sparkline.

      * Start Value Color: Enable this setting and click the Caption color icon to open the Color dialog. You can set a color for the start values.

        Information noteThis setting is not available for bars and whiskers.

      * End Value Color: Enable this setting and click the Caption color icon to open the Color dialog. You can set a color for the end values.

        Information noteThis setting is not available for bars and whiskers.

      * Force 0: Fixes the lower edge of the chart to zero on the axis.

        Information noteNot available for whiskers.

      * Shared Y-Axis Scale: Forces all cells in the column to use the same y-axis scale.

      * Link: No other settings.
* Column Alignment: Click the Engine icon to open the popup.
  * Column Alignment Popup: Label sets the alignment for the label to Left, Centered, or Right.
  * Data (Numeric): Sets the alignment for the horizontal label to Left, Centered, or Right.
  * Data (Text): Sets the alignment for text data to Left, Centered, or Right.
* Visual Cues: Click the Engine icon to open the popup.
  * Visual Cues Popup:
    * Upper Limit: Settings for the upper numeric interval value category. The numeric value above which the upper interval of numeric values begins is stated in the edit box. If this box is left empty no upper interval is defined.
    * Normal: Settings for the normal numeric interval value category. This interval is defined as all values between the upper limits and lower limits. By default, all numeric values fall within the normal interval.
    * Lower Limit: Settings for the lower numeric interval value category. The numeric value below which the lower interval of numeric values begins is stated in the edit box. If this box is left empty no lower interval is defined.
* Use Expression Total:

  Check this box to use expression total. Click the Gen Settings icon to open the popup.

  [](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Ajax/WebView_StraightTable.htm)
  #### Total Popup

  Total Mode  
  Select one of the options in the drop-down list to decide how the total of the selected expression is to be calculated.   
    
  No Totals  
  No total will be calculated for the expression.   
    
  Expression Totals  
  The expression total will be calculated using all the values of the field. If, e.g., the selected column contains the average salaries for different business categories, choosing the Expression Totals option will result in the average salary for all the business categories.   
    
  Aggregation of Rows  
  The individual values of each data point (each bar in a bar chart, each row in a straight table etc.) for the selected expression will be summed up, aggregated, using the selected aggregation function (typically summed up). Choose an aggregation function in the edit box.
* Accumulate Expression:

  Check this box to accumulate expressions. Click the Engine icon to open the popup.
  * Accumulation Popup: Select one of the options to decide whether the values in the sheet object should be accumulated or not.
    * Accumulate: In an accumulated chart, each y-value is added to the y-value of the following x-value.
    * No Accumulation: The y-values of the selected chart expression will not be accumulated.
    * Full Accumulation: Each y-value accumulating all previous y-values of the expression. Full accumulation does not work if the chart trellis is enabled.
    * Accumulation Steps: Enter a number in the box or drag the slider to set the number of y-values in the expression to be accumulated.
* Attribute Expression Styles:
  * Background Color: Define an attribute expression for calculating the cell background color of the dimension cell. The expression used should return a valid color representation (a number representing the Red, Green and Blue components as defined in Visual Basic) which is typically achieved by using one of the special chart color functions. If the result of the expression is not a valid color representation, black will be used.
  * Text Color: Define an attribute expression for calculating the cell text color of the dimension cell. The expression used should return a valid color representation (a number representing the Red, Green and Blue components as defined in Visual Basic) which is typically achieved by using one of the special chart color functions. If the result of the expression is not a valid color representation, black will be used.
  * Text Format: Define an attribute expression for calculation of the font style of text in the table cell for each dimension cell. The expression used as text format expression should return a string containing a '&lt;B&gt;' for bold text, '&lt;I&gt;' for italic text and/or '&lt;U&gt;' for underlined text.

#### Sort

Sets the sort order of the values in the sheet object. Some sort options may not be available for all sheet objects.   
If more than one sort order is specified, the sort order will be state, expression, frequency, numeric, text, load order. State refers to the logical state (selected, optional, or excluded).

* Primary Sort:
  * Y-Value: Sets whether the dimension values should be sorted according to the numeric value of the y-axis. This option is not available for calculated dimensions.
  * Frequency: Sorts the field values by frequency (number of concurrences in the table).
  * Numeric Value: Sorts the field values by their numeric values.
  * Text: Sorts the field values in alphabetical order.
  * Load Order: Sorts the field values by the initial load order.
* Secondary Sort: Frequency: Sorts the field values by frequency (number of concurrences in the table).   
  Numeric Value: Sorts the field values by their numeric values.  
  Text: Sorts the field values in alphabetical order.  
  Load Order: Sorts the field values by the initial load order.
* Sort by Expression:

[](https://help.qlik.com/en-US/qlikview/Subsystems/Client/Content/QV_QlikView/Ajax/WebView_StraightTable.htm)

#### Sort by Expression

Sorts the field values according to the expression entered.

The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.

Keep Selected on Top: Enable this to keep the selected on top.

* Number Format Tab: Each field has a default number format which can be set in the Document Properties: Number page. It is however possible to use a separate number format for an individual sheet object. This property page applies to the active object and contains the following controls for formatting values:
  * Number Format: Choose a number format from the alternatives below.
  * Default: Both numbers and text. Numbers are shown in original format.
  * Number: Shows numeric values with the number of digits set in the Precision field.
  * Integer: Shows numeric values as integers.
  * Fixed to: Shows numeric values as decimal values with the number of decimal digits set in the Decimals field.
  * Money: Shows values in the format set in the Format Pattern field. The default format is the Windows Currency setting.
  * Date: Shows values that can be interpreted as dates in the format set in the Format Pattern field.
  * Time: Shows values that can be interpreted as time in the format set in the Format Pattern field.
  * Timestamp: Shows values that can be interpreted as date + time in the format set in the Format Pattern field.
  * Interval: Shows time as sequential time increments (e.g. format = mm shows the value as the number of minutes since calendar start (1899:12:30:24:00).
  * Format Pattern: The format code that further specifies the display format of the field. ISO sets the format to the ISO standard. Only valid for Date, Time, Timestamp and Interval. Sys sets the format to the system settings.
  * Precision: The number of digits that will be displayed.
  * Decimals: Sets the number of decimals included.
  * Decimals Separator: Sets the symbol for decimal separators.
  * Thousand Separator: Sets the symbol for thousand separators.
  * In Percent: Shows formatting in percentage instead of absolute numbers. The setting is only available for Number, Integer and Fixed to.
  * Preview: Shows a preview of the number format specified above.

### More.../Less...

Click this button to expand/collapse the foldout that contains additional tabs. Depending on if the Dimensions or Expressions field is active, different tabs are displayed.

## Straight Table Properties: Presentation

This section describes Straight Table properties.

### Allow Interactive Sort

Deselecting this check box will disable the Sort command of the object menu.

### Max Number

Enter a number or drag the slider to set the maximum number of rows to display. Rows displaying sums are not counted; however, sums will still be calculated using all the rows of the table.

### Suppress Header Row

If this check box is marked the table will be shown without header (label) row.

### Sort Indicators

If this check box is selected, a sort indicator icon (arrow) will be shown in the header of the column, which is at the top of the current column sort order. The direction of the icon indicates whether the column is sorted ascending or descending.

### Selection Indicators

Displays selection indicators (beacons) in the table columns containing fields with selections.

### Total Position

Settings for display of totals in the straight table.

### Allow Move Column

Deselect this check box to disable moving columns.

### Background Color

Sets the background to a color, either a solid color or a gradient. Click the Caption color icon to choose the color.

### Background Image

Sets an image as background. Click the Add image icon to browse for an image. Click the Settings icon to open the Image popup.

#### Image Popup

* No Stretch: Displays the image without stretching. This may cause parts of the picture to be invisible or only part of the object to be filled.
* Fill: The image is stretched to fit the object area without keeping the aspect ratio of the image.
* Keep Aspect: The image is stretched as far as possible to fill the object area while keeping the aspect ratio.
* Fill with Aspect: The image is stretched to fill the object area in both directions while keeping the aspect ratio.
* Horizontal: Left, Centered or Right alignment.
* Vertical: Top, Centered or Bottom alignment.
* Transparency: Set the level of transparency by entering a value or by dragging the slider. At 100% the background will be completely transparent.

### More.../Less...

Click this button to expand/collapse the foldout that contains additional tabs.

#### General

* Style: Choose an appropriate style from the drop-down list.
* Stripes Every: Specify if and how long intervals in rows, shaded stripes should appear.
* Cell Borders: Click the Engine icon to open the popup.
  * Cell Border Settings Popup:
    * Vertical Dimension Cell Borders: If this check box is deselected all vertical cell borders in dimension cells of the current style will be removed.
    * Vertical Expression Cell Borders: If this check box is deselected all vertical cell borders in expression cells of the current style will be removed.
    * Border Above Spacing: If this check box is marked dimension spacing rows will be preceded by the same horizontal borders as those below. Furthermore all vertical borders will be removed within the spacing area.
* Suppress Zero-Values: If this check box is marked, all combinations of the dimension fields returning zero or null from all expressions will be disregarded in the calculation. This option is selected by default.
* Suppress Missing: If this check box is marked, all combinations of the dimension fields associated with only null values in all fields in all expressions will be disregarded in the calculation. This option is selected by default. Turning it off can be useful only in special cases, e.g. if null values is to be counted in a chart.
* Horizontal Label: Mark this checkbox to display the straight table transposed 90 degrees, so that labels from a left column and each table record becomes a column of data. Some clients may not handle this setting!
* Vertical Labels: Displays the column titles vertically.
* Null Symbol: The symbol entered here will be used for displaying NULL values in the table.
* Missing Symbol: The symbol entered here will be used for displaying missing values in the table.
* Wrap Header: The contents of the header will be wrapped in two or more lines.
* Wrap Cell Text: If this check box is marked, the contents of the data cells will be wrapped in two or more lines.
* Calculation Conditions: The expression entered here sets a condition to be fulfilled for the chart to be calculated. If the condition is not fulfilled, the text 'Calculation condition unfulfilled' will be displayed in the chart. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.

#### Styles

* Font: To set the font type click the Font icon .
* Caption Font: To set the caption font type click the Font icon.
* Active Caption: To set the background color for the active caption click the Caption color icon. To set the text color click the Font color icon.
* Inactive Caption: To set the background color for the inactive caption click the Caption color icon. To set the text color click the Font color icon.
* Use Border: Mark this check box in order to use a border around the sheet object. Click the Gen CaptionColor to set the color of the border.
* Border Width: Specify a value or drag the slider to set the width of the border. The width is specified in pixels.
* Rounded Corners: Click the Settings icon to open the Rounded Corners popup.

  Information note

  Rounded Corners is only available if you have selected Advanced Styling Mode in Document Properties: General.
  * Rounded Corners Popup: Select Fixed or Relative roundness of the corners, and which corners to be affected. Also select Squareness by entering a value.
* Scroll Bar Width: Specify a value or drag the slider to set the width of the scroll bar. This control affects both the width and the relative size of the scroll bar symbols.

## Straight Table Properties: Caption

This section describes Straight Table properties.

* Label: In the text box you can enter a title to be shown in the caption of the sheet object. If no Label is set, the name of the field will be used if Show Caption is selected.

  The value may be entered as a calculated formula.

  Click the Function icon to open the Edit Expression dialog.

* Show Caption: When this option has been checked a caption will be drawn at the top of the sheet object. List boxes and other "box objects" will have the option switched on by default whereas buttons, text objects and line/arrow objects will not.

* Caption Alignment: Can be Left, Centered, or Right.

* Multi Line Caption (Word Wrap): If this option is checked, the text will be displayed in two or more rows.

* Number of Rows: If multiple lines are allowed for the caption, specify the number of rows in the input field, or drag the slider to the desired number.

* Caption Alignment: Can be Top, Centered, or Bottom.

### More.../Less...

This section describes More.../Less... properties.

#### Icons in caption

* Menu: Opens the object menu.
* Clear: Clears all the current selections in the active sheet object.
* Print: Opens the selected sheet object(s) in tabular format in another browser window. Some clients may not handle this setting!
* Copy Data: Copies the field values in the sheet object. Some clients may not handle this setting!
* Copy Image to Clipboard: Copies the sheet object as an image to the Clipboard. Some clients may not handle this setting!
* Send to Excel: Exports possible (including selected) values to Microsoft Excel, which is automatically launched if not already running. The exported values will appear as one column in a new Excel worksheet. For this functionality to work Microsoft Excel 2007 or later must be installed on the computer. Some clients may not handle this setting!
* Allow Minimize: When this option has been checked a minimize icon will be displayed in the window caption of the sheet object, providing that it is possible to minimize the object. Furthermore, this will make it possible to minimize the object by double-clicking the caption.
* Auto Minimize: This option becomes available when Allow Minimize is checked. When Auto Minimize is checked for several sheet objects on the same sheet, all but one will be automatically minimized at any time. This is useful e.g. for alternately displaying several graphs in the same sheet area.
* Allow Minimize: When this option has been checked a maximize icon will be displayed in the window caption of the sheet object, providing that it is possible to maximize the object. Furthermore, this will make it possible to maximizing the object by double-clicking the caption. If both Allow Minimize and Allow Maximize are checked, double-clicking will effect minimizing of the object.
* Help Text: Here you may enter a help text to be displayed in a pop-up window. This option is not available at document level. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.   
  It is possible to enter e.g. a description of the sheet object. A help icon will be added to the window caption of the object. When the mouse pointer is over the icon, the text will be displayed in a pop-up window.
* Fast Type Change: Here you can enable toggling between chart types. Not available for all objects. Click the Settings icon to open the popup.
* Fast Type Settings Popup: Check the boxes for the chart types you want to toggle between using fast type change.

## Straight Table Properties: Options

### Options

Some options may not be available for all objects.

* Read Only: Makes the chart read only, that is selections cannot be made by clicking or painting with the mouse in the chart.
* Allow Move/Size: If this option has been deselected it will be impossible to move or resize the sheet object.
* Allow Copy/Clone: If this option has been deselected it will be impossible to make a copy of the sheet object. This setting may not be handled by all clients.
* Size Object to Data: Normally the borders around all table sheet objects in QlikView will shrink when selections cause the size of the table to be less than allocated size for the sheet object. By deselecting this check box this automatic adjustment of size will be turned off leaving any surplus space blank.
* Allow Show Info in Caption: When the Info function is in use an info icon will be displayed in the window caption whenever a field value has information associated to it. If you don't want the info icon to be displayed in the caption, you can uncheck this option. Only available for list box, statistics box, multi box and input box.
* Preserve Scroll Position: When marking this check box and the corresponding one in the User Preferences, Objects dialog, QlikView will preserve the vertical scroll position when a selection in table objects has been made.
* Use Show Condition: The sheet object will be shown or hidden depending on a conditional expression which will be evaluated continuously depending on e.g. selections etc. The sheet object will only be hidden when the condition returns false. The value may be entered as a calculated formula. Click the Function icon to open the Edit Expression dialog.
* Normal: Specify the position of the object by setting Left and Top margins, and Width and Height of the object.
* Minimized: Specify the position of the minimized sheet object by setting Left and Top margins, and Width and Height of the minimized object.
* More.../Less...: The following options are available:
  * Owner: Domain and User Id of the owner.

  * Share Object: Enable to share objects with other users. Enabling this selection will enable the settings below.

  * Share with: Choose either Share with everyone or Share by username.

  * Users (Domain\UserID): If Share by username is chosen a list with added users will be shown.

    To add users click the Add icon, a row is added, highlight the row to unlock it and edit the user information. To remove users click the Remove icon after each user to be removed.