Search Object

Search objects can be used for searching for information anywhere in the document.

To create a new Search Object select Layout - New Sheet Object - Search Object in the Main Menu, right-click in the sheet area and select New Sheet Object - Search Object or click on the Create Search Object tool in the toolbar (if the tool has been activated).

By a right-click on a search object the Search Object: Object Menu will be displayed. It can also be accessed from the Object menu, when the search object is the active object.

Object Menu

The search object Object menu is opened by right-clicking the object. The menu commands are:

Properties... Opens the Search Object Properties dialog where a number of parameters can be set.
Notes

Allows creating and sharing notes about the current object.

Notes and Comments

Order

This cascade menu is only available when the Design Grid command of the View menu is activated or when the Always Show Design Menu Items under User Preferences: Design is checked. It contains four commands to set the layout layer of the sheet objects. Valid layer numbers are -128 to 127.

Bring to Front
Sets the layout layer of the sheet object to the largest value currently used by any sheet object on the current sheet.

Send to Back
Sets the layout layer of the sheet object to the smallest value currently used by any sheet object on the current sheet.

Bring Forward
Increases the layout layer of the sheet object by one. Maximum value is 127.

Send Backward
Decreases the layout layer of the sheet object by one. Minimum value is -128.


Copy to Clipboard This cascade menu contains the various copy options for the sheet object.
Image
Copies an image of the sheet object to the clipboard. The image will include or exclude the sheet object caption and border depending on the settings in the User Preferences dialog, Export page.
Object
Copies the entire sheet object to the clipboard for pasting elsewhere in the layout or in another document opened within the current instance of QlikView.
Linked Objects

Opens a menu with the following commands for linked objects.
Adjust Position of Linked Objects
All linked objects on all sheets are adjusted to the same position and size as the one/ones highlighted.
Unlink This Object/Unlink Objects
This destroys the link between the objects, making them different objects with different object IDs.

Minimize Iconizes the object. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if minimizing is allowed in the object's Properties dialog on the Caption page.
Maximize Enlarges the object to fill the sheet. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if maximizing is allowed in the object's Properties dialog on the Caption page.
Restore Restores a minimized or maximized object to its previous size and location. Double-clicking the icon of a minimized object or clicking the icon in the object caption (if shown) of a maximized object produces the same result. This command is available only for minimized or maximized objects.
Help Opens QlikView help.
Remove Removes the sheet object from the sheet.

General

On the General tab you can configure the search options.

All Fields

Mark this radio button to allow the search object to search all fields in the document. By default, system fields are not included in the All Fields option. To include system field, specify the system field name in List of Fields.

List of Fields Mark this radio button and list the fields in the field below to set which fields should be searchable. Use semicolon (;) as separator between fields. The wildcard characters * and ? are allowed in field names. The list may be defined as a calculated formula for dynamic update.
Selected Fields Mark this radio button and choose what fields should be searchable.
Show Fields from Table This drop-down menu shows the value All Tables which contains all fields of the document. By selecting a specific table name in the drop-down menu you may limit the Selected Fields list to only fields from that internal table.
Finally, you may select the value All Tables (Qualified) which will show all fields in the document qualified with their table name. A field will appear one time for each table it appears in.
Default Search Mode Specifies the initial default search mode to be used in text searches. The mode can always be changed on the fly by typing * or ~ as part of the search string. The following alternatives are available:
<use default>
The default as specified under User Preferences will apply.
Use Wildcard Search
The initial search string will be two wildcards with the cursor between them to facilitate a wildcard search.
Use Fuzzy Search
The initial search string will be a tilde (~) to denote a fuzzy search.
Use Normal Search
No additional characters will be added to the search string. Without wildcards, a Normal Search will be made.

Object ID

The unique ID of the current search object. Upon creation, every sheet object is assigned a unique ID for control via Automation. The ID consists of a combination of letters defining the type of object, as well as of a number. The first search object of a document will be assigned the ID SO01. Linked sheet objects share the same object ID. An object ID may be changed to any other string that is currently not used for any other sheet object, sheet or bookmark in the document.
Alternate States Choose one of the available states in the list. The following Alternate States are always available.
Inherited
The sheets and sheet objects are always in the inherited state unless overridden by the QlikView developer. This setting is inherited from the object on the level above, a chart in a sheet gets the same settings as the sheet if inherited is chosen.
Default state
This is the state where most QlikView usage occurs and is represented by $. The QlikView document is always in the default state.

Presentation

Search Result

Include Excluded Mark this check box to include those values in the search that have been excluded by selections.
Highlight Search Substring The search string so far will be highlighted in the matches.
Collapse when result in field exceeds Limit the number of displayed matches in each field.

Visual Style

Appearance Choose between a Rounded and Squared look.
Show Reflection A reflection of the search object will be shown in the layout.
Text in Search Field Enter the text that should be visible in the search object before you enter a search string. By clicking the ... button the full Edit Expression dialog is opened for easier editing of long formulas.

Sort

In Sort Fields by group the sort order of the fields in the search object can be set.

Text Sorts the fields containing search hits in alphabetical order.
Number of Hits Sorts the fields containing search hits according to the number of hits in each field.
As Listed on General Tab Sorts the fields containing search hits according to the order in which the fields are listed on the General tab.

Font

Here the Font, Font style and Size of the font to be used can be set.

The font can be set for any single object (Object Properties: Font), or all objects in a document (Apply to Objects on Document Properties: Font).

Further, the default document fonts for new objects can be set on Document Properties: Font. There are two default fonts:

  1. The first default font (List Boxes, Charts, etc) is used for most objects, including list boxes and charts.
  2. The second default font (Text Objects and Buttons) is used for buttons and text boxes, which are objects that usually need a larger font.

Finally, the default fonts for new documents can be set on User Preferences: Font.

For charts, buttons and text objects (except search objects) a font Color can also be specified. The color may Fixed or it can be dynamically Calculated from an expression. The expression must be a valid color representation, which is created using the color functions. If the result of the expression is not a valid color representation, the font color will default to black.

Color functions

Additional settings are:

Drop Shadow If this option is checked a drop shadow will be added to the text.
Underline If this option is checked the text will be underlined.

A sample of the selected font is shown in the preview pane.

Layout

A Layout setting will apply to the current object only, if it is made from the Object Properties page.
A Layout setting will apply to all objects of the specified type(s) in the document, if it is made from the Document Properties page.

Use Borders

Enable this setting in order to use a border around the sheet object. Specify the type of border by selecting it in the drop-down menu.

Shadow Intensity The Shadow Intensity drop-down menu makes it possible to set the intensity of the shadow that surrounds the sheet objects. There is also the choice of No Shadow.
Border Style The following predefined border types are available:
Solid
A solid unicolored border.
Depressed
Border giving the impression of depressing the sheet object from the background.
Raised
Border giving the impression of raising the sheet object from the background.
Walled
Border giving the impression of a wall around the sheet object.
Border Width This option is available for all border types. The width can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Color Click this button to open a dialog in which an appropriate base color can be chosen from the color palette for all border types.
Rainbow Creates a rainbow colored border for all border types. The rainbow will start with the selected base color on top of the sheet object.

When Simplified is the chosen Styling Mode in Document Properties: General, there is no choice of border type, there is only the Shadow Intensity drop-down menu and the Border Width setting.

Rounded Corners

In the Rounded Corners group the general shape of the sheet object is defined. These settings allow for drawing of sheet objects ranging from perfectly circular/elliptical via super elliptical to rectangular. Rounded Corners is only available if you have selected Advanced Styling Mode in Document Properties: General.

Rounded Corners Checking this option makes the alternatives for rounded corner shapes possible.
Corners Corners for which the check box remains unmarked will be drawn rectangular instead.
Squareness A variable number between 2 and 100 where 100 defines a rectangle with perfectly square corners and 2 corresponds to a perfect ellipse (a circle for a 1:1 aspect ratio). A squareness between 2 and 5 is usually optimal for achieving rounded corners.
Corner Radius This setting determines the radius of the corners in fixed distance (Fixed) or in percent of the total quadrant (Relative (%)). This setting lets you control the extent to which the corners will be affected by the underlying general shape set under Squareness. The distance can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).

Layer

In the Layer group an object can be defined as residing in one of three layers:

Bottom A sheet object with the Bottom layer property can never obscure sheet objects in the Normal and Top layers. It can only be placed on top of other sheet objects in the Bottom layer.
Normal When created, sheet objects reside in the Normal (middle) layer. A sheet object in the Normal layer can never be obscured by sheet objects in the Bottom layer and can never obscure sheet objects in the Top layer.
Top A sheet object in the Top layer can never be obscured by sheet objects in the Normal and Bottom layers. Only other sheet objects in the Top layer can be placed on top of it.
Custom The Top, Normal and Bottom layers correspond to internally numbered layers 1, 0 and -1 respectively. In fact all values between -128 and 127 are accepted. Choose this option to enter a value of your choice.

Theme Maker...

Opens the Theme Maker wizard where you can create a layout theme.

Apply Theme ...

You can apply a layout theme to the object, sheet or document.

Layout Themes

Show

In the Show group it is possible to specify a condition under which the sheet object is displayed:

Always The sheet object will always be displayed.
Conditional

The sheet object will be shown or hidden depending on a conditional function which will be evaluated continuously depending on e.g. selections etc. The sheet object will only be hidden when the condition returns FALSE.

Conditional functions

Note:

Users with Admin privileges for the document can override all show conditions by selecting Show All Sheets and Sheet Objects in Document Properties: Security. This functionality can be toggled by pressing Ctrl+Shift+S.

Document Properties: Security

Options

In the Options group, it is possible to disallow moving and resizing of the sheet object. The settings in this group are only relevant if the corresponding check boxes are enabled in Document Properties: Layout and Sheet Properties: Security.

Allow Move/Size If this option has been deselected it will be impossible to move or resize the sheet object.
Allow Copy/Clone If this option has been deselected it will be impossible to make a copy of the sheet object.
Allow Info

When the info function is in use an info icon will be displayed in the window caption whenever a field value has information associated to it. If you don't want the info icon to be displayed in the caption, you can uncheck this option.

Info

Size to Data Normally the borders around all table sheet objects in QlikView will shrink when selections cause the size of the table to be less than allocated size for the sheet object. By deselecting this check box this automatic adjustment of size will be turned off leaving any surplus space blank.

Scrollbars

Various controls for changing the scrollbar layout are located in the Scrollbars group:

Preserve Scroll Position

With this setting enabled, QlikView will try to preserve the scroll position of tables and charts with a scroll bar when a selection is made in another object. The setting must be enabled in User Preferences: Objects as well.

The scroll position is not preserved when you close the document.

Scroll Buttons Sets the scroll button color. Select a color by clicking the button. Note that medium gray tones often render the best results for scroll bars. Either color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the appropriate button.
Scroll Background

Sets the scrollbar background color. Select a color by clicking the button.

Scrollbar Width This control affects both the width and the relative size of the scrollbar symbols.
Scroll Style

Sets the scroll bar style. Select a style in the drop-down control. The Classic scroll bar style corresponds to QlikView 4/5 scroll bars. The Standard scroll bar style gives a more modern look. The third style is Light, which is a thinner, lighter bar.

The Styling Mode must be set to Advanced for the scroll bar style to be visible. This setting can be found on the General tab by opening the Settings drop-down menu and selecting Document Properties.

Apply To... Opens the Caption and Border Properties dialog where you can set where to apply the properties that have been set on the Layout page.

Caption

A Caption setting will apply to the current object only, if it is made from the Object Properties page.
A Caption setting will apply to all objects of the specified type(s) in the document, if it is made from the Document Properties page.

On the Caption page, specify layout options that are completely different from the general layout of the object.

Show Caption When this option has been checked a caption will be drawn at the top of the sheet object. List boxes and other "box objects" will have the option switched on by default whereas buttons, text objects and line/arrow objects will not.
Title Text In the text box you can enter a title to be shown in the caption of the sheet object. Use the Font... button to change the caption font.

Set the colors of the caption in its different states. The settings for Active Colors and Inactive Colors can be made separately from each other.

Click the Background Color or Text Color button to open the Color Area dialog. The Background Color can be defined as a solid or a gradient color on the Color Area dialog. Text Color can be defined a Fixed or a Calculated color using color functions.

Color functions

Wrap Text If this option is checked, the caption will be displayed in two or more rows.
Caption Height (Lines) Set the number of caption lines in this edit box.

The precise size and position of the QlikView object can be determined and adjusted by the size/position settings for the Normal or Minimized QlikView sheet object. These settings are measured in pixels:

X-pos Sets the horizontal position of the left side of sheet object in relation to the sheet's left edge.
Y-pos Sets the vertical position of the top side of sheet object in relation to the sheet's upper edge.
Width Sets the width of the QlikView sheet object.
Height Sets the height of the QlikView sheet object.

The orientation of the caption label can be altered with the Caption Alignment options:

Horizontal The label can be horizontally aligned: Left, Centered or Right within the caption area.
Vertical The label can be vertically aligned: Top, Centered or Bottom within the caption area.

Special Icons
Many of the object menu commands of the sheet objects can be configured as caption icons. Select commands to be shown as caption icons by marking the check box to the left of each command in the list.

Note: Use the special caption icons with care. Too many icons will only confuse the user.
Allow Minimize When this option has been checked a minimize icon will be displayed in the window caption of the sheet object, providing that the object is minimizable. Furthermore, this will make it possible to minimize the object by double-clicking the caption.
Auto Minimize This option becomes available when Allow Minimize is checked. When Auto Minimize is checked for several sheet objects on the same sheet, all but one will be automatically minimized at any time. This is useful e.g. for alternately displaying several graphs in the same sheet area.
Allow Maximize When this option has been checked a maximize icon will be displayed in the window caption of the sheet object, providing that the object is maximizable. Furthermore, this will make it possible to maximizing the object by double-clicking the caption. If both Allow Minimize and Allow Maximize are checked, double-clicking will effect minimizing of the object.
Help Text

Here you may enter a help text to be displayed in a pop-up window. The help text may be specified as a calculated formula. This option is not available at document level. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

Expression syntax for calculated formulas

Enter e.g. a description of the sheet object. A help icon will be added to the window caption of the object. When the mouse pointer is over the icon, the text will be displayed in a pop-up window.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?