Inline Data Wizard

The Inline Data Wizard dialog is opened from the Insert menu, Load Statement, Load Inline. It is used to create load inline statements in the script.

The dialog contains something looking like a spreadsheet and in fact works like one in most respects. Note however that calculation formulas will not be evaluated in this spreadsheet as they would e.g. in Microsoft Excel.

Each column represents a field to be loaded into QlikView by means of an inline table. Each row is a record in the table. A data cell is selected by clicking it. A value may then be typed or pasted in from clipboard. Press Enter or an arrow key to accept the value and move to another cell.

The top (label) row is reserved for field labels. Double-click in a label cell to edit it. If no values are entered in the label row the field names F1, F2 etc will be used.

Edit Menu

The Edit menu contains some basic editing commands.

Insert Column Inserts a new blank column if one or more columns are selected.
Delete Column Deletes the selected column(s).
Insert Row Inserts a new blank row if one or more rows are selected.
Delete Row Deletes the selected rows.

Tools Menu

The Tools menu contains the command Document Data that opens the Import Document Data Wizard from which it is possible to paste field values from any existing field in the document. In the dialog it is possible to see how many field values are present in any selected field. It is also possible to choose to insert all values, selected values or excluded values into the inline wizard.

Click OK to close the dialog and generate a Load inline statement reflecting the contents of the dialog's table grid.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?