QlikWorld 2020 Global Conference. Join us to discover how to get the most from your data. Act fast. Register now and save.

Button

Buttons can be created and defined in QlikView to perform commands or actions. There are basically three types of buttons; the Launch/Export Button, the Shortcut Button and the Macro button.

By right-clicking the object, the Button: Object Menu will be displayed. It can also be accessed from the Object menu, when the button is the active object.

Object Menu

The button Object menu is opened by right-clicking the object. The menu commands are:

Properties... Opens the Button Properties dialog where a number of parameters can be set.
Notes

Allows creating and sharing notes about the current object.

Notes and Comments

Order

This cascade menu is only available when the Design Grid command of the View menu is activated or when the Always Show Design Menu Items under User Preferences: Design is checked. It contains four commands to set the layout layer of the sheet objects. Valid layer numbers are -128 to 127.

Bring to Front
Sets the layout layer of the sheet object to the largest value currently used by any sheet object on the current sheet.

Send to Back
Sets the layout layer of the sheet object to the smallest value currently used by any sheet object on the current sheet.

Bring Forward
Increases the layout layer of the sheet object by one. Maximum value is 127.

Send Backward
Decreases the layout layer of the sheet object by one. Minimum value is -128.


Send to Excel Exports the text to Microsoft Excel, which is automatically launched if not already running. The text will appear in a single cell in a new Excel worksheet. For this functionality to work Microsoft Excel 2007 or later must be installed on the computer.
Copy to Clipboard This cascade menu contains the various copy options for the sheet object.
Text
Copies the text displayed on the button to the clipboard.
Image
Copies an image of the sheet object to the clipboard. The image will include or exclude the sheet object caption and border depending on the settings in the User Preferences dialog, Export page.
Object
Copies the entire sheet object to the clipboard for pasting elsewhere in the layout or in another document opened within the current instance of QlikView.
Linked Objects

Opens a menu with the following commands for linked objects.
Adjust Position of Linked Objects
All linked objects on all sheets are adjusted to the same position and size as the one/ones highlighted.
Unlink This Object/Unlink Objects
This destroys the link between the objects, making them different objects with different object IDs.

Minimize Iconizes the object. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if minimizing is allowed in the object's Properties dialog on the Caption page.
Maximize Enlarges the object to fill the sheet. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if maximizing is allowed in the object's Properties dialog on the Caption page.
Restore Restores a minimized or maximized object to its previous size and location. Double-clicking the icon of a minimized object or clicking the icon in the object caption (if shown) of a maximized object produces the same result. This command is available only for minimized or maximized objects.
Help Opens QlikView help.
Remove Removes the sheet object from the sheet.

General

In the Text group you can set the properties of the text to be displayed on the button.

Text

Entering a text in the text field labels the button. The text may be defined as a calculated formula. The text may consist of several lines, divided when you press Enter.

Expression syntax for calculated formulas

Alignment The button text can be left-aligned, centered or right-aligned.

In the Background group you can specify the background of the button. The drop-down gives you three different basic button styles to choose from:

Aqua Default for new buttons. Gives a rounded button with three-dimensional glassy look.
Plain Produces a traditional plain QlikView button.
System Default
Provides a solid background in the color defined for buttons in the operating system.
Image Produces an image button. The image could be either a single static image or a combined image with three parts, one for each of the button’s three possible states (active, inactive or depressed).
Combined Image
Mark this radio button and browse to an image file using the Select Image... button in order to assign a three-state combined image to the button. The image file must consist of three images, side by side, of the button: the first one of an active button, the second of a depressed button and the third one of a dimmed (inactive) button.
Single Image
Mark this radio button and browse to an image file using the Select Image... button in order to assign a single-state image to the button. Image types supported include jpg, png, bmp, gif and animated gif.
Color Select this radio button if you want the button to be displayed with a colored background (not available with the Image setting). The color can be defined as a solid color or as a gradient via the Color Area dialog that opens when clicking the color button.
Transparency Sets the degree of transparency of the button background. At 100% the background will be completely transparent. The transparency will apply regardless if a color or an image is used for background.
Alternate State Choose one of the available states in the list. The following Alternate States are always available.
Inherited
The sheets and sheet objects are always in the inherited state unless overridden by the QlikView developer. This setting is inherited from the object on the level above, a chart in a sheet gets the same settings as the sheet if inherited is chosen.
Default state
This is the state where most QlikView usage occurs and is represented by $. The QlikView document is always in the default state.
Object ID The unique ID of the current button. Upon creation, every sheet object is assigned a unique ID for control via Automation. The ID consists of a combination of letters defining the type of object, as well as of a number. The first button of an document will be assigned the ID BU01. Shared objects share the same object ID. An object ID may be changed to any other string that is currently not used for any other sheet object, sheet or bookmark in the document.
Enable Condition The expression entered here determines the status of the button. If the expression returns 0, the button will be disabled; if the expression returns 1, the button will be enabled. If no expression is entered, 1 is assumed. Buttons that are disabled due to underlying status cannot be enabled by means of a condition.
Print Settings... By pressing this button you will gain access to the Print Settings dialog where margins and header/footer format can be defined.

Actions

On this page actions can be set for certain objects:

  • buttons
  • text objects
  • gauges
  • line/arrow objects

Actions include launching an external application or exporting data from QlikView.

Add Opens the Add Action dialog where the actions for the object are chosen. Choose the type of action in the lists. Depending on the action, different parameters for the action will appear on the Actions page.
Input parameters for listed actions are calculated before the first action is executed. If a parameter is changed after the execution has started (for example if an action is changed by a previous action), the change is not registered in the chain of actions.
Delete Removes the action from the object.
Promote Moves the selected action up in the list of actions.
Alternate State Sets the state that the action refers to. This setting is only relevant for actions related to selections or bookmarks.

Add Action dialog

The following actions can be added from the Add Action dialog. In all fields with the ... button it is possible to enter a calculated formula.

Expression syntax for calculated formulas

Selection

Select in Field Selects the values and fields that are specified. In the Search String you can specify a search mask, e.g. (A|B) will select both A and B. Quoting is only required with non-numeric values and can be omitted with numeric values.
Select Excluded Selects the excluded values in the specified field.
Select Possible Selects the possible values in the specified field.
Toggle Select Toggles between the current selection and the specified Field and Search String. In the Search String you can specify a search mask, e.g. (A|B) will select both A and B.
Forward Goes one step forward in the list of selections.
Back Goes back one step in the list of selections.
Pareto Select Makes a pareto selection in the specified field based on an expression and percentage. This type of selection is used to select the top contributors to a measure, typically in line of a general 80/20 rule. For example, to find the top customers that contribute to 80% of the turnover, Customer should be used as field, sum(Turnover) should be used as expression and 80 should be used as percentage.
Lock Field Locks the selections in the specified field.
Lock All Locks all values in all fields.
Unlock Field Unlocks the selections in the specified field.
Unlock All Unlocks all values in all fields.
Unlock and Clear All Unlocks all values and clears all selections in all fields.
Clear Other Fields Clears all related fields except the one specified.
Clear All Clears all selections except locked ones.
Clear Field Clears a specific field.
Copy State Contents Copies the selection from the Source State to the Target State. Only available when alternate states have been defined.
Swap State Contents Swaps the selections between State 1 and State 2. Only available when alternate states have been defined.

Layout

Activate Object Activates the object specified by Object ID. This function does not work in Ajax client.
Activate Sheet Activates the sheet specified by Sheet ID.
Activate Next Sheet Opens the next sheet in the document.
Activate Previous Sheet Opens the previous sheet in the document.
Minimize Object Minimizes the object specified by Object ID.
Maximize Object Maximizes the object specified by Object ID.
Restore Object Restores the object specified by Object ID.
Set State Name Applies the specified State to the object specified by Object ID. Only available when having defined alternate states.

Bookmark

Apply Bookmark

Applies a bookmark specified by Bookmark ID. If two bookmarks have the same ID, the document bookmark is applied. To apply the server bookmark specify Server\bookmarkID. 

Create Bookmark

Creates a bookmark from the current selection. Specify Bookmark ID and Bookmark Name. Select Hidden to create a hidden bookmark.

Replace Bookmark

Replaces the bookmark specified by Bookmark ID with the current selection.

Print

Print Object

Prints the object specified by Object ID. Specify the Printer name if the object should be sent to another printer than the default printer. (Not available as document and sheet trigger.)

Print Sheet

Prints the sheet specified by Sheet ID. (Not available as document and sheet trigger.) This function does not work in AJAX client.

Print Report

Prints the report specified by Report ID. Specify the Printer name if the report should be sent to another printer than the default printer. Mark the check box Show Print Dialog if you want the Windows print dialog to be shown. (Not available as document and sheet trigger.)

External

Export

Exports a table containing a specific set of fields, but only those records that are applicable according to the made selection are exported. Click on the Setup button on the Actions page to open the Export Action Settings dialog. (not available as document and sheet trigger)

Launch

Launches an external program. The following settings can be configured in the Actions dialog:
Application
Click on Browse... to find the application that should be launched. (Not available as document and sheet trigger.)
Filename
Enter the path to the file that should be opened with the application specified above. (Not available as document and sheet trigger.)
Parameters
Specify parameters for the command line from which the application is started. (Not available as document and sheet trigger.)
Working Directory
Sets the working directory for the application to be launched. (Not available as document and sheet trigger.)
Exit application when QlikView is closed
Forces the application to be closed when QlikView is exited. (Not available as document and sheet trigger.)
This function does not work in AJAX client.

Open URL

You can use Open URL to open a URL to a QlikView document from within another QlikView document (document chaining). This setting opens the URL in the default web browser. This function cannot be used as a document and sheet trigger. If using Open URL, make sure to enter the document name in the action-string in lower case.

Where possible, use Open QlikView Document instead of Open URL.

Open QlikView Document

You can use Open QlikView Document to open a QlikView document from within another QlikView document (document chaining). The extension of the destination file must be included. This function cannot be used as a document and sheet trigger. Relative paths to navigate from one QlikView document to another are supported in all clients as long as the chained documents are stored in the same folder structure (mount).

Examples

The following examples show how to write the file path to the destination file to setup the document chaining using Open QlikView Document.

Example: File located in the same folder structure (same mount).

  • If the destination file is in the same folder:
    DestinationDoc.qvw
  • If the destination file is in a sub folder:
    SubFolder/DestinationDoc.qvw
  • If the destination file is in an upper folder:
    ../DestinationDoc.qvw
  • If the destination file is in an upper and parallel folder:
    ../ParallelFolder/DestinationDoc.qvw

Example: File located in a different folder structure (different mount).

The relative path between different mounts is supported in the Ajax client only.

  • If the destination file is in a different mount:
    ../DifferentMount/DestinationDoc.qvw

Example: Using the mount path to point to a QlikView document

Setting the path to mounted folders is supported in the Ajax client only.

  • If the destination file is in the same mounted folder:
    \Mount\DestinationDoc.qvw
  • If the destination file is in a different mounted folder:
    \DifferentMount\DestinationDoc.qvw
Note: The doc chaining with mounted folders does not work with the Internet Explorer (IE) plug-in.

Example: Using the absolute path to point to a QlikView document

The use of absolute paths for document chaining is supported in the Ajax client and in QlikView Desktop.

  • Absolute path to the Local Root folder or mount:
    C:\...\DestinationDoc.qvw
  • Absolute path to a Network Share:
    \\SharedStorage\...\DestinationDoc.qvw

Select Transfer State to transfer the selections from the original document to the destination document. The destination document will first be cleared of selections.
Select Apply state on top of current to retain the destination document’s selections and apply the original document’s selections on top of them.

Note: Using Apply state on top of current can return unexpected results if the selections made in the two documents are conflicting.

Select Open in same Window to open the new document in the same browser tab when using the AJAX ZFC client.

Note: Open QlikView Document action is not supported for non domain users when using the Internet Explorer (IE) plug-in.

Run Macro

Enter the path and name of the macro to be run. Type any name for which it is possible to later create a macro in the Edit Module dialog, or a calculated expression for dynamic update.

Set Variable

Assigns a value to the specified variable.

Show Information

Shows the associated information, such as a text file or an image for the field specified by Field. This function does not work in AJAX client.

Close This Document

Closes the active QlikView document.

Reload

Performs a reload on the current document. This function does not work both in AJAX client and IE-plugin.

Dynamic Update

Performs a dynamic update of the data in the currently loaded document. The statement for the dynamic update is to be entered in the Statement field.

The intended usage of Dynamic Update allows a QlikView Administrator to feed limited amounts of data in to a QlikView document from a single source without running a reload of the document. Analysis can then be performed by multiple clients connecting to the QlikView Server.

Note! The uploaded information is stored in RAM only so any data added or updated using Dynamic Update will be lost if a reload of the document is performed.

The following grammar describes the possible statements and their components that can be used with the Dynamic Update feature:

  • statements ::= statement { “;” statement }
  • statement ::= insert_statement | update_statement | delete_statement | begin_transaction_statement | commit_transaction_statement
  • insert_statement ::= "INSERT" "INTO" ("*" | table_name) field_list "VALUES" value_list {"," value_list} ["KEY" ["AUTO" | (" (" field_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
  • update_statement ::= "UPDATE" ("*" | table_name) set_clause {"," | set_clause} "WHERE" condition ["AUTO" "INSERT"]
  • delete_statement ::= "DELETE" "FROM" ("*" | table_name] "WHERE" condition
  • begin_transaction_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans_name]
  • commit_transaction_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans_name]
  • table_name ::= identifier | quoted_name
  • field_list ::= "(" field_name {"," field_name} ")"
  • value_list ::= "("value {"," value} ")"
  • set_clause ::= "SET" field_name "=" any_valid_non_aggregated_qlikview_expression
  • field_name ::= identifier | quoted string
  • value ::= identifier | any_qlikview_number | quoted string
  • condition ::= any_valid_non_aggregated_qlikview_expression
  • identifier ::= any_qlikview_identifier
  • quoted_string ::= "[" [^]]+ "]"

Example:  

UPDATE AbcTable SET Discount = 123 WHERE AbcField=1

Note: To use this feature, Dynamic Update must be allowed both on the Document and on the Server.
Note: Actions that trigger other actions, so called cascading actions, may cause unforeseen consequences and are not supported!
Note:

There are limitations as to the behavior of certain macro triggers when working with documents on QlikView Server.

Using Macros in QV Documents on the QV-Server

Export Action Settings Dialog

Selection

In this group you set what fields should be selected for export.

Fields In the fields box you find a list of the available fields.
Export Lines In this box you find the fields you have selected for export. The fields for which you have allowed multiple values are marked with an asterisk.
Add > Adds fields to the Export Lines box.
< Remove Removes fields from the Export Lines box.
Promote Moves the selected field one step up, i.e. one step to the left in the export table.
Demote Moves the selected field one step down, i.e. one step to the right in the export table.
Multi Value (*) By marking a field in the Export Lines box and checking this control, you allow a field to have several values in the export listing.

Export to

In this group you can choose whether you want to export the values to a file or to the clipboard.

File

If you export to a file you must mark this check box and enter the file name. If no file name is entered, the values will be exported to the clipboard. The file name may be entered as a calculated formula.

Expression syntax for calculated formulas

Browse Opens the Export File dialog, allowing you to browse for a file to which the values should be exported.
Clipboard Default setting. If no file is specified above, the values will be exported to the clipboard.
Field Selections If this control is checked, the export file will, for each selected field, have all the possible field values on one row, separated by tabs.
Include Labels If this control is checked, the first position on the line (when Field Selections is set) or the first record (when Records is set) will contain the field names.
Records If this control is checked, the export file will have one column for each selected field, separated by tabs.
Append to Existing File If this control is checked the export will be appended to the export file, if the file already exists. Labels will not be exported when appending to an existing file. If the export file does not exist, this flag has no meaning.

Number Formatting

Some other programs may have difficulties to handle numbers with number format correctly. QlikView offers three options for number formatting of numeric data to be exported to files or to the clipboard.

New export buttons will inherit the default setting from the User Preferences: Export page. The setting can however be individually set for each export button.

Full Format Instructs QlikView to export numeric data with its full number format, just as it is shown in the document’s sheet objects.
No Thousand Separator Removes any thousand separator from numeric data.
No Formatting Removes all number formatting from the data and exports the raw numbers. The decimal separator will be as defined in the system settings (Control Panel).
Note:

There are limitations as to the behavior of certain macro triggers when working with documents on QlikView Server.

Using Macros in QV Documents on the QV-Server

Font

Here the Font, Font style and Size of the font to be used can be set.

The font can be set for any single object (Object Properties: Font), or all objects in a document (Apply to Objects on Document Properties: Font).

Further, the default document fonts for new objects can be set on Document Properties: Font. There are two default fonts:

  1. The first default font (List Boxes, Charts, etc) is used for most objects, including list boxes and charts.
  2. The second default font (Text Objects and Buttons) is used for buttons and text boxes, which are objects that usually need a larger font.

Finally, the default fonts for new documents can be set on User Preferences: Font.

For charts, buttons and text objects (except search objects) a font Color can also be specified. The color may Fixed or it can be dynamically Calculated from an expression. The expression must be a valid color representation, which is created using the color functions. If the result of the expression is not a valid color representation, the font color will default to black.

Color functions

Additional settings are:

Drop Shadow If this option is checked a drop shadow will be added to the text.
Underline If this option is checked the text will be underlined.

A sample of the selected font is shown in the preview pane.

Layout

A Layout setting will apply to the current object only, if it is made from the Object Properties page.
A Layout setting will apply to all objects of the specified type(s) in the document, if it is made from the Document Properties page.

Use Borders

Enable this setting in order to use a border around the sheet object. Specify the type of border by selecting it in the drop-down menu.

Shadow Intensity The Shadow Intensity drop-down menu makes it possible to set the intensity of the shadow that surrounds the sheet objects. There is also the choice of No Shadow.
Border Style The following predefined border types are available:
Solid
A solid unicolored border.
Depressed
Border giving the impression of depressing the sheet object from the background.
Raised
Border giving the impression of raising the sheet object from the background.
Walled
Border giving the impression of a wall around the sheet object.
Border Width This option is available for all border types. The width can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Color Click this button to open a dialog in which an appropriate base color can be chosen from the color palette for all border types.
Rainbow Creates a rainbow colored border for all border types. The rainbow will start with the selected base color on top of the sheet object.

When Simplified is the chosen Styling Mode in Document Properties: General, there is no choice of border type, there is only the Shadow Intensity drop-down menu and the Border Width setting.

Rounded Corners

In the Rounded Corners group the general shape of the sheet object is defined. These settings allow for drawing of sheet objects ranging from perfectly circular/elliptical via super elliptical to rectangular. Rounded Corners is only available if you have selected Advanced Styling Mode in Document Properties: General.

Rounded Corners Checking this option makes the alternatives for rounded corner shapes possible.
Corners Corners for which the check box remains unmarked will be drawn rectangular instead.
Squareness A variable number between 2 and 100 where 100 defines a rectangle with perfectly square corners and 2 corresponds to a perfect ellipse (a circle for a 1:1 aspect ratio). A squareness between 2 and 5 is usually optimal for achieving rounded corners.
Corner Radius This setting determines the radius of the corners in fixed distance (Fixed) or in percent of the total quadrant (Relative (%)). This setting lets you control the extent to which the corners will be affected by the underlying general shape set under Squareness. The distance can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).

Layer

In the Layer group an object can be defined as residing in one of three layers:

Bottom A sheet object with the Bottom layer property can never obscure sheet objects in the Normal and Top layers. It can only be placed on top of other sheet objects in the Bottom layer.
Normal When created, sheet objects reside in the Normal (middle) layer. A sheet object in the Normal layer can never be obscured by sheet objects in the Bottom layer and can never obscure sheet objects in the Top layer.
Top A sheet object in the Top layer can never be obscured by sheet objects in the Normal and Bottom layers. Only other sheet objects in the Top layer can be placed on top of it.
Custom The Top, Normal and Bottom layers correspond to internally numbered layers 1, 0 and -1 respectively. In fact all values between -128 and 127 are accepted. Choose this option to enter a value of your choice.

Theme Maker...

Opens the Theme Maker wizard where you can create a layout theme.

Apply Theme ...

You can apply a layout theme to the object, sheet or document.

Layout Themes

Show

In the Show group it is possible to specify a condition under which the sheet object is displayed:

Always The sheet object will always be displayed.
Conditional

The sheet object will be shown or hidden depending on a conditional function which will be evaluated continuously depending on e.g. selections etc. The sheet object will only be hidden when the condition returns FALSE.

Conditional functions

Note:

Users with Admin privileges for the document can override all show conditions by selecting Show All Sheets and Sheet Objects in Document Properties: Security. This functionality can be toggled by pressing Ctrl+Shift+S.

Document Properties: Security

Options

In the Options group, it is possible to disallow moving and resizing of the sheet object. The settings in this group are only relevant if the corresponding check boxes are enabled in Document Properties: Layout and Sheet Properties: Security.

Allow Move/Size If this option has been deselected it will be impossible to move or resize the sheet object.
Allow Copy/Clone If this option has been deselected it will be impossible to make a copy of the sheet object.
Allow Info

When the info function is in use an info icon will be displayed in the window caption whenever a field value has information associated to it. If you don't want the info icon to be displayed in the caption, you can uncheck this option.

Info

Size to Data Normally the borders around all table sheet objects in QlikView will shrink when selections cause the size of the table to be less than allocated size for the sheet object. By deselecting this check box this automatic adjustment of size will be turned off leaving any surplus space blank.

Scrollbars

Various controls for changing the scrollbar layout are located in the Scrollbars group:

Preserve Scroll Position

With this setting enabled, QlikView will try to preserve the scroll position of tables and charts with a scroll bar when a selection is made in another object. The setting must be enabled in User Preferences: Objects as well.

The scroll position is not preserved when you close the document.

Scroll Buttons Sets the scroll button color. Select a color by clicking the button. Note that medium gray tones often render the best results for scroll bars. Either color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the appropriate button.
Scroll Background

Sets the scrollbar background color. Select a color by clicking the button.

Scrollbar Width This control affects both the width and the relative size of the scrollbar symbols.
Scroll Style

Sets the scroll bar style. Select a style in the drop-down control. The Classic scroll bar style corresponds to QlikView 4/5 scroll bars. The Standard scroll bar style gives a more modern look. The third style is Light, which is a thinner, lighter bar.

The Styling Mode must be set to Advanced for the scroll bar style to be visible. This setting can be found on the General tab by opening the Settings drop-down menu and selecting Document Properties.

Apply To... Opens the Caption and Border Properties dialog where you can set where to apply the properties that have been set on the Layout page.

Caption

A Caption setting will apply to the current object only, if it is made from the Object Properties page.
A Caption setting will apply to all objects of the specified type(s) in the document, if it is made from the Document Properties page.

On the Caption page, specify layout options that are completely different from the general layout of the object.

Show Caption When this option has been checked a caption will be drawn at the top of the sheet object. List boxes and other "box objects" will have the option switched on by default whereas buttons, text objects and line/arrow objects will not.
Title Text In the text box you can enter a title to be shown in the caption of the sheet object. Use the Font... button to change the caption font.

Set the colors of the caption in its different states. The settings for Active Colors and Inactive Colors can be made separately from each other.

Click the Background Color or Text Color button to open the Color Area dialog. The Background Color can be defined as a solid or a gradient color on the Color Area dialog. Text Color can be defined a Fixed or a Calculated color using color functions.

Color functions

Wrap Text If this option is checked, the caption will be displayed in two or more rows.
Caption Height (Lines) Set the number of caption lines in this edit box.

The precise size and position of the QlikView object can be determined and adjusted by the size/position settings for the Normal or Minimized QlikView sheet object. These settings are measured in pixels:

X-pos Sets the horizontal position of the left side of sheet object in relation to the sheet's left edge.
Y-pos Sets the vertical position of the top side of sheet object in relation to the sheet's upper edge.
Width Sets the width of the QlikView sheet object.
Height Sets the height of the QlikView sheet object.

The orientation of the caption label can be altered with the Caption Alignment options:

Horizontal The label can be horizontally aligned: Left, Centered or Right within the caption area.
Vertical The label can be vertically aligned: Top, Centered or Bottom within the caption area.

Special Icons
Many of the object menu commands of the sheet objects can be configured as caption icons. Select commands to be shown as caption icons by marking the check box to the left of each command in the list.

Note: Use the special caption icons with care. Too many icons will only confuse the user.
Allow Minimize When this option has been checked a minimize icon will be displayed in the window caption of the sheet object, providing that the object is minimizable. Furthermore, this will make it possible to minimize the object by double-clicking the caption.
Auto Minimize This option becomes available when Allow Minimize is checked. When Auto Minimize is checked for several sheet objects on the same sheet, all but one will be automatically minimized at any time. This is useful e.g. for alternately displaying several graphs in the same sheet area.
Allow Maximize When this option has been checked a maximize icon will be displayed in the window caption of the sheet object, providing that the object is maximizable. Furthermore, this will make it possible to maximizing the object by double-clicking the caption. If both Allow Minimize and Allow Maximize are checked, double-clicking will effect minimizing of the object.
Help Text

Here you may enter a help text to be displayed in a pop-up window. The help text may be specified as a calculated formula. This option is not available at document level. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

Expression syntax for calculated formulas

Enter e.g. a description of the sheet object. A help icon will be added to the window caption of the object. When the mouse pointer is over the icon, the text will be displayed in a pop-up window.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?