Statistics Box

The statistics box is a compact way of showing a numeric field in which the separate records are of less interest than e.g. their sum or average. A selection of statistical functions are available. When no specific range of values is selected QlikView treats all the values listed in the corresponding field list box (option values) as the sample.

The default name of the box is the same as that of the field to which the selected values belong.

Right-click on the statistics box to display the Object menu.

Object Menu

The statistics box Object menu is opened by right-clicking the object. The menu commands are:

Properties... Opens the Statistics Box Properties dialog where a number of parameters can be set.
Notes

Allows creating and sharing notes about the current object.

See: Notes and Comments

Order

This cascade menu is only available when the Design Grid command of the View menu is activated or when the Always Show Design Menu Items under User Preferences: Design is checked. It contains four commands to set the layout layer of the sheet objects. Valid layer numbers are -128 to 127.

Bring to Front
Sets the layout layer of the sheet object to the largest value currently used by any sheet object on the current sheet.

Send to Back
Sets the layout layer of the sheet object to the smallest value currently used by any sheet object on the current sheet.

Bring Forward
Increases the layout layer of the sheet object by one. Maximum value is 127.

Send Backward
Decreases the layout layer of the sheet object by one. Minimum value is -128.


Select Possible All non-excluded values in the corresponding list box are selected.
Select Excluded All excluded values in the corresponding list box are selected.
Select All All values in the corresponding list box are selected.
Clear Clears all the current selections in the corresponding list box.
Clear Other Fields Clears the selections in all the other sheet objects, while maintaining the ones in the corresponding list box.
Lock Locks the selected value(s) in the corresponding list box.
Unlock Unlocks the locked value(s) in the corresponding list box.
Print...

Opens the Print dialog to let you print the contents of the statistics box.

See: Print: General

Print as PDF...

Opens the Print dialog with the PDF-XChange 3.0 printer pre-selected. After pressing the Print button you will be prompted for a file name for the PDF output file. This command is only available if a PDF printer is available on the system.

Send to Excel Exports possible (including selected) values to Microsoft Excel, which is automatically launched if not already running. QlikView exports in BIFF (native Excel format) format. The exported values will appear in a new Excel worksheet. For this functionality to work Microsoft Excel 97 or later must be installed on the computer.
Export... Opens the Save as dialog where path, file name and (table) file type for the exported data content can be specified.
Copy to Clipboard This cascade menu contains the various copy options for the sheet object.
Data
Copies the data rows of the statistics box to the clipboard.
Cell Value
Copies the text value of the statistics box cell right-clicked upon (when invoking the Object menu) to the clipboard.
Image
Copies an image of the sheet object to the clipboard. The image will include or exclude the sheet object caption and border depending on the settings in the User Preferences: Export page.
Object
Copies the entire sheet object to the clipboard for pasting elsewhere in the layout or in another document opened within the current instance of QlikView.
Linked Objects

Opens a menu with the following commands for linked objects.
Adjust Position of Linked Objects
All linked objects on all sheets are adjusted to the same position and size as the one/ones highlighted.
Unlink This Object/Unlink Objects
This destroys the link between the objects, making them different objects with different object IDs.

Minimize Iconizes the object. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if minimizing is allowed in the object's Properties dialog on the Caption page.
Maximize Enlarges the object to fill the sheet. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if maximizing is allowed in the object's Properties dialog on the Caption page.
Restore Restores a minimized or maximized object to its previous size and location. Double-clicking the icon of a minimized object or clicking the icon in the object caption (if shown) of a maximized object produces the same result. This command is available only for minimized or maximized objects.
Help Opens QlikView help.
Remove Removes the sheet object from the sheet.

General

The General property page is opened by selecting Statistics Box from New Sheet Object in the View menu, or by a right-click on a statistics box and choosing Properties from the float menu. Here it is possible to choose the statistics to be calculated and displayed in the statistics box.

Title Here you can enter a text that will be shown in the sheet object's title area.
Alternate State Choose one of the available states in the list. The following Alternate States are always available.
Inherited
The sheets and sheet objects are always in the inherited state unless overridden by the QlikView developer. This setting is inherited from the object on the level above, a chart in a sheet gets the same settings as the sheet if inherited is chosen.
Default state
This is the state where most QlikView usage occurs and is represented by $. The QlikView document is always in the default state.
Object ID This is used for marco purposes. Every sheet object is assigned a unique ID. For statistics boxes, the ID starts with SB01. Linked objects share the same object ID. You may edit this ID number later on.
Field Select the field that contains the values to be used from the list in the Field group box.
Use as Title

Click the button Use as Title if you want the field name as box title if not, type a title in the Title edit box. The title can also be defined as a calculated formula for dynamic update of the label text. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

See: Expression syntax for calculated formulas

Available Functions Select the statistical functions you want from the list in the Available Functions window and move them to the Displayed Functions window by double-clicking or clicking the Add button.
Show Standard Error Check Show standard Error to display standard error values for Average and Std dev calculations.
Cell Borders Check Cell Borders to display separation by horizontal lines, resembling the rows of a table.
Background... Opens the Background Settings dialog.
Displayed Functions Lists the statistical functions that will be used in the statistics box.
Settings for Selected Row The appearance of the statistics box can be further modified from the Settings for Selected Row group.
Label Replace default function names by entering alternative labels here.
Background Color Specifies the background color of the selected row. The background color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the button.
Text Color This alternative lets you pick a text color for the selected row.
Apply Colors to all Rows Check this alternative before clicking Apply or OK to apply the selected color to all rows of the statistics box.

The available statistical functions are:

Numeric count Sample size. Number of numeric values among the possible values)
Null count Number of empty field values among the possible values
Text count Number of alpha-numeric values among the possible values
Total count Total number of possible values. This is the same number as the frequency that can be shown in a list box. (sum of Numeric count and Text count)
Missing count Number of non-numeric values among the possible values (sum of Null count and Text count)
Sum Sample sum
Average Sample arithmetic mean (average value)
Std dev Sample standard deviation
Skewness Sample skewness
Kurtosis Sample kurtosis
Min Sample minimum
Max Sample maximum
Only value Only possible numeric value
Median Sample median
Fractile Sample fractile

Sample consists of all not excluded (i.e. selected + optional) values of the field.

If the values that represent recognizable field values, such as Min, Max, are clicked the corresponding field values will become selected.

Number

The Statistics Box Properties: Number tab is opened by a right-click on a statistics box and choosing the Properties command from the float menu.

Statistically correct number formats for the various statistical functions that can be displayed in statistics box are automatically derived from the base field's data and number format. Here it is possible to set override number formats for individual functions. To do this, select a statistical function from the Functions list, check the alternative Override Document Settings and specify a number format in the group control below. This property page applies to the active object and contains the following controls for formatting values:

Number Shows numeric values with the number of digits set in the Precision spinner box.
Integer Shows numeric values as integers.
Fixed to _ Decimals Shows numeric values as decimal values with the number of decimal digits set in the Decimals spinner box.
Money Shows values in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box. The default format is the Windows Currency setting.
Date Shows values that can be interpreted as dates in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box.
Time Shows values that can be interpreted as time in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box.
Timestamp Shows values that can be interpreted as date + time in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box.
Interval Shows time as sequential time increment (e.g. format = mm shows the value as the number of minutes since calendar start ( 1899:12:30:24:00).

The Show in Percent (%) button operates on the following formats: Number, Integer and Fixed to.

Decimal and Thousand separators can be set in the edit boxes of the Separators group.

The ISO button uses the ISO standard for the formatting of date, time and timestamp.

The System button applies the settings of the system to the formatting.

Font

Here the Font, Font style and Size of the font to be used can be set.

The font can be set for any single object (Object Properties: Font), or all objects in a document (Apply to Objects on Document Properties: Font).

Further, the default document fonts for new objects can be set on Document Properties: Font. There are two default fonts:

  1. The first default font (List Boxes, Charts, etc) is used for most objects, including list boxes and charts.
  2. The second default font (Text Objects and Buttons) is used for buttons and text boxes, which are objects that usually need a larger font.

Finally, the default fonts for new documents can be set on User Preferences: Font.

For charts, buttons and text objects (except search objects) a font Color can also be specified. The color may Fixed or it can be dynamically Calculated from an expression. The expression must be a valid color representation, which is created using the color functions. If the result of the expression is not a valid color representation, the font color will default to black.

See: Color functions

Additional settings are:

Drop Shadow If this option is checked a drop shadow will be added to the text.
Underline If this option is checked the text will be underlined.

A sample of the selected font is shown in the preview pane.

Layout

A Layout setting will apply to the current object only, if it is made from the Object Properties page.
A Layout setting will apply to all objects of the specified type(s) in the document, if it is made from the Document Properties page.

Use Borders

Enable this setting in order to use a border around the sheet object. Specify the type of border by selecting it in the drop-down menu.

Shadow Intensity The Shadow Intensity drop-down menu makes it possible to set the intensity of the shadow that surrounds the sheet objects. There is also the choice of No Shadow.
Border Style The following predefined border types are available:
Solid
A solid unicolored border.
Depressed
Border giving the impression of depressing the sheet object from the background.
Raised
Border giving the impression of raising the sheet object from the background.
Walled
Border giving the impression of a wall around the sheet object.
Border Width This option is available for all border types. The width can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Color Click this button to open a dialog in which an appropriate base color can be chosen from the color palette for all border types.
Rainbow Creates a rainbow colored border for all border types. The rainbow will start with the selected base color on top of the sheet object.

When Simplified is the chosen Styling Mode in Document Properties: General, there is no choice of border type, there is only the Shadow Intensity drop-down menu and the Border Width setting.

Rounded Corners

In the Rounded Corners group the general shape of the sheet object is defined. These settings allow for drawing of sheet objects ranging from perfectly circular/elliptical via super elliptical to rectangular. Rounded Corners is only available if you have selected Advanced Styling Mode in Document Properties: General.

Rounded Corners Checking this option makes the alternatives for rounded corner shapes possible.
Corners Corners for which the check box remains unmarked will be drawn rectangular instead.
Squareness A variable number between 2 and 100 where 100 defines a rectangle with perfectly square corners and 2 corresponds to a perfect ellipse (a circle for a 1:1 aspect ratio). A squareness between 2 and 5 is usually optimal for achieving rounded corners.
Corner Radius This setting determines the radius of the corners in fixed distance (Fixed) or in percent of the total quadrant (Relative (%)). This setting lets you control the extent to which the corners will be affected by the underlying general shape set under Squareness. The distance can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).

Layer

In the Layer group an object can be defined as residing in one of three layers:

Bottom A sheet object with the Bottom layer property can never obscure sheet objects in the Normal and Top layers. It can only be placed on top of other sheet objects in the Bottom layer.
Normal When created, sheet objects reside in the Normal (middle) layer. A sheet object in the Normal layer can never be obscured by sheet objects in the Bottom layer and can never obscure sheet objects in the Top layer.
Top A sheet object in the Top layer can never be obscured by sheet objects in the Normal and Bottom layers. Only other sheet objects in the Top layer can be placed on top of it.
Custom The Top, Normal and Bottom layers correspond to internally numbered layers 1, 0 and -1 respectively. In fact all values between -128 and 127 are accepted. Choose this option to enter a value of your choice.

Theme Maker...

Opens the Theme Maker wizard where you can create a layout theme.

Apply Theme ...

You can apply a layout theme to the object, sheet or document.

See: Layout Themes

Show

In the Show group it is possible to specify a condition under which the sheet object is displayed:

Always The sheet object will always be displayed.
Conditional

The sheet object will be shown or hidden depending on a conditional function which will be evaluated continuously depending on e.g. selections etc. The sheet object will only be visible when the condition returns TRUE.

See: Conditional functions

Note:

Users with Admin privileges for the document can override all show conditions by selecting Show All Sheets and Sheet Objects in Document Properties: Security. This functionality can be toggled by pressing Ctrl+Shift+S.

See: Document Properties: Security

Options

In the Options group, it is possible to disallow moving and resizing of the sheet object. The settings in this group are only relevant if the corresponding check boxes are enabled in Document Properties: Layout and Sheet Properties: Security.

Allow Move/Size If this option has been deselected it will be impossible to move or resize the sheet object.
Allow Copy/Clone If this option has been deselected it will be impossible to make a copy of the sheet object.
Allow Info

When the info function is in use an info icon will be displayed in the window caption whenever a field value has information associated to it. If you don't want the info icon to be displayed in the caption, you can uncheck this option.

See: Info

Size to Data Normally the borders around all table sheet objects in QlikView will shrink when selections cause the size of the table to be less than allocated size for the sheet object. By deselecting this check box this automatic adjustment of size will be turned off leaving any surplus space blank.

Scrollbars

Various controls for changing the scrollbar layout are located in the Scrollbars group:

Preserve Scroll Position

With this setting enabled, QlikView will try to preserve the scroll position of tables and charts with a scroll bar when a selection is made in another object. The setting must be enabled in User Preferences: Objects as well.

The scroll position is not preserved when you close the document.

Scroll Buttons Sets the scroll button color. Select a color by clicking the button. Note that medium gray tones often render the best results for scroll bars. Either color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the appropriate button.
Scroll Background

Sets the scrollbar background color. Select a color by clicking the button.

Scrollbar Width This control affects both the width and the relative size of the scrollbar symbols.
Scroll Style

Sets the scroll bar style. Select a style in the drop-down control. The Classic scroll bar style corresponds to QlikView 4/5 scroll bars. The Standard scroll bar style gives a more modern look. The third style is Light, which is a thinner, lighter bar.

The Styling Mode must be set to Advanced for the scroll bar style to be visible. This setting can be found on the General tab by opening the Settings drop-down menu and selecting Document Properties.

Apply To... Opens the Caption and Border Properties dialog where you can set where to apply the properties that have been set on the Layout page.

Caption

A Caption setting will apply to the current object only, if it is made from the Object Properties page.
A Caption setting will apply to all objects of the specified type(s) in the document, if it is made from the Document Properties page.

On the Caption page, specify layout options that are completely different from the general layout of the object.

Show Caption When this option has been checked a caption will be drawn at the top of the sheet object. List boxes and other "box objects" will have the option switched on by default whereas buttons, text objects and line/arrow objects will not.
Title Text In the text box you can enter a title to be shown in the caption of the sheet object. Use the Font... button to change the caption font.

Set the colors of the caption in its different states. The settings for Active Colors and Inactive Colors can be made separately from each other.

Click the Background Color or Text Color button to open the Color Area dialog. The Background Color can be defined as a solid or a gradient color on the Color Area dialog. Text Color can be defined a Fixed or a Calculated color using color functions.

See: Color functions

Wrap Text If this option is checked, the caption will be displayed in two or more rows.
Caption Height (Lines) Set the number of caption lines in this edit box.

The precise size and position of the QlikView object can be determined and adjusted by the size/position settings for the Normal or Minimized QlikView sheet object. These settings are measured in pixels:

X-pos Sets the horizontal position of the left side of sheet object in relation to the sheet's left edge.
Y-pos Sets the vertical position of the top side of sheet object in relation to the sheet's upper edge.
Width Sets the width of the QlikView sheet object.
Height Sets the height of the QlikView sheet object.

The orientation of the caption label can be altered with the Caption Alignment options:

Horizontal The label can be horizontally aligned: Left, Centered or Right within the caption area.
Vertical The label can be vertically aligned: Top, Centered or Bottom within the caption area.

Special Icons
Many of the object menu commands of the sheet objects can be configured as caption icons. Select commands to be shown as caption icons by marking the check box to the left of each command in the list.

Note: Use the special caption icons with care. Too many icons will only confuse the user.
Allow Minimize When this option has been checked a minimize icon will be displayed in the window caption of the sheet object, providing that the object is minimizable. Furthermore, this will make it possible to minimize the object by double-clicking the caption.
Auto Minimize This option becomes available when Allow Minimize is checked. When Auto Minimize is checked for several sheet objects on the same sheet, all but one will be automatically minimized at any time. This is useful e.g. for alternately displaying several graphs in the same sheet area.
Allow Maximize When this option has been checked a maximize icon will be displayed in the window caption of the sheet object, providing that the object is maximizable. Furthermore, this will make it possible to maximizing the object by double-clicking the caption. If both Allow Minimize and Allow Maximize are checked, double-clicking will effect minimizing of the object.
Help Text

Here you may enter a help text to be displayed in a pop-up window. The help text may be specified as a calculated formula. This option is not available at document level. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

See: Expression syntax for calculated formulas

Enter e.g. a description of the sheet object. A help icon will be added to the window caption of the object. When the mouse pointer is over the icon, the text will be displayed in a pop-up window.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?