Slider/Calendar Object

Slider/Calendar objects provide alternative means for selecting field values in QlikView. They can also be used for entering values in QlikView script variables. As its name suggests, the slider/calendar object has two completely different modes. As different as they may look, they still work very much the same way behind the visual user interface.

Right-click on a slider/calendar object and the Slider/Calendar Object: Object Menu will be displayed. It can also be accessed from the Object menu, when the slider/calendar object is the active object.

Using a Slider/Calendar Object

Slider Mode

A single value, two values or a range of values (depending on the properties of the object) is selected in a field or inserted into one or two variables by means of dragging a thumb tack along the slider background. The thumb tack can also be moved by means of scroll arrows. Some sliders may incorporate a scale and tick marks for navigation.

Calendar Mode

A slider/calendar object in calendar mode appears in the layout as drop-down box with a calendar icon to the right. When clicking on the calendar icon it will expand to a calendar control. It is possible to navigate between months and years by means of the arrow buttons or the month and year drop-down controls. After selecting a date or a range of dates (depending on the properties of the object) in the calendar control the selection will be applied to the underlying field or variable.

If the object is connected to a field, selections in the field will be reflected in the expanded calendar control, using the same selection color codes as found in list boxes (e.g. green for selected values). Provided that the object is configured for multiple values, it will be possible to paint over multiple values just like in a list box. By pressing the Ctrl-key it is even possible to select multiple ranges of values, even if they appear in different months or years. Once the calendar control is closed after the selection, the drop-down box will function essentially as a field drop-down in a multi box.

Object Menu

The slider/calendar object Object menu is opened by right-clicking the object. The menu commands are:

Properties... Opens the Slider/Calendar Object Properties dialog where a number of parameters can be set.
Notes

Allows creating and sharing notes about the current object.

See: Notes and Comments

Order

This cascade menu is only available when the Design Grid command of the View menu is activated or when the Always Show Design Menu Items under User Preferences: Design is checked. It contains four commands to set the layout layer of the sheet objects. Valid layer numbers are -128 to 127.

Bring to Front
Sets the layout layer of the sheet object to the largest value currently used by any sheet object on the current sheet.

Send to Back
Sets the layout layer of the sheet object to the smallest value currently used by any sheet object on the current sheet.

Bring Forward
Increases the layout layer of the sheet object by one. Maximum value is 127.

Send Backward
Decreases the layout layer of the sheet object by one. Minimum value is -128.


Copy to Clipboard This cascade menu contains the various copy options for the sheet object.
Image
Copies an image of the sheet object to the clipboard. The image will include or exclude the sheet object caption and border depending on the settings in the User Preferences: Export page.
Object
Copies the entire sheet object to the clipboard for pasting elsewhere in the layout or in another document opened within the current instance of QlikView.
Linked Objects

Opens a menu with the following commands for linked objects.
Adjust Position of Linked Objects
All linked objects on all sheets are adjusted to the same position and size as the one/ones highlighted.
Unlink This Object/Unlink Objects
This destroys the link between the objects, making them different objects with different object IDs.

Minimize Iconizes the object. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if minimizing is allowed in the object's Properties dialog on the Caption page.
Maximize Enlarges the object to fill the sheet. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if maximizing is allowed in the object's Properties dialog on the Caption page.
Restore Restores a minimized or maximized object to its previous size and location. Double-clicking the icon of a minimized object or clicking the icon in the object caption (if shown) of a maximized object produces the same result. This command is available only for minimized or maximized objects.
Help Opens QlikView help.
Remove Removes the sheet object from the sheet.

General

The Slider/Calendar Object Properties: General page is opened by a right-click on a slider/calendar object and choosing the Properties command in the float menu. Here you can make general settings for the data to be manipulated by the slider/calendar object. It is also possible to reach this information via the dialog New Slider/Calendar Object.

Under Input Style select the basic mode of the slider/calendar object. Use the drop-down to select whether the object should be represented by a Slider control or a Calendar input control.

The Data group is where it is defined which data object the slider/calendar is connected to. A slider/calendar can be connected to either a field or to one or a pair of variables.

Field Select this radio button if to connect the slider/calendar object to a field or an expression. Select the field in the drop-down box. If Expression is chosen in the drop-down the Edit Expression dialog will open.
Edit... Opens the Edit Expression dialog for the expression chosen in the drop-down list.
Variable(s) Check the radio button and select the desired variable(s) in the drop-down list(s). The second variable is only available if you select Multi Value under Mode (see below).

In the Mode group specify if the slider/calendar should be used for selecting a Single Value or a range of values - Multi Value.

In the Value Mode group you specify if the slider/calendar should select Discrete values (unavailable for Multi Value mode) or define a Continuous/Numeric range of values (unavailable for Single Value mode with Field data). This group is not available in Calendar mode. In Calendar mode discrete values are always assumed.

Min Value Sets the minimum value for the slider/calendar in Continuous/Numeric value mode.
Max Value Sets the maximum value for the slider/calendar in Continuous/Numeric value mode.
Static Step Check the box and enter a value in the edit box to specify a static step for slider/calendar values in the Continuous/Numeric value mode.
Value 1 Shows current value for the slider in Continuous/Numeric value mode if the slider/calendar is Single Value. In Multi Value mode the low value is shown.
Value 2 Shows current high value for the slider/calendar in Continuous/Numeric value mode. Only relevant in Multi Value mode.
Override Locked Field If this check box is marked, selections can be made via the slider/calendar object in a field even if the field is locked. The field will still be locked for logical changes stemming from selections in other fields. This option is selected by default for slider/calendar objects.
Fixed Range When this alternative is checked, the user will not be able to widen or narrow the range by dragging the edges of the slider thumb-tack.
Alternate State Choose one of the available states in the list. The following Alternate States are always available.
Inherited
The sheets and sheet objects are always in the inherited state unless overridden by the QlikView developer. This setting is inherited from the object on the level above, a chart in a sheet gets the same settings as the sheet if inherited is chosen.
Default state
This is the state where most QlikView usage occurs and is represented by $. The QlikView document is always in the default state.
Object ID

This is used for marco purposes. Every sheet object is assigned a unique ID. For slider objects, the ID starts with SL01. Linked objects share the same object ID. You may edit this ID number later on.

See: Internal Macro Interpreter

Print Settings This button takes you to the Print Settings dialog where margins and header/footer format can be defined.

Presentation (Slider Mode)

The Slider/Calendar Object Properties: Presentation tab is opened by a right-click on a Slider/Calendar object and choosing the Properties command from the float menu. This is where the visual properties of the slider/calendar object can be configured.

The Colors group lets you define colors for the different parts of the slider/calendar, as shown in this figure:

A Ticks
B Scale background
C Slider background
D Thumb tack
E Scroll arrows

Slider Background and Scale Background color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the corresponding button. The degree of transparency of the slider background can be set using the Transparency control to the right of the button. At 0% the background will be completely opaque. At 100% the background will be completely transparent.

Thumb Tack, Scroll Arrows and Unit Ticks color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the corresponding button.

In the Scroll Orientation group the slider can be displayed in the Horizontal or Vertical direction.

In the Label Orientation you can determine whether scale text should be oriented in Horizontal or Vertical direction.

In the Scale group you can define a slider scale. Select Use Automatic Scale for the scale to be automatically generated based on slider size and underlying values. The alternative Use Custom Scale lets you specify a number of scale settings:

Major Units The number defines the number of major units on the slider scale.
Labels on Every n Major Unit Defines the density of scale label text.
Minor Units per Major Unit Defines the number of minor units between each major unit on the slider scale.

Scroll arrows can be visible or hidden with the alternative Show Scroll Arrows.

Slider Style can be set as Solid or Shimmer.

Note: There are limitations to the automatic scale and vertical label orientation functions in AJAX/WebView mode.
If it is possible, it is recommended that you Use Custom Scale to define the scale settings.

Presentation (Calendar Mode)

The Slider/Calendar Object Properties: Presentation tab is opened by a right-click on a Slider/Calendar object and choosing the Properties command from the float menu. This is where the visual properties of the slider/calendar object can be configured.

The Colors group lets you define the color of the calendar control background. The Background color can be defined as a solid color or a gradient via the Color Area dialog that opens when clicking the button. The degree of transparency of the calendar control background can be set using the Transparency control to the right of the button. At 0% the background will be completely opaque. At 100% the background will be completely transparent.

Sort

On the Sort tab the sort order can be set for the slider data. This dialog is very similar to its counterpart under Document Properties.

See also:

 
  • NumberDocument Properties
  • See also:

  • FontFont styleSize
  • Object Properties: FontApply to ObjectsDocument Properties: Font
  • Document Properties: Font
  • User Preferences: Font
  • ColorFixedCalculated
  • See: Color functions

  • Use Borders
  • SimplifiedStyling ModeDocument Properties: GeneralShadow IntensityBorder Width
  • Rounded Corners
  • Rounded CornersRounded CornersAdvancedStyling ModeDocument Properties: General
  • Layer
  • Layer
  • Theme Maker...
  • Theme Maker
  • Apply Theme ...
  • See: Layout Themes
  • Show
  • Show
  • Options
  • OptionsDocument Properties: LayoutSheet Properties: Security
  • Scrollbars
  • Scrollbars
  • Object Properties
    Document Properties
  • Caption
  • Active ColorsInactive Colors
  • Background ColorText ColorColor AreaBackground ColorsolidgradientColor AreaText ColorFixedCalculated
  • See: Color functions
  • NormalMinimized
  • Caption Alignment
  • Special Icons

Number

Font

  1. The first default font (List Boxes, Charts, etc) is used for most objects, including list boxes and charts.
  2. The second default font (Text Objects and Buttons) is used for buttons and text boxes, which are objects that usually need a larger font.
Drop Shadow If this option is checked a drop shadow will be added to the text.
Underline If this option is checked the text will be underlined.

Layout

Shadow Intensity The Shadow Intensity drop-down menu makes it possible to set the intensity of the shadow that surrounds the sheet objects. There is also the choice of No Shadow.
Border Style The following predefined border types are available:
Solid
A solid unicolored border.
Depressed
Border giving the impression of depressing the sheet object from the background.
Raised
Border giving the impression of raising the sheet object from the background.
Walled
Border giving the impression of a wall around the sheet object.
Border Width This option is available for all border types. The width can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Color Click this button to open a dialog in which an appropriate base color can be chosen from the color palette for all border types.
Rainbow Creates a rainbow colored border for all border types. The rainbow will start with the selected base color on top of the sheet object.
Rounded Corners Checking this option makes the alternatives for rounded corner shapes possible.
Corners Corners for which the check box remains unmarked will be drawn rectangular instead.
Squareness A variable number between 2 and 100 where 100 defines a rectangle with perfectly square corners and 2 corresponds to a perfect ellipse (a circle for a 1:1 aspect ratio). A squareness between 2 and 5 is usually optimal for achieving rounded corners.
Corner Radius This setting determines the radius of the corners in fixed distance (Fixed) or in percent of the total quadrant (Relative (%)). This setting lets you control the extent to which the corners will be affected by the underlying general shape set under Squareness. The distance can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Bottom A sheet object with the Bottom layer property can never obscure sheet objects in the Normal and Top layers. It can only be placed on top of other sheet objects in the Bottom layer.
Normal When created, sheet objects reside in the Normal (middle) layer. A sheet object in the Normal layer can never be obscured by sheet objects in the Bottom layer and can never obscure sheet objects in the Top layer.
Top A sheet object in the Top layer can never be obscured by sheet objects in the Normal and Bottom layers. Only other sheet objects in the Top layer can be placed on top of it.
Custom The Top, Normal and Bottom layers correspond to internally numbered layers 1, 0 and -1 respectively. In fact all values between -128 and 127 are accepted. Choose this option to enter a value of your choice.
Always The sheet object will always be displayed.
Conditional

The sheet object will be shown or hidden depending on a conditional function which will be evaluated continuously depending on e.g. selections etc. The sheet object will only be visible when the condition returns TRUE.

See: Conditional functions

Note:

Users with Admin privileges for the document can override all show conditions by selecting Show All Sheets and Sheet Objects in Document Properties: Security. This functionality can be toggled by pressing Ctrl+Shift+S.

See: Document Properties: Security

Allow Move/Size If this option has been deselected it will be impossible to move or resize the sheet object.
Allow Copy/Clone If this option has been deselected it will be impossible to make a copy of the sheet object.
Allow Info

When the info function is in use an info icon will be displayed in the window caption whenever a field value has information associated to it. If you don't want the info icon to be displayed in the caption, you can uncheck this option.

See: Info

Size to Data Normally the borders around all table sheet objects in QlikView will shrink when selections cause the size of the table to be less than allocated size for the sheet object. By deselecting this check box this automatic adjustment of size will be turned off leaving any surplus space blank.
Preserve Scroll Position

With this setting enabled, QlikView will try to preserve the scroll position of tables and charts with a scroll bar when a selection is made in another object. The setting must be enabled in User Preferences: Objects as well.

The scroll position is not preserved when you close the document.

Scroll Buttons Sets the scroll button color. Select a color by clicking the button. Note that medium gray tones often render the best results for scroll bars. Either color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the appropriate button.
Scroll Background

Sets the scrollbar background color. Select a color by clicking the button.

Scrollbar Width This control affects both the width and the relative size of the scrollbar symbols.
Scroll Style

Sets the scroll bar style. Select a style in the drop-down control. The Classic scroll bar style corresponds to QlikView 4/5 scroll bars. The Standard scroll bar style gives a more modern look. The third style is Light, which is a thinner, lighter bar.

The Styling Mode must be set to Advanced for the scroll bar style to be visible. This setting can be found on the General tab by opening the Settings drop-down menu and selecting Document Properties.

Apply To... Opens the Caption and Border Properties dialog where you can set where to apply the properties that have been set on the Layout page.

Caption

Show Caption When this option has been checked a caption will be drawn at the top of the sheet object. List boxes and other "box objects" will have the option switched on by default whereas buttons, text objects and line/arrow objects will not.
Title Text In the text box you can enter a title to be shown in the caption of the sheet object. Use the Font... button to change the caption font.
Wrap Text If this option is checked, the caption will be displayed in two or more rows.
Caption Height (Lines) Set the number of caption lines in this edit box.
X-pos Sets the horizontal position of the left side of sheet object in relation to the sheet's left edge.
Y-pos Sets the vertical position of the top side of sheet object in relation to the sheet's upper edge.
Width Sets the width of the QlikView sheet object.
Height Sets the height of the QlikView sheet object.
Horizontal The label can be horizontally aligned: Left, Centered or Right within the caption area.
Vertical The label can be vertically aligned: Top, Centered or Bottom within the caption area.
Note: Use the special caption icons with care. Too many icons will only confuse the user.
Allow Minimize When this option has been checked a minimize icon will be displayed in the window caption of the sheet object, providing that the object is minimizable. Furthermore, this will make it possible to minimize the object by double-clicking the caption.
Auto Minimize This option becomes available when Allow Minimize is checked. When Auto Minimize is checked for several sheet objects on the same sheet, all but one will be automatically minimized at any time. This is useful e.g. for alternately displaying several graphs in the same sheet area.
Allow Maximize When this option has been checked a maximize icon will be displayed in the window caption of the sheet object, providing that the object is maximizable. Furthermore, this will make it possible to maximizing the object by double-clicking the caption. If both Allow Minimize and Allow Maximize are checked, double-clicking will effect minimizing of the object.
Help Text

Here you may enter a help text to be displayed in a pop-up window. The help text may be specified as a calculated formula. This option is not available at document level. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

See: Expression syntax for calculated formulas

Enter e.g. a description of the sheet object. A help icon will be added to the window caption of the object. When the mouse pointer is over the icon, the text will be displayed in a pop-up window.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?