Multi Box

Due to its unique option to sort the displayed fields by applicability (), the multi box offers the ultimate solution to the problem of displaying a large number of list boxes on the same sheet. This Sort by Applicability option is accessed from the Multi Box Properties: General page.

Right-click on the multi box to display the Object menu.

Object Menu

The multi box Object menu has three different versions. If the caption area is clicked the float menu will contain commands that are applicable to the whole box, whereas if an individual field is under the pointer the menu will be extended to include commands that apply to that field. Finally, if you first open a file, the float menu will have yet another layout. The combined commands of the menus are:

Properties... Opens the Multi Box Properties dialog where a number of parameters can be set.
Notes

Allows creating and sharing notes about the current object.

See: Notes and Comments

Order

This cascade menu is only available when the Design Grid command of the View menu is activated or when the Always Show Design Menu Items under User Preferences: Design is checked. It contains four commands to set the layout layer of the sheet objects. Valid layer numbers are -128 to 127.

Bring to Front
Sets the layout layer of the sheet object to the largest value currently used by any sheet object on the current sheet.

Send to Back
Sets the layout layer of the sheet object to the smallest value currently used by any sheet object on the current sheet.

Bring Forward
Increases the layout layer of the sheet object by one. Maximum value is 127.

Send Backward
Decreases the layout layer of the sheet object by one. Minimum value is -128.


Search

Opens the search box.

See: Search

Fuzzy Search

Opens the text search box in fuzzy search mode.

See: Fuzzy Search

Advanced Search

Opens the advanced search dialog. The dialog makes it possible to enter advanced search expressions. This command can also be invoked by the following keyboard shortcut: Ctrl+Shift+F.

See: Advanced Search dialog

Select Possible All non-excluded values of the field are selected.
Select Excluded All excluded values of the field are selected.
Select All All values of the field are selected.
Clear All Selections Clears all the current selections of the multi box.
Clear Clears all the current selections of the field.
Clear Other Fields Clears the selections in all the other sheet objects, including selections in other fields of the current multi box, while maintaining selections in this specific field of the current multi box.
Lock Locks the selected value(s) of the field.
Lock All Selections Locks the selected value(s) of the multi box.
Unlock Unlocks the locked value(s) of the field.
Unlock All Selections Unlocks the locked value(s) of the multi box.
Print...

Opens the Print dialog where print settings can be specified. Printing the multi box is only meaningful when a single value is displayed in each field (either because it's the only selected value or the only associated value).

See: Print: General

Print as PDF...

Opens the Print dialog with the PDF-XChange 3.0 printer pre-selected. After pressing the Print button you will be prompted for a file name for the PDF output file. This command is only available if a PDF printer is available on the system.

Send to Excel Exports possible (including selected) values to Microsoft Excel, which is automatically launched if not already running. QlikView exports in BIFF (native Excel format) format. The exported values will appear in a new Excel worksheet. For this functionality to work Microsoft Excel 97 or later must be installed on the computer. This operation is only meaningful when a single value is displayed in each field (either because it's the only selected value or the only associated value).
Export... Opens a dialog where you can export the multi box as a table to a file of your choice. The file formats offered include a range of delimited text file formats: HTML, XML, BIFF (native Excel format), and QVO.
Copy to Clipboard This cascade menu contains the various copy options for the sheet object.
Data
Copies the data rows of the multi box to the clipboard.
Cell Value
Copies the text value of the multi box cell right-clicked upon (when invoking the Object menu) to the clipboard.
Image
Copies an image of the sheet object to the clipboard. The image will include or exclude the sheet object caption and border depending on the settings in the User Preferences dialog, Export page.
Object
Copies the entire sheet object to the clipboard for pasting elsewhere in the layout or in another document opened within the current instance of QlikView.
Linked Objects

Opens a menu with the following commands for linked objects.
Adjust Position of Linked Objects
All linked objects on all sheets are adjusted to the same position and size as the one/ones highlighted.
Unlink This Object/Unlink Objects
This destroys the link between the objects, making them different objects with different object IDs.

Minimize Iconizes the object. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if minimizing is allowed in the object's Properties dialog on the Caption page.
Maximize Enlarges the object to fill the sheet. Clicking on the icon in the object caption (if shown) produces the same result. This command is available only if maximizing is allowed in the object's Properties dialog on the Caption page.
Restore Restores a minimized or maximized object to its previous size and location. Double-clicking the icon of a minimized object or clicking the icon in the object caption (if shown) of a maximized object produces the same result. This command is available only for minimized or maximized objects.
Help Opens QlikView help.
Remove Removes the sheet object from the sheet.

General

Title

In the Title window the multi box can be given a name which will be displayed in the window caption.The title can also be defined as a calculated formula for dynamic update of the label text. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

See: Expression syntax for calculated formulas

Alternate State Choose one of the available states in the list. The following Alternate States are always available.
Inherited
The sheets and sheet objects are always in the inherited state unless overridden by the QlikView developer. This setting is inherited from the object on the level above, a chart in a sheet gets the same settings as the sheet if inherited is chosen.
Default state
This is the state where most QlikView usage occurs and is represented by $. The QlikView document is always in the default state.

Available Fields

In this column the names of the data source fields are shown. Initially all fields (excluding system fields) appear in this column. To include the system fields check Show System Fields.

See: System fields

Key fields will be indicated with a key symbol. Select the items to be used/removed by clicking them. Use the Add > or the < Remove button to move them to the desired column.

Fields Displayed in Multibox In this column the names of the fields selected from the Available Fields list to be included in the multi box are shown. Initially no fields are shown in this column.
When a field is selected in this list, you may give it a custom Label in the edit window.
Show Fields from Table From here, you control what fields appear in the Available Fields list. The drop-down list displays the alternative All Tables by default.
The alternative All Tables (Qualified) shows the fields qualified by the name of the table(s) they occur in. This means that key (connecting) fields will be listed more than once. (This alternative is only used for viewing purposes and has nothing to do with Qualify fields in the load script.)
It is also possible to view the fields of one table at a time.
Expression Opens the Edit Expression dialog where an expression can be created that can then be used as a displayed field in the multi box.
Edit... Opens the Edit Expression dialog for the field chosen in the Fields Displayed in Multibox column.
Promote Moves a field upwards in the display order.
Demote Moves a field downwards in the display order.
Count Order Sorts the fields in the Fields Displayed in Multibox column in numerical order.
Load Order Sorts the fields in the Fields Displayed in Multibox column in load order, i.e. the order in which they are read from the database.
Text Order Sorts the fields in the Fields Displayed in Multibox column in alphabetical order.
Sort by Applicability When this option is checked, the sort order of the Fields Displayed in Multibox will be dynamically updated during selections so that fields with non-excluded field values will move upwards in the list while fields without possible values will move downwards. This option will in many cases make it possible to use literally hundreds of fields in a single multi box.
Object ID

This is used for marco purposes. Every sheet object is assigned a unique ID. For multi boxes, the ID starts with MB01. Linked objects share the same object ID. You may edit this ID number later on.

See: Internal Macro Interpreter

Sort

You reach the Sort tab by right-clicking a sheet object (List Box, Multi Box, Table Box, Chart or Slider/Calendar object) and choosing Properties from the float menu (or Object, Properties in the main menu). Here you set the sort order of the values in the sheet object. Some sort options may not be available for some sheet objects.

Sort by:

State Sorts the field values according to their logical state (selected, optional or excluded).
The Auto Ascending setting sorts the list box (or, in a multi box, the drop-down list containing the field values) according to State only if the list box contains a vertical scroll bar. However, if you enlarge the list box to show all values, the sort order State is completely switched off.
Expression

Sorts the field values according to the expression entered into the text edit box below this sort option. If using sort by expression, an alternative set of records must be defined by a set expression. Note that sort by expression here only works with numeric fields and not text fields.

See: Set analysis and set expressions

Frequency Sorts the field values by frequency (number of occurrences in the table).
Numeric Value Sorts the field values by numeric value.
Text Sorts the field values in alphabetical order.
Load Order Sorts the field values by the initial load order.

The Default button sort order sets the default sort order.

The order of priority is State, Expression, Frequency, Numeric Value, Text, Load Order. Each of these sort criteria can be set to Ascending or Descending.

Presentation

The Multi Box Properties: Presentation tab is opened by a right-click on a multi box and choosing the Properties command in the Object menu. Here it is possible to adjust the layout of the multi box cells. Adjustments are made independently for the different fields of the multi box. It is also possible to adjust the layout for the - Closed Multi Box -.

Alignment Here you set the alignment of field values. The alignment of Text and Numbers is set separately.
Multiline Settings In this group the multi box field cells may be set to display values in multiple rows, which is useful for long text strings.
Wrap Text
With this option selected, a cell will display its contents in more than one row.
Cell HeightnLines
Here the desired limit to the number of cell rows is specified.
Frequency Show
Toggles the status for whether the frequency of the selected field value is shown or not. By frequency is meant the number of selectable combinations in which the value occurs.
In Percent
Toggles the status for whether the frequency should be shown in absolute numbers or as percentages of the total number of entries.
Advanced This button opens the Advanced Field Settings dialog which offers settings for image representation of field values and special text search options.
Single Column With this option checked, the multi box field values will always be presented in a single column.
Suppress Horizontal Scroll Bar Check this option to suppress the horizontal scroll bar that is normally displayed when field values are too wide to for the specified width of the multi box. Instead, field values will be truncated as needed.
Order by Column In multi box fields with more than one column, values are displayed row-wise in the sort order specified. The Order by column option switches to column-wise display.
Cell Borders The field values will be separated by horizontal lines, resembling the rows of a table. Cell borders is automatically activated when the Wrap Text option is checked, but may be subsequently deactivated.
Hide Excluded Toggles whether the excluded field values should be shown or not. Excluded values become unselectable as well.
Read Only This checkbox disables selections made directly in this particular multi box field, making it a display tool only.
Ignore Null NULL-values are not considered for the sake of displaying possible values of a specific field.
Note: Incorrect use of this option may lead to the display of non-correlated data in the multi box.
Override Locked Field This check box allows selections to be made in a particular field of the multi box even if that field is locked. The field will remain locked for selections made elsewhere in the document.
Grid Style This checkbox changes the multi box layout, so that each label is positioned above its corresponding field.
Read Only This checkbox disables selections made directly in the multi box fields, making it a display tool only.
Closed Color Sets the color of the data column cells of a closed multi box. A color can be defined as a solid color or a gradient via the Color Area dialog that opens when clicking the button.
Limit Drop-down to n Lines Limits the length of opened drop-down list boxes in the multi box. Enter the maximum number of values to be shown in the edit box.
Style Choose between the styles Borders and Light.
Background... Opens the Background Settings dialog.

Advanced Field Settings

The Advanced Field Settings dialog can be accessed from Multi Box Properties: Presentation, Table Box Properties: Presentation and Chart Properties: Dimensions. The image options described below are unavailable for bitmap charts.

Image Options

Representation The following alternatives are given:
Text
When selecting this option the expression values will always be interpreted and displayed as text.
Image
When selecting this option QlikView will try to interpret each expression value as a reference to an image. The reference may be a path to an image file on disk (e.g. C:\Mypic.jpg) or inside the qvw document (e.g. qmem://<Name>/<Peter>). If QlikView cannot interpret an expression value as a valid image reference, the value itself will be displayed.
Info as Image
When selecting this option QlikView will display image info linked to the field value via info load/select in the script. If no image info is available for a field value, the value itself will be displayed, unless the Hide Text When Image Missing box is checked. The option is not available for bitmap charts.
Image Formatting Only available when the image options have been selected above. This setting describes how QlikView formats the image to fit in the cell. There are four alternatives.
No Stretch
If this option is selected, the image will be shown as is, without any stretching. This may cause parts of the picture to be invisible or only part of the cell to be filled.
Fill
If this option is selected, the image will be stretched to fit the cell without bothering about keeping the aspect ratio of the image.
Keep Aspect
If this option is selected, the image will be stretched as far as possible to fill the cell while keeping the aspect ratio. This typically results in areas either on both sides of or above and below which are not filled by the image.
Fill with Aspect
If this option is selected, the image will be stretched to fill the cell in both directions while keeping the aspect ratio. This typically results in cropping of the image in one direction.
Hide Text When Image Missing If this option is selected, QlikView will not display the field value text if interpretation as an image reference fails for some reason. The cell will then be left blank.
Selection Style Override When images are shown instead of text it may be necessary to use another selection style than the document default so that the logical state of the field values remains visible. Use the drop-down list under Selection Style Override to select a suitable selection style, e.g. Corner Tag.

Search Options

This group allows you to control certain aspects of text search applicable to opened multi boxes and drop-down select in tables.

Include Excluded Values in Search This setting specifies whether excluded values should be included in text searches. The following alternatives are available:
<use default>
The default as specified under User Preferences applies.
Yes
Excluded values are always included in text search.
No
Excluded vales are never included in text search, whereas optional values are included as usual.
Default Search Mode This setting specifies the initial default search mode to be used in text searches. The mode can always be changed on the fly by typing * or ~ as part of the search string. The following alternatives are available:
<use default>
The default as specified under User Preferences applies.
Use Wildcard Search
The initial search string will be two wildcards with the cursor between them to facilitate a wildcard search.
Use Fuzzy Search
The initial search string will be a tilde (~) to denote a fuzzy search.
Use Normal Search
No additional characters will be added to the search string. Without wildcards, a Normal Search will be made.

Number

The Multi Box Properties: Number tab is opened by a right-click on a multi box and choosing the Properties command from the float menu.

This property page provides formatting settings for all fields of the multi box. The number formatting can be set individually for fields by selecting one or several fields (Click, Shift-click or Ctrl-click) in the Fields text box.

Each field has a default number format which can be set in the Document Properties: Number page. It is however possible to use a separate number format for an individual sheet object. To do this, check the alternative Override Document Settings and specify a number format in the group control below. This property page applies to the active object and contains the following controls for formatting values:

Mixed Both numbers and text. Numbers shown in original format.
Number Shows numeric values with the number of digits set in the Precision spinner box.
Integer Shows numeric values as integers.
Fixed to _ Decimals Shows numeric values as decimal values with the number of decimal digits set in the Decimals spinner box.
Money Shows values in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box. The default format is the Windows Currency setting.
Date Shows values that can be interpreted as dates in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box.
Time Shows values that can be interpreted as time in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box.
Timestamp Shows values that can be interpreted as date + time in the format set in the Format Pattern edit box. An example of this format is shown in the Preview text box.
Interval Shows time as sequential time increment (e.g. format = mm shows the value as the number of minutes since calendar start ( 1899:12:30:24:00).

The Show in Percent (%) button operates on the following formats: Number, Integer and Fixed to.

Decimal and Thousand separators can be set in the edit boxes of the Separators group.

The ISO button uses the ISO standard for the formatting of date, time and timestamp.

The System button applies the settings of the system to the formatting.

The Change Document Format button opens the Document Properties: Number page where the default number format of any field can be edited.

See also:

 
  • FontFont styleSize
  • Object Properties: FontApply to ObjectsDocument Properties: Font
  • Document Properties: Font
  • User Preferences: Font
  • ColorFixedCalculated
  • See: Color functions

  • Use Borders
  • SimplifiedStyling ModeDocument Properties: GeneralShadow IntensityBorder Width
  • Rounded Corners
  • Rounded CornersRounded CornersAdvancedStyling ModeDocument Properties: General
  • Layer
  • Layer
  • Theme Maker...
  • Theme Maker
  • Apply Theme ...
  • See: Layout Themes
  • Show
  • Show
  • Options
  • OptionsDocument Properties: LayoutSheet Properties: Security
  • Scrollbars
  • Scrollbars
  • Object Properties
    Document Properties
  • Caption
  • Active ColorsInactive Colors
  • Background ColorText ColorColor AreaBackground ColorsolidgradientColor AreaText ColorFixedCalculated
  • See: Color functions
  • NormalMinimized
  • Caption Alignment
  • Special Icons

Font

  1. The first default font (List Boxes, Charts, etc) is used for most objects, including list boxes and charts.
  2. The second default font (Text Objects and Buttons) is used for buttons and text boxes, which are objects that usually need a larger font.
Drop Shadow If this option is checked a drop shadow will be added to the text.
Underline If this option is checked the text will be underlined.

Layout

Shadow Intensity The Shadow Intensity drop-down menu makes it possible to set the intensity of the shadow that surrounds the sheet objects. There is also the choice of No Shadow.
Border Style The following predefined border types are available:
Solid
A solid unicolored border.
Depressed
Border giving the impression of depressing the sheet object from the background.
Raised
Border giving the impression of raising the sheet object from the background.
Walled
Border giving the impression of a wall around the sheet object.
Border Width This option is available for all border types. The width can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Color Click this button to open a dialog in which an appropriate base color can be chosen from the color palette for all border types.
Rainbow Creates a rainbow colored border for all border types. The rainbow will start with the selected base color on top of the sheet object.
Rounded Corners Checking this option makes the alternatives for rounded corner shapes possible.
Corners Corners for which the check box remains unmarked will be drawn rectangular instead.
Squareness A variable number between 2 and 100 where 100 defines a rectangle with perfectly square corners and 2 corresponds to a perfect ellipse (a circle for a 1:1 aspect ratio). A squareness between 2 and 5 is usually optimal for achieving rounded corners.
Corner Radius This setting determines the radius of the corners in fixed distance (Fixed) or in percent of the total quadrant (Relative (%)). This setting lets you control the extent to which the corners will be affected by the underlying general shape set under Squareness. The distance can be specified in mm, cm, inches (", inch), pixels (px, pxl, pixel), points (pt, pts, point) or docunits (du, docunit).
Bottom A sheet object with the Bottom layer property can never obscure sheet objects in the Normal and Top layers. It can only be placed on top of other sheet objects in the Bottom layer.
Normal When created, sheet objects reside in the Normal (middle) layer. A sheet object in the Normal layer can never be obscured by sheet objects in the Bottom layer and can never obscure sheet objects in the Top layer.
Top A sheet object in the Top layer can never be obscured by sheet objects in the Normal and Bottom layers. Only other sheet objects in the Top layer can be placed on top of it.
Custom The Top, Normal and Bottom layers correspond to internally numbered layers 1, 0 and -1 respectively. In fact all values between -128 and 127 are accepted. Choose this option to enter a value of your choice.
Always The sheet object will always be displayed.
Conditional

The sheet object will be shown or hidden depending on a conditional function which will be evaluated continuously depending on e.g. selections etc. The sheet object will only be visible when the condition returns TRUE.

See: Conditional functions

Note:

Users with Admin privileges for the document can override all show conditions by selecting Show All Sheets and Sheet Objects in Document Properties: Security. This functionality can be toggled by pressing Ctrl+Shift+S.

See: Document Properties: Security

Allow Move/Size If this option has been deselected it will be impossible to move or resize the sheet object.
Allow Copy/Clone If this option has been deselected it will be impossible to make a copy of the sheet object.
Allow Info

When the info function is in use an info icon will be displayed in the window caption whenever a field value has information associated to it. If you don't want the info icon to be displayed in the caption, you can uncheck this option.

See: Info

Size to Data Normally the borders around all table sheet objects in QlikView will shrink when selections cause the size of the table to be less than allocated size for the sheet object. By deselecting this check box this automatic adjustment of size will be turned off leaving any surplus space blank.
Preserve Scroll Position

With this setting enabled, QlikView will try to preserve the scroll position of tables and charts with a scroll bar when a selection is made in another object. The setting must be enabled in User Preferences: Objects as well.

The scroll position is not preserved when you close the document.

Scroll Buttons Sets the scroll button color. Select a color by clicking the button. Note that medium gray tones often render the best results for scroll bars. Either color can be defined as a solid color or a gradient via the Color Area dialog that opens when you click the appropriate button.
Scroll Background

Sets the scrollbar background color. Select a color by clicking the button.

Scrollbar Width This control affects both the width and the relative size of the scrollbar symbols.
Scroll Style

Sets the scroll bar style. Select a style in the drop-down control. The Classic scroll bar style corresponds to QlikView 4/5 scroll bars. The Standard scroll bar style gives a more modern look. The third style is Light, which is a thinner, lighter bar.

The Styling Mode must be set to Advanced for the scroll bar style to be visible. This setting can be found on the General tab by opening the Settings drop-down menu and selecting Document Properties.

Apply To... Opens the Caption and Border Properties dialog where you can set where to apply the properties that have been set on the Layout page.

Caption

Show Caption When this option has been checked a caption will be drawn at the top of the sheet object. List boxes and other "box objects" will have the option switched on by default whereas buttons, text objects and line/arrow objects will not.
Title Text In the text box you can enter a title to be shown in the caption of the sheet object. Use the Font... button to change the caption font.
Wrap Text If this option is checked, the caption will be displayed in two or more rows.
Caption Height (Lines) Set the number of caption lines in this edit box.
X-pos Sets the horizontal position of the left side of sheet object in relation to the sheet's left edge.
Y-pos Sets the vertical position of the top side of sheet object in relation to the sheet's upper edge.
Width Sets the width of the QlikView sheet object.
Height Sets the height of the QlikView sheet object.
Horizontal The label can be horizontally aligned: Left, Centered or Right within the caption area.
Vertical The label can be vertically aligned: Top, Centered or Bottom within the caption area.
Note: Use the special caption icons with care. Too many icons will only confuse the user.
Allow Minimize When this option has been checked a minimize icon will be displayed in the window caption of the sheet object, providing that the object is minimizable. Furthermore, this will make it possible to minimize the object by double-clicking the caption.
Auto Minimize This option becomes available when Allow Minimize is checked. When Auto Minimize is checked for several sheet objects on the same sheet, all but one will be automatically minimized at any time. This is useful e.g. for alternately displaying several graphs in the same sheet area.
Allow Maximize When this option has been checked a maximize icon will be displayed in the window caption of the sheet object, providing that the object is maximizable. Furthermore, this will make it possible to maximizing the object by double-clicking the caption. If both Allow Minimize and Allow Maximize are checked, double-clicking will effect minimizing of the object.
Help Text

Here you may enter a help text to be displayed in a pop-up window. The help text may be specified as a calculated formula. This option is not available at document level. Click the ... button to open the Edit Expression dialog for easier editing of long formulas.

See: Expression syntax for calculated formulas

Enter e.g. a description of the sheet object. A help icon will be added to the window caption of the object. When the mouse pointer is over the icon, the text will be displayed in a pop-up window.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?