File menu

The File menu is a drop-down menu at the top of the screen, and contains the following commands:

New Opens a new QlikView window and allows to create a new QlikView file.
Open... Opens a new QlikView window and allows to open a QlikView file or a Table file. Opening a table file automatically opens the File Wizard. This command can also be invoked by the following keyboard shortcut: Ctrl+O.
Open in Server... Opens a dialog where it is possible to connect to a QlikView Server and browse for a document to open in client mode.
This command can also be invoked by the following keyboard shortcut: Ctrl+Shift+O.
Note: When opening documents as a client to QlikView Server the possibilities are restricted on what is possible to do with the document compared to when opening local documents. As a client it is not possible to add or delete sheet objects, depending on whether the document supports collaboration. Sheets cannot be added or deleted. Furthermore, not all properties dialogs can be accessed, macros changed, the script accessed, data reloaded or the document saved.
Refresh Document This command is only available with documents opened on QlikView Server and when there is a newer version of the document available on the server. When invoking a refresh access is gained to the latest data, while maintaining the session including selections and layout state.
Open URL... Opens the Open URL dialog. In this dialog type a valid URL to any web page. The web page will be opened in a separate window inside QlikView. This functionality may be used for, for example, the QlikView Publisher Accesspoint or for pages displaying QlikView Server documents via AJAX clients. Opened web pages can be accessed via the Windows menu just as with standard QlikView document windows.
Open FTP... Opens a new QlikView window, allows the opening of a QlikView file or table file from an Ftp server. Opening a table file automatically opens the File Wizard.
Close Closes the active QlikView file.
Favorites This cascade menu controls a list of user-defined favorite documents, managed independently of the Recent documents list (see below).
Save

Saves the present configuration in a QlikView file. Data, script and layout are saved. This command can also be invoked by the following keyboard shortcut: Ctrl+S.

If you want to share a QlikView document using AJAX clients, the file name must not contain hash (#) characters.

Save As...

Saves the present configuration in a new QlikView file under a new name. This command can also be invoked by the following keyboard shortcut: F12.

If you want to share a QlikView document using AJAX clients, the file name must not contain hash (#) characters.

Save Link... Saves a link to a document opened on a QlikView Server as a text file on the local machine. The file will have the qvw extension but will not contain any data or layout. When opening such a link document QlikView will attempt to reconnect to the server and open the document on the QlikView Server. This command is not available for local documents.
Mail as Attachment... Only available when working with a local document. Creates a mail with a copy of the current qvw document attached. The mail recipient will be able to open the qvw document provided he or she has access to QlikView and access rights to the document (if section access security is used). For this command to work a mail client has to be configured on the computer.
Mail with Bookmark as a Link... Only available when working with a QlikView Server document. Creates a mail with a URL link to the current server document. A temporary server bookmark will be created (including layout state) and encoded in the URL. The mail recipient will be able to use the URL link to open the server document and see what you see, obviously provided that he or she has access rights to the document and data therein. A mail client has to be configured on the computer for this command to work. The QlikView Server must be configured to allow server bookmarks
Print... Opens the standard Print dialog, allows to print the current sheet object. This command is not available for list boxes. This command can also be invoked by the following keyboard shortcut: Ctrl+P.
Print as PDF... Opens the Print dialog with the PDF-XChange 3.0 printer pre-selected. This command can also be invoked by the following keyboard shortcut: Ctrl+Shift+P.
Print Possible... Opens the standard Print dialog, allows to print the possible (selected and optional) values of the current list box. This command is only available for list boxes.
Print Possible as PDF... This command must be used when printing list boxes and multi boxes as PDF.
Print Sheet... Opens the Print dialog, allows to print an image of the current sheet.
Print Preview... Shows preview of printable sheet objects
Source Control Settings
Set which MSSCCI (Microsoft Source Code Control Interface) provider dll to use when adding a project or getting a project from source control.

Add Project to Source Control
Saves the opened QlikView document and automatically creates a project folder and project files. Invokes the source control system to add the project to source control.

Get Project from Source Control
Retrieves a project from source control and rebuilds the QlikView document from the project files. QlikView data is not stored in source control. To fill the document with the data the command Reload has to be executed on the rebuilt document.

Get Latest Version
Retrieves the latest version of the document from the source control system and rebuilds the QlikView document.

Check In Pending Changes
Saves the QlikView document and performs a check in operation to the source control system. This can include four different source control operations with their own dialogs:
  • Add newly created files.
  • Undo the checked out files that need to be deleted from the source control.
  • Remove the files that correspond to the removed sheets or sheet objects that are part of the source control.
  • Check in modified files.

If the document was not up to date before the Check In Pending Changes operation, then reopen the document to load the project changes that could be introduced while resolving the conflicts.

 

Undo Pending Changes
Undoes the changes. If there are locally modified files that are not checked out in the Source Control system, those files are checked out before the undo checkout operation is performed. This operation will rebuild the QlikView document by deleting files that were added and not checked in, and references to pending delete files are restored.
Export Export Contents...
This alternative is only available when an exportable sheet object is active. It then performs the export operation found on the sheet object’s Object menu.

Export Sheet Image...
Opens a dialog for saving an image of the current sheet to file.

Export Document Layout
Opens a dialog for saving the document layout as an XML file. No data from the document are saved in the XML file.

Export Sheet Layout...
Opens a dialog for saving the current sheet’s layout as an XML file. No data from the document are saved in the XML file.
Import Import Document Layout
Opens a dialog for importing the document layout of another document saved as XML. No data are imported.

Import Sheet Layout
Opens a dialog for importing the layout from another sheet saved as XML. No data are imported.
Edit Script... Opens the Edit Script dialog. In this it is possible to write and execute scripts that open and connect to databases.
Reload Executes the current load script and reloads data to the active QlikView document. This needs to be done if the contents of the database have been changed since the last time a reload was made. This command can also be invoked by the following keyboard shortcut: Ctrl+R.
Partial Reload Executes the current load script, including all script commands, such as Drop table, and reloads data to the active QlikView document. However, only those tables whose load and select statements are preceded by the Replace or Add prefix are reloaded. Data tables that are not affected by this kind of load or select statements will not be affected by the partial reload. This command can also be invoked by the following keyboard shortcut: Ctrl+Shift+R.
Reduce Data Opens a menu containing the following two commands:

Keep Possible Values
Reduces the QlikView database by removing all excluded values.

Remove All Values
Creates a template by removing all the values from the QlikView database, but keeping the database structure and the layout.
Table Viewer... Opens the Table Viewer dialog where the structure of the loaded data can be studied in a graphical view of tables, fields and associations. This command can also be invoked by the following keyboard shortcut: Ctrl+T.
Recent documents list A listing of the last QlikView documents used. The number of documents shown can be set in the Settings: User Preferences dialog. Default number is 8. Selecting one of these is equivalent to the Open command.
Exit Closes the open documents and exits QlikView.