Formatting Word reports

When creating templates to generate Word reports, the default formatting setting is the QlikView or Qlik Sense formatting. However, you can also use the Word formatting tools.

Note: Table formatting using Word tools only works if you save your template in .docx format, and not in .doc. Save Word templates in .doc format only if necessary for backward compatibility.

Allow application of Word formatting for whole chart

After you have added a QlikView object as a table, for example CH184 in Creating Word reports, do the following:

  1. In the Template Editor, click the CH184 node of the object that you just added.
  2. In the Properties window, clear the Keep Source Formats check box.

    This will cause the contents of all cells in all columns of the table to be exported from QlikView without formatting.

  3. Click the Toolbar button.

Wrap text feature

Selecting Wrap Text causes Qlik NPrinting to automatically create two lines if the cell is too small. This works only when Keep Source Formats is not selected. Wrap Text is a table property that affects all columns of the table.

Apply Word formatting to entire table

Before adding the table to the template, do the following:

  1. Select the Insert tab on the toolbar.
  2. Select Table.
  3. Select the uppermost left cell to insert a 1x1 table into the template.

Add your table to the template

Do the following:

  1. Expand the CH184 node.

  2. Drag and drop them into the table cell in the template. You can select multiple values by keeping Ctrl or Shift pressed during the columns selection.

    This will create all tags and insert them into a horizontal series of cells. The cells may exceed the page layout but this will be addressed in the following subsection.

Set table to AutoFit columns

Do the following:

  1. Select the Layout tab in the Table Tools section of the toolbar.
  2. Click AutoFit in the Cell Size section of the toolbar.
  3. Select AutoFit Contents.

Apply table style

After selecting the table, do the following:

  1. Select the Design tab in the Table Tools section of the toolbar.
  2. Select a general style in the Table Styles section of the toolbar.

Preview and save

Do the following:

  1. Click Preview.
  2. Check the report, close it, and then edit the template again if necessary.
  3. Click Save and Close to save the template and close the Template Editor.

Did this information help you?

Thanks for letting us know. Is there anything you'd like to tell us about this topic?

Can you tell us why it did not help you and how we can improve it?