Skip to main content

System requirements for Qlik NPrinting Engine

ON THIS PAGE

System requirements for Qlik NPrinting Engine

This section lists the minimum hardware and software requirements for Qlik NPrinting Engine.

Qlik NPrinting Engine can be installed on both physical and virtual machines. In both configurations, virtualized applications are not supported. For example, the Qlik NPrinting Engine will not work if it is installed on a different computer from QlikView Desktop, and it is distributed as a virtualized application.

By default, only one Qlik NPrinting Engine is available for each Qlik NPrinting Server license. If you want to add additional engines to your Qlik NPrinting environment, you need to purchase them.

Requirements

These Qlik NPrinting Engine requirements are for configurations where each Qlik NPrinting component is installed on a different computer. If you install more than one component (for example, the server and the engine) on the same computer, the minimum hardware requirements increase.

  • Platforms:
    • Microsoft Windows Server 2012
    • Microsoft Windows Server 2012 R2
    • Microsoft Windows Server 2016
    • Microsoft Windows Server 2019
  • Processors (CPUs): Multi-core x64 compatible processors with a minimum of two cores.
  • Memory: 2 GB is required for each core with a minimum of 4 GB of RAM in total.
    • QlikView Desktop must have enough memory to manage the QlikView documents that you use as reporting data sources.
    • A MultiDoc report is a report with data from many QlikView documents. If you create MultiDoc reports, all QlikView documents used as data sources will be opened at the same time.

    • Connecting additional Qlik Sense servers will have an impact on Qlik NPrinting Server system resources.You may need to increase the RAM and CPU usage on Qlik Qlik NPrinting Engine and Qlik NPrinting Server computers if you connect to multiple Qlik Sense.

  • Disk space: 300 MB minimum
  • Storage: Only Windows, local or shared, storage is supported.
  • Server clocks:

    Qlik NPrinting Server and Qlik NPrinting EngineWindows server clocks must be synchronized within a tolerance of 2 seconds. A Windows server synchronizes its clock with the domain controller clock, so, if Qlik NPrinting Server and Qlik NPrinting Engine are in the same domain, clocks will be in sync. You should not manually remove this option. If you install Qlik NPrinting Server and Qlik NPrinting Engine on different Windows server domains, you must ensure that clocks are synchronized within a tolerance of 2 seconds.

  • Platform security: TLS 1.2 must be enabled.
  • Note: License activations request access to the Qlik Licensing Service. Open port 443 and allow outbound calls to license.qlikcloud.com.

    Use of a proxy is supported. For more information about setting up a proxy service in Windows, see Licensing service proxy Setup

QlikView compatibility with Qlik NPrinting

QlikView Desktop is required for QlikView connection with Qlik NPrinting and must be installed on each Qlik NPrinting Engine computer.

If using server or cluster connections, QlikView Server and QlikView Desktop must be on the same version.

The following versions of QlikView are supported for connection with Qlik NPrinting:

  • QlikView November 2017 (12.20) or higher

  • QlikView November 2018 (12.30) SR1 or higher

  • QlikView April 2019 (12.40) or higher

  • QlikView April 2020 SR2 (12.50 SR2) or later
  • QlikView May 2021 (12.60) or higher
  • Warning: QlikView Desktop Personal Edition is not supported.
    Warning: QlikView in SaaS editions of Qlik Sense is not supported.

If you are migrating from QlikView NPrinting 16 to Qlik NPrinting November 2019 or newer, you may need to upgrade your QlikView version. See: Upgrading QlikView NPrinting 16 before migration.

Qlik Sense compatibility with Qlik NPrinting

The following Qlik Sense versions are supported when connecting to Qlik NPrinting. Note that your Qlik NPrinting version must be equal to or newer than your Qlik Sense on Windows version:

  • Qlik Sense Enterprise on Windows November 2017 or later.
  • Qlik NPrinting 17.2.1 or later is required to connect to Qlik Sense 3.1.2 or newer.

  • Qlik Sense 2.3 or later is required to create connections to Qlik Sense apps.

  • Qlik Sense 3.0.1 or later is required to distribute reports to a Qlik Sense hub.

  • Qlik Sense 3.1 or later is required if you are connecting to multiple Qlik Sense servers.

No client software is required for connecting Qlik Sense with Qlik NPrinting.

Note: SaaS editions of Qlik Sense and Qlik Sense Enterprise on Kubernetes are not supported for connecting to Qlik NPrinting.

Additional software installed

The following software is installed during the Qlik NPrinting Engine setup, unless it is already installed. It must not be removed:

  • PDF X-CHANGE 5.0.269
  • .NET framework: 4.7.2 or later

    .NET framework version 4.7.2 is installed when you install Qlik NPrinting Server, Qlik NPrinting Engine, or Qlik NPrinting Designer. The installation of .NET framework version 4.7.2 requires an active internet connection. If .NET framework version 4.7.2 or later is not already installed on a computer without an internet connection, the installation will fail. You must install the .NET framework version 4.7.2 or later on computers without and internet connection before you install Qlik NPrinting Server, Qlik NPrinting Engine, or Qlik NPrinting Designer.If an internet connection is not available on a computer with .NET framework version 4.7.2 or later already installed, the installer will skip this part of the installation.