Trichterdiagramm

Diagramme sind grafische Darstellungen numerischer Daten. Das Trichterdiagramm eignet sich besonders gut für die Darstellung von Verteilungs- und Prozessdaten. Es ähnelt in seiner Logik dem Kreisdiagramm. Die Segmente hängen in der Höhe (bzw. Breite bei horizontaler Ausrichtung) oder in der Fläche vom Formelwert ab. Alternativ können Segmente gleicher Höhe bzw. Breite verwendet werden, wobei es sich empfiehlt, die Formelwerte numerisch anzeigen zu lassen.

Es ist möglich, zwischen verschiedenen Darstellungen eines vorhandenen Diagramms zu wechseln, indem der Diagrammtyp im Dialogfeld Diagrammeigenschaften: Allgemein geändert wird.

Durch Klicken mit der rechten Maustaste auf das Trichterdiagramm wird das Trichterdiagramm: Objekt-Menü angezeigt. Dasselbe Menü finden Sie unter Objekt auf der Menüleiste, wenn das Trichterdiagramm aktiv ist.

Objekt-Menü

Klicken Sie mit der rechten Maustaste auf ein Diagramm. Ein Menü wird geöffnet. Sie können das Menü auch im Hauptmenü über Objekt aufrufen, wenn ein Diagramm aktiv ist.

Das Menü enthält folgende Befehle:

Eigenschaften Durch den Befehl „Eigenschaften“ gelangen Sie in den Dialog Eigenschaften. Dort können Sie das Diagramm bearbeiten.
Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Trennen Dem Diagrammtitel wird der Text „(Getrennt)“ angehängt und die Tabelle wird nicht mehr mit den im Dokument vorgenommenen Auswahlen aktualisiert (dennoch können im Diagramm weiterhin Auswahlen getroffen werden). Der Befehl ist nur verfügbar, wenn das Diagramm verbunden ist. Um ein Diagramm bei verschiedenem Auswahlstatus zu vergleichen, kann man eine Kopie des Diagramms machen und diese trennen.
Verbinden Dieser Befehl verbindet ein getrenntes Diagramm wieder mit den zugrunde liegenden Daten. Das Diagramm wird dynamisch mit den Daten verknüpft. Der Befehl ist nur verfügbar, wenn das Diagramm getrennt wurde.
Referenz setzen Blendet eine Referenz der momentanen Grafik ein. Bei weiteren Auswahlaktionen bleiben diese unverändert im Hintergrund sichtbar, so dass die Daten verglichen werden können. Die Achsen werden dabei so angepasst, dass sowohl die momentanen Daten als auch die Referenz möglichst vollständig sichtbar sind. Die Referenz steht im Hintergrund und wird möglicherweise von den momentanen Daten verdeckt. Die Farbe der Referenz kann durch die Option Referenzmodus auf der Seite Diagrammeigenschaften: Allgemein eingestellt werden. Referenzen sind nur in bestimmten Diagrammtypen anwendbar, z. B. in Balkendiagrammen, Liniendiagrammen, Kombinationsdiagrammen, Radar-Diagrammen, Punktdiagrammen, Gitternetzdiagrammen und Messzeiger-Diagrammen mit Nadeln. Enthält das Diagramm eine Drilldown- oder zyklische Gruppe, können keine Referenzen gesetzt werden. Beim Schließen des Dokuments und bei der Ausführung des Skripts verschwindet die Referenz. Die maximale Anzahl der Objekte, die einbezogen werden, wenn die Option Referenz setzen auf 500 eingestellt ist.
Referenz löschen Dieser Befehl wird durch den Befehl Referenz setzen ersetzt, wenn eine Referenz gesetzt wurde. Dadurch wird die bereits festgelegte Referenz gelöscht und das Diagramm wird in den normalen Anzeigemodus zurückgesetzt.
Kopie erstellen Erstellt eine Kopie des Diagramms auf dem Arbeitsblatt. Beim Kopieren von getrennten Diagrammen ist die Kopie verbunden.
Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Auswahl aufheben (alle Felder) Hebt die Auswahl in allen Dimensionen des Diagramms auf.
Drucken… Öffnet den Dialog Drucken, wo Sie die Druckeinstellungen vornehmen können.
Als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Werte nach Excel exportieren Exportiert die dem Diagramm zugrundeliegenden Werte nach Excel, das automatisch gestartet wird, falls es noch nicht ausgeführt wird. Die Tabelle erscheint auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.
Exportieren Exportiert das Diagramm in eine Bilddatei. Als Dateiformate stehen png, jpg, bmp und gif zur Verfügung.
In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Werte
Kopiert die Werte in Form einer Tabelle in die Zwischenablage.
Bild
Kopiert ein Bild des Diagrammobjekts in die Zwischenablage. Das Bild enthält oder enthält nicht die Titelleiste und den Rahmen des Arbeitsblattobjekts, je nach den Einstellungen auf der Seite Benutzereinstellungen: Exportieren.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Eigenschaften des Diagramms: Allgemein

Im Dialog Allgemein legen Sie unter anderem Diagrammtyp und -titel fest. Er wird auf der ersten Seite des Assistenten für Quick-Diagramme sowie im Dialog Eigenschaften des Diagramms angezeigt.

Fenstertitel

Der Text dieses Eingabefeldes erscheint in der Titelleiste der Diagrammbox. Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Diagrammtitel anzeigen

Standardmäßig dient die Bezeichnung der ersten Formel als Diagrammtitel. Deaktivieren Sie diese Option, wenn kein Diagrammtitel angezeigt werden soll. Löschen Sie das Eingabefeld, um zum ursprünglichen Titel zurückzukehren. Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt. Tabellendiagramme und Pivottabellen haben grundsätzlich keinen Diagrammtitel.

Formelsyntax in dynamischen Ausdrücken

Diagrammtitel formatieren Führt in den Dialog Diagrammtitel formatieren, wo Sie die Schriftart und -größe für den Diagrammtitel festlegen können.
Druckoptionen

Die Schaltfläche Druckoptionen führt in den Dialog Druckoptionen. Dort können Sie Seitenränder, Kopf- und Fußzeilen für den Druck des Objekts definieren. Der Dialog Druckoptionen enthält zwei Seiten, Druck-Layout und Drucken, Kopfzeile/Fußzeile.

Drucken: Layout und Drucken: Kopfzeile/Fußzeile

Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Für Diagramme beginnt die ID mit CH01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Interner Makro-Interpreter

Getrennt Ist diese Option aktiviert, ist das Diagramm von den zugrunde liegenden Daten getrennt und wird bei der Auswahl von Werten nicht aktualisiert.
Read Only Versetzt das Diagramm in den Read-Only-Modus, d. h. es können keine Werte darin ausgewählt werden.
Bedingung für die Berechnung Steht in diesem Feld eine logische Formel, wird das Diagramm nur dann berechnet und angezeigt, wenn die Bedingung erfüllt ist. Andernfalls erscheint der Text "Bedingung für die Berechnung nicht erfüllt". Der Wert kann als dynamischer Ausdruck eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten.
Diagrammtyp Unter Diagrammtyp wählen Sie den Typ des Diagramms per Mausklick auf das entsprechende Icon. Eine Übersicht finden Sie auf der Seite Diagrammtypen.
Schneller Typwechsel Hier können Sie den schnellen Wechsel des Diagrammtyps per Mausklick, d. h. ohne den Umweg über den Eigenschaftsdialog aktivieren.
Zulässige Typen
In dieser Liste wählen Sie, welche Diagrammtypen im Dropdown-Menü angezeigt werden sollen. Wählen Sie die Diagrammtypen, zwischen denen ein schneller Typwechsel zugelassen sein soll.
Bevorzugte Symbolposition
Entscheiden Sie, ob das Symbol für schnellen Typwechsel im Diagramm oder in der Titelleiste des Arbeitsblattobjekts angezeigt werden soll. Diese Option steht nur für grafische Diagramme, nicht aber für Tabellen zur Verfügung.
Elemente Originalgröße Per Mausklick auf diese Schaltfläche werden Größenänderungen der Elemente in grafischen Diagrammen rückgängig gemacht. Die Originalposition einzelner Elemente ist nicht betroffen.
Elemente Originalposition Per Mausklick auf diese Schaltfläche werden verschobene Elemente in grafischen Diagrammen an ihre alte Position zurückgesetzt.
Fehlermeldungen

Öffnet den Dialog Benutzerdefinierte Fehlermeldungen.

Benutzerdefinierte Fehlermeldungen

Referenzmodus Hier legen Sie fest, wie die Referenz dargestellt wird, wenn im Objekt-Menü des Diagramms eine solche gesetzt wird. Referenzen sind nur für bestimmte Diagrammtypen verfügbar.

Eigenschaften des Diagramms: Dimensionen

Auf die Seite Diagrammeigenschaften: Dimensionen greifen Sie durch Rechtsklicken auf ein Diagramm zu. Dort wählen Sie Eigenschaften aus. Oder Sie wählen Eigenschaften im Objekt-Menü aus, wenn das Diagramm aktiv ist.

Beim Anlegen eines Diagramms sind zunächst zwei Dinge zu bedenken:

  • Was möchten Sie sich ansehen? Was sollen die Balken in einem Balkendiagramm wie groß anzeigen? Das könnten z. B. Summen von Verkaufszahlen sein. Diese Einstellung nehmen Sie auf der Seite Formeln vor.
  • Wonach möchten Sie gruppieren? Welche Feldwerte sollen als Bezeichnung für die Balken im Balkendiagramm dienen? Die Gruppierung kann beispielsweise pro Land oder pro Jahr erfolgen. Diese Einstellung nehmen Sie auf der Seite Dimensionen vor.

Ein Diagramm kann auch mehrere Dimensionen anzeigen. Die maximale Zahl von Dimensionen variiert je nach Diagrammtyp, Komplexität der Daten und Speicherplatz. In Kreis-, Linien- und Punktdiagrammen können maximal zwei Dimensionen dargestellt werden, in Balken- und Matrixdiagrammen maximal drei. Netz- und Trichterdiagramme enthalten nur eine Dimension. In Messzeiger-Diagrammen werden gar keine Dimensionen benutzt. Weitere Dimensionen werden ignoriert.

Die Werte einer Diagrammdimension werden einem Feld entnommen, das auf der Seite Diagrammeigenschaften: Dimensionen definiert wird. Anstelle eines einzelnen Feldes kann eine Dimension auch aus einer Gruppe von Feldern bestehen (siehe Gruppen bearbeiten).

Felder, Gruppen oder Formeln (dynamische Dimensionen) können als Dimensionen verwendet werden. Es kann auch eine synthetische Dimension sein.

Funktionen für synthetische Dimensionen

Durch Klicken auf die Schaltflächen (Mausklick, Strg-Klick) Hinzufügen>> und <<Entfernen sowie per Doppelklick verschieben Sie das markierte Feld zurück in die Liste der verfügbaren Felder/Gruppen.

Es ist aber auch möglich, Dimensionen in Diagrammen über eine Formel zu berechnen.

Diese Eigenschaftenseite wird zum Definieren von Dimensionen verwendet.

Verfügbare Felder/Gruppen

Auflistung aller verfügbaren Felder/Feldgruppen zur Verwendung als Dimension (z. B. entlant der x-Achse eines Balkendiagramms). Feldgruppen ist ein vertikaler Pfeil vorangestellt, wenn es sich um Drilldown-Gruppen handelt, oder ein gebogener Pfeil, wenn es sich um eine zyklische Gruppe handelt. Gruppen werden auf der Seite Eigenschaften des Dokuments: Gruppen definiert. Markieren Sie per Mausklick die Elemente, die Sie verwenden/entfernen möchten. Verschieben Sie sie mit den Schaltflächen Hinzufügen > oder < Entfernen in die gewünschte Spalte.
Die Zahl der möglichen Dimensionen variiert je nach Diagrammtyp.
Alle Felder, die in mehr als einer internen Tabelle erscheinen, werden mit einem kleinen Schlüssel gekennzeichnet. Kreisdiagramme, Liniendiagramme und Punktdiagramme können nicht mehr als zwei Dimensionen darstellen. In Balkendiagrammen können bis zu drei Dimensionen angezeigt werden.

Dokumenteigenschaften: Gruppen

Systemfelder anzeigen Aktivieren Sie diese Option, wenn in der Liste Verfügbare Felder/Gruppen die Systemfelder mit angezeigt werden sollen.
Felder aus Tabelle Hier legen Sie fest, welche Felder/Gruppen in der Liste Verfügbare Felder/Gruppen angezeigt werden. In der Dropdown-Liste wird die Alternative Alle Tabellen standardmäßig angezeigt.
Durch die Option Alle Tabellen (qualifiziert) werden den Feldnamen die Namen der Tabellen, in denen sie vorkommen, vorangestellt. Dies bedeutet, dass wichtige Felder (zur Verbindung) mehr als einmal gelistet werden. (Diese Alternative betrifft nur die Anzeige, nicht jedoch die Qualify-Felder im Skript.)
Sie können auch nur die Felder einer Tabelle anzeigen. Beachten Sie, dass verfügbare Gruppen immer aufgeführt werden.
Gruppen bearbeiten Über diese Schaltfläche gelangen Sie direkt zur Seite Eigenschaften des Dokuments: Gruppen, auf der Feldergruppen, die als Dimensionen verwendet werden, definiert werden können.
Animation Führt in den Dialog Animation, wo Sie eine Animation des Diagramms über die erste Dimension einstellen können. Dies ist nur für grafische Diagramme mit Ausnahme von Kreisdiagrammen möglich. Animierte Diagramme sind gegebenenfalls in ihrer Funktionalität eingeschränkt.
Gitterdiagramm Führt in den Dialog Gitterdiagramm. Dort können Sie ein Gitterdiagramm definieren, bei dem für jeden Wert der Dimension ein eigenes kleines Diagramm angezeigt wird. Jede Art grafisches Diagramm kann als Gitterdiagramm dargestellt werden.
Dimensionen des Diagramms

Liste der Dimensionen des Diagramms. Die Zahl der zulässigen Dimensionen hängt vom Diagrammtyp ab. Falls zu viele Dimensionen definiert sind, werden diese ignoriert. In Tabellen kann die Darstellung der Datenzellen der Dimensionen durch Attributformeln gestaltet werden. Ist eine Attributformel definiert, erscheint ihr Symbol farbig statt grau oder bei Textformatschwarz statt grau. Die Gestaltung durch Attributformeln hat Vorrang vor den normalen Einstellungen des Diagramms. Wenn Sie auf das Pluszeichen vor der Dimension klicken, erscheinen Platzhalter oder Attributformeln der Dimension.
Hintergrundfarbe
Doppelklicken Sie auf Hintergrundfarbe, um eine Attributformel für die Berechnung der Hintergrundfarbe der Dimensionszelle einzugeben. Die verwendete Formel muss eine gültige Farbe ergeben, wie sie in Visual Basic definiert ist, (d. h. mit Rot-, Grün- und Blau-Anteilen). Dies erreichen Sie mit Hilfe der Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.
Textfarbe
Doppelklicken Sie auf Textfarbe, um eine Attributformel für die Berechnung der Textfarbe der Dimensionszelle einzugeben. Die verwendete Formel muss eine gültige Farbe ergeben, wie sie in Visual Basic definiert ist, (d. h. mit Rot-, Grün- und Blau-Anteilen). Dies erreichen Sie mit Hilfe der Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Farbfunktionen

Textformat
Doppelklicken Sie auf Textformat, um eine Attributformel für die Berechnung der Schriftart für den Text in der Tabellenzelle für jede Dimensionszelle einzugeben. Die als Textformatformel verwendete Formel muss einen String liefern, der '<B>' für fett, '<I>' für kursiv und/oder '<U>' für unterstrichen enthält.

Durch die Schaltflächen Nach vorn und Nach hinten lässt sich die Reihenfolge der Dimensionen des Diagramms ändern.

Neue dynamische Dimension...

Öffnet den Dialog Formel bearbeiten zum Hinzufügen und Bearbeiten einer neuen dynamischen Dimension. Die Dimension eines Diagramms ist häufig ein einzelnes Feld, es kann jedoch auch eine Formel bzw. dynamische Dimension verwendet werden. Eine dynamische Dimension besteht aus einer Formel mit einem oder mehreren Feldern. Alle Standardfunktionen dürfen verwendet werden. Aggregierungsfunktionen dürfen nicht verwendet werden, doch mit Hilfe der Funktion Aggr kann eine verschachtelte Aggregierung erreicht werden.

Formelsyntax in dynamischen Ausdrücken

Bearbeiten Öffnet die Dimension zum Bearbeiten im Dialog Formel bearbeiten. Einzelheiten dazu finden Sie unter Neue dynamische Dimension... oben.
Einstellungen für markierte Dimension

In dieser Gruppe finden Sie Einstellungen für einzelne Dimensionen.
Bedingung
Mit dieser Option können Sie die Dimension dynamisch ein- oder ausblenden, je nachdem, welchen Wert einer Bedingungsformel Sie eingegeben haben. Dazu klicken Sie auf die Schaltfläche ... in der Bearbeitungsbox unten.

NULL-Werte weglassen
Ist diese Option aktiviert, werden NULL-Werte der unter Dimensionen des Diagramms ausgewählten Dimensionen nicht im Diagramm angezeigt.
Alle anzeigen
Aktivieren Sie diese Option, um alle Dimensionswerte anzuzeigen, unabhängig davon, was ausgewählt wurde. Wenn der Formelwert für die ausgeschlossenen Dimensionswerte Null ist, muss die Option Null-Werte weglassen auf der Seite Präsentation deaktiviert sein. Andernfalls funktioniert die Option Alle Werte anzeigen nicht. Alle Werte anzeigen gilt nicht, wenn Sie eine Formel als Dimension verwenden.
Legende anzeigen
Ist die Option Legende anzeigen aktiviert, erscheinen die Werte der Dimension als Beschriftung auf der x-Achse.
Bezeichnung
Ist die Option Bezeichnung aktiviert, wird die Feldbezeichnung angezeigt. In den Eingabefeldern können Sie die Bezeichnungen bearbeiten. Bezeichnungen können auch als dynamischer Ausdruck eingegeben werden. Sie werden dann dynamisch aktualisiert. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Erweitert
Öffnet den Dialog Erweiterte Einstellungen für markiertes Feld, wo Ihnen Optionen für eine grafische Interpretation der Werte und spezielle Suchfunktionen zur Verfügung stehen.

Advanced Field Settings

Kommentar
Ein Kommentarfeld, in dem die ausgewählte Dimension beschrieben werden kann. Der Kommentar kann mit Hilfe eines dynamischen Ausdrucks eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten.
Seitenumbrüche
Hier können Sie Seitenumbrüche für den Ausdruck von Pivottabellen und Tabellendiagrammen einfügen. Es sind drei Modi verfügbar, die folgende Auswirkung haben:

Keine Umbrüche
Es werden nur Seitenumbrüche wie erforderlich am Ende jeder Seite eingefügt.
Nach Bedarf
Es wird immer dann ein Seitenumbruch eingefügt, wenn die Zeilen für den jeweils nächsten Wert der Dimension nicht mehr komplett auf die Seite passen würden.
Bei jedem neuen Wert
Es wird jedes Mal ein Seitenumbruch eingefügt, wenn sich der Dimensionswert ändert.

Eigenschaften des Diagramms: Beschränkung der Dimension

Dimensionsgrenzen können für Diagrammtypen definiert werden – außer für Messzeiger-Diagramme und Pivottabellen.

Auf dem Registerreiter für Dimensionsgrenzen ist die Anzahl der Dimensionswerte festgelegt, die in einem Diagramm angezeigt wird.

Vorher ist es jedoch wichtig, den Effekt zu beschrieben, den die drei Optionen im Dropdown-Fenster hervorrufen. Das Dropdown-Fenster enthält drei Werte: Erste, Größte und Kleinste. Diese Werte steuern, wie die Formelverwaltung die Werte sortiert, die zur Diagrammverwaltung zurückgegeben werden. Eine dieser Optionen muss ausgewählt sein, wenn die Dimension eingeschränkt werden soll. Der Sortiervorgang wird nur für die erste Formel ausgeführt. In Pivottabellen ist es jedoch möglich, dass die Primärsortierung Vorrang vor der ersten Dimensionssortierung hat.

Diese Eigenschaftenseite wird zum Definieren von Dimensionsgrenzen verwendet. Jede Dimension im Diagramm wird separat konfiguriert.

Grenzen

Schränkt die Werte ein, die mit der ersten Formel angezeigt werden
Diese Eigenschaften werden zur Festlegung verwendet, wie viele Dimensionswerte im Diagramm entsprechend den nachfolgenden Einstellungen dargestellt werden.

Anzeige einschränken auf
Wählen Sie diese Option, falls Sie eine bestimmte Anzahl der ersten, größten oder kleinsten Werte anzeigen möchten. Wird diese Option auf 5 eingestellt, werden fünf Werte angezeigt. Wurde für die Dimension Sonstige anzeigen aktiviert, nimmt das andere Segment einen der fünf Anzeigenplätze ein.

Die Option Erste gibt die Zeilen zurück, basierend auf den Optionen, die auf dem Registerblatt Sortieren des Eigenschaften-Dialogs gewählt sind. Ist das Diagramm ein Tabellendiagramm, werden die Zeilen basierend auf der zurzeit primären Sortierung zurückgegeben. Ein Benutzer kann also die angezeigten Werte ändern, indem er eine Spalte per Doppelklick auf einer beliebigen Spaltenüberschrift zum primären Sortierziel bestimmt.

Die Option Größte gibt die Zeilen in absteigender Reihenfolge basierend auf der ersten Formel im Diagramm zurück. Bei Verwendung in einem Tabellendiagramm bleiben die angezeigten Dimensionswerte konsistent, während die Formeln interaktiv sortiert werden. Die Dimensionswerte ändern sich (können sich ändern), wenn die Reihenfolge der Formeln geändert wird.

Die Option Kleinste gibt die Zeilen in aufsteigender Reihenfolge basierend auf der ersten Formel im Diagramm zurück. Bei Verwendung in einem Tabellendiagramm bleiben die angezeigten Dimensionswerte konsistent, während die Formeln interaktiv sortiert werden. Die Dimensionswerte ändern sich (können sich ändern), wenn die Reihenfolge der Formeln geändert wird.

Geben Sie die Anzahl der darzustellenden Werte ein. Der Wert kann als dynamischer Ausdruck eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten.

Höhe des Werts:
Wählen Sie diese Option, um alle Dimensionswerte anzuzeigen, die der angegebenen Bedingung für diese Option entsprechen. Wählen Sie diese Option, um Werte basierend auf einem Prozentsatz des Ganzen oder einem genauen Wert anzuzeigen. Die Option relativ zum Gesamten aktiviert einen relativen Modus, der der Option Relativ im Registerblatt Formeln des Eigenschaftendialogs ähnelt. Der Wert kann als dynamischer Ausdruck eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten.

Nur Werte anzeigen, die wie folgt akkumulieren:
Wenn diese Option ausgewählt ist, dann werden alle Zeilen bis zur aktuellen Zeile akkumuliert, und das Ergebnis wird mit dem in der Option festgelegten Wert verglichen. Die Option Relativ zum Gesamten aktiviert einen relativen Modus, der der Option Relativ im Registerblatt Formeln im Eigenschaftendialog ähnelt. Sie vergleicht die akkumulierten Werte (auf Basis von erstem, größtem und kleinstem Wert) mit dem Gesamtwert. Der Wert kann als dynamischer Ausdruck eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten. Wählen Sie die Option Grenzwerte einbeziehen aus, um den Dimensionswert einzuschließen, der den Vergleichswert enthält.

Formelsyntax in dynamischen Ausdrücken

Hinweis: Negative Werte werden nicht berücksichtigt, wenn die akkumulierte Beschränkungssumme berechnet wird. Wir empfehlen, dass Sie keine relativen Beschränkungen für Felder verwenden, die negative Werte enthalten.
Hinweis: Wenn Sie zu einer dynamischen Dimension eine Beschränkung hinzufügen und die Daten für diese dynamische Dimension sortiert sind, wird die Beschränkung vor der Sortierfolge angewendet.
Optionen Sonstige anzeigen
Die Aktivierung dieser Option erzeugt ein Segment Sonstige im Diagramm. Alle Dimensionswerte, die nicht den Vergleichskriterien für die Anzeigenbeschränkungen entsprechen, werden im Segment Sonstige zusammengefasst. Befinden sich Dimensionen nach der gewählten Dimension, steuert Weitere Dimensionen ausblenden, ob einzelne Werte für die folgende / innere Dimensionen-Anzeige im Diagramm dargestellt werden.

Bezeichnung
Geben Sie den im Diagramm anzuzeigenden Namen ein. Bei fehlender Eingabe wird die Bezeichnung automatisch auf den Text der Formel eingestellt. Der Wert kann als dynamischer Ausdruck eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten.

Gesamtwert anzeigen
Nach Aktivierung dieser Option zeigt das Diagramm einen Gesamtwert für die gewählte Dimension an. Dieser Gesamtwert unterscheidet sich vom Gesamtwert der Formel, der auf der Registerkarte Formeln im Eigenschaften-Dialogfeld konfiguriert ist.

Bezeichnung
Geben Sie den im Diagramm anzuzeigenden Namen ein. Bei fehlender Eingabe wird die Bezeichnung automatisch auf den Text der Formel eingestellt. Der Wert kann als dynamischer Ausdruck eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten.

Globaler Gruppierungsmodus
Diese Option gilt nur für innere Dimensionen. Nach Aktivierung dieser Option werden die Beschränkungen nur auf Grundlage der gewählten Dimension berechnet. Alle vorhergehenden Dimensionen werden ignoriert. Bei einer Deaktivierung werden die Beschränkungen basierend auf allen vorhergehenden Dimensionen berechnet.

Formel über alle Werte im Vergleich zu Dimensionen über alle Werte

Dimensionen über alle Werte werden von der Formelverwaltung generiert und dann als separate Zeilen (oder Dimensionswerte) zurück an die Diagrammverwaltung gegeben. Dies wirkt sich auf die Zeilen für Sonstige aus. Der Unterschied zwischen der Verwendung von Formel über alle Werte und Dimensionen über alle Werte wird unten dargestellt.

Formel über alle Werte und Dimensionen über alle Werte

Wird Dimensionen über alle Werte verwendet, können Sie in Tabellendiagrammen mit Teilsummen arbeiten.

Eigenschaften des Diagramms: Formeln

Zum Öffnen der Registerkarte Diagrammeigenschaften: Formeln klicken Sie mit der rechten Maustaste auf ein Diagramm oder eine Tabelle und wählen Sie Eigenschaften aus dem Objekt-Menü aus.

Beim Anlegen eines Diagramms sind zwei Dinge zu bedenken:

  • Welche Daten sollen angezeigt werden, d. h. was soll die Balkenhöhe im Balkendiagramm angeben? Das können z. B. Summen von Verkaufszahlen sein. Dies ist die Formel.
  • Wonach sollen die angezeigten Daten gruppiert werden? Die Gruppierung kann beispielsweise pro Jahr erfolgen. Dies ist die Dimension.
Hinweis: Das Registerblatt Formeln variiert je nach Diagramm- und Tabellentyp. Grau unterlegte Optionen sind für den entsprechenden Diagramm- oder Tabellentyp nicht verfügbar.
Formelliste

Die Formelliste in der linken oberen Ecke enthält die Berechnungen der Formeln. Die Liste hat die Form einer Baumstruktur.
Vor jeder Formel (oder Gruppe von Formeln) wird das Symbol ( ' + ' ) angezeigt. Wenn Sie darauf klicken, werden Hilfsformeln und Attributformeln (sofern vorhanden) angezeigt. Gleichzeitig wird das Symbol durch das Reduzierungssymbol ( ' - ' ) ersetzt. Manche Darstellungsformen erfordern mehrere Hilfsformeln, welche die Darstellung definieren (z. B. Kurschart oder Boxplot, Beschreibung weiter unten).
Mit Hilfe von Attributformeln kann die Darstellung dynamisch gestaltet werden. Klicken Sie auf [+] vor der Formel, um die Platzhalter für die Attributformeln der Dimension einzublenden. Dies sind:

Hintergrundfarbe
Bearbeiten Sie die Standardformel für die Hintergrundfarbe, um die Attributformel zum Berechnen der Anzeigefarbe des Datenpunkts zu erstellen. Die Attributformel muss eine gültige QlikView-Farbe ergeben. Dies erreichen Sie mit Hilfe der Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet. Analog können Sie eine Formel für die Textfarbe definieren.

Farbfunktionen

Textfarbe
Sie können mit der gleichen Methode wie für die Hintergrundfarbe eine Hilfsformel für die Textfarbe erstellen (siehe weiter oben).

Textformat
Bearbeiten Sie die Formel für das Textformat, um eine Attributformel zum Berechnen der Schriftart des für den Datenpunkt angezeigten Texts (bzw. bei Tabellen des Textes in der Tabellenzelle für jede Dimensionszelle) einzugeben. Das berechnete Textformat hat Vorrang vor den Einstellungen des Tabellendesigns, das in Diagrammeigenschaften: Design. Die als Textformatformel verwendete Formel muss einen String liefern, der '<B>' für fett, '<I>' für kursiv und/oder '<U>' für unterstrichen enthält. Vor dem String muss ein Gleichheitszeichen = stehen.

Segment ausrücken
Klicken Sie auf Segment ausrücken, um eine Attributformel einzugeben, die berechnet, ob und welche Segmente aus dem Kreisdiagramm ausgerückt und dadurch hervorgehoben werden. Diese Attributformel wirkt sich nur auf Kreisdiagramme aus.

Balkensockel
Klicken Sie auf Balkensockel, um eine Attributformel zur Berechnung des Abstands des Balken bzw. Balkensegments für den Datenpunkt von der x-Achse einzugeben. Die Formel kann sowohl einen positiven als auch einen negativen Wert ergeben. Der Balken bzw. das Segment wird entsprechend verschoben. Dies ist insbesondere für das Anlegen von Wasserfalldiagrammen sinnvoll. Nur für Balkendiagramme.

Linienart
Klicken Sie auf Linienart zur Eingabe einer Attributformel zur Berechnung einer Linienart für eine Linie oder ein mit dem Datenpunkt verbundenen Liniensegment. Dieser Typ von Attributformel wirkt sich nur auf Linien-, Kombi- und Netzdiagramme aus. Die Linienbreite regulieren Sie durch den Parameter Wn, wobei n ein multiplizierender Faktor ist, mit dem die eingestellte Standardlinienbreite multipliziert wird. Die Zahl n muss eine reelle Zahl zwischen 0,5 und 8 sein. Beispiel: <W2,5>. Die Art der Linie regulieren Sie durch den Parameter <Sn>, wobei n eine ganze Zahl zwischen 1 und 4 ist (1 = durchgezogene Linie, 2 = gestrichelt, 3 = gepunktet, 4 = Strich-Punkt). Beispiel: <S3>. <Wn> und <Sn> können frei kombiniert werden, es wird aber nur das jeweils erste Auftreten berücksichtigt. Die Tags müssen in einfachen Anführungszeichen stehen.

Wert anzeigen
Klicken Sie auf Wert anzeigen, um eine Attributformel einzugeben, die berechnet, ob der Datenpunktplatz mit einem Wert für „Werte in der Grafik“ ergänzt werden soll, selbst wenn Werte in der Grafik für die Hauptformel nicht ausgewählt wurde. Ist die Option Werte in der Grafik für die Hauptformel ausgewählt, wird die Attributformel ignoriert. Nur für Balken-, Linien-, Kreis-, Trichter- und Kombi-Diagramme.

Add Neue Formeln (auch Hilfs- oder Attributformeln) können Sie über die Schaltfläche Einfügen definieren. Diese Option finden Sie auch im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet.
Löschen Per Mausklick auf Löschen löschen Sie die markierte Formel. Diese Option finden Sie auch im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet.
Kopieren Den Befehl Kopieren finden Sie nur im Formelmenü, das sich durch rechten Mausklick auf eine Formel oder Hilfs-/Attributformel öffnet. Wenn Sie diesen Befehl für eine Hauptformel verwenden, werden alle mit der Formel (einschließlich Bezeichnung) verbundenen Daten und Einstellungen im XML-Format in die Zwischenablage kopiert. Die Formel kann dann an anderer Stelle in ein QlikView-Diagramm im selben oder in einem anderen Dokument eingefügt werden. Der Befehl kann auch auf Attributformeln angewendet werden. In diesem Fall wird nur die Definition der Attributformel kopiert. Die Attributformel kann in jede Formel in demselben oder einem anderen Diagramm eingefügt werden.
Exportieren Den Befehl Exportieren... finden Sie nur im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet. Wenn Sie diesen Befehl für eine Hauptformel verwenden, werden alle mit der Formel (einschließlich Bezeichnung) verbundenen Daten und Einstellungen in eine XML-Datei exportiert. Eine exportierte Formel kann im selben oder in einem anderen QlikView-Dokument wieder importiert werden. Im Dialog Formel exportieren können Sie den Speicherort wählen. Die Formeldatei erhält die Dateierweiterung Ex.xml.
Einfügen Den Befehl Einfügen finden Sie nur im Formelmenü, das sich durch rechten Mausklick auf eine Formel oder Hilfs-/Attributformel öffnet. Eine zuvor in die Zwischenablage kopierte Formel wird in die Formelliste eingefügt. Dadurch wird eine neue Formel erstellt, die mit der kopierten identisch ist. Wurde eine Attributformel kopiert, können Sie sie in eine Hauptformel einfügen.
Importieren Den Befehl Importieren finden Sie nur im Formelmenü, das sich durch rechten Mausklick auf eine leere Stelle in der Formelliste öffnet. In einem daraufhin geöffneten Dialog können Sie zu der zuvor exportierten Formel navigieren. Die importierte Formel wird im Diagramm als neue Formel angezeigt.
Nach oben
Nach unten
Enthält die Liste mehrere Formeln, können Sie ihre Reihenfolge mit Hilfe der Schaltflächen Nach vorn und Nach hinten ändern. Die Reihenfolge hat Einfluss auf die Darstellung im Diagramm.
Gruppe Die Schaltfläche Gruppe dient dazu, Formeln in Felderzyklen zusammenzufassen. Sie können dann direkt im Diagramm mit Hilfe der Zyklus-Schaltfläche zwischen den Formeln des Formelzyklus hin- und herwechseln. Per rechtem Mausklick auf das Zyklus-Symbol im Diagramm können Sie die gewünschte Formel auch direkt aus der angezeigten Popup-Liste auswählen.
Hinweis:

Der Formelzyklus ist nicht mit zyklischen Gruppen zu verwechseln!

Zyklische Gruppen

Ausgruppieren Um eine Formel aus einem Formelzyklus herauszunehmen, markieren Sie sie und klicken Sie auf Ausgruppieren. Enthält der Formelzyklus nur noch eine einzige Formel, wird er automatisch aufgelöst und die Formel erscheint wieder als eigenständige Formel in der Liste.
Aktivieren Wenn Sie diese Option deaktivieren, wird die Formel im Diagramm nicht berücksichtigt.
Relativ Aktivieren Sie diese Option, wenn die Daten in Prozentsätzen statt in absoluten Zahlen angezeigt werden sollen. Diese Option ist für Pivottabellen nicht verfügbar.
Ausblenden Blendet die markierte Formel aus. Der Raum, den die Balken eingenommen hätten, bleibt jedoch erhalten.
Bedingung Durch die Aktivierung dieses Kontrollkästchens kann eine Bedingung festgelegt werden, die auf dem Auswahlstatus basiert und festlegt, ob die Formel angezeigt wird. Falls die Bedingung als WAHR oder NULL ausgewertet wird, erfolgt die Anzeige der Formel; wird sie als FALSCH ausgewertet, wird sie nicht angezeigt.
Bezeichnung Vor jeder Formel in der Formelliste befindet sich ein kleines Icon, das die Diagrammtypen bzw. die Art der Darstellung der Formel anzeigt (siehe unten).
Definition Syntax der markierten Formel. Die Syntax kann direkt in diesem Feld editiert werden. Per Mausklick auf die Schaltfläche ... rechts daneben öffnet sich der Dialog Formel bearbeiten.
Kommentar In diesem Kommentarfeld können Sie eine Bemerkung oder Erläuterung zu der markierten Formel eingeben.
Darstellung Hier legen Sie fest, in welcher Form die markierte Formel angezeigt werden soll. Einige Optionen sind nur für bestimmte Diagrammtypen verfügbar. Manche Optionen lassen sich nicht miteinander kombinieren oder erfordern zusätzliche Hilfsformeln.

Balken
Zeigt die Werte der markierten Formel als Balken an. Diese Option ist nur für Balken- und Kombi-Diagramme verfügbar.

Symbol
Zeigt die Werte der markierten Formel als Punkte bzw. Symbole an. Diese Option ist nur für Linien- und Kombi-Diagramme verfügbar. In der Dropdown-Liste können Sie zwischen verschiedenen Symbolen wählen.

Linie
Zeigt die Werte der markierten Formel als Linie an. Diese Option ist nur für Linien- und Kombi-Diagramme verfügbar. In der Dropdown-Liste können Sie zwischen normalen Linien, geglätteten Linien und drei verschiedenen Optionen für Stufen wählen.

Börse
Zeigt die Werte der markierten Formel als Kurschart an. Die Formel hat ein eigenes Icon in der Formelliste und erscheint automatisch als leerer Platzhalter für vier Hilfsformeln, die die Darstellung definieren. Die erste Hilfsformel Höchstkurs markiert den höchsten Punkt. Die zweite Hilfsformel wird für einen niedrigen Punkt verwendet. Beide müssen eine gültige Formel enthalten, sonst kann das Kurschart nicht angezeigt werden. Die dritte Hilfsformel Schlusskurs ist optional, wird aber ansonsten für den Schlusspunkt einer Kurschart verwendet. Die vierte Hilfsformel „Eröffnungskurs“ ist ebenfalls optional, wird aber ansonsten für den Anfangspunkt einer Kurschart verwendet. Wird die Darstellung Kurschart gewählt, werden automatisch Platzhalter für die Hilfsformeln erstellt. Es ist nicht möglich, die Darstellung Kurschart mit Balken-, Linien- oder Punktdarstellung, Boxplot oder Fehlerbalken zu kombinieren. Ist bereits eine dieser Darstellungen gewählt, kann die Option Kurschart für die betreffende Formel nicht gewählt werden. Diese Option ist nur für Kombi-Diagramme verfügbar.

Boxplot
Aktivieren Sie diese Option, um die Werte der Formel als Boxplot anzuzeigen. Dies wird häufig für die Anzeige von Statistikdaten verwendet. Die Formel hat ein eigenes Icon in der Formelliste und erscheint automatisch als leerer Platzhalter für vier Hilfsformeln, die die Darstellung definieren. Die erste Hilfsformel "Box oben" markiert die Oberkante der Box. Die zweite Hilfsformel wird für einen niedrigen Punkt verwendet. Beide müssen eine gültige Formel enthalten, sonst kann der Boxplot nicht angezeigt werden. Die dritte, vierte und fünfte Hilfsformel ist optional. Gegebenenfalls definieren diese Hilfsformeln einen Median, einen oberen Plus/Minus-Balken und einen unteren Plus/Minus-Balken. Eine gängige Erweiterung des Boxplots ist die Darstellung von Ausreißern ober- oder unterhalb der Box. Dies erreichen Sie mit Hilfe einer weiteren Formel, deren Ergebnisse Sie als Punkte anzeigen lassen. Wird die Darstellung Boxplot gewählt, werden automatisch Platzhalter für die Hilfsformeln erstellt. Es ist nicht möglich, die Darstellung Boxplot mit Balken-, Linien- oder Punktdarstellung, Kurschart oder Fehlerbalken zu kombinieren. Ist bereits eine dieser Darstellungen gewählt, kann die Option Boxplot für die betreffende Formel nicht gewählt werden. Diese Option ist nur für Kombi-Diagramme verfügbar.

Fehlerbalken
Aktivieren Sie diese Option, um eine oder zwei Formeln nach der gewählten Formel als Hilfsformeln für Fehlerbalken zu verwenden, die oberhalb der Datenpunkte der Hauptformel dargestellt werden. Ist eine Hilfsformel „Symmetrisch“ definiert, wird der berechnete Fehler symmetrisch um den Datenpunkt herum dargestellt. Sind dagegen Hilfsformeln für Oberhalb und Unterhalb definiert, werden die berechneten Ergebnisse oberhalb und unterhalb des Datenpunkts dargestellt. Die Hilfsformeln zur Berechnung des Fehlers sollten positive Zahlen ergeben. Sie werden in der Liste der Formeln mit dem Symbol für symmetrisch bzw. für oberhalb und für unterhalb gekennzeichnet. Wird die Darstellung Fehlerbalken gewählt, werden automatisch Platzhalter für die Hilfsformeln erstellt. Diese Option ist nur für Balken-, Linien- und Kombi-Diagramme verfügbar.

Werte in der Grafik
Markieren Sie dieses Kontrollkästchen, um das Ergebnis einer Formel als Text über den Datenpunkten anzuzeigen. Diese Option ist nur für Balken-, Linien-, Kombi- und Kreisdiagramme verfügbar. In Kreisdiagrammen werden die Zahlen neben den Segmenten angezeigt.

Text an Achse
Aktivieren Sie diese Option, um das Ergebnis der Formel an jedem x-Achsenwert, jeder Achse und den Achsenbezeichnungen anzuzeigen. Diese Option ist nur für Balken-, Linien- und Kombi-Diagramme verfügbar.

Text als Popup
Markieren Sie dieses Kontrollkästchen, um das Ergebnis einer Formel in der Popup-Box anzuzeigen, wenn Sie den Mauszeiger in einem Diagramm im Layout über einen Datenpunkt bewegen. Diese Option kann wahlweise mit anderen Darstellungsformen kombiniert werden. Es ist aber auch möglich, eine quasi „unsichtbare“ Formel zu definieren, die nur als Quick-Info erscheint.
Darstellung

Repräsentation
Diese Option ist nur für Tabellendiagramme und Pivottabellen verfügbar.

Text
Die Werte der Formel werden immer als Text interpretiert und angezeigt.

Bild
Mit dieser Option versucht QlikView, die einzelnen Formelwerte als Referenzen zu Bildern zu interpretieren. Diese Referenzen können auf extern gespeicherte Bilder verweisen (z. B. C:\MeinBild.jpg) oder auf Bilder, die in das Dokument eingebunden sind (z. B. qmem://Name/Peter). Kann QlikView die Referenz nicht interpretieren, wird stattdessen der Wert selbst angezeigt. Dies können Sie durch die Option Text ausblenden wenn Bild fehlt verhindern.

Kreisförmiger Messzeiger, Linearer Messzeiger, Ampel-Messzeiger, Digitaler Messzeiger
Mit den einzelnen Messzeiger-Optionen wird das Messzeigerdiagramm als Bild in der Zelle der Tabelle angezeigt. Das Layout des Messzeigers kann geändert werden, und zwar im Dialog Diagrammeigenschaften: Präsentation, der über die Schaltfläche Messbereich erreichbar ist.

Mini-Diagramm
Mit dieser Option werden in QlikView die Werte der Formel in einem Balken- oder Liniendiagramm angezeigt. Das Diagrammergebnis wird in die verfügbare Zelle der Tabelle eingetragen. Klicken Sie auf Mini-Diagramm konfigurieren, um die Eigenschaften der Mini-Diagramme zu ändern. Diese Option ist nur für Tabellendiagramme verfügbar.

Mini chart settings

Hinweis: Mini-Diagramme werden beim Export nach Excel nicht mit exportiert!

Link
Aktivieren Sie diese Option, um eine Formel in das Feld Definition einzugeben, mit der ein anklickbarer Link in der Tabellenzelle erstellt wird. Die Formel sollte ein Ergebnis der Art AngezeigterText<URL>HyperlinkText ergeben. AngezeigterText ist das, was in der Zelle der Tabelle sichtbar ist. HyperlinkText ist der tatsächliche Hyperlink, der in einem neuen Browserfenster geöffnet wird. Ist ein gültiger Hyperlink definiert, erscheint der Text in der Zelle unterstrichen. Anderenfalls ist der Text nicht unterstrichen. Bitte beachten Sie, dass es nicht möglich ist, Hyperlink-Werte auszuwählen. Per Mausklick auf die Schaltfläche ... rechts daneben öffnet sich der Dialog Formel bearbeiten.
Beispiele:
=Name & '<url>' & Link
=Name & '<url>www.qlikview.com'
wobei Name und Link im Skript geladene Tabellenfelder sind.

Bild anpassen
Diese Optionen sind nur verfügbar, oben die Option Bild ausgewählt wurde. Diese Option ist nur für Tabellendiagramme und Pivottabellen verfügbar. Hier legen Sie fest, wie das Bild in die Zelle eingepasst werden soll. Es stehen vier Optionen zur Verfügung: 

Original
Wird diese Option ausgewählt, wird das Bild ohne Strecken in Originalgröße angezeigt. Es kann sein, dass das Bild nicht vollständig zu sehen ist oder ein Teil der Zelle leer bleibt.
Strecken
Passt das Bild ohne Rücksicht auf das Seitenverhältnis so an, dass es die Zelle genau ausfüllt.
Minimal anpassen
Damit wird das Bild soweit wie möglich gestreckt, um den Textobjektbereich auszufüllen, während das Seitenverhältnis beibehalten wird.
Maximal anpassen
Damit wird das Bild bei festem Seitenverhältnis so gestreckt, dass es die Textbox in beiden Richtungen füllt. Dabei wird das Bild gegebenenfalls abgeschnitten.
Akkumulation

Legen Sie fest, ob und wie die Werte des Diagramms akkumuliert werden. Akkumulation bedeutet, dass jeder y-Wert zu dem y-Wert des folgenden x-Werts addiert wird. Werden z. B. die Werte eines Diagramms akkumuliert, das die Umsätze pro Jahr anzeigt, wird der Umsatz von 1996 zu dem von 1997 addiert. Wenn Ihr Diagramm mehrere Formeln enthält, wählen Sie die Formel, deren Werte in der Formelliste akkumuliert werden sollen. In Pivottabellen kann nicht akkumuliert werden.

Keine Akkumulierung
Ist diese Option aktiviert, werden die y-Werte der markierten Diagrammformel nicht akkumuliert.

Vollständige Akkumulierung
Ist diese Option aktiviert, akkumuliert jeder y-Wert alle vorangegangenen y-Werte der Formel. Siehe oben unter Akkumulation. Vollständige Akkumulation funktioniert nicht für mehrere Dimensionen mit NULL- oder 0-Werten.

Hinweis: Vollständige Akkumulation funktioniert nicht, falls das Diagrammgitter aktiviert ist.

Akkumulationn Schritte zurück
Legen Sie durch Eingabe einer Zahl fest, über wie viele der vorangehenden y-Werte akkumuliert werden soll. Siehe oben unter Akkumulation.

Gesamtwert

Diese Gruppe ist nur bei Tabellendiagramm-Objekte für die ausgewählte Formel aktiviert. Drei Einstellungen sind möglich:

Keine Gesamtwerte
Es werden keine Gesamtwerte für die ausgewählte Formel berechnet.
Formel über alle Werte
Der Gesamtwert der Formel wird auf der nächsten Ebene ausgewertet. Liefert die markierte Formel durchschnittliche Gehälter nach Abteilung, so ergibt Formel über alle Werte das durchschnittliche Gehalt über alle Abteilungen.
F(x) der y-Werte
Wenn diese Option aktiviert wird, werden die einzelnen Werte jedes Datenpunkts (jeder Balken im Balkendiagramm, jede Zeile im Tabellendiagramm usw.) für die ausgewählte Formel anhand der in der Dropdown-Liste ausgewählte Aggregierungsfunktion (meist Summe) aggregiert.

Hinweis: Beim Wert des Ersten Strings oder Letzten Strings handelt es sich in alphanumerischer Reihenfolge um den höchsten oder den niedrigsten Wert, der in der Tabelle zu finden ist. Die Reihenfolge der alphanumerischen Sequenz beginnt mit 0 bis 9, gefolgt von A bis Z.
Breite der Balkenumrahmung Definiert die Breite der Balkenumrahmung in Balken- und Kombi-Diagrammen. Der Wert kann in mm, cm, inch (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Formeln als Legende Wenn Sie mit mehreren Formeln arbeiten, können Sie diese zusammen mit den zugehörigen Farben in einer Legende anzeigen lassen.
Trendlinien

In manchen Diagrammen lassen sich statistische Trendlinien anzeigen. In Balken-, Linien-, Kombi- oder Punktdiagrammen mit höchstens einer Dimension und einer Formel lassen sich statistische Trendlinien anzeigen. Für andere Diagrammtypen ist die Funktion Trendlinien nicht verfügbar. In Punktdiagrammen entsprechen die Datenpunkte der Funktion y=f(x). In Balken-, Linien- und Kombi-Diagrammen können alle Optionen unter Darstellung deaktiviert und Trendlinien weiterhin hinzugefügt werden. Diese können dann ohne die zugrundeliegenden Datenpunkte dargestellt werden. Trendlinien in Balken-, Linien- und Kombi-Diagrammen können durch Angabe eines Intervalls für “Extrapolation rechts" oder "Extrapolation links" extrapoliert werden (Seite Achsen). Trendlinien erscheinen als gepunktete Linien. Bei diskreten x-Achsen werden die Trendlinien mit Symbolen angezeigt. Bei kontinuierlichen x-Achsen werden keine Symbole angezeigt.

Mittelwert
Trendlinie in Form des Mittelwertes als waagerechte Linie.
Linear
Lineare Trendlinie.
Polynom 2. Grades
Trendlinie in Form eines Polynoms 2. Grades.
Polynom 3. Grades
Trendlinie in Form eines Polynoms 3. Grades.
Polynom 4. Grades
Trendlinie in Form eines Polynoms 4. Grades.
Exponentiell
Exponentielle Trendlinie.
Gleichung anzeigen
Ist diese Option für eine bestimmte Formel aktiviert, werden für die markierte Formel zusätzlich zu den Trendlinien auch deren Gleichungen als Text im Diagramm angezeigt.
R2 anzeigen
Ist diese Option für eine bestimmte Formel aktiviert, wird für die markierte Formel zusätzlich zu den Trendlinien auch deren Bestimmtheitskoeffizient als Text im Diagramm angezeigt.

Lineare Regression in Tabellen

See also:

 

Eigenschaften des Diagramms: Sortieren

Auf die Seite Diagrammeigenschaften: Sortieren gelangen Sie, indem Sie mit der rechten Maustaste auf ein Diagramm klicken und im Objekt-Menü die Option Eigenschaften auswählen.

Hier legen Sie fest, wie die Werte der Dimensionen im Diagramm sortiert werden sollen.

Auf die Seite Diagrammeigenschaften: Sortieren andere Optionen.

Eigenschaften des Diagramms, Sortieren (Tabellendiagramm)

Die Liste Dimension enthält die Dimension des Diagramms. Markieren Sie in der Liste Dimensionen eine oder mehrere Dimensionen, für die Sie eine Sortierfolge definieren oder ändern möchten, und aktivieren Sie unter Sortieren nach eine oder mehrere der folgenden Sortierfolgen:

y-Wert Sortiert die Werte nach dem numerischen y-Wert. Diese Option ist für dynamische Dimensionen nicht verfügbar.
Bundesstaat Sortiert die Werte nach ihrem logischen Status: ausgewählt, wählbar, ausgeschlossen (bei aufsteigender Sortierung).
Formel Sortiert die Werte entsprechend der Formel, die im Feld darunter eingegeben wird.
Häufigkeit Sortiert die Werte nach ihrer Häufigkeit.
Numerischer Wert Sortiert die Werte nach ihrem numerischen Wert.
Text Sortiert die Werte alphabetisch.
Lade-Reihenfolge Sortiert die Werte nach der Reihenfolge, in der sie geladen wurden.

Sind mehrere Sortierfolgen aktiviert, wird nach der in der Liste der Sortierfolgen angegebenen Priorität sortiert. Es kann aus folgenden Sortierfolgen gewählt werden: Aufsteigend und Absteigend oder A -> Z und Z -> A.

Per Mausklick auf die Schaltfläche Standard setzen Sie die Dimensionswerte zurück auf die Standardsortierfolge, die im Dialogfeld Eigenschaften des Dokuments: Sortieren definiert ist.

Die Option Sortierfolge der Gruppe ignorieren ist nur verfügbar, wenn als Dimension eine Gruppe markiert ist. Normalerweise werden im Dialog Eigenschaften der Gruppe Sortierfolgen für jedes einzelne Feld innerhalb der Gruppe festgelegt. Ist diese Option aber aktiviert, werden diese Sortierfolgen ignoriert, und Sie können eine andere Sortierfolge definieren, die unabhängig vom momentan verwendeten Feld auf diese Dimension angewendet wird.

Eigenschaften des Diagramms: Design

Auf dieser Seite legen Sie fest, wie das Diagramm aussehen bzw. wie sein Aussehen variiert werden soll. Nicht alle aufgeführten Funktionen sind für jeden Diagrammtyp verfügbar.

Varianten Wählen Sie eine der Darstellungsvarianten. Dies beeinflusst in einigen Fällen nicht nur das Aussehen des Diagramms, sondern auch seine Funktionalität.
Ausrichtung Legen Sie die Ausrichtung des Diagramms auf vertikal oder horizontal fest.
Subtyp In dieser Gruppe wird der Modus festgelegt: Gruppiert oder Gestapelt für Balken und Überlappend oder Gestapelt für Netzdiagramme. Für diese Einstellung muss das Diagramm zwei Dimensionen oder eine Dimension und mehr als eine Formel anzeigen. Sollten bei gestapelten Balken negative Werte auftauchen, so werden diese unterhalb der x-Achse angezeigt.

Bei der Darstellung von Balkendiagrammen mit mehreren Dimensionen und Formeln gelten folgende Grundsätze, die Sie bei der Wahl des Subtyps berücksichtigen sollten:
  • Auf der x-Achse werden maximal zwei Dimensionen angezeigt.
  • Eine dritte Dimension kann durch mehrfarbig gestapelte Balken dargestellt werden.
  • Nur Tabellendiagramme können mehr als drei Dimensionen anzeigen.
  • Bei zwei oder mehr aktivierten Formeln werden die ersten beiden Dimensionen auf der x-Achse angezeigt, die Formeln durch mehrfarbig gestapelte Balken.
  • Sind zwei oder mehr Formeln aktiviert und die Untergruppe ist als gestapelt festgelegt, werden alle Formeln innerhalb eines Stapels gemäß einer Achse berechnet (standardmäßig der linken). Das ist auch der Fall, wenn Sie eine Formel für die Berechnung gemäß der linken Achse und eine für die Berechnung gemäß der rechten Achse festlegen.
 

Die folgende Tabelle zeigt, wie Subtypen mit mehreren Dimensionen und Formeln dargestellt werden.

Dimensionen Formeln Subtyp
1 1 Einzelner Balken
1 2 oder mehr Formeln gruppiert oder gestapelt
2 1 Dimensionen gruppiert oder gestapelt
2 2 oder mehr Dimensionen gruppiert
3 1 1. und 2. Dimension gruppiert, 3. Dimension gestapelt
3 2 oder mehr 1. und 2. Dimension gruppiert, Formeln gestapelt
4 1 1. und 2. Dimension gruppiert, 3. Dimension gestapelt
4 2 oder mehr 1. und 2. Dimension gruppiert, Formeln gestapelt
3D-Ansicht Stellen Sie über diese Einstellungen in dieser Gruppe den Winkel ein, aus dem das dreidimensionale Diagramm dargestellt wird.
Oberer Winkel
Vertikaler Winkel in Grad für die 3D-Ansicht. Der Wert muss eine ganze Zahl zwischen 5 und 45 sein.
Seitlicher Winkel
Seitlicher Winkel in Grad für die 3D-Ansicht. Der Wert muss eine ganze Zahl zwischen 5 und 45 sein.
Farbschema Mit diesen Optionen wenden Sie ein Farbschema auf das Diagramm an. Wird ein Design in der Dropdown-Liste ausgewählt, werden alle Farben unter Farbpalette auf der Seite Farben entsprechend des ausgewählten Designs geändert. Die Änderung ist sofort wirksam, und die Einstellung wird erst gespeichert, wenn Sie diese Seite des Dialogfelds das nächste Mal aufrufen. Die tatsächlichen Basisfarben der Farbpalette werden nicht verändert. Das Farbschema steht nicht für alle Diagrammvarianten zur Verfügung. Folgende Optionen sind verfügbar:
Einfarbig
Die Farben der Farbpalette werden als einfache deckende Farben verwendet.
Dunkler Farbverlauf
Die Farben der Farbpalette werden durch einen Farbverlauf abgedunkelt.
Heller Farbverlauf
Die Farben der Farbpalette werden durch einen Farbverlauf aufgehellt.
Glänzend
Die Balken erhalten einen glänzenden Schimmer.
Abgrenzung des Anzeigebereichs Hier bestimmen Sie, wie sich der Anzeigebereich vom Hintergrund des Diagramms abheben soll. Diese Optionen sind nur für Diagramme mit Anzeigebereich verfügbar. Folgende Optionen sind verfügbar:
Rahmen
Um den Anzeigebereich erscheint ein Rahmen.
Schatten
Der Hintergrund des Anzeigebereichs wird durch einen Schatten begrenzt.
Minimal
Der Anzeigebereich hebt sich nicht vom Hintergrund des Diagramms ab.
Vorschau Hier sehen Sie ein Muster für ein Diagramm mit den gewählten Einstellungen.

Eigenschaften des Diagramms: Präsentation (Trichterdiagramm)

In diesem Dialog stehen verschiedene Optionen für die Darstellung des Trichterdiagramms zur Verfügung.

Quick-Info Ist diese Option aktiviert, erscheint im Diagramm der zu einem Segment gehörige Dimensionswert, wenn Sie den Mauszeiger darüber bewegen. Diese Option ist unabhängig von der Anzeige von Formelwerten in Quick-Infos.
Breite der Spitze (%) Legen Sie die Breite der Trichterspitze in % der Breite des Trichtereingangs fest.
Umgekehrte Ausrichtung Aktivieren Sie diese Option, wenn die Trichterspitze nach oben bzw. bei horizontaler Ausrichtung des Diagramms nach links zeigen soll.
Segmentgröße Hier legen Sie fest, wie die Größe der Segmente von den durch die Formel berechneten y-Werten abhängen soll.
Einheitliche Segmenthöhe
Keine Proportionalität zu Daten. Alle Segmente haben dieselbe Höhe (bzw. Breite in horizontalen Trichterdiagrammen), unabhängig vom y-Wert. Ist diese Option gewählt, sollten die numerischen y-Werte in den Segmenten angezeigt werden.
Segmenthöhe proportional zum y-Wert
Alle Segmente haben eine Höhe (bzw. Breite in horizontalen Trichterdiagrammen) proportional zu den zugrundeliegenden Daten.
Segmentfläche proportional zu Daten
Die Segment ist proportional zu den zugrunde liegenden Dateien.
Legende anzeigen

In der Gruppe Legende anzeigen können Sie die Anzeige der Dimensionsbezeichnungen steuern. Aktivieren Sie die Option, um Achsenbeschriftungen anzuzeigen. Die Werte werden immer nur für das oberste Level angezeigt.
Einstellungen
Führt in den Dialog Legende formatieren, wo Sie die Legendeneinstellungen ändern können.
Zahlen in der Legende
Aktivieren Sie dieses Kontrollkästchen, um Werte neben den Dimensionswertebezeichnungen anzuzeigen.
Legende begrenzen (Zeichen)
Aktivieren Sie diese Option, um die Länge der Legendeneinträge und der an der x-Achse angezeigten Werte auf die angegebene Zahl von Zeichen zu begrenzen. Einträge, die nicht vollständig angezeigt werden können, werden im Diagramm durch ... ergänzt.

Legende formatieren

Freier Text

Unter Freier Text können Sie beliebige Erläuterungstexte zur Anzeige im Diagramm eingeben.
Add
Durch Klicken auf diese Schaltfläche öffnen Sie das Dialogfeld Freier Text. Dort können Sie Gleittexte erstellen, die im Diagramm angezeigt werden sollen.
Bearbeiten
Markieren Sie ein gelistetes Textelement und klicken Sie auf diese Schaltfläche, um den Dialog Freier Text zu öffnen und das markierte Textelement zu bearbeiten. Sie können auch einfach mit einem Doppelklick auf das Textelement in der Liste gehen.
Löschen
Markieren Sie ein gelistetes