Zu Hauptinhalt springen

Auswahlstatusbox

Current selections box example

In der Statusbox werden die Auswahlstatus nach Name und Wert der Felder gelistet. Dieses Tool zeigt die gleichen Informationen wie das unverankerte Fenster "Auswahlstatus" an, es ist jedoch wie jedes andere Objekt direkt auf dem Arbeitsblatt angeordnet. Die Indikatoren werden verwendet, um zwischen ausgewählten und gesperrten Werten zu unterscheiden.

Durch einen Rechtsklick auf eine Statusbox wird das Statusbox: Objekt-Menü) angezeigt. Dasselbe Menü finden Sie unter Objekt auf der Menüleiste, wenn die Statusbox aktiv ist.

Hinweis: Wenn Sie eine Auswahl in einem Feld mithilfe der Suche treffen, wird das Suchwort als Feldwert angezeigt.

Objekt (Menü)

Öffnen Sie das Objekt-Menü der Statusbox durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

Eigenschaften

Öffnet den Dialog Eigenschaften der Statusbox, in dem Sie eine Reihe von Parametern einstellen können.

Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

  • In den Vordergrund: Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.
  • In den Hintergrund: Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.
  • Eine Ebene nach vorn: Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.
  • Eine Ebene nach hinten: Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.

Trennen

Dem Diagrammtitel wird der Text „(Getrennt)“ angehängt und die Tabelle wird nicht mehr mit den im Dokument vorgenommenen Auswahlen aktualisiert (dennoch können im Diagramm weiterhin Auswahlen getroffen werden). Der Befehl ist nur verfügbar, wenn das Diagramm verbunden ist. Um ein Diagramm bei verschiedenem Auswahlstatus zu vergleichen, kann man eine Kopie des Diagramms machen und diese trennen.

Verbinden

Dieser Befehl verbindet ein getrenntes Diagramm wieder mit den zugrunde liegenden Daten. Das Diagramm wird dynamisch mit den Daten verknüpft. Der Befehl ist nur verfügbar, wenn das Diagramm getrennt wurde.

Referenz setzen

Blendet eine Referenz der momentanen Grafik ein. Bei weiteren Auswahlaktionen bleiben diese unverändert im Hintergrund sichtbar, so dass die Daten verglichen werden können. Die Achsen werden dabei so angepasst, dass sowohl die momentanen Daten als auch die Referenz möglichst vollständig sichtbar sind. Die Referenz steht im Hintergrund und wird möglicherweise von den momentanen Daten verdeckt. Die Farbe der Referenz kann durch die Option Referenzmodus auf der Seite Diagrammeigenschaften: Allgemein eingestellt werden. Referenzen sind nur in bestimmten Diagrammtypen anwendbar, z. B. in Balkendiagrammen, Liniendiagrammen, Kombinationsdiagrammen, Radar-Diagrammen, Punktdiagrammen, Gitternetzdiagrammen und Messzeiger-Diagrammen mit Nadeln. Enthält das Diagramm eine Drilldown- oder zyklische Gruppe, können keine Referenzen gesetzt werden. Beim Schließen des Dokuments und bei der Ausführung des Skripts verschwindet die Referenz. Die maximale Anzahl der Objekte, die einbezogen werden, wenn die Option Referenz setzen auf 500 eingestellt ist.

Referenz löschen

Dieser Befehl wird durch den Befehl Referenz setzen ersetzt, wenn eine Referenz gesetzt wurde. Dadurch wird die bereits festgelegte Referenz gelöscht und das Diagramm wird in den normalen Anzeigemodus zurückgesetzt.

Kopie erstellen

Erstellt eine Kopie des Diagramms auf dem Arbeitsblatt. Beim Kopieren von getrennten Diagrammen ist die Kopie verbunden.

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

  • In den Vordergrund: Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.
  • In den Hintergrund: Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.
  • Eine Ebene nach vorn: Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.
  • Eine Ebene nach hinten: Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.

Wählbare Werte auswählen

Alle wählbaren Werte des Felds, auf das Sie klicken, werden ausgewählt.

Ausgeschlossene Werte auswählen

Alle ausgeschlossenen Werte des Felds werden ausgewählt.

Alle Werte auswählen

Alle Werte des Felds werden ausgewählt.

Löschen

Hebt die Auswahl im aktuellen Feld auf.

Auswahl in anderen Feldern aufheben

Die wählbaren Werte des Feldes, auf das Sie klicken, werden ausgewählt, danach wird die Auswahl in allen anderen Feldern aufgehoben.

Sperren

Sperrt die gesperrten Werte des Felds.

Freigeben

Hebt die Sperrung auf in dem Feld, auf das Sie klicken.

Drucken…

Öffnet den Dialog Drucken, wo Sie die Druckeinstellungen vornehmen können.

Als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker Microsoft-Druckausgabe in PDF vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Werte nach Excel exportieren

Exportiert den Text der Schaltfläche nach Microsoft Excel, das automatisch gestartet wird, wenn es nicht bereits ausgeführt wird. Der Text erscheint auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.

Exportieren

Exportiert den Inhalt der Statusbox in eine Datei. Die Datei kann in einem der folgenden Formate gespeichert werden: Komma-getrennt, Semikolon-getrennt, Tab-getrennt, Hypertext (HTML), XML und Excel (xls oder xlsx). Vorbesetzt wird das Format *.qvo (QlikView-Output). Es handelt sich dabei um eine Tab-getrennte Textdatei.

In die Zwischenablage kopieren

Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.

  • Daten: Kopiert den Inhalt (die Auswahl) der Statusbox in die Zwischenablage.
  • Wert der Zelle: Kopiert den Textwert der mit der rechten Maustaste angeklickten Statusboxzelle (zum Aufrufen des Objektmenüs) in die Zwischenablage.
  • Bild: Kopiert ein Bild der Statusbox in die Zwischenablage. Entsprechend der Einstellungen im Dialog Benutzereinstellungen unter Export sind Titel und Rahmen mit im Bild enthalten oder nicht.
  • Objekt: Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.

Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.

  • Position der verlinkten Objekte anpassen: Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
  • Verlinkung der Objekte lösen: Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren

Minimiert das Objekt auf die Größe eines Icons. Alternativ können Sie auf Minimize in der Titelleiste des Objekts klicken. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialogfeld Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.

Maximieren

Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Alternativ können Sie auf Maximize in der Titelleiste des Objekts klicken. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialogfeld Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.

Wiederherstellen

Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Dasselbe erreichen Sie per Doppelklick auf das Icon des minimierten Diagramms oder auf Restore in der Titelleiste des maximierten Objekts. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.

Hilfe

Öffnet die QlikView-Hilfe.

Löschen

Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Die Seite Eigenschaften der Statusbox: Allgemein wird angezeigt, indem Sie mit der rechten Maustaste auf eine Statusbox klicken und im Objekt-Menü den Befehl Eigenschaften auswählen. Hier konfigurieren Sie die Statusbox.

Eigenschaften der aktuellen Auswahl (Statusbox)
Eigenschaft Beschreibung
Titel

Titel der Statusbox. Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Alternativer Status

Wählen Sie einen der verfügbaren Zustände aus der Liste. Folgende Auswahlräume sind immer verfügbar:

  • Vererbt: Die Arbeitsblätter und Objekte befinden sich immer im vererbten Zustand, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
  • Standard: Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Für Statusboxen beginnt die ID mit CS01.

Interner Makro-Interpreter

Unter Angezeigte Spalten legen Sie fest, in welcher Form der Auswahlstatus angezeigt werden soll. Eine Spalte mit den Feldnamen wird immer angezeigt.

  • Status: Ist diese Option aktiviert, erscheint in der Statusbox ein Auswahlindikator für jedes Feld.
  • Werte: Ist diese Option aktiviert, erscheint in der Statusbox eine Spalte, in der die ausgewählten Werte aufgelistet sind bzw. in der ihre Anzahl angegeben ist.
  • Auswahl per Dropdown: Ist diese Option aktiviert, erscheint hinter den Feldnamen in der Statusbox ein Dropdown-Icon. Per Mausklick auf dieses Icon erscheint eine Liste aller Werte des Feldes. Darin können Sie die Auswahl modifizieren.
  • Icons für Auswahl aufheben: Zeigt in jeder Zeile der Statusbox ein kleines Icon an. Klicken Sie auf das Icon, um die Auswahl in dem betreffenden Feld aufzuheben. Ist die Auswahl in einem Feld gesperrt, erscheint in der zugehörigen Zeile kein Icon.
  • Icons für Sperren/Freigeben: Zeigt in jeder Zeile der Statusbox ein kleines Icon für das Sperren/Freigeben an. Klicken Sie auf das Icon, um die Auswahl in dem betreffenden Feld zu sperren oder freizugeben.

Aktivieren Sie die Option Spaltenüberschriften, um die Spaltenüberschriften einzublenden. In den Eingabefeldern können Sie Bezeichnungen für die Spalten bearbeiten.

  • Felder: Spaltenüberschrift für die Spalte Felder.
  • Status: Spaltenüberschrift für die Spalte Status.
  • Werte: Spaltenüberschrift für die Spalte Werte.

Unter Farben definieren Sie die in der Statusbox verwendeten Farben.

  • Bezeichnungen Hintergrund: Farbe für den Hintergrund der Spaltenüberschriften.
  • Bezeichnungen Textfarbe: Textfarbe der Spaltenüberschriften.
  • Textfarbe: Textfarbe für den Inhalt der Spalten.
  • Hintergrund...: Führt in den Dialog Hintergrund gestalten.

Schriftart

In diesem Dialog stellen Sie Schriftart, Schriftschnitt und Schriftgrad ein.

Die Schriftart kann für jedes einzelne Objekt (Eigenschaften des Objekts: Schriftart) oder für alle Objekte in einem Dokument festgelegt werden (Auf Objekte anwenden in Eigenschaften des Dokuments: Schriftart).

Ferner können Sie Standardschriftarten für neu angelegte Objekte im Dialogfeld Eigenschaften des Dokuments: Schriftart definieren. Es gibt zwei Standard-Schriftarten:

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.

Zudem können Sie die Standardschriftarten für neue Dokumente unter Benutzereinstellungen: Schriftart definieren.

Für Schaltflächen, Diagramme und Textboxen (außer Suchobjekten) können Sie außerdem eine Schriftfarbe auswählen. Die Farbe kann fest sein oder dynamisch anhand einer Formel berechnet werden. Die Farbformel muss eine gültige Farbe ergeben. Verwenden Sie hierzu die Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Farbfunktionen

Weitere Optionen in diesem Dialog:

  • Schattiert: Zeigt die Schrift mit einem Schatten an.
  • Unterstrichen: Zeigt die Schrift unterstrichen an.

In der Vorschau wird ein Muster der aktuellen Einstellungen angezeigt.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

  • Schatten: Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
  • Art: Die folgenden vordefinierten Rahmentypen sind verfügbar:
    • Einfarbig: Liefert einen einfarbigen Rand rund um das Objekt.
    • Konkav: Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
    • Konvex: Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
    • 3 D: Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
  • Breite: Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
  • Farbe: Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
  • Regenbogen: Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.

Wenn Vereinfacht das ausgewählte Aussehen der Objekte in Dokumenteigenschaften: Allgemein ist, kann kein Rahmentyp ausgewählt werden. Es steht lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie die Option Erweitert Aussehen der Objekte in Dokumenteigenschaften: Allgemein ausgewählt haben.

  • Abgerundete Ecken: Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
  • Ecken: Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
  • Rechtwinkligkeit: Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
  • Radius: Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

  • Unten: Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
  • Normal: Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
  • Oben: Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
  • Benutzerdefiniert: Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

  • Immer: Das Objekt wird immer angezeigt.
  • Bedingung: Das Arbeitsblattobjekt wird in Abhängigkeit von einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

    Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Die Einstellungen in dieser Gruppe sind nur relevant, wenn die entsprechenden Kontrollkästchen in Dokumenteigenschaften: Layout und Eigenschaften des Arbeitsblatts: Sicherheit aktiviert werden.

  • Größe/Position ändern: Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
  • Kopieren: Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
  • Info zulassen: Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

    Info
  • Größe anpassen: Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

  • Scroll-Position beibehalten: Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden. Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.
  • Scroll-Pfeile: Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
  • Hintergrund: Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.
  • Breite Scroll-Leiste: Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
  • Aussehen: Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.
    Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

 

  • Anwenden auf...: Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

  • Titelleiste anzeigen: Ist diese Option aktiviert, hat das Arbeitsblattobjekt eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
  • Titeltext: Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

  • Text umbrechen: Zeigt die Titelleiste in mehreren Zeilen an.
  • Größe der Titelleiste (Zeilen): Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

  • Horizontale Position: Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
  • Vertikale Position: Abstand zwischen dem oberen Rand des Arbeitsblattobjekts und dem oberen Rand des Arbeitsblatts.
  • Breite: Breite des QlikView-Objekts.
  • Höhe: Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

  • Horizontal: Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
  • Vertikal: Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
  • Minimieren: Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
  • Auto-Minimieren: Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
  • Maximieren: Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
  • Kommentar: Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.


    Formelsyntax in dynamischen Ausdrücken

    Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.