Benutzereinstellungen: Design

Unter Shortcuts für Skript und Makros können Sie Tastenkombinationen für die Bedienung des Skript-Debuggers über die Tastatur definieren.

Durch die Tastenkombination Strg+QS im Skripteditor erscheint eine Liste aller Tastatur-Shortcuts.

Bearbeiten Markieren Sie einen Befehl in der Liste, klicken Sie auf Ändern, und definieren Sie eine Tastenkombination für den markierten Befehl.

Es gibt zwei optionale Tastenbelegungen:

Visual Basic Stellt die bekannten Standard-Shortcuts des Visual Basic Debuggers ein.
Visual C++ Stellt die bekannten Standard-Shortcuts des Visual C++ Debuggers ein.

 

Log-Dateien für neue Dokumente anlegen Eine Log-Datei (.log) wird beim Ausführen des Skripts erstellt. Die Datei enthält einen Zeitstempel mit der Start- und Endzeit, die ausgeführten Skriptzeilen, die von den Skriptzeilen generierten Zeilen und eine Fehlermeldung, falls die Skriptausführung fehlgeschlagen ist.
Anzahl von Zeilen im Dateiassistenten Gibt die Anzahl der Datensätze an, die in den Tabellen-Dateiassistenten zum Analysieren der Tabelle gelesen wurden.
Makrosprache Wählen Sie zwischen VBScript und JScript.
Entwurfsmodus Abstand der Rasterpunkte (mm)
Abstand zwischen den Rasterpunkten im Entwurfsmodus.
Linienabstand (mm)
Abstand zwischen den Gitterlinien im Entwurfsmodus.
Maßeinheit für Seitenränder Hier können Sie auswählen, ob die Standardeinheit für Seitenränder im Dialogfeld Drucken: Layout in cm oder in inch gemessen werden soll.
Aussehen der Objekte Wählen Sie einen der verfügbaren Modi, um das Aussehen aller Objekte zu definieren. Das gewählte Aussehen wird für alle Objekte in neu angelegten Dokumenten benutzt.
Aussehen der Titelleisten Bestimmen Sie das Aussehen der Titelleisten der Objekte. Der gewählte Stil wird auf alle Objekte innerhalb des Dokuments angewendet.
Formatvorlage für neue Dokumente Hier können Sie eine Formatvorlage für alle neuen Dokumente wählen. Die ausgewählte Formatvorlage muss so auf der Festplatte gespeichert sein, dass jederzeit auf sie zugegriffen werden kann. Sie sollte Formate für alle in QlikView vorkommenden Objekttypen enthalten.
Ganz am Ende der Dropdown-Liste können Sie auf Durchsuchen klicken, um in den Verzeichnissen Ihres Computers nach einer Formatvorlage zu suchen, die nicht im Standardverzeichnis für QlikView-Formatvorlagen abgelegt ist. Ist keine Formatvorlage definiert, werden neue Dokumente ohne Standardformatvorlage erstellt.
Immer alle Befehle im Objekt-Menü anzeigen Ist diese Option aktiviert, enthalten die Objekt-Menüs stets alle verfügbaren Befehle.
Wenn diese Option nicht aktiviert ist, erscheinen einige der Befehle nur, wenn der Entwurfsmodus im Menü Ansicht aktiviert ist.