Tabellenbox

Die Tabellenbox ist ein Objekt, das mehrere Felder gleichzeitig anzeigt. Die Werte werden in Form von Datensätzen angezeigt, d. h. zusammengehörige Werte stehen jeweils in einer Zeile. Beliebige Felder können in einer Tabellenbox zusammengefasst werden, auch wenn sie aus unterschiedlichen Datenquellen stammen.

Per rechtem Mausklick auf das Eingabefeld öffnet sich das Menü Objekt.

Hinweis: Wenn Sie größere Mengen Felddaten aus nicht verlinkten Datentabellen zu einer Tabellenbox hinzufügen, erstellt QlikView kartesische Joins zur Auflösung der erforderlichen Verbindung. Dies kann zu einem hohen Speicherbedarf und Leistungsproblemen führen.

Arbeiten mit Tabellenboxen

Sortieren

Um die Reihenfolge der Datensätze in der Tabellenbox zu ändern, gehen Sie mit einem rechten Mausklick auf die Spalte, die die Sortierfolge vorgeben soll, und wählen Sie Sortieren aus dem Menü. Doppelklicken Sie auf die Überschrift der Spalte, nach der sortiert werden soll. Durch nochmalige Anwendung des Befehls Sortieren oder nochmaligen Doppelklick auf dieselbe Spalte wird die Sortierfolge umgekehrt.

Reihenfolge der Spalten ändern

Die Reihenfolge der Felder in der Tabellenbox können Sie per Drag and Drop ändern. Klicken Sie auf eine Spaltenüberschrift, und ziehen Sie die Spalte bei gedrückter Maustaste an die gewünschte Position. Diese Funktion können Sie durch die Option Ziehen und Ablegen deaktivieren (im Dialogfeld Eigenschaften der Tabellenbox: Präsentation).

Objekt-Menü

Das Objekt-Menü der Tabellenbox kann in zwei unterschiedlichen Versionen vorliegen. Wenn Sie mit der rechten Maustaste auf den Titel der Tabellenbox klicken, enthält das Menü Befehle für das gesamte Objekt. Wenn Sie mit der rechten Maustaste auf ein Feld in der Tabellenbox klicken, enthält das Menü zusätzlich noch feldspezifische Befehle. Nachfolgend werden alle verfügbaren Befehle in allen Varianten des Menüs erläutert:

Eigenschaften Öffnet den Dialog Eigenschaften der Tabellenbox, in dem Sie eine Reihe von Parametern einstellen können.
Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Spaltenbreite anpassen Passt die Breite sämtlicher Spalten auf den jeweils längsten darin vorkommenden Wert an. Die Spaltenüberschriften werden mitberücksichtigt.
Einheitliche Spaltenbreite Überträgt die Breite der angeklickten Spalte auf alle Spalten der Tabelle.
Sortieren Sortiert die Datensätze in der Tabellenbox nach dem Feld, auf das Sie klicken.
Zellenformat Führt in den Dialog Zellenformat. Dort können Sie die Zellen und die Schattierung des angeklickten Felds formatieren. Dieser Befehl ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist.
Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Wert ändern Nur verfügbar für Spalten, die ein Inputfeld enthalten. Der Befehl versetzt die angeklickte Zelle in den Editiermodus. Alternativ können Sie auf das Input-Icon in der Zelle klicken.
Werte zurücksetzen Nur verfügbar für Spalten, die ein Inputfeld enthalten. Der Befehl öffnet folgendes Untermenü:
Einzelnen Wert zurücksetzen
Setzt den Wert des angeklickten Felds auf den ursprünglich durch das Skript geladenen Wert zurück.
Wählbare Werte zurücksetzen
Setzt die Werte aller wählbaren Feldwerte auf deren Standardwert aus dem Skript zurück.
Alle Werte zurücksetzen
Setzt die Werte aller Feldwerte auf deren Standardwert aus dem Skript zurück.
Wählbare Werte auswählen Alle wählbaren Werte des Felds, auf das Sie klicken, werden ausgewählt.
Ausgeschlossene Werte auswählen Alle ausgeschlossenen Werte des Felds werden ausgewählt.
Alle Werte auswählen Alle Werte des Felds werden ausgewählt.
Auswahl aufheben (alle Felder) Hebt die Auswahl in allen Feldern der Tabellenbox auf.
Löschen Hebt die Auswahl im aktuellen Feld auf.
Auswahl in anderen Feldern aufheben Alle wählbaren Werte des Felds, auf das Sie klicken, werden ausgewählt, danach wird die Auswahl in allen anderen Feldern aufgehoben.
Sperren Sperrt die Auswahl in dem Feld, auf das Sie klicken.
Freigeben Hebt die Sperrung auf in dem Feld, auf das Sie klicken.
Drucken… Öffnet den Dialog Drucken, wo Sie die Druckeinstellungen vornehmen können.
Als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Export nach Excel Exportiert mögliche (einschließlich der gewählten) Werte nach Microsoft Excel, das automatisch gestartet wird, falls es nicht bereits ausgeführt wird. Die exportierten Werte erscheinen auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.
Exportieren

Exportiert die Tabelle in eine Datei. Die Datei kann in einem der folgenden Formate gespeichert werden: Komma-getrennt, Semikolon-getrennt, Tab-getrennt, Hypertext (HTML), XML und Excel (xls oder xlsx). Vorbesetzt wird das Format *.qvo (QlikView-Output). Es handelt sich dabei um eine Tab-getrennte Textdatei.

Bilder in einer Tabellenbox werden beim Export in das HTML-Format nicht mit exportiert.

In die Zwischenablage kopieren

Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Vollständige Tabelle
Kopiert die Tabelle mit Spaltenüberschriften und Auswahlstatus in die Zwischenablage.
Tabellendatenbereich
Kopiert nur die Werte der Tabelle in die Zwischenablage.
Wert der Zelle
Kopiert den Textwert der mit der rechten Maustaste angeklickten Listbox (beim Aufrufen des Objekt-Menüs) in die Zwischenablage.
Bild
Kopiert ein Bild des Arbeitsblattobjekts in die Zwischenablage. Das Bild enthält oder enthält nicht die Titelleiste und den Rahmen des Arbeitsblattobjekts, je nach den Einstellungen auf der Seite Benutzereinstellungen: Exportieren. Tabellennamen aus dem verborgenen Skript sind nicht im Systemfeld $Table gelistet.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Zellenformat

In diesem Dialog können Sie spezielle Formate für Zellen in Tabellenboxen, Pivottabellen und Tabellendiagrammen definieren. Sie öffnen den Dialog über das Objekt-Menü einer Tabellenbox, eines Tabellendiagramms oder einer Pivottabelle, wenn die Option Entwurfsmodus im Menü Ansicht aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Dialogfeld Benutzereinstellungen: Design aktiviert ist.

Das gewählte Zellenformat bezieht sich auf das Feld oder die Formel, auf das/die Sie mit der rechten Maustaste geklickt haben, um das Objekt-Menü zu öffnen. Die kleinste als eine Einheit zu formatierende Zellengruppe ist ein Feld (normalerweise eine Spalte) in einem Tabellenfeld oder eine Formel/Dimension in einem Tabellendiagramm. Werden die Zeilen der Tabelle durch abwechselnde farbliche Schattierung hervorgehoben, sind diese Streifen einzeln zu formatieren.

Wird der Dialog zum benutzerdefinierten Anpassen von Teilen einer Tabelle verwendet, erscheint das Tabellenformat wie auf der Seite Design im Eigenschaftsdialog der Tabelle definiert als [Benutzerdefiniert]. Wählen Sie dort ein anderes Tabellenformat, gehen individuelle Zellenformate verloren.

Hinweis: Formate, die mit Hilfe von Attributformeln definiert werden, haben Vorrang vor den Einstellungen im Eigenschaftsdialog auf der Seite „Design“ und vor denen im Dialog „Zellenformat“.
Vorschaufenster Im Vorschaufenster sehen Sie eine Vorschau der gewählten Einstellungen. Im Gegensatz zum kleinen Mustertext auf der rechten Seite erkennen Sie im Vorschaufenster, wie die Einstellungen in der Tabelle nach Anwendung von Attributformeln und/oder Visualisierungen wirken.
Sie können innerhalb des Vorschaufensters auf andere Zellen klicken, um diese zu formatieren. Klicken Sie dazu einfach auf die gewünschte Zelle.
Rückgängig Per Mausklick auf Rückgängig machen Sie die im Dialog Zellenformat vorgenommenen Änderungen Schritt für Schritt rückgängig.
Nachdem Sie den Dialog Zellenformat geschlossen haben, können Sie alle darin vorgenommenen Änderungen mit Hilfe der Schaltfläche Layout rückgängig auf der Symbolleiste auf einmal rückgängig machen.
Wiederherstellen Per Mausklick auf die Schaltfläche Wiederherstellen werden zuvor rückgängig gemachte Änderungen im Dialog Zellenformat Schritt für Schritt wiederhergestellt.
Mustertext Kleine Vorschau der gewählten Einstellungen.
Hintergrundfarbe Farbe des Zellenhintergrunds.
Textfarbe Farbe des Texts.
Trennlinie vor der Zelle Wählen Sie eine Linienart und eine Farbe für die Trennlinie vor Zelle. Sie können die Art über eine Dropdown-Liste und die Farbe über eine Schaltfläche definieren. Beachten Sie, dass die Trennlinie nach der Zelle mit der Trennlinie vor der nachfolgenden Zelle zusammenfällt, daher kann das Aussehen in der Tabelle vom hier eingestellten Format abweichen.
Trennlinie nach der Zelle Wählen Sie eine Linienart und eine Farbe für die Trennlinie nach Zelle. Sie können die Art über eine Dropdown-Liste und die Farbe über eine Schaltfläche definieren. Beachten Sie, dass die Trennlinie nach der Zelle mit der Trennlinie vor der nachfolgenden Zelle zusammenfällt, daher kann das Aussehen in der Tabelle vom hier eingestellten Format abweichen.
Schrift Hier haben Sie Optionen zur Gestaltung des Textes.
Größe
Wählen Sie in der Dropdown-Liste die Schriftgröße für die Tabelle.
Fett
Aktivieren Sie diese Option, wenn die Schrift fett sein soll.
Kursiv
Aktivieren Sie diese Option, wenn die Schrift kursiv sein soll.
Unterstrichen
Aktivieren Sie diese Option, wenn die Schrift unterstrichen sein soll.
Schattiert
Aktivieren Sie diese Option, wenn die Schrift schattiert sein soll.
Anwenden auf Die Einstellungen beziehen sich normalerweise auf das Feld oder die Formel, auf die Sie mit der rechten Maustaste geklickt haben, um das Objekt-Menü zu öffnen. Mit Hilfe der Optionen in dieser Dropdown-Liste können Sie das Format auf alle Felder, Dimensionen oder Formeln der Tabelle anwenden.

Allgemein

Eigenschaften der Tabellenbox: Allgemein öffnen Sie durch Rechtsklick auf eine Tabellenbox und Auswahl des Befehls Eigenschaften im Objekt-Menü oder durch Auswahl des Befehls Eigenschaften, wenn eine Tabellenbox aktiv ist.

Titel

Geben Sie unter Titel einen beliebigen Namen für die Tabellenbox ein. Ihr Eintrag erscheint in der Titelleiste der Tabellenbox.Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Verfügbare Felder Hier sind alle Felder des Dokuments aufgeführt. Anfänglich werden alle Felder (ausschließlich Systemfelder) in dieser Spalte angezeigt. Markieren Sie Systemfelder anzeigen, um Systemfelder anzuzeigen. Markieren Sie per Mausklick die Elemente, die Sie verwenden/entfernen möchten. Verschieben Sie sie mit den Schaltflächen Hinzufügen > oder < Entfernen in die gewünschte Spalte.
Felder in der Tabellenbox In dieser Spalte werden die Namen der Felder, die aus der Liste Verfügbare Felder ausgewählt wurden und in die Tabellenbox aufgenommen werden sollen, angezeigt. Beim Anlegen einer neuen Tabellenbox ist diese Liste zunächst leer.
Sie können in dieser Liste Felder markieren und ihnen unter Einstellungen für markiertes Feld eine andere Bezeichnung zuweisen.
Systemfelder anzeigen Aktivieren Sie diese Option, um die Systemfelder in der Liste Verfügbare Felder mit anzeigen zu lassen.
Felder aus Tabelle Hier legen Sie fest, welche Felder in der Liste Verfügbare Felder angezeigt werden. In der Dropdown-Liste wird die Alternative Alle Tabellen standardmäßig angezeigt. Soll sie nur Felder aus einer bestimmten Tabelle anzeigen, wählen Sie den entsprechenden Tabellennamen aus der Dropdown-Liste.
Durch die Option Alle Tabellen (qualifiziert) werden den Feldnamen die Namen der internen Tabellen vorangestellt. Dies bedeutet, dass wichtige Felder (zur Verbindung) mehr als einmal gelistet werden. (Diese Alternative betrifft nur die Anzeige, nicht jedoch die Qualify-Felder im Skript.)
Nach oben Verschiebt das markierte Feld in der Liste um einen Platz nach oben.
Nach unten Verschiebt das markierte Feld in der Liste um einen Platz nach unten.
Häufigkeit Sortiert die Spalte Felder in der Tabellenbox nach der Anzahl der Werte.
Lade-Reihenfolge Sortiert die Spalte Felder in der Tabellenbox nach der Reihenfolge, in der sie geladen wurden.
Alphabetisch Sortiert die Spalte Felder in der Tabellenbox alphabetisch.
Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Für Tabellenboxen beginnt die ID mit TB01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Interner Makro-Interpreter

Bedingung für die Berechnung Geben Sie eine Bedingung für die Berechnung, wird die Tabellenbox nur dann berechnet und angezeigt, wenn die Bedingung erfüllt ist. Anderenfalls erscheint der Text "Bedingung für die Berechnung nicht erfüllt".
Fehlermeldungen

Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Benutzerdefinierte Fehlermeldungen. Dort können Sie die standardmäßigen Fehlermeldungen in Tabellenboxen (und Diagramme) anpassen.

Benutzerdefinierte Fehlermeldungen

Sortieren

Eigenschaften der Tabellenbox: Sortieren öffnen Sie durch Rechtsklick auf eine Tabellenbox und Auswahl des Befehls Eigenschaften im Objekt-Menü.

In der Liste Priorität der Sortierfolgen werden die Felder der Tabellenbox angezeigt. Die Reihenfolge der Felder wird durch die Sortierfolge bestimmt, die durch den Befehl Sortieren festgelegt wird. Die Reihenfolge der Felder kann durch die Schaltflächen Nach vorn und Nach hinten verändert werden. Das Kriterium für die Sortierfunktion kann für jedes Feld der Liste definiert werden. Die Sortierung wird nachfolgend erläutert.

Sortieren nach:

Formel Sortiert die Werte entsprechend einer Formel, die im Feld darunter eingegeben wird.
Häufigkeit Schaltet den Status ein oder aus, ob die Sortierung der Werte nach Häufigkeit erfolgen soll.
Numerischer Wert Schaltet den Status ein oder aus, ob die Sortierung der Werte nach numerischem Wert erfolgen soll.
Text Schaltet den Status ein oder aus, ob die Sortierung der Werte nach dem Alphabet (ASCII-Standard) erfolgen soll.
Lade-Reihenfolge Schaltet den Status ein oder aus, ob die Sortierung der Werte nach der Lade-Reihenfolge erfolgen soll.

Sind mehrere Sortierfolgen aktiviert, wird nach folgender Priorität sortiert: Formel, Häufigkeit, numerischer Wert, Alphabet, Lade-Reihenfolge.

Präsentation

Eigenschaften der Tabellenbox: Präsentation öffnen Sie, indem Sie mit der rechten Maustaste auf eine Tabllenbox klicken und den Befehl Eigenschaften im Objekt-Menü auswählen.

In diesem Dialog legen Sie das Layout der Tabellenbox fest.

Ausrichtung Die Standardausrichtung der Feldwerte kann für Text und Zahlen getrennt festgelegt werden. Wählen Sie dazu das Feld in der Liste Felder und dann die entsprechende Option in der Gruppe Ausrichtung. Standardmäßig werden Textwerte linksbündig und Zahlen rechtsbündig dargestellt.
Zeilen mit NULL-Wert weglassen Zeilen mit einem Feldwert von Null der ausgewählten Felder werden entfernt. Mit Null ist kein Wert gemeint.
Auswahl per Dropdown Ein Dropdown-Pfeil wird links neben der Spaltenüberschrift des ausgewählten Feldes angezeigt. Klicken Sie auf das Icon, um auf die Feldwerte in einer Dropdown-Liste zuzugreifen. Es funktioniert wie die Auswahl in einer Multibox.
Erweitert Öffnet den Dialog Erweiterte Einstellungen für markiertes Feld, wo Ihnen Optionen für eine grafische Interpretation der Werte und spezielle Suchfunktionen zur Verfügung stehen.
Mehrzeilige Zellen Legen Sie fest, ob für das markierte Feld mehrzeilige Zellen angezeigt werden sollen, was bei langen Textstrings nützlich ist.
Text umbrechenGröße der Überschriften n Zeilen
Stellt die Spaltenüberschriften in mehreren Zeilen dar. Hier wird die Einschränkung für die Anzahl der Kopfzeilen festgelegt.
Text umbrechenGröße der Zellen n Zeilen
Zeigt den Inhalt der Zellen in mehreren Zeilen an. Hier wird die gewünschte Einschränkung für die Anzahl der Zeilen in einer Zelle festgelegt.
Überschriften senkrecht Alle Feldnamen werden in die vertikale Position gedreht.
Drag and Drop Wenn diese Option aktiviert ist, können Sie die Felder der Tabellenbox durch Klicken und Ziehen der Kopfzeile sortieren.
Sortierungsindikator Ein Sortierungsindikator-Icon wird rechts neben der Spaltenüberschrift des Felds angezeigt, das zur Sortierung der Tabellenbox verwendet wird. Das Icon wird gedreht, um die aufsteigende oder absteigende Sortierfolge anzuzeigen.
Auswahlindikatoren Ein Sortierungsindikator-Icon wird rechts neben der Spaltenüberschrift des Felds angezeigt, das zur Sortierung der Tabellenbox verwendet wird. Das Icon wird gedreht, um die aufsteigende oder absteigende Sortierfolge anzuzeigen.
Spaltenüberschriften ausblenden Durch diese Option wird die Zeile mit den Spaltenüberschriften ausgeblendet.

Design

Diese Designseite gilt für alle QlikView -Tabellen, d. h. Tabellenboxen, Pivottabellen und Tabellendiagramme. Hier bestimmen Sie das Design der Tabelle.

Tabellenformat Wählen Sie das gewünschte Tabellenformat aus der Dropdown-Liste. Erscheint hier [Benutzerdefiniert], wurde ein individuelles Zellenformat definiert. Wenn Sie das Tabellenformat ändern, geht das individuelle Zellenformat verloren.
Schattierung: je n Zeilen Geben Sie an, in welchen Intervallen die Zeilen der Tabelle schattiert werden sollen.
Kompaktansicht Diese Option ist nur für Pivottabellen verfügbar. Nur für Pivottabellen. Ist diese Option aktiviert, werden die in Spalten angezeigten Dimensionen in einer platzsparenden Kompaktansicht dargestellt.
Nur erste Dimensionsbeschriftung verwenden
Diese Einstellung ist nur für Pivottabellen verfügbar, die sich bereits in der Kompaktansicht befinden und ändert den Stil der Pivottabelle weiter.
Trennlinien für Dimensionsspalten Nur für Pivottabellen und Tabellendiagramme. Blendet die vertikalen Trennlinien der Dimensionsspalten aus.
Trennlinien für Formelspalten Nur für Pivottabellen und Tabellendiagramme. Blendet die vertikalen Trennlinien der Formelspalten aus.
Abgrenzung der Abstandszeile

Diese Option ist nur von Bedeutung, wenn im Dialog Erweiterte Einstellungen für markiertes Feld Abstandszeilen definiert sind. Wenn diese Option aktiviert ist, kann das Tabellendesign leicht modifiziert werden.

Advanced Field Settings

Hintergrund Führt in den Dialog Hintergrund gestalten.
Transparenz Zellenhintergrund Wenn Sie der Tabelle im Dialog Hintergrund gestalten eine Hintergrundfarbe oder ein Hintergrundbild zugewiesen haben, können Sie die Transparenz des Hintergrunds einstellen.
Transparenz Zellenabgrenzung Stellt die Transparenz der Linien zur Abgrenzung der Zellen ein.

Schriftart

In diesem Dialog stellen Sie Schriftart, Schriftschnitt und Schriftgrad ein.

Die Schriftart kann für jedes einzelne Objekt (Eigenschaften des Objekts: Schriftart) oder für alle Objekte in einem Dokument festgelegt werden (Auf Objekte anwenden in Eigenschaften des Dokuments: Schriftart).

Ferner können Sie Standardschriftarten für neu angelegte Objekte im Dialogfeld Eigenschaften des Dokuments: Schriftart definieren. Es gibt zwei Standard-Schriftarten:

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.

Zudem können Sie die Standardschriftarten für neue Dokumente unter Benutzereinstellungen: Schriftart definieren.

Für Schaltflächen, Diagramme und Textboxen (außer Suchobjekten) können Sie außerdem eine Schriftfarbe auswählen. Die Farbe kann fest sein oder dynamisch anhand einer Formel berechnet werden. Die Farbformel muss eine gültige Farbe ergeben. Verwenden Sie hierzu die Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Farbfunktionen

Weitere Optionen in diesem Dialog:

Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

In der Vorschau wird ein Muster der aktuellen Einstellungen angezeigt.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.

Wenn Vereinfacht das ausgewählte Aussehen der Objekte in Dokumenteigenschaften: Allgemein ist, kann kein Rahmentyp ausgewählt werden. Es steht lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie die Option Erweitert Aussehen der Objekte in Dokumenteigenschaften: Allgemein ausgewählt haben.

Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent...

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Die Einstellungen in dieser Gruppe sind nur relevant, wenn die entsprechenden Kontrollkästchen in Dokumenteigenschaften: Layout und Eigenschaften des Arbeitsblatts: Sicherheit aktiviert werden.

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.