Statistikbox

Die Statistikbox zeigt statistische Größen, z. B. Summe oder Mittelwert, bezogen auf die auswählbaren bzw. ausgewählten Werte eines Feldes an. Eine Auswahl von Statistikfunktionen ist verfügbar. Sind keine Werte ausgewählt, berechnet QlikView die statistischen Größen für sämtliche Werte des Feldes.

Die Statistikbox trägt standardmäßig denselben Namen, wie das Feld, auf das sie sich bezieht.

Per rechtem Mausklick auf die Statistikbox öffnet sich das Objekt-Menü.

Objekt-Menü

Öffnen Sie das Objekt-Menü der Statistikbox durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

Eigenschaften Öffnet den Dialog Eigenschaften der Statistikbox. Dort können Sie einige Parameter einstellen.
Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Wählbare Werte auswählen Alle wählbaren Werte des zugrunde liegenden Feldes werden ausgewählt.
Ausgeschlossene Werte auswählen Alle ausgeschlossenen Werte des zugrundeliegenden Feldes werden ausgewählt.
Alle Werte auswählen Alle Werte des zugrunde liegenden Feldes werden ausgewählt.
Löschen Hebt die Auswahl im zugrunde liegenden Feld auf.
Auswahl in anderen Feldern aufheben Alle wählbaren Werte im zugrunde liegenden Feld werden ausgewählt, danach wird die Auswahl in allen anderen Feldern aufgehoben.
Sperren Sperrt die Auswahl im zugrunde liegenden Feld.
Freigeben Hebt die Sperrung im zugrunde liegenden Feld auf.
Drucken…

Öffnet den Dialog Drucken. Hier können Sie den Inhalt der Statistikbox drucken.

Drucken: Allgemein

Als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Export nach Excel Exportiert mögliche (einschließlich der gewählten) Werte nach Microsoft Excel, das automatisch gestartet wird, falls es nicht bereits ausgeführt wird. Die exportierten Werte erscheinen auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.
Exportieren Öffnet den Dialog Speichern unter, in dem Pfad, Dateiname und (Tabellen-) Dateityp für den exportierten Dateninhalt angegebenen werden können.
In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Daten
Kopiert die Datenzeilen der Statistikbox in die Zwischenablage.
Wert der Zelle
Kopiert den Textwert der angeklickten Zelle der Statistikbox (beim Aufrufen des Objekt-Menüs) in die Zwischenablage.
Bild
Kopiert ein Bild des Arbeitsblattobjekts in die Zwischenablage. Das Bild enthält oder enthält nicht die Titelleiste und den Rahmen des Arbeitsblattobjekts, je nach den Einstellungen auf der Seite Benutzereinstellungen: Exportieren.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Zum Eigenschaftendialog Allgemein gelangen Sie über die Auswahl von Statistikbox unter Neues Objekt im Menü Ansicht oder über Rechtsklick auf eine Statistikbox und Auswahl von Eigenschaften im Menü. Hier wählen Sie die Statistik, die berechnet und in der Statistikbox angezeigt werden soll.

Titel Titel der Statistikbox. Der Titel wird in der Titelleiste des Objekts angezeigt.
Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Die ID für Statistikboxen beginnt mit SB01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.
Feld Wählen Sie das Feld mit den zu verwendenden Werten aus der Liste Feld.
Als Titel verwenden

Klicken Sie auf Als Titel verwenden, wenn der Feldname als Titel der Statistikbox erscheinen soll. Anderenfalls geben Sie im Eingabefeld Titel einen beliebigen anderen Titel ein. Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Verfügbare statistische Größen Markieren Sie in der Liste Verfügbare statistische Größen die gewünschten Funktionen, und verschieben Sie sie per Mausklick auf Hinzufügen oder per Doppelklick in die Liste Angezeigte statistische Größen.
Standardfehler anzeigen Durch die Option Standardfehler anzeigen können Sie den Standardfehler für Mittelwert und Standardabweichung anzeigen lassen.
Trennlinien Aktivieren Sie Trennlinien, so dass horizontale Trennlinien zur Darstellung von Reihen in der Tabelle eingefügt werden.
Hintergrund Führt in den Dialog Hintergrund gestalten.
Angezeigte statistische Größen Liste der statistischen Größen, die in der Statistikbox angezeigt werden.
Einstellungen für markierte Zeile Unter Einstellungen für markierte Zeile haben Sie weitere Formatierungsmöglichkeiten.
Bezeichnung Hier können Sie eine alternative Bezeichnung für die markierte statistische Größe eingeben.
Hintergrundfarbe Definieren Sie eine Hintergrundfarbe für die markierte statistische Größe. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Textfarbe Wählen Sie eine Textfarbe für die markierte statistische Größe.
Farben auf alle Zeilen übertragen Aktivieren Sie diese Option vor dem Klicken auf Übernehmen oder OK, um die ausgewählte Farbe aus alle Zeilen der Statistikbox zu übernehmen.

Folgende statistische Größen sind verfügbar:

Anzahl numerischer Werte Stichprobenumfang. Anzahl der numerischen Werte unter den möglichen Werten)
Anzahl NULL-Werte Anzahl der NULL-Werte in der Stichprobe.
Anzahl Stringwerte Anzahl der alphanumerischen Werte in der Stichprobe.
Anzahl aller Werte Gesamtzahl der möglichen Werte. Diese Zahl entspricht der Häufigkeit der anzeigbaren Werte in einer Listbox. (Summe aus Anzahl numerischer Werte und Anzahl Stringwerte)
Anzahl nicht-numerischer Werte Anzahl nicht-numerischer Werte in der Stichprobe. Dies entspricht der Summe der Anzahl NULL-Werte und der Stringwerte.
Sum Summe der Werte in der Stichprobe.
Mittelwert Arithmetisches Mittel der Werte in der Stichprobe.
Standardabweichung Standardabweichung der Stichprobe.
Schiefe Schiefe der Stichprobe.
Kurtosis Exzess der Stichprobe.
Min Kleinster Wert in der Stichprobe.
Max Größter Wert in der Stichprobe.
Einzelner Wert Einziger wählbarer bzw. ausgewählter Wert des Felds.
Median Median der Stichprobe.
Fractile Quantil der Stichprobe. Der Prozentsatz kann manuell eingegeben werden.

Der Begriff „Stichprobe“ bezeichnet alle nicht ausgeschlossenen, d. h. alle wählbaren und ausgewählten Werte des Felds.

Wenn die Werte, die einen einzelnen Feldwert repräsentieren, z. B. Minimum oder Maximum, angeklickt werden, werden die dazugehörigen Feldwerte markiert.

Zahl

Zu Eigenschaften der Statistikbox: Zahlen gelangen Sie, indem Sie mit der rechten Maustaste auf die Statistikbox klicken und den Befehl Eigenschaften im Objekt-Menü auswählen.

Die Zahlenformate der in der Statistikbox angezeigten statistischen Funktionen werden automatisch von dem Zahlenformat des zugrunde liegenden Feldes abgeleitet. In diesem Dialog können Sie andere Zahlenformate für einzelne Funktionen wählen. Markieren Sie dazu eine der Funktionen in der Liste Funktionen, aktivieren Sie die Option Dokument-Standard ignorieren, und wählen Sie ein anderes Zahlenformat. Die Eigenschaftenseite bezieht sich auf das aktive Objekt und enthält die folgenden Steuerelemente für die Formatierung von Werten:

Zahl Rundet numerische Werte auf die unter Genauigkeit angegebene Zahl von Stellen.
Ganze Zahl Zeigt numerische Werte als ganze Zahlen an.
Dezimalzahl Zeigt numerische Werte als Dezimalzahlen mit der angegebenen Zahl von Stellen an.
Money Zeigt numerische Werte als Geldbeträge an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau. Standard ist das von Windows vorgegebene Währungsformat.
Date Zeigt numerische Werte als Datum an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Time Zeigt numerische Werte als Uhrzeit an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Timestamp Zeigt numerische Werte als Zeitstempel an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Interval Zeigt numerische Werte als die Zeitspanne an. Beispiel: Das Format = mm zeigt den Wert in Form der Minuten an, die seit dem Kalenderbeginn (30. Dezember 1899, 24:00 Uhr) vergangen sind.

Die Schaltfläche In % anzeigen ist für folgende Formate verfügbar: Zahl, Ganze Zahl und Dezimalzahl.

Unter Trennzeichen können Sie ein Dezimal- und ein Tausendertrennzeichen festlegen.

Durch die Schaltfläche ISO wird das Format für Datum, Uhrzeit, Zeitstempel und Intervall zurück auf ISO-Standard gesetzt.

Per Mausklick auf die Schaltfläche System werden die vom Betriebssystem vorgegebenen Formate eingestellt.

Schriftart

In diesem Dialog stellen Sie Schriftart, Schriftschnitt und Schriftgrad ein.

Die Schriftart kann für jedes einzelne Objekt (Eigenschaften des Objekts: Schriftart) oder für alle Objekte in einem Dokument festgelegt werden (Auf Objekte anwenden in Eigenschaften des Dokuments: Schriftart).

Ferner können Sie Standardschriftarten für neu angelegte Objekte im Dialogfeld Eigenschaften des Dokuments: Schriftart definieren. Es gibt zwei Standard-Schriftarten:

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.

Zudem können Sie die Standardschriftarten für neue Dokumente unter Benutzereinstellungen: Schriftart definieren.

Für Schaltflächen, Diagramme und Textboxen (außer Suchobjekten) können Sie außerdem eine Schriftfarbe auswählen. Die Farbe kann fest sein oder dynamisch anhand einer Formel berechnet werden. Die Farbformel muss eine gültige Farbe ergeben. Verwenden Sie hierzu die Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Farbfunktionen

Weitere Optionen in diesem Dialog:

Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

In der Vorschau wird ein Muster der aktuellen Einstellungen angezeigt.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.

Wenn Vereinfacht das ausgewählte Aussehen der Objekte in Dokumenteigenschaften: Allgemein ist, kann kein Rahmentyp ausgewählt werden. Es steht lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie die Option Erweitert Aussehen der Objekte in Dokumenteigenschaften: Allgemein ausgewählt haben.

Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent...

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Die Einstellungen in dieser Gruppe sind nur relevant, wenn die entsprechenden Kontrollkästchen in Dokumenteigenschaften: Layout und Eigenschaften des Arbeitsblatts: Sicherheit aktiviert werden.

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.