Multibox

Da die Multibox über die einzigartige Option verfügt, die angezeigten Felder nach Status zu sortieren, ist sie die ideale Methode, um auf dem gleichen Arbeitsblatt eine große Anzahl von Listboxen anzuzeigen. Diese Option Sortieren nach Status wird über die Seite Eigenschaften der Multibox: Allgemein aufgerufen.

Per rechtem Mausklick auf die Multibox öffnet sich das Objekt-Menü.

Objekt-Menü

Das Objekt-Menü der Multibox hat drei verschiedene Versionen. Wenn Sie mit einem rechten Mausklick auf den Titel der Tabellenbox gehen, enthält das Menü Befehle für das gesamte Objekt. Wenn Sie mit einem rechten Mausklick auf ein Feld in der Tabellenbox gehen, enthält das Menü zusätzlich noch feldspezifische Befehle. Wenn Sie zuerst eine Datei öffnen, sieht das Objekt-Menü wiederum anders aus. Nachfolgend werden alle verfügbaren Befehle in allen Varianten des Menüs erläutert:

Eigenschaften Öffnet den Dialog Eigenschaften der Multibox. Dort können Sie einige Parameter einstellen.
Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Suchen

Öffnet das Suchfenster.

Suchen

Fuzzy-Suche

Öffnet das Suchfenster im Fuzzy-Modus.

Fuzzy-Suche

Erweiterte Suche

Öffnet das Suchfenster für die erweiterte Suche. Dieser Dialog ermöglicht die Eingabe von erweiterten Suchformeln. Dasselbe erreichen Sie mit der Tastenkombination STRG+UMSCHALT+F.

Suchfenster für die erweiterte Suche

Wählbare Werte auswählen Alle wählbaren Werte des Felds, auf das Sie klicken, werden ausgewählt.
Ausgeschlossene Werte auswählen Alle ausgeschlossenen Werte des Felds werden ausgewählt.
Alle Werte auswählen Alle Werte des Felds werden ausgewählt.
Auswahl aufheben (alle Felder) Hebt die Auswahl in allen Feldern der Multibox auf.
Löschen Hebt die Auswahl im aktuellen Feld auf.
Auswahl in anderen Feldern aufheben Die wählbaren Werte des Feldes, auf das Sie klicken, werden ausgewählt, danach wird die Auswahl in allen anderen Feldern aufgehoben.
Sperren Sperrt die Auswahl in dem Feld, auf das Sie klicken.
Auswahl sperren (alle Felder) Sperrt die Auswahl in allen Feldern der Multibox.
Freigeben Hebt die Sperrung auf in dem Feld, auf das Sie klicken.
Auswahl freigeben (alle Felder) Hebt die Sperrung für alle Felder der Multibox auf.
Drucken…

Öffnet den Dialog Drucken, wo Sie die Druckeinstellungen vornehmen können. Der Druck einer Multibox ist nur sinnvoll, wenn in den Feldern einzelne Werte anzeigt werden (entweder, da es der einzige ausgewählte oder der einzige zugeordnete Wert ist).

Drucken: Allgemein

Als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Export nach Excel Exportiert mögliche (einschließlich der gewählten) Werte nach Microsoft Excel, das automatisch gestartet wird, falls es nicht bereits ausgeführt wird. Die exportierten Werte erscheinen auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version. Dieser Befehl ist nur sinnvoll, wenn in den Feldern einzelne Werte anzeigt werden.
Exportieren

Exportiert den Inhalt der Multibox als Tabelle in eine Datei Ihrer Wahl. Die Datei kann in einem der folgenden Formate gespeichert werden: Komma-getrennt, Semikolon-getrennt, Tab-getrennt, Hypertext (HTML), XML und Excel (xls oder xlsx). Vorbesetzt wird das Format *.qvo (QlikView-Output). Es handelt sich dabei um eine Tab-getrennte Textdatei.

In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Daten
Kopiert den Inhalt der Multibox in die Zwischenablage.
Wert der Zelle
Kopiert den Textwert der mit der rechten Maustaste angeklickten Multiboxzelle (beim Aufrufen des Objektmenüs) in die Zwischenablage.
Bild
Kopiert ein Bild des Arbeitsblattobjekts in die Zwischenablage. Entsprechend der Einstellungen im Dialog Benutzereinstellungen unter Export sind Titel und Rahmen mit im Bild enthalten oder nicht.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Titel

Geben Sie unter Titel einen beliebigen Namen für die Multibox ein. Ihr Eintrag erscheint in der Titelleiste der Multibox.Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.

Verfügbare Felder

Hier sind alle Felder des Dokuments aufgeführt. Anfänglich werden alle Felder (ausschließlich Systemfelder) in dieser Spalte angezeigt. Markieren Sie Systemfelder anzeigen, um Systemfelder anzuzeigen.

Systemfelder

Schlüsselfelder sind durch einen kleinen Schlüssel gekennzeichnet. Markieren Sie per Mausklick die Elemente, die Sie verwenden/entfernen möchten. Verschieben Sie sie mit den Schaltflächen Hinzufügen > oder < Entfernen in die gewünschte Spalte.

Felder in der Multibox In dieser Spalte werden die Namen der aus der Liste Verfügbare Felder in die Multibox aufzunehmenden Felder angezeigt. Beim Anlegen einer neuen Tabellenbox ist diese Liste zunächst leer.
Sie können in dieser Liste Felder markieren und ihnen unter Einstellungen für markiertes Feld eine andere Bezeichnung zuweisen.
Felder aus Tabelle Hier legen Sie fest, welche Felder in der Liste Verfügbare Felder angezeigt werden. In der Dropdown-Liste wird die Alternative Alle Tabellen standardmäßig angezeigt.
Durch die Option Alle Tabellen (qualifiziert) werden den Feldnamen die Namen der internen Tabellen vorangestellt. Dies bedeutet, dass wichtige Felder (zur Verbindung) mehr als einmal gelistet werden. (Diese Alternative betrifft nur die Anzeige, nicht jedoch die Qualify-Felder im Skript.)
Sie können auch nur die Felder einer Tabelle anzeigen.
Formel Öffnet den Dialog Formel bearbeiten, wo Sie eine Formel für ein dynamisches Feld erstellen und dann als Feld in der Multibox verwenden können.
Bearbeiten Öffnet das in der Liste der Felder in der Multibox markierte Feld Multibox markierte Feld im Dialog Formel bearbeiten
Nach oben Verschiebt das markierte Feld in der Liste um einen Platz nach oben.
Nach unten Verschiebt das markierte Feld in der Liste um einen Platz nach unten.
Häufigkeit Sortiert die Spalte Felder in der Multibox nach der Anzahl der Werte.
Lade-Reihenfolge Sortiert die Spalte Felder in der Multibox nach der Reihenfolge, in der sie geladen wurden.
Alphabetisch Sortiert die Spalte Felder in der Multibox alphabetisch.
Sortieren nach Status Sortiert die Spalte Felder in der Multibox danach, ob sie wählbare Werte enthalten oder nicht. Ist diese Option aktiviert, werden Felder, die keine wählbaren Werte enthalten automatisch nach unten verschoben. Durch diese Option kann man auch Multiboxen mit sehr vielen Feldern sinnvoll nutzen.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Die ID für Multiboxen beginnt mit MB01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Interner Makro-Interpreter

Sortieren

Das Registerblatt Sortieren existiert in den Eigenschaftsdialogen von Listboxen, Multiboxen, Tabellenboxen, Schiebereglern/Kalenderboxen usw. Gehen Sie mit einem rechten Mausklick auf das Objekt und wählen Sie Eigenschaften aus dem Hauptmenü. Hier legen Sie die Sortierfolgen für die Werte der im Objekt angezeigten Felder fest. Gegebenenfalls sind nicht alle Optionen in allen Objekttypen verfügbar.

Sortieren nach:

Bundesstaat Sortiert die Werte nach logischem Status (ausgewählt, optional, ausgeschlossen).
Durch die Option Bedingt aufsteigend werden die Werte nach Status sortiert, solange die Listbox Scroll-Leisten hat und nicht alle Werte zu sehen sind. Sind jedoch alle Werte zu sehen, wird die Sortierung nach Status deaktiviert und nach der nächsten gewählten Sortierfolge sortiert.
Formel

Sortiert die Werte anhand der Formel, die Sie im Eingabefeld darunter eingeben. Bei Verwendung von Sortierformeln müssen Sie die der Berechnung zugrunde liegenden Werte über die Auswahlformel bestimmen. Beachten Sie, dass Sortierformeln hier nur mit numerischen Feldern und nicht mit Textfeldern funktionieren.

Aggregierung und Auswahlformeln

Häufigkeit Sortiert die Werte nach der Häufigkeit, d. h. danach, wie oft sie in der internen Tabelle vorkommen.
Numerischer Wert Sortiert die Werte des Feldes nach ihrem numerischen Wert.
Text Sortiert die Feldwerte alphabetisch.
Lade-Reihenfolge Sortiert die Werte nach der Reihenfolge, in der sie geladen wurden.

Per Mausklick auf Standard setzen Sie die Sortierung zurück auf die Standardsortierfolge.

Sind mehrere Sortierfolgen aktiviert, wird nach folgender Priorität sortiert: Status, Formel, Häufigkeit, Numerischer Wert, Alphabet, Lade-Reihenfolge. Zu jeder Sortierung kann angegeben werden, ob Aufsteigend oder Absteigend sortiert werden soll.

Präsentation

Auf die Registerkarte Eigenschaften der Multibox: Präsentation gelangen Sie, indem Sie mit der rechten Maustaste auf eine Multibox klicken und den Befehl Eigenschaften im Menü Objekt auswählen. Hier können Sie das Layout der Multibox-Zellen konfigurieren. Markieren Sie ein oder mehrere Felder, für die Sie Einstellungen vornehmen möchten. Es gibt auch Einstellungen, die sich auf die geschlossene Multibox beziehen.

Ausrichtung Richten Sie die Werte des markierten Feldes linksbündig, zentriert oder rechtsbündig aus. Text und Zahlen können einzeln ausgerichtet werden.
Mehrzeilige Zellen Legen Sie fest, ob für das markierte Feld mehrzeilige Zellen angezeigt werden sollen, was für lange Textstrings nützlich ist.
Text umbrechen
Zeigt den Inhalt der Zellen in mehreren Zeilen an.
Größe der ZellennZeilen
Hier wird die gewünschte Einschränkung für die Anzahl der Zeilen in einer Zelle festgelegt.
Häufigkeit Anzeigen
Blendet die Anzeige der Häufigkeit der Feldwerte ein oder aus. Mit Häufigkeit ist die Zahl der wählbaren Kombinationen gemeint, in denen der Wert erscheint.
In Prozent
Zeigt statt absoluter Werte die Häufigkeiten in Prozent bezogen auf die Gesamtzahl der Datensätze an.
Erweitert Öffnet den Dialog Erweiterte Einstellungen für markiertes Feld, wo Ihnen Optionen für eine grafische Interpretation der Werte und spezielle Suchfunktionen zur Verfügung stehen.
Einzelne Spalte Stellt den Inhalt des markierten Feldes in jedem Fall in einer einzelnen Spalte dar.
Horizontale Scroll-Leiste ausblenden Wenn Sie diese Option aktivieren, bekommt die Multibox keine horizontale Scroll-Leiste die normal angezeigt wird, wenn die Feldwerte zu breit für die bestimmte Breite der Multibox sind. Feldwerte werden entsprechend an die Anzeige angepasst.
Nach Spalte sortieren In Multiboxen mit mehr als einer Spalte werden die Werte zeilenweise der angegebenen Sortierfolge entsprechend angeordnet. Durch die Option Nach Spalte sortieren werden die Werte spaltenweise angezeigt.
Trennlinien Zeigt horizontale Trennlinien zwischen den Zellen des markierten Feldes an. Die Option Trennlinien ist automatisch aktiviert, wenn die Option Text umbrechen ausgewählt ist, kann jedoch auch nachträglich deaktiviert werden.
Ausgeschlossene Werte ausblenden Diese Option regelt, ob ausgeschlossene Feldwerte angezeigt werden sollen oder nicht. Ausgeschlossene Werte können in diesem Fall nicht ausgewählt werden.
Read Only Ist diese Option aktiviert, können in dem markierten Feld keine Werte ausgewählt werden.
NULL-Werte ignorieren Erst wenn nur noch ein Wert des markierten Feldes ausgewählt bzw. wählbar ist, zeigt die Multibox diesen an. Sollen NULL-Werte in diesem Zusammenhang nicht mitgezählt werden, aktivieren Sie diese Option.
Hinweis: Bitte bedenken Sie, dass die Multibox dadurch möglicherweise Werte zeigt, die nicht in logischem Zusammenhang stehen.
Sperrung ignorieren Durch diese Option können in der Multibox in dem markierten Feld Werte ausgewählt werden, auch wenn es gesperrt ist. Das Feld bleibt jedoch gesperrt für logische Änderungen durch Auswahlaktionen in anderen Feldern.
Blockraster Ändert die Darstellung der Multibox, so dass die Feldnamen über den zugehörigen Dropdown-Listen stehen.
Read Only Ist diese Option aktiviert, können in der Multibox keine Werte mehr ausgewählt werden.
Farbe geschlossener Felder Hier legen Sie die Farbe für die geschlossenen Felder der Multibox fest. Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Dropdown beschränken auf n Zeilen Beschränkt die Zahl der in den Dropdown-Listen angezeigten Werte. Geben Sie eine Maximalzahl von Werten ein.
Design Wählen Sie in dieser Dropdown-Liste den Stil Klassisch oder den Stil Modern für die Multibox aus.
Hintergrund Führt in den Dialog Hintergrund gestalten.

Erweiterte Einstellungen für markiertes Feld

In das Dialogfeld Erweiterte Einstellungen für markiertes Feld gelangen Sie über Eigenschaften der Multibox: Präsentation, Eigenschaften der Tabellenbox: Präsentation und Diagrammeigenschaften: Dimensionen. Für grafische Diagramme sind die nachfolgend beschriebenen Optionen für Bilder nicht verfügbar.

Optionen für Bilder

Repräsentation Folgende Optionen sind verfügbar:
Text
Die Werte werden immer als Text interpretiert und angezeigt.
Bild
Die Formelwerte in QlikView werden als Referenzen zu Bildern interpretiert. Die Referenzen können auf extern gespeicherte Bilder verweisen (z. B. C:\MeinBild.jpg) oder auf Bilder, die in das Dokument eingebunden sind (z. B. qmem://Name/Peter). Kann QlikView einen Formelwert nicht als gültige Bildreferenz interpretieren, wird stattdessen der Wert selbst angezeigt.
Info als Bild
Es werden in QlikView die Bilder angezeigt, die den Werten des Feldes durch info load/select im Skript zugewiesen wurden. Ist die Option Text ausblenden wenn Bild fehlt nicht ausgewählt, steht für den Feldwert keine Info zur Verfügung, wird der eigentliche Wert angezeigt. Diese Option ist für Bitmap-Diagramme nicht verfügbar.
Bild anpassen Diese Optionen sind nur verfügbar, wenn unter Repräsentation die Optionen für Bilder ausgewählt wurden. Hier legen Sie fest, wie das Bild in die Zelle eingepasst werden soll. Es stehen vier Optionen zur Verfügung.
Original
Wird diese Option ausgewählt, wird das Bild ohne Strecken in Originalgröße angezeigt. Es kann sein, dass das Bild nicht vollständig zu sehen ist oder ein Teil der Zelle leer bleibt.
Strecken
Passt das Bild ohne Rücksicht auf das Seitenverhältnis so an, dass es die Zelle genau ausfüllt.
Minimal anpassen
Damit wird das Bild soweit wie möglich gestreckt, um den Textobjektbereich auszufüllen, während das Seitenverhältnis beibehalten wird. Der verbleibende Platz in der Zelle bleibt leer.
Maximal anpassen
Damit wird das Bild bei festem Seitenverhältnis so gestreckt, dass es die Textbox in beiden Richtungen füllt. Dabei wird das Bild gegebenenfalls abgeschnitten.
Text ausblenden wenn Bild fehlt Wenn diese Option gewählt wird, zeigt QlikView den Feldwerttext nicht an, wenn die Referenz zum Bild aus irgendeinem Grund nicht interpretiert werden kann. Die Zelle bleibt in diesem Fall leer.
Visualisierung des Auswahlstatus Wenn anstelle von Text Bilder angezeigt werden, ist es möglicherweise erforderlich, einen anderen Auswahlstatus als den Dokumentstandard zu verwenden, so dass der logische Status der Feldwerte sichtbar bleibt. Treffen Sie in der angezeigten Dropdown-Liste unter Visualisierung des Auswahlstatus eine passende Auswahl, wie beispielsweise Fotoecken.

Suchoptionen

Hier legen Sie fest, wie in den Werten des Feldes beim Dropdown in Multibox, Tabellenbox, Pivottabelle oder Tabellendiagramm normalerweise gesucht wird.

Auch in ausgeschlossenen Werten suchen Mit dieser Einstellung definieren Sie, ob sich die Suche nur auf wählbare oder auch auf ausgeschlossene Werte des Feldes beziehen soll. Folgende Optionen sind verfügbar:
<Standard verwenden>
Es wird der in den Benutzereinstellungen ausgewählte Standard verwendet.
Ja
Ausgeschlossene Werte werden bei der Textsuche immer berücksichtigt.
Nein
Ausgeschlossene Werte werden bei der Textsuche niemals berücksichtigt. Optionale Werte werden wie immer berücksichtigt.
Standard-Suchmodus Mit dieser Einstellung legen Sie fest, wie Sie in der Listbox im Allgemeinen suchen möchten. Sie können den Modus auch noch während der Eingabe des Suchworts ändern, indem Sie * oder ~ im Suchfenster eingeben. Folgende Optionen sind verfügbar:
<Standard verwenden>
Es wird der in den Benutzereinstellungen ausgewählte Standard verwendet.
Suche mit Wildcards
Die anfängliche Suchzeichenfolge besteht in dem von zwei Wildcards umschlossenen Cursor für eine einfache Wildcard-Suche.
Fuzzy-Suche verwenden
Dem Suchwort wird eine Tilde (~) für die Fuzzy-Suche vorangestellt.
Normale Suche
Zum Suchwort werden keine weiteren Zeichen hinzugefügt. Eine normale Suche ohne Wildcards wird durchgeführt.

Zahl

Auf die Registerkarte Eigenschaften der Multibox: Zahlen gelangen Sie, indem Sie mit der rechten Maustaste auf die Multibox klicken und den Befehl Eigenschaften im Objekt-Menü auswählen.

Hier definieren Sie Zahlenformate für die Feldwerte in der Multibox. Sie können für jedes Feld ein individuelles Zahlenformat wählen. Markieren Sie dazu das Feld in der Liste. Per Umschalt- oder Strg-Klick können Sie mehrere Felder markieren.

Jedes Feld hat ein Standardzahlenformat, das auf der Seite Dokumenteigenschaften: Zahlen festgelegt werden kann. Sie können jedoch in einem individuellen Objekt ein abweichendes Zahlenformat definieren. Aktivieren Sie dazu die Option Dokument-Standard ignorieren, und wählen Sie ein anderes Zahlenformat. Die Eigenschaftenseite bezieht sich auf das aktive Objekt und enthält die folgenden Steuerelemente für die Formatierung von Werten:

Gemischt Zahlen und Text. Zahlen werden im Originalformat gezeigt.
Zahl Rundet numerische Werte auf die unter Genauigkeit angegebene Zahl von Stellen.
Ganze Zahl Zeigt numerische Werte als ganze Zahlen an.
Dezimalzahl Zeigt numerische Werte als Dezimalzahlen mit der angegebenen Zahl von Stellen an.
Money Zeigt numerische Werte als Geldbeträge an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau. Standard ist das von Windows vorgegebene Währungsformat.
Date Zeigt numerische Werte als Datum an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Time Zeigt numerische Werte als Uhrzeit an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Timestamp Zeigt numerische Werte als Zeitstempel an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Interval Zeigt numerische Werte als die Zeitspanne an. Beispiel: Das Format = mm zeigt den Wert in Form der Minuten an, die seit dem Kalenderbeginn (30. Dezember 1899, 24:00 Uhr) vergangen sind.

Die Schaltfläche In % anzeigen ist für folgende Formate verfügbar: Zahl, Ganze Zahl und Dezimalzahl.

Unter Trennzeichen können Sie ein Dezimal- und ein Tausendertrennzeichen festlegen.

Durch die Schaltfläche ISO wird das Format für Datum, Uhrzeit, Zeitstempel und Intervall zurück auf ISO-Standard gesetzt.

Per Mausklick auf die Schaltfläche System werden die vom Betriebssystem vorgegebenen Formate eingestellt.

Mit der Schaltfläche Dokument-Standard ändern wird das Dialogfeld Dokumenteigenschaften: Zahlen geöffnet, in dem das Standardzahlenformat eines beliebigen Felds bearbeitet werden kann.

See also:

 
  • SchriftartSchriftschnittSchriftgrad
  • Eigenschaften des Objekts: SchriftartAuf Objekte anwendenEigenschaften des Dokuments: Schriftart
  • Eigenschaften des Dokuments: Schriftart
  • Benutzereinstellungen: Schriftart
  • Schriftfarbe festberechnet
  • Farbfunktionen

  • Rahmen
  • VereinfachtAussehen der ObjekteDokumenteigenschaften: AllgemeinSchattenBreite
  • Abgerundete Ecken
  • Abgerundete EckenAbgerundete EckenErweitertAussehen der ObjekteDokumenteigenschaften: Allgemein
  • Ebene
  • Ebene
  • Vorlagen-Assistent...
  • Assistent für Formatvorlagen
  • Vorlage anwenden ...
  • Formatvorlagen
  • Anzeigen
  • Anzeigen
  • Optionen
  • OptionenDokumenteigenschaften: LayoutEigenschaften des Arbeitsblatts: Sicherheit
  • Scroll-Leisten
  • Scroll-Leisten
  • Titelleiste
    Eigenschaften des Dokuments
  • Titelleiste
  • Aktive TitelleisteInaktive Titelleiste
  • HintergrundfarbeTextfarbeFarbflächeHintergrundfarbeFarbflächeFarbeFarbverlaufTextfarbefixedynamische
  • Farbfunktionen
  • normaleminimierte
  • Ausrichtung des Titels
  • Spezialsymbole

Schriftart

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.
Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

Layout

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.
Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.
Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.
Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.
Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.
Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.
Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.
Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.