Listbox

Die Listbox ist das einfachste und grundlegende Objekt in QlikView. Sie repräsentiert ein Feld einer Tabelle und enthält eine Liste mit allen Werten dieses Feldes. In Listboxen können Sie Werte auswählen und augenblicklich sehen, welche Daten logisch damit zusammenhängen. Die Auswahl von Werten entspricht somit einer Datenbankabfrage.

Listboxen können auch zur Anzeige von Drilldown-Gruppen oder zyklischen Gruppen verwendet werden. Im Fall einer Drilldown-Gruppe führt die Auswahl eines einzelnen Werts in der Listbox zu einem Drilldown auf das nächste Feld der Gruppe. Per Mausklick auf die Drillup-Schaltfläche in der Titelleiste stellen Sie die ursprüngliche Ansicht wieder her.

Zeigt die Listbox eine zyklische Gruppe, so können Sie mit Hilfe der Zyklus-Schaltfläche in der Titelleiste zum jeweils nächsten Feld der Gruppe wechseln. Im Objekt-Menü der Listbox können Sie durch den Befehl Felderzyklus direkt das gewünschte Feld auswählen.

Per rechtem Mausklick auf die Listbox öffnet sich das Objekt-Menü.

Objekt-Menü

Öffnen Sie das Objekt-Menü der Listbox durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

Eigenschaften Öffnet den Dialog Eigenschaften der Listbox. Dort können Sie einige Parameter einstellen.
Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Felderzyklus

Dieser Befehl ist nur verfügbar, wenn die Listbox eine zyklische Gruppe anzeigt. Er führt in ein Untermenü mit allen Feldern der zyklischen Gruppe zur direkten Auswahl des in der Listbox anzuzeigenden Felds.

Zyklische Gruppen

Suche

Öffnet das Suchfenster.

Suchen

Fuzzy-Suche

Öffnet das Suchfenster im Fuzzy-Modus.

Fuzzy-Suche

Erweiterte Suche

Öffnet das Suchfenster für die erweiterte Suche. Dieser Dialog ermöglicht die Eingabe von erweiterten Suchformeln. Dasselbe erreichen Sie mit der Tastenkombination STRG+UMSCHALT+F.

Suchfenster für die erweiterte Suche

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Wert ändern Nur verfügbar für Listboxen, die ein Inputfeld enthalten. Der Befehl versetzt die angeklickte Zelle in den Editiermodus. Alternativ können Sie auf das Input-Icon in der Zelle klicken.
Werte zurücksetzen Nur verfügbar für Listboxen, die ein Inputfeld enthalten. Der Befehl öffnet ein Untermenü mit drei Optionen:
Einzelnen Wert zurücksetzen
Setzt den Wert des angeklickten Felds auf den ursprünglich durch das Skript geladenen Wert zurück.
Wählbare Werte zurücksetzen
Setzt die Werte aller wählbaren Feldwerte auf deren Standardwert aus dem Skript zurück.
Alle Werte zurücksetzen
Setzt die Werte aller Feldwerte auf deren Standardwert aus dem Skript zurück.
Wählbare Werte auswählen Alle wählbaren Werte des Feldes werden ausgewählt.
Ausgeschlossene Werte auswählen Alle ausgeschlossenen Werte des Feldes werden ausgewählt.
Alle Werte auswählen Alle Werte des Feldes werden ausgewählt.
Löschen Hebt die Auswahl in der Listbox auf.
Auswahl in anderen Feldern aufheben Alle wählbaren Werte in der Listbox werden ausgewählt, danach wird die Auswahl in allen anderen Feldern aufgehoben.
Sperren Sperrt die Auswahl in der Listbox. (Ausgegraut, wenn keine Auswahl getroffen wurde.)
Freigeben Hebt die Sperrung in der aktiven Listbox auf. (Wird anstelle von Sperren angezeigt, wenn die Auswahl gesperrt wurde).
Quick-Diagramm anlegen

Startet den Assistenten für Quick-Diagramme, der ein einfaches Diagramm im abgekürzten Verfahren erstellt, d. h. in wenigen grundlegenden Arbeitsschritten.

Assistent für Quick-Diagramme

Zeitdiagramm anlegen

Öffnet den Assistenten für Zeitdiagramme. Dieser unterstützt Sie beim Anlegen von Diagrammen, bei denen eine Kennzahl (Formelwert) über einen Zeitraum betrachtet oder auch mit einem anderen Zeitraum verglichen wird.

Assistent für Zeitdiagramme

Neue Statistikbox Legt eine Statistikbox an, in der statistische Daten für das zugehörige Feld angezeigt werden.
Mögliche Auswahl drucken

Öffnet den Dialog Drucken, wo Sie die Druckeinstellungen vornehmen können. Alle nicht ausgeschlossenen Werte der aktiven Listbox werden an den Drucker übermittelt.

Drucken: Allgemein

Mögliche Auswahl als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Export nach Excel

Exportiert mögliche (einschließlich der gewählten) Werte nach Microsoft Excel, das automatisch gestartet wird, falls es nicht bereits ausgeführt wird. Die exportierten Werte erscheinen auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.

Hinweis: Mini-Diagramme werden beim Export nach Excel nicht exportiert.
Exportieren Öffnet den Dialog Speichern unter, in dem Pfad, Dateiname und (Tabellen-) Dateityp für den exportierten Dateninhalt angegebenen werden können.
In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Wählbare Werte
Kopiert die wählbaren bzw. ausgewählten Werte der Listbox in die Zwischenablage.
Wert der Zelle
Kopiert den Textwert der mit der rechten Maustaste angeklickten Listbox (beim Aufrufen des Objekt-Menüs) in die Zwischenablage.
Bild
Kopiert ein Bild des Arbeitsblattobjekts in die Zwischenablage. Das Bild enthält oder enthält nicht die Titelleiste und den Rahmen des Arbeitsblattobjekts, je nach den Einstellungen auf der Seite Benutzereinstellungen: Exportieren.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Zur Registerkarte Eigenschaften der Listbox: Allgemein gelangen Sie, indem Sie mit der rechten Maustaste auf eine Listbox klicken und den Befehl Eigenschaften im Objekt-Menü auswählen. Hier konfigurieren Sie die Listbox.

Titel

Titel der Listbox. Vorbesetzt wird der Feldname. Für das dynamische Update des Bezeichnungstexts kann auch ein dynamischer Ausdruck als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Feld Wählen Sie ein Feld in der Dropdown-Liste aus. Die Listbox enthält die Werte des ausgewählten Feldes.
Listboxen können Drilldown-Gruppen oder zyklische Gruppen anzeigen. Dabei wird jeweils nur ein Feld der Feldergruppe in der Listbox angezeigt. Feldergruppen werden im Dialogfeld Dokumenteigenschaften: Gruppen definiert und mit den verfügbaren Feldern angezeigt.
Im Fall einer Drilldown-Gruppe führt die Auswahl eines einzelnen Werts in der Listbox zu einem Drilldown auf das nächste Feld der Gruppe. Per Mausklick auf die in der Titelleiste erscheinende Drillup-Schaltfläche stellen Sie die ursprüngliche Ansicht wieder her.
Zeigt die Listbox eine zyklische Gruppe, so können Sie mit Hilfe der Zyklus-Schaltfläche in der Titelleiste zum jeweils nächsten Feld der Gruppe wechseln. Im Objekt-Menü der Listbox können Sie durch den Befehl Felderzyklus das gewünschte Feld direkt auswählen.
Weiterhin ist es möglich, ein Formelfeld in einer Listbox anzuzeigen. Ein Formelfeld ist nicht das Ergebnis eines Skripts, sondern wird durch eine Formel definiert. Dieselbe Regel gilt für dynamische Dimensionen. Wählen Sie dazu in der Dropdown-Liste <Formel> und definieren Sie die Formel im Dialog Formel bearbeiten.
Als Titel verwenden
Ist diese Option aktiviert, wird der Feldname als Titel eingesetzt. Im Eingabefeld Titel erscheint in diesem Fall <Feldname>.
Bearbeiten
Diese Schaltfläche ist nur verfügbar, wenn als Feld <Formel> gewählt ist. Wenn Sie darauf klicken, öffnet sich der Dialog Formel bearbeiten, wo Sie die Formel bearbeiten können.
Hinweis: Enthält eine Listbox ein dynamisch berechnetes Feld, ist die Funktionalität der Listbox möglicherweise leicht modifiziert. Manche Optionen sind gegebenenfalls nicht verfügbar (siehe unten). Ferner können keine Statistikboxen für dynamische Felder angelegt werden.
Hinweis: Dynamische Felder müssen sich stets aus einem oder mehreren Feldern berechnen. Rein synthetische, über die valuelist- oder valueloop-Funktion berechnete Felder sind nicht zulässig. Bei Auswahlaktionen in dynamisch berechneten Feldern werden die der Berechnung zugrunde liegenden „echten“ Feldwerte ausgewählt. Berechnet sich das dynamische Feld anhand mehrerer Felder, können die logischen Zusammenhänge bei unterschiedlichen Auswahlkonstellationen mitunter recht komplex sein.  
Hinweis: Bei sehr großen Datenmengen können Listboxen mit dynamisch berechneten Feldern unter Umständen zu Performance-Problemen führen.
Hinweis: Es ist nicht möglich, MEASURE-Felder, die mithilfe der Funktion Direct Discovery definiert worden sind, in einer Listbox zu verwenden.
Und-Modus

Bei Auswahl mehrerer Werte in einem Feld kann ein logisches UND oder ein logisches ODER zugrunde gelegt werden. Standardmäßig ist die Auswahl eine ODER-Verknüpfung. Aktivieren Sie diese Option, wenn stattdessen eine UND-Verknüpfung interpretiert werden soll. Diese Option ist nur für Felder verfügbar, die bestimmten Bedingungen genügen. Diese Option ist für berechnete Felder nicht verfügbar.

Alternativen anzeigen Standardmäßig werden bei Auswahl von Werten in einer Listbox die verbleibenden Werte automatisch ausgeschlossen. Ist die Option Alternativen anzeigen jedoch aktiviert, bleiben die verbleibenden Werte wählbar, auch wenn sie nicht mit den ausgewählten Werten der Listbox zusammenhängen. Lediglich durch die Auswahl von Werten in anderen Objekten können diese Werte ausgeschlossen werden. Anderenfalls werden sie von vornherein ausgeschlossen und grau hinterlegt. Diese Option ist für berechnete Felder nicht verfügbar.
Ausgeschlossene Werte ausblenden Diese Option regelt, ob ausgeschlossene Werte angezeigt werden sollen oder nicht. Ausgeschlossene Werte können in diesem Fall nicht ausgewählt werden.
Read Only Ist diese Option aktiviert, kann der Auswahlstatus in der Listbox nicht verändert werden. Statusänderungen durch Auswahl in anderen Feldern werden aber weiterhin angezeigt.
Genau ein ausgewählter Wert

Durch diese Option kann in der Listbox nur ein Wert ausgewählt werden. Dies ist sinnvoll, wenn Eindeutigkeit gegeben sein muss, z. B. in einem Währungsfeld. Diese Option wird erst verfügbar, wenn in der Listbox genau ein Wert ausgewählt ist. Diese Option ist für berechnete Felder nicht verfügbar.

Hinweis: Durch das Aktivieren dieser Option wird das Datenmodell modifiziert. Als Folge davon funktionieren vorhandene Lesezeichen möglicherweise nicht mehr, selbst wenn Sie dieselben Feldnamen beibehalten.
Sperrung ignorieren Durch diese Option können in der Listbox Werte ausgewählt werden, auch wenn das Feld gesperrt ist. Die Sperrung bleibt jedoch erhalten für logische Änderungen durch Auswahlaktionen in anderen Feldern.
Baumansicht

Zeigt in der Listbox eine Baumansicht an. Diese Funktion ist nur relevant, wenn Felder die Pfadrepräsentation von Knoten in einer Hierarchie enthalten. Solche Felder werden mit dem Parameter Path des Präfixes Hierarchy generiert.

Baumansicht in Listboxen

Trennzeichen Zeichen, das als Trennzeichen in den Pfaden der Hierarchie verwendet wird.
Häufigkeiten anzeigen Blendet den Status der Häufigkeit eines Feldwertes ein oder aus. Mit Häufigkeit ist die Zahl der wählbaren Kombinationen gemeint, in denen der Wert erscheint. Diese Option ist für berechnete Felder nicht verfügbar.
In Prozent Zeigt statt absoluter Werte die Häufigkeiten in Prozent bezogen auf die Gesamtzahl der Datensätze an.
Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Die ID für Listboxen beginnt mit LB01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Interner Makro-Interpreter

Auch in ausgeschlossenen Werten suchen Mit den Optionen Ja, Nein oder <Standard verwenden> der Dropdown-Liste wird mit der Option gesucht, die Sie im Dialogfeld Benutzereinstellungen: Allgemein ausgewählt haben.
Standard-Suchmodus Legen Sie fest, wie Sie in der Listbox im Allgemeinen suchen möchten. Sie können den Modus auch noch während der Eingabe des Suchworts ändern, indem Sie * oder ~ im Suchfenster eingeben. Folgende Optionen sind verfügbar:
<Standard> verwenden
Es wird der in den Benutzereinstellungen ausgewählte Standard verwendet.
Suche mit Wildcards
Die anfängliche Suchzeichenfolge besteht in dem von zwei Wildcards umschlossenen Cursor für eine einfache Wildcard-Suche.
Fuzzy-Suche verwenden
Dem Suchwort wird eine Tilde (~) für die Fuzzy-Suche vorangestellt.
Normale Suche
Zum Suchwort werden keine weiteren Zeichen hinzugefügt. Eine normale Suche ohne Wildcards wird durchgeführt.
Assoziative Suche verwenden
Assoziative Suche wird im Suchfeld verwendet.

Suchen

Druckoptionen Führt in den Dialog „Druckoptionen“, wo Sie Seitenränder, Kopf- und Fußzeilen für den Druck des Objekts definieren können.
Alle Werte drucken Normalerweise werden beim Druck von Listboxen nur die ausgewählten oder wählbaren Werte gedruckt. Aktivieren Sie diese Option, um alle Werte (d. h. auch die ausgeschlossenen) zu drucken.
Druck wie Layout Ist diese Option aktiviert, wird die Listbox so ausgedruckt, wie sie auf dem Arbeitsblatt erscheint, d. h. gegebenenfalls mit mehreren Spalten und mit der farbigen Codierung des Auswahlstatus. Dies ist z. B. hilfreich, wenn die Listbox in einen Report eingefügt wird.

Formeln

Unter Formeln stellen Sie eine oder mehrere Formeln zusammen zur Anzeige von berechneten Werten in der Listbox. Jede Formel erhält eine eigene Spalte in der Listbox. In der oberen linken Ecke des Dialogs sehen Sie eine Liste der definierten Formeln.

Mit Hilfe von Attributformeln kann die Darstellung dynamisch gestaltet werden. Klicken Sie auf das Erweiterungssymbol vor der Formel, um die Attributformeln der Formel einzublenden.

Sie können eine beliebige Anzahl und Kombination aus Attributformeln für eine gegebene Grundformel verwenden. Die Gestaltung durch Attributformeln hat Vorrang vor den normalen Einstellungen.

Add Per Mausklick auf diese Schaltfläche gelangen Sie in den Dialog Formel bearbeiten. Dort können Sie eine neue Formel definieren. Diese Option finden Sie auch im Formelmenü, das sich durch rechten Mausklick auf eine Formel in der Formelliste öffnet.
Löschen Löscht die markierte Formel. Diese Option finden Sie auch im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet.
Kopieren Diese Option finden Sie im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet. Wenn Sie diesen Befehl für eine Hauptformel verwenden, werden alle mit der Formel (einschließlich Bezeichnung) verbundenen Daten und Einstellungen im XML-Format in die Zwischenablage kopiert. Die Formel kann dann an anderer Stelle in ein QlikView Objekt eingefügt werden. Der Befehl kann auch auf Attributformeln angewendet werden. In diesem Fall wird nur die Definition der Attributformel kopiert. Die Attributformel kann in jede Formel in demselben oder einem anderen Objekt eingefügt werden.
Exportieren Diese Option finden Sie im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet. Wenn Sie diesen Befehl für eine Hauptformel verwenden, werden alle mit der Formel (einschließlich Bezeichnung) verbundenen Daten und Einstellungen in eine XML-Datei exportiert. Eine exportierte Formel kann im selben oder in einem anderen QlikView-Dokument wieder importiert werden. Im Dialog Formel exportieren können Sie den Speicherort wählen. Die Formel erhält als Dateierweiterung xml.
Einfügen Diese Option finden Sie - wenn eine Formel in der Zwischenablage abgelegt wurde - im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet. Eine zuvor in die Zwischenablage kopierte Formel wird in die Formelliste eingefügt. Dadurch wird eine neue Formel erstellt, die mit der kopierten identisch ist. Wurde eine Attributformel kopiert, können Sie sie in eine Hauptformel einfügen.
Importieren Diese Option finden Sie im Formelmenü, das sich durch rechten Mausklick auf eine Formel öffnet. In einem daraufhin geöffneten Dialog können Sie zu der zuvor exportierten Formel navigieren. Die importierte Formel wird im Diagramm als neue Formel angezeigt.
Nach oben Verschiebt die markierte Formel in der Liste um einen Platz nach oben. So können Sie die Reihenfolge der Formeln ändern.
Nach unten Verschiebt die markierte Formel in der Liste um einen Platz nach unten. So können Sie die Reihenfolge der Formeln ändern.
Symbol für NULL-Werte Das hier eingegebene Symbol dient zur Anzeige der NULL-Werte in der Tabelle.
Symbol für fehlende Werte Das hier eingegebene Symbol dient zur Anzeige der fehlenden Werte in der Tabelle.
Aktivieren Diese Option aktiviert die markierte Formel. Eine Formel, die nicht aktiviert ist, wird ignoriert.
Definition Syntax der markierten Formel. Die Syntax kann direkt in diesem Feld editiert werden. Per Mausklick auf die Schaltfläche ... rechts daneben öffnet sich der Dialog Formeln bearbeiten.
Anzeigen Ist die Option Immer gewählt, werden die Werte der markierten Formel immer angezeigt. Durch die Option Bedingung werden die Werte der markierten Formel nur angezeigt, wenn die definierte logische Bedingung erfüllt ist.
Ausrichtung In dieser Gruppe kann die Standardausrichtung Ihrer Formeln festgelegt werden. Text und Zahlen können einzeln ausgerichtet werden.
Darstellung Legen Sie fest, in welcher Form die Werte der markierten Formel angezeigt werden.
Repräsentation Folgende Optionen sind verfügbar:
Text
Die Werte werden immer als Text interpretiert und angezeigt.
Bild
Die Formelwerte in QlikView werden als Referenzen zu Bildern interpretiert. Die Referenzen können auf extern gespeicherte Bilder verweisen (z. B. C:\MeinBild.jpg) oder auf Bilder, die in das Dokument eingebunden sind (z. B. qmem://Name/Peter). Kann QlikView einen Formelwert nicht als gültige Bildreferenz interpretieren, wird stattdessen der Wert selbst angezeigt.
Kreisförmiger Messzeiger
Wenn diese Option ausgewählt wird, zeigt QlikView die Formelwerte als kreisförmiger Messzeiger an. Die Ergebnisse der Formel werden als Messzeiger-Diagramm in der Zelle der Tabelle angezeigt. Klicken Sie auf Messzeiger konfigurieren..., um die Eigenschaften der Messzeiger zu ändern.
Linearer Messzeiger
Wenn diese Option ausgewählt wird, zeigt QlikView die Formelwerte als linearer Messzeiger an. Die Ergebnisse der Formel werden als Messzeiger-Diagramm in der Zelle der Tabelle angezeigt. Klicken Sie auf Messzeiger konfigurieren..., um die Eigenschaften der Messzeiger zu ändern.
Ampel-Messzeiger
Wenn diese Option ausgewählt wird, zeigt QlikView die Formelwerte als Ampel-Messzeiger an. Die Ergebnisse der Formel werden als Messzeiger-Diagramm in der Zelle der Tabelle angezeigt. Klicken Sie auf Messzeiger konfigurieren..., um die Eigenschaften der Messzeiger zu ändern.
Digitaler Messzeiger
Wenn diese Option ausgewählt wird, zeigt QlikView die Formelwerte als digitaler Messzeiger an. Die Ergebnisse der Formel werden als Messzeiger-Diagramm in der Zelle der Tabelle angezeigt. Klicken Sie auf Messzeiger konfigurieren..., um die Eigenschaften der Messzeiger zu ändern.
Mini-Diagramm
Bei Auswahl dieser Option zeigt QlikView den Formelwert in einem Miniaturdiagramm, wobei die Formel über einer Extra-Dimension aggregiert ist. Das Diagrammergebnis wird in die verfügbare Zelle der Tabelle eingetragen. Klicken Sie auf Mini-Diagramm konfigurieren, um die Eigenschaften der Mini-Diagramme festzulegen.
Hinweis: Mini-Diagramme werden beim Export nach Excel nicht mit exportiert.
Messbereich Diese Schaltfläche ist nur verfügbar, wenn Sie unter Repräsentation eine Anzeige durch Messzeiger gewählt haben. Per Mausklick auf diese Schaltfläche öffnet sich das Dialogfeld „Messzeiger konfigurieren“. Dieses entspricht im Wesentlichen dem Dialogfeld Eigenschaften des Diagramms: Präsentation für Messzeiger-Diagramme.
Mini-Diagramm konfigurieren Diese Schaltfläche ist nur verfügbar, wenn Sie unter Repräsentation die Anzeige als Mini-Diagramm gewählt haben. Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Eigenschaften des Mini-Diagramms.
Bild anpassen Diese Optionen sind nur verfügbar, wenn unter Repräsentation die Optionen für Bilder ausgewählt wurden. Hier legen Sie fest, wie das Bild in die Zelle eingepasst werden soll. Es stehen vier Optionen zur Verfügung.
Original
Wird diese Option ausgewählt, wird das Bild ohne Strecken in Originalgröße angezeigt. Es kann sein, dass das Bild nicht vollständig zu sehen ist oder ein Teil der Zelle leer bleibt.
Strecken
Passt das Bild ohne Rücksicht auf das Seitenverhältnis so an, dass es die Zelle genau ausfüllt.
Minimal anpassen
Damit wird das Bild soweit wie möglich gestreckt, um den Textobjektbereich auszufüllen, während das Seitenverhältnis beibehalten wird. Der verbleibende Platz in der Zelle bleibt leer.
Maximal anpassen
Damit wird das Bild bei festem Seitenverhältnis so gestreckt, dass es die Textbox in beiden Richtungen füllt. Dabei wird das Bild gegebenenfalls abgeschnitten.
Text ausblenden wenn Bild fehlt
Wenn diese Option gewählt wird, zeigt QlikView den Feldwerttext nicht an, wenn die Referenz zum Bild aus irgendeinem Grund nicht interpretiert werden kann. Die Zelle bleibt in diesem Fall leer.

Mini-Diagramm konfigurieren

Nur verfügbar, wenn die Option Mini-Diagramm auf der Seite Formeln im Dialog Eigenschaften eines Tabellendiagramms ausgewählt ist. Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Eigenschaften des Mini-Diagramms.

Dimension Wählen Sie die Dimension, auf die sich die Formelwerte beziehen sollen.

Darstellung

Mode Wählen Sie zwischen Linien, Linien mit Punkten, Punkten, Balken und Plus/Minus-Balken.
Farbe Öffnet den Dialog Farbfläche, in dem Sie eine Farbe für die Mini-Diagramme wählen können.
Maximum farbig markieren Soll der Maximalwert des Mini-Diagramms hervorgehoben werden, aktivieren Sie diese Option, klicken Sie auf die farbige Schaltfläche, und wählen Sie im Dialog Farbfläche eine Farbe aus.
Minimum farbig markieren Soll der Minimalwert des Mini-Diagramms hervorgehoben werden, aktivieren Sie diese Option, klicken Sie auf die farbige Schaltfläche, und wählen Sie im Dialog Farbfläche eine Farbe aus.
Startwert farbig markieren Soll der Startwert des Mini-Diagramms hervorgehoben werden, aktivieren Sie diese Option, klicken Sie auf die farbige Schaltfläche, und wählen Sie im Dialog Farbfläche eine Farbe aus. Diese Option ist für Balken und Plus/Minus-Balken nicht verfügbar.
Endwert farbig markieren Soll der Endwert des Mini-Diagramms hervorgehoben werden, aktivieren Sie diese Option, klicken Sie auf die farbige Schaltfläche, und wählen Sie im Dialog Farbfläche eine Farbe aus. Diese Option ist für Balken und Plus/Minus-Balken nicht verfügbar.
Standardfarben Stellt die QlikView-Standardfarben für das Mini-Diagramm ein.
Skalenstartwert 0 Ist diese Option aktiviert, beginnt die x-Achse stets mit dem Wert Null. Diese Option ist für Plus/Minus-Balken nicht verfügbar.
Einheitliche y-Achsen-Skala Ist diese Option aktiviert, wird für alle Mini-Diagramme dieselbe y-Achsen-Skala zugrunde gelegt.

Sortieren

Die Dialogseite Sortieren existiert in den Eigenschaftsdialogen von Listboxen, Multiboxen, Tabellenboxen, Schiebereglern/Kalenderboxen usw. Gehen Sie mit einem rechten Mausklick auf das Objekt, und wählen Sie Eigenschaften aus dem Objekt-Menü (oder Objekt, Eigenschaften im Hauptmenü). Hier legen Sie die Sortierfolgen für die Werte der im Objekt angezeigten Felder fest. Gegebenenfalls sind nicht alle Optionen in allen Objekttypen verfügbar.

Sortieren nach:

Bundesstaat

Sortiert die Werte nach logischem Status (ausgewählt, optional, ausgeschlossen).
Durch die Option Bedingt aufsteigend werden die Werte nach Status sortiert, solange die Listbox Scroll-Leisten hat und nicht alle Werte zu sehen sind. Sind jedoch alle Werte zu sehen, wird die Sortierung nach Status deaktiviert und nach der nächsten gewählten Sortierfolge sortiert.

Hinweis: Verwenden Sie die Reihenfolge Bedingt aufsteigend nicht in einem Listenfeld innerhalb einer Sammelbox.
Formel Sortiert die Werte anhand der Formel, die Sie im Eingabefeld darunter eingeben. Bei Verwendung von Sortierformeln müssen Sie die der Berechnung zugrunde liegenden Werte über die Auswahlformel bestimmen, da die Formel anhand der ausgewählten/wählbaren Werte in der Liste berechnet und nur ausgewählte/wählbare Werte in der Liste sortiert werden.
Hinweis: Sortierformeln funktionieren nur mit numerischen Feldern und nicht mit Textfeldern.

Aggregierung und Auswahlformeln

Häufigkeit Sortiert die Werte nach der Häufigkeit, d. h. danach, wie oft sie in der internen Tabelle vorkommen.
Numerischer Wert Sortiert die Werte des Feldes nach ihrem numerischen Wert.
Text Sortiert die Feldwerte alphabetisch.
Lade-Reihenfolge Sortiert die Werte nach der Reihenfolge, in der sie geladen wurden.

Per Mausklick auf Standard setzen Sie die Sortierung zurück auf die Standardsortierfolge.

Sind mehrere Sortierfolgen aktiviert, wird nach folgender Priorität sortiert: Status, Formel, Häufigkeit, Numerischer Wert, Alphabet, Lade-Reihenfolge. Zu jeder Sortierung kann angegeben werden, ob Aufsteigend oder Absteigend sortiert werden soll.

Präsentation

Zur Registerkarte Eigenschaften der Listbox: Präsentation gelangen Sie, indem Sie mit der rechten Maustaste auf eine Listbox klicken und den Befehl Eigenschaften im Objekt-Menü auswählen. Hier konfigurieren Sie die Listbox.

In der Gruppe Optionen für Bilder können Sie einen Feldwert, der einen Verweis auf ein Bild im Speicher oder auf einem Speichermedium enthält, als das Bild interpretieren:

Wählen Sie unter Repräsentation zwischen Text (Standard), Bild und Info als Bild.

Wenn Sie Bild wählen, interpretiert QlikView die Werte als Referenzen zu Bildern. Diese Referenzen können auf extern gespeicherte Bilder verweisen (z. B. C:\MeinBild.jpg) oder auf Bilder, die in das Dokument eingebunden sind (z. B. qmem://Name/Peter). Kann QlikView die Referenz nicht interpretieren, wird stattdessen der Wert selbst angezeigt. Dies können Sie durch die Option Text ausblenden wenn Bild fehlt verhindern.

Wählen Sie Info als Bild, werden die Bilder angezeigt, die den Werten des Feldes durch die Befehle info load/info select im Skript zugewiesen wurden. Ist die Option Text ausblenden wenn Bild fehlt nicht ausgewählt, steht für den Feldwert keine Info zur Verfügung, wird der eigentliche Wert angezeigt.

Unter Bild anpassen legen Sie fest, wie das Bild in die Zelle der Multibox oder Tabelle eingepasst werden soll.

Original Zeigt das Bild einmal unverändert in der Mitte an. Es kann sein, dass das Bild nicht vollständig zu sehen ist oder ein Teil der Fläche leer bleibt.
Strecken Passt das Bild ohne Rücksicht auf das Seitenverhältnis so an, dass es die Zelle genau ausfüllt.
Minimal anpassen Passt das Bild bei festem Seitenverhältnis so an, dass es komplett zu sehen ist.
Maximal anpassen Passt das Bild bei festem Seitenverhältnis so an, dass es komplett zu sehen ist. Dabei wird das Bild gegebenenfalls abgeschnitten.

Wenn anstelle von Text Bilder angezeigt werden, ist es möglicherweise erforderlich, einen anderen Auswahlstatus als den Dokumentstandard zu verwenden, so dass der logische Status der Feldwerte sichtbar bleibt. Treffen Sie in der angezeigten Dropdown-Liste unter Visualisierung des Auswahlstatus eine passende Auswahl, wie beispielsweise Fotoecken.

Einzelne Spalte Stellt den Inhalt des markierten Feldes in jedem Fall in einer einzelnen Spalte dar.
Horizontale Scroll-Leiste ausblenden Ist diese Option aktiviert, wird die horizontale Scroll-Leiste nicht normal angezeigt, wenn die Feldwerte für die vorgegebene Breite der Listbox zu breit sind. Feldwerte werden entsprechend an die Anzeige angepasst.
Feste Spaltenzahl Zeigt stets die angegebene Zahl von Spalten in der Listbox an. Diese Option und die Option Einzelne Spalte schließen sich gegenseitig aus.
Nach Spalte sortieren In Listboxen mit mehr als einer Spalte werden die Werte zeilenweise der angegebenen Sortierfolge entsprechend angeordnet. Durch die Option Nach Spalte sortieren werden die Werte spaltenweise angezeigt.
Trennlinien Zeigt horizontale Trennlinien zwischen den Zellen des markierten Feldes an. Die Option Trennlinien ist automatisch aktiviert, wenn die Option Text umbrechen ausgewählt ist, kann jedoch auch nachträglich deaktiviert werden.
Suchwort
hervorheben
Ist diese Option aktiviert, wird bei der Suche das Suchwort in den Treffern farblich hervorgehoben.
Hintergrund Führt in den Dialog Hintergrund gestalten.
Ausrichtung Ausrichtung für Feldwerte in der Listbox. Text und Zahlen können einzeln ausgerichtet werden.
Mehrzeilige Zellen Legen Sie fest, ob für das markierte Feld mehrzeilige Zellen angezeigt werden sollen.
Wrap Cell Text
Zeigt den Inhalt der Zellen in mehreren Zeilen an.
Höhe n Zeilen
Bestimmen Sie die Zahl der Zeilen pro Zelle.

Hintergrund gestalten

Farbe Ist diese Option aktiviert, erhält das Objekt einen farbigen Hintergrund. Wählen Sie dazu eine Farbe per Mausklick auf die farbige Schaltfläche.
Transparenz Diese Optionen sind nur verfügbar, wenn ein farbiger Hintergrund gewählt ist. Definiert die Transparenz des farbigen Hintergrunds.
Bild Ist diese Option aktiviert, erhält das Objekt einen Bildhintergrund. Klicken Sie auf Durchsuchen, um ein Bild dafür auszuwählen. Per Mausklick auf Löschen wird das Hintergrundbild gelöscht.
Bild anpassen Diese Optionen sind nur verfügbar, wenn ein Bildhintergrund gewählt ist. Hier legen Sie fest, wie das Bild in den Hintergrund des Objekts eingepasst werden soll.
Original
Das Bild wird ohne Strecken in Originalgröße angezeigt. Es kann sein, dass das Bild nicht vollständig zu sehen ist oder ein Teil der Hintergrundfläche leer bleibt.
Strecken
Passt das Bild ohne Rücksicht auf das Seitenverhältnis so an, dass es den Hintergrund genau ausfüllt.
Minimal anpassen
Damit wird das Bild soweit wie möglich gestreckt, um den Hintergrund auzufüllen, während das Seitenverhältnis beibehalten wird.
Maximal anpassen
Damit wird das Bild bei festem Seitenverhältnis so gestreckt, dass es den Hintergrund in beiden Richtungen füllt. Dabei wird das Bild gegebenenfalls abgeschnitten.
Horizontale Ausrichtung Diese Optionen sind nur verfügbar, wenn ein Bildhintergrund gewählt ist. Richten Sie das Hintergrundbild links, zentriert oder rechts aus.
Vertikale Ausrichtung Diese Optionen sind nur verfügbar, wenn ein Bildhintergrund gewählt ist. Richten Sie das Hintergrundbild oben, zentiert oder unten aus.
Transparenz Diese Optionen sind nur verfügbar, wenn ein Bildhintergrund gewählt ist. Definiert die Transparenz des Bildhintergrunds.

Zahl

Zur Seite Eigenschaften: Zahl gelangen Sie, indem Sie mit der rechten Maustaste auf ein Arbeitsblattobjekt klicken und den Befehl Eigenschaften im Objekt-Menü auswählen.

Jedes Feld hat ein Standardzahlenformat, das auf der Seite Dokumenteigenschaften: Zahlen festgelegt werden kann. Sie können jedoch in einem individuellen Objekt ein abweichendes Zahlenformat definieren. Aktivieren Sie dazu die Option Dokument-Standard ignorieren, und wählen Sie ein anderes Zahlenformat. Die Eigenschaftenseite bezieht sich auf das aktive Objekt und enthält die folgenden Steuerelemente für die Formatierung von Werten:

Gemischt Zahlen und Text. Zahlen werden im Originalformat gezeigt.
Zahl Rundet numerische Werte auf die unter Genauigkeit angegebene Zahl von Stellen.
Ganze Zahl Zeigt numerische Werte als ganze Zahlen an.
Dezimalzahl N Stellen Zeigt numerische Werte als Dezimalzahlen mit der angegebenen Zahl von Stellen an.
Money Zeigt numerische Werte als Geldbeträge an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau. Standard ist das von Windows vorgegebene Währungsformat.
Date Zeigt numerische Werte als Datum an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Time Zeigt numerische Werte als Uhrzeit an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Timestamp Zeigt numerische Werte als Zeitstempel an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Interval Zeigt numerische Werte als die Zeitspanne an. Beispiel: Das Format = mm zeigt den Wert in Form der Minuten an, die seit dem Kalenderbeginn (30. Dezember 1899, 24:00 Uhr) vergangen sind.
In % anzeigen Diese Option betrifft die folgenden Formate: Zahl, Ganze Zahl und Dezimalzahl.

Unter Trennzeichen können Sie ein Dezimal- und ein Tausendertrennzeichen festlegen.

Durch die Schaltfläche ISO wird das Format für Datum, Uhrzeit, Zeitstempel und Intervall zurück auf ISO-Standard gesetzt.

Per Mausklick auf die Schaltfläche System werden die vom Betriebssystem vorgegebenen Formate eingestellt.

Mit der Schaltfläche Dokument-Standard ändern wird das Dialogfeld Dokumenteigenschaften: Zahlen geöffnet, in dem das Standardzahlenformat eines beliebigen Felds bearbeitet werden kann.

Schriftart

In diesem Dialog stellen Sie Schriftart, Schriftschnitt und Schriftgrad ein.

Die Schriftart kann für jedes einzelne Objekt (Eigenschaften des Objekts: Schriftart) oder für alle Objekte in einem Dokument festgelegt werden (Auf Objekte anwenden in Eigenschaften des Dokuments: Schriftart).

Ferner können Sie Standardschriftarten für neu angelegte Objekte im Dialogfeld Eigenschaften des Dokuments: Schriftart definieren. Es gibt zwei Standard-Schriftarten:

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.

Zudem können Sie die Standardschriftarten für neue Dokumente unter Benutzereinstellungen: Schriftart definieren.

Für Schaltflächen, Diagramme und Textboxen (außer Suchobjekten) können Sie außerdem eine Schriftfarbe auswählen. Die Farbe kann fest sein oder dynamisch anhand einer Formel berechnet werden. Die Farbformel muss eine gültige Farbe ergeben. Verwenden Sie hierzu die Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Farbfunktionen

Weitere Optionen in diesem Dialog:

Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

In der Vorschau wird ein Muster der aktuellen Einstellungen angezeigt.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.

Wenn Vereinfacht das ausgewählte Aussehen der Objekte in Dokumenteigenschaften: Allgemein ist, kann kein Rahmentyp ausgewählt werden. Es steht lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie die Option Erweitert Aussehen der Objekte in Dokumenteigenschaften: Allgemein ausgewählt haben.

Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent...

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Die Einstellungen in dieser Gruppe sind nur relevant, wenn die entsprechenden Kontrollkästchen in Dokumenteigenschaften: Layout und Eigenschaften des Arbeitsblatts: Sicherheit aktiviert werden.

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.

Eigenschaften von Titelleiste und Rahmen

Im Dialog Eigenschaften von Titelleiste und Rahmen können Sie die Eigenschaften von Titelleiste und Rahmen auf andere Objekte übertragen.

Eigenschaften übertragen auf... Aktivieren Sie diese Option, um die Eigenschaften auf andere Objekte des Dokuments zu übertragen.
1. Wählen Sie eine der folgenden Optionen:
Objekte auf diesem Arbeitsblatt
Wendet die Einstellungen nur auf Objekte im aktuellen Arbeitsblatt an. Diese Option ist nur verfügbar, wenn der Dialog aus den Eigenschaften eines Objekts heraus geöffnet wurde.
Objekte in diesem Dokument
Überträgt die Einstellungen auf Objekte im gesamten Dokument.
2. Wählen Sie eine der folgenden Optionen:
Nur dieser Objekttyp
Überträgt die Einstellungen auf alle Objekte dieses Typs. Diese Option ist nur verfügbar, wenn der Dialog aus den Eigenschaften eines Objekts heraus geöffnet wurde.
Alle Objekttypen
Überträgt die Einstellungen auf alle Objekte.
Als Standard für neue Objekte in diesem Dokument verwenden Aktivieren Sie diese Option, wenn die Eigenschaften für alle neu angelegten Objekte in diesem Dokument verwendet werden sollen. Diese Option ist nur verfügbar, wenn der Dialog aus den Eigenschaften eines Objekts heraus geöffnet wurde.

Baumansicht in Listboxen

Enthält ein Feld Pfade einer Hierarchie, z. B. Alle Produkte/Getränke/Alkoholische Getränke/Bier, kann diese Hierarchie in Form einer Baumansicht in der Listbox dargestellt werden. In der Baumansicht sind die Knoten eingerückt, um Ihnen die Navigation sowie das Ein- und Ausblenden einzelner Zweige der Hierarchie zu erleichtern.

In der Baumansicht können Sie wie gewohnt Werte auswählen. Auch die Auswahl von Werten auf unterschiedlichen Ebenen ist möglich.

Für Endknoten und Knoten, deren Unterknoten voll eingeblendet sind, wird die übliche farbige QlikView-Codierung des Auswahlstatus verwendet. Sind die Unterknoten ausgeblendet, könnten sie dagegen unterschiedlichen Status haben. In diesem Fall wird der Knoten nur dann grün unterlegt, wenn alle zugehörigen Werte ausgewählt sind, und grau wenn alle zugehörigen Werte ausgeschlossen sind. Anderenfalls bleibt der Knoten weiß. Ein Auswahlindikator zeigt den Status der ausgeblendeten Knoten.

Listboxen und Tabellenboxen mit Direct Discovery erstellen

Listboxen

Listboxen können mit DIMENSION- und MEASURE-Feldern erstellt werden. Wenn Sie ein MEASURE-Feld in einer Listbox-Formel verwenden, sollte die Funktion aggr() verwendet werden, um den aggregierten Wert des MEASURE-Felds mit einem DIMENSION-Feld zu zeigen. Auswahlen mithilfe von DIMENSION-Feldern in einer Listbox generieren SQL-Abfragen in der Datenquelle, um die entsprechende Tabelle im Speicher zu erstellen.

DETAIL-Felder sind in Listboxen nicht verfügbar.

Hinweis:

Da Listboxen nur die einmaligen Werte eines DIMENSION-Felds anzeigen, verwendet die von QlikView generierte Abfrage zum Anzeigen der Daten in der Listbox den Befehl DISTINCT, um die Daten aus der Datenbank abzurufen. Einige Datenbanken erfordern jedoch, dass die Abfrage eine GROUP BY-Klasse anstelle des DISTINCT-Befehls enthält. Wenn die Direct Discovery-Tabelle aus einer Datenbank stammt, die GROUP BY erfordert, ändern Sie das Standardverhalten der DIMENSION-Abfrage mit der Variablen DirectDistinctSupport.

DirectDistinctSupport

Tabellenboxen

Tabellenboxen können alle Direct Discovery-Feldtypen anzeigen und bieten die Möglichkeit, detaillierte Informationen für Felder in Spalten anzuzeigen, die Direct Discovery-Felder enthalten. Tabellenboxen sind die einzigen QlikView Objekte, in denen Felder mit der Bezeichnung DETAIL im Direct Query Load-Befehl verwendet werden können.

Wenn Direct Discovery-Felder in einer Tabellenbox verwendet werden, wird eine Grenze festgelegt, um die Anzahl der angezeigten Zeilen einzuschränken. Standardschwellenwert ist 1000 Datensätze. Diese Standardeinstellung kann mithilfe der DirectTableBoxListThreshold -Variablen im Ladeskript geändert werden Hier ein Beispiel:

SET DirectTableBoxListThreshold=5000

Die Begrenzung gilt nur für Tabellenboxen, die Direct Discovery-Felder enthalten. Tabellenboxen, die nur im Speicher befindliche Felder enthalten, werden durch die Einstellung DirectTableBoxListThreshold nicht eingeschränkt.

In der Tabellenbox werden erst Felder angezeigt, wenn die Auswahl weniger Datensätze als das Begrenzungslimit enthält.

Direct Discovery-Felder können in einer Tabellenbox mit internen Feldern gemischt werden. Tabellenboxen, die nur Direct Discovery-Felder enthalten, müsse auch ein DIMENSION-Feld aufweisen.

Tabellenboxen mit Direct Discovery-Daten zeigen auch dann alle ausgewählten Zeilen, wenn diese identische Daten enthalten. Tabellenboxen mit internen Daten zeigen jedoch nur eine der ausgewählten Zeilen, wenn diese identische Daten enthalten.