Inputbox

Die Inputbox dient dazu, Werte für QlikView­Variablen einzugeben bzw. diese Werte anzuzeigen.

Per rechtem Mausklick auf das Eingabefeld öffnet sich das Objekt-Menü. Dasselbe Menü finden Sie unter Objekt auf der Menüleiste, wenn die Inputbox aktiv ist.

Arbeiten mit Inputboxen

Inputboxen haben stets drei Spalten. In der ersten Spalte erscheinen Namen von Variablen, in der zweiten ein Gleichheitszeichen "=" und in der dritten Spalte die zu den Variablen gehörigen Werte. Die Zahl der angezeigten Variablen ist beliebig.

Variablen in QlikView sind Elemente, die im Gegensatz zu Feldern immer nur einen Wert enthalten. Darüber hinaus wird der Wert eines Feldes im Skript mit den Befehlen load und select definiert, während man den Wert einer Variablen mit den Befehlen let, set definieren kann. Die Zuweisung eines Werts kann auch über einen Aufruf der Automation-Schnittstelle erfolgen oder in einer Inputbox innerhalb des Layouts.

Variablen enthalten numerische oder alphanumerische Daten. Beginnt der Wert einer Variablen mit einem Gleichheitszeichen '=', interpretiert QlikView den Wert als Formel (QlikView-Formel) und liefert das Ergebnis statt des eigentlichen Formeltexts.

Die Inputbox zeigt stets den aktuellen Wert der Variablen. Klickt man auf einen solchen Wert, wird die zugehörige Zelle in den Editiermodus gesetzt, und Sie können den bisherigen Wert ändern. Besteht der Wert aus einer Formel, wird im Editiermodus die Formel statt ihrem Ergebnis angezeigt. Die Zelle im Editiermodus enthält in der Regel auch eine ...-Schaltfläche, durch die ein volles Editierfenster geöffnet und die Erstellung komplexer Formeln vereinfacht wird. Somit ist die Zelle einer Inputbox mit den Zellen der gängigen Tabellenkalkulationsprogramme zu vergleichen.

Inputboxen können so konfiguriert werden, dass sie Dropdown-Icons oder Scroll-Pfeile anzeigen, mit deren Hilfe man die zuletzt benutzten Werte oder vordefinierte Werte auswählen kann. Anhand von Eingabebeschränkungen kann man verhindern, dass unpassende Werte eingegeben werden. Bei Variablen im Read-Only-Modus kann der Wert in der Inputbox nicht geändert werden.

See also:

 
  • Objekt-Menü
  • Eigenschaften der InputboxAllgemeinEigenschaften
  • Eigenschaften der InputboxBeschränkungenEigenschaftenAngezeigten VariablenVariablenBeschränkungen
  • Eigenschaften des DokumentsVariablenEinstellungenEigenschaften des DokumentsVariablenSystemvariablen anzeigenNeu...Löschen
  • Einstellungen für markierte VariableWert...Formel bearbeiten
  • In Lesezeichen abspeichern
  • Eingabebeschränkungen
  • Werteliste
  • Vordefinierte Werte
  • See also:

  • Eigenschaften der InputboxZahlenEigenschaften
  • Variablen
  • Dokumenteigenschaften: Zahl
  • Dokument-Standard ignorieren
  • In % anzeigenZahlGanze ZahlDezimalzahl
  • TrennzeichenDezimalTausender
  • ISO
  • System
  • See also:

  • SchriftartSchriftschnittSchriftgrad
  • Eigenschaften des Objekts: SchriftartAuf Objekte anwendenEigenschaften des Dokuments: Schriftart
  • Eigenschaften des Dokuments: Schriftart
  • Benutzereinstellungen: Schriftart
  • Schriftfarbe festberechnet
  • Farbfunktionen

  • Rahmen
  • VereinfachtAussehen der ObjekteDokumenteigenschaften: AllgemeinSchattenBreite
  • Abgerundete Ecken
  • Abgerundete EckenAbgerundete EckenErweitertAussehen der ObjekteDokumenteigenschaften: Allgemein
  • Ebene
  • Ebene
  • Vorlagen-Assistent...
  • Assistent für Formatvorlagen
  • Vorlage anwenden ...
  • Formatvorlagen
  • Anzeigen
  • Anzeigen
  • Optionen
  • OptionenDokumenteigenschaften: LayoutEigenschaften des Arbeitsblatts: Sicherheit
  • Scroll-Leisten

Objekt-Menü

Eigenschaften... Öffnet die Seite Eigenschaften der Inputbox, wo die Parameter konfiguriert werden können.
Notizen

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Drucken… Öffnet den Dialog Drucken, wo Sie die Druckeinstellungen vornehmen können.
Als PDF drucken

Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Nachdem Sie dort auf Drucken geklickt haben, müssen Sie einen Namen für die PDF-Datei angeben. Dieser Befehl ist nur verfügbar, wenn ein PDF-Drucker installiert ist.

Export nach Excel Exportiert den Inhalt der Inputbox nach Microsoft Excel, das automatisch gestartet wird, falls es nicht bereits ausgeführt wird. Die exportierten Werte erscheinen auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.
Exportieren

Exportiert den Inhalt der Inputbox in eine Datei. Die Datei kann in einem der folgenden Formate gespeichert werden: Komma-getrennt, Semikolon-getrennt, Tab-getrennt, Hypertext (HTML), XML und Excel (xls oder xlsx). Standard ist das Format *.qvo (QlikView Output). Es handelt sich dabei um eine Tab-getrennte Textdatei.

In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Daten
Kopiert die Datenzeilen der Inputbox in die Zwischenablage. 
Wert der Zelle
Kopiert den Textwert der mit der rechten Maustaste angeklickten Zelle der Inputbox (zum Aufrufen des Objekt-Menüs) in die Zwischenablage.
Bild
Kopiert ein Bild des Arbeitsblattobjekts in die Zwischenablage. Das Bild enthält oder enthält nicht die Titelleiste und den Rahmen des Arbeitsblattobjekts, je nach den Einstellungen auf der Seite Benutzereinstellungen: Exportieren.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen Instanz von QlikView geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Titel

Titel der Inputbox. Für das dynamische Update des Bezeichnungstexts kann auch eine Formel als Titel eingegeben werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Verfügbare Variablen Liste der verfügbaren statistischen Variablen. Ist die Option Systemvariablen anzeigen aktiviert, erscheinen hier auch die Systemvariablen. Markieren Sie per Mausklick die Elemente, die Sie verwenden/entfernen möchten. Verschieben Sie sie mit den Schaltflächen Hinzufügen > oder < Entfernen in die gewünschte Spalte.
Systemvariablen anzeigen Zeigt in der Liste Verfügbare Variablen die Systemvariablen mit an.
Neue Variable Führt in den Dialog Neue Variable, wo Sie eine neue Variable definieren können.
Angezeigte Variablen Liste der in der Inputbox angezeigten Variablen. Beim Anlegen einer neuen Inputbox ist diese Liste zunächst leer.
Nach oben Verschiebt die markierte Variable in der Liste der angezeigten Variablen um einen Platz nach oben.
Nach unten Verschiebt die markierte Variable in der Liste der angezeigten Variablen um einen Platz nach unten.
Bezeichnung

Hier kann eine Bezeichnung für die markierte Variable eingetragen werden. Sie wird in der Inputbox anstelle des Variablennamens benutzt. Die Bezeichnung kann auch als Formel für ein dynamisches Update verwendet werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Alternativer Zustand Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID

Wird für Makro-Zwecke verwendet. Inputboxen tragen standardmäßig einzigartige IDs, die im Falle einer Inputbox mit IB01 beginnen. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Interner Makro-Interpreter

Präsentation

Variablen Liste der in der Inputbox angezeigten Variablen. Markieren Sie die Variable, deren Einstellungen Sie ändern möchten.
Gleichheitszeiten anzeigen Deaktivieren Sie diese Option, wenn in der Inputbox keine Gleichheitszeichen angezeigt werden sollen. Dies gilt für alle Variablen der Inputbox.
Hintergrund Führt in den Dialog Hintergrund gestalten.
Ausrichtung Richten Sie den Wert der markierten Variablen links, zentriert oder rechts aus.
Farben für markierte Zeile Hier können Sie die Zeile der markierten Variablen formatieren.
Hintergrund
Definieren Sie eine Hintergrundfarbe für die markierte statistische Größe. Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Text
Gibt die Textfarbe der ausgewählten Zeile an.
Auf alle Zeilen übertragen
Aktivieren Sie diese Option, bevor Sie auf Übernehmen oder OK klicken, um die ausgewählten Farben auf alle Zeilen der Inputbox zu übertragen.

Beschränkungen

Keine Beschränkungen Alle Werte werden akzeptiert.
Standard Die eingegebenen Werte werden mit einer Reihe üblicher Standardbeschränkungen verglichen, die aus der Dropdown-Box ausgewählt werden können. Standardmäßig sind keine Beschränkungen ausgewählt, d. h. es können beliebige Werte für die Variable eingegeben werden. Nur eine der Optionen Standard, Benutzerdefiniert, Nur vordefinierte Werte und Schreibgeschützt kann ausgewählt werden.
Benutzerdefiniert Hier kann eine Eingabebeschränkung in Form einer logischen Formel definiert werden. Die QlikView-Formel muss WAHR (d. h. einen von Null verschiedenen Wert) ergeben, wenn der eingegebene Wert zulässig sein soll. Der eingegebene Wert erscheint in der Formel als Dollar-Zeichen ($).

Example:  

$>0 führt dazu, dass nur positive Zahlen akzeptiert werden.

Der zuletzt eingegebene Wert erscheint in der Formel als Name der Variablen.

Example:  

$>=abc+1 als Beschränkung für die Variable abc führt dazu, dass nur Werte akzeptiert werden, die mindestens um 1 größer sind als der vorhergehende Wert.

Nur vordefinierte Werte Eingegebene Werte werden mit einer Liste von Werten verglichen, die in der Gruppe Vordefinierte Werte festgelegt wurden. Es können nur Werte eingegeben werden, die sich in der Liste finden.
Read Only Versetzt die markierte Variable in den Read-Only-Modus, d. h. es können keine Werte eingegeben werden.
Dialog "Formel bearbeiten zulassen" Ist diese Option aktiviert, erscheint in der Inputbox die Schaltfläche ..., die in den Dialog Formel bearbeiten führt.
Sound bei ungültiger Eingabe Ist diese Option aktiviert, gibt QlikView bei Eingabe eines nicht zulässigen Werts ein akustisches Signal aus.
Fehlermeldung

Die Eingabe eines unzulässigen Werts ignoriert QlikView normalerweise einfach. Wenn Sie diese Option auswählen, können Sie eine benutzerdefinierte Fehlermeldung festlegen, die dem Benutzer bei nicht korrekten Eingaben angezeigt wird. Die Fehlermeldung wird in die Bearbeitungsbox eingegeben. Sie kann auch als Formel für ein dynamisches Update verwendet werden. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Benutzerdefinierte Fehlermeldungen

Formelsyntax in dynamischen Ausdrücken

Keine Liste Es werden keine Werte zur Auswahl bereitgehalten.
Liste der N letzten Werte Die N zuletzt eingegebenen Werte werden in Form einer Dropdown-Liste zur Auswahl angeboten. Die Zahl der vorgehaltenen Werte legen Sie im Feld fest.
Vordefinierte Werte als Dropdown Die Liste Vordefinierte Werte (siehe unten) werden in Form einer Dropdown-Liste zur Auswahl angeboten.
Vordefinierte Werte mit Scroll Für die ausgewählte Variable in der Inputbox steht dem Benutzer eine Scroll-Steuerung zur Verfügung. Es ist möglich unter den Vordefinierten Werte zu scrollen.
Zahlenfolge Durch diese Option werden alle Werte einer Zahlenfolge mit einer unteren Grenze (Von) und einer oberen Grenze (Bis) und einer Schrittweite (Schritt) vordefiniert. Diese Option kann allein oder in Verbindung mit Gelistete Werte angewendet werden.
Gelistete Werte Durch diese Option werden beliebige Werte vordefiniert. Das können numerische oder alphanumerische Werte sein. Alphanumerische Werte müssen in einfachen Anführungszeichen stehen (z. B. 'abc'). Die Werte der Liste werden durch Semikolon ( ; ) voneinander abgetrennt (z. B. 'abc';45;14.3;'xyz' ). Diese Option kann allein oder in Verbindung mit Zahlenfolge angewendet werden.
Kommentar In diesem Kommentarfeld können Sie eine Bemerkung oder Erläuterung zu der markierten Variablen eingeben.

Zahl

Mixed Zahlen und Text. Zahlen werden im Originalformat gezeigt.
Zahl Rundet numerische Werte auf die unter Genauigkeit angegebene Zahl von Stellen.
Ganze Zahl Zeigt numerische Werte als ganze Zahlen an.
Dezimalzahl Zeigt numerische Werte als Dezimalzahlen mit der angegebenen Zahl von Stellen an.
Währung Zeigt numerische Werte als Geldbeträge an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau. Standard ist das von Windows vorgegebene Währungsformat.
Datum Zeigt numerische Werte als Datum an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Time Zeigt numerische Werte als Uhrzeit an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Zeitstempel Zeigt numerische Werte als Zeitstempel an, wie im Feld Formatcode vorgegeben. Ein Muster sehen Sie in der Vorschau.
Intervall Zeigt die Zeit als aufeinanderfolgende Zeitschritte an (z. B. Format = mm zeigt den Wert in Minuten an, die seit dem Kalenderbeginn vergangen sind (1899:12:30:24:00).

Schriftart

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.
Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

Layout

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.
Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.
Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.