Menü Datei

Das Dropdown-Menü Datei finden Sie auf der Menüleiste. Es enthält folgende Befehle:

Neu Öffnet ein neues QlikView-Fenster und ermöglicht die Erstellung einer neuen QlikView-Datei.
Öffnen Öffnet ein bestehendes QlikView-Dokument oder eine Tabellendatei. Beim Öffnen von Tabellendateien gelangen Sie automatisch in den Dateiassistenten. Dasselbe erreichen Sie mit der Tastenkombination Strg+O.
Auf dem Server öffnen Öffnet einen Dialog, in dem Sie auf einen QlikView Server zugreifen und ein Dokument im Client-Modus öffnen können.
Dasselbe erreichen Sie mit der Tastenkombination STRG+UMSCHALT+O.
Hinweis: Wenn Sie ein QlikView Server-Dokument im Client-Modus öffnen, haben Sie nur eine eingeschränkte Funktionalität zur Verfügung. Je nach Client-Variante und Server-Einstellungen können Sie gegebenenfalls Veränderungen am Layout vornehmen. Objekte können nicht hinzugefügt oder gelöscht werden. Möglicherweise können nicht alle Eigenschaftsdialoge aufgerufen werden. Ferner sind eventuell auch das Ändern von Makros, der Skriptzugriff, das Laden von Daten oder das Speichern von Dokumenten nicht möglich.
Dokument aktualisieren Diese Schaltfläche wird nur verfügbar, wenn Sie mit einem Server-Dokument arbeiten, von dem eine neuere Version auf dem Server verfügbar ist. Durch den Befehl wird das Dokument aktualisiert, ohne dass Sie die Sitzung beenden müssen. Sogar das momentane Layout und der Auswahlstatus bleiben erhalten.
URL öffnen Führt in den Dialog URL öffnen. Dort können Sie die URL einer beliebigen Internetseite eingeben. Die Seite wird in einem eigenen Fenster innerhalb von QlikView angezeigt Dieser Befehl kann beispielsweise für den QlikView Publisher AccessPoint benutzt werden oder für QlikView Server-Dokumente, die mit dem AJAX-Client geöffnet werden. Geöffnete Webseiten sind genau wie geöffnete QlikView-Dokumente über das Menü Fenster zugänglich.
Über FTP öffnen Öffnet ein neues QlikView-Fenster, ermöglicht das Öffnen einer QlikView-Datei oder Tabelle von einem FTP-Server aus. Beim Öffnen von Tabellendateien gelangen Sie automatisch in den Dateiassistenten.
Schließen Schließt das aktive Dokument.
Favoriten Mit den Befehlen in diesem Untermenü können Sie eine Favoritenliste mit häufig benutzten Dokumente anlegen und verwalten. Diese ist unabhängig von den zuletzt geöffneten Dokumenten (siehe unten).
Speichern

Speichert das aktive QlikView-Dokument. Daten, Skript und Layout werden gespeichert. Dasselbe erreichen Sie mit der Tastenkombination STRG+S.

Zum Freigeben eines QlikView-Dokuments über die AJAX-Clients darf der Dateiname kein Hash-Zeichen (#) enthalten.

Speichern unter

Speichert das komplette QlikView-Dokument unter anderem Namen, d. h. in eine neue Datei. Dasselbe erreichen Sie mit der Tastenkombination F12.

Zum Freigeben eines QlikView-Dokuments über die AJAX-Clients darf der Dateiname kein Hash-Zeichen (#) enthalten.

Link speichern Speichert den Link zu einem Dokument auf einem QlikView-Server als Textdatei. Diese Datei erhält die Erweiterung qvw, enthält aber nicht das QlikView-Dokument, d. h. keine Daten und Layoutinformationen. Beim Öffnen der Linkdatei stellt QlikView eine Verbindung zum QlikView Server her und öffnet das Dokument. Dieser Befehl ist für lokal gespeicherte Dokumente nicht verfügbar.
Dokument per E-Mail versenden Dieser Befehl ist nur bei der Arbeit mit Server-Dokumenten verfügbar. Er verschickt eine Kopie des aktiven Dokuments als Anhang in einer E-Mail. Der E-Mail-Empfänger kann das Dokument öffnen, sofern er QlikView auf seinem Computer installiert und die nötigen Zugriffsrechte für das Dokument hat. Dieser Befehl funktioniert nur, wenn ein Mail-Client auf dem Computer konfiguriert ist.
Hyperlink per E-Mail versenden Dieser Befehl ist nur bei der Arbeit mit QlikView Server-Dokumenten verfügbar. Er verschickt eine E-Mail mit einem Hyperlink zu dem aktiven Server-Dokument. Dabei wird der aktuelle Auswahlstatus und das Layout in einem temporären Lesezeichen gespeichert und im Hyperlink codiert. Wenn der Empfänger auf den Link klickt, öffnet sich das Server-Dokument und das Lesezeichen wird aufgerufen, vorausgesetzt der Empfänger hat die nötigen Zugriffsrechte für das Dokument und die darin enthaltenen Daten. Dieser Befehl funktioniert nur, wenn ein Mail-Client installiert ist Ferner muss der QlikView Server Lesezeichen zulassen.
Drucken… Führt in den Dialog Drucken. Von dort aus können Sie das aktive Objekt drucken. Dieser Befehl ist für Listboxen nicht verfügbar. Dasselbe erreichen Sie mit der Tastenkombination STRG+P.
Als PDF drucken Führt in den Dialog Drucken, wobei der Drucker PDF-XChange 3.0 vorausgewählt ist. Dasselbe erreichen Sie mit der Tastenkombination STRG+UMSCHALT+P.
Mögliche Auswahl drucken Führt in den Dialog Drucken. Von dort aus können Sie die wählbaren oder ausgewählten Werte der Listbox drucken. Von dort aus können Sie die wählbaren bzw. ausgewählten Werte der Listbox drucken.
Mögliche Auswahl als PDF drucken Dieser Befehl ist nur verfügbar, wenn eine List- oder Multibox aktiv ist.
Arbeitsblatt drucken Führt in den Dialog Drucken. Von dort aus können Sie das aktive Arbeitsblatt drucken.
Seitenansicht Zeigt eine Vorschau des druckbaren Objekts
Versionskontrolle Einstellungen
Zur Einstellung der Provider-DLL, die MSSCCI (Microsoft Source Code Control Interface) verwenden soll, wenn ein Projekt hinzugefügt oder aus der Versionskontrolle abgerufen wird.

Projekt zur Versionskontrolle hinzufügen
Speichert das geöffnete QlikView Dokument und erstellt automatisch ein Projektverzeichnis und Projektdateien. Veranlasst das Versionskontrollsystem, das Projekt der Versionskontrolle hinzuzufügen.

Projekt aus Versionskontrolle abrufen
Ruft ein Projekt aus der Versionskontrolle ab und baut das QlikView Dokument erneut aus den Projektdateien auf. In der Versionskontrolle werden keine QlikView-Daten gespeichert. Um das Dokument mit Daten zu füllen, muss der Befehl „Skript ausführen“ im neu aufgebauten Dokument ausgeführt werden.

Letzte Version abrufen
Ruft die neueste Version des Dokuments aus dem Versionskontrollsystem ab und baut das QlikView Dokument erneut auf.

Anstehende Änderungen einpflegen
Speichert das QlikView Dokument und führt einen Einpflegevorgang im Versionskontrollsystem durch. Dies kann verschiedene Versionskontrollvorgänge mit eigenen Dialogen beinhalten:
  • Neu erstellte Dateien hinzufügen.
  • Ausgecheckte Dateien rückgängig machen, die aus der Versionskontrolle gelöscht werden müssen.
  • Dateien entfernen, die zu entfernten Arbeitsblättern oder Objekten gehören, die in der Versionskontrolle enthalten sind.
  • Einpflegen geänderter Dateien.

Falls das Dokument vor dem Vorgang „Anstehende Änderungen einpflegen“ nicht aktuell war, öffnen Sie das Dokument erneut zum Laden der Projektänderungen, die eingeleitet werden könnten, während die Konflikte aufgelöst werden.

 

Anstehende Änderungen rückgängig machen
Macht Änderungen rückgängig. Falls es lokal geänderte Dateien gibt, die im Versionskontrollsystem nicht ausgecheckt werden, werden diese Dateien ausgecheckt, bevor der Checkout rückgängig gemacht wird. Mit diesem Vorgang wird das QlikView-Dokument neu aufgebaut, indem Dateien gelöscht werden, die hinzugefügt aber nicht eingepflegt wurden. Außerdem werden Verweise zu Dateien, die zur Löschung anstehen, wiederhergestellt.
Exportieren Inhalte exportieren...
Dieser Befehl ist nur verfügbar, wenn ein exportierbares Objekt aktiv ist. Es wird der Exportvorgang ausgeführt, der im Objekt-Menü des aktiven Objekts zu finden ist.

Arbeitsblatt als Bild exportieren...
Führt in einen Dialog zum Speichern des aktiven Arbeitsblatt in eine Bilddatei.

Dokument-Layout exportieren
Öffnet einen Dialog zum Speichern des Dokumentlayouts in einer XML-Datei. Die Daten des Dokuments werden nicht mitgespeichert.
Skript bearbeiten Führt in den Dialog Skript bearbeiten. Dort können Sie Skripte ändern, anhand derer Datenbankverbindungen hergestellt und Datenbanken geöffnet werden.
Skript ausführen Führt das Skript aus und lädt Daten in das Dokument ein. Dieser Befehl sollte ausgeführt werden, wenn die Datenquelle seit der letzten Ausführung des Skripts aktualisiert wurde. Dasselbe erreichen Sie mit der Tastenkombination STRG+R.
Skript partiell ausführen Führt das Skript aus und lädt Daten in das Dokument ein, einschließlich aller Skript-Befehle, z. B. Drop table, und lädt die Daten erneut in das aktive QlikView-Dokument. Es werden jedoch nur die Tabellen erneut geladen, deren "load"- und "select"-Befehle den Zusatz Ersetzen oder Hinzufügen tragen. Datentabellen, die von dieser Art „load“- oder „select“-Befehl nicht betroffen sind, werden von der partiellen Ausführung des Skripts nicht berührt. Dasselbe erreichen Sie mit der Tastenkombination STRG+UMSCHALT+R.
Daten eingrenzen Es wird ein Menü mit den folgenden beiden Befehlen geöffnet:

Wählbare Werte beibehalten
Verkleinert die QlikView Datenbank, indem alle ausgeschlossenen Werte gelöscht werden.

Alle Werte löschen
Erstellt eine Vorlage durch Löschen sämtlicher Werte aus der QlikView Datenbank. Die Datenbankstruktur und das Layout bleiben jedoch erhalten.
Tabellenstruktur Führt in den Dialog "Tabellenstruktur", wo die internen Tabellen, Felder und Verknüpfungen in einer grafischen Übersicht dargestellt sind. Dasselbe erreichen Sie mit der Tastenkombination STRG+T.
Liste der zuletzt geöffneten Dokumente Liste der zuletzt geöffneten QlikView-Dokumente. Die Anzahl der Dokumente können Sie im Dialogfeld Einstellungen: Benutzereinstellungen ändern. Die Standardanzahl ist 8. Die Auswahl einer dieser Optionen entspricht dem Befehl Öffnen.
Exit Schließt die geöffneten Dokumente und beendet QlikView.