Skript bearbeiten

In das Dialogfeld Skript bearbeiten gelangen Sie über das Menü Datei oder indem Sie auf das Symbol Skript bearbeiten in der Symbolleiste klicken.

Hier können Sie das Skript eingeben und ausführen, das zum Verbinden Ihres Dokuments mit einer ODBC-Datenquelle oder anderen Datendateien und zum Einlesen der gewünschten Informationen dient.

Das Skript kann man manuell eingeben oder automatisch generieren lassen. Komplexe Skriptbefehle müssen allerdings – zumindest teilweise – von Hand eingegeben werden.

Im Dialog Skript bearbeiten gibt es die automatische Vervollständigung, d. h. bereits während Ihrer Eingabe im Editierfeld schlägt Ihnen das Programm passende Syntax-Befehle und -Funktionen vor. Die Vorschläge umfassen auch Wörter, die Teil der Skript-Syntax sind. Ferner sind die im Skript vorkommenden Texttypen durch unterschiedliche Farben und Schriftarten codiert. Diese können Sie ändern, wenn Sie möchten. Wählen Sie dazu im Skripteditor aus dem Menü Extras den Befehl Editor konfigurieren.

Am oberen Rand enthält der Dialog mehrere Menüs. Einige der häufig gebrauchten Befehle sind auch als Schaltflächen auf der darunterliegenden Symbolleiste verfügbar. Die Symbolleiste enthält auch eine Dropdown-Liste der Registerblätter des Skripts.

Menüs im Dialog Skript bearbeiten

Das Skriptfenster

Im oberen Bereich des Dialogs Skript bearbeiten wird die Skriptsyntax angezeigt und editiert. Im unteren Bereich finden Sie Werkzeuge und Funktionen.

Das Skriptfenster

Im Skriptfenster wird die Syntax des Skripts angezeigt. Die Zeilen sind durchnummeriert. Das Skript kann unterteilt und auf mehrere Registerreiter verteilt werden, die bei der Ausführung des Skripts der Reihe nach von links nach rechts abgearbeitet werden.

Bei Verwendung eines verborgenen Skripts erscheint dieses auf einem eigenen Registerblatt ganz links. (Nur Anwender, die das erforderliche Passwort kennen, können es einsehen.)

Die im Skript vorkommenden Texttypen sind durch unterschiedliche Farben und Schriftarten codiert. Die farbige Codierung können Sie durch den Befehl Editor konfigurieren im Menü Extras ändern.

Werkzeuge und Funktionen

Der untere Bereich des Dialogs besteht aus mehreren Seiten, die Werkzeuge, Funktionen und Einstellungen zur Generierung des Skripts enthalten.