Containerbox

Die Containerbox dient als Platzhalter für OCX-Steuerungselemente.

Das Objektmenü der Containerbox finden Sie unter Objekt auf der Menüleiste, wenn die Containerbox aktiv ist.

OCX-Steuerungselemente sind fensterlose Programmteile, die von Ihnen, von Qlik oder vom Hersteller anderer Software-Programme entwickelt werden können, sofern sie den OCX-Vorgaben von QlikView entsprechen. Das Steuerungselement nimmt genau den Platz der Containerbox ein. Die Kommunikation zwischen QlikView und dem OCX-Steuerungselement erfolgt über den internen Makro-Interpreter.

Interner Makro-Interpreter.

Objekt-Menü

Öffnen Sie das Objekt-Menü der Containerbox durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

OCX-Eigenschaften Führt in den Eigenschaftsdialog des ausgewählten OCX-Steuerungselements. Dieser wird vom Entwickler des Steuerungselements bereitgestellt. Er kann daher variieren oder auch ganz fehlen.
Eigenschaften Öffnet den Dialog Eigenschaften der Containerbox, in dem Sie eine Reihe von Parametern einstellen können.
Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Bild
Kopiert die Containerbox als Bild in die Zwischenablage. Entsprechend der Einstellungen im Dialog Benutzereinstellungen unter Export sind Titel und Rahmen mit im Bild enthalten oder nicht.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Die Seite Eigenschaften der Containerbox\: Allgemein öffnen Sie, indem Sie mit der rechten Maustaste auf eine Containerbox klicken und den Befehl Eigenschaften im Objekt-Menü auswählen. Hier konfigurieren Sie die Containerbox.

 

Aktuelles OCX-Steuerungselement Name des derzeit verwendeten OCX-Steuerungselements.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Wir empfehlen, nur alphanumerische Zeichen in der ID zu verwenden. Für Containerboxen beginnt die ID mit CO01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Interner Makro-Interpreter

OCX-Steuerungselement auswählen Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Insert Object, wo Sie ein OCX-Steuerungselement auswählen können, das in der Containerbox angezeigt werden soll.
OCX-Eigenschaften Führt in den Eigenschaftsdialog des ausgewählten OCX-Steuerungselements. Dieser wird vom Entwickler des Steuerungselements bereitgestellt und variiert je nach Funktionalität. Gegebenenfalls ist ein solcher Eigenschaftsdialog auch nicht vorhanden.
Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.

Wenn Vereinfacht das ausgewählte Aussehen der Objekte in Dokumenteigenschaften: Allgemein ist, kann kein Rahmentyp ausgewählt werden. Es steht lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie die Option Erweitert Aussehen der Objekte in Dokumenteigenschaften: Allgemein ausgewählt haben.

Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent...

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Die Einstellungen in dieser Gruppe sind nur relevant, wenn die entsprechenden Kontrollkästchen in Dokumenteigenschaften: Layout und Eigenschaften des Arbeitsblatts: Sicherheit aktiviert werden.

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.