Schaltfläche

Schaltflächen in QlikView dienen dazu, Befehle oder Aktionen per Mausklick auszuführen. Es gibt drei Arten von Schaltflächen: die Starten/Exportieren-Schaltfläche, Shortcut-Schaltflächen und Makro-Schaltflächen.

Per rechtem Mausklick auf das Objekt wird das Schaltfläche: Objekt-Menü angezeigt. Dasselbe Menü finden Sie unter Objekt auf der Menüleiste, wenn die Schaltfläche aktiv ist.

Objekt-Menü

Öffnen Sie die Schaltfläche Objekt-Menü durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

Eigenschaften Öffnet den Dialog Eigenschaften der Schaltfläche, in dem Sie eine Reihe von Parametern einstellen können.
Hinweise

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Notizen und Kommentare

Ebene

Dieses Untermenü ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn die Option Immer alle Befehle im Objekt-Menü anzeigen im Menü Benutzereinstellungen: Design aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Arbeitsblattobjekt in die höchste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

In den Hintergrund
Bringt das Arbeitsblattobjekt in die niedrigste von einem Objekt auf dem aktuellen Arbeitsblatt verwendete Layoutebene.

Eine Ebene nach vorn
Bringt das Arbeitsblattobjekt um eine Layoutebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Arbeitsblattobjekt um eine Layoutebene nach hinten. Der Minimalwert ist -128.


Export nach Excel Exportiert den Text der Schaltfläche nach Microsoft Excel, das automatisch gestartet wird, wenn es nicht bereits ausgeführt wird. Der Text erscheint auf dem ersten Tabellenblatt eines neuen Excel-Dokuments. Dieser Befehl funktioniert nur in Verbindung mit Microsoft Excel 2007 oder einer späteren Version.
In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Text
Kopiert den Text der Schaltfläche in die Zwischenablage.
Bild
Kopiert ein Bild des Arbeitsblattobjekts in die Zwischenablage. Entsprechend der Einstellungen im Dialog Benutzereinstellungen unter Export sind Titel und Rahmen mit im Bild enthalten oder nicht.
Objekt
Kopiert das komplette Arbeitsblattobjekt in die Zwischenablage. Es kann dann beispielsweise an einer anderen Stelle im Layout oder in einem anderen in der aktuellen QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Durch Klicken auf das Symbol in der Titelleiste des Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Durch Doppelklicken auf das Symbol eines minimierten Objekts oder Klicken auf das Symbol in der Titelleiste eines maximierten Objekts (falls angezeigt) erhalten Sie das gleiche Ergebnis. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Entfernen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

Mit den Optionen unter Text definieren den auf der Schaltfläche angezeigten Text.

Text

Hier geben Sie den Text ein, der auf der Schaltfläche erscheinen soll. Es kann auch ein dynamischer Ausdruck eingegeben werden. Mit Hilfe der Enter-Taste kann ein mehrzeiliger Text eingegeben werden.

Formelsyntax in dynamischen Ausdrücken

Ausrichtung Richtet den Text auf der Schaltfläche rechtsbündig, zentriert oder linksbündig aus.

Unter Hintergrund legen Sie fest, wie der Hintergrund der Schaltfläche aussehen soll. Es stehen drei Optionen zur Auswahl:

Glaslinse Diese Option wird für neue Schaltflächen vorbesetzt. Sie erhalten eine dreidimensional wirkende Schaltfläche in der Optik einer Glaslinse.
Classic Liefert eine herkömmlich aussehende QlikView-Schaltfläche.
Systemstandard
Durch diese Option erhält die Schaltfläche die vom Betriebssystem vorgesehene Farbe für Schaltflächen.
Bild Zeigt ein Bild auf der Schaltfläche an. Dies kann entweder ein einzelnes Bild sein oder ein zusammengesetztes Bild, das aus drei Teilen für die drei möglichen Zustände der Schaltfläche (verfügbar, nicht verfügbar, angeklickt) besteht.
Zusammengesetztes Bild
Wählen Sie diese Option und klicken Sie auf Bild auswählen, um ein zusammengesetztes Bild auszusuchen. Die Datei sollte drei nebeneinander angeordnete Bilder enthalten. Das erste Bild erscheint auf der verfügbaren Schaltfläche, das zweite auf der angeklickten ("gedrückten") Schaltfläche und das dritte auf der nicht verfügbaren Schaltfläche.
Einzelnes Bild
Wählen Sie diese Option und klicken Sie auf Bild auswählen, um ein einzelnes Bild auszusuchen. Dieses wird immer auf der Schaltfläche angezeigt, unabhängig von deren Verfügbarkeit. Unterstützte Bildformate sind jpg, png, bmp, gif und animierte gif.
Farbe Aktivieren Sie diese Option, wenn die Schaltfläche einen farbigen Hintergrund haben soll (nicht verfügbar, wenn ein Bild verwendet wird). Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche. Dort können Sie eine Farbe oder einen Farbverlauf definieren.
Transparenz Definiert die Transparenz des Hintergrunds der Schaltfläche. Bei 100 % ist der Hintergrund transparent. Dies gilt sowohl für farbige Hintergründe wie für Bildhintergründe.
Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Die Arbeitsblätter und Objekte befinden sich immer im vererbten Status, wenn Sie nicht vom QlikView Developer überschrieben werden. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Zustand, in dem die meisten QlikView Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID ID der Schaltfläche. Jedes Layout-Element hat eine eindeutige ID für die Steuerung über Makros. Die ID enthält standardmäßig zwei Buchstaben, die den Typ des Elements repräsentieren, sowie eine laufende Nummer. Schaltflächen tragen die IDs BU01, BU02 usw. Gemeinsame Objekte haben dieselbe Objekt ID. Es kann ein beliebiger anderer String als ID verwendet werden, vorausgesetzt er ist eindeutig.
Bedingung für Verfügbarkeit Hier können Sie eine logische Formel eingeben, deren Ergebnis bestimmt, ob die Schaltfläche verfügbar ist oder nicht. Ergibt die Formel falsch bzw. 0, ist die Schaltfläche nicht verfügbar, ergibt die Formel wahr oder 1, ist sie verfügbar. Ist keine Formel angegeben, ist die Schaltfläche immer verfügbar. Die allgemeinen Regeln für die Verfügbarkeit von Schaltflächen können allerdings nicht durch Eingabe einer Formel umgangen werden.
Druckoptionen Führt in den Dialog Druckoptionen, wo Sie Seitenränder, Kopf- und Fußzeilen für den Druck des Objekts definieren können.

Aktionen

Auf dieser Dialogseite können Sie für bestimmte Objekte Aktionen definieren, und zwar für:

  • Schaltflächen
  • Textboxen
  • Messzeiger-Diagramme
  • Linienobjekte

Aktionen können unter anderem das Starten externer Applikationen oder der Export von Daten aus QlikView sein.

Add Öffnet den Dialog Aktion hinzufügen, in dem die Aktionen für das Objekt ausgewählt werden. Wählen Sie die gewünschte Aktion aus der Liste. Nachdem Sie eine Aktion gewählt haben, erscheinen die zugehörigen Parameter im Dialog Aktionen. Die Aktionen werden in der Reihenfolge ausgeführt, in der sie in der Liste erscheinen.
Löschen Löscht die Aktion aus dem Objekt.
Nach oben Verschiebt die markierte Aktion in der Liste um einen Platz nach oben.
Alternativer Status Definiert den Status, auf den sich die Aktion bezieht. Diese Option ist nur für Aktionen verfügbar, die sich auf eine Auswahl oder Lesezeichen beziehen.

Aktionen hinzufügen

Im Dialog Aktionen hinzufügen können Sie die nachfolgend beschriebenen Aktionen wählen. In Feldern, die eine Schaltfläche mit drei Punkten "..." enthalten, können Sie einen dynamischen Ausdruck definieren.

Formelsyntax in dynamischen Ausdrücken

Auswahl

Auswahl in Feld Wählt im angegebenen Feld alle Werte aus, die dem Suchwort entsprechen. Im Suchwort können Sie eine Suchmaske angeben. Beispiel: Mit (A|B) wird sowohl A als auch B ausgewählt. Anführungszeichen sind nur für nicht numerische Werte erforderlich und können für numerische Werte entfallen.
Ausgeschlossene Werte auswählen Wählt die ausgeschlossenen Werte des angegebenen Feldes aus.
Wählbare Werte auswählen Wählt die wählbaren Werte des angegebenen Feldes aus.
Auswahl umschalten Wechselt zwischen der momentanen Auswahl und dem angegebenen Suchwort im angegebenen Feld hin und her. Im Suchwort können Sie mit Suchmasken arbeiten. Wenn Sie etwa (A|B) eingeben, werden A und B ausgewählt.
Vorwärts Führt in der Liste der letzten Auswahlaktionen einen Schritt vorwärts.
Zurück Führt in der Liste der letzten Auswahlaktionen einen Schritt zurück.
Pareto-Auswahl Erlaubt eine Pareto-Auswahl im angegebenen Feld anhand einer Formel und eines Prozentsatzes. Eine Pareto-Auswahl gibt Aufschluss darüber, welche Werte die größten Beiträge zu einer bestimmten Maßzahl leisten, häufig in Form einer 80/20-Analyse. Möchten Sie beispielsweise die größten Kunden ermitteln, mit denen 80 % des Umsatzes erzielt werden, verwenden Sie Kunde als Feld, sum (Umsatz) als Formel und 80 als Prozentsatz.
Auswahl sperren Sperrt die Auswahl im angegebenen Feld.
Auswahl sperren (alle Felder) Sperrt die Auswahl in allen Feldern des Dokuments.
Auswahl freigeben Gibt die Auswahl im angegebenen Feld frei.
Auswahl freigeben (alle Felder) Gibt die Auswahl in allen Feldern des Dokuments frei.
Auswahl freigeben und aufheben Gibt die Auswahl in allen Feldern des Dokuments frei und hebt sie auf.
Auswahl in anderen Feldern aufheben Hebt die Auswahl in allen Feldern mit Ausnahme des angegebenen Feldes auf.
Auswahl aufheben Hebt die Auswahl in allen Feldern des Dokuments auf, mit Ausnahme von gesperrten Werten.
Auswahl im Feld aufheben Löscht ein bestimmtes Feld.
Status-Inhalte kopieren Kopiert die Auswahl vom Quell-Status zum Ziel-Status. Nur verfügbar, wenn Auswahlräume definiert sind.
Inhalt der Auswahlräume tauschen Tauscht die Auswahlen zwischen Status 1 und Status 2 aus. Nur verfügbar, wenn Auswahlräume definiert sind.

Layout

Objekt aktivieren Aktiviert das Objekt mit der angegebenen Objekt ID. Diese Funktion funktioniert nicht im Ajax-Client.
Arbeitsblatt aktivieren Aktiviert das Arbeitsblatt mit der angegebenen Arbeitsblatt-ID.
Nächstes Arbeitsblatt Aktiviert das nachfolgende Arbeitsblatt.
Vorangehendes Arbeitsblatt Aktiviert das vorangehende Arbeitsblatt.
Objekt minimieren Minimiert das Objekt mit der angegebenen Objekt-ID.
Objekt maximieren Maximiert das Objekt mit der angegebenen Objekt-ID.
Objekt wiederherstellen Zeigt das Objekt mit der angegebenen Objekt-ID wieder in ursprünglicher Größe und Position an.
Name des Auswahlraums definieren Wendet den angegebenen Status auf das Objekt an, das von der Objekt ID spezifiziert wird. Nur verfügbar, wenn ein alternativer Status definiert wurden.

Lesezeichen

Lesezeichen aufrufen

Ruft das Lesezeichen mit der angegebenen Lesezeichen ID auf. Haben zwei Lesezeichen dieselbe Lesezeichen-ID, wird das Dokument-Lesezeichen aufgerufen. Um stattdessen das Server-Lesezeichen aufzurufen, geben Sie Server\LesezeichenID ein. 

Lesezeichen anlegen

Speichert den aktuellen Auswahlstatus in einem Lesezeichen. Geben Sie Lesezeichen ID und Lesezeichenname an. Wählen Sie Verborgen , um ein verborgenes Lesezeichen zu erstellen.

Lesezeichen ersetzen

Überschreibt das Lesezeichen mit der angegebenen Lesezeichen ID mit dem momentanen Auswahlstatus.

Drucken

Objekt drucken

Druckt das Objekt mit der angegebenen Objekt-ID. Soll das Objekt auf einem anderen Drucker als dem Standarddrucker gedruckt werden, geben Sie den Druckernamen an. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)

Arbeitsblatt drucken

Druckt das Arbeitsblatt mit der angegebenen Arbeitsblatt-ID. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene.) Diese Funktion funktioniert im AJAX-Client nicht.

Report drucken

Druckt den Report mit der angegebenen Report-ID. Soll der Report auf einem anderen Drucker als dem Standarddrucker gedruckt werden, geben Sie den Druckernamen an. Aktivieren Sie die Option Druckdialog öffnen, wenn der Windows-Druckdialog geöffnet werden soll. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)

Extern

Exportieren

Exportiert eine Tabelle mit den angegebenen Feldern in eine Datei oder in die Zwischenablage. Dabei werden nur die Datensätze exportiert, die mit der momentanen Auswahl logisch zusammenhängen. Klicken Sie auf die Setup-Schaltfläche auf der Seite Aktionen, um das Dialogfeld Aktionseinstellungen exportieren zu öffnen (nicht für Auslöser auf Dokument- oder Arbeitsblattebene).

Starten

Startet ein externes Programm. Die folgenden Einstellungen können im Dialogfeld Aktionen konfiguriert werden:
Anwendung
Klicken Sie auf Durchsuchen..., um die Anwendung zu suchen, die gestartet werden soll. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)
Dateiname
Geben Sie den Pfad zu der Datei ein, die mit der oben angegebenen Anwendung geöffnet werden soll. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)
Parameter
Geben Sie die Parameter für die Befehlszeile an, über die die Anwendung gestartet wird. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)
Arbeitsverzeichnis
Legt das Arbeitsverzeichnis für die zu startende Anwendung fest. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)
Anwendung beenden, wenn QlikView geschlossen ist
Erzwingt das Schließen der Anwendung, wenn QlikView beendet wird. (Nicht für Auslöser auf Dokument- oder Arbeitsblattebene)
Diese Funktion funktioniert nicht im AJAX-Client.

URL öffnen

Sie können URL öffnen verwenden, um eine URL zu einem QlikView Dokument von einem anderen QlikView Dokument aus zu öffnen (Dokumentketten). Mit dieser Einstellung wird die angegebene URL im Standard-Webbrowser geöffnet. Diese Funktion kann nicht als Auslöser für ein Dokument oder Arbeitsblatt verwendet werden. Wenn Sie URL öffnen verwenden, müssen Sie den Dokumentnamen im Aktions-String in Kleinbuchstaben eingeben.

Verwenden Sie nach Möglichkeit QlikView Dokument öffnen anstelle von URL öffnen.

QlikView Dokument öffnen

Sie können QlikView Dokument öffnen verwenden, um ein QlikView Dokument von einem anderen QlikView Dokument aus zu öffnen (Dokumentketten). Die Erweiterung der Zieldatei muss mit angegeben werden. Diese Funktion kann nicht als Auslöser für ein Dokument oder Arbeitsblatt verwendet werden. Relative Pfade zum Navigieren von einem QlikView Dokument zu einem anderen werden von allen Clients unterstützt, vorausgesetzt, die verketteten Dokumente werden in der gleichen Ordnerstruktur (Mount) gespeichert.

Beispiele

Die folgenden Beispiele zeigen, wie der Dateipfad zur Zieldatei geschrieben wird, um die Dokumentkette mit QlikView Dokument öffnen einzurichten.

Example: Datei in der gleichen Ordnerstruktur (gleicher Mount).

  • Wenn sich die Zieldatei im gleichen Ordner befindet:
    DestinationDoc.qvw
  • Wenn sich die Zieldatei in einem Unterordner befindet:
    SubFolder/DestinationDoc.qvw
  • Wenn sich die Zieldatei in einem übergeordneten Ordner befindet:
    ../DestinationDoc.qvw
  • Wenn sich die Zieldatei in einem übergeordneten und parallelen Ordner befindet:
    ../ParallelFolder/DestinationDoc.qvw

Example: Datei in einer anderen Ordnerstruktur (anderer Mount).

Der relative Pfad zwischen verschiedenen Mounts wird nur im Ajax-Client unterstützt.

  • Wenn sich die Zieldatei in einem anderen Mount befindet:
    ../DifferentMount/DestinationDoc.qvw

Example: Verwenden des Mount-Pfads zum Zeigen auf ein QlikView Dokument

Das Festlegen des Pfads zu gemounteten Ordnern wird nur vom Ajax-Client unterstützt.

  • Wenn sich die Zieldatei sich im gleichen gemounteten Ordner befindet:
    \Mount\DestinationDoc.qvw
  • Wenn sich die Zieldatei in einem anderen gemounteten Ordner befindet:
    \DifferentMount\DestinationDoc.qvw
Hinweis: Die Dokumentkette mit gemounteten Ordnern funktioniert mit dem Internet Explorer-Plug-in (IE) nicht.

Example: Verwenden des absoluten Pfads zum Zeigen auf ein QlikView Dokument

Die Verwendung von absoluten Pfaden für Dokumentketten wird vom Ajax-Client und in QlikView Desktop unterstützt.

  • Absoluter Pfad zum lokalen Root-Ordner oder Mount:
    C:\...\DestinationDoc.qvw
  • Absoluter Pfad zu einer Netzwerkfreigabe:
    \\SharedStorage\...\DestinationDoc.qvw

Wählen Sie Auswahlstatus übergeben, um die Auswahl aus dem Originaldokument an das Zieldokument zu übergeben. Im Zieldokument wird die Auswahl zunächst aufgehoben.
Wählen Sie die Option Auswahlstatus additiv anwenden, um die Auswahl im Zieldokument nicht aufzuheben und additiv den Auswahlstatus des Originaldokuments anzuwenden.

Hinweis: Bei Verwendung von Auswahlstatus additiv anwenden können unerwartete Ergebnisse zurückgegeben werden, wenn die in den beiden Dokumenten getroffenen Auswahlen miteinander im Konflikt stehen.

Wählen Sie die Option Im gleichen Fenster öffnen, um bei Verwendung des AJAX ZFC Client das neue Dokument im selben Browserfenster zu öffnen.

Hinweis: Der Vorgang zum Öffnen des QlikView Dokuments wird bei Verwendung des Internet Explorer-Plugins (IE) für Benutzer, die nicht der Domäne angehören, nicht unterstützt.

Makro ausführen

Geben Sie den Pfad und Namen des auszuführenden Makros ein. Geben Sie den Namen eines bereits vorhandenen Makros ein oder den Namen eines Makros, das Sie später im Dialog Modul bearbeiten anlegen. Es kann auch ein dynamischer Ausdruck eingegeben werden.

Variablenwert setzen

Weist der angegebenen Variablen den angegebenen Wert zu.

Information anzeigen

Zeigt die mit den Werten des angegebenen Feldes verknüpften Informationen an, z. B. ein Bild oder einen Text. Diese Funktion funktioniert nicht im AJAX-Client.

Dokument schließen

Schließt das aktive Dokument.

Skript ausführen

Lädt das aktuelle Dokument erneut. Diese Funktion funktioniert weder im AJAX-Client noch im IE-Plugin.

Dynamisches Update

Führt ein dynamisches Update der Daten im aktuell geladenen Dokument aus. Der Befehl für das dynamische Update wird über das Befehl-Feld eingegeben.

Die Verwendung des dynamischen Updates ermöglicht es dem QlikView-Administrator, unbegrenzte Datenmengen aus einer einzelnen Quelle in ein QlikView-Dokument einzuspeisen, ohne das Dokument erneut zu laden. Die Analyse kann anschließend von mehreren Clients ausgeführt werden, die eine Verbindung zu QlikView Server herstellen.

Hinweis: Die hochgeladenen Informationen werden nur im RAM gespeichert, so dass alle Daten, die mithilfe des Dynamischen Updates hinzugefügt oder aktualisiert werden, bei einem erneuten Ladevorgang des Dokuments verloren gehen.

In der folgenden Grammatik werden die möglichen Befehle und die Komponenten beschrieben, die mit dem Dynamischen Update verwendet werden können:

  • statements ::= statement { “;” statement }
  • statement ::= insert_statement | update_statement | delete_statement | begin_transaction_statement | commit_transaction_statement
  • insert_statement ::= "INSERT" "INTO" ("*" | table_name) field_list "VALUES" value_list {"," value_list} ["KEY" ["AUTO" | (" (" field_list ")")] ["REPLACE" (["WITH" "ONE"] | "EACH") ]]
  • update_statement ::= "UPDATE" ("*" | table_name) set_clause {"," | set_clause} "WHERE" condition ["AUTO" "INSERT"]
  • delete_statement ::= "DELETE" "FROM" ("*" | table_name] "WHERE" condition
  • begin_transaction_statement ::= "BEGIN" ("TRANSACTION" | "TRAN") [trans_name]
  • commit_transaction_statement ::= "COMMIT" ["TRANSACTION" | "TRAN"] [trans_name]
  • table_name ::= identifier | quoted_name
  • field_list ::= "(" field_name {"," field_name} ")"
  • value_list ::= "("value {"," value} ")"
  • set_clause ::= "SET" field_name "=" any_valid_non_aggregated_qlikview_expression
  • field_name ::= identifier | quoted string
  • value ::= identifier | any_qlikview_number | quoted string
  • condition ::= any_valid_non_aggregated_qlikview_expression
  • identifier ::= any_qlikview_identifier
  • quoted_string ::= "[" [^]]+ "]"

Example:  

UPDATE AbcTable SET Discount = 123 WHERE AbcField=1

Hinweis: Dynamisches Update muss im Dokument und auf dem Server zugelassen sein, damit diese Funktion verwendet werden kann.
Hinweis: Aktionen, die andere Aktionen auslösen, können zu unvorhergesehenen Konsequenzen führen und sind unbedingt zu vermeiden.
Hinweis:

Es bestehen Einschränkungen beim Gebrauch bestimmter Makro-Auslöser, wenn das Dokument auf einem QlikView Server genutzt wird.

Gebrauch von Makros im QlikView Server

Dialogfeld zu Exporteinstellungen

Auswahl

Hier definieren Sie, was exportiert wird.

Felder In der Feldbox finden Sie eine Liste aller Felder des Dokuments.
Exportfelder Hier stehen die Felder, deren Werte exportiert werden. Für die mit einem Sternchen (*) gekennzeichneten Felder können mehrere Werte exportiert werden.
Hinzufügen > Fügt markierte Felder der Liste Exportfelder hinzu.
< Entfernen Entfernt die markierten Felder aus der Liste Exportfelder.
Nach oben Verschiebt das markierte Feld in der Liste der Exportfelder um einen Platz nach oben.
Nach unten Verschiebt das markierte Feld in der Liste der Exportfelder um einen Platz nach unten.
Mehrfachwert (*) Ist diese Option aktiviert, dürfen für das in Exportfelder markierte Feld mehrere Werte exportiert werden. Anderenfalls ist der Export nur möglich, wenn Eindeutigkeit gegeben ist.

Exportieren in

Hier bestimmen Sie, in welcher Form die Werte exportiert werden.

Datei

Aktivieren Sie diese Option, um die Werte in eine Datei zu exportieren. Geben Sie Pfad und Namen der Exportdatei ein. Ist keine Exportdatei angegeben, werden die Daten stattdessen in die Zwischenablage exportiert. Der Dateiname kann als dynamischer Ausdruck eingegeben werden.

Formelsyntax in dynamischen Ausdrücken

Durchsuchen Führt in den Dialog Exportdatei. Dort geben Sie an, in welche Datei die Daten exportiert werden.
Zwischenablage Diese Option ist vorbesetzt. Wenn keine Exportdatei angegeben ist, werden die Daten ebenfalls in die Zwischenablage exportiert.
Felder in Zeilen Ist diese Option aktiviert, wird in der Exportdatei für jedes Feld eine Zeile angelegt, d. h. die Werte eines Feldes stehen hintereinander durch Tabs getrennt. Die Datensätze stehen in Spalten.
Feldnamen mitexportieren Ist diese Option aktiviert, werden die Feldnamen in der ersten Spalte (bei Felder in Reihen) oder in der ersten Zeile (bei Felder in Spalten) eingefügt.
Felder in Spalten Ist diese Option aktiviert, wird in der Exportdatei für jedes Feld eine Spalte angelegt, d. h. die Werte eines Feldes stehen untereinander. Die Datensätze stehen in Zeilen, wobei die Werte durch Tabs getrennt sind.
An bestehende Datei anhängen Ist diese Option aktiviert, werden die zu exportierenden Daten in der bereits bestehenden Exportdatei ergänzt. Feldnamen werden hierbei nicht exportiert. Besteht noch keine Exportdatei, hat diese Option keine Wirkung.

Zahlenformat

Manche Programme haben Probleme mit der Verarbeitung von Zahlenformaten. In QlikView gibt es drei verschiedene Optionen für den Export von numerischen Daten in die Zwischenablage oder in Dateien.

Beim Anlegen neuer Schaltflächen werden automatisch die Einstellungen auf der Seite Benutzereinstellungen: Export übernommen. Selbstverständlich können Sie aber für jede Exportaktion ein separates Zahlenformat wählen.

Vollständiges Format Exportiert numerische Daten mit vollständigem Zahlenformat, d. h. genau so, wie sie in den Objekten erscheinen.
Kein Tausendertrennzeichen Entfernt alle Tausendertrennzeichen aus den numerischen Daten.
Keine Formatierung Entfernt jegliche Formatierung aus den zu exportierenden Daten. Es wird das in den Systemeinstellungen (Systemsteuerung) angegebene Dezimaltrennzeichen verwendet.
Hinweis:

Es bestehen Einschränkungen beim Gebrauch bestimmter Makro-Auslöser, wenn das Dokument auf einem QlikView Server genutzt wird.

Gebrauch von Makros im QlikView Server

Schriftart

In diesem Dialog stellen Sie Schriftart, Schriftschnitt und Schriftgrad ein.

Die Schriftart kann für jedes einzelne Objekt (Eigenschaften des Objekts: Schriftart) oder für alle Objekte in einem Dokument festgelegt werden (Auf Objekte anwenden in Eigenschaften des Dokuments: Schriftart).

Ferner können Sie Standardschriftarten für neu angelegte Objekte im Dialogfeld Eigenschaften des Dokuments: Schriftart definieren. Es gibt zwei Standard-Schriftarten:

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.

Zudem können Sie die Standardschriftarten für neue Dokumente unter Benutzereinstellungen: Schriftart definieren.

Für Schaltflächen, Diagramme und Textboxen (außer Suchobjekten) können Sie außerdem eine Schriftfarbe auswählen. Die Farbe kann fest sein oder dynamisch anhand einer Formel berechnet werden. Die Farbformel muss eine gültige Farbe ergeben. Verwenden Sie hierzu die Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Farbfunktionen

Weitere Optionen in diesem Dialog:

Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

In der Vorschau wird ein Muster der aktuellen Einstellungen angezeigt.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Die folgenden vordefinierten Rahmentypen sind verfügbar:
Einfarbig
Liefert einen einfarbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Rahmenbreite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer entsprechenden Grundfarbe aus der Farbpalette für alle Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Objekt.

Wenn Vereinfacht das ausgewählte Aussehen der Objekte in Dokumenteigenschaften: Allgemein ist, kann kein Rahmentyp ausgewählt werden. Es steht lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie die Option Erweitert Aussehen der Objekte in Dokumenteigenschaften: Allgemein ausgewählt haben.

Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent...

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird in Abhängigkeit einer Bedingungsformel angezeigt oder ausgeblendet, die kontinuierlich beispielsweise anhand von Auswahlaktionen usw. ausgewertet wird. Das Arbeitsblattobjekt wird nur ausgeblendet, wenn die Bedingung den Wert FALSE ergibt.

Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten für das Dokument können alle Anzeigebedingungen überschreiben, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Dokumenteigenschaften: Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Die Einstellungen in dieser Gruppe sind nur relevant, wenn die entsprechenden Kontrollkästchen in Dokumenteigenschaften: Layout und Eigenschaften des Arbeitsblatts: Sicherheit aktiviert werden.

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen: Objekte aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe der Scroll-Leiste fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Die Option Aussehen der Objekte muss auf Erweitert gesetzt sein, damit Sie das Aussehen der Scroll-Leisten anpassen können. Diese Einstellung finden Sie auf der Registerkarte Allgemein, die Sie öffnen, indem Sie im Dropdown-Menü Einstellungen die Option Eigenschaften des Dokuments wählen.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixeln vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Die Bezeichnung kann horizontal ausgerichtet werden: Links, Zentriert oder Rechts innerhalb des Titelleistenbereichs.
Vertikal Die Bezeichnung kann vertikal ausgerichtet werden: Oben, Zentriert oder Unten innerhalb des Titelleistenbereichs.

Spezialsymbole
Viele Befehle aus dem Objekt-Menü der Arbeitsblattobjekte können auch als Symbol in der Titelleiste konfiguriert werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.