Schieberegler/Kalenderbox

Schieberegler/Kalenderboxen bieten eine Alternative zur Auswahl von Feldwerten in QlikView. Sie können auch zur Eingabe von Werten in QlikView-Skriptvariablen verwendet werden. Wie der Name bereits andeutet, stehen zwei sehr verschiedene Modi für dieses Objekt zur Verfügung. Sie sehen zwar unterschiedlich aus, haben aber dieselbe Funktion.

Per rechtem Mausklick auf einen Schieberegler/eine Kalenderbox gelangen Sie in das Objekt-Menü des Schiebereglers/der Kalenderbox. Dasselbe Menü finden Sie unter Objekt auf der Menüleiste, wenn ein Schieberegler oder eine Kalenderbox aktiv ist.

Arbeiten mit Schiebereglern/Kalenderboxen

Schieberegler

Mit Hilfe von Schiebereglern lassen sich Werte in Feldern auswählen, und zwar je nach Konfiguration ein Wert oder ein ganzer Wertebereich. Alternativ können Schieberegler dazu benutzt werden, ein oder zwei Werte für eine oder zwei Variablen zu definieren. All das geschieht durch die Bedienung des Schiebers mit der Maus. Das Aussehen des Schiebereglers kann variiert werden. Farben, Skalenabschnitte usw. lassen sich individuell konfigurieren.

Kalenderbox

Die Kalenderbox ist eine Dropdown-Liste mit einem kleinen Kalendersymbol auf der rechten Seite. Beim Klicken auf das Kalendersymbol öffnet sich der Kalender. Mithilfe der Dropdown-Pfeile können Sie sich zwischen Monaten und Jahren hin- und herbewegen. Je nach Konfiguration der Kalenderbox können Sie im Kalender ein Datum oder einen Zeitraum auswählen, und diese Auswahl wird auf das zugrundeliegende Feld oder die Variable übertragen.

Bezieht sich die Kalenderbox auf ein Feld, wird die Auswahl im Kalender durch dieselben Farben visualisiert wie die Auswahl in den Listboxen (grün für ausgewählt usw.). Ist die Auswahl mehrerer Werte zugelassen, können Sie im Kalender einen ganzen Zeitraum mit der Maus markieren, genau so wie Sie es auch in einer Listbox tun würden. Mit Hilfe der Strg-Taste lassen sich auch mehrere Zeiträume auswählen, selbst wenn diese in unterschiedlichen Monaten oder Jahren liegen. Wenn der Kalender geschlossen ist, funktioniert die Kalenderbox im Wesentlichen wie ein Feld in einer Multibox.

Objekt-Menü

Öffnen Sie das Objekt-Menü des Schiebereglers/der Kalenderbox durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

Eigenschaften Öffnet den Dialog Eigenschaften des Schiebereglers/der Kalenderbox. Dort können Sie einige Parameter einstellen.
Notizen

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Siehe: Notizen und Kommentare

Ebene

Dieser Befehl ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn im Dialog Benutzereinstellungen, Design die Option Immer alle Befehle im Objekt-Menü anzeigen aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Objekt in die höchste momentan von einem Objekt auf dem Arbeitsblatt verwendete Ebene.

In den Hintergrund
Bringt das Objekt in die niedrigste momentan von einem Objekt auf dem Arbeitsblatt verwendete Ebene.

Eine Ebene nach vorn
Bringt das Objekt eine Ebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Objekt eine Ebene nach hinten. Der Minimalwert ist -128.


In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Bild
Kopiert das Objekt als Bild in die Zwischenablage. Entsprechend den Einstellungen im Dialog Benutzereinstellungen, Export werden Titel und Rahmen mitkopiert oder nicht.
Objekt
Kopiert das komplette Objekt in die Zwischenablage. Es kann dann beispielsweise auf einem anderen Arbeitsblatt oder in einem anderen in der QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Alternativ können Sie auf in der Titelleiste des Objekts klicken. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Alternativ können Sie auf in der Titelleiste des Objekts klicken. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Dasselbe erreichen Sie per Doppelklick auf das Icon des minimierten Diagramms oder auf in der Titelleiste des maximierten Objekts. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

In den Dialog Eigenschaften des Schiebereglers/Kalenderbox, Allgemein gelangen Sie durch den Befehl Eigenschaften im Objekt-Menü des Schiebereglers bzw. der Kalenderbox. In diesem Dialog definieren Sie, auf welche Daten sich der Schieberegler/die Kalenderbox beziehen soll. Auch wenn Sie einen neuen Schieberegler anlegen, öffnet sich der Dialog Neuer Schieberegler/Kalenderbox.

Unter Variante wählen Sie zwischen den Standardvarianten Schieberegler und Kalenderbox. Verwenden Sie die Dropdown-Liste, um auszuwählen, ob das Objekt durch einen Schieberegler-Befehl oder einen Kalender-Eingabefehl repräsentiert werden soll.

In der Gruppe Daten definieren Sie, auf welches Datenobjekt sich auf den Schieberegler auswirken soll. Das kann entweder ein Feld oder eine oder zwei Variablen sein.

Feld Aktivieren Sie diese Option, wenn sich der Schieberegler/die Kalenderbox auf ein Feld bzw. eine Formel beziehen soll. Wählen Sie das gewünschte Feld aus der Dropdown-Liste. Wenn Sie Formel wählen, öffnet sich der Dialog Formel bearbeiten, wo Sie eine Formel für ein dynamisches Feld definieren können.
Bearbeiten Öffnet die in der Dropdown-Liste ausgewählte Formel im Dialog Formel bearbeiten.
Variable(n) Aktivieren Sie diese Option, wenn sich der Schieberegler/die Kalenderbox auf eine Variable beziehen soll, und wählen Sie diese aus der Dropdown-Liste aus. Eine zweite Variable können Sie nur festlegen, wenn als Anzeigemodus die Option Mehrere Werte aktiviert ist (siehe unten).

Unter Modus legen Sie fest, welche Werte mit dem Schieberegler auszuwählen sein sollen. Die Option Einzelner Wert erlaubt die Auswahl eines Werts in einem Feld oder einer Variablen. Die Option Mehrere Werte ermöglicht für Felder die Auswahl eines Wertebereichs, für Variablen die Auswahl von zwei Werten für zwei Variablen.

Unter Wertebereich definieren Sie die Art des Wertebereichs. Ist die Option Diskret gewählt, umfasst der Wertebereich nur existierende Werte eines Feldes bzw. die vordefinierten Werte einer Variablen. Diese Option ist für den Modus Mehrere Werte nicht verfügbar. Ist die Option Kontinuierlich/ Numerisch aktiviert, umfasst der Wertebereich einen kontinuierlichen numerischen Bereich bzw. die vordefinierten Werte einer Variablen. Diese Option ist für den Modus Einzelner Wert in Verbindung mit einem Feld nicht verfügbar. Diese Option ist für Kalenderboxen nicht verfügbar. Bei Kalenderboxen werden diskrete Werte immer vorausgesetzt.

Minimalwert Geben Sie für kontinuierliche numerische Wertebereiche unter Kontinuierlich/Numerisch den Minimalwert ein.
Maximalwert Geben Sie unter Kontinuierlich/Numerisch den Maximalwert ein.
Intervall Geben Sie unter Kontinuierlich/Numerisch die Intervallgröße ein.
Wert 1 Zeigt unter Kontinuierlich/Numerisch den aktuellen Wert an, wenn für Schieberegler/Kalenderbox Einzelner Wert ausgewählt wurde. Im Modus Mehrere Werte wird der kleinste Wert angezeigt.
Wert 2 Zeigt unter Kontinuierlich/Numerisch den größten Wert an. Im Modus Mehrere Werte hat dieses Feld keine Bedeutung.
Sperrung ignorieren Ist diese Option aktiviert, können mit Hilfe des Schiebereglers/der Kalenderbox Werte ausgewählt werden, auch wenn das Feld gesperrt ist. Das Feld bleibt jedoch gesperrt für logische Änderungen durch Auswahlaktionen in anderen Feldern. Diese Option ist standardmäßig aktiviert.
Feste Bereichsgröße Ist diese Option aktiviert, bleibt die Bereichsgröße bei kontinuierlich numerischem Wertebereich stets fest. In diesem Fall kann die Größe des Schiebers nicht mehr durch Ziehen mit der Maus verändert werden.
Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Dies ist der normale Auswahlraum. Er gilt, wenn kein anderer Auswahlraum gewählt wurde. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Auswahlraum in dem die meisten QlikView-Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Die ID für Schiebereglerobjekte beginnt mit SL01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Siehe: Interner Makro-Interpreter

Druckoptionen Führt in den Dialog Druckoptionen, wo Sie Seitenränder, Kopf- und Fußzeilen für den Druck des Objekts definieren können.

Präsentation (Schieberegler)

Das Registerblatt Eigenschaften des Schiebereglers/Kalenderbox: Präsentation wird angezeigt, wenn Sie mit rechts auf eine(n) Schieberegler/Kalenderbox klicken und Eigenschaften auswählen. Hier werden die visuellen Eigenschaften des Schiebereglers/der Kalenderbox konfiguriert.

Mit der Gruppe Farben können Sie Farben für die verschiedenen Teile des Schiebereglers/der Kalenderbox wie hier dargestellt definieren:

A Häkchen
B Skalenhintergrund
C Schieberegler
D Schieber
E Scroll-Pfeile

Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe für Schieberegler und Skalenhintergrund als einfarbig oder Farbverlauf angeben können. Der Grad der Transparenz der Schiebeleiste wird über die Transparenzeinstellungen rechts neben der Schaltfläche festgelegt. Bei 0 % ist der Hintergrund deckend. Bei 100 % ist der Hintergrund transparent.

Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe für Schieber, Scroll-Pfeile und Skalenabschnitte als einfarbig oder Farbverlauf angeben können.

In der Gruppe Scroll-Richtung kann der Schieberegler horizontal oder vertikal dargestellt werden.

In Skalenbeschriftung können Sie festlegen, ob der Skalentext horizontal oder vertikal dargestellt werden soll.

In der Gruppe Skala können Sie eine Skala für den Schieberegler definieren. Wählen Sie Automatische Skala aus, damit die Skala automatisch basierend auf der Größe des Schiebereglers und den zugrunde liegenden Werten generiert wird. Mit der Alternative Benutzerdefinierte Skala können Sie folgende Einstellungen vornehmen:

Skalenabschnitte Legen Sie die Zahl der Skalenabschnitte fest.
Beschriftung an jedem n-ten Skalenabschnitt Definieren Sie, wie dicht die Beschriftung der Skalenabschnitte sein soll.
Teilstriche pro Skalenabschnitt Legen Sie die Zahl der Teilstriche pro Skalenabschnitt fest.

Scroll-Pfeile können über Scroll-Pfeile anzeigen angezeigt oder ausgeblendet werden.

Schieberart kann als Deckend oder Schattiert definiert werden.

Hinweis: Es bestehen Beschränkungen für die automatische Skalen- und vertikale Skalenbeschriftungsfunktion im AJAX/WebView-Modus.
Wenn möglich, empfehlen wir, Benutzerdefinierte Skala zu verwenden, um die Skaleneinstellungen zu definieren.

Präsentation (Kalendermodus)

Das Registerblatt Eigenschaften des Schiebereglers/Kalenderbox: Präsentation wird angezeigt, wenn Sie auf eine(n) Schieberegler/Kalenderbox rechtsklicken und Eigenschaften auswählen. Hier werden die visuellen Eigenschaften des Schiebereglers/der Kalenderbox konfiguriert.

Unter Farben wählen Sie eine Farbe für den Hintergrund des Kalenders. Per Mausklick auf diese Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können. Der Grad der Transparenz des Kalenderhintergrunds wird über die Transparenzeinstellungen rechts neben der Schaltfläche festgelegt. Bei 0 % ist der Hintergrund deckend. Bei 100 % ist der Hintergrund transparent.

Sortieren

Im Dialog Sortieren legen Sie Sortierfolgen für die Werte des Schiebereglers fest. Dieser Dialog weist starke Ähnlichkeiten mit dem entsprechenden Dialog unter Eigenschaften des Dokuments auf.

Zahl

Auf dem Registerblatt Zahlen legen Sie das Zahlenformat für die Schieberegler fest. Dieser Dialog weist starke Ähnlichkeiten mit dem entsprechenden Dialog unter Eigenschaften des Dokuments auf.

Schriftart

In diesem Dialog stellen Sie Schriftart, Schriftschnitt und Schriftgrad ein.

Die gewählte Schriftart kann sich auf ein Objekt beziehen (Eigenschaften des Objekts, Schriftart) oder auf alle Objekte des Dokuments (Schaltfläche Auf alle Objekte anwenden im Dialog Eigenschaften des Dokuments, Schriftart).

Ferner können Sie im Dialog Eigenschaften des Dokuments, Schriftart Standardschriftarten für alle danach neu angelegten Objekte definieren. Es gibt zwei Standard-Schriftarten:

  1. Die erste Standard-Schriftart wird für die meisten Objekte verwendet, etwa für Listboxen, Diagramme usw.
  2. Die zweite Standard-Schriftart ist für Textboxen und Schaltflächen vorgesehen. Hier wird häufig eine größere Schriftart verwendet.

Ferner existiert die Dialogseite Schriftart auch in den Benutzereinstellungen. Die dort gewählten Schriftarten werden für neu angelegte Dokumente als Standard-Schriftart verwendet.

Für Schaltflächen, Diagramme und Textboxen (außer Suchobjekten) können Sie außerdem eine Schriftfarbe auswählen. Die Farbe kann fest sein oder dynamisch anhand einer Formel berechnet werden. Die Farbformel muss eine gültige Farbe ergeben. Verwenden Sie hierzu die Farbfunktionen. Ergibt die Formel keine gültige Farbe, wird Schwarz verwendet.

Siehe: Farbfunktionen

Weitere Optionen in diesem Dialog:

Schattiert Zeigt die Schrift mit einem Schatten an.
Unterstrichen Zeigt die Schrift unterstrichen an.

In der Vorschau wird ein Muster der aktuellen Einstellungen angezeigt.

Layout

Die Seite „Layout“ existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Rahmen

Zeigt einen Rahmen rund um das Objekt an. Wählen Sie die Art des Rahmens aus der Dropdown-Liste

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Wählen Sie die Art des Rahmens.
Schlicht
Liefert einen schlichten, farbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Breite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer geeigneten Grundfarbe aus der Farbpalette bei allen Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Arbeitsblattobjekt.

Wenn für Aussehen der Objekte in Document Properties: GeneralVordefiniert ausgewählt ist, kann kein Rahmentyp ausgewählt werden. Es stehen lediglich das Dropdown-Menü Schatten und die Einstellung Breite zur Verfügung.

Abgerundete Ecken

Im Dialog Abgerundete Ecken definieren Sie, ob das Objekt abgerundete Ecken haben soll. Alle Formen zwischen Kreis bzw. Ellipse und Quadrat bzw. Rechteck sind möglich. Die Option Abgerundete Ecken ist nur dann verfügbar, wenn Sie unter Document Properties: General für das Aussehen der Objekte die Option Erweitert ausgewählt haben.

Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.

Ebene

In der Gruppe Ebene legen Sie fest, in welcher Ebene sich das Objekt befindet.

Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.

Vorlagen-Assistent...

Öffnet den Assistent für Formatvorlagen. Dort können Sie eine Formatvorlage erstellen.

Vorlage anwenden ...

Sie können eine Formatvorlage auf das Objekt, Arbeitsblatt oder Dokument anwenden.

Siehe: Formatvorlagen

Anzeigen

Unter Anzeigen legen Sie fest, ob das Objekt immer oder nur unter einer bestimmten Bedingung angezeigt werden soll.

Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird nur angezeigt, wenn die im Eingabefeld definierte logische Bedingung erfüllt ist. Eine solche Bedingung können Sie mit Hilfe der Konditionalfunktionen definieren. Die Anzeige erfolgt nur, wenn die Bedingung den Wert Wahr ergibt.

Siehe: Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten können sich die Arbeitsblätter dennoch ansehen, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Siehe: Eigenschaften des Dokuments, Sicherheit

Optionen

Unter Optionen können Sie bestimmte Funktionen für das Objekt zulassen oder unterbinden. Diese Einstellungen können auch auf Dokumentebene (Dialog Eigenschaften des Dokuments, Layout) und auf Arbeitsblattebene vorgenommen werden (Dialog Eigenschaften des Arbeitsblatts, Sicherheit).

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Siehe: Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.

Scroll-Leisten

Unter Scroll-Leisten konfigurieren Sie die in dem Objekt angezeigten Scroll-Leisten:

Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen, Objekte, aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe für die Scroll-Leisten fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Das Aussehen der Objekte muss auf Erweitert gesetzt werden, damit der Stil der Scroll-Leiste sichtbar ist. Diese Einstellung kann auf der Registerkarte Allgemein durch Öffnen des Dropdown-Menüs Einstellungen und Auswählen der Option Dokumenteigenschaften vorgenommen werden.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Die Seite Titelleiste existiert in den Eigenschaftsdialogen von Objekten und Dokumenten.
Die Einstellungen auf der Seite Eigenschaften des Dokuments beziehen sich dementsprechend auf ein einzelnes Objekt oder alle Objekte des Dokuments.

Auf der Seite Titelleiste treffen Sie Einstellungen bezüglich der Titelleiste eines oder mehrerer Objekte.

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.

Hier können Sie Farben für die Titelleiste je nach Status einstellen. Die Einstellungen für Aktive Titelleiste und Inaktive Titelleiste können getrennt vorgenommen werden.

Klicken Sie auf Hintergrundfarbe oder Textfarbe, um den Dialog Farbfläche anzuzeigen. Die Hintergrundfarbe kann im Dialog Farbfläche als Farbe oder Farbverlauf definiert werden. Die Textfarbe kann über Farbfunktionen als fixe oder dynamische Farbe definiert werden.

Siehe: Farbfunktionen

Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.

Die genaue Größe und Position des QlikView-Objekts kann über die Einstellungen für Größe und Position für normale oder minimierte QlikView-Objekte festgelegt werden. Diese Einstellungen werden in Pixel vorgenommen:

Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.

Die Ausrichtung der Bezeichnung kann über die Optionen Ausrichtung des Titels vorgenommen werden:

Horizontal Richten Sie den Titeltext linksbündig, zentriert oder rechtsbündig aus.
Vertikal Richten Sie den Titeltext oben, zentriert oder unten aus.

Icons
Viele Befehle aus dem Objekt-Menü können auch als Icon in der Titelleiste des Objekts genutzt werden. Hier können Sie diese Befehle wählen, indem Sie ein Häkchen vor den betreffenden Befehl setzen.

Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder der Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Siehe: Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.