Linienobjekt

Objekt, das Linien oder Pfeile auf dem Arbeitsblatt anzeigt, um das Layout ansprechender und informativer zu gestalten. Linienobjekte können an jeder Position auf dem Arbeitsblatt eingefügt werden, auch in Bereichen, in denen sich andere Objekte befinden.

Per rechtem Mausklick auf das Linienobjekt gelangen Sie in dessen Objekt-Menü. Dasselbe Menü finden Sie unter Objekt auf der Menüleiste, wenn das Linienobjekt aktiv ist.

Objekt-Menü

Öffnen Sie das Objekt-Menü des Linienobjekts durch rechten Mausklick auf das Objekt. Folgende Menübefehle sind verfügbar:

Eigenschaften Öffnet den Dialog Eigenschaften des Linienobjekts. Dort können Sie einige Parameter einstellen.
Notizen

Ermöglicht das Erstellen und die Freigabe von Notizen zum aktuellen Objekt.

Siehe: Notizen und Kommentare

Ebene

Dieser Befehl ist nur verfügbar, wenn im Menü Ansicht die Option Entwurfsmodus aktiviert ist oder wenn im Dialog Benutzereinstellungen, Design die Option Immer alle Befehle im Objekt-Menü anzeigen aktiviert ist. Es beinhaltet vier Befehle zum Festlegen der Anzeigeebene der Objekte. Der Bereich zulässiger Ebenennummern liegt zwischen -128 und +127.

In den Vordergrund
Bringt das Objekt in die höchste momentan von einem Objekt auf dem Arbeitsblatt verwendete Ebene.

In den Hintergrund
Bringt das Objekt in die niedrigste momentan von einem Objekt auf dem Arbeitsblatt verwendete Ebene.

Eine Ebene nach vorn
Bringt das Objekt eine Ebene nach vorn. Der Höchstwert ist 127.

Eine Ebene nach hinten
Bringt das Objekt eine Ebene nach hinten. Der Minimalwert ist -128.


In die Zwischenablage kopieren Öffnet ein Untermenü mit Befehlen bezüglich des Kopierens in die Zwischenablage.
Bild
Kopiert das Objekt als Bild in die Zwischenablage. Entsprechend den Einstellungen im Dialog Benutzereinstellungen, Export werden Titel und Rahmen mitkopiert oder nicht.
Objekt
Kopiert das komplette Objekt in die Zwischenablage. Es kann dann beispielsweise auf einem anderen Arbeitsblatt oder in einem anderen in der QlikView-Instanz geöffneten Dokument eingefügt werden.
Verlinkte Objekte

Öffnet ein Untermenü mit Befehlen für verlinkte Objekte.
Position der verlinkten Objekte anpassen
Alle verlinkten Objekte auf allen Arbeitsblättern werden in Größe und Position an das aktive Objekt angepasst.
Verlinkung der Objekte lösen
Löst die Verlinkung der verlinkten Objekte und macht sie somit zu eigenständigen Objekten mit eigener ID.

Minimieren Minimiert das Objekt auf die Größe eines Icons. Alternativ können Sie auf in der Titelleiste des Objekts klicken. Dieser Befehl ist nur verfügbar, wenn die Minimierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Maximieren Maximiert das Objekt, so dass es bildschirmfüllend dargestellt wird. Alternativ können Sie auf in der Titelleiste des Objekts klicken. Dieser Befehl ist nur verfügbar, wenn die Maximierung im Dialog Eigenschaften des Objekts auf der Seite Titelleiste aktiviert ist.
Wiederherstellen Zeigt das Objekt wieder in ursprünglicher Größe und Position an. Dasselbe erreichen Sie per Doppelklick auf das Icon des minimierten Diagramms oder auf in der Titelleiste des maximierten Objekts. Dieser Befehl ist nur für minimierte oder maximierte Objekte verfügbar.
Hilfe Öffnet die QlikView-Hilfe.
Löschen Löscht das Objekt aus dem Arbeitsblatt.

Allgemein

In diesen Dialog gelangen Sie durch den Befehl Eigenschaften aus dem Objekt-Menü des Linienobjekts.

Unter Ausrichtung bestimmen Sie, ob die Linie horizontal, vertikal oder diagonal steigend bzw. fallend verlaufen soll: Horizontal, Vertikal, Diagonal steigend oder Diagonal fallend.

Unter Form definieren Sie das Aussehen des Linienobjekts.

Linienart Wählen Sie zwischen durchgehenden, gestrichelten und/oder gepunkteten Linien.
Linienbreite Definiert die Breite der Linie. Der Wert kann in mm, cm, inch (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Pfeile Legen Sie fest, ob an den Enden der Linie Pfeilspitzen erscheinen und welche Form diese Pfeilspitzen haben.

Per Mausklick auf die Schaltfläche Farbe gelangen Sie in den Dialog Farbfläche. Dort können Sie eine statische oder dynamische Farbe für das Linienobjekt definieren.

Ferner können Sie den Hintergrund des Linienobjekts festlegen.

Farbe Aktivieren Sie diese Option, wenn das Linienobjekt einen farbigen Hintergrund haben soll. Per Mausklick auf die farbige Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Bild Ist diese Option aktiviert, müssen Sie per Mausklick auf die Schaltfläche Bild auswählen ein Bild importieren
Transparenz Diese Option stellt den Transparenzgrad des Objekthintergrunds ein. Bei 0 % ist der Hintergrund deckend. Bei 100 % ist der Hintergrund transparent. Dies gilt sowohl für farbige Hintergründe wie für Bildhintergründe.
Objekt ID

Wird für Makro-Zwecke verwendet. Jedem Objekt wird eine eindeutige ID zugewiesen. Die ID für Linienobjekte beginnt mit LA01. Verlinkte Objekte haben dieselbe ID. Diese ID-Nummer kann später bearbeitet werden.

Siehe: Interner Makro-Interpreter

Alternativer Status Wählen Sie einen Auswahlraum aus der Dropdown-Liste. Folgende Auswahlräume sind immer verfügbar:
Vererbt
Dies ist der normale Auswahlraum. Er gilt, wenn kein anderer Auswahlraum gewählt wurde. Der Auswahlraum des Dokuments vererbt sich auf das Arbeitsblatts, der Auswahlraum des Arbeitsblatts vererbt sich auf die Objekte.
Standard
Dies ist der Auswahlraum in dem die meisten QlikView-Aktionen stattfinden. Er ist durch $ repräsentiert. Das QlikView-Dokument befindet sich immer im Auswahlraum Standard.

Aktionen

Auf der Seite Aktionen definieren Sie die Aktionen, die ausgeführt werden, wenn man auf das Objekt klickt. Dieser Dialog ist identisch mit der Seite Aktionen für Schaltflächen.

Siehe auch:

 

  • Rahmen
  • Aussehen der ObjekteDocument Properties: GeneralVordefiniertSchattenBreite
  • Abgerundete Ecken
  • Abgerundete EckenAbgerundete EckenDocument Properties: GeneralAussehen der ObjekteErweitert
  • Ebene
  • Ebene
  • Vorlagen-Assistent...
  • Assistent für Formatvorlagen
  • Vorlage anwenden ...
  • Siehe: Formatvorlagen
  • Anzeigen
  • Anzeigen
  • Optionen
  • OptionenEigenschaften des Dokuments, LayoutEigenschaften des Arbeitsblatts, Sicherheit
  • Scroll-Leisten
  • Scroll-Leisten
  • Titelleiste
    Eigenschaften des Dokuments
  • Titelleiste
  • Aktive TitelleisteInaktive Titelleiste
  • HintergrundfarbeTextfarbeFarbflächeHintergrundfarbeFarbflächeFarbeFarbverlaufTextfarbefixedynamische
  • Siehe: Farbfunktionen
  • normaleminimierte
  • Ausrichtung des Titels
  • Icons

Layout

Schatten Unter Schatten wählen Sie die Intensität des Schattens. Sie haben auch die Möglichkeit Kein Schatten zu wählen.
Art Wählen Sie die Art des Rahmens.
Schlicht
Liefert einen schlichten, farbigen Rand rund um das Objekt.
Konkav
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt sinke in das Arbeitsblatt ein.
Konvex
Liefert einen Rahmen, der den Eindruck erweckt, das Objekt stehe aus dem Arbeitsblatt hervor.
3 D
Liefert einen gewölbten und schattierten Rahmen rund um das Objekt.
Breite Diese Option ist für alle Rahmentypen verfügbar. Die Breite kann in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Farbe Klicken Sie auf diese Schaltfläche, um ein Dialogfeld zur Auswahl einer geeigneten Grundfarbe aus der Farbpalette bei allen Rahmentypen zu öffnen.
Regenbogen Erstellt einen regenbogenfarbenen Rahmen bei allen Rahmentypen. Der Regenbogen beginnt mit der ausgewählten Grundfarbe über dem Arbeitsblattobjekt.
Abgerundete Ecken Aktivieren Sie diese Option, wenn das Objekt abgerundete Ecken haben soll.
Ecken Per Mausklick kann für jede Ecke einzeln die Rundung ein- und ausgeschaltet werden.
Grad Eine Zahl zwischen 2 und 100 regelt die Form zwischen Ellipse und Rechteck. 2 liefert eine Ellipse, bei höheren Zahlen wird die Form immer eckiger. Werte zwischen 2 und 5 liefern normalerweise die besten Ergebnisse.
Radius Diese Einstellung bestimmt den Radius der Ecken als festen Abstand (Statisch) oder in Prozent des Gesamtquadrats (Relativ (%)) Mit dieser Einstellung können Sie steuern, inwieweit die Ecken von den zugrunde liegenden allgemeinen Formeinstellungen unter Grad betroffen sind. Der Eckenradius kann als statischer Wert in mm, cm, Zoll (", inch), Pixeln (px, pxl, pixel), Punkten (pt, pts, point) oder Docunits (du, docunit) angegeben werden.
Bottom Ein Objekt mit der Ebeneneigenschaft Unten kann nie Objekte überdecken, die sich in den Ebenen Normal oder Oben befinden. Es kann nur im Vordergrund vor anderen Objekten in der Ebene Unten stehen.
Normal Die meisten Objekte, die Sie neu anlegen, befinden sich standardmäßig in der normalen (mittleren) Anzeigeebene. Objekte in der normalen Anzeigeebene können niemals Objekte überdecken, die im Vordergrund stehen, und sie können niemals von Objekten überdeckt werden, die im Hintergrund stehen.
Top Ein Objekt mit der Ebeneneigenschaft Oben kann nie von Objekten überdeckt werden, die sich in den Ebenen Normal oder Unten befinden. Nur andere Objekte in der Ebene Oben können über dieses gelegt werden.
Benutzerdefiniert Die Ebenen Hintergrund, Normal und Vordergrund entsprechen den numerischen Werten -1, 0 und 1. Alle Werte zwischen -128 und 127 sind akzeptabel. Mit dieser Option können Sie einen Wert Ihrer Wahl eingeben.
Immer Das Objekt wird immer angezeigt.
Bedingung

Das Objekt wird nur angezeigt, wenn die im Eingabefeld definierte logische Bedingung erfüllt ist. Eine solche Bedingung können Sie mit Hilfe der Konditionalfunktionen definieren. Die Anzeige erfolgt nur, wenn die Bedingung den Wert Wahr ergibt.

Siehe: Konditionalfunktionen

Hinweis:

Anwender mit Admin-Rechten können sich die Arbeitsblätter dennoch ansehen, indem sie die Option Alle Arbeitsblätter und Objekte anzeigen in Dokumenteigenschaften: Sicherheit aktivieren. Dasselbe erreichen Sie mit Hilfe der Tastenkombination STRG+UMSCHALT+S.

Siehe: Eigenschaften des Dokuments, Sicherheit

Größe/Position ändern Ist diese Option aktiviert, kann das Objekt beliebig vergrößert, verkleinert und auf dem Arbeitsblatt verschoben werden. Anderenfalls sind Größe und Position fest.
Kopieren Ist diese Option aktiviert, kann das Objekt kopiert werden, anderenfalls nicht.
Info zulassen

Wird die Info-Funktion verwendet, erscheint in der Fenstertitelzeile ein Info-Icon, wenn der Feldwert mit dieser Funktion verknüpfte Informationen enthält. Soll kein Info-Icon angezeigt werden, deaktivieren Sie diese Option.

Siehe: Info

Größe anpassen Normalerweise schrumpfen die Grenzen rund um alle Tabellenblattobjekte in QlikView, wenn eine Tabellengröße ausgewählt wurde, die kleiner ist, als die dem Blattobjekt zugewiesene Größe. Ist diese Option jedoch deaktiviert, ist die automatische Größeneinstellung deaktiviert. Der nicht benötigte Platz bleibt weiß.
Scroll-Position beibehalten

Ist diese Option aktiviert, behält QlikView bei Auswahlaktionen die Scroll-Position bei. Dies gilt auch für Diagramme mit einer Scroll-Leiste. Diese Einstellung muss auch unter Benutzereinstellungen, Objekte, aktiviert werden.

Die Scroll-Position wird beim Schließen des Dokuments nicht beibehalten.

Scroll-Pfeile Farbe der Scroll-Pfeile einstellen. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen. Grautöne eignen sich zumeist am Besten. Per Mausklick auf die Schaltfläche öffnet sich der Dialog Farbfläche, wo Sie eine Farbe oder einen Farbverlauf definieren können.
Hintergrund

Legt die Hintergrundfarbe für die Scroll-Leisten fest. Per Mausklick auf die Schaltfläche können Sie eine Farbe auswählen.

Breite Diese Steuerung wirkt sich auf die Breite und relative Größe der Scroll-Leistensymbole aus.
Aussehen

Definiert das Aussehen der Scroll-Leisten. Wählen Sie ein Design aus der Dropdown-Liste. Das Design Classic entspricht dem Scroll-Leisten-Design von QlikView 4/5. Das Design Standard verleiht der Scroll-Leiste ein moderneres Aussehen. Das dritte Design Modern ergibt eine schmalere, leichtere Leiste.

Das Aussehen der Objekte muss auf Erweitert gesetzt werden, damit der Stil der Scroll-Leiste sichtbar ist. Diese Einstellung kann auf der Registerkarte Allgemein durch Öffnen des Dropdown-Menüs Einstellungen und Auswählen der Option Dokumenteigenschaften vorgenommen werden.

Anwenden auf Führt in den Dialog Eigenschaften von Titelleiste und Rahmen. Dort können Sie die im Eigenschaftsdialog unter Layout eingestellten Eigenschaften auf andere Objekte des Dokuments übertragen.

Titelleiste

Titelleiste anzeigen Ist diese Option aktiviert, haben die Objekte eine Titelleiste am oberen Rand. Einige Objekte (z. B. Listboxen, Tabellenboxen, Diagramme) haben standardmäßig eine Titelleiste, andere dagegen nicht (z. B. Schaltflächen, Textboxen oder Linienobjekte).
Titeltext Geben Sie den Text für die Titelleiste des Objekts ein. Ändern Sie die Schriftart der Titelleiste über die Schaltfläche Schriftart.
Text umbrechen Zeigt die Titelleiste in mehreren Zeilen an.
Größe der Titelleiste (Zeilen) Legt die Anzahl der Zeilen der Titelleiste fest.
Horizontale Position Abstand zwischen dem linken Rand des Objekts und dem linken Rand des Arbeitsblatts.
Vertikale Position Abstand zwischen dem oberen Rand des Objekts und dem oberen Rand des Arbeitsblatts.
Breite Breite des QlikView-Objekts.
Höhe Höhe des QlickView-Objekts.
Horizontal Richten Sie den Titeltext linksbündig, zentriert oder rechtsbündig aus.
Vertikal Richten Sie den Titeltext oben, zentriert oder unten aus.
Hinweis: Verwenden Sie Icons in der Titelleiste von Objekten sparsam. Zu viele Icons verwirren nur.
Minimieren Ist diese Option aktiviert, kann das Objekt auf die Größe eines Icons minimiert werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder der Doppelklick auf den Titel der Box minimieren Sie das Objekt.
Auto-Minimieren Diese Option ist nur verfügbar, wenn die Option Minimieren aktiviert ist. Die Option Auto-Minimieren wird für mehrere Objekte auf demselben Arbeitsblatt aktiviert und ist dafür vorgesehen, leichter zwischen der Anzeige dieser Objekte hin- und herzuwechseln. Von diesen Objekten kann dann immer nur eines in voller Größe angezeigt werden, die anderen sind minimiert.
Maximieren Ist diese Option aktiviert, kann das Objekt maximiert, d. h. bildschirmfüllend angezeigt werden. In der rechten oberen Ecke der Box erscheint daraufhin ein entsprechendes Symbol. Per Mausklick auf das Symbol oder per Doppelklick auf den Titel der Box maximieren Sie das Objekt. Sind die Optionen Minimieren und Maximieren aktiviert, wird das Objekt per Doppelklick auf den Titel allerdings minimiert und nicht maximiert.
Kommentar

Hier können Sie einen beliebigen Kommentar oder Erläuterungstext zu dem Objekt eingeben. Es kann auch ein dynamischer Ausdruck eingegeben werden. Diese Option ist nicht auf Dokumentebene verfügbar. Per Mausklick auf die Schaltfläche ... öffnet sich der Dialog Formel bearbeiten, der Sie beim Editieren langer Ausdrücke unterstützt.

Siehe: Formelsyntax in dynamischen Ausdrücken

Geben Sie beispielsweise eine Beschreibung des Objekts ein. Ein Icon für Hilfe wird zur Titelleiste des Objekts hinzugefügt. Wird der Mauszeiger darauf positioniert, erscheint der eingegebene Text. Hat das Objekt keine Titelleiste, erscheint der Kommentar, wenn man die Maus über das Objekt bewegt.