Inline-Assistent

Sie öffnen den Inline-Assistenten im Menü Einfügen über die Befehle Load-Befehl, Load Inline. Der Inline-Assistent dient dazu, Ihnen den Gebrauch von load inline-Befehlen zu erleichtern.

Der Inline-Assistent ähnelt einem Tabellenkalkulationsprogramm und funktioniert auch weitgehend genauso. Formeln, wie Sie sie möglicherweise aus Microsoft Excel kennen, unterstützt der Inline-Assistent allerdings nicht.

Jede Spalte im Inline-Assistenten entspricht einem in QlikView einzulesenden Feld. Jede Zeile repräsentiert einen Datensatz der Inline-Tabelle. Sie wählen eine Zelle, indem Sie darauf klicken. Anschließend können Sie einen Wert eingeben oder aus der Zwischenablage einfügen. Drücken Sie ENTER oder eine der Pfeiltasten, um den Wert zu bestätigen und zur nächsten Zelle zu springen.

In der obersten Zeile des Inline-Assistenten stehen die Feldnamen. Doppelklicken Sie auf die oberste Zeile, um sie zu bearbeiten. Vorbesetzt wird F1, F2 usw.

Menü Bearbeiten

Das Menü Bearbeiten in diesem Dialog enthält einige hilfreiche Befehle für die Arbeit im Inline-Assistenten.

Spalte einfügen Fügt eine neue Spalte in die Inline-Tabelle ein. Dazu muss mindestens eine Spalte markiert sein.
Spalte löschen Löscht die markierten Spalten.
Zeile einfügen Fügt eine neue Zeile in die Inline-Tabelle ein. Dazu muss mindestens eine Zeile markiert sein.
Zeile löschen Löscht die markierten Zeilen.

Menü Extras

Das Menü Extras enthält den Befehl Daten aus aktuellem Dokument, welcher den Dialog Daten aus dem aktuellen Dokument importieren öffnet. Dort können Sie Werte aus einem der Felder des Dokuments in den Inline-Assistenten kopieren. Sie sehen dort die Felder des Dokuments mit der Anzahl der enthaltenen Werte. Sie können entweder alle Werte eines Feldes oder nur wählbare oder ausgeschlossene Werte in den Inline-Assistenten kopieren.

Per Mausklick auf OK schließt sich der Inline-Assistent, und im Skript wird ein entsprechender load inline-Befehl generiert.