Veröffentlichen eines komplexen Berichts über eine Qlik Sense App

In diesem Tutorial erfahren Sie, wie Sie mithilfe von Qlik Sense Daten einen komplexen Qlik NPrinting Excel-Bericht erstellen und veröffentlichen.

Qlik NPrinting hat viele Funktionen. Dieses Tutorial soll erfahrene Benutzer beim Erstellen eines Berichts unterstützen. Darin wird jedoch nicht jeder Berichtstyp, jedes Designelement oder jede Veröffentlichungsoption erläutert. Am Ende dieses Tutorials haben Sie einen Excel-Bericht erstellt, bearbeitet und veröffentlicht, der von Ihren ausgewählten Benutzern angezeigt werden kann.

Weitere Qlik NPrinting Tutorials:

Hinweis: Microsoft Office muss installiert sein, damit Berichte in Office-Dateiformaten bearbeitet und erstellt werden können.

Dieses Tutorial verfolgt die folgenden Lernziele:

Zugriff auf eine Qlik Sense App

Berichte benötigen Daten. Erfahren Sie, wie Sie eine Qlik Sense Beispiel-App herunterladen und importieren.

Verbinden von Qlik NPrinting mit einer Qlik Sense App 

Qlik NPrinting muss eine Verbindung zu einer Qlik Sense App herstellen. Erfahren Sie, wie Sie Qlik NPrinting für den Zugriff auf eine Beispiel-App oder auf Ihre vorhandenen Qlik Sense Daten konfigurieren.

Erstellen eines neuen Filters

Mit Filtern können Sie Ihre Daten optimieren. Erstellen Sie einen Filter, um zu steuern, welche Daten von Ihren Benutzern angezeigt werden können.

Erstellen einer neuen Qlik NPrinting Berichtsvorlage

Berichtsvorlagen bestimmen das Layout und die Ausgabeformate der Berichte. In diesem Abschnitt wird gezeigt, wie Sie einen neuen Bericht erstellen.

Bearbeiten der Berichtsvorlage

Berichte bieten viele verschiedene Formatierungsoptionen. Sie fügen Ihrem Bericht Excel-Tabellen, Tabellen mit Zwischensummen und Ebenen hinzu.

Veröffentlichen in NewsStand und per E-Mail

NewsStand ist eine Webkonsole, die Benutzer zum Anzeigen von Berichten öffnen können. Erfahren Sie, wie Sie die Veröffentlichung Ihres Berichts in NewsStand und per E-Mail automatisieren.

Zugriff auf eine Qlik Sense App

Qlik Sense Apps enthalten die Daten und Visualisierungen, mit denen Qlik NPrinting Berichte erstellt. Es gibt verschiedene Möglichkeiten, um auf eine Qlik Sense App zuzugreifen:

  • Sie können eine Qlik Sense App von der Qlik Hilfeseite herunterladen und sie in Ihren Qlik Sense Apps-Ordner hochladen. Dieses Tutorial bezieht sich häufig auf Werte und Felder in dieser Beispiel-App. Wenn Sie dieses Tutorial zum ersten Mal nutzen, wird empfohlen, die bereitgestellte App und keine benutzerdefinierte App zu verwenden.
  • Sie können Ihre eigene Qlik Sense App verwenden und direkt zu Verbinden von Qlik NPrinting mit einer Qlik Sense App  gehen. Wenn Sie Ihre eigene App verwenden, um dieses Tutorial abzuschließen, verwenden Sie eine einfache App. Bei komplexen Qlik Sense Apps kommt es bei Qlik NPrinting zu längeren Ladezeiten.

Herunterladen einer Qlik Sense App von der Qlik Hilfeseite und Importieren der App in Qlik Sense

Gehen Sie folgendermaßen vor:

  1. Gehen Sie auf der Qlik NPrinting Hilfeseite zu Sample files und laden Sie die ZIP-Datei Beispieldatei - Start mit den Grundlagen in den gewünschten Speicherort auf Ihrem Computer herunter.
  2. Dekomprimieren Sie den Ordner unter Windows. Beginner's tutorial.qvf ist Ihre Qlik Sense Datei.
  3. Senden Sie die App an den Systemadministrator mit der Bitte, Beginner’s tutorial.qvf in QMC zu importieren.
  4. Bitten Sie den Systemadministrator, die App in einem Stream zu veröffentlichen, auf den Sie zugreifen können. Sie kann im Standardstream Everyone (Jeder) veröffentlicht werden.

Die App Anfänger-Tutorial wird jetzt in Ihrem Qlik Sense Hub angezeigt.

Verbinden von Qlik NPrinting mit einer Qlik Sense App 

Als Nächstes erstellen wir eine Qlik NPrinting App und verbinden sie mit Ihrer Qlik Sense App.

Eine Qlik Sense App und eine Qlik NPrinting App unterscheiden sich stark voneinander.

  • Die Qlik Sense App enthält Daten und verwendet Visualisierungen, um diese Daten zu untersuchen.
  • Die Qlik NPrinting App enthält Berichte, Filter und die Verbindung zu einer Qlik Sense App oder einem QlikView Dokument.

Mit Qlik NPrinting Apps kann der Qlik NPrinting Designer auf Ihre Qlik Sense Daten zugreifen, sodass Informationen in einem Bericht verwendet werden können.

Hinweis: Für das Herstellen einer Verbindung zwischen Qlik NPrinting und Ihren Qlik Sense Apps müssen Qlik Sense Zertifikate auf allen Qlik NPrinting Engine-Computern installiert sein. Siehe: Installieren von Zertifikaten.

Gehen Sie folgendermaßen vor:

  1. Melden Sie sich bei der Qlik NPrinting Webkonsole an.
  2. Klicken Sie im Hauptmenü auf die Dropdown-Liste Apps und dann auf Apps.
  3. Klicken Sie auf die Schaltfläche App erstellen.
    1. Geben Sie einen Namen für die neue App ein. Beispiel: Tutorial für Fortgeschrittene – NP-App.
    2. Lassen Sie das Kontrollkästchen Aktiviert aktiviert. Andernfalls wird Ihre App von der Qlik NPrinting Engine ignoriert.
    3. Klicken Sie auf Erstellen.

      Jetzt wird Tutorial für Fortgeschrittene – NP-App unter Apps angezeigt.

      Apps screen

  4. Klicken Sie im Hauptmenü auf die Dropdown-Liste Apps und dann auf Verbindungen.
    1. Klicken Sie auf die Schaltfläche Verbindung erstellen.
    2. Geben Sie im Feld Name einen Namen für die Verbindung ein: Tutorial für Fortgeschrittene – Verbindung.
    3. Wählen Sie in der Dropdown-Liste App die Qlik NPrinting-App aus, die Sie zuvor erstellt haben: Turtorial für Fortgeschrittene – NP-App.
    4. Wählen Sie Qlik Sense als Quelle aus.
    5. Geben Sie folgende Daten ein:
      • Proxy-Adresse: vollständiger Computername des Qlik Sense Servers. Sie finden dies im Qlik Sense Hub in der Adressleiste Ihres Browsers. Das Format ist: https://sense_proxy_computer_name.domain_name.
      • Qlik Sense App-ID: Diese Informationen sind im Qlik Sense Hub in der Adressleiste Ihres Browsers auf der Übersichtsseite Ihrer App verfügbar.

      • Identität: der <Windows-Domänenname>\<Benutzername> des Qlik Sense Benutzers, der Zugriff auf die App hat.

    6. Klicken Sie auf die Schaltfläche Überprüfung ausführen. Dadurch wird sichergestellt, dass die Verbindung gültig ist.

      Falls die Verbindung gültig ist, wird die Meldung „Überprüfung erfolgreich“ angezeigt. Falls nicht, wird die folgende Meldung angezeigt: „Fehler erkannt. Überprüfen Sie die unten aufgeführten Details.“

      Successful Qlik Sense connection verification screen.

    7. Nachdem Ihre Verbindungseinstellungen überprüft wurden, klicken Sie auf Erstellen. Sie kehren automatisch zum Menü Verbindungen zurück.
    8. Klicken Sie auf Ihre neue Verbindung. Der folgende Status wird angezeigt: Cache-Status − Wird erzeugt. Das heißt, dass Qlik NPrinting eine Verbindung zu Qlik Sense herstellt und Metadaten importiert. Bei einer großen Qlik Sense App dauert dieser Vorgang möglicherweise einige Minuten.
      Hinweis:

      Jedes Mal, wenn Sie neue Objekte zu Ihrer Qlik Sense App hinzufügen, müssen Sie die Verbindungsmetadaten erneut laden.

    9. Sobald der Cache-Status Erzeugt lautet, können Sie eine neue Berichtsvorlage erstellen. Falls ein Fehlerstatus angezeigt wird, überprüfen Sie die Verbindungsinformationen.

Jetzt können Sie Ihre neue Verbindung im Bildschirm Verbindungen anzeigen.

Successful generated Qlik Sense connection.

Falls bei der Herstellung der Verbindung zu Ihrer Qlik Sense App Probleme auftreten, finden Sie Informationen dazu unter:

Erstellen eines neuen Filters

Mit statischen Filtern können Sie Ihre Daten entsprechend den Feldern Ihrer Qlik Sense App verfeinern. Im vorliegenden Fall erstellen wir einen Filter mit dem Namen Wein und Bier über das Feld Produktgruppe. In einer Tabelle oder einem Bild mit diesem Filter werden nur Ergebnisse für Wein und Bier angezeigt und alle anderen Produkttypen ignoriert.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie im Hauptmenü auf die Dropdown-Liste Apps und dann auf Filter.
  2. Klicken Sie auf Filter erstellen.
  3. Geben Sie einen Namen für den Filter ein. Beispiel: Wein und Bier.
  4. Wählen Sie unter App die Option Tutorial für Fortgeschrittene – NP-App aus.
  5. Klicken Sie auf Erstellen.

    Filter creation screen.

  6. Klicken Sie im Filter-Menü auf Felder.
  7. Klicken Sie auf Feld hinzufügen.
  8. Wählen Sie unter Verbindung Ihre Verbindung aus.
  9. Wählen Sie unter Name die Option Produktgruppe aus.

    Lassen Sie Werte überschreiben deaktiviert.

  10. Lassen Sie Wert: im Bereich Werte stehen. Diese Option erzwingt, dass Qlik NPrinting die Liste von Werten auswählt, die Sie angeben.
  11. Beginnen Sie, den gewünschten Wert einzugeben. Eine Liste der möglichen Werte wird angezeigt. Wählen Sie in diesem Fall Alkoholische Getränke.
  12. Klicken Sie auf Erstellen.

    Adding a field to a filter.

Erstellen einer neuen Qlik NPrinting Berichtsvorlage

Berichtsvorlagen bestimmen das Layout und die Ausgabeformate der Berichte. Über die Standardoptionen des ausgewählten Berichtstyps können Sie Objekte anordnen und Seiten formatieren. Ein Excel-Bericht hat zum Beispiel dieselben Formatierungsoptionen und dieselbe Benutzeroberfläche wie ein Excel-Arbeitsblatt.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie in der Qlik NPrinting Webkonsole im Hauptmenü auf Berichte.
  2. Klicken Sie auf die Schaltfläche Bericht erstellen.
  3. Geben Sie im Feld Titel einen Titel ein. Beispiel: Tutorial für Fortgeschrittene – Excel.
  4. Wählen Sie in der Dropdown-Liste Typ die Option Excel aus.
  5. Wählen Sie in der Dropdown-Liste App den Eintrag Tutorial für Fortgeschrittene – NP-App aus.
  6. Klicken Sie unter Vorlage auf die Option Leere Datei.
  7. Lassen Sie das Kontrollkästchen Aktiviert aktiviert. Andernfalls wird Ihr Bericht von der Qlik NPrinting Engine ignoriert.
  8. Aktivieren Sie das Kontrollkästchen Dynamische Benennung aktivieren. Damit können Sie Variablen zu Ihren Berichtsnamen hinzufügen.

    Diese Feldelemente können mit den Ziehpunkten zum Sortieren auf der rechten Seite neu sortiert werden.

  9. Sie benötigen mindestens eine Variable. Wählen Sie Berichtsname.
  10. Klicken Sie auf Variable hinzufügen. Wählen Sie Benutzer Abteilung.
  11. Klicken Sie auf Variable hinzufügen. Wählen Sie Benutzerdefiniert. Fügen Sie im angezeigten Textfeld einen Binde- oder Unterstrich hinzu.
  12. Klicken Sie auf Variable hinzufügen. Wählen Sie Datum. Wählen Sie ein Datumsformat aus.
  13. Im Feld Vorschau wird Ihr dynamischer Berichtsname angezeigt.
  14. Klicken Sie auf Erstellen.

    Creating a report template with dynamic naming.

Unter Berichte wird jetzt Tutorial für Fortgeschrittene – Excel angezeigt.

Bearbeiten der Berichtsvorlage

Es gibt viele Möglichkeiten zum Bearbeiten einer Berichtsvorlage. Wir fügen Folgendes hinzu:

  • Titel: einfacher Text, der zum Organisieren des Berichts verwendet wird. Titel können mit den Standardformatierungsoptionen in Excel geändert werden.
  • Ebenen: Unterteilen Ihrer Daten nach Dimension. Ebenen können auf Tabellen und Bilder angewendet werden.
  • Tabellen: Stellen Ihre Qlik Sense Daten im Tabellenformat dar. Sie können Excel-Tabellen erstellen oder Qlik Sense-Tabellen importieren.
  • Objektfilter: Damit verfeinern Sie die Daten, die in einem Objekt wie einem Diagramm oder einer Tabelle angezeigt werden.

In diesem Abschnitt werden nicht alle Möglichkeiten behandelt, die Qlik NPrinting Designer für die Berichtsvorlage bietet. Informationen über weitere Excel-Berichtsfunktionen finden Sie unter: Excel-Berichte.

Hinweis: Ihre Berichtsvorschau sieht möglicherweise anders aus als die unten angezeigten Abbildungen, je nachdem, wie Sie sie formatiert haben. Manche Objekte haben möglicherweise etwas abweichende Namen, je nachdem, in welcher Reihenfolge sie ausgewählt wurden.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie in der Qlik NPrinting web console im Hauptmenü auf Berichte.
  2. Klicken Sie im Bildschirm Berichte auf Ihren Bericht.
  3. Klicken Sie auf die Schaltfläche Vorlage bearbeiten, um den Qlik NPrinting Designer Vorlageneditor zu öffnen.

    Edit report template button.

  4. Geben Sie in Zelle A1 einen Titel ein: Zum Beispiel Quarterly trends and customer sales by region.

    Tipp: Sie können mit den Excel-Formatierungsoptionen das Aussehen dieser Titel ändern. Sie können beispielsweise die Schriftgröße und -farbe ändern. Sie können außerdem mehrere Zellen verknüpfen, damit der Titel so wie der restliche Bericht zentriert wird.
  5. Fügen Sie eine Ebene hinzu:
    1. Klicken Sie im linken Fenster mit der rechten Maustaste auf Ebenen und wählen Sie Ebenen hinzufügen aus.
    2. Ein neues Fenster wird geöffnet. Wählen Sie Region aus. Klicken Sie auf OK.

    3. Ziehen Sie Region_Level in die Zelle A2.
    4. Schneiden Sie das </Region_Level>-Tag aus und fügen Sie es in A17 ein.

      Innerhalb dieser Tags platzierte Objekte werden nach Region organisiert.

    5. Erweitern Sie Region_Level im linken Fenster.
    6. Verschieben Sie Region durch Ziehen und Ablegen in die Zelle A4.

      Dadurch wird sichergestellt, dass jede Ebene ihre eigene Überschrift hat.

  6. Fügen Sie eine Excel-Tabelle hinzu:
    1. Fügen Sie in Zelle A6 einen Untertitel hinzu: Vierteljährliche Trends.
    2. Klicken Sie im Vorlageneditor mit der rechten Maustaste auf Tabellen und wählen Sie Objekte hinzufügen aus.
    3. Ein neues Fenster wird geöffnet. Wählen Sie Vierteljährlicher Trend aus. Klicken Sie auf OK.
    4. Wählen Sie im Bereich links TFWPC – Vierteljährlicher Trend aus. Damit wird der Bereich Eigenschaften unten geöffnet.
    5. Wählen Sie das Kontrollkästchen Keep Source Formats aus.

      Dadurch wird die Qlik Sense-Formatierung aus der Tabelle entfernt, damit Sie sie anpassen können.

    6. Legen Sie Show Headers auf In Tag-Zelle anzeigen fest.
    7. Spalten-Header werden in die Tag-Zellen eingefügt, und die Daten beginnen in der Zeile darunter. Formeln und Variablen in den ursprünglichen Qlik Sense-Headern werden nicht ersetzt.

    8. Ziehen Sie TFWPC – Vierteljährlicher Trend in die Zelle A8. Wählen Sie die Zelle aus, die das Tag TFWPC enthält, falls diese noch nicht ausgewählt wurde.
    9. Wählen Sie die Registerkarte Einfügen auf der Excel-Symbolleiste aus.
    10. Klicken Sie auf das Symbol Tabelle in der Gruppe Tabellen. Klicken Sie auf OK.

    11. Gehen Sie zu Tabellentools > Design, um die Tabellenformatierung anzuwenden.
      • Die für die Überschriftszelle verwendete Schriftart und Ausrichtung gelten für alle Zellen der Tabelle in der Überschriftszeile.
      • Die für die Inhaltszelle verwendete Schriftart und Ausrichtung gelten für alle Zellen der Tabelle in den Inhaltszeilen.
      • Die Zahlenformatierung hat keine Auswirkungen.
    12. Klicken Sie auf der Qlik NPrinting Designer-Symbolleiste auf Vorschau, um eine Vorschau der Tabelle aufzurufen.

      Sie haben jetzt eine Excel-Tabelle, die sortiert und gefiltert werden kann. Sie können jedoch keine Zahlen formatieren.

  7. Fügen Sie eine Tabelle mit Zwischensummen hinzu:
    1. Fügen Sie in Zelle A11 einen Untertitel hinzu: Kundenumsatz.
    2. Klicken Sie im Vorlageneditor mit der rechten Maustaste auf Tabellen und wählen Sie Objekte hinzufügen aus.
    3. Ein neues Fenster wird geöffnet. Wählen Sie Kundenumsatz und Menge aus. Klicken Sie auf OK.
    4. Wählen Sie im linken Bereich Kundenumsatz und Menge aus. Damit wird der Bereich Eigenschaften unten geöffnet.
    5. Wählen Sie das Kontrollkästchen Keep Source Formats aus.
    6. Erweitern Sie den neuen Knoten Kundenumsatz und Menge.
    7. Ziehen Sie Kunde – Kunde zu A13 und JWaPFv – Umsatz zu B13.
    8. Geben Sie in Zelle A15 Folgendes ein: Region gesamt. Fügen Sie in Zelle B15 eine Formel hinzu: =SUM(B14).

      Formatieren Sie B15 für die Anzeige als Währung.

      Designer, edit template screen.

  8. Fügen Sie eine Tabelle mit Zwischensummen und einem Filter hinzu:
    1. Fügen Sie der Excel-Arbeitsmappe ein neues Arbeitsblatt hinzu.
    2. Gehen Sie zu dem neuen Arbeitsblatt. Fügen Sie in Zelle A1 einen Untertitel hinzu: Wein- und Bierumsatz nach Region.
    3. Klicken Sie im linken Fenster mit der rechten Maustaste auf Ebenen und wählen Sie Ebenen hinzufügen aus.
    4. Ein neues Fenster wird geöffnet. Wählen Sie Region aus. Klicken Sie auf OK.
    5. Ziehen Sie Region_Level in die Zelle A2.
    6. Schneiden Sie das </Region_Level>-Tag aus und fügen Sie es in A17 ein.
    7. Erweitern Sie Region_Level im linken Fenster.
    8. Verschieben Sie Region durch Ziehen und Ablegen in die Zelle A4.

      Dadurch wird sichergestellt, dass jede Ebene ihre eigene Überschrift hat.

    9. Klicken Sie im Vorlageneditor mit der rechten Maustaste auf Tabellen und wählen Sie Objekte hinzufügen aus.
    10. Ein neues Fenster wird geöffnet. Wählen Sie Produkt-Baumstruktur aus. Klicken Sie auf OK.
    11. Klicken Sie auf den Knoten Produkt-Baumstruktur. Klicken Sie unter Eigenschaften > Filter auf ¥. Wählen Sie den Filter Bier und Wein aus.

      Damit wird sichergestellt, dass in der neuen Tabelle nur Daten im Zusammenhang mit Bieren und Weinen angezeigt werden.

      Wählen Sie das Kontrollkästchen Keep Source Formats aus.

    12. Erweitern Sie den Knoten Produkt-Baumstruktur.
    13. Ziehen Sie Produkttyp zu B5, Elementbeschreibung zu C5 und Umsatz zu D5.
    14. Geben Sie in Zelle C7 Folgendes ein: Region gesamt. Fügen Sie in Zelle D17 eine Formel hinzu: =SUM(D6).
    15. Geben Sie in Zelle C10 Folgendes ein: Gesamtumsatz. Fügen Sie in Zelle D10 eine Formel hinzu: =SUM(D6:D8)/2.
    16. Wählen Sie sowohl D7 als auch D10 aus und formatieren Sie sie für die Anzeige als Währung.

      Designer, report template edit screen

  9. Klicken Sie im Menü des Qlik NPrinting Vorlageneditors auf die Registerkarte Datei. Klicken Sie auf Speichern.
  10. Klicken Sie auf die Registerkarte Vorlage und dann auf die Schaltfläche Vorschau, um eine Vorschau des Berichts anzuzeigen.

    Das Laden der Vorschau kann je nach Größe Ihres Berichts einige Minuten dauern. Sie können die Vorschaugenerierung anhalten, indem Sie auf die Schaltfläche Abbrechen klicken.

    Report preview screen

    Report preview screen, second sheet.

    Warnung: Änderungen im Vorschaumodus werden nicht gespeichert.
  11. Wenn Sie den Bericht weiter bearbeiten möchten, schließen Sie das Vorschaufenster und formatieren Sie ihn im Vorlageneditor.
  12. Wenn Sie die Bearbeitung des Berichts abgeschlossen haben, klicken Sie auf Speichern und schließen.

Die Berichtsvorlage wird jetzt gespeichert und kann mit anderen Benutzern geteilt werden.

Veröffentlichen in NewsStand und per E-Mail

Berichte müssen veröffentlicht werden, damit Benutzer auf sie zugreifen können. Wir werden in NewsStand und per E-Mail veröffentlichen.

NewsStand ist ein Webportal, über das sich Benutzer eine Vorschau von Berichten anzeigen, Berichte herunterladen und automatische Aktualisierungen abonnieren können. Siehe: NewsStand-Überblick

E-Mails enthalten Ihre Berichte als Anhänge. Die Inhalte der Berichte können durch Hinzufügen von Text und Bildern angepasst werden. Siehe: Distributing reports by email.

Sie werden auch einen Auslöser erstellen, der Ihre Berichte automatisch nach einem Zeitplan veröffentlicht.

Hinweis: Sie müssen Ihren SMTP-E-Mail-Server konfigurieren, damit E-Mails aus Qlik NPrinting versendet werden können. Siehe: Configure SMTP Server.

Gehen Sie folgendermaßen vor:

  1. Klicken Sie im Hauptmenü der Qlik NPrinting Webkonsole auf Aufgaben und wählen Sie Veröffentlichen-Aufgabe aus.
  2. Klicken Sie auf die Schaltfläche Aufgabe erstellen.

    1. Geben Sie einen Namen ein. Beispiel: Tutorial für Fortgeschrittene veröffentlichen.
    2. Wählen Sie Ihre App in der Dropdown-Liste aus. Tutorial für Fortgeschrittene – NP-App.
    3. Behalten Sie die Standardwerte der anderen Optionen bei. Klicken Sie auf Erstellen.

      Publish task overview screen.

  3. Klicken Sie auf die Registerkarte Reports.
    1. Klicken Sie auf die Schaltfläche Bericht einfügen.
    2. Wählen Sie Advanced Tutorial Excel aus der Dropdown-Liste Bericht wählen.
    3. Wählen Sie in der Dropdown-Liste Ausgabeformat die Option XLS aus.
    4. Vergewissern Sie sich, dass die Kontrollkästchen An E-Mail anhängen und Aktiviert aktiviert sind.
    5. Klicken Sie auf Bericht einfügen.

      Adding a report to a publish task.

  4. Klicken Sie auf die Registerkarte Benutzer/Gruppen.
    1. Klicken Sie auf die Schaltfläche Benutzer oder Gruppe einfügen.
    2. Wählen Sie einen Benutzer oder eine Gruppe in der Dropdown-Liste Empfänger wählen aus.

      Wenn Sie erfahren möchten, wie Sie neue Benutzer erstellen, finden Sie Informationen dazu unter: Creating users.

    3. Aktivieren Sie die Kontrollkästchen Aktiviert, NewsStand-Empfänger und E-Mail-Empfänger.
    4. Klicken Sie auf Empfänger einfügen.
  5. Klicken Sie auf die Registerkarte Ziele.
    1. Klicken Sie in der NewsStand-Spalte auf das Kontrollkästchen Für alle veröffentlichen.
    2. Klicken Sie in der E-Mail-Spalte auf das Kontrollkästchen Für alle veröffentlichen.
    3. Klicken Sie auf Speichern.
  6. Passen Sie die E-Mail-Vorlage an:
    1. Klicken Sie im Aufgaben-Hauptmenü auf E-Mail-Nachricht.
    2. In Von wählen Sie eine der folgenden Optionen aus:
      • Benutzer: Wählen Sie die E-Mail in der Dropdown-Liste aus. Sie können die Liste auch im Suchformular filtern:
      • Benutzerdefiniert: Geben Sie eine gültige E-Mail-Adresse ein.

    3. Wählen Sie in der Dropdown-Liste An die Option Ausgewählte Benutzer.
    4. Geben Sie einen Betreff ein.
    5. Wählen Sie das Format der E-Mail aus, indem Sie auf HTML klicken. HTML unterstützt formatierten und dynamischen Text.

    6. Fügen Sie Text zum E-Mail-Textteil hinzu. Sie können ihn anhand der Formatierungsschaltflächen anpassen.
    7. Klicken Sie auf Benutzer und wählen Sie dann die Tags aus der Liste aus. Sie werden bei der E-Mail-Generierung durch den entsprechenden Wert ersetzt.

      Beispielsweise wird %%User_Company%% durch den Namen des Unternehmens des Empfängers ersetzt. In diesem Beispiel wurden %%User_FullName%%, %%User_Department%% und %%User_Company%% hinzugefügt.

      Wenn diese Informationen in Ihren Benutzerprofilen nicht vorhanden sind, enthält die Nachricht leere Zeichenfolgen. Siehe: Creating users.

    8. Wählen Sie in der Dropdown-Liste Anhänge die Option Alle angehängten Berichte aus.
    9. Klicken Sie auf Speichern.

      Email customization screen.

  7. Erstellen Sie einen Auslöser:
    1. Klicken Sie im Aufgaben-Hauptmenü auf Auslöser.
    2. Klicken Sie auf Auslöser erstellen.
    3. Geben Sie einen Namen ein: Tutorial Trigger.
    4. Wählen Sie im Abschnitt Zeitplan den Zeitplantyp aus. Wählen Sie für dieses Tutorial: Wöchentlich.

      Die Aufgabe wird an den festgelegten Wochentagen automatisch ausgeführt.

    5. Klicken Sie unter Tägliches Intervall auf Einmal. Belassen Sie die Standardzeit.
    6. Im Abschnitt Start können Sie das Startdatum und die Zeitzone der Uhrzeiten festlegen, die für den Auslöser angegeben wurden. Das Standardstartdatum ist der Tag, an dem der Auslöser erstellt wurde.
    7. Klicken Sie auf Erstellen, um den neuen Auslöser im Repository zu speichern.

      Trigger creation interface

  8. Gehen Sie zurück zur Seite Übersicht.
  9. Klicken Sie auf die Schaltfläche Jetzt ausführen.

    Oben auf der Seite wird eine Bestätigungsmeldung angezeigt.

Die Empfänger können nun in ihrem jeweiligen Browser den NewsStand aufrufen und Ihren Bericht anzeigen. Außerdem erhalten sie den Bericht per E-Mail. Da Sie einen Auslöser erstellt haben, erhalten Benutzer einmal pro Woche gemäß dem festgelegten Zeitplan auch einen aktualisierten Bereicht.

Tipp: In Standardinstallationen können Sie von der Qlik NPrinting Webkonsole zu Ihrem NewsStand wechseln, indem Sie in der Browserleiste den Port von 4993 zu 4994 ändern. Wenn beispielsweise Ihre Webkonsole https://YourServerName:4993 ist, dann ist Ihr NewsStand https://YourServerName:4994.

NewsStand